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Chapter 3 
3 Using HEC-DSSVue: An Overview 

With HEC-DSSVue you can access, visualize, and manipulate data stored in 
HEC-DSS database files using a variety of utilities and functions available 
from the main HEC-DSSVue screen, shown in Figure 3.1.   

Figure 3.1 HEC-DSSVue Main Window 

 

This chapter provides an overview of HEC-DSSVue and its basic operations 
using the main menu and selection buttons.  

  

3.1 HEC-DSSVue Main Screen 
The main screen of HEC-DSSVue consists of a Menu Bar, Tool Bar, File Name 
box, Search boxes, a list of HEC-DSS Pathnames, a list of Selected Pathnames, 
and Selection Buttons.  The following sections describe these features in detail. 
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3.1.1 Menu Bar  
 Main menu options in HEC-
DSSVue (Figure 3.2) allow you to 
search for, select, and edit HEC-
DSS data sets; control the display 
of pathnames; and access plots and 
tables, among other tasks.  The HEC-DSSVue menus are as follows: 

File File menu commands are New, Open, Close DSS File(s), Print 
Catalog Preview, Print Catalog and Exit.  The file menu also lists 
the last 6 most recently used files. 

Edit Edit menu commands are Tabular Edit…, Graphical Edit..., and 
Select All.   

View The View menu allows you to customize the display of HEC-DSS 
pathnames, refresh the catalog and search pathnames.  Available 
commands are Pathname List, Pathname Parts, Condensed 
Catalog, No Pathnames, Refresh Catalog, Search pathnames by 
string, and Search pathnames by parts. 

Display Use the Display menu to open plots and tables with the Plot and 
Tabulate commands.  You may also set the Plot Data Options of 
Normalize, and Synch data set times to first. 

Utilities Utilities menu provides access to Math Functions, Manual Data 
Entry (Time Series and Paired Data), and it allows you to Rename 
Records, Duplicate Records, Copy Records, Delete Records, 
Undelete Records, Merge Files, Squeeze, access the Script Button 
Frame with the Script Browser command, access the Script 
Selector, and view HEC-DSS Status. 
 

3.1.2 Tool Bar 
Tool bar buttons provide shortcuts to frequently used menu commands: 

 Opens a File Browser, which allows you to select a HEC-DSS file 
(same as Open in the File menu). 
 
 Plots the selected data (same as Plot in the Display menu) 
 
 Displays the selected data in table form (same as Tabulate in the 
Display menu). 

 
Graphically Edit the selected data (same as Graphical Edit in the Edit 
menu). 
 
Open the Math Functions dialog with the selected data. 

Figure 3.2 HEC-DSSVue Menu 
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3.1.3 File Name 
The File Name box (Figure 3.3) displays the file name and location of the 
currently open HEC-DSS file.  Also, if you know the exact location and name 
of the HEC-DSS database file you wish to open, you can type it directly into 
the File Name box to open it, then press the Enter key. 

Figure 3.3 File Name Box 

Beneath the file name are the number of pathnames in the list, the number 
selected, the total number in the database file, and the size of the database file.  
If you do not have access to write to the file, the words “Read Only” will be 
displayed following the file size. 

3.1.4 Search Boxes  
The Data Selection List also provides a search area where you can Search 
Pathnames (Figure 3.4) or Search Parts (Figure 3.5) of an open HEC-DSS 
file.  The search method desired is set from the View menu.    

To search and display all pathnames containing a specific string, type that 
string into the box and press the Search button.  Those pathnames in the file 
that contain that string will be displayed in the list. 

The Search by Parts option provides a selectable drop down list of the parts 
of all the pathnames in the file.  When a part is selected, only those pathnames 
that match that part are shown. 

 
Figure 3.4 Search Pathnames option 

 
Figure 3.5 Search by Parts option 

 

3.1.5 List of HEC-DSS Pathnames 
Once you have opened an HEC-DSS file, its pathnames appear in a list 
beneath the search area, either as a Pathname List, or by Pathname Parts, in 
Condensed Catalog format, or with No Pathnames displayed.  (The No 
Pathnames option is typically used to access very large databases using only 
scripted functions.)  These options are set from the View menu, as described 
in Section 3.4.1.  Figure 3.6 shows the pathname parts displayed. 
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Figure 3.6 List of HEC-DSS Pathnames by Parts 

 

3.1.6 Selected Pathnames 
When you select a pathname (see Section 3.5), it appears beneath the list of all 
pathnames in the selection area (Figure 3.7).  You can make the size of 
selected list taller or shorter by grabbing the separator line between the two 
lists with the mouse, and moving it up or down. 

Figure 3.7 Selected Pathnames 

 

3.1.7 Selection Buttons 
There are five buttons at the bottom of the Data Selection List window (Figure 
3.8).   

 
 

Figure 3.8 Select, De-Select, Clear Selections, Restore Selections, and Set Time Window 
Buttons 

 Select: You add a pathname to the selection list by highlighting it and 
clicking the Select button.  Until you highlight a pathname, the Select 
button remains inactive.  You can also do a “quick select,” if the selection 
list is empty, by highlighting a pathname, then pressing the plot or tabulate 
button. 

 De-Select:  To remove a pathname from the selection list, you highlight 
the pathname in the lower list then press the De-Select button. 

 Clear Selections: You can remove all pathnames from the selection list 
by clicking the Clear Selections button. 

 Restore Selections: The Restore Selections button restores all selections 
you have cleared or de-selected. 

 Set Time Window: You can set the time window of the data to view with 
the Set Time Window button. 
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3.2 File Menu Operations 
HEC-DSSVue’s File menu allows you to create a New HEC-DSS file, Open 
an existing HEC-DSS file, Close the HEC-DSS file you have opened, show 
the Print Catalog Preview, Print the Catalog, open a recently opened file, 
and Exit the program.  The following sections discuss these operations. 

3.2.1 Creating a New HEC-DSS File 
To create a new HEC-DSS database file, from the File menu, click New.  
When the File dialog box opens, type in a name for the new file and HEC-
DSSVue will create it for you.  Data can then be entered through the Manual 
Data Entry window from the Utilities menu.  If you copy records from an 
existing file, the new DSS file does not need to exist; it will be created 
automatically. 

 

3.2.2 Opening a HEC-DSS File 
If you know the name of the HEC-DSS database file you wish to open, you 
can type the file name (including the path) directly into the File Name box 
(Figure 3.3).  Otherwise, choose Open from the File menu or click the  
button to select the HEC-DSS database file you want.   

A File Browser window will open, as shown in Figure 3.9.   

In the File Browser 
window, use the 
standard Windows 
controls to browse to 
the HEC-DSS file 
that you wish to open, 
then click Open.  

The name of the file 
you have selected will 
now appear in the 
File Name box 
(Figure 3.3), and the 
pathnames of the 
records contained in the file will display in the List of HEC-DSS Pathnames. 

 

3.2.3 Closing the HEC-DSS File 
To close the HEC-DSS database file that you currently have opened, from the 
File menu, click Close.  This will allow some older MS-DOS based programs 
to access the file, or for you to rename or delete the file.  Note:  HEC-DSS is a 

 
Figure 3.9 Open HEC-DSS File 
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multi-user database system.  Some older MS-DOS programs exclusively 
locked HEC-DSS files to fully utilize disk caching.   

 

3.2.4 Printing the Catalog  
You can Print the catalog or show what the catalog will look like when it is 
printed, from the Print Catalog Preview… command or from the Print 
Catalog command from the File menu.  Each command opens the Print 
Properties dialog box (Figure 3.10), which offers options on three tabs.  

The Page tab allows you to 
specify the page Orientation, 
Scaling, and Selection; you can 
also choose to print the table as 
ASCII, Repeat Headers on every 
page, and print the Gridlines. 

On the Header/Footer tab, you 
can type in the header and footer 
you want to appear on your 
printed pages. 

The Table Title tab offers a 
default title for the table based on 
the data source.  You may edit 
this title. 

On the Print Properties dialog 
box, the Print button performs 
two functions, depending on 
whether you arrived at the dialog 
box via the Print command or the 
Print Preview command.  

 

3.2.5 Exiting HEC-DSSVue 
To exit HEC-DSSVue, from the File menu, click Exit.  (If you have opened 
HEC-DSSVue from another application, such as CWMS or ResSim, select 
Close from HEC-DSSVue’s File menu.) 

 

 

 

 
Figure 3.10 Print Properties Dialog Box 
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3.3 Edit Menu Operations 
Edit menu commands are Tabular Edit, Graphical Edit, and Select All.   

 

3.3.1 Tabular Editing of HEC-DSS Data 
To edit data in a tabular format, from the Edit menu, click Tabular Edit.  
This will display the data in a table format with editing turned on and is the 
same as selecting Allow Editing from a tables Edit menu. 

Chapter 4 on Utilities discusses tabular editing in detail. 

3.3.2 Graphical Editing of HEC-DSS Data 
To edit data in a graphical format, from the Edit menu, click Graphical Edit.  
This will display the data in a combined plot/table format. 

Chapter 4 on Utilities discusses graphical editing in detail. 

3.3.3 Selecting All Pathnames in a HEC-DSS File 
From the View menu, you can select all pathnames in a HEC-DSS file for 
visualization by clicking Select All .  Refer to Section 3.5 for more 
information about selecting pathnames for visualization. 
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3.4 View Menu Operations 
The View menu allows you to customize the display of HEC-DSS pathnames 
and search pathnames.  The following sections describe these options. 

 

3.4.1 Choosing a Display Mode for HEC-DSS Pathnames 
To specify the display mode for HEC-DSS Pathnames, from the View menu, 
choose Pathname List, Pathname Parts, Condensed Catalog, or No 
Pathnames.  Figure 3.11shows a Pathname List of HEC-DSS files displayed.  

 
Figure 3.11 HEC-DSSVue – Data Selection List window, pathname list 
displayed 

You can also view the pathnames the Pathname Parts List (Figure 3.12). 

 
Figure 3.12 HEC-DSSVue – Data Selection List window, pathname parts 
displayed 

The Condensed Catalog style (Figure 3.13) abridges time series data sets so 
that the date span for the entire data set displays in place of the “D” part.    

 
Figure 3.13 HEC-DSSVue – Data Selection List window, condensed catalog 
displayed 
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3.4.2 Refreshing the Catalog 
The catalog automatically refreshes whenever you add, delete or rename 
records.  For very large files, or network files, a dialog box will be shown 
asking if you want a new catalog.  When the catalog is refreshed, it re-
inventories all records on disk to get a pathname for every record.  To 
generate a new catalog manually, from the Edit menu, click Refresh Catalog.  

 

3.4.3 Searching and Filtering HEC-DSS Pathnames 
With HEC-DSSVue, you can select specific data sets from a list of pathnames 
(or catalog) in the database.  You can refine the list by searching for either a 
string in the pathnames or for pathname parts.   

The following sections describe searching and filtering options. 

 

3.4.4 Searching Pathname Strings 
The Search Pathnames by String feature allows you to search for records 
whose pathnames contain specific strings of characters. For example, if you 
search for “FLOW” the list will display only pathnames containing the string 
“FLOW” in the pathname. 

To Search Pathnames by String: 

1. From the View menu, choose Search Pathnames by string. 
2.  In the Search Pathname box (Figure 3.4), type the character string you 

want to filter the pathnames.   
3. Click the Search button. 
 

3.4.5 Filtering HEC-DSS Pathnames by Parts 
The Search by Parts feature lets you choose specific pathname parts from 
those available in a HEC-DSS file.  

To Search by Parts: 

• From the View menu, click Search pathnames 
by parts. 

• Click on the down arrows beside the pathname 
parts you want to search.  This allows you to view 
lists of available names in the file (Figure 3.14).  

• When you have a pathname part list open, you 
can scroll through the list to locate the pathname 
part you want.   

• Click on a pathname part to select it. 
• To return to the previous list, click on the blank field at the top of the list. 

 
Figure 3.14 Selecting 
Pathname Parts 
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3.5 Selecting Pathnames 
Once you have filtered a HEC-DSS file for the pathnames you want, you 
select specific pathnames to visualize data for or perform a utility function on.  
When you select a Pathname, it will appear in the Selected Pathnames List 
(Figure 3.7). 

There are several ways to select pathnames: 

 Double-click on an individual pathname in the HEC-DSS Pathname List.   

 Highlight a pathname in the HEC-DSS Pathname List then click the Select 
button (Figure 3.1).  Until you select a pathname, the Select button 
remains inactive.   

 Click and drag your mouse to select a series of pathnames, and then click 
the Select button.  You can also use Ctrl+click to select multiple, non-
consecutive pathnames. 

 Hold down the control key and click on pathnames to highlight them, or 
hold down on the shift key to highlight all pathnames between mouse 
clicks, and then click the Select button. 

 If you wish to select all of the pathnames, from the Edit menu, choose 
Select All. 

 If no pathnames are selected, you can just highlight one or more 
pathnames and then perform the function that you intended.  If pathnames 
have already been added to the selection box, those pathnames will be 
used instead of the highlighted ones. 

 

 

3.5.1 De-Selecting Pathnames 
To de-select a pathname currently in the Selected Pathnames List: 

1. Click the record’s pathname in the Selected Pathnames List to select it. 
2. Click the De-Select button.  The pathname will no longer appear in the 

Selected Pathnames List. 

To remove all pathnames from the Selected Pathnames List, click the Clear 
Selections button.  To restore selections you have cleared, use the Restore 
Selections button. 
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3.5.2 Setting the Time Window 
You can also specify the time window for data you want displayed in plots 
and tables.  For example, if you have a set of HEC-DSS records ranging from 
October 1, 1993, to December 30, 1993, you can specify a narrower time 
window, such as 05OCT1993 to 25OCT1993 for plots and tables you view, 
and for operations with math functions. 

To set the Time Window: 

1. Click the Set Time Window button.  The Set Time Window dialog 
box will open (Figure 3.15). 

Figure 3.15 Set Time Window Dialog Box 

2. You may either enter specific dates and times or use the current time. 

 To use the current time, click the Set Current Time button.  This 
will set both the start and end dates and times to the current time. 

 To specify dates and times: 
a. Enter the Start Date and End Date.  Although a variety of 

formats will be recognized for the date, the typical format is 
DDMMMYYYY. 

b. Enter the Start Time and End Time in 24-hour format (e.g., 
for 2:00 PM, type “1400”). 

 You may select the starting and ending dates from the calendar 
tool, accessible from a button on the right side of the date field.  
When you click on this button, the selection calendar in a monthly 
format is opened (Figure 3.16 Calendar Selection Tool).  You may 
scroll through months or years by using the appropriate arrow key 
at the top of the box. 

3. The Apply to All Data checkbox is set by default.  The time window 
will be applied to all pathnames that have been selected.  To have the 
time window apply only to pathnames selected after this, uncheck this 
box. 
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4. Click the Apply button to apply the time window without closing the 
dialog box. 

5. Click OK to apply the time window and close the dialog box. 

 

 
Figure 3.16 Calendar Selection Tool 
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3.6 Visualizing HEC-DSS Data with Plots and Tables 
Once the Selected Pathnames List contains all the pathnames you wish to 
display, you can generate plots and tables.   

To create a plot or table from the Display menu, select Plot or Tabulate.  
You can also click on the Plot  button or the Tabulate  button.   

From a plot window, you can also tabulate data using the Tabulate command 
in the plot’s File menu.  Likewise, to open a plot from a table, you can use the 
Plot command in the table’s File menu. 

Figure 3.17 shows examples of the plots and tables HEC-DSSVue can 
produce.  

 
 Figure 3.17 Example Plot and Table 

HEC-DSSVue plots are highly customizable.  You can add titles, specify 
colors and patterns of backgrounds and lines, change line styles, add markers 
and callouts, add borders to labels, and customize legends, axes, and tic 
marks. 

For more information on plots, refer to the chapter on Plots. 

For more information about tables, see the chapter on Utilities.   
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3.6.1 Plot Data Options 
Two options are provided as a quick way to compare time series data sets for 
different time periods or for different amounts.  The options are turned on or 
off by selecting them from the submenu and then clicking them.   

The Normalize option will subtract the differences between the values of first 
and the second or subsequent data sets from the corresponding data set, so that 
the curves all start at the same value (which is the value of the first data in the 
first data set).  This is often used to compare cumulative precipitation curves, 
which usually start at different values. 

The Synch data set times to first option will subtract the differences between 
the times of first and the second or subsequent data sets from the 
corresponding data set, so that the curves all start at the same time (which is 
the time in the first data set).  This is often used to directly compare 
hydrographs for different years or time periods. 

Each option will remain on until you turn it off or the program exits.  The 
options can be used in combination with each other.  For example, if you want 
to compare cumulative precipitation curves for different years, set each option 
to on.  Figure 3.18 shows such an example of normalized cumulative 
precipitation for years 1986 and 1995, synched to the same start time. 

 
 Figure 3.18 Normalized and Time Synched Precipitation Data for Years 1986 and 1995 
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3.7 Utilities Menu Operations 
The Utilities menu provides access to Math Functions, Manual Data Entry 
(Time Series and Paired Data), and it allows you to Rename Records, 
Duplicate Records, Copy Records, Delete Records, Undelete Records, 
Merge Files, Squeeze, access the Script Browser and the Script Selector, 
and view the HEC-DSS Status of files opened. 

These functions are discussed in detail in three separate chapters: Math 
Functions, Utilities (which also covers tabular editing and printing 
functions), and Scripting. 

 

3.8 Plug-ins 
HEC-DSSVue has the capability of accepting Java jar plug-ins.  A plug-in is 
essentially compiled Java code that has been written to extend the capability 
of HEC-DSSVue.  It is similar to a script, but can be more powerful and more 
customizable.  For example, a plug-in might retrieve data, decode it and store 
it into a HEC-DSS file.  Another use might be to perform sophisticated math 
functions on data selected from the main screen. 

Plug-ins are added by placing the jar plug-in file in the HecDssVue/Plugins 
directory.  When HEC-DSSVue is executed, it searches this directory for 
available plug-ins and loads them into the program.  Most plug-ins will add a 
button to the main toolbar, adjacent to any script buttons.  To remove a plug-
in, simply remove its jar file from the Plugins directory. 

Visit the HEC-DSSVue area of the HEC web site to obtain publicly accessible 
plug-ins, or contact HEC for more information. 
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