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Chapter 4 
4 Utilities  

HEC-DSSVue utilities allow you to tabulate, edit, duplicate, copy, rename, 
and delete data, manually enter data, create and edit scripts, and perform math 
functions, as well as merge and squeeze HEC-DSS files. 

This chapter provides guidance in using these utilities and also shows you 
how to print, copy, and export tabular HEC-DSS data. 
 

4.1 Viewing Tabular Data 
Figure 4.1 shows an example table produced using HEC-DSSVue.  Tables 
allow you to view and edit HEC-DSS data in a vertical scrolling window that 
shows the ordinate (starting from the start date/time), the date and time stamp, 
and the values for the selected data sets.  From the File menu of the table 
window, you can view the tabular data in plot format by clicking Plot. 

 

Figure 4.1 Example Tabulation from HEC-DSSVue 
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4.1.1 Accessing Tables 
To access tables, first select the pathnames of the records you wish to view.  
There are several ways to select pathnames: 

 Double-click on an individual pathname in the HEC-DSS Pathname List.   
 Highlight a pathname in the HEC-DSS Pathname List then click the 

Select.  
 If you wish to select all of the pathnames for visualization, from the Edit 

menu, click Select All. 
 If no pathnames are in the selection list, individual pathnames can just be 

highlighted for quick selection. 

When you select a pathname, it will appear in the Selected Pathnames List. 

Once you have selected the pathnames you want to visualize, you can open a 
table by clicking on the Tabulate  button, or from the Display menu, by 
clicking Tabulate. 
 

4.1.2 Customizing the Display of Tabular Data 
In HEC-DSSVue tables you have several options for displaying data.  

to Show Missing values as blanks (the default), “-901.0”, “M”, or “-M-”. 
 

4.2 Editing Tabular Data 
In HEC-DSSVue, you can edit data directly in tables.   

From the Edit menu of the table, select Allow Editing (Figure 4.2) to 
manually edit the data in the table.  When this option is checked, the 
background of non-editable table cells is changed to grey, the Cut and Paste 
commands become available in the menu, as well 
as the menu items Insert Rows, Append Rows 
and Delete Rows.  Currently, you can insert, 
append or delete rows only when you are 
working with a single data set. 

 
Figure 4.2 Edit menu - 
Allow Editing option 
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You can also use shortcut menu commands to edit 
multiple selected cells in tables (Figure 4.3 Shortcut 
Menu).  

If the Allow Editing option is disabled (greyed-out), 
then either you do not have permission to write back to 
the file, or the table was started from a dialog that does 
not have access to write to the file (such as a plot). 

If you make any edits, HEC-DSSVue prompts you can 
save your changes with the Save or Save As items 
under the File menu.  If you do not save your data, 
HEC-DSSVue will prompt you to save your changes 
when you close the window.   
 

4.2.1 Selecting Table Cells 
To select an individual table cell, double-click on it.   

To select several consecutive cells, click and drag your mouse.  You can also 
use Ctrl+Click to select multiple, non-consecutive records. 

If you wish to select all rows in a table, from the shortcut menu, click Select 
All (Figure 4.3). 

 
 

4.2.2 Cutting and Pasting Data 
The Cut command removes data from its current location and places it on the 
clipboard in ASCII format.  For time series data, the Cut command will 
replace the data values with missing flags. 

You can cut data from one set of cells and paste them into another set of cells 
(in the same table or another table).  To do this: 

1. From the View menu of the table (or tables), click Allow Editing. 
2. Select the cells you want to cut. 
3. From either the View menu or the shortcut menu (Figure 4.3 Shortcut 

Menu), click Cut. 
4. Select the cells where you want to move the data. 
5. From either the View menu or the shortcut menu (Figure 4.3 Shortcut 

Menu), click Paste.   

 

Figure 4.3 Shortcut 
Menu  
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4.2.3 Copying and Pasting Data 
The Copy command places the selected data on the clipboard in ASCII 
format.  You can also copy data from one set of cells to another.  To do this: 

1. Select Allow Editing from the View menu of the table (or tables). 
2. Select the cells you want to copy. 
3. Choose Copy from either the View menu or the shortcut menu (Figure 

4.3) of the table. 
4. Select the cells where you want to copy the data. 
5. Choose Paste from either the View menu or the shortcut menu (Figure 

4.3) of the table.   

You can also use the Copy command to copy and paste data into another 
application, such as Microsoft Excel or Word. 
 

4.2.4 Clearing Table Cells 
When you clear table cells, the data is not saved on the clipboard, so you 
cannot later paste the data back into the table.  For time series data, the Clear 
command will replace the data values with missing flags. To clear table cells: 

1. From the View menu of the table (or tables), click Allow Editing. 
2. Select the cells you want to clear. 
3. From the shortcut menu of the table (Figure 4.3 Shortcut Menu), click 

Clear. 
 

4.2.5 Inserting Rows 
For regular-interval time series data, rows can only be inserted at the 
beginning of the data set.  For irregular-interval time series data and paired 
data, select with your mouse the ordinate of the row where you want rows 
inserted and then from the Edit menu select Insert Rows…  A small dialog 
box will be displayed asking you to enter the number of rows to insert.  Type 
in the number of rows you want inserted and press OK.  That number of blank 
rows will be inserted at that row moving the original row that you selected 
down.  For irregular-interval time series data, enter the date and time and 
value for each row, or for paired data, the X and Y ordinate values.  Be sure to 
delete any rows where you have not filled values in. 
 

4.2.6 Appending Rows 
Appending rows is automatic when editing data.  When you set the table into 
edit mode, two blank rows appear at the end of the table where you can enter 
data.  After you enter data for a row, an additional blank row appears.  When 
you save the data, any blank rows at the end of the table are removed 
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automatically.  You can specify an additional number of rows to append to the 
data set by selecting the Append Rows… option from the Edit menu.  After 
you select this, enter the number of rows you want appended to the end of the 
data set in the dialog box that appears.  Delete any rows where you have not 
filled values in. 

4.2.7 Deleting Rows 
You may delete rows from a table when working with irregular-interval time 
series data and paired data.  To delete a row from a table, first select the row 
(see Section 4.2).  Next, from the Edit menu, click Delete Rows. 

If you are working with regular interval time series data, you will not be able 
to delete rows; instead, the Delete Rows function will change the data values 
to missing.  This is the same as selecting Clear from the shortcut menu. 
 
 

4.3 Printing, Copying, and Exporting Tables 
HEC-DSSVue tables offer several commands that allow you to print as well 
as export or copy, and paste tables into other applications such as Microsoft 
Excel and Word. 
 

4.3.1 Printing Tables 
You can access the Print and Print Preview command from either the File 
menu (Figure 4.4) or from the shortcut menu (Figure 4.5) of the table 
window.   

 

 
Figure 4.4 File Menu--Table Window 

 
Figure 4.5 Shortcut 
Menu--Print Command 
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In a table, the Print and Print 
Preview commands open the 
Print Properties dialog box 
(Figure 4.6), which offers options 
on three tabs. 

The Page tab allows you to 
specify the page Orientation, 
Scaling, and Selection; you can 
also choose to print the table as 
ASCII, Repeat Headers on every 
page, and print the Gridlines. 

On the Header/Footer tab, you 
can type in the header and footer 
you want to appear on your 
printed pages. 

The Table Title tab offers a 
default title for the table based on 
the data source.  You may edit 
this title. 

On the Print Properties dialog 
box, the Print button performs two functions, depending on whether you 
arrived at the dialog box via the Print command or the Print Preview 
command. 

 
Figure 4.6 Print Properties Dialog Box 
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From the Print Preview command 
on the shortcut menu, the Print 
button on the Print Properties 
dialog box opens a Print Preview 
window, which allows you to view 
the table as it will be printed.  Figure 
4.7 shows an example. You can click 
the Print button in the Print Preview 
window to print your table. 

From the Print command, the Print 
button on the Print Properties 
dialog box opens a Windows-style 
print dialog box, where you can 
choose your printer, set printer 
properties, and specify the number of 
copies to print.  You can also print 
your table to a file instead of to a 
printer. 

 
 

 

 

4.3.2 Exporting Tables 
From the shortcut menu, click Export to export a table to a file, which you 
can then open in another application.  

The Export command opens the Table Export Options dialog box (Figure 
4.8). 

In the Table Export Options 
dialog box, you can choose the 
Field Delimiter (tab, space, 
comma, or colon), specify Fixed-
Width Columns, choose to display 
Quoted Strings, Include Column 
Headers, and opt to Print 
Gridlines and Title. 

 

 

 

 

 
Figure 4.7 Print Preview of a Table  

 
Figure 4.8 Table Export Options Dialog 
Box 
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4.3.3 Copying Tables to the Clipboard for Use in Other 
Applications 

To copy a table to the clipboard, click Copy from the table window’s Edit 
menu (Figure 4.9).  You can also right-click inside the table and select Copy 
from the shortcut menu (Figure 4.10). You can then paste the table as tab-
separated values into another application such as Microsoft Excel or Word.    

 

 
Figure 4.9 Edit Menu--Table Window 

 
Figure 4.10 Shortcut Menu--
Copy Command 
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4.4 Entering Data Manually 
You can enter time series and paired data manually using the Manual Data 
Entry editors available from the Utilities menu. 
 

4.4.1 Entering Time Series Data Manually 
To enter time series data manually: 

1. From the Utilities menu, choose Manual Data Entry, and then select 
Time Series.  The Manual Time Series Data Entry dialog box 
(Figure 4.11) will open. 

 

Figure 4.11 HEC-DSSVue Manual Time Series Data Entry Dialog Box 
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2. Type the Pathname Parts into the A, B, C, and F boxes, then select 
the appropriate time interval for the E box.  The complete pathname 
will automatically appear in the Pathname box.  You can also enter 
the pathname into the Pathname box; the parts will appear in the 
Pathname Parts boxes.  You cannot enter the “D” (date) part, as this 
is set according to your Start Date). 

3. Enter the Start Date (e.g., 25Mar2002) and Start Time (e.g., 1400). 
4. Enter the Units (e.g., CFS) 
5. From the Type list, select a data type.  Your options are PER-AVER, 

INST-VAL, PER-CUM, and INST-CUM. 
6. For regular-interval time series data, the Date/Time boxes in the table 

will fill in automatically according to the start date and time you have 
entered.  For irregular-interval data, you will need to enter a date and 
time for each data value. 

7. Type the data values into the third column. 
8. To view the data in plot form, click the Plot button. 
9. To graphically edit the data you have entered, click Graphically Edit. 
10. To save the new time series record, click Save. 

 

You can paste data on the clipboard from another application by clicking the 
Paste button.  This allows you to copy data from various applications like 
Microsoft Excel into HEC-DSS.  When you paste data into HEC-DSS, the tab 
characters and carriage return characters in the program that you are copying 
from must match the data entry table.  Tab characters move to the next 
column to the right, while carriage return characters move to the next row 
down.  These are the default characters used in Excel. 

For regular interval time series data, the data must be in a columnar format 
(e.g., a column from Microsoft Excel) and should contain data values only.  
For irregular interval data, the date and time must precede each data value, 
with tab characters separating them.  For paired data, all values for each 
ordinate must be separated by a tab character.  To enter data using the paste 
capability: 

1. Complete steps 1 through 5 (above.) 
2. Select your data set from the other application and Copy it into the 

clipboard. 
3. Press the Paste button located just above the table.  You should see the 

data from the clipboard appear in the table. 

 

You can also automatically generate regular-interval time series data.  This 
will fill in a single number for a time window.  To generate this data: 

1. Complete steps 1 through 5 (above.) 
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2. Select the Automatic Generation tab. 
3. Enter the End Date and End Time for the data. 
4. Enter the Fill Value, which is the single value for the specified time 

window. 
5. Press the Generate button.  This will return you to the Manual Entry tab, 

where you can plot, save, or further edit the data. 
 

4.4.2 Entering Paired Data Manually 
To enter paired data manually: 

1. From the Utilities menu, choose Manual Data Entry, and then select 
Paired Data.  The Manual Paired Data Entry dialog box dialog box 
(Figure 4.12) will open. 

 
Figure 4.12 HEC-DSSVue Manual Paired Data Entry Dialog Box 
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1. Type the Pathname Parts into the A, B, C, D, E, and F boxes.  The 

complete pathname will automatically appear in the Pathname box.  
You can also enter the pathname into the Pathname box; the parts will 
appear in the Pathname Parts boxes.  Be sure the “C” part contains 
both an X parameter and a Y parameter, separated by a hyphen (e.g., 
STAGE-FLOW or ELEV-DAMAGE). 

2. Select the Number of Curves for the Y parameter from the list. 
3. Enter the X Units (belonging to the first parameter) and the Y Units 

(belonging to the second parameter). 
4. Choose the X Type and Y Type from the lists. Available options are 

Linear, Log, and Probability. 
5. In the table, the Y ordinates column will split into individual columns 

according to the Number of Curves you have specified.  
6. Type the data values into the X ordinates and Y ordinates columns. 
7. To view the data in plot form, click the Plot button. 
8. To save the new time series record, click Save. 

 

You can paste data on the clipboard from another application by clicking the 
Paste button.  This allows you to copy data from various applications like 
Microsoft Excel into HEC-DSS.  When you paste data into HEC-DSS, the tab 
characters and carriage return characters in the program that you are copying 
from must match the data entry table.  Tab characters move to the next 
column to the right, while carriage return characters move to the next row 
down.  These are the default characters used in Excel.  For paired data, all 
values for each ordinate must be separated by a tab character with a carriage 
return character at the end of each row.  To enter data using the paste 
capability: 

1. Complete steps 1 through 6 (above.) 
2. Select your data set from the other application and Copy it into the 

clipboard. 
3. Press the Paste button located just above the table.  You should see the 

data from the clipboard appear in the table. 
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4.5 Graphical Editing  
You can view and edit time series data in a combined plot/table using the 
Graphical Editor for HEC-DSSVue.  An example of the Graphical Editor is 
shown in Figure 4.13.  To access the HEC-DSSVue Graphical Editor, select 
one or more pathnames from the main HEC-DSSVue screen and then select 
Graphical Edit… from the Edit menu, or click on the Graphical Edit  
button.  Only time series data can be edited through the graphical editor. 

 

 
Figure 4.13 HEC-DSSVue Graphical Editor 

The Graphical Editor displays an editable plot of the data on the top of the 
window and a scrollable table of the data on the bottom of the window.  The 
area of the data that is visible in the table is marked with a green hash region 
in the plot.  As you scroll through the table, the green hash area moves along 
with the data that is displayed.  When you select a point on the curve or in the 
table, a black vertical line is drawn at that point to show which value has been 
selected. 
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You can edit data in the graphical editor by drawing a curve with your mouse, 
or by selecting a point on the curve and moving that point up or down, or by 
changing a value in the associated table.  You can also have the editor linear 
interpolate missing points, or use the other fill options associated with tables. 

You can only edit one curve at a time, but you can plot other data sets on the 
same graph for comparison purposes.  You can also select multiple data sets 
and scroll through them as you edit.   

 

4.5.1 Graphical Editor Components 
Figure 4.14 shows the major components of the graphical editor. 

 

  

 
 

 

 

Figure 4.14 HEC-DSSVue Graphical Editor Components 

 

Selected value/row

Estimate / allow 
Point editing 

Viewable table area 
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irregular-
interval rows 

Original column   Edit column Edited column 
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The components of the graphical editor are: 

• Selected value/row shows what data value is selected on the plot and its 
corresponding row in the table. 

• Viewable table area indicates the area in the plot that corresponds to the 
data showing in the table. 

• Data Set indicates which data set is being edited. 

• Estimate generates a linear interpolation for selected rows where there is 
missing data or copies the original data into the editable field.  Estimate 
All performs this for all rows in the table. 

• Accept copies data from the Estimate/Entry (edit) column into the edited 
column for the selected rows.  This is for intermediate saving of the last 
data edited.  Accept All copies all data from the edit column into the 
edited column.  You select this if you want to retain all changed values. 

• Add adds rows for irregular-interval time series data.  A dialog will be 
displayed to set the date and time for the row added. 

• Delete removes rows for irregular-interval time series data.  You cannot 
remove regular-interval data; you can only change it to missing. 

• Original column contains the values of the original data set.  The values 
are generally depicted with an orange curve in the plot with each point 
marked by an “x”.  If the value is the same as the one in the Revised 
column, that point will be over drawn with the blue revised value. 

• Estimate/Entry (Edit) column is the column where data can be manually 
entered or edited with the point tool.  These values are marked with 
magenta triangles in the plot.   When you are satisfied with the changes, 
press the Accept or Accept All button and the values will display in the 
Revised column. 

• Revised (Edited) column contains the final values that will be saved 
when Save or Save As is selected.  These values are colored blue and 
marked with an “x”. 
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4.5.2 Graphical Editor Tools and Buttons 
Figure 4.15 shows the mouse tools and toolbar buttons available in the 
graphical editor. 

 

 
 
  

 
Figure 4.15 Graphical Edit Tools 

The mouse tools are: 

• Select Point tool selects a point on the curve to edit by moving the mouse 
to that point and pressing the left mouse button. 

• Zoom tool put the mouse in zoom mode.  To zoom-in, move the mouse to 
one corner of the area you want to zoom-in to, press and hold down the 
left mouse button while dragging the mouse to the opposite corner and the 
release the button.  To zoom-out, press the right mouse button.  The graph 
is zoomed-out in increments. 

• Single Point Edit tool puts the mouse in a point edit mode, as described 
in Section 4.5.4. 

• Line Draw (multi-point edit) tool puts the mouse in a line draw mode, as 
described in Section 4.5.3. 

The toolbar buttons are: 

• Save button saves the data in the Revised column to the DSS file without 
changing the pathname. 

Save As

Save

Undo Plot Tabulate 

Line Draw

Single Point 

Zoom

Select Point
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• Save As button saves the data in the Revised column to the DSS file after 
allowing you to change one or more of the pathname parts. 

• Undo button restores the values to the original data set, undoing all 
changes. 

• Plot button plots the original and revised data in a standard plot window 

• Tabulate button tabulates the original and revised data in a standard 
table. 

 

4.5.3 Editing a Curve with the Line Draw Tool 
You can edit data by drawing a curve freehand (actually mouse-hand) by 
moving the mouse from left to right while clicking on the left mouse button at 
selected inflection points.  To do this: 

1. Select the data set from the drop down box at the top of the screen if it is 
not selected already.   

2. Press the Line Draw (multi-point edit)  tool. 

3. Move the mouse to the left-most position of the curve where you want to 
start editing. 

4. Click on the left mouse button to mark the first data point. 

5. Move the mouse right along your desired curve and press the left mouse 
button at inflection points.  The graphical editor will draw a straight line 
between points. 

6. If you make a mistake, you can move the mouse left past that point and 
insert a new inflection point.  You can backup as many points at one time 
as you want. 

7. When you are finished with a curve segment, press the right mouse button.  
(That location will not be used as part of the curve.)  The line segments 
just given will be drawn with magenta triangles, and those data points 
entered in the Estimate/Entry column. 

8. You can draw other curve segments elsewhere on the plot using the same 
procedure. 

9. If you need to remove a curve segment that you have drawn, select the 
values for it in the table and press the Estimate button.  The original 
values will be copied into the Estimate/Entry column. 

10. After completing your curve, press the Accept button or the Accept All 
button to accept all edits.  This will copy the data from the 
Estimate/Entry column into the Revised column and will be ready to 
save to the HEC-DSS file. 
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11. At the end of all of your edits, press the Save  or Save As  button or 
select that item from the File menu to store your changes in the HEC-DSS 
file. 

 

4.5.4 Editing a Point with the Single-Point Edit Tool 
You can edit single data values by double clicking on the new point that you 
want or clicking on the existing point and moving it vertically.  To do this: 

1. Select the data set from the drop down box at the top of the screen if it is 
not selected already.   

2. Press the Single-Point Edit  tool. 

3. Find the new value of the point on the graph that you want to edit and 
double click the mouse at that location.  This will enter the value that you 
selected into the Estimate/Entry column.   

4. Edit the remaining points that you desire to have changed and when you 
are complete, press the Accept button or the Accept All button to accept 
all edits.  This will copy the data from the Estimate/Entry column into 
the Revised column and will be ready to save to the HEC-DSS file. 

5. At the end of all of your edits, press the Save  or Save As  button or 
select that item from the File menu to store your changes in the HEC-DSS 
file. 

 

You can also grab the point that you want to modify and move it vertically.  
To do this: 

1. Click the left mouse button on the data point you want to edit.  The table 
row containing that point will be highlighted. 

2. Press the Estimate button to provide a value to start from, unless there is 
already a value in the Estimate column.  A magenta triangle will be drawn 
at that point on the curve. 

3. Move the mouse over the triangle and press and hold down the left mouse 
button.  Move the mouse up or down to the desired value. 

4. Edit the remaining points that you desire to have changed and when you 
are complete, press the Accept button or the Accept All button to accept 
all edits.  This will copy the data from the Estimate/Entry column into 
the Revised column and will be ready to save to the HEC-DSS file. 

5. At the end of all of your edits, press the Save  or Save As  button or 
select that item from the File menu to store your changes in the HEC-DSS 
file. 
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4.5.5 Editing Data in the Table 
You can edit data in the table, and add or delete irregular-interval time series 
values, although you cannot extend the table.  Regular-interval values cannot 
be deleted or added, however you can change values to missing.  To edit data 
within the table: 

1. Select the data set from the drop down box at the top of the screen if it is 
not selected already.   

2. Select the row in the table that you want to edit at, or select the location on 
the graph with the mouse after pressing the Select  tool. 

3. Type in the new values in the Estimate/Entry column.  To move to the 
next row in the column, press the Tab key. 

4. You can copy the original value to the Estimate/Entry column and then 
change it by pressing the Estimate or Estimate All button. 

5. When complete, press the Accept button or the Accept All button to 
accept all edits.  This will copy the data from the Estimate/Entry column 
into the Revised column and will be ready to save to the HEC-DSS file. 

6. At the end of all of your edits, press the Save  or Save As  button or 
select that item from the File menu to store your changes in the HEC-DSS 
file. 

You can repeat values or linearly interpolate between selected values or delete 
values by using the popup selector shown in Figure 4.16. 

 

 
Figure 4.16 Table Fill Options Box 

To fill multiple values in the table: 

1. Select (highlight) the starting row of the data that you want to fill.  For 
linear and repeat fill, this marks the starting value to use, which will not be 
changed.  If the clear fill option is selected, this is the first value to be 
cleared. 

2. Mark the ending row.  You can do this by holding down the left mouse 
button and moving the mouse down the table, or by left-clicking the 
mouse on the ending row while holding down the “Shift” key. 

3. Right click the mouse button to bring up the popup window in Figure 4.16 
and then select either Fill – Linear, Fill – Repeat, or Clear.  For Linear, 
the values between the first and last point will be linearly interpolated, 
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with the first and last point remaining the same.  For Repeat, the first 
value will be repeated through the last value.  For Clear, all values within 
the selected rows will be set to missing. 

4. When complete, press the Accept button or the Accept All button to 
accept all edits.  This will copy the data from the Estimate/Entry column 
into the Revised column and will be ready to save to the HEC-DSS file. 

5. At the end of all of your edits, press the Save  or Save As  button or 
select that item from the File menu to store your changes in the HEC-DSS 
file. 

 

4.5.6 Printing the Table and Graph 
You can print the table or graph by using the Print Table or Print Graph 
command from the File menu of the Graphical Editor window. 

The Print Table commands open 
the Print Properties dialog box 
(Figure 4.17), which offers 
options on three tabs. 

The Page tab allows you to 
specify the page Orientation, 
Scaling, and Selection; you can 
also choose to print the table as 
ASCII, Repeat Headers on every 
page, and print the Gridlines. 

On the Header/Footer tab, you 
can type in the header and footer 
you want to appear on your 
printed pages. 

The Table Title tab offers a 
default title for the table based on 
the data source.  You may edit 
this title. 

When you press the Print button, 
a standard Windows-style print 
dialog box opens to select the printer and printer options. 

The Print Graph command opens a standard Windows-style print dialog box 
to select the printer and printer options for printing the graph.  The printed 
graph will include the shaded hash area. 

You can set the page settings for the printed graph.  To do this, click Page 
Setup from the File menu.   

 
Figure 4.17 Print Table Properties Dialog Box 

 



HEC-DSSVue User’s Manual  Chapter 4 – Utilities 
 

  4-21
  

From the File menu, click Page 
Setup.  The Page Setup dialog box 
will open (Figure 4.18).  Here you 
can set the page Orientation, Page 
Margins, Page Numbers, and 
Printer Scale.   

Set Margins opens the Printer 
Margins dialog box (Figure 4.19).  
 

 
Figure 4.19 Printer Margins Dialog Box 

 

4.5.7 Graphical Editor View Options 
From the View menu, you can choose to plot the other data sets that you have 
selected on the same plot at the same time by selecting the Show Comparison 
Data item.  If the data types are the same, the data sets will plot in the same 
viewport; otherwise they will be plotted in different viewports. 

You cannot edit the other data sets at the same time.  To edit comparison data 
sets, you must select a data set from the Selected Data Set box under the 
menu area. 

You can also display a standard table of the selected data (original and 
modified) from the Tabulate item, or a standard plot from the Show Plot 
item.  You can set the precision of decimal places for displaying your data by 
selecting Decimal Places and selecting the number of decimal places you 
wish to display. 

 

 
Figure 4.18 Page Setup Dialog Box 
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4.6 Renaming HEC-DSS Data in HEC-DSSVue 
The Rename command renames record pathnames.  To rename HEC-DSS 
records: 

1. Select the record or records to rename. 
2. From the Utilities menu, select Rename Records.    The Rename 

Records to: dialog box (Figure 4.20) will open. 
You may change one or more pathname parts or the entire record. Type the 

new Pathname Parts into the A, B, C, D, E, and F boxes.  You cannot 
change the D or E parts for time series data (use Math Functions to 
accomplish this).  For multiple records, pathname parts that are the same 
for all records will show up in the dialog.  Where parts differ (such as 
having pathnames with C parts of FLOW and ELEVATION), the part will 
be displayed with an asterisk (*). 

3. Click OK. 

 
Figure 4.20 HEC-DSSVue Rename Records to Dialog Box 

 
 

4.7 Copying Records into another HEC-DSS File 
To copy records into another HEC-DSS file,   

1. Select the record or records to copy. 
2. From the Utilities menu, select Copy Records.  The Copy Records into 

HEC-DSS File dialog box (Figure 4.21) will open. 
3. In the File Name box, type in a new HEC-DSS filename or select an 

existing HEC-DSS File into which you want to copy the record into and 
click Open.  A confirmation message will appear stating that the record 
has been copied to the HEC-DSS file you selected.   
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4. If the record(s) already exist in that file, a message box will appear asking 
if you want them to be overwritten (Figure 4.22).  If the number of 
pathnames is four or less, their names will be displayed in the message 
box; otherwise they will be printed in the log screen. 

 

 
Figure 4.21 HEC-DSSVue Copy Records into HEC-DSS File Dialog 
Box 

 
 
Figure 4.22 Message Asking if Records Should be Overwritten. 

4.8 Duplicating Records 
 

The Duplicate command duplicates records in the same HEC-DSS file, giving 
the new records different pathnames.   

To duplicate records:  

1. Select the record or records to duplicate. 
2. From the Utilities menu, select Duplicate Records.  The New Pathname 

Parts for Duplicate Records dialog box (Figure 4.23) will open. 
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Figure 4.23 HEC-DSSVue New Pathname Parts for Duplicate Records 
Dialog Box 

 
3. Type the new Pathname Parts into the A, B, C, D, E, and F boxes    You 

cannot change the D or E parts for time series data (use Math Functions to 
accomplish this).  For multiple records, pathname parts that are the same 
for all records will show up in the dialog.  Where parts differ (such as 
having pathnames with C parts of FLOW and ELEVATION), the part will 
be displayed with an asterisk (*).   

4. Click OK.  A confirmation message will appear, stating that the records 
have been duplicated.  

 

4.9 Deleting Records 
When you delete data from a HEC-DSS file, the data is marked as missing, 
but not actually removed until you squeeze the file.  You can recover deleted 
records with the Undelete command, described later.  Once a file has been 
squeezed, records cannot be undeleted. To delete records from a HEC-DSS 
file: 

1. Select the record or records to delete. 
2. From the Utilities menu, select Delete Records.  A dialog box will 

confirm that you want to delete those records.  If the number or records is 
four or less, their pathnames will be displayed in the dialog. 

3. Click OK.  A confirmation message will appear, stating that the records 
have been deleted.   

 

4.10 Undoing Deletions  
Deleted records may be recovered as long as the HEC-DSS file has not been 
squeezed.  When a file is squeezed, all deleted records are physically 
removed.  
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You can undelete records in three ways:  1) Undelete all records in the file;  2)  
Select the records to undelete from a list;  3)  Undelete the records that you 
just deleted.  To undelete records from a HEC-DSS file: 

1. From the Utilities menu, select UnDelete and then select either All, 
Selected…, or Last Deleted.   

2. To undelete all records select All.  A dialog box will confirm that you 
want to undelete all of the records in the file.  Click OK.  A confirmation 
message will appear, stating that the records have been undeleted. 

3. To undelete the records that you have just deleted, select Last Deleted.  A 
dialog box will confirm that you want to undelete the records that you just 
deleted.  Click OK.  A confirmation message will appear, stating that the 
records have been undeleted. 

4. If you choose Selected…, a list of the pathnames that you can undelete 
will appear (Figure 4.24).  Check the boxes of the records that you want to 
undelete, or press the Select All button to undelete all records in the list.  
You can unselect the checked records by pressing the Unselect All button.  
Once you have made your selection, press the OK button to undelete those 
records and close the dialog, or press Apply to undelete the records and 
leave the dialog open, or press Cancel to quit the dialog.  A confirmation 
message will appear stating that the records have been undeleted. 

 
 

Figure 4.24 HEC-DSSVue Undelete Records Selection Dialog Box 
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4.11 Merging HEC-DSS Files 
Merging copies all of the records in the currently opened HEC-DSS file into 
another.  This is similar to selecting all records then using the Copy Records 
option, but is much more efficient.  However, this option will overwrite any 
records with the same pathnames and will not splice together time series 
records.  To merge the current HEC-DSS file into another:  

1. From the Utilities menu, click Merge Files.  The Merge (copy all 
records) into HEC-DSS File dialog box (Figure 4.25) will open.   

2. In the File Name box, select an existing HEC-DSS File into which you 
want to copy all of the records into and click Open.  A confirmation 
message will appear stating that the records have been copied into the 
HEC-DSS file you selected.  

 
 

 

 
Figure 4.25 HEC-DSSVue Merge (copy all records) into HEC-DSS 
File Dialog Box 

 

4.12 Squeezing HEC-DSS Files 
When you delete or rename records, a HEC-DSS file will accumulate inactive 
space.  The Squeeze command removes inactive space by copying all valid 
data to a new file then renaming the new file to the old filename.  The 
Squeeze command will also automatically re-adjust internal HEC-DSS table 
sizes to optimize access to the data.  This is similar to de-fragmenting your 
file system.   Once a squeeze has been accomplished, deleted data cannot be 
recovered. 
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To squeeze an HEC-DSS file: 

1. Open the HEC-DSS file, then, from the Utilities menu, click Squeeze.  A 
window will appear indicating the status of the squeeze process, as shown 
in Figure 4.26.   

2. If you wish, you may cancel the squeeze prior to completion, by pressing 
the Cancel button.   

3. When the process is complete, a confirmation will appear (Figure 4.27) 
 

 
Figure 4.26 HEC-DSSVue Squeeze Progress Window 

 
Figure 4.27 Example HEC-DSSVue Squeeze Confirmation Message 
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4.13 Scripting 
You can use Jython scripts that you or others write, to perform math 
functions, create custom plots or tables, and automate repetitive tasks.  To 
edit, test, and select scripts, use the Script Browser.  To run scripts that have 
already been setup, use the Script Selector window.  To access the Script 
Browser (Figure 4.28), from the Utilities menu, click Script Browser.  To 
access the Script Selector window, from the Utilities menu, click Script 
Selector.  For more information, refer to the chapter on Scripting. 

 

Figure 4.28 Script Browser 
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4.14 Performing Math Functions  
To access HEC-DSSVue Math Functions, from the Utilities menu, click 
Math Functions.  The Math Functions dialog box (Figure 4.29) will open. 

 

 
Figure 4.29 HEC-DSSVue Math Functions Dialog Box 

HEC-DSSVue Math Functions facilitate the mathematical manipulation of 
time series and paired data sets you have selected.  Available functions fall 
into six categories: Arithmetic, General, Time Conversion, Hydrologic, 
Smoothing, and Statistics.  Each function category is a tab on the Math 
Functions screen. 

Use the Operator list to select functions, and choose data sets from the 
Selected Data Set list. Click the Compute button to apply a function.  The 
Compute button is available only if the data on the function screen is 
complete. 

Refer to the Chapter 6 on Math Functions for more information. 
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