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Chapter 5 
Customizing Plots 

Plots are highly customizable and offer an array of information that will assist 
you with reviewing your data.  Figure 5.1 shows a sample plot illustrating raw 
and revised data for stage and flow at a location called Beech Creek Station.   
 

 
Figure 5.1 Plot Window 

With the Pointer Tool , you can access shortcut menus that allow you to 
customize features of your plots using the plot window’s editing tools.  The 
following sections discuss these tools in detail. 

The Zoom Tool  allows you to view data closely at a specific time.  To 
zoom in, select the Zoom Tool then “draw” a rectangle around the section of 
the plot you wish to enlarge.  To zoom out, right-click anywhere in the display 
area using the Zoom Tool.   

Title Bar
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If you wish to keep the plot window on top of your desktop so you can view it 
while working in other windows, you can select Always on Top from the 
View menu.  A check mark indicates this option is active. 

5.1 Customizing Plots: Overview 
Plot properties editors allow you to configure default properties for plots as 
well as customize individual plots.  

Figure 5.2 shows the features of plots you can configure.   

 
Figure 5.2 Configurable Features of Plots 

 Title: Optionally, you can add a title to the plot display. 
 Panel Background Color: You can specify the background color of the 

plot window (light grey is the default). 
 Curve/Line Properties: You can choose the line and point styles, add 

labels, and specify symbols to indicate quality. 
 Marker:  You can add markers on the X and Y axes and customize the 

appearance of these markers. 
 Spacer:  You can specify the distance between viewports, between a 

viewport and the legend, and the width of side margins. 
 Callout: You can add descriptive callouts at specific points along a line. 
 Viewport: You can customize the border around the viewport, the 

background color and pattern, and the appearance of gridlines.  You can 
also specify the number, size, and content of viewports.  

 Label: You can add borders and backgrounds to axis and legend labels. 
 Axis:  You can specify either a linear or log axis type, specify the axis 

scale, and customize tic marks. 
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 Legend: You can add titles to the plot legend and specify whether the 
legend appears below or to the right of the plot. 
 

5.2 Using Plot Editors 
Several different editing interfaces allow you to either set defaults for all plots 
or specify properties of individual plots.  Figure 5.3 shows three examples: the 
Default Plot Properties Editor, the Plot Properties Editor, and the 
Viewport Properties Editor.   

Figure 5.3 Examples of Plot Properties Editors 

As Figure 5.3 illustrates, the editors can look almost identical to each other.  
Therefore, it is necessary for you to understand what the editors do and how to 
access the correct editor for your purpose. 
 

5.2.1   Setting Defaults vs. Customizing Individual Plots 
Plot editors and tools fall into two categories in terms of function: either they 
allow you to specify defaults for all plots you create, or they allow you to 
customize individual plots.   

Across these two functional categories, the plot editors and tools either allow 
you to edit a variety of plot properties, or they can be specialized editors that 
allow you to edit a single property. 

To configure the default appearance of all plots, you need to use the Default 
Plot Properties Editor and Default Line Style Options Editor.  All settings 
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you specify in these editors will apply to all new plots you open.  You can 
access these editors only from the Edit menu of plots.   

To customize individual plots, you can use the Plot Properties Editor and the 
Configure Plot Editor, both accessed from the Edit menu of a plot window.  
Also, using right-click shortcut menus, you can access specialized editors for 
individual plot features.  The Viewport Properties Editor is an example of a 
specialized editor.  

Additionally, once you have customized an individual plot, you can export its 
settings as a Template that you can apply to other plots.  To create a template 
based upon a plot, you will use the Export Properties option in the File menu 
of the plot window. 

Likewise, you can import Templates to apply previously defined properties to 
an individual plot. To apply a template to a new plot, you will use the Import 
Properties option in the File menu of the new plot window. 
 

5.2.2   Accessing Editors  
You can access properties editors from shortcut menus (Figure 5.4) and from 
the Edit menu in the plot window (Figure 5.5).  

 
Figure 5.4 Shortcut Menu 

Figure 5.5 Edit Menu 

You will use these menus according to whether you are defining properties for 
an individual plot or setting default properties for all plots you create. 

Use shortcut menus to edit specific components of an individual plot.  For 
example, if you want to edit axis label properties on a plot, right-click on the 
axis label to access the shortcut menu for the label (Figure 5.4), then select the 
Edit Properties command for the label. 

Use the Edit menu of a plot window to access the Plot Properties Editor, 
Default Line Style Options Editor, Default Plot Properties Editor, and 
Configure Plot Editor.  These editors, discussed in Section 5.3, allow you to 
edit a variety of plot properties.   
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5.3 Recognizing Plot Editors and Tools 
Following is an overview of the editing tools that allow you to customize 
plots.  Later sections provide more detailed instructions on editing specific 
plot properties using these tools. 
 

5.3.1   Plot Properties Editor 
The Plot Properties Editor (Figure 5.6) is accessed from the Edit menu of a 
plot, and allows you to configure multiple display properties of an individual 
plot, including the Curves, Axis, the plot Title, Gridlines, border and 
background Patterns of the viewport, Marker Lines, Legend, and properties 
of the plot window panel.   

Figure 5.6 Plot Properties Editor 

When you customize properties of a plot using the Plot Properties Editor, your 
changes apply only to that individual plot unless you export the plot’s 
properties (see Section 5.12). 

To access the Plot Properties Editor, from the Edit menu, choose Plot 
Properties. 
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5.3.2   Individual Plot Property Editors 
When you want to edit a specific property of a plot without launching the Plot 
Properties Editor (discussed in Section 5.3.1), you can use individual plot 
property editors instead.  These individual plot property editors correspond to 
the tabs of the Plot Properties Editor.   

To access an individual plot property editor, right-click on the element you 
want to edit, then select Edit Properties from the shortcut menu. 

For example, if you right-click inside the gridded 
plot area, called the viewport, you will see the 
Viewport shortcut menu (Figure 5.7).  When you 
choose Edit Properties, the Viewport Properties 
Editor will open (Figure 5.8). 

The Viewport Properties Editor lets you edit only 
properties associated with the viewport, using the 
same Patterns and Gridlines tabs as appear in the Plot Properties Editor. 

 

 
Figure 5.8 Viewport Properties Editor 

Other individual properties editors are the Title Properties Editor, Axis 
Properties Editor, Curve Properties Editor, Label Properties Editor, 
Marker Properties Editor, Legend Properties Editor, and the Spacer 
Properties Editor.  

The only plot property you cannot edit using an individual property editor is 
the color of the plot window panel.  (See Section 5.10 for more information.) 

 
Figure 5.7 Viewport 
Shortcut Menu 
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5.3.3   Configure Plot Editor 
The Configure Plot Editor (Figure 5.9) is accessed from the Edit menu of a 
plot and allows you to customize the layout of an individual plot.  You can 
add and remove axes and add, remove, arrange the order of, and set the weight 
of viewports in the plot window. 

 
Figure 5.9 Configure Plot Editor 

 

When you customize the layout of a plot using the Configure Plot Editor, your 
changes apply only to that individual plot unless you export the plot’s 
properties (see Section 5.12). 

To access the Configure Plot Editor, from the Edit menu, click Configure 
Plot Layout.  
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5.3.4   Default Line Style Options Editor 
With the Default Line Style Options Editor (Figure 5.10), you can specify 
the default line and fill styles, as well as labels, used across all plots for 
specific parameters. 

   

Figure 5.10 Default Line Style Options Editor 

To access the Default Line Style Options Editor, from the Edit menu, choose 
Default Line Styles. 

Refer to Section 5.5.2   for more information on the Default Line Styles 
Options Editor. 



HEC-DSSVue User’s Manual Chapter 5 – Customizing Plots
 

9 

5.3.5    Default Plot Properties Editor 
The Default Plot Properties Editor (Figure 5.11) allows you to configure the 
default display properties of all plots you create.  Properties you can configure 
include the border and background of the Viewport, the Title, Grid lines, 
Labels, Axis, Marker Lines, Legend, and miscellaneous properties of the 
plot window panel. 

Figure 5.11 Default Plot Properties Editor 

When you customize plot properties using the Default Plot Properties Editor, 
your changes apply to all plots you create. 

To access the Default Plot Properties Editor, from the Edit menu, click 
Default Plot Properties. 



Chapter 5 – Customizing Plots HEC-DSSVue User’s Manual
 

10 

5.4 Customizing Plot Titles 
You can add titles to individual plots and configure default properties for all 
plot titles. 

To add or edit a title on an individual plot, you can either: 

 From the Edit menu, choose Plot Properties.  When the Plot Properties 
Editor opens, select the Title tab.   
Or 

 Right-click in the blank area above the 
plot (below the menu bar) with the 

Pointer Tool , and then select Edit 
Properties from the shortcut menu 
(Figure 5.12).  The Title Properties 
Editor will open. 

To specify the appearance of titles for all of your plots, from the Edit menu, 
click Default Plot Properties, then select the Title tab of the Default Plot 
Properties editor. 

Whether you are using the Plot Properties Editor, the specialized Title 
Properties Editor, or the Default Plot Properties Editor, the worksheet for 
editing plot title properties is the same.   

Figure 5.13 shows the Title Properties Editor.  This editor contains the same 
fields as the Title tab of the Plot Properties Editor and the Default Plot 
Properties Editor. 

 
Figure 5.13 Edit Title Properties 

 
 

Figure 5.12 Shortcut Menu--Title 
Properties 
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1. To specify a title for the plot, select Custom.  
2. In the Title panel, type the title you want in the Title box. 
3. From the Alignment list, select the alignment for the plot title.  Your 

choices are Center, Left, or Right. 
4. From the Size list, select the text size for the title.  The Sample box 

provides a preview of your plot title.    
5. The Border group allows you to add a border around the title.  You can 

specify the Color, line Style, and line Weight. 
6. The Background group lets you add a background Color and/or Pattern 

behind your plot title. 

Click Apply to save your changes and continue adjusting the appearance of 
the title.  Click OK when you are finished. 

 

5.5 Customizing Curves  
You can customize line and point styles, add labels, and specify symbols to 
indicate data quality in your plots.  Additionally, you can specify the 
parameter-based default curve styles used across all plots. 

There are three different ways to edit plot curves, depending on whether you 
wish to customize one or more curves in an individual plot or specify defaults 
for all plots. 
 

5.5.1   Customizing Curves in Individual Plots 
To customize all curves in an individual plot, from the Edit menu, choose 
Plot Properties.  When the Plot Properties Editor opens, select the Curves 
tab.   

To customize a specific curve 
in an individual plot, right-
click on the line or curve you 
wish to edit with the Pointer 

Tool , then select Edit 
Properties from the shortcut 
menu (Figure 5.14).  The Edit 
Curve Properties Editor will open. 
 

The Curves tab of the Plot Properties Editor and the Edit Curve Properties 
Editor are nearly identical with two exceptions:   

 First, at the top of the Curves tab of the Plot Properties Editor, there is a 
list of all curves contained in the plot.  In contrast, when you open the 
Edit Curve Properties Editor, it deals only with the curve you selected 
when you launched the editor; therefore, there is no list of curves. 

 
Figure 5.14 Shortcut Menu--Curve Properties 
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 Second, the Curves tab of the Plot Properties Editor has a Remove Line 
button, whereas the Edit Curve Properties Editor does not. 

Despite these differences, both the Edit Curve Properties Editor and the 
Curves tab of the Plot Properties Editor allow you to edit Style, Label, and 
Quality Symbols.  (You can edit Quality Symbols only if the plot has quality 
set for its data.)    

5.5.2   Specifying Parameter-Based Default Curve Styles 
To specify parameter-based default curve styles for all of your plots, from the 
Edit menu, click Default Line Styles.  The Default Line Styles Options 
Editor will open (Figure 5.10). 

The Default Line Styles Options Editor gives you a way to edit line styles 
from the Line Styles box (Figure 5.15).  You can specify the default, 
parameter-based curve styles used for all plots.   

Figure 5.15 Default Line Style Options Editor: Detail of Line Styles Box 

The Line Styles box displays typical data types with default line and fill styles 
predefined. 

You can edit all of these fields, change default line and fill styles for existing 
types, and add new data types to the list.  At this time, there is no delete 
option. 

Name and Parameter 
To edit an existing name or parameter, highlight it, and then enter the new 
name or parameter.  The name corresponds to the “C” part of HEC-DSS 
pathnames.  The parameter associates data sets to be plotted in the same 
viewport.  For example, FLOW-IN and FLOW-OUT are different “C” parts, 
but both are FLOW data sets and are to be plotted in the same viewport. 
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Type 
To change the data type associated with a Name and Parameter, click the 
down-arrow and select from the list. 

Line Number 
The Line Number column indicates the number of lines associated with a data 
type.  See Adding New Data Styles below. 

Line/Fill 
The Line/Fill property determines how curves associated with a particular 
name/parameter/type combination will appear in all plots.  To specify the 
Line/Fill, select the row, and then customize the Line and Point properties as 
discussed in Section 5.5.3.   

Adding New Data Styles 
To add a new data type: 

1. From the File menu of the Default Line Style Options Editor, choose 
New.  The New Data Type dialog box will open (Figure 5.16). 

2. Select a parameter from the 
Parameter list.  

3. Enter a name in the Name box. 
4. From the Type list, select the data 

type. 
5. In the Number of Lines box, 

enter the number of curves you 
want to add for this new data 
type. 

6. If you want to reverse the Y-axis, 
select Y Axis Reversed. 

7. Click OK to close the dialog box. 

The Line Styles box will now display the new data type you have added, 
repeated as many times as you specified in the Number of Lines box (reflected 
in the Line Number column).  You can customize the new data types as 
described above. 

To save your changes, from the File menu, click Save.  To close the Default 
Line Styles Options Editor, from the File menu, click Close.  

 
Figure 5.16 New Data Type Dialog Box 
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5.5.3   Specifying Line and Point Styles of Curves 
Figure 5.17 shows the curve Line and Point Style worksheet.  This worksheet 
is available from the Curves tabs of the Edit Curve Properties Editor, the 
Plot Properties Editor, and the Default Line Styles Options Editor (Section 
5.5.2).   

 
Figure 5.17 Curve Line and Point Style Editing Interface 

The Style tab has three main groups, Line, Point, and Missing Value 
Symbols which allow you to customize line and point styles, and a symbol 
that can be shown for missing values.  Beneath the Point group, the Sample 
box provides a preview of the way your line and point choices will look.    

To define line styles for curves: 

1. In the Line group, click Custom. 
2. Select the color, style, and weight you want for the line.   
3. You can display lines with fill above or below, or without fill.  Figure 5.18 

shows a plot with line fill below, whereas Figure 5.19 shows the same plot 
without line fill. 

4. Select if you want the curve drawn in a stair-stepped style, or linear with a 
line drawn directly between each point. 

5. Select if you want a line drawn to interpolate where there are missing 
values. 
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Figure 5.18 Plot with Line Fill 

 
Figure 5.19 Plot without Line Fill 

To define point styles for curves: 

1. In the Point group, click Custom. 
2. Choose the Style, Line Color, and Fill Color 

you want.  The Line Color is the “border” 
around the point symbol, whereas the Fill 
Color is the color inside the point symbol.  
Figure 5.20 shows an example of a dark line 
color and a light fill color. 

3. In the Size box, specify the size of the point 
(in pixels) either by selecting a size from the 
list or by typing in a number from 1-45. 

4. Automatic Symbol Drawing allows the plot 
to compute how to draw the points so they do not overlap. As you zoom in 
the plot will draw more points because you are increasing the distance 
between points. This will continue until all points on the curve are drawn.  

5. Draw Symbols on Data Points allows you to specify how to draw the 
points so they don’t overlap.  If you set the Skip box to one (1), then it 
will draw one point, skip the next, then draw the third, etc.  The Offset 
box allows you to say how many points on the curve to initially skip 
before drawing points. 

 

To define missing value symbols for curves: 

1. In the Missing Value Symbol group, click Custom. 
2. Choose the Style, Line Color, and Fill Color you want.  The Line Color 

is the “border” around the point symbol, whereas the Fill Color is the color 
inside the point symbol.  Figure 5.20 shows an example of a dark line 
color and a light fill color. 

3. In the Size box, specify the size of the point (in pixels) either by selecting 
a size from the list or by typing in a number from 1-45. 

4. This will place the selected symbol on each missing value. 
  

5.5.4   Customizing Curve Labels 
Figure 5.21 shows the curve Label worksheet, available from the Curves tabs 
of the Edit Curve Properties Editor, the Plot Properties Editor, and the 
Default Line Styles Options Editor (Section 5.5.2).  This worksheet allows 

 
Figure 5.20 Example Line 
and Fill Colors 
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you to customize curve labels. 
 

Figure 5.21 Curve Label Editing Interface 

To customize curve labels: 

1. Select Custom. 
2. Enter the text you want to appear in the curve label in the Label Text box. 
3. In the Alignment list, click Left, Center, or Right to select the alignment 

of the curve label. 
4. To set the position of the label, from the Position list, click Above, 

Center, or Below. 

The Sample box provides a preview of the way your labels will look.    
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5.5.5   Customizing Curve Quality Symbols 
Figure 5.22 shows the curve Quality Symbols worksheet, available from the 
Curves tabs of the Edit Curve Properties Editor, the Plot Properties 
Editor, and the Default Line Styles Options Editor (Section 5.5.2).  This 
worksheet allows you to customize curves for plots that have quality set for 
their data. 

 
Figure 5.22 Curve Quality Symbols Editing Interface 

To customize quality symbols: 

1. Choose Custom. 
2. Select a symbol Style, Line Color, Fill Color, and Size for each quality of 

data. 
 
 
 

5.6 Customizing Viewport Properties 
Viewports are the gridded areas in the plot window that contain plot curves.  
You can customize the border around the viewport, the background color and 
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pattern, and the appearance of gridlines. 
 

5.6.1   Customizing Viewport Borders and Background  
To customize the borders and backgrounds of viewports in an individual plot, 
you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Patterns tab.   
Or 

 Right-click in a blank area inside the 

viewport with the Pointer Tool , and 
then select Edit Properties from the shortcut 
menu (Figure 5.23).  When the Viewport 
Properties Editor opens, select the Patterns 
tab. 

To specify the default border and background of viewports for all of your 
plots, from the Edit menu, click Default Plot Properties.  When the Default 
Plot Properties Editor opens, choose the Viewport tab. 

Figure 5.24 shows the Edit Viewport Properties Editor with the Patterns 
tab selected.  This worksheet, accessed from the shortcut menu, contains the 
same items as the Patterns tab of the Plot Properties Editor and the 
Viewport tab of the Default Plot Properties Editor. 

 
Figure 5.24 Viewport Properties Editor--Patterns Tab 

The Patterns (or Viewport) tab has two main groups, Border and 
Background, which allow you to customize border and background of the 

 
Figure 5.23 Shortcut Menu--
Viewport Properties 
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viewport, respectively.  Beneath the Border group, the Sample box provides a 
preview of the way the viewport border and background will look.    

1. Select Custom in the Border group and choose the Color, Style, and 
Weight for the border you want to appear around the plot viewport. 

2. Select Custom in the Background group and choose the Color and 
Pattern you want for the background. 

Click Apply to save your changes and continue adjusting the appearance of 
the border and background.  Click OK when you are finished. 

 

5.6.2   Customizing Viewport Gridlines 
To customize gridlines of viewports in an individual plot, you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Gridlines tab.   
Or 

 Right-click in a blank area inside the viewport 

with the Pointer Tool , and then select 
Edit Properties from the shortcut menu 
(Figure 5.25).  When the Viewport Properties 
Editor opens, select the Gridlines tab. 

To specify viewport gridlines for all of your plots, 
from the Edit menu, select Default Plot 
Properties.  When the Default Plot Properties Editor opens, choose the 
Grids tab. 

Figure 5.26 shows the Viewport Properties Editor with the Gridlines tab 
selected.  This worksheet, accessed from the shortcut menu, contains the same 
items as the Gridlines tab of the Plot Properties Editor and the Grids tab of 
the Default Plot Properties Editor. 

By default, the plot viewport displays gridlines only for the Major X Grid 
and Major Y Grid.  The default color is light gray.  To change the 
appearance of Major X and Y gridlines, select Custom and make your 
selections for Color, Style, and Weight. 

By default, the Minor X Grid and Minor Y Grid are set to None and do not 
display in the plot viewport. If you want to display gridlines for the Minor X 
Grid and Minor Y Grid, select Custom and make your selections for Color, 
Style, and Weight. 

Click Apply to view your changes without closing the editor.  Click OK when 
you are finished. 

 

 
Figure 5.25 Shortcut 
Menu--Viewport 
Properties 
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Figure 5.26 Viewport Properties Editor--Gridlines Tab 

 

5.7 Adding and Customizing Marker Lines 
You can add marker lines on your plot’s X and Y axes and customize the 
appearance of these markers.   
 

5.7.1   Adding Markers 
To add a marker: 

1. Right-click on the location in the plot where you want the marker to 
appear. 

2. From the Viewport shortcut menu 
(Figure 5.27), point to Add 
Marker, and then click either On 
X-Axis or On Y-Axis. 

The marker will now appear in the plot. 

 
 

 
Figure 5.27 Shortcut Menu: Add 
Marker 
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5.7.2   Deleting Markers 
To delete a marker line in a plot, right click on it 

with the Pointer Tool , and then click Delete 
from the Marker Line shortcut menu (Figure 
5.28). 

 
 

5.7.3   Customizing Markers 
To edit the properties of a marker in an individual plot, you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Marker tab.  This worksheet is available only if a 
marker exists in the plot.  Choose the marker you want to edit from the 
Marker Lines list. 
Or 

 With the Pointer Tool , right-click on the marker you want to edit.  
From the Marker Line shortcut menu, select Edit Properties (Figure 
5.28).  The Edit Marker Line Properties Editor will open. 

To specify the default appearance of markers for all of your plots, from the 
Edit menu, click Default Plot Properties.  When the Default Plot 
Properties Editor opens, choose the Marker Lines tab. 

The interfaces for the specialized Edit Marker Line Editor and the Default 
Plot Properties Editor are very similar.  However, the Plot Properties 
Editor interface differs in two ways.  First, the Marker worksheet is available 
only if a marker exists in the current plot.  Second, at the top of the editing 
panel there is a Marker Lines list containing all markers that exist in the 
current plot.   

You can edit the line style and label of a marker using two editing tabs.  
Figure 5.29 shows the Edit Marker Line Properties Editor with the Style 
worksheet selected, while Figure 5.30 shows the Label/Value worksheet.  
The Marker Line tabs in the Plot Properties Editor and the Default Plot 
Properties Editor share the same two worksheets. 
 

Figure 5.28 Shortcut 
Menu—Marker Line 
Properties 
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Figure 5.29 Marker Line Properties 
Editor—Style Tab 

 
Figure 5.30 Marker Line Properties 
Editor—Label/Value Tab 

To edit the line style for markers: 

1. Select the Style tab. 
2. Choose Custom. 
3. Select the Color, Style, and Weight for the marker line. 
4. You can display marker lines with fill 

Above or Below, or without fill.  Figure 
5.31 shows a plot with line Fill Above and 
a hatched pattern selected. 

The Sample box provides a preview of the 
way the marker line will look.    

Click Apply to save your changes without 
closing the editor.   

To add a label to a marker line: 

1. Select the Label/Value tab. 
2. Choose Custom. 
3. In the Label Text box, enter the text you want to appear in the label. 
4. From the Alignment list, select the justification of the label--Left, Center, 

or Right. 
5. To set the position of the label, from the Position list, select either Above, 

Center, or Below. 

 
Figure 5.31 Marker Line with 
Fill Above 
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6.  For the Date value, enter the date in the 
format DDMMYYYY (e.g., 21Dec1993).  
You can also click the  button to access the 
Calendar Tool (Figure 5.32) to select the 
date. 

7. For the Time value, enter the time in 24-hour 
military format (e.g., for 5:08 pm, enter 
“1708”). 

The Sample box provides a preview of the way 
the marker line will look.    

Click Apply to save and view your changes 
without closing the editor.  Click OK when you 
are finished editing marker line properties. 
 

5.7.4   Editing Callouts 
You can add descriptive callouts at specific points 
along a curve (Figure 5.33).  To do this: 

1. Right-click on the location on the curve where 
you want the callout to appear.  

2. From the shortcut menu (Figure 5.34), point to 
Add Callout. 

3. In the Add Callout dialog 
box (Figure 5.35), enter the 
text you want to appear in 
the callout, and then click 
OK. 

To hide all callouts in a plot, 
right-click on a curve in the plot.  
From the shortcut menu, click 
Hide Callouts. 

Once you have hidden 
callouts, Hide Callouts in 
the shortcut menu changes to 
Show Callouts, allowing 
you to return callouts to the 
plot display. 

To permanently remove all 
callouts from the plot, right-
click on a curve in the plot to access the shortcut menu, then click Clear 
Callouts. 
 

 
Figure 5.32 Calendar Tool 

 
Figure 5.33 Callout 

 
Figure 5.34 Shortcut Menu: Add Callout 

Figure 5.35  Add Callout Dialog Box 
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5.8 Customizing Axes 
You can choose either a linear or log axis type, specify the axis scale, modify 
tic marks, and customize axis labels.  Probability plots are generated for 
paired data sets with a type of “PROB”, and cannot be changed without 
changing the data type. 

5.8.1   Changing Axis Type 
By default, plots display using a linear scale (Linear Axis), in which the axis 
increases and decreases by x.  You can also use the log scale, which allows 
you to view curves that grow exponentially in a near straight line because 
the axis increases or decreases by the log (x).  For example, you might wish to 
use the log scale when the axis has evenly-spaced major tics with values of 
1,10,100,1000, and so on, such as in a performance history plot showing many 
years of data. 

To change the axis type of an individual 
plot, right-click on an axis.  From the 
Axis Tics shortcut menu, point to Set 
Axis Type, and then select the axis type 
from the submenu (Figure 5.36).  
Depending on the axis type, you can 
click either Log Axis or Linear Axis. 

 

5.8.2   Specifying Axis Scale 
You can specify the axis scale and tic interval for individual plots.  To do this, 
you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Axis tab.  From the Axis worksheet, select the 
axis you want to edit from the Axis list.  Once you have this set, click the 
Scale tab to access the Scale worksheet. 
Or 

 Right-click on the axis with the Pointer Tool 

.  From the Axis Tics shortcut menu 
(Figure 5.37), click Edit Properties.  When 
the Edit Axis Properties Editor opens, choose 
the Scale tab. 

Figure 5.38 shows the Plot Properties Editor with the Axis tab selected and 
the Scale worksheet open.  The Axis worksheets of the Plot Properties 
Editor and the Default Plot Properties Editor are nearly identical, except for 
the Axis list on the Plot Properties Editor.  The Scale and Tics sub-
worksheets are available in all three editors.  

 
Figure 5.36 Shortcut Menu - Set Axis 
Type 

 
Figure 5.37 Shortcut 
Menu—Axis Tics  
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Figure 5.38 Plot Properties Editor--Scale Worksheet 

With the Scale worksheet, you can specify the range of the scale, the amount 
of the scale that is visible, and the tic intervals.   

If the Auto box is checked, the plot will automatically select the scale.  
Otherwise, as you zoom in and out of the plot, its view values change while 
the minimum and maximum scale range values remain fixed: 

 Maximum: enter the value of the maximum range of the scale. 
 Minimum: enter the value of the minimum range of the scale. 
 View Maximum: enter the maximum visible range of the scale.  
 View Minimum: enter the minimum visible range of the scale.   

Tic intervals are the distances between tics on the axis scale:   

 Major Tic Interval:  specify the distance between each major tic. 
 Minor Tic Interval:  specify a value less than or equal to the major tic 

value. 

You can also choose to reverse the axis and invert the data by selecting 
Reverse (Invert) Axis.  If the data set is paired, you can switch the X and Y 
axis, so what is plotted on the X axis becomes plotted on the Y axis instead. 

Click Apply to save and view your changes without closing the editor.   

Click OK to save your changes and close the editor. 
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5.8.3   Modifying Tic Marks 
You can modify the color of tic marks, choose whether or not major and 
minor tic marks display, and specify whether labels display.  (See also 
“Specifying Axis Scale” in Section 5.8.2 for information about modifying tic 
intervals.) 

To modify tic marks in an individual plot, you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Axis tab.   From the Axis worksheet, select the 
axis you want to edit from the Axis list.  Once you have this set, choose 
the Tics tab to set tic marks. 
Or 

 Right-click on the axis with the Pointer Tool .  From the Axis Tics 
shortcut menu (Figure 5.37), click Edit Properties.  When the Edit Axis 
Properties Editor opens, choose the Tics tab. 

To specify default settings for axis tics in all of your plots, click Default Plot 
Properties from the plot Edit menu.  When the Default Plot Properties 
Editor opens, choose the Axis tab, then the Tics tab. 

Figure 5.39 shows the Tics worksheet of the Edit Axis Properties Editor.  
The Tics worksheet is nearly identical on the Edit Axis Properties Editor, 
Plot Properties Editor, and Default Plot Properties Editor.  However, at 
the top of the Plot Properties Editor is an Axis list containing all of the axes 
available for editing in the current plot.  In the Plot Properties Editor, you 
must choose an axis to edit before you can make any changes. 

By default, plot axes display major tic 
marks with labels.  To turn off these 
options, click to clear the Use major 
tick marks and Use tick mark labels 
check boxes. 

You can also select Use minor tic 
marks.  

To change tic color, select the color 
you want from the Tic Color list. 

Click Apply to save and view changes 
without closing the editor. 

Click OK to save your changes and 
close the editor.  

 
 

 
Figure 5.39 Axis Properties Editor--Tics 
Tab 
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5.8.4   Customizing Axis Labels 
You can add borders and backgrounds to axis labels. 

To customize axis labels in an individual plot, you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Axis tab.  On the Axis worksheet, select the axis 
you want to edit from the Axis list.  Once you have this set, select the 
Label tab to set axis label properties.   
Or 

 Right-click on the axis label with the Pointer 

Tool .  From the G2d Label shortcut 
menu (Figure 5.40), click Edit Properties.  
The Edit Label Properties Editor will open. 

To specify default settings for axis labels in all of 
your plots, select Default Plot Properties from the 
plot Edit menu.  When the Default Plot 
Properties Editor opens, choose the Axis tab, then the Label tab. 

Figure 5.41 shows the Edit Label Properties Editor.  The same worksheet is 
available on the Label tabs of the Plot Properties Editor and Default Plot 
Properties Editor, with one difference.  The Plot Properties Editor has an 
Axis list containing all of the axes available for editing in the current plot.   

Figure 5.41 Label Properties Editor 

The Label worksheet has two groups, Border and Background, which allow 
you to customize border and background of the label, respectively.  Beneath 
the Border group, the Sample box provides a preview of the label.   

To add a border around the axis label, choose Custom in the Border group, 
and then select the Color, Style, and Weight for the borderline. 

 
Figure 5.40 G2d Label 
Shortcut Menu 
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To add a background to the axis label, choose Custom in the Background 
group, and then select a Color and Pattern.  

Click Apply to save and view your changes without closing the editor.  Click 
OK when you are finished editing axis label properties. 
 

 

5.9 Customizing Legends 
As Figure 5.42 illustrates, you can add titles to the top of plot legends and add 
text and graphics to the right and left sides.  You can also specify whether the 
legend appears below or to the right of the plot (refer to Section 5.10.2  ). 

Figure 5.42 Customizing Legends 

To add legend labels to an individual plot, you can either: 

 From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Legend tab.   
Or 

 Right-click in a blank area inside the legend 

panel of the plot with the Pointer Tool .   
From the Legend Panel shortcut menu 
(Figure 5.43), click Edit Properties. The Edit 
Legend Properties Editor will open. 

To specify default settings for all of your plot legends, from the Edit menu, 
click Default Plot Properties.  When the Default Plot Properties Editor 
opens, choose the Legend tab. 

Whether you are using the Plot Properties Editor, Edit Legend Properties 
Editor, or Default Plot Properties Editor, the worksheet for editing legend 
titles is the same.   

Figure 5.44 shows the Legend Properties Editor.  This worksheet, accessed 
from the shortcut menu, contains the same fields as the Legend worksheets of 
both the Plot Properties Editor and the Default Plot Properties Editor. 

Figure 5.43 Shortcut Menu 
- Legend Panel  
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Figure 5.44 Legend Properties Editor 

1. In the Legend Title box, enter the title you want to appear along the top of 
the legend box. 

2. In the Left Block Area and Right Block Area groups, you can specify the 
Icon and Text you want to appear on either side of the legend block. 
 If you wish to display icons, type the exact paths and filenames of the 

icon in the Icon field.  (The path is the location on your computer.) 
 Enter any text you want to display in the Text boxes. 

3. Click Apply to view your changes without closing the editor.  Click OK 
to save your changes and close the editor. 
 

 
5.10 Customizing Window Panels 

You can customize the color and spacing of the window “panel” in which 
plots are displayed; you can also choose whether the plot legend displays 
horizontally along the bottom of the plot panel or vertically along the right 
side.   

To customize panel properties of an individual plot, from the Edit menu, click 
Plot Properties.  When the Plot Properties Editor opens, select the Misc. 
tab.   

To specify panel properties for all of your plots, from the Edit menu, click 
Default Plot Properties.  When the Default Plot Properties Editor opens, 
choose the Misc. tab. 

Whether you are using the Plot Properties Editor or the Default Plot 
Properties Editor, the Misc. worksheet is the same.  Figure 5.45 shows the 
Misc. worksheet of the Default Plot Properties Editor. 
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Figure 5.45 Default Plot Properties Editor--Misc. Tab 

You can also edit the legend layout and spacer size from individual property 
editors accessed from shortcut menus, as discussed below. 
 

5.10.1   Customizing the Panel Background Color 
To customize the panel background color, click the down arrow beside the 
Panel Background Color field to select the color you want.   There is no 
individual property editor available for customizing the panel background 
color.  
 

5.10.2   Customizing the Legend Layout 
If you want the plot legend to display horizontally along the bottom of the plot 
panel, in the Legend Layout group, select Horizontal.   If you want the plot 
legend to display vertically along the right side of the plot panel, select 
Vertical.   

Another way to adjust the position of the legend for an individual plot is to 
use the Legend Panel shortcut menu (Figure 5.46).   

To access the Legend Panel shortcut menu, 
with the pointer tool right-click on a blank 
area inside of the legend panel in the plot 
window panel.  If the legend is currently 
positioned horizontally, you can click Move 
To Right, which will cause the legend to 
display vertically.  If the legend is currently 
positioned vertically, you can click Move to Bottom, which will cause the 
legend to display horizontally. 

 

 
Figure 5.46 Legend Panel 
Shortcut Menu 
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5.10.3   Customizing the Horizontal Spacer Size 
In the Plot Properties Editor and Default Plot Properties Editor, horizontal 
spacer size refers to the space between viewports in plots with multiple 
viewports.  In single-viewport plots, it is the “margin” space between the right 
side of the viewport and the edge of the window panel.   

To specify the horizontal spacer size using the Misc. tab of the Plot 
Properties Editor or Default Plot Properties Editor, in the Horizontal 
Spacer Size group, select Custom, then either select the pixel size from the 
list or enter a value less than 50. 

You can also use the Spacer shortcut menu (Figure 
5.47) to customize both horizontal and vertical 
spacer size for an individual plot.   

To access the Spacer shortcut menu, right-click on 
a blank space on the plot panel.  Click between 
viewports if you want to adjust vertical spacing 
between viewports, or to the right of a viewport to adjust horizontal spacing.   

From the Spacer shortcut 
menu, click Edit Properties.  
The Edit Spacer Properties 
dialog box will open (Figure 
5.48).   

To specify the spacer size, 
enter a value less than 50. 

 

 

5.11 Customizing Plot Layout  
The Configure Plot Editor (Figure 5.49) displays plot components in a “tree” 
structure and allows you to customize the layout of an individual plot.  You 
can add and remove axes as well as add, remove, arrange the order of, and set 
the weight of viewports in the plot window panel. 

Figure 5.47 Spacer 
Shortcut Menu 

 
Figure 5.48 Edit Spacer Properties Dialog Box 
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Figure 5.49 Configure Plot Editor 

When you customize the layout of a plot using the Configure Plot Editor, 
your changes apply only to that individual plot unless you export the plot’s 
properties (see Section 5.12). 

To access the Configure Plot Editor, from the Edit menu, select Configure 
Plot Layout. 
 

5.11.1   Adding and Removing Viewports 
To add a new viewport to a plot, from the Configure Plot Editor’s Edit menu 
click Add Viewport.  The new viewport will appear at the bottom of the 
“tree” in the Selected Data Sets box. 

To remove a viewport, you can either: 

 Click on the name of the viewport 
in the Selected Data Sets “tree.” 
From the Edit menu, click 
Remove Viewport. 
Or 

 Right-click on the viewport’s 
name in the Selected Data Sets 
“tree.” From the shortcut menu 
(Figure 5.50), click Remove. 

 
Figure 5.50 Shortcut Menu--Remove 

Viewport 
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5.11.2   Setting Viewport Weights 
You can customize the relative sizes of viewports in your plots.  To do this: 

1. From the Edit menu of the 
Configure Plot Layout Editor, 
click Set Viewport Weights.  
The Set Plot Viewport Weights 
dialog box will open. 

2. In the Set Plot Viewport 
Weights dialog box (Figure 5.51), 
you can specify the relative size 
of each viewport as a percentage 
value, with all of the weights 
adding up to 100%. Figure 5.51 
shows four viewports of equal weight at 25% each. 

Note that the Set Plot Viewport Weights dialog box offers the same right-
click shortcut menu commands as are available in all tables.  You can cut, 
copy, and paste data cells; insert, append, and delete rows; and print and 
export.  For more information, refer to the section on tabular data in the 
Utilities chapter. 

Click Apply to save and view your changes without closing the dialog box.  
Click OK to save your changes and close the dialog box. 
 

5.11.3   Adding and Removing Axes 
By default, viewports have a left Y-axis.  You can also add a right Y-axis, 
remove both the left and right Y-axes, and add a new left Y-axis if you have 
previously removed it.  Viewports can have a maximum of two axes, and you 
cannot remove an axis when a data set is associated with it. 

To add an axis to a viewport, you can either: 

 Click on the viewport’s name in the tree in the Selected Data Sets box.  
From the Edit menu, choose Add Axis. 
Or 

 Right-click on the 
viewport’s name in the 
tree in the Selected 
Data Sets.  From the 
shortcut menu (Figure 
5.52), click Add Axis. 

The tree now displays 
another axis for the viewport you selected.   

 

 
Figure 5.51 Set Plot Viewport Weights 
Dialog Box 

 
Figure 5.52 Shortcut Menu - Add 

Axis 
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To remove an axis that has no data associated with it, you can either: 

 Click on the name of the axis you wish to remove in the tree in the 
Selected Data Sets box.  From the Edit menu, click Remove Axis. 
Or 

 Right-click on the axis you wish to remove in the tree in the Selected Data 
Sets box.  From the shortcut menu, click Remove.   

The selected axis will no longer display in the tree. 
 

5.11.4   Arranging Viewports and Axes 
You can rearrange the vertical order of viewports in a plot window and move 
axes (with their associated data sets) to different viewports.   

To move a viewport or axis, 

1. From the tree in the Selected Data Sets box, right-click on the name of a 
viewport or axis you want to move.   

2. From the shortcut menu, click Move Up or Move Down from the shortcut 
menu.   

3. Either click OK or Apply for the change to take effect in the plot window. 

Note that you cannot move individual data sets in the Configure Plot Layout 
Editor.  You can move only the axis with which a data set is associated. 

 

5.11.5   Reversing Axes (Invert Data) 
To reverse the direction of an axis so that the data is inverted, right-click on 
the name of the axis in the tree.  From the shortcut menu, click Reverse.  
Either click OK or Apply for the change to appear in the plot window.   
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5.12 Exporting and Importing Templates 
After you have customized a plot, you can save its settings as a template for 
use in other plots. 

Generally, you will use templates when scripting plots.  For example, every 
day you generate a plot of flow, stage, and precipitation via a script, and then 
apply a template that has all of the correct formatting, such as viewport 
placement, size, line colors, and fills.   For more information about using 
templates with scripts, refer to the chapter on Scripting.   

To create a template from a plot: 

1. From the File menu, click Export 
Properties.  

2. From the Export Plot Template 
dialog box (Figure 5.53), specify 
whether you want the template to 
be available for All Applications 
or This Watershed only, and then 
give the template a Name. 

3. Click OK to save the template and 
close the dialog box. 

To apply (import) a template you have 
created to another plot currently open: 

1. From the File menu, click Import 
Properties. 

2. In the Import Plot 
Template dialog box 
(Figure 5.54), specify 
whether you want to use a 
template available for All 
Applications or for This 
Watershed only. 

3. A list of available 
templates will display.  
Choose the template you 
want by clicking on its 
name.   

4. When you select a 
template, its name will 
display in the Name field. 

5. Click OK to apply the 
template to the current 
plot and close the dialog 
box. 

 
Figure 5.53 Export Plot Template 
Dialog Box 

 
Figure 5.54 Import Plot Template Dialog Box 
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5.13 Additional Viewing Options for Plots 
The File menu of plots (Figure 5.55) contains 
several commands that allow you to view plot 
data in tabular form, save plots, and copy and 
paste plots into other applications such as 
Microsoft Word, Excel, and Visio. 

 
 
 
 
 
 
 
 
 

5.13.1   Viewing Data in Tabular Form 
To view plot data in tabular form, from the File menu, click Tabulate.  A 
dialog box will open displaying the data in tabular form (Figure 5.56). 

 
Figure 5.56 Data in Tabular Form 

For more information about tables, refer to the chapter on Utilities. 

Figure 5.55 File Menu 
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5.13.2   Saving Plots  
You can save a plot as an image (JPEG), a Windows Metafile (*.wmf), as 
Portable Network Graphics (*.png), or other formats.   

To do this, from the File menu, click Save As.  From the Save dialog box 
(Figure 5.57), select the location where you want to save the plot, enter a 
filename in the File name box, and select the file type you want from the 
Files of type list, then click Save.  

Figure 5.57 Save Dialog Box 

 

5.13.3   Copying Plots to the Clipboard  
Use Copy to Clipboard from the File menu to copy a plot to the clipboard.  
You can then paste the plot as an image into another application such as 
Microsoft Word, Excel, or Visio.    
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5.14 Printing Plots 
The Print command, available from the File menu of plots, opens a standard, 
Windows-style print dialog box. 

From the File menu, click Page 
Setup.  The Page Setup dialog box 
will open (Figure 5.58).  Here you 
can set the page Orientation, Page 
Margins, Page Numbers, and 
Printer Scale.   

Set Margins opens the Printer 
Margins dialog box (Figure 5.59).  
 

 
Figure 5.59 Printer Margins Dialog Box 

 

To view the plot as it will 
be printed, from the File 
menu, click Print Preview.    
Figure 5.60 shows an 
example. 

Finally, the Print Multiple 
command allows you to 
print several plots on one 
page.   The Print Multiple 
dialog box (Figure 5.61) 
shows all of the currently 
open plots in the Available 
Plots box.  To select plots 
for printing, double-click 
on the plots in the 
Available Plots box and 
the selected plots will move 
to the Selected Plots box. 

 
Figure 5.58 Page Setup Dialog Box 

 
Figure 5.60 Example Print Preview of a Plot 
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Next, use the slider bars to specify the number of plots you wish to appear 
horizontally and vertically on the page.  The grid to the right of the sliders 
reflects your choices.  

 
Figure 5.61 Print Multiple Dialog Box 

Figure 5.62 shows a preview of the plots set up above.  From the Print 
Multiple dialog box, you can also use the Page Setup and Print Preview 
commands.  The two commands are available from the File menu of the Print 
Multiple dialog box. 

 

 
Figure 5.62 Print Multiple Preview Dialog Box (Example) 
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