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Chapter 3 
3 Using HEC-DSSVue: An Overview 

With HEC-DSSVue you can access, visualize, and manipulate data stored in 
HEC-DSS database files using a variety of utilities and functions available 
from the main HEC-DSSVue screen, shown in Figure 3.1.   

Figure 3.1 HEC-DSSVue Main Window 

 

This chapter provides an overview of HEC-DSSVue and its basic operations 
using the main menu and selection buttons.  

  

3.1 HEC-DSSVue Main Screen 
The main screen of HEC-DSSVue consists of a Menu Bar, Tool Bar, File Name 
box, Search boxes, a list of HEC-DSS Pathnames, a list of Selected Pathnames, 
and Selection Buttons.  The following sections describe these features in detail. 
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3.1.1 Menu Bar  
 Main menu options in HEC-
DSSVue (Figure 3.2) allow you to 
search for, select, and edit HEC-
DSS data sets; control the display 
of pathnames; and access plots and 
tables, among other tasks.  The HEC-DSSVue menus are as follows: 

File File menu commands are New, Open, and Exit.  The file menu also 
lists your most recently used files. 

Edit Edit menu commands are Undo, Cut, Copy, Paste, Delete, Edit 
Data, and Select All.   

View The View menu allows you to customize the display of HEC-DSS 
pathnames and search pathnames.  Available commands are 
Pathname List, Pathname Parts, Condensed Catalog, No 
Pathnames, Refresh Catalog, Search pathnames by string, and 
Search pathnames by parts. 

Display Use the Display menu to open plots and tables with the Plot and 
Tabulate commands.   

Utilities Utilities menu provides access to Math Functions, Manual Data 
Entry (Time Series and Paired Data), and it allows you to Rename 
Records, Copy Records, Duplicate Records, Merge Files, 
Squeeze, access the Script Button Frame with the Script Browser 
command, access the Script Selector, and view HEC-DSS Status. 
 
 

3.1.2 Tool Bar 
Tool bar buttons provide shortcuts to frequently used menu commands: 

 Opens a File Browser, which allows you to select a HEC-DSS file 
(same as Open in the File menu). 

 Plots the selected data (same as Plot in the Display menu) 

 Displays the selected data in table (same as Tabulate in the Display 
menu). 

Figure 3.2 HEC-DSSVue Menu 
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3.1.3 File Name 
The File Name box (Figure 3.3) displays the file name and location of the 
currently open HEC-DSS file.  Also, if you know the exact location and name 
of the HEC-DSS database file you wish to open, you can type it directly into 
the File Name box to open it. 

Figure 3.3 File Name Box 

Beneath the file name are the number of pathnames in the list, the number 
selected, the total number in the database file, and the size of the database file. 

 

3.1.4 Search Boxes  
The Data Selection List also provides a search area where you can Search 
Pathnames (Figure 3.4) or Search Parts (Figure 3.5) of an open HEC-DSS 
file.  The search method desired is set from the View menu.    

To search and display all pathnames containing a specific string, type that 
string into the box and press the Search button.  Those pathnames in the file 
that contain that string will be displayed in the list. 

The Search by Parts option provides a selectable drop down list of the parts 
of all the pathnames in the file.  When a part is selected, only those pathnames 
that match that part are shown. 

 
Figure 3.4 Search Pathnames option 

Figure 3.5 Search by Parts option 

 

3.1.5 List of HEC-DSS Pathnames 
Once you have opened an HEC-DSS file, its pathnames appear in a list 
beneath the search area, either as a Pathname List, or by Pathname Parts, in 
Condensed Catalog format, or with No Pathnames displayed.  (The No 
Pathnames option is typically used to access very large databases using only 
scripted functions.)  These options are set from the View menu, as described 
in Section 3.4.1.  Figure 3.6 shows the pathname parts displayed. 
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Figure 3.6 List of HEC-DSS Pathnames by Parts 

 

3.1.6 Selected Pathnames 
When you select a pathname (see Section 3.5), it appears beneath the list of all 
pathnames in the selection area (Figure 3.7).  You can make the size of 
selected list taller or shorter by grabbing the separator line between the two 
lists with the mouse, and moving it up or down. 

Figure 3.7 Selected Pathnames 

 

3.1.7 Selection Buttons 
There are five buttons at the bottom of the Data Selection List window (Figure 
3.8).   

 

Figure 3.8 Select, De-Select, Clear Selections, Restore Selections, and Set Time Window 
Buttons 

� Select: You add a pathname to the selection list by highlighting it and 
clicking the Select button.  Until you highlight a pathname, the Select 
button remains inactive.  You can also do a “quick select,” if the selection 
list is empty, by highlighting a pathname, then pressing the plot or tabulate 
button. 

� De-Select:  To remove a pathname from the selection list, you highlight 
the pathname in the lower list then press the De-Select button. 

� Clear Selections: You can remove all pathnames from the selection list 
by clicking the Clear Selections button. 

� Restore Selections: The Restore Selections button restores all selections 
you have cleared or de-selected. 

� Set Time Window: You can set the time window of the data to view with 
the Set Time Window button. 
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3.2 File Menu Operations 
HEC-DSSVue’s File menu allows you to Open an existing HEC-DSS file, 
create a New HEC-DSS file, open a recently opened file, and Exit the 
program.  The following sections discuss these operations. 

3.2.1 Opening a HEC-DSS File 
If you know the name of the HEC-DSS database file you wish to open, you 
can type the file name (including the path) directly into the File Name box 
(Figure 3.3).  Otherwise, choose Open from the File menu or click the  
button to select the HEC-DSS database file you want.   

A File Browser window will open, as shown in Figure 3.9.   

In the File Browser 
window, use the 
standard Windows 
controls to browse to 
the HEC-DSS file 
that you wish to open, 
then click Open.  

The name of the file 
you have selected will 
now appear in the 
File Name box 
(Figure 3.3), and the 
pathnames of the 
records contained in the file will display in the List of HEC-DSS Pathnames. 

 

3.2.2 Creating a New HEC-DSS File 
To create a new HEC-DSS database file, from the File menu, click New.  
When the File dialog box opens, type in a name for the new file and HEC-
DSSVue will create it for you.  Data can then be entered through the Manual 
Data Entry window from the Utilities menu.  If you copy records from an 
existing file, the new DSS file does not need to exist; it will be created 
automatically. 

 

3.2.3 Exiting HEC-DSSVue 
To exit HEC-DSSVue, from the File menu, click Exit.  (If you have opened 
HEC-DSSVue from another application, such as CWMS or ResSim, select 
Close from HEC-DSSVue’s File menu.) 

 
Figure 3.9 Open HEC-DSS File 
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3.3 Edit Menu Operations 
Edit menu commands are Undo, Cut, Copy, Paste, Delete, Edit Data, and 
Select All.   

 

3.3.1 Cutting or Copying and Pasting Records into 
Another File 

You can cut or copy one or more records from a HEC-DSS File and paste 
it/them into another HEC-DSS file.  To do this: 

1. Click on an individual pathname in the List of HEC-DSS Pathnames to 
select it, or click and drag your mouse to select a series of pathnames.  
You can also use Ctrl+click to select multiple, non-consecutive 
pathnames.  

2. From the Edit menu, click Cut or Copy.  A Cut will delete the data, 
whereas a Copy will not.  If 
you use Cut, a confirmation 
message will appear that the 
record has been deleted 
(Figure 3.10).  (If you did not 
intend to delete the record, 
use Undo from the Edit 
menu.) 

3. From the Edit menu, click Paste.  The Paste Records into HEC-DSS 
File dialog box will appear (Figure 3.11). 

4. Either choose an 
existing HEC-
DSS file or, if you 
wish to create a 
new file, type a 
name for the new 
file and click 
Open. 

5. A confirmation 
message will 
appear. 

 

3.3.2 Deleting Records 
To delete a record from a HEC-DSS file: 

1. Click on an individual pathname in the List of HEC-DSS Pathnames to 
select it, or click and drag your mouse to select a series of pathnames.  

Figure 3.10 Confirmation of Deletion 

Figure 3.11 Paste Records into HEC-DSS File dialog 
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You can also use Ctrl+click to select multiple, non-consecutive 
pathnames.  

2. From the Edit menu, click Delete.  A confirmation message will verify the 
deletion. 

3.  

3.3.3 Undoing Deletions 
From the Edit menu, click Undo to “undo” the most recent deletion in your 
session.   

 

3.3.4 Editing HEC-DSS Data 
To access tabular data for editing, from the Edit menu, click Edit Data.   

Chapter 4 on Utilities discusses tabular editing in detail. 

 

3.3.5 Selecting All Pathnames in a HEC-DSS File 
From the View menu, you can select all pathnames in a HEC-DSS file for 
visualization by clicking Select All .  Refer to Section 3.5 for more 
information about selecting pathnames for visualization. 
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3.4 View Menu Operations 
The View menu allows you to customize the display of HEC-DSS pathnames 
and search pathnames.  The following sections describe these options. 

 

3.4.1 Choosing a Display Mode for HEC-DSS Pathnames 
To specify the display mode for HEC-DSS Pathnames, from the View menu, 
choose Pathname List, Pathname Parts, Condensed Catalog, or No 
Pathnames.  Figure 3.13 shows a Pathname List of HEC-DSS files displayed.  

 
Figure 3.12 HEC-DSSVue – Data Selection List window, pathname list 
displayed 

You can also view the pathnames the Pathname Parts List (Figure 3.12). 

Figure 3.13 HEC-DSSVue – Data Selection List window, pathname parts 
displayed 

The Condensed Catalog style (Figure 3.14) abridges time series data sets so 
that the date span for the entire data set displays in place of the “D” part.    

 
Figure 3.14 HEC-DSSVue – Data Selection List window, condensed catalog 
displayed 
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3.4.2 Refreshing the Catalog 
The catalog automatically refreshes whenever you add or delete records.  
When the catalog is refreshed, it re-inventories all records on disk to get a 
pathname for every record.  To refresh the catalog manually, from the Edit 
menu, click Refresh Catalog.  

 

3.4.3 Searching and Filtering HEC-DSS Pathnames 
With HEC-DSSVue, you can select specific data sets from a list of pathnames 
(or catalog) in the database.  You can refine the list by searching for either a 
string in the pathnames or for pathname parts.   

The following sections describe searching and filtering options. 

 

3.4.4 Searching Pathname Strings 
The Search Pathnames by String feature allows you to search for records 
whose pathnames contain specific strings of characters. For example, if you 
search for “FLOW” the list will display only pathnames containing the string 
“FLOW” in the pathname. 

To Search Pathnames by String: 

1. From the View menu, choose Search Pathnames by string. 
2.  In the Search Pathname box (Figure 3.4), type the character string you 

want to filter the pathnames.   
3. Click the Search button. 
4.  

3.4.5 Filtering HEC-DSS Pathnames by Parts 
The Search by Parts feature lets you choose specific pathname parts from 
those available in a HEC-DSS file.  

To Search by Parts: 

1. From the View menu, click Search pathnames 
by parts. 

2. Click on the down arrows beside the pathname 
parts you want to search.  This allows you to view 
lists of available names in the file (Figure 3.15).  

3. When you have a pathname part list open, you 
can scroll through the list to locate the pathname 
part you want.   

4. Click on a pathname part to select it. 
5. To return to the previous list, click on the blank field at the top of the list. 

Figure 3.15 Selecting 
Pathname Parts 



Chapter 3 — Using HEC-DSSVue: An Overview HEC-DSSVue User’s Manual
 

3-10 

3.5 Selecting Pathnames 
Once you have filtered a HEC-DSS file for the pathnames you want, you 
select specific pathnames to visualize data for or perform a utility function on.  

There are several ways to select pathnames: 

� Double-click on an individual pathname in the HEC-DSS Pathname List.   

� Highlight a pathname in the HEC-DSS Pathname List then click the Select 
button (Figure 3.1).  Until you select a pathname, the Select button 
remains inactive.   

� Click and drag your mouse to select a series of pathnames, and then click 
the Select button.  You can also use Ctrl+click to select multiple, non-
consecutive pathnames. 

� If you wish to select all of the pathnames, from the Edit menu, choose 
Select All. 

When you select a Pathname, it will appear in the Selected Pathnames List 
(Figure 3.7).  

 

3.5.1 De-Selecting Pathnames 
To de-select a pathname currently in the Selected Pathnames List: 

1. Click the record’s pathname in the Selected Pathnames List to select it. 
2. Click the De-Select button.  The pathname will no longer appear in the 

Selected Pathnames List. 

To remove all pathnames from the Selected Pathnames List, click the Clear 
Selections button.  To restore selections you have cleared, use the Restore 
Selections button. 
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3.5.2 Setting the Time Window 
You can also specify the time window for data you want displayed in plots 
and tables.  For example, if you have a set of HEC-DSS records ranging from 
October 1, 1993, to December 30, 1993, you can specify a narrower time 
window, such as 05OCT1993 to 25OCT1993 for plots and tables you view. 

To set the Time Window: 

1. Click the Set Time Window button.  The Set Time Window dialog 
box will open (Figure 3.16). 

Figure 3.16 Set Time Window Dialog Box 

2. You may either enter specific dates and times or use the current time. 

� To use the current time, click the Set Current Time button.  This 
will set both the start and end dates and times to the current time. 

� To specify dates and times: 
a. Enter the Start Date and End Date.  Although a variety of 

formats will be recognized for the date, the recommended 
format is DDMMMYYYY. 

b. Enter the Start Time and End Time in 24-hour format (e.g., 
for 2:00 PM, type “1400”). 

3. Click the Apply button to apply the time window without closing the 
dialog box. 

4. Click OK to apply the time window and close the dialog box. 
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3.6 Visualizing HEC-DSS Data with Plots and Tables 
Once the Selected Pathnames List contains all the pathnames you wish to 
display, you can generate plots and tables.   

To create a plot or table from the Display menu, select Plot or Tabulate.  
You can also click on the Plot  button or the Tabulate  button.   

From a plot window, you can also tabulate data using the Tabulate command 
in the plot’s File menu.  Likewise, to open a plot from a table, you can use the 
Plot command in the table’s File menu. 

Figure 3.17 shows examples of the plots and tables HEC-DSSVue can 
produce.  

 
 Figure 3.17 Example Plot and Table 

HEC-DSSVue plots are highly customizable.  You can add titles, specify 
colors and patterns of backgrounds and lines, change line styles, add markers 
and callouts, add borders to labels, and customize legends, axes, and tic 
marks. 

For more information on plots, refer to the chapter on Plots. 

For more information about tables, see the chapter on Utilities.   
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3.7 Utilities Menu Operations 
The Utilities menu provides access to Math Functions, Manual Data Entry 
(Time Series and Paired Data), and it allows you to Rename Records, Copy 
Records, Duplicate Records, Merge Files, Squeeze, access the Script 
Editor, and view HEC-DSS Status.   

These functions are discussed in detail in three separate chapters: Math 
Functions, Utilities (which also covers tabular editing and printing 
functions), and Scripting. 


