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Chapter 4 
4 Utilities  

HEC-DSSVue utilities allow you to tabulate, edit, copy, rename, and delete 
data, manually enter data, create and edit scripts, and perform math functions, 
as well as merge and squeeze HEC-DSS files. 

This chapter provides guidance in using these utilities and also shows you 
how to print, copy, and export tabular HEC-DSS data. 
 

4.1 Viewing Tabular Data 
Figure 4.1 shows an example table produced using HEC-DSSVue.  Tables 
allow you to view and edit HEC-DSS data in a vertical scrolling window that 
shows the ordinate (starting from the start date/time), the date and time stamp, 
and the values for the selected data sets.  From the File menu of the table 
window, you can view the tabular data in plot format by clicking Plot. 

 

Figure 4.1 Example Tabulation from HEC-DSSVue 
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4.1.1 Accessing Tables 
To access tables, first select the pathnames of the records you wish to view.  
There are several ways to select pathnames: 

� Double-click on an individual pathname in the HEC-DSS Pathname List.   
� Highlight a pathname in the HEC-DSS Pathname List then click the Select 

button.  Until you select a pathname, the Select button remains inactive.   
� Click and drag your mouse to select a series of pathnames, and then click 

the Select button.  You can also use Ctrl+Click to select multiple, non-
consecutive pathnames.  

� If you wish to select all of the pathnames for visualization, from the Edit 
menu, click Select All. 

� If no pathnames are in the selection list, individual pathnames can just be 
highlighted for quick selection. 

When you select a pathname, it will appear in the Selected Pathnames List. 

Once you have selected the pathnames you want to visualize, you can open a 
table by clicking on the Tabulate  button, or from the Display menu, by 
clicking Tabulate. 
 

4.1.2 Customizing the Display of Tabular Data 
In HEC-DSSVue tables you have several options for displaying data.   

From the View menu, you can choose to display commas in numbers by 
selecting the Commas command.  The date and time of the data can be 
tabulated in separate columns by selecting Date and Time Separately.  To 
have the dates display the years with four digits, select Date With 4 Digit 
Years.  You can set the precision of decimal places for your data by selecting 
Decimal Places and selecting the number of decimal places you wish to 
display. 
 

4.2 Editing Tabular Data 
In HEC-DSSVue, you can edit data directly in 
tables.   

From the Edit menu of the table, select Allow 
Editing (Figure 4.2) to manually edit the data in the 
table.  When this option is checked, the Cut and 
Paste commands also become available in the 
menu.  

You can also use shortcut menu commands to edit 
multiple selected cells in tables (Figure 4.3).  

 
Figure 4.2 Edit menu - 
Allow Editing option 
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If you make any edits, HEC-DSSVue prompts you can save your changes 
with the Save or Save As items under the File menu.  If you do not save your 
data, HEC-DSSVue will prompt you to save your changes when you close the 
window.   
 

4.2.1 Selecting Table Cells 
To select an individual table cell, double-click on it.   

To select several consecutive cells, click and drag your 
mouse.  You can also use Ctrl+Click to select multiple, 
non-consecutive records. 

If you wish to select all rows in a table, from the 
shortcut menu, click Select All (Figure 4.3). 

 
 

4.2.2 Cutting and Pasting Data 
The Cut command removes data from its current location and places it on the 
clipboard in ASCII format.  For regular-interval time series data, the Cut 
command will replace the data values with missing flags. 

You can cut data from one set of cells and paste them into another set of cells 
(in the same table or another table).  To do this: 

1. From the View menu of the table (or tables), click Allow Editing. 
2. Select the cells you want to cut. 
3. From either the View menu or the shortcut menu (Figure 4.3), click Cut. 
4. Select the cells where you want to move the data. 
5. From either the View menu or the shortcut menu (Figure 4.3), click 

Paste.   

 

4.2.3 Copying and Pasting Data 
The Copy command places the selected data on the clipboard in ASCII 
format.  You can also copy data from one set of cells to another.  To do this: 

1. Select Allow Editing from the View menu of the table (or tables). 
2. Select the cells you want to copy. 
3. Choose Copy from either the View menu or the shortcut menu (Figure 

4.3) of the table. 
4. Select the cells where you want to copy the data. 
5. Choose Paste from either the View menu or the shortcut menu (Figure 

4.3) of the table.   

 
Figure 4.3 Shortcut 
Menu 
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You can also use the Copy command to copy and paste data into another 
application, such as Microsoft Excel or Word. 
 

4.2.4 Clearing Table Cells 
When you clear table cells, the data is not saved on the clipboard, so you 
cannot later paste the data back into the table.  For regular-interval time series 
data, the Clear command will replace the data values with missing flags. To 
clear table cells: 

1. From the View menu of the table (or tables), click Allow Editing. 
2. Select the cells you want to clear. 
3. From the shortcut menu of the table (Figure 4.3), click Clear. 

 

4.2.5 Appending Rows 
Appending rows is automatic when editing data.  When you set the table into 
edit mode, two blank rows appear at the end of the table where you can enter 
data.  After you enter data for a row, an additional blank row appears.  When 
you save the data, any blank rows at the end of the table are removed 
automatically. 
 

4.2.6 Deleting Rows 
You may delete rows from a table when working with irregular-interval time 
series data and paired data.  To delete a row from a table, first select the row 
(see Section 4.2.1).  Next, from the shortcut menu (Figure 4.3), click Delete 
Row(s). 

If you are working with regular interval time series data, you will not be able 
to delete rows; instead, change the data to missing data flags (-901.) 
 
 

4.3 Printing, Copying, and Exporting Tables 
HEC-DSSVue tables offer several commands that allow you to print as well 
as export or copy, and paste plots into other applications such as Microsoft 
Excel and Word. 
 

4.3.1 Printing Tables 
You can access the Print command from either the File menu (Figure 4.5) or 
from the shortcut menu (Figure 4.6) of the table window.  The Print 
Preview command is also available in the shortcut menu. 
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Figure 4.5 File Menu--Table Window 

 
Figure 4.6 Shortcut 
Menu--Print Command 

  

 

In a table, the Print and Print 
Preview commands open the 
Print Properties dialog box 
(Figure 4.7), which offers options 
on three tabs. 

The Page tab allows you to 
specify the page Orientation, 
Scaling, and Selection; you can 
also choose to print the table as 
ASCII, Repeat Headers on every 
page, and print the Gridlines. 

On the Header/Footer tab, you 
can type in the header and footer 
you want to appear on your 
printed pages. 

The Table Title tab offers a 
default title for the table based on 
the data source.  You may edit 
this title. 

On the Print Properties dialog 
box, the Print button performs two functions, depending on whether you 
arrived at the dialog box via the Print command or the Print Preview 
command. 

 
Figure 4.7 Print Properties Dialog Box 
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From the Print Preview command on 
the shortcut menu, the Print button 
on the Print Properties dialog box 
opens a Print Preview window, 
which allows you to view the table as 
it will be printed.  Figure 4.8 shows 
an example. You can click the Print 
button in the Print Preview window to 
print your table. 

From the Print command, the Print 
button on the Print Properties dialog 
box opens a Windows-style print 
dialog box, where you can choose 
your printer, set printer properties, 
and specify the number of copies to 
print.  You can also print your table to 
a file instead of to a printer. 

 
 

 

 

4.3.2 Exporting Tables 
From the shortcut menu, click Export to export a table to a file, which you 
can then open in another application.  

The Export command opens the Table Export Options dialog box (Figure 
4.9). 

In the Table Export Options 
dialog box, you can choose the 
Field Delimiter (tab, space, 
comma, or colon), specify Fixed-
Width Columns, choose to display 
Quoted Strings, Include Column 
Headers, and opt to Print 
Gridlines and Title. 

 

 

 

 

 
Figure 4.8 Print Preview of a Table 
(Example) 

Figure 4.9 Table Export Options Dialog 
Box 
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4.3.3 Copying Tables to the Clipboard for Use in Other 
Applications 

To copy a table to the clipboard, click Copy from the table window’s Edit 
menu (Figure 4.10).  You can also right-click inside the table and select Copy 
from the shortcut menu (Figure 4.11). You can then paste the table as tab-
separated values into another application such as Microsoft Excel or Word.    

 

 
Figure 4.10 Edit Menu--Table Window 

 
Figure 4.11 Shortcut Menu--
Copy Command 
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4.4 Entering Data Manually 
You can enter time series and paired data manually using the Manual Data 
Entry editors available from the Utilities menu. 
 

4.4.1 Entering Time Series Data Manually 
To enter time series data manually: 

1. From the Utilities menu, choose Manual Data Entry, and then select 
Time Series.  The Manual Time Series Data Entry dialog box (Figure 
4.12) will open. 

Figure 4.12 HEC-DSSVue Manual Time Series Data Entry Dialog Box 

2. Type the Pathname Parts into the A, B, C, and F boxes, then select the 
appropriate time interval for the E box.  The complete pathname will 
automatically appear in the Pathname box.  You can also enter the 
pathname into the Pathname box; the parts will appear in the Pathname 
Parts boxes.  You cannot enter the “D” (date) part, as this is set according 
to your Start Date). 
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3. Enter the Start Date (e.g., 25Mar2002) and Start Time (e.g., 1400). 
4. Enter the Units (e.g., CFS) 
5. From the Type list, select a data type.  Your options are PER-AVER, 

INST-VAL, PER-CUM, and INST-CUM. 
6. For regular-interval time series data, the Date/Time boxes in the table will 

fill in automatically according to the start date and time you have entered.  
For irregular-interval data, you will need to enter a date and time for each 
data value. 

7. Type the data values into the third column. 
8. To view the data in plot form, click the Plot button. 
9. To save the new time series record, click Save. 
 

You can also automatically generate regular-interval time series data.  This 
will fill in a single number for a time window.  To generate this data: 

1. Complete steps 1 through 5 (above.) 
2. Select the Automatic Generation tab. 
3. Enter the End Date and End Time for the data. 
4. Enter the Fill Value, which is the single value for the specified time 

window. 
5. Press the Generate button.  This will return you to the Manual Entry tab, 

where you can plot, save, or further edit the data. 
 
 

4.4.2 Entering Paired Data Manually 
To enter paired data manually: 

1. From the Utilities menu, choose Manual Data Entry, and then select 
Paired Data.  The Manual Paired Data Entry dialog box dialog box 
(Figure 4.13) will open. 
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Figure 4.13 HEC-DSSVue Manual Paired Data Entry Dialog Box 

2. Type the Pathname Parts into the A, B, C, D, E, and F boxes.  The 
complete pathname will automatically appear in the Pathname box.  You 
can also enter the pathname into the Pathname box; the parts will appear 
in the Pathname Parts boxes.  Be sure the “C” part contains both an X 
parameter and a Y parameter, separated by a hyphen (e.g., STAGE-FLOW 
or ELEV-DAMAGE). 

3. Select the Number of Curves for the Y parameter from the list. 
4. Enter the X Units (belonging to the first parameter) and the Y Units 

(belonging to the second parameter). 
5. Choose the X Type and Y Type from the lists. Available options are 

Linear, Log, and Probability. 
6. In the table, the Y ordinates column will split into individual columns 

according to the Number of Curves you have specified.  
7. Type the data values into the X ordinates and Y ordinates columns. 
8. To view the data in plot form, click the Plot button. 
9. To save the new time series record, click Save. 
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4.5 Renaming HEC-DSS Data in HEC-DSSVue 
The Rename command renames record pathnames.  To rename HEC-DSS 
records: 

1. Select the record or records to rename. 
2. From the Utilities menu, select Rename Records.    The Rename 

Records to: dialog box (Figure 4.14) will open. 

 
Figure 4.14 HEC-DSSVue Rename Records to Dialog Box 

3. You may change one or more pathname parts or the entire record. Type 
the new Pathname Parts into the A, B, C, D, E, and F boxes.  You cannot 
change the D or E parts for time series data (use Math Functions to 
accomplish this).  For multiple records, pathname parts that are the same 
for all records will show up in the dialog.  Where parts differ (such as 
having pathnames with C parts of FLOW and ELEVATION), the part will 
be displayed with an asterisk (*). 

4. Click OK. 
 

4.6 Copying Records into a HEC-DSS File 
To copy records into another HEC-DSS file,   

1. Select the record or records to copy. 
2. From the Utilities menu, select Copy Records.  The Copy Records into 

HEC-DSS File dialog box (Figure 4.15) will open. 
3. In the File Name box, type in a new HEC-DSS filename or select an 

existing HEC-DSS File into which you want to copy the record into and 
click Open.  A confirmation message will appear stating that the record 
has been copied to the HEC-DSS file you selected. 
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Figure 4.15 HEC-DSSVue Copy Records into HEC-DSS File Dialog 
Box 

4.7 Duplicating Records 
 

The Duplicate command duplicates records in the same HEC-DSS file, giving 
the new records different pathnames.   

To duplicate records:  

1. Select the record or records to duplicate. 
2. From the Utilities menu, select Duplicate Records.  The New Pathname 

Parts for Duplicate Records dialog box (Figure 4.16) will open. 

Figure 4.16 HEC-DSSVue New Pathname Parts for Duplicate Records 
Dialog Box 

3. Type the new Pathname Parts into the A, B, C, D, E, and F boxes    You 
cannot change the D or E parts for time series data (use Math Functions to 
accomplish this).  For multiple records, pathname parts that are the same 
for all records will show up in the dialog.  Where parts differ (such as 
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having pathnames with C parts of FLOW and ELEVATION), the part will 
be displayed with an asterisk (*).   

4. Click OK.  A confirmation message will appear, stating that the records 
have been duplicated.  

 

4.8 Merging HEC-DSS Files 
Merging copies all of the records in the currently opened HEC-DSS file into 
another.  This is similar to selecting all records then using the Copy Records 
option, but is much more efficient.  However, this option will overwrite any 
records with the same pathnames, and will not splice together time series 
records.  To merge the current HEC-DSS file into another:  

1. From the Utilities menu, click Merge.  The Merge (copy all records) 
into HEC-DSS File dialog box (Figure 4.17) will open.   

 

 
Figure 4.17 HEC-DSSVue Merge (copy all records) into HEC-DSS 
File Dialog Box 

2. In the File Name box, select an existing HEC-DSS File into which you 
want to copy all of the records into and click Open.  A confirmation 
message will appear stating that the records have been copied into the 
HEC-DSS file you selected.  

 

4.9 Squeezing HEC-DSS Files 
When you delete or rename records, a HEC-DSS file will accumulate inactive 
space.  The Squeeze command removes inactive space by copying all valid 
data to a new file then renaming the new file to the old filename.  The 
Squeeze command will also automatically re-adjust internal HEC-DSS table 
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sizes to optimize access to the data.  Once a squeeze has been accomplished, 
deleted data cannot be recovered. 

To squeeze an HEC-DSS file: 

1. Open the HEC-DSS file, then, from the Utilities menu, click Squeeze.  A 
window will appear indicating the status of the squeeze process, as shown 
in Figure 4.18.   

2. If you wish, you may cancel the squeeze prior to completion, by pressing 
the Cancel button.   

3. When the process is complete, a confirmation will appear (Figure 4.19) 

 
Figure 4.18 HEC-DSSVue Squeeze progress window (example) 

 
Figure 4.19 Example HEC-DSSVue Squeeze Confirmation Message 
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4.10 Scripting 
You can use Jython scripts that you or others write, to perform math 
functions, create custom plots or tables, and automate repetitive tasks.  To 
edit, test, and select scripts, use the Script Browser.  To run scripts that have 
already been setup, use the Script Selector window.  To access the Script 
Browser (Figure 4.21), from the Utilities menu, click Script Browser.  To 
access the Script Selector window, from the Utilities menu, click Script 
Selector.  For more information, refer to the chapter on Scripting. 

 

Figure 4.21 Script Browser 
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4.11 Performing Math Functions  
To access HEC-DSSVue Math Functions, from the Utilities menu, click 
Math Functions.  The Math Functions dialog box (Figure 4.22) will open. 

Figure 4.22 HEC-DSSVue Math Functions Dialog Box 

HEC-DSSVue Math Functions facilitate the mathematical manipulation of 
time series and paired data sets you have selected.  Available functions fall 
into six categories: Arithmetic, General, Time Conversion, Hydrologic, 
Smoothing, and Statistics.  Each function category is a tab on the Math 
Functions screen. 

Use the Operator list to select functions, and choose data sets from the 
Selected Data Set list. Click the Compute button to apply a function.  The 
Compute button is available only if the data on the function screen is 
complete. 

Refer to the chapters on Math and Scripting for more information about math 
functions and scripting in HEC-DSSVue Math. 

 


