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CHAPTER 3 
 
 

Displaying & Editing Data 
 
 
HEC-DSSVue allows you to plot, tabulate, and edit data in HEC-DSS 
files.  This chapter covers setting a time window to access and view time 
series data with, tabulating time series and paired data, editing data and 
displaying supplemental data associated with a data set.  Plotting is 
covered in the chapter "Customizing Plots". 
 
For HEC-DSSVue Version 2.0, you can "drag" data sets from the main 
window onto a plot or table to add that data set to the plot or table.  The 
file that you are dragging from does not need to be the same as where the 
original data came from; in fact you can drag a data set from a different 
instance of HEC-DSSVue. 
 
 

3.1 Setting a Time Window 
 
You can specify the time window for data you want displayed in plots and 
tables and to perform math functions on.  For example, if you have a set of 
HEC-DSS records ranging from October 1, 1993, to December 30, 1993, 
you can specify a narrower time window such as 05OCT1993 to 
25OCT1993 for plots, tables, and operations with math functions. 
 
To set the Time Window: 
 
 1. From the Display menu, click Time Window.  The Set Time 

Window dialog box will open (see Figure 3.1, page 3-2). 
 2. You may select no time window, which will retrieve all the data 

for a data set, enter specific dates and times, use a time window 
relative to the current time, or access data by water year. 

 3. To access all data in a data set, select No Time Window (see 
Figure 3.1, page 3-2). 

 4. To set a specific time window, select Specific Time Window. 
 a. If you wish, you can set the fields to the current time by 

clicking Set Current Time and then change what you want 
manually. 

 b. To specify dates and times: 
 i. Enter the Start Date and End Date (see Figure 3.1, page 

3-1).  Although a variety of formats will be recognized for 
the date, the typical format is DDMMMYYYY. 
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Figure 3.1  Set Time Window Dialog Box 

 
 ii. Enter the Start Time and End Time in 24-hour format 

(e.g., for 2:00 PM, type "1400"). 
 c. You may select the starting and 

ending dates from the calendar 
tool, From the Start Date box, 
click on      .  The calendar tool 
in a monthly format will open 
(Figure 3.2).  You may scroll 
through months or years by 
using the appropriate arrow 
key at the top of the box. 

 5. To set a time window relative to 
the current time, select Relative to 
Current Time (Figure 3.1). 

 a. Select the units you want to go 
back and forward from the 
current time.  You can select 
hours, days, months, or years. 

 b. Enter the Go Back and Go 
Forward units. 

 c. If you do not set a unit, No 
Time Window will be set. Figure 3.2  Calendar Tool 
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 6. Accessing DSS data by water year, from the Set Time Window 

dialog box select (see Figure 3.1, page 3-2) Individual Water 
Year.  You can change the default start date of the water year from 
October first by setting a new date in the Start Date of Water 
Year box.  This will read all the data in a data set and then separate 
it into individual data sets by water year.  This setting is primarily 
useful when using math functions in HEC-DSSVue.  If you plot 
data when this setting is selected, you should choose Plot 
Individual Data Sets. 

 7. To keep your settings for the next time you run HEC-DSSVue, 
select Retain Between Sessions.  The next time you execute HEC-
DSSVue, your time window will be set. 

 8. Click OK the Set Time Window dialog box will close (see Figure 
3.1, page 3-2), and the time window settings will be applied. 

 
 

3.2 Display Data Options 
 
Two options are provided as a quick way to compare time series data sets 
for different time periods or for different amounts.  The options are turned 
on or off by selecting and un-selecting them from the Display menu, point 
to Display Data Options, and the two available options are - Normalize 
and Synch data set times to first. 
 
Normalize will subtract the differences between the values of first and the 
second or subsequent data sets from the corresponding data set, so that the 
curves all start at the same value (which is the value of the first data point 
in the first data set).  This is often used to compare cumulative 
precipitation curves, which usually start at different values. 
 
Synch data set times to first will subtract the differences between the 
times of first and the second or subsequent data sets from the 
corresponding data set, so that the curves all start at the same time (which 
is the time in the first data set).  This is often used to directly compare 
hydrographs for different years or time periods. 
 
Each option will remain on until you turn it off or the program exits.  The 
options can be used in combination with each other.  For example, if you 
want to compare cumulative precipitation curves for different years, set 
each option to on.  Figure 3.3 shows such an example of normalized 
cumulative precipitation for years 1986 and 1995, synched to the same 
start time. 
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Figure 3.3  Normalized and Time Synched Precipitation Data for Years 1986 and 1995 
 
 

3.3 Viewing Tabular Data 
 
An example table produced using HEC-DSSVue is shown in Figure 3.4.  
Tables allow you to view and edit HEC-DSS data in a vertical scrolling  
 

 
Figure 3.4  Example Tabulation from HEC-DSSVue 
 



HEC-DSSVue User's Manual Chapter 3 - Displaying & Editing Data 

3–5 

window that shows the ordinate (starting from the start date/time), the date 
and time stamp, and the values for the selected data sets.  From the File 
menu of a table dialog box (see Figure 3.4, page 3-4), you can view the 
tabular data in plot format by clicking Plot.  Respectively, you can 
tabulate data displayed in a plot dialog box, from the File menu, click 
Tabulate. 
 
 

3.3.1 Accessing Tables 
 
To access tables, first select the pathnames of the records you wish to 
view.  There are several ways to select pathnames: 
 
 ■ Double-click on an individual pathname in the HEC-DSS 

Pathname list. 
 ■ Highlight a pathname in the HEC-DSS Pathname list then click 

Select.  Until you select a pathname, the Select button remains 
inactive.   

 ■ Click and drag your mouse to select a series of pathnames, and 
then click Select.  You can also use Ctrl+click to select multiple, 
non-consecutive pathnames. 

 ■ If you wish to select all of the pathnames, click Select All from the 
Edit menu. 

 ■ If no pathnames are in the selection list, individual pathnames can 
just be highlighted for quick selection. 

 ■ Drag additional datasets from the main screen onto the table to add 
them to the table. 

 
Once you have selected the pathnames you want to visualize, you can 
open a table by clicking the Tabulate      button from the Tool Bar, or 
from the Display menu click Tabulate. 
 
 

3.3.2 Customizing the Display of Tabular Data 
 
From a tabular data dialog box, from the View menu, you can choose to 
display commas in numbers by clicking Commas.  You can reverse the 
order of the table by clicking Reverse Order.  For time series data, this 
option will show the latest values first.  The date and time of the data can 
be tabulated in separate columns by clicking Date and Time Separately.  
To have the dates display the years with four digits, click Date With 4 
Digit Years.  You can set the precision of decimal places for your data by 
pointing to Show Decimal Places and then clicking the number of 
decimal places you wish to display (see Figure 3.5, page 3-6).  You can 
also change how missing values are displayed by pointing to Show 
Missing As and then by clicking blanks (the default), -901.0, M, or -M-. 
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Figure 3.5 HEC-DSSVue Tables have Several 

Options for Displaying Data 
 
 

3.3.3 Searching for Values 
 
You can search for specific values in your 
dataset, from a tabulate dialog box (see 
Figure 3.4, page 3-4), from the Edit menu 
click Find (Figure 3.6), or press the F3 
key.  Using either option will open the 
Find dialog box (Figure 3.7). 
 
In the Find what box (Figure 3.7), enter 
the item that you are searching for in your 
dataset.  When you click Find Next 
(Figure 3.7), the next value that matches 
will be highlighted.  You can search up from where your cursor is, or  

Figure 3.7  Find Dialog Box 
 
search down.  You have the option of searching for the exact number or 
part of that number.  You can also search for a date or time. 
 
 

Figure 3.6  Tabulate Edit Menu 
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3.3.4 Comparing Datasets 
 
If you tabulate two or more similar time 
series data sets, you can compare values 
from both sets from the table.  From a 
tabulate dialog box (see Figure 3.4, page 
3-4), from the Edit menu, click Compare 
data sets (Figure 3.8) 
 
A message will appear displaying the 
number of values that differ in the 
selected data sets (Figure 3.9) and the 
differences between the two data sets will 
be highlighted in red, as show in Figure 
3.10. 
 
For more information and options to 
compare datasets, see Chapter 4, Section 
4.7. 
 
 
 

 
Figure 3.10  Comparison of Two Data Sets 
 
 

Figure 3.8  Compare Data Sets 

Figure 3.9 Display of the number of 
values that vary 
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3.4 Editing Tabular Data 
 
In HEC-DSSVue, you can edit data directly in tables, but first you must 
set the table to allow editing. 
 
From a tabulate dialog box (see Figure 3.4, page 
3-4), from the Edit menu, click Allow Editing 
(Figure 3.11).  This will set the table editable 
and allow you to manually edit the listed data.  
When this option is checked, the background of 
non-editable table cells display grey and the 
Cut, Paste, Insert Rows, and Delete Rows 
commands become available from the Edit 
menu. 
 
If the Allow Editing option is disabled (grayed-
out), you may not have permission to write to 
the file or the table was started from a dialog 
that does not have access to write to the file (such as a plot window). 
 
Changes made to a table can be saved, from the File menu, click Save or 
click Save As.  If you do not save your data before you close the table 
window, HEC-DSSVue will prompt you to save your changes before it 
closes the window. 
 
 

3.4.1 Selecting Table Cells 
 
To select an individual table cell, simply click on it. 
 
To select several consecutive cells, click, hold down 
and drag your mouse over the cells.  You can also 
hold down the Ctrl key and click to select multiple, 
non-consecutive records. 
 
If you wish to select all rows in a table, from the 
Edit menu, click Select All. 
 
You can also use shortcut menu items to edit 
multiple selected cells in tables (Figure 3.12). 
 
 

3.4.2 Cutting and Pasting Data 
 
The Cut command removes data from the cell and places it on the 
computers clipboard in ASCII format.  For regular-interval time series 
data, the Cut command will set the emptied cell to the missing data flag. 

Figure 3.11 Edit Menu - 
Allow Editing 

Figure 3.12 Shortcut 
Menu 
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You can cut data from one set of cells and paste it into another set of cells 
(in the same table or another table).  To do a cut and paste: 
 
 1. From the View menu, click Allow Editing. 
 2. Select the cells you want to Cut the data from. 
 3. From either the View menu or the shortcut menu (see Figure 3.12, 

page 3-8), click Cut. 
 4. Select the cells where you want to Paste the data. 
 5. From either the View menu or the shortcut menu (see Figure 3.12, 

page 3-8), click Paste. 
 

Tip:  The keyboard shortcut keys, Ctrl + x and Ctrl + v 
also work for cut and paste. 

 
 

3.4.3 Copying and Pasting Data 
 
The Copy command copies selected cell data and places it on the 
computers clipboard in ASCII format.   
 
You can copy data from one set of cells and paste it into another set of 
cells (in the same table or another table).  To do a copy and paste: 
 
 1. From the View menu, click Allow Editing. 
 2. Select the cells you want to Copy the data from. 
 3. From either the View menu or the shortcut menu (see Figure 3.12, 

page 3-8), click Copy. 
 4. Select the cells where you want to Paste the data. 
 5. From either the View menu or the shortcut menu (see Figure 3.12, 

page 3-8), click Paste. 
 

Tip: The keyboard shortcut keys, Ctrl + x and Ctrl + v also 
work for cut and paste. 

 
 

3.4.4 Clearing Table Cells 
 
To delete and remove data from table cells use the Clear command.  
Cleared data is not saved to the computer's clipboard, so you will not be 
able to paste the data back into the table.  However, for time series data, 
the Clear command will remove the data from the cell and add a missing 
flag to the emptied cell.  To clear table cells: 
 
 1. From the View menu, click Allow Editing. 
 2. Select the cells you want to clear. 
 3. From the shortcut menu (see Figure 3.12, page 3-8), click Clear. 
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3.4.5 Adding and Inserting Rows 

 
Depending on what type of data is being edited in a table, rows can be 
inserted, appended, or added to the beginning or end of the table. 
 
Appending rows is automatic when Allow Editing is set.  When Allow 
Editing is selected, two blank rows automatically appear at the end of the 
table.  When ever you enter data in a row at the bottom of the table, an 
additional blank row will be appended.  When you save the data, any 
blank rows at the end of the table are removed automatically. 
 
For regular interval time series data, rows can only be inserted at the 
beginning or end of the data set.  For irregular interval time series data and 
paired data, rows can be inserted between any existing table rows.  To 
insert a row into the table: 
 
 1. Using your mouse pointer, click on the row you would like to 

insert rows next to and then from the Edit menu, click Insert 
Rows. 

 2. The Extend Data Set dialog box will open (Figure 3.13).  This 
dialog may be different from what's pictured in Figure 3.13 
depending on what type of data is displayed in the table. 

 

 
Figure 3.13  Extend Data Set Dialog Box for Regular Interval Data 

 
 3. For irregular interval time series data (see Figure 3.14, page 3-11), 

you have the option to Insert between the selected dates, Insert 
before the first date, and Append after the last date.  Regular 
interval data can only have data inserted before and after the 
existing time steps.  Each choice requires you to enter the number 
of rows that will be added.  From the Number Rows list, enter or 
select the number of rows that will be added to the table at the 
given area. 
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Figure 3.14 Extend Data Set Dialog Box for Irregular Interval Data 

 
 4. Irregular interval time series data requires an interval to be 

selected.  From the Interval list, select an interval, default is 
1HOUR.  If you would like the data and time filled for each 
inserted row, be sure Set the data and time for each row is 
selected. 

 5. For a paired data table, all that is required is entering the number of 
rows you would like to insert.  From the Edit menu, click Insert 
Rows, the Insert Rows dialog box will open (Figure 3.15).  In the 
Number to insert box, enter the number of rows you would like to 
add.  Paired data tables also allow you to add additional columns, 
from. 

 

 
Figure 3.15 Insert Rows Dialog Box  

 
 6. Once you are done entering information for the insert, click OK. 
 7. The entered number of blank rows will be inserted at that row, 

moving the original row that you selected down. 
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3.4.6 Deleting Rows and Columns 
 
You may delete rows from a table when working with irregular-interval 
time series data and paired data.  To delete a row from a table, select the 
row and then from the Edit menu, click Delete Rows. 
 
If you are working with regular interval time series data, you will not be 
able to delete rows; instead, the Delete Rows function will change the data 
values to missing.  This is the same as clicking Clear (see Figure 3.12, 
page 3-8) from the shortcut menu. 
 
In a paired data table you can delete a column.  To delete a paired data 
column, select the column and then from the Edit menu, click Delete 
Column.  The Delete Column message box will open (Figure 3.16), 
requiring you to verify you would like to delete the entire column.  Click 
Yes to finish deleting the column. 
 

 
Figure 3.16  Delete Column Message Box 
 
 

3.5 Printing, Copying, and Exporting Tables 
 
HEC-DSSVue tables offer several commands that allow you to print, copy 
or export data and then paste tables into other applications such as 
Microsoft Excel and Word.  The following sections describe each in 
detail. 
 
 

3.5.1 Printing Tables 
 
You can access the Print and Print 
Preview commands from either the 
File menu (Figure 3.17) or from the 
shortcut menu (see Figure 3.18, page  
3-13) of the table window. 
 
In a table, the Print and Print Preview 
commands open the Properties dialog 
box (see Figure 3.19, page 3-13), 
which offers options on three tabs. 

Figure 3.17 File Menu - Tabulate 
Dialog Box 
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The Page tab allows you to specify the page 
Orientation, Scaling, and Selection.  You can 
also choose to print the table as ASCII, Repeat 
Headers on every page, and print the Gridlines. 
 
On the Header/Footer tab you can type in the 
header and footer you want to appear on your 
printed pages. 
 
The Table Title tab offers a default title for the 
table based on the data source, which you can 
change. 
 
On the Properties dialog box, the Print 
command performs two functions, depending on 
whether you arrived at the dialog box via the 
Print command or the Print Preview command. 
 

 
Figure 3.19  Properties Dialog Box - Printing 
 
If the Properties dialog box was opened using the Print Preview menu, 
the Preview button on the Properties dialog box opens a Print Preview 
dialog box that allows you to view the table as it will look when it is 
printed, see Figure 3.20 (see page 3-14).  You can click Print in the Print 
Preview dialog box to print your table. 
 
From the Print command, the Print button on the Properties dialog box 
opens a Windows-style print dialog box where you can choose your  

Figure 3.18 Print Shortcut 
Menu 
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Figure 3.20  Print Preview Dialog Box - Table 
 
printer, set printer properties, and specify the number of copies to print.  
You can also print your table to a file instead of to a printer. 
 
 

3.5.2 Exporting Tables 
 
Tables can be exported and converted into a *.txt file.  Once the table is in 
the form of a *.txt file, it can be opened in a different application such as 
Microsoft Excel or Word.  
 
From the shortcut menu or the 
File menu, click Export, the 
Table Export Options dialog box 
will open (Figure 3.21). 
 
In the Table Export Options 
dialog box, you can choose a 
Field Delimiter (TAB, SPACE, 
COMMA, COLON, or SEMI-
COLON), specify Fixed-Width 
Columns, choose to display 
Quoted Strings, Include 
Column Headers, and opt to 
Print Gridlines and a Title. 
 

Figure 3.21 Table Export Options Dialog Box 
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3.5.3 Copying Tables to the Clipboard for Use in Other 
Applications 

 
To copy a table to the clipboard, from a table dialog box, from the Edit 
menu, click Copy (Figure 3.22).  You can also right-click inside the table 
and click Copy from the shortcut menu (Figure 3.23).  To copy the entire  
 

 
Figure 3.22  Edit Menu - Table Dialog Box 
 
table from the shortcut menu, click Select All and 
then click Copy.  You can then paste the table as 
tab-separated values into another application such 
as Microsoft Excel or Word.  Only the data is 
copied to the clipboard; the table gridlines are not 
copied.  (Use the export options when you want 
to copy table gridlines.) 
 
You can also highlight a portion of the table and 
then click Copy.   This will copy the portion of 
the table that you highlighted to the clipboard. 
 
 

3.5.4 Tabulate and Editing using MS Excel (Optional) 
 
If the Excel plug-in is loaded, you can tabulate (or export) data in 
Microsoft Excel and edit time series data in Excel.  Simply select the data 
sets you wish to tabulate as you normally would and then either press the 
Excel tool in the toolbar, or from the Display menu, click Tabulate in 
Excel (assuming you have Microsoft Excel installed).  Figure 3.24 (see 
page 3-16) shows how the data is displayed in Excel. 
 
To edit data in Excel, select your data sets and from the Edit menu, click 
Edit in Excel.  This will load the selected data into an Excel spreadsheet  

Figure 3.23 Shortcut  
 Menu - Copy 
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Figure 3.24  Tabular Data Exported to Excel 
 
and then read it back to DSS once you have saved it.  In this mode, you 
may not add or delete rows or columns; you can only change the data.  
After you are finished, save the Excel spreadsheet and then click OK or 
Cancel from the dialog from HEC-DSSVue. 
 

Note - Take caution with dates and time in Excel.  Excel 
shows times as "Beginning of Period", while the HEC-DSS 
convention shows times as "End of Period".  A data value for 
midnight will show up as 2400 hours at the end of the day in 
HEC-DSS, while Excel will display that as 0000 hours for the 
next day.  For daily data, the hours might not be shown in 
Excel and the data can be misinterpreted to be for the 
following day. 
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3.6 Graphical Editing 

 
You can view and edit time series data in a combined plot/table using the 
Graphical Editor (Figure 3.25) for HEC-DSSVue.  To access the HEC-
DSSVue Graphical Editor, select one or more pathnames from the main 
HEC-DSSVue screen, from the Edit menu, click Graphical Edit or from 
the toolbar click the Graphical Edit       button.  Only time series data can 
be edited through the graphical editor. 
 

 
Figure 3.25  Graphical Editor 
 
The Graphical Editor displays an editable plot of the data on the top of 
the editor and a scrollable table of the data on the bottom of the editor.  
The area of the data that is visible in the table is marked with a green hash 
region in the plot.  As you scroll through the table, the green hash area 
moves along with the data that is displayed.  When you select a point on 
the curve or in the table, a red vertical line is drawn at that point to show 
which value has been selected. 
 
You can edit data in the Graphical Editor by drawing a curve with your 
mouse, or by selecting a point on the curve and moving that point up or 
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down, or by changing a value in the associated table.  You can also have 
the editor linear interpolate missing points, or use the other fill options 
associated with tables. 
 
You can only edit one curve at a time, but you can plot other data sets on 
the same graph for comparison purposes.  You can also select multiple 
data sets and scroll through them as you edit.  The major components of 
the Graphical Editor are shown in Figure 3.25 (page 3-17). 
 
The components of the graphical editor are: 
 
 
 ● Current Selected Row shows what data value is selected on the 

plot and its corresponding row in the table. 
 
 ● Displayed Table Values indicates the area in the plot that 

corresponds to the data showing in the table. 
 
 ● Selected Data Set field displays the pathname for the data set 

being edited. 
 
 ● Estimate button generates a linear interpolation for selected rows 

for missing data or copies the original data into the editable field. 
The Estimate All button performs this for all rows in the table.  
Data must be in the editable field before the point editor can be 
used. 

 
 ● The Accept button copies data from the Estimate/Entry column 

into the Revised column for the selected rows.  This is for 
intermediate saving of the last data edited.  If you want to retain all 
changed values, the Accept All button copies all data from the 
Estimate/Entry column into the Revised column.  

 
 ● The Add Data button adds rows for irregular interval time series 

data.  A dialog will be displayed to set the date and time for the 
row added. 

 
 ● The Delete Data button removes rows for irregular-interval time 

series data.  You cannot remove regular-interval data; you can only 
change it to missing. 

 
 ● Original column contains the values of the original data set.  The 

values are generally depicted with a red curve in the plot with each 
point marked by an 'x'.  If the value is the same as the one in the 
Revised column, that point will be over drawn with the blue 'x' as 
well. 
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 ● Estimate/Entry (edit) column is an empty editable column where 
you enter data manually or edit with the point tool.  These values 
show-up in the plot as magenta triangles.   When you are satisfied 
with the changes you made in this column, press the Accept or 
Accept All button. 

 
 ● Revised (edited) column contains the final values that will be 

saved when Save or Save As is selected.  These values display as a 
blue 'x' in the plot. 

 
 

3.6.1 Graphical Editor Tools and Buttons 
 
The Graphical Editor contains mouse tools and shortcut icon buttons to 
help aid with the editing process.  Available mouse tools: 
 
 Select Point tool selects a point on the curve to edit by moving the 

mouse to that point and clicking the left mouse button. 
 
 Zoom tool put the mouse in a zoom mode.  To zoom-in, move the 

mouse to one corner of the area you want to zoom-in to, click and 
hold down the left mouse button while dragging the mouse to the 
opposite corner and the release the button.  To zoom-out, click the 
right mouse button.  The graph is zoomed-out in increments. 

 
 Single Point edit tool puts the mouse in a point edit mode, as 

described in Section 3.6.3. 
 
 Line Draw is a multi-point edit tool that puts the mouse in a line 

draw mode, as described in the next section. 
 
Available tool bar buttons: 
 
 Save button saves the data in the Revised column to the DSS file 

without changing the pathname. 
 
 Save As button saves the data in the Revised column to the DSS file 

after allowing you to change one or more of the pathname parts. 
 
 Undo button restores the values to the original data set, undoing all 

changes. 
 
 Plot button plots the original and revised data in a standard plot 

window. 
 
 Tabulate button tabulates the original and revised data in a standard 

table. 
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3.6.2 Editing a Curve with the Line Draw Tool 

 
You can edit data by drawing a curve freehand by moving the mouse from 
left to right while clicking on the left mouse button at selected inflection 
points.  To do this: 
 
 1. Select the data set from the drop down box at the top of the screen 

if it is not selected already. 
 2. Select the Line Draw (multi-point edit)        tool. 
 3. Move the mouse to the left-most position of the curve where you 

want to start editing. 
 4. Click on the left mouse button to mark the first data point. 
 5. Move the mouse right along your desired curve and press the left 

mouse button at inflection points.  The Graphical Editor will 
draw a straight line between points. 

 6. If you make a mistake, you can move the mouse left past that point 
and insert a new inflection point.  You can backup as many points 
at one time as you want. 

 7. When you are finished with a curve segment, press the right mouse 
button.  (That location will not be used as part of the curve.)  The 
line segments just given will be drawn with magenta triangles, and 
those data points are entered in the Estimate/Entry column. 

 8. You can draw other curve segments elsewhere on the plot using 
the same procedure. 

 9. If you need to remove a curve segment that you have drawn, select 
the values for it in the table and press the Estimate button.  The 
original values will be copied into the Estimate/Entry column. 

 10. After completing your curve, press the Accept button or the 
Accept All button to accept all edits.  This will copy the data from 
the Estimate/Entry column into the Revised column and will be 
ready to save to the HEC-DSS file. 

 11. At the end of all of your edits, press the Save      or Save As       
button or select that item from the File menu to store your changes 
in the HEC-DSS file. 

 
 

3.6.3 Editing a Point with the Single-Point Edit Tool 
 
You can edit single data values by double clicking on the new point that 
you want or clicking on the existing point and moving it vertically.  To do 
this: 
 
 1. Select the data set from the drop down box at the top of the screen 

if it is not selected already. 
 2. Click the       Single-Point edit tool. 
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 3. Find the new value of the point on the graph that you want to edit 
and double click the mouse at that location.  This will enter the 
value that you selected into the Estimate/Entry column. 

 4. Edit the remaining points that you desire to have changed and 
when you are complete, press the Accept button or the Accept All 
button to accept all edits.  This will copy the data from the 
Estimate/Entry column into the Revised column and will be 
ready to save to the HEC-DSS file. 

 5. At the end of all of your edits, press the Save      or Save As       
button or select that item from the File menu to store your changes 
in the HEC-DSS file. 

 
You can also grab the point that you want to modify and move it 
vertically.  To do this: 
 
 1. Click the left mouse button on the data point you want to edit.  The 

table row containing that point will be highlighted. 
 2. Press the Estimate Missing button to provide a value to start from, 

unless there is already a value in the Estimate column.  A magenta 
triangle will be drawn at that point on the curve.  To edit existing 
points, double click the point and a magenta triangle will appear. 

 3. Move the mouse over the triangle and press and hold down the left 
mouse button.  Move the mouse up or down to the desired value. 

 4. Edit the remaining points that you desire to have changed and 
when you are complete, press the Accept button or the Accept All 
button to accept all edits.  This will copy the data from the 
Estimate/Entry column into the Revised column and will be 
ready to save to the HEC-DSS file. 

 5. At the end of all of your edits, press the Save      or Save As       
button or select that item from the File menu to store your changes 
in the HEC-DSS file. 

 
3.6.4 Editing Data in the Table 

 
You can edit, add, and delete data in an irregular-interval time series table 
but you cannot extend the table.  Regular-interval values cannot be deleted 
or added but you can change values to missing.  To edit data within the 
table: 
 
 1. Select the data set from the drop down box at the top of the screen 

if it is not selected already. 
 2. Select the row in the table that you want to edit at, or select the 

location on the graph with the mouse after pressing the Select      
tool. 

 3. Type in the new values in the Estimate/Entry column.  To move 
to the next row in the column, press the Tab key or use the up and 
down arrows. 
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 4. You can copy the original value to the 
Estimate/Entry column by selecting 
all data sets you want to change, right-
clicking and selecting Fill - Linear, as 
shown in Figure 3.26. You can then 
change it by pressing the Estimate or 
Estimate All button. 

 5. When complete, press the Accept 
button or the Accept All button to 
accept all edits.  This will copy the data from the Estimate/Entry 
column into the Revised column and will be ready to save to the 
HEC-DSS file. 

 6. At the end of all of your edits, press the Save      or Save As       
button or select that item from the File menu to store your changes 
in the HEC-DSS file. 

 
You can repeat values or linearly interpolate between selected values or 
delete values by using the shortcut shown in Figure 3.26. 
 
To fill multiple values in the table: 
 
 1. Select (highlight) the starting row of the data that you want to fill.  

For linear and repeat fill, this marks the starting value to use, 
which will not be changed.  If the clear fill option is selected, this 
is the first value to be cleared. 

 2. Mark the ending row.  You can do this by holding down the left 
mouse button and moving the mouse down the table, or by left-
clicking the mouse on the ending row while holding down the 
Shift key. 

 3. Right click the mouse button to bring up the popup window in 
Figure 3.26 and then select either Fill – Linear, Fill – Repeat, or 
Clear.  For Linear, the values between the first and last point will 
be linearly interpolated, with the first and last point remaining the 
same.  For Repeat, the first value will be repeated through the last 
value.  For Clear, all values within the selected rows will be set to 
missing. 

 4. When complete, press the Accept button or the Accept All button 
to accept all edits.  This will copy the data from the 
Estimate/Entry column into the Revised column and will be 
ready to save to the HEC-DSS file. 

 5. At the end of all of your edits, press the Save      or Save As       
button or select that item from the File menu to store your changes 
in the HEC-DSS file. 

 
 

Figure 3.26 Shortcut Menu 
Table Fill 
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3.6.5 Printing the Table and Graph 
 
You can print the table or graph by using the Print Table or Print Graph 
command under the Graphical Editor’s File menu. 
 
The Print Table command opens the Properties dialog (Figure 3.27), 
which offers options on three tabs. 
 

 
Figure 3.27  Properties Dialog Box - Printing Tables 
 
The Page tab allows you to specify the page Orientation, Scaling, and 
Selection.  You can also choose to print the table as ASCII, Repeat 
Headers on every page, and print the Gridlines. 
 
On the Header/Footer tab, you can type in the header and footer you want 
to appear on your printed pages. 
 
The Table Title tab offers a default title for the table based on the data 
source, which you can change. 
 
When you click Print, a standard Windows-style print dialog box opens to 
select the printer and printer options. 
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The Print Graph command opens a standard Windows-style print dialog 
box to select the printer and printer options for printing the graph.  The 
printed graph will include the shaded hash area and the current selected 
row line. 
 
You can set the page settings for the printed graph.  To do this, click Page 
Setup from the File menu. 
 
From the File menu, click Page Setup.  The Page Setup dialog will open 
(Figure 3.28).  Here you can set the page Orientation, Margins, Page 
Numbers, and Printer Scale properties. 
 

 
Figure 3.28  Page Setup Dialog Box  
 
The Set Margins button opens the Printer Margins dialog (Figure 3.29). 
 

 
Figure 3.29  Printer Margins Dialog Box  
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3.6.6 Graphical Editor View Options 
 
From the View menu, you can choose to plot the other data sets that you 
have selected on the same plot at the same time by clicking Show 
Comparison Data.  If the data types are the same, the data sets will plot 
in the same viewport; otherwise they will be plotted in different viewports. 
 
You cannot edit the comparison data sets.  To edit comparison data sets, 
you must select a data set from the Selected Data Set list. 
 
You can also display a standard table of the selected data, from the View 
menu, click Tabulate, or to display a standard plot from the View menu, 
click Show Plot.  You can set the precision of decimal places for your 
data by pointing to Decimal Places and selecting the number of decimal 
places you wish to display from the list in the submenu. 
 
 

3.7 Supplemental Information 
 
To view supplemental information, from the DSSVue main window, from 
the Display menu, click Supplemental Information, the Location and 
Supplemental Information dialog box will open (Figure 3.30).  
Supplemental information for a pathname includes the following: 
 

 
Figure 3.30  Location and Supplemental Information Dialog Box  
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 Type: The type of the data in the data set, such as regular-interval 

time series or paired data, etc.  The number is the HEC-DSS 
internal number stored with the data. 

 
 Last Written: The date and time the latest data was written. 
 
 By Program: Displays the name of the program that last wrote this 

data set. 
 
 Record tag: Tag ID used with legacy programs. 
 
 Version: The number of times this data set has been written to.  
 
 Precision: Indicates if this data set is single (4 bytes per value) or 

double precision (8 bytes per value). 
 
 Display Precision: Precision used to view the data in tables.  This 

number is the number of digits to the right of the 
decimal place to show and is automatically set 
when data is entered. 

 
 Compression: Displays the type of compression used if the data 

record has been compressed. 
 
 Password Protected: Displays Yes if the data is password protected. 
 
 Supplemental Info: Meta-data set in the user header.  This can be a 

variety of information, dependent on the 
program that stored it.  Often, data is given in a 
key: parameter format. 

 
 Coordinate System: Coordinate system identifying the location.  

Available coordinate systems include: 
Lat/long, State Plane FIPS, State Plane 
ADS, UTM, or Local (other). 

 
 Coordinate ID: The UTM zone number, or FIPS SPEC number or 

ADS SPCS number. 
 
 Horizontal Datum: Horizontal datum can be either: unset, NAD83, 

NAD27, WAS84, WAS72, or Local (other). 
 
 Datum Units: Units of the datum, including: Not Specified, English, 

SI, Decimal Degrees, or Degrees Minutes Seconds. 
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 X Coordinate: Longitude, Easting or decimal degrees (negative for 
Western Hemisphere). 

 
 Y Coordinate: Latitude, Northing or decimal degrees 
 
 Time Zone ID: Time zone identifier for this location 
 
 Time Zone Offset:  Offset from UTC, in milliseconds. 
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