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CHAPTER 4 
 
 

Utilities 
 
With HEC-DSSVue, you can rename, delete, duplicate, and copy data in 
HEC-DSS files.  You can also compare data sets and whole files to 
determine differences as well as search for values within files. 
 
Other utilities include verifying the database integrity, "squeezing" a 
database to remove unused space, and rebuild tables to make access more 
efficient. 
 
HEC-DSSVue supports Jython (a Python derivative for Java) scripting to 
aid in performing repeated tasks and accessing programming level 
operations. 
 
 

4.1 Renaming HEC-DSS Data in HEC-DSSVue 
 
The Rename Records command opens a pathname editor, which allows 
you to change the common pathname parts of the selected records.  To 
rename HEC-DSS records: 
 
 1. Select the record or records to rename. 
 2. From the Edit menu, select Rename Records.    The Rename 

Records to: dialog will open, see Figure 4.1. 
 

 
Figure 4.1  Rename Records to: Dialog Box 

 
 3. You may change one or more pathname parts or the entire record. 

Type the new Pathname Parts into the A:, B:, C:, D:, E:, and F: 
boxes.  Note:  You cannot change the D or E parts for time series 
data (use Math Functions to accomplish this). 
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 4. For multiple records, pathname parts that are the same for all 
records will show up in the dialog.  Where parts differ (such as 
having pathnames with C parts of FLOW and ELEVATION), the 
part will be displayed with an asterisk (*). 

 5. When you are finished changing the pathnames, click OK to close 
the Rename Records to: dialog and save your changes. 

 
 

4.2 Deleting Records 
 
When you delete data from a HEC-DSS file, the data is marked as missing 
but it is not actually removed from the file until you run a Squeeze of the 
file.  You can recover deleted records with the Undelete command 
described in the next section.  Once a file has been squeezed, records 
cannot be undeleted. To delete records from a HEC-DSS file: 
 
 
 1. Select the record or records to delete. 
 2. From the Edit menu, select Delete Records.  A dialog box will 

confirm that you want to delete those records.  If the number of 
data sets is four or less, their pathnames will be displayed in the 
dialog. 

 3. Click OK.  A confirmation message will appear, stating that the 
records have been deleted. 

 
 

4.3 Undoing Deletions 
 
Deleted records may be recovered as long as the HEC-DSS file has not 
been squeezed.  When a file is squeezed, all deleted records are physically 
removed.  
 
You can undelete records in three ways: undelete all records in the file, 
select the records to undelete from a list, or undelete the records that you 
just deleted.   
 
To undelete records from a HEC-DSS file: 
 
 1. From the Edit menu, point to Undelete. 
 2. To undelete all records click All.  A dialog box will appear to 

confirm that you want to undelete all of the records in the file.  
Click OK.  A confirmation message will appear that states the 
records have been undeleted. 

 3. To undelete the records that you have just deleted clickLast 
Deleted.  A dialog box will confirm that you want to undelete the 
records that you just deleted.  Click OK.  A confirmation message 
will appear that states the records have been undeleted. 
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 4. If you click Select, a list of the previously deleted pathnames will 
open, as shown in Figure 4.2. 

 

 
Figure 4.2  Undelete Records Dialog Box 

 
 5. Check the boxes next to the records that you want to undelete, or 

click Select All to undelete all records in the list.  You can unselect 
the checked records by clicking Unselect All.  Once you have 
made your selection, click OK to undelete those records and close 
the dialog.  Alternatively, you can click Apply to undelete the 
records and leave the dialog box open.  A confirmation message 
will appear stating that the records have been undeleted. 

 
 

4.4 Duplicating Records 
 
The Duplicate command duplicates records in the same HEC-DSS file, 
giving the new records different pathnames.  To duplicate records: 
 
 1. Select the record or records to duplicate. 
 2. From the Edit menu, click Duplicate Records.  The New 

pathname parts for duplicate 5ecords dialog box will open, 
Figure 4.3. 

 

 
Figure 4.3  New pathname parts for duplicate records: Dialog Box 
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 3. Type the new Pathname Parts into the A:, B:, C:, D:, E:, and F: 
boxes. You cannot change the D or E parts for time series data (use 
Math Functions to accomplish this). 

 4. For multiple records, pathname parts that are the same for all 
records will show up in the dialog.  Where parts differ (such as 
having pathnames with C parts of FLOW and ELEVATION), the 
part will be displayed with an asterisk (*). 

 5. When you are finished changing the pathnames, click OK to close 
the New Pathname Parts for Duplicate Records dialog and save 
your changes.  A confirmation message will appear stating that the 
records have been duplicated. 

 
 

4.5 Copying Records into Another HEC-DSS File 
 
To copy records into another HEC-DSS file: 
 
 1. Select the record or records to copy. 
 2. From the Edit menu, click Copy To.  The Copy Records into 

HEC-DSS File browser will open, Figure 4.4. 
 

 
Figure 4.4  Copy Records into HEC-DSS File Browser 

 
 3. In the File name box, type in a new HEC-DSS filename or select 

an existing HEC-DSS File you want to copy the record into and 
click Open.  A confirmation message will appear stating that the 
record has been copied to the HEC-DSS file you selected. 

 4. If the record(s) already exist in that file, a message box will appear 
asking if you want them to be overwritten, Figure 4.5 (page 4-5).   
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Figure 4.5  Message Box - Overwriting Existing Records 

 
  If the number of pathnames is four or less, their names will be 

displayed in the message box; otherwise they will be printed in the 
log screen. 

 
 

4.6 Merging HEC-DSS Files 
 
Merging copies all of the records in the currently opened HEC-DSS file 
into another.  This is similar to selecting all records then using the Copy 
Records option, but is much more efficient.  However, this option will 
overwrite any records with the same pathnames and will not splice 
together time series records.  To merge the current HEC-DSS file into 
another: 
 
 1. From the Edit menu, click Merge (copy).  The Merge (copy all 

records) into HEC-DSS File browser (Figure 4.6) will open. 
 

 
Figure 4.6  Merge (copy all records) into HEC-DSS File Browser 
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 2. In the File Name box, select an existing HEC-DSS File into which 
you want to copy all of the records into and click Open.  A 
confirmation message will appear stating that the records have 
been copied into the HEC-DSS file you selected. 

 
 

4.7 Comparing Data Sets 
 
If you have similar time series data sets, you can compare them and find 
the differences.  The Compare functions will tell you how many values are 
different and highlight them in a table.  You can set options in the 
compare functions to allow a tolerance between values or compare only 
where there are valid values for the same times. 
 
You can compare data sets from the 
Compare data sets menu option from 
the Edit menu (Figure 4.7) of a table 
dialog box.  Also, from the DSSVue 
main window, by selecting the 
pathnames for those data sets and from 
the Tools menu, pointing to Compare 
and selecting on of the available options. 
 
To compare data sets from a table dialog 
box: 
 
 1. At least two pathnames must be selected for comparing data sets to 

work.  Select the records you would like to compare from the 
Selected Pathnames List.  Open a table dialog box, from the Edit 
menu, click Compare data sets. 

 2. A message box will open displaying the number of values that 
differ in the selected data sets (Figure 4.8) and the differences 
between the two data sets will be highlighted in red, as show in 
Figure 4.9 (page 4-7). 

 

 
Figure 4.8  Number of Different Values 

Figure 4.7  Edit Menu 



HEC-DSSVue User's Manual Chapter 4 - Utilities 

4-7 

 
Figure 4.9  Highlight of Differences Between Two Data Sets 

 
To compare data sets from the DSSVue main window: 
 
 1. At least two pathnames must be selected for comparing data sets to 

work.  Select the records you would like to compare from the 
Selected Pathnames List.  From the Tools menu, point to 
Compare, click Data Sets, the Compare Data Sets message box 
will open (Figure 4.10). 

 

 
Figure 4.10  Compare Data Sets Message Box 

 
 2. To view a complete table of the data sets, click Show Full Table.  

To view a table of only the values that differ, click Show Only 
Differences, as shown in Figure 4.11 (page 4-8). 
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Figure 4.11  Display Only the Differences in the Data Sets 

 
Comparing data sets can be customized to include tolerance levels, 
ignoring of missing data, and set to compare only values with matching 
time steps. To use these options, you must compare data sets from the 
DSSVue main window: 
 
 1. At least two pathnames must be selected for comparing data sets to 

work.  Select the records you would like to compare from the 
Selected Pathnames List.  From the Tools menu, point to 
Compare, click Data Sets with Options, the Compare Options 
dialog box will open (Figure 4.12). 

 

 
Figure 4.12  Compare Options Dialog Box 

 
 2. To ignore all missing values during the compare, check Ignore 

Missing Values.  To only compare values at match time steps, 
check Coincident Times Only. 
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 3. In the Allowable Difference area of the Compare Options dialog, 
you can change the allowable tolerance for the comparison.  By 
default the comparison uses no tolerance; the Exact option is 
selected.  Instead of using the exact value, you can choose to allow 
a percent by selecting Percent Difference and entering a percent 
value from 0-100 in the field.  To set a numerical difference, select 
Amount Difference and enter a value in the field. 

 4. When you are finished selecting Compare Options, click OK. 
 5. The Compare Data Sets message box will appear displaying the 

number of values that differ in the selected data sets (Figure 4.13). 
 

 
Figure 4.13  Compare Data Sets Message Box 

 
 6. To view a table of only the values that differ, click Show Only 

Differences.  To view a complete table of the data sets, click Show 
Full Table. 

 
 

4.8 Comparing HEC-DSS Files 
 
Two HEC-DSS files can be compared to determine the differences of 
records contained in each file.  This is useful in determining if a new 
version of a program gives the same answers as an older one.  Individual 
or groups of records within the HEC-DSS files can be compared to 
determine the differences between their data.  Options to compare are 
found under the Compare command.   
 
To compare two HEC-DSS Files: 
 
 1. The current selected HEC-DSS file, displayed on the selected tab 

and in the File Name field, will be compared to a selected HEC-
DSS file you will choose using a file browser.  From the Tools 
menu, point to Compare, click Files, the Compare to HEC-DSS 
File browser open. 

 2. The Compare to HEC-DSS File browser will appear.  Use the file 
browser to select the comparison HEC-DSS file.  Once you have 
selected a file, click Open. 

 3. A message box  will display (see Figure 4.14, page 4-10) , 
summarizing the number of records contained in both of the HEC- 
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Figure 4.14  File Comparison Result Message Box 

 
  DSS files.  To view a list of the different records, click Show 

Differences. 
 4. The Differences window will appear listing all the records that are 

different between the two files as in Figure 4.15. 
 

 
Figure 4.15  Comparing Files - List of records that are different between files 

 
 5. The Compare Records dialog box will open (Figure 4.16) that 

lists records in common between the two files that contain different 
values.  If you want to set a tolerance to compare values with, 
press the Options button. 

 

 
Figure 4.16  Compare Record Dialog Box 

 
 6. The Compare Options dialog box (see Figure 4.17, page 4-11) 

allows you to set options to compare values by ignoring missing 
values (where both values are non-missing) for the same times,  
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Figure 4.17  Compare Options Dialog Box 

 
  compare values for coincident times only (where there are valid 

values in both data sets at the same time), and set a tolerance to 
compare between numbers.  For the tolerance, you can set a 
percent amount that values can differ by or an absolute value that 
they can differ. 

 7. When you select the records that you want to compare and press 
the Compare Records button, a table showing the differences for 
each pair will be displayed.  Values that are different are 
highlighted in red for the file that you are comparing to, as shown 
in Figure 4.18. 

 

 
Figure 4.18  Comparison of Data Sets 
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4.9 Searching for a Value 
 
You can search for a value in time series and paired data sets.  You can set 
a tolerance to search within or you can search for values less than or 
greater than a specified number. 
 
You can tabulate the records that match your specifications.  Those values 
will be highlighted in red.  To search for a value: 
 
 1. Select the data sets that you want to search.  From the Tools menu, 

click Search for Value, the Enter Value to Search for dialog box 
will open (Figure 4.19). 

 

 
Figure 4.19  Enter Value to Search for Dialog Box 

 
 2. From the Enter Value to Search for dialog, enter the value you 

would like to find in the Search for box.  If you would like to 
search within a tolerance for this value, enter the range in the 
Within +- box. 

 3. By default, the search is set to find the exact value, give or take the 
Within value.  However, you can choose to search for values 
Greater Than, Less Than, Greater than or Equal to, or Less 
than or Equal to the 
Search for value. 

 4. Once you are finished 
selecting your search 
criteria, click OK. 

 5. The Found Values 
message box will 
appear (Figure 4.20) 
listing all selected data 
sets that meet your 
search criteria. Figure 4.20  Found Values Message Box 
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 6. To tabulate the search findings, click Yes on the Found Values 
window.  A table will display listing all values that meet the search 
criteria in red, see Figure 4.21 below. 

 

 
Figure 4.21  Found Values from Search 

 
 

4.10 Checking File Integrity 
 
You can check to see if a database has been damaged.  Generally, this is 
rare but occasionally a file can be damaged from disk problems, errant 
programs lost file links or other situations.  Checking file integrity is 
similar to a "Check Disk" in Microsoft Windows. 
 
In addition to checking for damage, checking file integrity will tell you if 
you can improve efficiency by squeezing the database.  However, it is 
usually faster just to squeeze the database than to check for it. 
 
Checking file integrity is a thorough and comprehensive process, so it will 
take time. 
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To check the integrity of an HEC-DSS file: 
 
 1. Open an HEC-DSS file, from the Tools menu, click Check File 

Integrity. 
 2. For larger files, the Database Integrity Check dialog box (Figure 

4.22) will open providing the status of the operation.  There are 
four major steps in the operation.  You can cancel at anytime 
without hurting anything.  Generally, the process goes faster once 
the first step has been completed. 

 

 
Figure 4.22  Database Integrity Check Dialog Box 

 
 3. A status report message window will open (Figure 4.23) after the 

integrity check has finished.  To view the integrity report, click 
View Log. 

 

 
Figure 4.23  Status Report Message Window 

 
 4. If any errors in the database are detected, a message window 

saying so will be displayed (see Figure 4.24, page 4-15).  Due to 
the comprehensive nature of the check, an error is usually reported 
for several processes within the check, so the total number of 
errors reported can be substantially more than there really are. 

 
  If an error is detected, it is recommended that you make a backup 

of your file and then squeeze the file.  Squeezing rebuilds the file, 
using a brute force approach that should retrieve all data possible  
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Figure 4.24  Error from Database Integrity Check 

 
  within the file.  You should review any critical data after you have 

squeezed it, as the same event that broke links within the file may 
have changed data values also. 

 5. If you have a lot of unused space due to deletions or other actions 
or the internal tables are not suited well to the number of data sets, 
a message will be displayed saying so. (Figure 4.25)  It is 
recommended that you squeeze the file to remove unused space 
and rebuild the internal tables. 

 

 
Figure 4.25  Status Report Message After Data Sets are Deleted 

 
 

4.11 Squeezing an HEC-DSS File 
 
When you delete or rename records, a HEC-DSS file will accumulate 
inactive space.  The Squeeze command removes inactive space by 
copying all valid data to a new file then renaming the new file to the old 
filename.  The Squeeze command will also automatically re-adjust 
internal HEC-DSS table sizes to optimize access to the data.  This is 
similar to de-fragmenting your file system.   Once a squeeze has been 
accomplished, deleted data cannot be recovered. 
 
To squeeze an HEC-DSS file: 
 
 1. Open an HEC-DSS file, from the Tools menu, click Squeeze.  A 

window will appear indicating the status of the squeeze process. 
 2. If you wish, you may cancel the squeeze prior to completion, by 

clicking Cancel. 
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 3. When the process is complete, a confirmation will appear (Figure 
4.26). 

 

 
Figure 4.26  Squeeze Confirmation Window 

 
 

4.12 Scripting 
 
You can use Jython scripts that you or others write to perform math 
functions, create custom plots or tables, and automate repetitive tasks.  To 
edit, test, and select scripts, use the Script Editor (Figure 4.27).  To 
access the Script Editor, from the Tools menu, click Script Editor. 
 

 
Figure 4.27  Script Editor 
 
To run scripts that have already been setup, use the Script Selector dialog 
box (Figure 4.28).  To access the Script Selector dialog box, from the 
Tools menu, click Script Selector.  For more information, refer to the 
chapter on Scripting. 
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Figure 4.28  Script Selector Dialog Box 
 
 

4.13 Catalogs 
 
The list of pathnames on the main screen is a modified version of the 
HEC-DSS Catalog.  A catalog is essentially a list of record pathnames in a 
DSS file, organized in one of several ways.  Because a catalog is separate 
and not really part of the DSS file, it only reflects the state of the DSS file 
the last time it was updated.  Whenever you add a new record to the 
database, the catalog becomes out of date; the catalog is not updated as it 
would be prohibitively slow. 
 
The new version of HEC-DSSVue retrieves an internal listing of 
pathnames to show in the main window.   However, since it takes time to 
sort and order them, a cache disk file is usually saved, and only updated 
when it is detected to be out of date.  For larger DSS files, HEC-DSSVue 
will ask the user if they want to spend the time to have it updated when it 
becomes out of date. 
 
This section covers the three primary forms of catalogs that can be stored 
on disk and viewed or printed.  A full catalog is a listing of all record 
pathnames in the file, along with their last written date and time, their 
version, the number of data they contain and the type of data it contains.  
An abbreviated catalog contains just the record pathnames and a 
condensed catalog groups dates for time series data and just shows a date 
span for the date part of a time series data set. 
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4.13.1 Condensed Disk Catalog 
 
A condensed catalog is a list of pathnames where the dates of time series 
data are grouped together and show a date span instead of a date D part for 
each record. 
 
To create a condensed catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Condensed Disk Catalog, click New. 
 2. A message box will appear stating the catalog has been updated 

and the number of records it contained (Figure 4.29). 
 

 
Figure 4.29  Catalog File Update Message Box 

 
To view a condensed disk catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Condensed Disk Catalog, click View. 
 2. A text dialog box will open (Figure 4.30) displaying the condensed 

disk catalog. 
 

 
Figure 4.30  Condensed Catalog Text Output 
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 3. You can print the catalog from the text dialog, from File menu, 
click Print. 

 4. From the text dialog, you can perform several file management 
functions:  Insert .txt, Save As .txt, change the Font, and Print 
Setup.  It also contains a Find menu that can facilitate a search of 
the catalog displayed. 

 
To print a condensed disk catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Condensed Disk Catalog, click Print. 
 2. A Print dialog box will open (Figure 4.31); click OK to send the 

catalog to the printer. 
 

 
Figure 4.31  Print Dialog Box 

 
 

4.13.2 Abbreviated Disk Catalog 
 
An abbreviated catalog is a sorted list of record pathnames in a HEC-DSS 
file. 
 
To create an abbreviated catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Abbreviated Disk Catalog, click New. 
 2. A message box will appear stating the catalog has been updated 

and the number of records it contained (see Figure 4.29, page  
  4-18). 
 
To view an abbreviated catalog: 
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 1. Open an HEC-DSS file, from the Advanced menu, point to 
Abbreviated Disk Catalog, click View. 

 2. A text dialog box will open (Figure 4.32) displaying the 
abbreviated disk catalog. 

 

 
Figure 4.32  Abbreviated Catalog Text Output 

 
 3. You can print the catalog from the text dialog, from File menu, 

click Print. 
 4. From the text dialog, you can perform several file management 

functions:  Insert .txt, Save As .txt, change the Font, and Print 
Setup.  It also contains a Find menu that can facilitate a search of 
the catalog displayed. 

 
To print an abbreviated catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Abbreviated Disk Catalog, click Print. 
 2. A Print dialog box will open (see Figure 4.31, page 4-19); click 

OK to send the catalog to the printer. 
 
 

4.13.3 Full Disk Catalog 
 
A Full Catalog is a listing of all record pathnames in the file, along with 
their last written date and time, their version, the number of data they 
contain and the type of data it contains. 
 
To create a full catalog: 
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 1. Open an HEC-DSS file, from the Advanced menu, point to Full 
Disk Catalog, click New. 

 2. A message box will appear stating the catalog has been updated 
and the number of records it contained (see Figure 4.29, page  

  4-18). 
 
To view a full catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to Full 

Disk Catalog, click View. 
 2. A text dialog box will open (Figure 4.33) displaying the full disk 

catalog. 
 

 
Figure 4.33  Full Disk Catalog Text Output 

 
 3. You can print the catalog from the text dialog, from File menu, 

click Print. 
 4. From the text dialog, you can perform several file management 

functions:  Insert .txt, Save As .txt, change the Font, and Print 
Setup.  It also contains a Find menu that can facilitate a search of 
the catalog displayed. 

 
To print an abbreviated catalog: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to Full 

Disk Catalog, click Print. 
 2. A Print dialog box will open (see Figure 4.31, page 4-19); click 

OK to send the catalog to the printer. 
 
 

4.14 Viewing the Console Output 
 
As the HEC-DSSVue application is running, it generates application 
runtime and DSS file output. To view the output for the current instance of 
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the HEC-DSSVue application, from the Advanced menu, click Console 
Output.  The Console Output dialog box will open (Figure 4.34). 
 

 
Figure 4.34  Console Output Dialog Box 
 
 

4.15 Viewing HEC-DSS File Output 
 
To view the output generated by HEC-DSS file interaction, from the 
Advanced menu, click DSS Output.  A basic text dialog box will open 
(Figure 4.35) displaying application process information on the DSS file. 
 

 
Figure 4.35  DSS Output Dialog Box 
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4.15.1 Program Options 

 
During the process of using HEC-DSSVue, properties are saved to 
maintain a memory of HEC-DSS file history, UI settings, and user 
preferences.  Program Options allow you to re-set any such properties 
back to the default settings that were set when HEC-DSSVue was first 
installed.  Other Program Options include required files to import/export 
SHEF data.  For more information on the SHEF tab, see Chapter 5. 
 
To reset all default properties for HEC-DSSVue: 
 
 1. Open an HEC-DSS file, from the Advanced menu, click Program 

Options, the Options dialog box will open (Figure 4.36). 
 

 
Figure 4.36  Options Dialog Box - General Tab 

 
 2. On the General tab, click the Reset To Program Defaults button. 
 3. A Reset all Program to Default message box will appear (Figure 

4.37), verifying you would like to reset the defaults.  Click Yes. 
 

 
Figure 4.37  Reset Program to Defaults Message Box 

 
 4. Once the program defaults have been set, a message will open 

asking you to exit HEC-DSSVue to complete the reset process 
(Figure 4.38).  Clicking Yes will close HEC-DSSVue, or you can 
choose to exit HEC-DSSVue later by clicking No. If you select 
No, some program settings may remain. 
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Figure 4.38 Reset Program to Default Confirmation 

Window 
 
 

4.16 Advanced Functions 
 
The following sections provide internal information, generally only for 
internal use.  They involve examining and modifying internal file structure 
and settings, changing the trace and output levels, and setting internal 
flags in HEC-DSS.  They are not intended for general use. 
 
 

4.16.1 Memory Monitor 
 
A set amount of memory is allocated for use during the HEC-DSSVue 
application runtime.  The Memory Monitor (Figure 4.39) displays the 
real-time memory used by the HEC-DSSVue application in relation to the 
memory the program has allocated.  To access it, from the Advanced 
menu, point to Status, click Memory Monitor. 
 

 
Figure 4.39  Memory Montior 
 
 

4.16.2 Open List of HEC-DSS Files 
 
A report listing the current open HEC-DSS file in HEC-DSSVue is 
available from the Advanced menu, point to Status, click DSS Files 
Opened.  The report, Figure 4.40 (page 4-25), lists the DSS Trace date 
and time and how many files were accessed.  It also contains access  
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Figure 4.40  HecDSS File Manager Status 
 
information for each file, the number of records accessed, how many of 
these records are currently selected, the file path to the HEC-DSS file that 
contains the file access information, and the number of records accessed 
for the current session of HEC-DSSVue. 
 
 

4.16.3 Viewing the DSS Header List 
 
The DSS Header List displays all the database variables and their values 
used for the current HEC-DSS file.   
 
To view the header list: 
 
 1. Open an HEC-DSS file, from the Advanced menu, point to 

Status, click DSS File Header. 
 2. A dialog box will open (see Figure 4.41, page 4-25) listing all the 

headers set for the current HEC-DSS file. 
 
 

4.16.4 HEC-DSS File Internals 
 
HEC-DSSVue offers tools to aid in viewing information on the current 
HEC-DSS file and debugging problems that might occur during runtime.  
These tools include increasing the Message Level, DSS ZSET, DSS 
ZINQIR, and Debug/Examine File.  The Debug options are intended to 
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be used internally only.  For more information see the separate HEC-DSS 
Programmer’s Manual. 
 

 Message Levels 
 
Message Levels control the detail of the messages written out to the HEC-
DSSVue Console Output.  The higher the Message Level, the more 
messages and detail will be written.  A normal setting is four; above that 
provide debugging output.  This setting is intended to be used by 
programmers only.  For more information on the Message Levels, see the 
separate HEC-DSS Programmer’s Manual. 
 
 

 DSS ZSET 
 
DSS ZSET is a tool for programmers to set file parameters.  For more 
information on the DSS ZSET, see the separate HEC-DSS 
Programmer's Manual. 
 
 

 DSS ZINQIR 
 
DSS ZINQIR is a tool for programmers to query file parameters.  For 
more information on the DSS ZINQIR, see the separate HEC-DSSVue 
Programmer's Manual. 
 
 

 Debug/Examine File 
 
The Debug/Examine File displays the internal contents of a HEC-DSS file 
for internal use.   Modifying values in this dialog can damage files. 
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