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CHAPTER 6 
 
 

Customizing Plots 
 
Plots are highly customizable and offer an array of information that will 
assist you with reviewing your data.  A sample plot illustrating raw and 
revised data for stage and flow at a location called Beech Creek Station is 
shown in Figure 6.1. 
 

 
Figure 6.1  Plot Dialog Box 
 
With the Pointer Tool       , you can access shortcut menus that allow you 
to customize features of your plots using the plot window’s editing tools.  
The following sections discuss these tools in detail. 
 
The Zoom Tool        allows you to "zoom in" and view data more 
precisely at smaller time intervals.  To zoom in, first select the Zoom 
Tool, then hold the left mouse button down and pull down to the right 
forming a square around the area you wish to zoom in to. The plot will 
redraw, magnifying the area in the square when the mouse key is released.  
Right-click to zoom out or from the View menu, click Zoom to all. 
 
If you wish to keep the plot window on top of all open windows on your 
desktop, from the View menu, click Always on Top, a check mark 
indicates this option is active. 
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6.1 Customizing Plots: Overview 
 
Plot properties editors allow you to configure default properties for plots 
as well as customize individual plots.  The features of plots that you can 
configure are shown in Figure 6.2. 
 

 
Figure 6.2  Configurable Features of Plots 
 
 ■ Title: Optionally, you can add a title to the plot display. 
 ■ Panel Background Color: You can specify the background color 

of the plot window.  By default, the panel uses the same 
background color the HEC-DSSVue application uses. 

 ■ Curve: You can choose the line and point styles, add a label, and 
specify data quality symbols to curves. 

 ■ Marker Line:  Marker lines can be added on the X and Y axis.  
You can customize their line styles and give them labels. 

 ■ Viewport Spacer:  You can specify the distance between 
viewports. 

 ■ Callout: You can add descriptive callouts at specific points along a 
curve.  Customize their fonts, borders, and backgrounds. 

 ■ Viewport: You can customize the borders around each viewport, 
their background color, pattern, and transparency, and the 
appearance of the gridlines. 

 ■ Label: Label fonts can be customized by color, style, and size.  
You can also give labels borders and background colors and 
patterns or choose to hide them. 

 ■ Axis:  You can adjust the scale, set a minimum or maximum, 
major and minor tic intervals, reverse the axis, switch x and y, 
change label styles and text, and customize tic marks. 
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 ■ Legend: You can add titles to the plot legend, specify the legend’s 
location in the plot window, add left and right blocks of text or 
graphics, change the background color, pattern, and transparency, 
or remove the legend from the plot window. 

 
 

6.2 Using Plot Editors 
 
Different plot editors allow you to set specific properties for individual 
plots or set default plot properties for all plots.  Three examples of these 
editors: the Default Plot Properties editor, the Plot Properties editor, 
and the Viewport Properties editor are shown in Figure 6.3. 
 

 
Figure 6.3  Examples of Plot Properties Editors 
 
 

6.2.1 Setting Defaults vs. Customizing Individual Plots 
 
Plot editors and tools fall into two categories in terms of function: either 
they allow you to specify defaults for all plots you create or they allow 
you to customize individual plots.   
 
Across these two functional categories, the plot editors and tools allow 
you to edit a variety of plot properties, or they can be specialized editors 
that allow you to edit a single property. 
 
To configure the default appearance of all plots, use the Default Plot 
Properties editor and Default Line Styles options editor.  All settings you 
specify in these editors will apply to future plots you open.  Default editors 
can only be accessed through the plot's Edit menu.   
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To customize individual plots, use the Plot Properties editor and the 
Configure Plot editor, accessed through plot windows using the Edit 
menu.  You can display specific plot property editors by right-clicking on 
components displayed in the plot window.  
  
Once you have customized an individual plot, you can export its settings 
as a Template that can be applied to other plots.  See Section 6.12 for 
more detail on templates. 
 
 

6.2.2 Accessing Editors 
 
You can access plot property editors from shortcut menus and from the 
Edit menu of the Plot dialog box (Figure 6.4). 
 

 
Figure 6.4  Accessing the Plot Property Editors 
 
Use these menus according to whether you are defining properties for an 
individual plot or setting default properties for all plots you create. 
Use shortcut menus to edit specific components of an individual plot.  For 
example, if you want to edit axis label properties on a plot, right-click on 
the axis label (see Figure 6.5, page 6-5), then select Edit Properties from 
the shortcut menu. 
 
Use the Edit menu of a plot window to access the Plot Properties editor, 
Default Line Styles options editor, Default Plot Properties editor, and 
Configure Plot editor.  These editors allow you to edit a variety of plot 
properties. 



HEC-DSSVue User's Manual Chapter 6 – Customizing Plots 

6-5 

 
Figure 6.5  Edit Properties 
 
 

6.3 Plot Editors and Tools 
 
The following sections are an overview of the editing tools that allow you 
to customize plots.  Later sections provide more detailed instructions on 
editing specific plot properties using these tools. 
 
 

6.3.1 Plot Properties Editor 
 
The Plot Properties editor (see Figure 6.6, page 6-6) is accessed from the 
Edit menu of a Plot dialog box by clicking Plot Properties.  It allows you 
to configure multiple display properties for the individual plot, including 
the Curves, Viewport, Title, Axis, Legend, Marker Lines, and the 
Layout or properties of the plot window panel. 
 
When you customize properties of a plot using the Plot Properties editor, 
your changes apply only to the individual plot displayed; unless you 
export the plot’s properties in a template (see Section 6.12). 
 
 

6.3.2 Individual Plot Property Editors 
 
When you want to edit a specific property of a plot without launching the 
Plot Properties editor (discussed in Section 6.3.3), you can use individual  
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Figure 6.6  Plot Properties Editor 
 
plot property editors instead.  These individual plot property editors 
correspond to the tabs of the Plot Properties editor.   
 
To access an individual plot property editor, 
right-click on the component you want to edit 
and then select Edit Properties from the 
shortcut menu.  For example, if you right-click 
inside the gridded plot area, called the viewport, 
you will see the Viewport shortcut menu 
(Figure 6.7).  When you choose Edit 
Properties, the Viewport Properties editor will 
open (Figure 6.8). 
 

 
Figure 6.8  Viewport Properties Editor 

Figure 6.7 Viewport Shortcut 
Menu 
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The Viewport Properties editor lets you edit only properties associated 
with that particular viewport, using the same options that appear for 
viewports in the Plot Properties editor. 
 
Other individual properties editors are the Edit Title Properties, Axis 
Properties, Curve Properties, Label Properties, Marker Properties, and 
Legend Properties.  
 
The only plot property you cannot edit using an individual property editor 
is the Layout.  (See Section Error! Reference source not found. for 
more information.) 
 
 

6.3.3 Configure Plot Editor 
 
The Configure Plot editor (Figure 6.9) is accessed from the Edit menu of 
a plot and allows you to customize the data configuration of an individual 
plot.  You can add and remove axes and add, remove, arrange the order of, 
and set the weight of viewports in the plot window. 
 

 
Figure 6.9  Configure Plot Editor 
 
When you customize the layout of a plot using the Configure Plot editor, 
your changes apply only to that individual plot; unless you create a 
template from the plot’s properties (see Section 6.12). 
 
To access the Configure Plot editor, from the Edit menu, click Configure 
Plot Layout.  See Section 6.11 for more information on this editor. 
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6.3.4 Default Line Styles Options Editor 

 
With the Default Line Styles options editor (Figure 6.10), you can specify 
the default line and fill styles, as well as labels, used across all plots for 
specific parameters. 
 

 
Figure 6.10  Default Line Styles Options Editor 
 
To access the Default Line Styles options editor, from the Edit menu, 
choose Default Line Styles. 
 
Refer to Section 6.5.2 for more information on the Default Line Styles 
options editor. 
 
 

6.3.5 Default Plot Properties Editor 
 
The Default Plot Properties editor (see Figure 6.11, page 6-9) allows you 
to configure the default display properties of all plots you create.  
Properties you can configure include Curves, Viewport, Title, Axis, 
Legend, Marker Lines, and Layout, which include the miscellaneous 
properties of the plot window panel. 
 
When you customize plot properties using the Default Plot Properties 
editor, your changes will apply to all future plots you create.  If you would 
like to apply them to the plot you currently have open, you will need to 
close and then reopen it first. 
 
To access the Default Plot Properties editor, from the Edit menu, click 
Default Plot Properties. 
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Figure 6.11  Default Plot Properties Editor 
 
 

6.4 Customizing Plot Titles 
 
You can add titles to individual plots and configure default properties for 
all plot titles. 
 
To add or edit a title on an individual plot, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Title tab. 
-Or- 

 ■ Right-click in the blank area above the 
plot (below the menu bar) with the 
Pointer Tool      , and then click Edit 
Properties from the shortcut menu 
(Figure 6.12).  The Edit Title 
Properties editor will open. 

 
To specify the appearance of titles for all of your plots, from the Edit 
menu, click Default Plot Properties, then select the Title tab of the 
Default Plot Properties editor. 
 
Whether you are using the Plot Properties editor, the specialized Title 
Properties editor, or the Default Plot Properties editor, the worksheet for 
editing plot title properties is the same.   
 

Figure 6.12 Shortcut Menu - 
Title Properties 
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The Edit Title Properties editor is shown in Figure 6.13.  This editor 
contains the same fields as the Title tab of the Plot Properties editor and 
the Default Plot Properties editor. 
 

 
Figure 6.13  Edit Title Properties 
 
 1. To specify a title for the plot, check Show Plot Title. 
 2. In the Text field, type the title you want displayed in the plot 

window. 
 3. In the Font section of the editor, select the font type from the Font 

dropdown list.  Choose the Style; Bold and/or Italic, Color of the 
font, and a Size of your text. 

 4. The Font section also includes the option to set Use Font Scaling.  
Checking this option and selecting a Min Size and Max Size, will 
set the minimum and maximum size your font can adjust to when 
resizing the plot window.  If this option is not selected, the font 
size will remain constant regardless of the window's size. 

 5. Below the Font section on the editor is the Alignment setting of 
the title. Alignment can display the tile text Center, Left, or 
Right. 

 6. The Border section allows you to add a border around the title.  
You can specify the Color, line Style and Weight. 

 7. The Background section lets you add a background Color and/or 
Pattern behind your plot title.  It also allows you to set the 
Transparency of the background. 

 8. The Sample box provides a preview of your plot title. 
 
Click Apply to save your changes and continue adjusting the appearance 
of the title.  Click OK to save your changes and close the editor. 
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6.5 Customizing Curves 

 
You can customize line and point styles, add labels, and specify symbols 
to indicate data quality in your plots.  Additionally, you can specify the 
parameter-based default curve styles used across all plots. 
 
There are three different ways to edit plot curves, depending on whether 
you wish to customize one or more curves in an individual plot or specify 
defaults for all plots. 
 
 

6.5.1 Customizing Curves in Individual Plots 
 
To customize all curves in an individual plot, from the Edit menu, choose 
Plot Properties.  Once the Plot Properties editor opens, select the 
Curves tab. 
 
To customize a specific curve in an individual plot, right-click on the line 
or curve you wish to edit using the Pointer Tool       , then select Edit 
Properties from the shortcut menu (Figure 6.14).  The Edit Curve 
Properties editor will open. 
 

 
Figure 6.14  Shortcut Menu - Curve Properties 
 
The Curves tab of the Plot Properties editor and the Edit Curve 
Properties editor are nearly identical with one exception.  At the top of 
the Curves tab of the Plot Properties editor, there is a list of all curves 
contained in the plot.  In contrast, when you open the Edit Curve 
Properties editor, only the selected curve’s DSS Path is displayed. 
 
Both the Edit Curve Properties editor and the Curves tab of the Plot 
Properties editor allow you to edit Style, Label, Legend Item, and 
Quality Symbols (you can edit Quality Symbols only if the plot has 
quality defined data). 
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6.5.2 Specifying Parameter-Based Default Curve Styles 

 
To specify parameter-based default curve styles for all of your plots, from 
the Edit menu, click Default Line Styles.  The Default Line Styles 
options editor will open (see Figure 6.10, page 6-8). 
 
The Default Line Styles options editor gives you a way to edit line styles 
from the Line Styles box (Figure 6.15).  You can specify the default, 
parameter-based curve styles used for all plots. 
 

 
Figure 6.15  Default Line Style Options Editor: Detail of Line Styles Box 
 
The Line Styles table displays typical data types with default line and fill 
styles predefined. 
 
You can edit all of these fields, change default line and fill styles for 
existing types, and add new data types to the list (currently, there is no 
delete option). 
 
The Line Styles table columns are described below in detail: 
 ■ Name The Name corresponds to the "C" part of HEC-DSS 

pathnames.  To edit an existing name, highlight it, and 
then type in the new Name. 

 ■ Parameter The Parameter is what distinguishes data sets and 
groups them together in the same viewport.  For 
example, FLOW-IN and FLOW-OUT have different 
Names or "C" parts, but both are Parameter 
“FLOW” data sets, so they will be plotted in the same 
viewport. 

 ■ Type The Type describes the regular and irregular interval time 
series record data, either INST-CUM (instantaneous 
cumulative), INST-VAL (instantaneous value), PER-
AVER (period average), PER-CUM (period cumulative), 
or ALL.  To change the data Type associated with a 
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Name and Parameter, click the down-arrow and select 
from the preexisting list. 

 ■ Line Number The Line Number column indicates the number of 
lines/curves displayed in the viewport and what 
style will be associated with that data.  For 
example, if you have three curves in a viewport 
each with the same Name, Parameter, and Type, 
the first line will be assigned the Line/Fill 
associated with Line Number 1; the second will 
use Line Number 2, the third Line Number 3, and 
so on.  If there is only one line displayed in the 
viewport for that data set, it will use the Line 
Number 1 line style.  See Adding New Data 
Styles below to add more Line Numbers to a 
particular data set. 

 ■ Line/Fill The Line/Fill property determines how curves 
associated with a particular Name/Parameter/Type 
combination will appear in all plots.  To specify the 
Line/Fill, select the row, and then customize the Line 
and Point properties as discussed in Section 6.5.4. 

 
 

6.5.3 Adding New Data Styles 
 
To add a new data type (i.e. insert a row in the Line Style table): 
 
 1. From the File menu of the Default Line Styles options editor, 

choose New Parameter.  The New Data Type dialog box will 
open (Figure 6.16). 

 

 
Figure 6.16  New Data Type Dialog Box 

 
 2. Select a parameter from the Parameter list. 
 3. Enter a name in the Name box. 
 4. From the Type list, select the data type. 
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 5. In the Number of Lines box, enter the number of curves you want 
to add for this new data type. 

 6. If you want to reverse the Y-axis, select Y Axis Reversed. 
 7. Click OK to save and close the dialog box. 
 
The Line Styles table will display the new data type you have added, 
repeated as many times as you specified in the Number of Lines box 
(reflected in the Line Number column).  You can customize the new data 
types as described above. 
 
To save your changes, from the File menu, click Save.  To close the 
Default Line Styles options editor, from the File menu, click Close. 
 
 

6.5.4 Specifying Line and Point Styles of Curves 
 
The curve Line and Point Style worksheet is shown in Figure 6.17.  This 
worksheet is available from the Curves tabs of the Edit Curve Properties 
editor, the Plot Properties editor, and the Default Line Styles options 
editor (Section 6.2). 
 

 
Figure 6.17  Curve Line and Point Style Editing Interface 
 
The Style tab has three main groups, Line, Point, and Missing Value 
Symbols which allow you to customize line and point styles, and a 
separate symbol that can be shown for missing values.  Beneath the Point 
group, the Sample box provides a preview of how your line and point 
choices will look.  
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To define line styles for curves: 
 
 1. In the Line group, click Draw Line. 
 2. Select a Color, Style, and Weight for the line. 
 3. You can display lines with fill above or below, or without fill.  A 

plot with line fill below is shown in Figure 6.18, whereas the same 
plot without line fill is shown in 
Figure 6.19.  To set this feature 
use the Fill selections; None, 
Below, or Above.  Then choose 
the Fill Color and Fill Pattern for 
the fill using the color and pattern 
dropdown lists located below the 
Fill section. 

 4. In the Type section, select if you want the curve drawn Stepped, 
in a stair-stepped style, or Linear, 
with a line drawn directly between 
each point. 

 5. If you would like to see missing 
values, check Draw Missing 
Value Symbols and select a Style, 
Line Color, Fill Color, and Size 
for the missing value points. 

 
To define Point styles for curves: 
 
 1. In the Point group, click Draw Points. 
 2. Choose the Style, Line Color, 

and Fill Color you want.  The 
Line Color is the “border” around 
the point symbol.  The Fill Color 
is the color inside the point 
symbol.  An example of a dark 
blue Line Color and a light blue 
Fill Color is illustrated in Figure 
6.20. 

 3. In the Size box, specify the size of 
the point (in pixels) either by 
selecting a size from the list or by 
typing in a number from 1- 45. 

 4. Automatic Symbol Drawing allows the program to determine the 
number of points to display on a curve.  The program will 
automatically calculate how many data points can display on the 
curve before they start to overlap one another.  Not all points will 
be displayed.  If the points overlap at the zoom level you view the 
plot at, the program will determine how many points can display  

Figure 6.18  Plot with Line Fill 

Figure 6.19  Plot without Line Fill 

Figure 6.20 Example Line and Fill 
Colors 
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  separately on the curve and only display those points.  As you 
zoom in, the plot will draw more and more points, as long as they 
do not touch. 

 5. Draw Symbols on Data Points allows you to specify how to draw 
the points so they don’t overlap.  If you set the Skip box to one (1), 
then it will draw one point, skip the next, then draw the third, etc.  
The Offset box allows you to say how many points on the curve to 
initially skip before drawing points. 

 
To define missing value symbols for curves: 
 
 1. In the Missing Value Symbols group, click Draw Missing Value 

Symbols. 
 2. Choose the Style, Line Color, and Fill Color you want.  The Line 

Color is the “border” around the point symbol, whereas the Fill 
Color is the color inside the point symbol.  Figure 6.20 (page 6-15) 
shows an example of a dark blue Line Color and a light blue Fill 
Color. 

 3. In the Size box, specify the size of the point (in pixels) either by 
selecting a size from the list or by typing in a number from 1- 45. 

 4. This will place the selected symbol on each missing value. 
 
 

6.5.5 Customizing Curve Labels 
 
The curve Label worksheet, available from the Curves tabs of the Edit 
Curve Properties editor, the Plot Properties editor, and the Default Line 
Styles options editor (Section 6.2) are shown in Figure 6.21.  This 
worksheet allows you to customize curve labels. 
 

 
Figure 6.21  Curve Label Editing Tab 
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To customize curve labels: 
 
 1. Check the Show Label checkbox. 
 2. Enter the text you want to appear in the curve label in the Label 

Text box.  You can also use text substitution for a curve label; see 
Section 6.16 for more information. 

 3. Using the Alignment list to select the horizontal position of the 
label on the curve; Left, Center, or Right. 

 4. To set the vertical position of the label on the curve, from the 
Position list, click Above, Center, or Below. 

 
The Sample box at the bottom of the editor provides a preview of how 
your label will display. 
 
 

6.5.6 Customizing Legend Items 
 
See Section 6.9.3 for information on customizing legend items. 
 
 

6.5.7 Customizing Curve Quality Symbols 
 
The curve Quality Symbols worksheet, available from the Curves tabs of 
the Edit Curve Properties editor, the Plot Properties editor, and the 
Default Line Styles options editor (Section 6.2) are shown in Figure 6.22.  
This worksheet allows you to customize curves for plots that have quality 
set for their data. 
 

 
Figure 6.22  Curve Quality Symbols Editing Tab 
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To customize quality symbols: 
 
 1. Check the Draw Quality Symbols checkbox. 
 2. Select a symbol Style, Line Color, Fill Color, and Size for each 

quality of data; Valid, Questionable, Rejected, and Missing. 
 
 

6.6 Customizing Viewport Properties 
 
Viewports are the gridded areas in the plot window that contain plot 
curves.  You can customize the border around the viewport, the 
background color and pattern, and the appearance of gridlines. 
 
 

6.6.1 Customizing Viewport Borders and Background 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Viewport tab. 
-Or- 

 ■ Right-click in a blank area inside 
the viewport with the Pointer Tool 

        , and then click Edit 
Properties from the shortcut menu 
(Figure 6.23).  The Viewport 
Properties editor will open. 

 
To specify the default border and 
background of viewports for all of your plots use the Default Plot 
Properties editor; from the Edit menu, click Default Plot Properties.  
Once the Default Plot Properties editor opens, select the Viewport tab.  
Changes made in the Default Plot Properties editor will apply to all 
viewports. 
 
The Viewport (#,#) Properties editor, which displays the viewport 
number in the title bar is shown in Figure 6.24 (page 6-19).  This number 
reflects the position of the viewport on the Plot dialog box.  For example: 
if you had two viewports in you plot, the top viewport’s number will 
display as (1,1).  The bottom plot would display as (2,1).  The worksheet, 
accessed from the shortcut menu, contains the same items as the Viewport 
tab of the Plot Properties editor and the Viewport tab of the Default Plot 
Properties editor.  In the Plot Properties editor there is a Select 
Viewport list when multiple viewports are displayed in the plot.  Select 
the viewport you would like to edit using this list. 
 
The Viewport tab has six main groups: Major X Grid, Major Y Grid, 
Minor X Grid, Minor Y Grid, Border and Background.  

Figure 6.23 Shortcut Menu - 
Viewport Properties 
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Figure 6.24  Viewport Properties Editor - Patterns Tab 
 
To customize the Border and Background of a Viewport: 
 
 1. Check the Draw Border checkbox at the top of the Border group 

and choose the Color, Style, and Weight for the border line you 
want to appear around the selected viewport. 

 2. Select Draw Background in the Background group and choose 
the Color, Pattern, and Transparency you want for the 
background. 

 
Click Apply to save your changes and continue adjusting the appearance 
of the border and background.  Click OK when you are finished. 
 
 

6.6.2 Customizing Viewport Gridlines 
 
To customize gridlines of viewports in an individual plot, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Viewport tab. 
-Or- 

 ■ Right-click in a blank area inside the viewport with the Pointer 
Tool      , and then click Edit Properties from the shortcut menu 
(see Figure 6.23, page 6-18). 

 
To specify viewport gridlines for all of your plots, from the Edit menu, 
select Default Plot Properties.  Once the Default Plot Properties editor 
opens, choose the Viewport tab. 
 
By default, the plot viewport displays gridlines only for the Major X Grid 
and Major Y Grid.  The default color is light gray.  To change the 
appearance of Major X and Y gridlines, select the Color, Style, and 
Weight of the gridlines located under their respective groups. 
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By default, the Minor X Grid and Minor Y Grid are not selected to draw 
and do not display in the plot viewport. If you want to display gridlines for 
the Minor X Grid and Minor Y Grid, check the Draw Minor X Grid 
and Draw Minor Y Grid checkboxes and then make your selections for 
Color, Style, and Weight (Figure 6.25). 
 

 
Figure 6.25  Viewport Properties Editor - Gridlines Tab 
 
Click Apply to view your changes without closing the editor.  Click OK 
when you are finished. 
 
 

6.7 Adding and Customizing Marker Lines 
 
You can add marker lines on your plot’s X and Y axes and customize the 
appearance of these markers, as displayed in the top viewport in Figure 
6.26. 
 

 
Figure 6.26  Adding Marker Lines to Plots 
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6.7.1 Adding Markers 
 
To add a marker: 
 
 1. Right-click on the location in the 

plot where you want the marker to 
appear. 

 2. From the Viewport shortcut menu 
(Figure 6.27), point to Add 
Marker, and then click either On 
X-Axis or On Y-Axis. 

 
The marker will now appear in the plot. 
 
 

6.7.2 Deleting Markers 
 
To delete a marker line in a plot, right click 
on the plot with the Pointer Tool,      from 
the shortcut menu, click Delete (Figure 
6.28). 
 
 

6.7.3 Customizing Markers 
 
To edit the properties of a marker in an individual plot, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Marker Lines tab.  This 
worksheet is available only if a marker exists in the plot.  Choose 
the marker you want to edit from the Marker Lines list. 

-Or- 
 ■ With the Pointer Tool      , right-click on the marker you want to 

edit.  From the Marker Line shortcut menu, click Edit Properties 
(Figure 6.28).  The Edit Marker Line Properties dialog box will 
open. 

 
To specify the default appearance of markers for all of your plots, from 
the Edit menu, click Default Plot Properties.  Once the Default Plot 
Properties editor opens, choose the Marker Lines tab. 
 
The interfaces for the specialized Edit Marker Line editor and the 
Default Plot Properties editor are very similar.  However, the Plot 
Properties Editor dialog box differs in two ways.  First, the Marker 
Lines worksheet is available only if a marker exists in the current plot.  
Second, at the top of the editing panel there is a Marker Lines list 
containing all markers that exist in the current plot. 

Figure 6.27 Shortcut Menu - Add 
Marker 

Figure 6.28 Shortcut Menu - Marker 
Line Properties 
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You can edit the line style and label of a marker through this worksheet. 
The Edit Marker Line Properties editor is shown in Figure 6.29.  The 
Marker Line tabs in the Plot Properties editor and the Default Plot 
Properties editor use similar worksheets as well. 
 

 
Figure 6.29  Marker Line Properties Editor - Style Tab 
 
To edit the line style for markers: 
 
 1. Select the Color, Style, and Weight 

for the marker line. 
 2. You can display marker lines with a 

Fill Above or Below the line.  A plot 
with the Fill Above and a hatched Fill 
Pattern selected using a red Fill Color 
is shown in Figure 6.30. 

 
The Sample box, located in the lower left-
hand corner of the worksheet, provides a 
preview of the new marker line.  
 
Click Apply to save your changes without closing the editor.  
 
To add a label to a marker line: 
 
 1. In the Label group, check the Draw Label checkbox and type the 

label name into the Text field. 
 2. In the Font section, select the labels Font, Style, Color, and Size. 
 3. Check Use Font Scaling if you would like to limit the size of the 

font when zooming in and out of the plot.  Set the Min Size and 
Max Size limits. 

Figure 6.30 Marker Line with 
Fill Above 
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 4. From the Alignment list, select the justification of the label; Left, 
Center, or Right of the marker line. 

 5. Set the position of the label from the Position list, either Above, 
Center, or Below the marker line. 

 
Set the position of the label from the Position list, either Above, Center, 
or Below the marker line. 
 
 1. If the marker line is on a date, the 

Date field will be displayed on the 
top of the worksheet. 

 2. To change the date, either enter the 
date in the format DDMMYYYY 
(e.g., 21Dec1993) or click the ellipse 
button      to access the Calendar 
Tool (Figure 6.31). 

 3. For the Time value, enter the time in 
24-hour military format (e.g., for 5:08 
pm, enter "1708"). 

 4. If the marker line appears on a 
specific value, the Value field will 
display at the top of the worksheet 
instead of the Date field.  To change 
this value, simply enter a new value 
in the field. 

 
 

6.7.4 Editing Callouts 
 
You can add descriptive callouts at specific points 
along a curve (Figure 6.32).  To add callouts: 
 
 1. Right-click on the location on the curve where 

you want the callout to appear. 
 2. From the shortcut menu (Figure 6.33), select Add Callout. 
 

 
Figure 6.33  Shortcut Menu - Add Callout 

 
 3. In the Add Callout dialog box (see Figure 6.34, page 6-24), enter 

the text you want to appear in the callout, and then click OK. 
 

Figure 6.31  Calendar Tool 

Figure 6.32  Callout 
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Figure 6.34  Add Callout Dialog Box 

 
To hide all callouts on a curve, right-click on the curve in the plot, or in 
the legend, and select Hide Callouts from the shortcut menu. 
 
Once you have hidden callouts, Hide Callouts in the shortcut menu 
changes to Show Callouts; allowing you to return callouts to the plot.  To 
permanently remove all callouts from a curve, right-click on a curve in the 
plot, or in the legend, and click Clear Callouts from the shortcut menu. 
 
 

6.8 Customizing Axes 
 
You can choose either a linear or log axis type, specify the axis scale, 
modify tic marks, and customize axis labels.  Probability plots are 
generated for paired data sets with a type of "PROB", and cannot be 
changed without changing the data type. 
 
 

6.8.1 Changing Axis Type 
 
By default, plots display using a linear scale (Linear Axis), in which the 
axis increases and decreases by x.  You can also use the log scale, which 
allows you to view curves that grow exponentially in a near straight line, 
because the axis increases or decreases by the log (x).  For example, you 
might wish to use the log scale when the axis has evenly-spaced major tics 
with values of 1,10,100,1000, and so on, such as in a performance history 
plot showing many years of data. 
 
To change the axis type of an individual plot, right-click on an axis, then 
from the Axis Tics shortcut menu, point to Set Axis Type, click Log Axis 
or click Linear Axis; depending on which axis type is already in use.  In 
Figure 6.35, the axis is using a Linear Axis, so the choice available is Log 
Axis. 
 

 
Figure 6.35  Shortcut Menu - Set Axis Type 

 



HEC-DSSVue User's Manual Chapter 6 – Customizing Plots 

6-25 

 
6.8.2 Specifying Axis Scale 

 
You can specify the axis scale and tic interval for individual plots.  To do 
this, select the editor either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Axis tab.  From the Axis 
worksheet, select the axis you want to edit from the Axis list.  
Then select the Scale tab. 

-Or- 
 ■ Right-click on the axis using the 

Pointer Tool      and from the Axis Tics 
shortcut menu (Figure 6.36), click Edit 
Properties.  When the Axis Properties 
dialog box opens, click the Scale tab. 

 
The Plot Properties editor with the Axis tab selected and the Scale 
worksheet open is shown in Figure 6.37.  The Axis worksheets of the Plot 
Properties editor and the Default Plot Properties editor are nearly 
identical, except for the Axis list on the Plot Properties editor.  The Axis 
Label and Tics sub-worksheets are available in all three editors. 
 

 
Figure 6.37  Plot Properties Editor - Scale Worksheet 
 

Figure 6.36 Shortcut Menu - 
Axis Tics 
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With the Scale worksheet, you can specify the range of the scale, the 
amount of the scale that is visible, and the tic intervals.   
If the checkboxes under the Auto heading are checked, the plot will 
automatically select the scale.  Otherwise, as you zoom in and out of the 
plot, its view values change while the minimum and maximum scale range 
values remain fixed: 
 
 ■ Maximum: enter the value of the maximum range of the scale. 
 ■ Minimum: enter the value of the minimum range of the scale. 
 ■ View Maximum: enter the maximum visible range of the scale. 
 ■ View Minimum: enter the minimum visible range of the scale. 
 
Tic intervals are the distances between tics on the axis scale: 
 
 ■ Major Tic Interval:  specify the distance between each major tic. 
 ■ Minor Tic Interval:  specify a value less than or equal to the 

major tic value. 
 
You can also choose to reverse the axis and invert the data by selecting 
Reverse (Invert) Axis.  If the data set is paired, you can switch the X and 
Y axis, so what is plotted on the X axis becomes plotted on the Y axis 
instead. 
 
Click Apply to save and view your changes without closing the editor.  
Click OK to save your changes and close the editor. 
 
 

6.8.3 Modifying Tic Marks 
 
You can modify the color of tic marks, choose whether or not major and 
minor tic marks display, and specify whether labels display.  (See also 
"Specifying Axis Scale" in Section 6.8.2 for information about modifying 
tic intervals.) 
 
To modify tic marks in an individual plot, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, click the Axis tab.  From the Axis 
worksheet, select the axis you want to edit from the Axis list.  
Once you have this set, click the Tics tab to set tic marks. 

-Or- 
 ■ Right-click on the axis using the Pointer Tool      and from the 

Axis Tics shortcut menu (see Figure 6.36, page 6-25), click Edit 
Properties.  When the Axis Properties dialog box opens, click the 
Tics tab. 
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To specify default settings for axis tics in all of your plots, click Default 
Plot Properties from the plot Edit menu.  Once the Default Plot 
Properties editor opens, choose the Axis tab, then the Tics tab. 
 
The Tics worksheet of the Axis Properties editor is shown in Figure 6.38 
above.  The Tics worksheet is nearly identical on the Axis Properties 
editor, Plot Properties editor, and Default Plot Properties editor.   
 

 
Figure 6.38  Axis Properties Editor - Tics Tab 
 
However, at the top of the Plot Properties editor is an Axis list containing 
all of the axes available for editing in the selected viewport.  In the Plot 
Properties editor, you must choose an axis to edit before you can make 
any changes to the tics. 
 
By default, plot axes display major tic marks with labels.  To turn these 
defaults off, uncheck the Use major tick marks and Show Tic Labels 
check boxes by clicking on them. 
 
You can also select Use minor tic marks, to display the minor tic marks 
in the viewport. 
 
To change the Tic Label: 
 
 1. The tic and tic labels use the same color.  To change their color, 

select a new color from the Color list in the Tic Labels group. 
 2. Select the label’s typeset using the Font list.  The font can display 

as Bold or Italic by checking the checkboxes next to either Style 
option. 
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 3. By default the Size is ignored, and Use Font Scaling is selected.  
Use Font Scaling allows the program to determine the best font 
size to display, using the Min Size and Max Size to limit the range 
of the font size. 

 
Click Apply to save and view changes without closing the editor.  Once 
you are done making changes in the editor, click OK to save the changes 
and close the editor. 
 
 

6.8.4 Customizing Axis Labels 
 
You can add borders and backgrounds to axis labels.  To customize axis 
labels in an individual plot, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, select the axis label's viewport in the 
Select Viewport list at the top of the editor.  Then click the Axis 
tab.  On the Axis worksheet, select the axis you want to edit from 
the Axis list, and then click the Axis Label tab to set axis label 
properties. 

-Or- 
 ■ Right-click on the axis label with the 

Pointer Tool      .  From the Axis Label 
shortcut menu (Figure 6.39), click Edit 
Properties.  The Label Properties editor 
will open. 

 
To specify default settings for axis labels in all of your plots, select 
Default Plot Properties from the plot’s Edit menu.  Once the Default 
Plot Properties editor opens, choose the Axis tab, then the Axis Label 
tab. 
 
The Label Properties editor is shown in Figure 6.40 (page 6-29).  The 
same worksheet is available on the Axis Label tabs of the Plot Properties 
editor and Default Plot Properties editor, with a few differences.  The 
Plot Properties editor has an Axis list containing all of the axes available 
for editing in the current selected viewport, which is displayed in the 
Select Viewport list. 
 
The Axis Label worksheet has three groups: Font, Border and 
Background.  The Sample box, located at the bottom left of the editor, 
provides a preview of the label changes.   
 
The current label text is displayed in the Text box.  To change the 
wording, highlight the displayed text in the box and type in the new axis  

Figure 6.39 Shortcut Menu - 
Axis Label 
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Figure 6.40  Label Properties Editor 
 
label name.  Text substitution can also be used here.  See section 6.16 for 
more information on text substitution. 
 
The font of the axis label can be customized using the tools located under 
the Font group.  The text typeset can be changed using the Font list.  The 
Style of the font can be changed by checking either the Bold or Italic 
checkboxes.  Choose the color of your font in the Color list.  By default 
the Use Font Scaling checkbox is set.  This option allows the program to 
determine the best size of the font, limiting the range between the selected 
Min Size and Max Size.  Otherwise, you can un-checking the Use Font 
Scaling and set a constant font size in the Size list. 
   
The Alignment list allows you to position the label, Left, Right, or Center, 
relative to the axis. 
 
To add a border around the axis label, check the Draw Border checkbox 
in the Border group, and then select the Color, Style, and Weight for the 
borderline. 
 
To add a background to the axis label, check the Draw Background 
checkbox in the Background group, and then select a Color, Pattern, and 
the Transparency level.  
 
Use the Show Axis Label checkbox to add or remove the axis label from 
the plot window. 
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Click Apply to save and view your changes without closing the editor.  
Click OK when you are finished editing axis label properties. 
 
 

6.9 Customizing Legends 
 
As illustrated in Figure 6.41, you can add titles to a plot legend, add text 
and graphics to the right and left sides of the Legend box, and customize 
the curve labels in the Legend box.  You can also specify whether the 
legend appears below, to the right, or inside the plot's viewports.  The 
legend can even be displayed in a separate window or hidden from 
display. 
 

 
Figure 6.41  Customizing Legends 
 
To add a title or side blocks to an individual plot’s legend, you can either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, select the Legend tab. 
-Or- 

 ■ Right-click in a blank area inside the 
legend panel of the plot with the Pointer 
Tool      .  From the Legend Panel 
shortcut menu (Figure 6.42), click Edit 
Properties. The Legend Properties 
editor will open. 

 
To specify default settings for all of your plot legends, from the Edit 
menu, click Default Plot Properties.  Once the Default Plot Properties 
editor opens, select the Legend tab. 
 
Whether you are using the Plot Properties editor, Legend Properties 
editor, or Default Plot Properties editor, the worksheet for editing legend 
titles is the same. 
 
The Legend Properties editor is shown in Figure 6.43 (page 6-31).  This 
worksheet, accessed from the shortcut menu, contains the same fields as 
the Legend worksheets of both the Plot Properties editor and the Default 
Plot Properties editor. 
 
To remove the legend from the plot window, uncheck the Show Legend 
checkbox on the editor, or from the plot window’s View menu select Hide 
Legend.  If you would like to add the legend back to the plot window,  

Figure 6.42 Shortcut Menu - 
Legend Panel 
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Figure 6.43  Legend Properties Editor 
 
either re-check the Show Legend box on the editor, or on the plot window 
from the View, click Show Legend. 
 
 

6.9.1 Legend Title 
 
To add and customize a title for the legend: 
 
 1. On the Legend Title tab, select the Draw Legend Title checkbox.  

Then enter the title you want to appear along the top of the legend 
in the Text box. 

 2. In the Font group, select the typeset for the title in the Font list. 
The Style of the font can also be changed by checking either the 
Bold or Italic checkboxes. 

 3. By default the Use Font Scaling checkbox is set.  This option 
allows the program to determine the best size of the font, limiting 
the range between the selected Min Size and Max Size.  
Otherwise, you can un-checking the Use Font Scaling and set a 
constant font size in the Size list. 

 4. Select the Alignment to position the title to the Left, Right, or 
Center of the legend. 

 5. If you would like the title to use a custom border check the Draw 
Border checkbox in the Border group.  Then select the Color, 
Style, and Weight for the borderline. 
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 6. Similarly, if you would like the title to use a custom background 
check the Draw Background checkbox in the Background group.  
Then select the Color, Pattern, and Transparency for the title’s 
background. 

 7. The Sample box in the lower left corner will display a preview of 
your title. 

 
 

6.9.2 Legend Blocks 
 
To add and customize a Left or Right Block to the legend: 
 
 1. First select the Left Block or Right Block tab in the Legend 

Properties editor and check the Draw Left Legend Block or the 
Draw Right Legend Block checkbox; depending on which 
workbook you are editing.  The workbooks are identical, except for 
these Draw checkboxes. 

 2. Type in the text for the block in the Text box. 
 3. In the Font group, select the typeset for the block in the Font list. 

The Style of the font can also be changed by checking either the 
Bold or Italic checkboxes. 

 4. By default the Use Font Scaling checkbox is set.  This option 
allows the program to determine the best size of the font, limiting 
the range between the selected Min Size and Max Size.  
Otherwise, you can un-checking the Use Font Scaling and set a 
constant font size in the Size list. 

 5. Select the Alignment to position the block’s text to the Left, 
Right, or Center of the legend. 

 6. If you wish to display a graphic in the block, under the Icon group 
either type the exact path* and filename of the image in the File 
field, or use the ellipse button      to use a file browser to find and 
select the image. 

 7. If you would like the block to use a custom border, check the 
Draw Border checkbox in the Border group.  Then select the 
Color, Style, and Weight for the borderline. 

 8. Similarly, if you would like the block to use a custom background, 
check the Draw Background checkbox in the Background group.  
Then select the Color, Pattern, and Transparency for the title’s 
background. 

 9. The Sample box in the lower left corner will display a preview of 
your legend block. 

 
To move the legend to a new location, either select the location in the 
Legend Position list on the Legend tab of the editor or from the plot 
window, from the View menu, click Legend Placement.  By default the 
legend is placed at the Bottom of Panel.  Other options include: Right of 
Panel, Separate Window, Viewport Upper Left, and Viewport Upper 
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Right.  If the legend displays in the viewport, the title and legend blocks 
will not appear, (Figure 6.44). 
 

 
Figure 6.44  Viewport Upper Left 
 
If the Legend Position is set for Right of Panel and the legend contains 
right and left blocks, the left block will be removed and the right block 
will display on the bottom of the legend, (Figure 6.45). 
 

 
Figure 6.45  Viewport Right of Panel 
 
Click Apply to view your changes without closing the editor.  When you 
are done making changes to the legend click OK to save your changes and 
close the editor. 
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6.9.3 Customizing Legend Items 
 
By default, the curves display their DSS Pathnames inside the legend.  
However, the legend labels, named Legend Items, can be customized for 
individual curves. 
 
To change a curve's Legend Item in an individual plot’s legend, you can 
either: 
 
 ■ From the Edit menu, click Plot Properties.  When the Plot 

Properties editor opens, select the Curves tab, then the Legend 
Item tab (Figure 6.46). 

 

 
Figure 6.46  Legend Item Curve Properties Editor 

 
-Or- 

 ■ Right-click on a Legend 
Item (curve label) in the 
legend with the Pointer 
Tool      .  From the 
shortcut menu (Figure 
6.47), select Edit 
Properties. The Curve 
Properties editor will 
open. 

Figure 6.47  Shortcut Menu - Legend Curves 
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To specify default settings for all plot Legend Items, from the Edit menu, 
click Default Plot Properties.  Once the Default Plot Properties editor 
opens, select the Curves tab, then the Legend Item tab.  Whether you are 
using the Plot Properties editor, Legend Properties editor, or Default 
Plot Properties editor, the worksheet for editing Legend Items is the 
same. 
 
 
To customize a Legend Item: 
 
 1. Enter the text you would like to display in the legend for the curve 

in the Text box.  Text Substitution can also be used here, see 
Section 6.16 for more information. 

 2. In the Font group, select the typeset for the legend item in the 
Font list. A Style can be used for the font by checking the Bold 
and/or Italic checkboxes. 

 3. By default, the Use Font Scaling checkbox is set.  This option 
allows the program to determine the best size of the font, limiting 
the range between the selected Min Size and Max Size.  
Otherwise, you can un-checking the Use Font Scaling and set a 
constant font size in the Size list. 

 4. If you would like the Legend Item to have a custom border around 
it, check the Draw Border checkbox in the Border group.  Then 
select the Color, Style, and Weight for the borderline. 

 5. Similarly, if you would like the Legend Item to use a custom 
background check the Draw Background checkbox in the 
Background group.  Then select the Color, Pattern, and 
Transparency for the item’s background. 

 6. The Sample box in the lower left corner will display a preview of 
your Legend Item. 

 7. If you would like the font changes to apply to all of the Legend 
Items in the plot, click the All Legend Items use the same font 
checkbox at the bottom of the worksheet. 

 
Click Apply to save your changes.  Once you are done with the editor, 
click OK to save the changes and close the window. 
 
 

6.10 Customizing Window Panels 
 
You can customize the background color, size, and viewport spacing the 
window plots are displayed in.   
 
To customize panel properties of an individual plot, from the Edit menu, 
click Plot Properties.  Once the Plot Properties editor opens, select the 
Layout tab.   
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To specify panel properties for all of your plots, from the Edit menu, click 
Default Plot Properties.  Once the Default Plot Properties editor opens, 
choose the Layout tab. 
 
Whether you are using the Plot Properties editor or the Default Plot 
Properties editor, the Layout worksheet is the same.  The Layout 
worksheet for the Plot Properties editor is shown in Figure 6.48. 
 

 
Figure 6.48  Default Plot Properties Editor - Layout Tab 
 
 

6.10.1 Customizing the Panel Background Color 
 
To customize the panel background color, select a color in the Panel 
Background Color list.   The default color is named Default.  The 
Default color uses the background color set by your computer’s operating 
system. 
 
 

6.10.2 Customizing the Horizontal Spacer Size 
 
In the Plot Properties editor and Default Plot Properties editor, 
horizontal spacer size refers to the space between viewports in plots with 
multiple viewports.   
 
To specify the horizontal spacer size using the Layout tab of the Plot 
Properties editor or Default Plot Properties editor, in the Space size in 
pixels field, either manually type in a size between 0 and 50 or use the up 
and down arrows to select a size. 
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6.10.3 Customizing the Window Size 
 
In the Plot Properties editor and Default Plot Properties editor, on the 
Layout tab enter the Width and Height of your plot window.  By default 
these values are empty, implying that the program will determine the best 
size for each plot window. 
 
 

6.11 Customizing Plot Layout 
 
The Configure Plot editor (Figure 6.49) displays plot components in a 
"tree" structure and allows you to customize the layout of an individual 
plot.  You can add and remove axes as well as add, remove, arrange the 
order of, and set the weight of viewports in the plot window panel. 
 

 
Figure 6.49  Configure Plot Editor 
 
When you customize the layout of a plot using the Configure Plot editor, 
your changes apply only to that individual plot unless you export the plot's 
properties (see Section 6.12). 
 
To access the Configure Plot editor, from the Edit menu, select 
Configure Plot Layout. 
 
 

6.11.1 Adding and Removing Viewports 
 
To add a new viewport to a plot, from the Configure Plot editor's Edit 
menu click Add Viewport.  The new viewport will appear at the bottom 
of the "tree" in the Selected Data Sets box. 
 
To remove an empty viewport, you can either: 
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 ■ Click on the name of the viewport in the Selected Data Sets 
"tree".  From the Edit menu, click Remove Viewport. 

-Or- 
 ■ Right-click on the viewport's name in the Selected Data Sets 

"tree".  From the shortcut menu (Figure 6.50), click Remove. 
 

 
Figure 6.50  Shortcut Menu - Viewport 

 
 

6.11.2 Setting Viewport Weights 
 
You can customize the relative sizes of viewports in your plots.  To do 
this: 
 
 1. From the Edit menu of the Configure Plot Layout editor, click 

Set Viewport Weights.  The Set Plot Viewport Weights dialog 
box will open. 

 2. In the Set Plot Viewport Weights dialog box (Figure 6.51); you 
can specify the relative size of each viewport as a percentage 
value, with all of the weights adding up to 100%.  Two viewports 
of equal weight at 50% each is shown in Figure 6.51. 

 

 
Figure 6.51  Set Plot Viewport Weights Dialog Box 

 
Click Apply to save and view your changes without closing the dialog box 
or click OK save your changes and close the dialog box. 
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6.11.3 Adding and Removing Axes 
 
By default, viewports have a left Y-axis.  You can add a right Y-axis, 
remove both the left and right Y-axes, and add a new left Y-axis if you 
have previously removed it.  Viewports can have a maximum of two axes.  
You cannot remove an axis when a data set is associated with it. 
 
To add an axis to a viewport, from the Configure Plot Editor you can 
either: 
 
 ■ Click on the viewport's name in the tree in the Selected Data Sets 

box.  From the Edit menu, click Add Axis. 
-Or- 

 ■ Right-click on the viewports name in the tree in the Selected Data 
Sets.  From the shortcut menu (see Figure 6.50, page 6-38), click 
Add Axis. 

 
The tree now displays another axis for the viewport you selected.   
 
To remove an axis that has no data associated with it, you can either: 
 
 ■ Click on the name of the axis you wish to remove in the tree in the 

Selected Data Sets box.  From the Edit menu, click Remove Axis. 
-Or- 

 ■ Right-click on the axis you wish to remove in the tree in the 
Selected Data Sets box.  From the shortcut menu (see Figure 6.50, 
page 6-38), click Remove. 

 
 

6.11.4 Arranging Viewports and Axes 
 
You can rearrange the vertical order of viewports in a plot window and 
move axes (with their associated data sets) to different viewports.   
 
To move a viewport or axis: 
 
 1. From the tree in the Selected Data Sets box, right-click on the 

name of a viewport or axis you want to move. 
 2. From the shortcut menu, click Move Up or Move Down. 
 3. Either click OK or Apply for the change to take effect in the plot 

window. 
 
Note that you cannot move individual data sets in the Configure Plot 
Layout editor.  You can move only the axis with which a data set is 
associated. 
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6.11.5 Reversing Axes (Invert Data) 
 
To reverse the direction of an axis so that the data is inverted, in the 
Configure Plot Layout editor, right-click on the name of the axis in the 
tree.  From the shortcut menu, click Reverse.  Either click OK or Apply 
for the change to appear in the plot window. 
 
 

6.12 Saving and Applying Templates 
 
After you have customized a plot, you can save its settings as a template 
for use in other plots. 
 
Generally, you will use templates when scripting plots.  For example: 
generating a plot of flow, stage, and precipitation via a script every day, 
and then apply a template that has all of the correct formatting, such as 
viewport placement, size, line colors, and fills.  For more information 
about using templates with scripts, refer to Chapter 8 on Scripting.   
 
To create a template from a plot: 
 
 1. From the File menu, click Save Template. 
 2. A Save browser will open (Figure 6.52). 
 

 
Figure 6.52  Save Browser 

 
 3. Give the template a name in the File name field and click the Save 

button.  A *.template file will be saved. 
 
To apply a template created from a previous plot: 
 
 1. From the File menu, click Apply Template. 
 2. An Open browser will open (see Figure 6.53, page 6-41). 
 3. Move to the *.template file’s location and select it by clicking on 

it. 
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Figure 6.53  Open Browser 

 
 4. When you select a template, its name will display in the File Name 

field. 
 5. Click Open to apply the template to the current plot. 
 
 

6.13 Additional Viewing Options for Plots 
 
The File menu of plots (Figure 6.54) contains 
several commands that allow you to view plot 
data in tabular form, save, copy, paste, and print 
plots.  Copy can be used to copy the plot into 
other applications available on your computer. 
 
 

6.13.1 Viewing Data in Tabular Form 
 
To view plot data in tabular form, from the File 
menu, click Tabulate.  A dialog box will open 
displaying the data in tabular form (Figure 6.55).  
For more information about tables, refer to 
Chapter 4 on Utilities. 
 

 
Figure 6.55  Data in Tabular Form 
 

Figure 6.54  File Menu 



Chapter 6 – Customizing Plots HEC-DSSVue User's Manual 

6-42 

6.13.2 Saving Plots 
 
You can save a plot as an image as a Windows Metafile (*.wmf), 
Postscript (*.ps), JPEG (*.jpg, *.jpeg), or Portable Network Graphics 
(*.png). 
 
To save a plot as a graphic file, from the File menu, click Save As.  From 
the Save browser (Figure 6.56), select the location where you want to save 
the plot, enter a filename in the File name box, and select the file type you 
want from the Files of type list, then click Save. 
 

 
Figure 6.56  Save Browser - Plots 
 
 

6.13.3 Copying Plots to the Clipboard 
 
Use Copy to Clipboard from the 
File menu to copy a plot to the 
clipboard.  You can then paste the 
plot as an image into other 
applications that are available on 
your computer. 
 
 

6.14 Printing Plots 
 
The Print command, available 
from the File menu of a plot, opens 
a standard, Windows-style print 
dialog box. 
 
From the File menu, click Page 
Setup.  The Page Setup dialog box 
will open (Figure 6.57).  Here you  Figure 6.57  Page Setup Dialog Box 
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can set the page Orientation, 
Margins, Page Numbers, and 
Printer Scale.  Set Margins opens 
the Printer Margins dialog box 
(Figure 6.58). 
 
To view the plot as it will be printed, 
from the File menu, click Print 
Preview.  An example is shown in 
Figure 6.59. 
 
Finally, the Print Multiple command 
allows you to print several plots 
on one page.  The Print 
Multiple dialog box (Figure 
6.60) shows all of the currently 
open plots in the Available Plots 
box.  To select plots for printing, 
double-click on the plots in the 
Available Plots box and the 
selected plots will move to the 
Selected Plots box.  Next, use 
the slider bars to specify the 
number of plots you wish to 
appear horizontally and 
vertically on the page.  The grid 
to the right of the sliders reflects 
your choices. 
 

 
Figure 6.60  Print Multiple Dialog Box 
 

Figure 6.58  Printer Margins Dialog Box 

Figure 6.59  Example Print Preview of a Plot 
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A preview of the plots set up above is shown in Figure 6.61.  From the 
Print Multiple dialog box, you can also use the Page Setup and Print 
Preview commands.  The two commands are available from the File menu 
of the Print Multiple dialog box. 
 

 
Figure 6.61  Print Multiple Preview Dialog Box (Example) 
 
 

6.15 Importing and Exporting Default Plot Properties 
 
Plot property changes made in a plot's Default Plot Properties editor 
apply to all plots used within the HEC-DSSVue application.  However, if 
you would like to use the same defaults for another HEC application, you 
can import or export the properties.  The properties must be moved 
from/to a compatible HEC "Next Generation" java based software 
application. 
 
Examples of compatible software are: HEC-DSSVue, HEC-FIA, HEC-
ResSim, HEC-RAS, HEC-HMS, CWMS, etc. 
 
 

6.15.1 Exporting Default Plot Properties 
 
Before you can import default plot properties, the properties must first by 
exported.  By exporting the properties, you create a *.zip file of all the 
necessary default plot property files needed. 
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To Export default plot properties: 
 
 1. In a plot window from the Edit menu, click Default Plot 

Properties.  In the Default Plot Properties dialog box, click 
Export (Figure 6.62). 

 

 
Figure 6.62  Default Plot Properties Dialog Box 

 
 2. A Save browser will open (Figure 6.63).  In the Save browser, type 

in a name for your default plot properties in the File name field, 
then click Save. 

 

 
Figure 6.63  Save Browser - Exporting Plot Properties 

 
 3. A *.zip file will be created containing all the files needed to import 

the properties to a different HEC application. 
 
 

6.15.2 Importing Default Plot Properties 
 
Once you have exported the default plot properties from a compatible 
HEC application, you can then Import them to a different HEC 
application. 
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To Import default plot properties: 
 
 1. In a plot window from the Edit menu, click Default Plot 

Properties.  In the Default Plot Properties dialog box, click 
Import (see Figure 6.62, page 6-45). 

 2. An Open browser will open (Figure 6.64).  Using the Open 
browser, select the *.zip default plot properties file, and then click 
Open. 

 

 
Figure 6.64  Open Browser - Importing Plot Properties 

 
 3. The default properties in the *.zip file will be imported and 

extracted into the current application.  The changes will be 
reflected in the Default Plot Properties editor. 

 
 

6.16 Text Substitution 
 
In all locations where the plot properties editors allow you to enter text, 
for example: the Plot Title, Legend Title, Axis Labels, Legend Labels, 
etc. you can use text substitution.  Text substitution is when you set the 
text using predefined keywords based on Date/Time and DSS related 
information.  These keywords will be used as a look-up and replaced when 
the text is used in the plot window according to the selected DSS data.   
 
In order for Keywords to be recognized as such, they must be bracketed on 
each side by % characters.  For example: %BPART% would result in the 
"BPART" of the DSS path being written in the final display text.  If you 
would like to have the actual percentage sign in the display text, use two 
% characters in a row %% and the second one will be displayed. 
 
By default, the first DSS path provided in the plot will be used for the text 
substitution.  However, adding a colon and integer value to the 
substitution keyword will instruct the substitution algorithm to use a 
different path.  For example %BPART:3% would show the "BPART" of  
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the third DSS path provided in the plot.  If there were less than three paths 
proved in the plot, the last DSS path listed would be used for the 
substitution. 
 
Text substitution keywords may be mixed with fixed text.   
 
For example: 

The text:  Final Results at %BPART% 
Would display:  Final Results for SHASTA 
Using the DSS path:  //SHASTA/ELEV/1HOUR/01JAN2000/ALT1/ 

 
The following is a list of available text substitution keywords: 
 
 DSS Path Parts: 
  APART DSS path A part 
  BPART DSS path B part 
  CPART DSS path C part 
  DPART DSS path D part 
  EPART DSS path E part 
  FPART DSS path F part 
  DSSPATH full DSS path 
 
 
 DSS File: 
  DSSFILENAME DSS file name only (without .dss extension)  
  DSSFILEPATH Full path to DSS file, including file name and 

extension 
  DSSFILEDIR Directory containing DSS file 
 
 Current Date/Time: 
  CURDATE Current Date (DDMMMYYYY) 
  CURMON Current Month 
  CURDAY Current Day 
  CURYEAR Current Year 
  CURTIME Current Time 
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