Hydrologic Modeling System HEC-HMS
User’s Manual

William A. Scharffenberg

U.S. Army Corps of Engineers
Hydrologic Engineering Center, HEC
609 Second St.
Davis, CA 95616-4687

HQ U.S. Army Corps of Engineers
20 Massachusetts Ave., NW
Washington, DC 20314-1000

Supersedes all previous versions.

Distribution is unlimited.

The Hydrologic Modeling System (HEC-HMS) is designed to simulate the precipitation-runoff processes of dendritic watershed systems. It supercedes HEC-1 and provides a similar variety of options but represents a significant advancement in terms of both computer science and hydrologic engineering. In addition to unit hydrograph and hydrologic routing options, capabilities include a linear quasi-distributed runoff transform (ModClark) for use with gridded precipitation, continuous simulation with either a one-layer or more complex five-layer soil moisture method, and a versatile parameter estimation option.

The program features a completely integrated work environment including a database, data entry utilities, computation engine, and results reporting tools. A graphical user interface allows the user seamless movement between the different parts of the program. Simulation results are stored in the Data Storage System HEC-DSS and can be used in conjunction with other software for studies of water availability, urban drainage, flow forecasting, future urbanization impact, reservoir spillway design, flood damage reduction, floodplain regulation, and systems operation.

Program functionality and appearance are the same across all supported platforms. It is available for Windows NT/98/95 and Sun Solaris operating systems.

Hydrology, watershed, precipitation runoff, river routing, flood control, water supply, computer simulation.
Hydrologic Modeling System
HEC-HMS

User's Manual

Version 2.1
January 2001

US Army Corps of Engineers
Hydrologic Engineering Center
609 Second Street
Davis, CA 95616-4687 USA

Phone (530) 756-1104
Fax (530) 756-8250
Email hms@usace.army.mil

Public Domain 2001. This Hydrologic Engineering Center, HEC, documentation and software was developed at U.S. Federal Government expense and is therefore in the public domain. Components of the HEC software were developed using proprietary commercial productivity software. HEC has executed agreements with the commercial software providers that enable the HEC software to be copied and distributed without restriction. The agreements require that the components of the commercial software used in the HEC applications software be only the runtime form bound in the executable. The commercial portions of the HEC software may not be used for any other applications. Further, the agreements require that users accept the provisions of the copyright restrictions of the commercial software components as noted in the following paragraphs.

Copyright 1995 Galaxy Runtime Components by Visix Software, Inc. All Rights Reserved.

Copyright 1995 AgX Toolmaster Runtime Components by Advanced Visual Systems, Inc. All Rights Reserved.

BY USING OR COPYING THIS SOFTWARE, USER AGREES TO ABIDE BY THE COPYRIGHT LAW AND ALL OTHER APPLICABLE LAWS OF THE U.S., INCLUDING, BUT NOT LIMITED TO, EXPORT CONTROL LAWS, AND THE TERMS OF THE FOLLOWING LICENSE AGREEMENT. THE HYDROLOGIC ENGINEERING CENTER SHALL HAVE THE RIGHT TO TERMINATE THIS LICENSE IMMEDIATELY BY WRITTEN NOTICE UPON USER'S BREACH OF, OR NONCOMPLIANCE WITH, ANY OF ITS TERMS. USER MAY BE HELD LEGALLY RESPONSIBLE FOR ANY COPYRIGHT INFRINGEMENT THAT IS CAUSED OR ENCOURAGED BY USER'S FAILURE TO ABIDE BY THE TERMS OF THIS LICENSE.

The above information and the full License Agreement are presented for acceptance when the software is first used. That information is also provided in Appendix F of this manual for reference.
# Table of Contents

## Chapter 1 Introduction ................................................................. 1

- **Features** ............................................................................... 1
- **Modeling Basin Components** .............................................. 2
  - **Losses** ............................................................................ 2
  - **Runoff Transform** ......................................................... 2
  - **Open-Channel Routing** .................................................. 2
- **Analysis of Meteorologic Data** ............................................ 2
- **Rainfall-Runoff Simulation** ............................................... 3
- **Parameter Estimation** ....................................................... 3
- **User's Manual Overview** .................................................. 3
  - **Contents** ......................................................................... 3
  - **Documentation Conventions** ......................................... 4

## Chapter 2 Installing the Program ............................................... 5

- **Operating System Requirements** ...................................... 5
- **Hardware Requirements and Recommendations** .............. 5
- **Installation Procedure** ..................................................... 6
  - **Microsoft Windows** .................................................... 6
  - **Sun Solaris** .................................................................. 7

## Chapter 3 Overview of the Program .......................................... 9

- **Starting the Program** ....................................................... 9
- **Project Definition Screen** .............................................. 10
  - **The Menu Bar** ................................................................ 10
  - **Components** .................................................................. 12
- **Data Storage** ................................................................... 12
- **Application Steps** ............................................................. 13
- **Create a New Project** ...................................................... 13
- **Enter Shared Data** ............................................................. 14
- **Create a Basin Model** ...................................................... 14
- **Create a Meteorologic Model** ........................................ 14
- **Create Control Specifications** ........................................ 14
- **Simulate and View Results** ............................................ 14
- **Exiting the Program** ........................................................ 15

## Chapter 4 Working with Projects .............................................. 16

- **Creating and Managing Projects** ...................................... 16
- **Directories and Files** ....................................................... 20
  - **Files Generated by the Program** .................................. 20
    - **User-Specified Files** ................................................ 20
    - **Project DSS File** ..................................................... 21
    - **External DSS Files** .................................................. 22
  - **Overview of Gage Data** ............................................... 22
  - **Creating External DSS Gages** ...................................... 23
  - **Creating Manual-Entry Gages** .................................... 24
  - **Editing Previously Created Gages** ............................... 26
  - **Viewing Gage Data** ...................................................... 27
  - **Deleting Gages** ............................................................. 29
  - **Overview of Paired Data** ............................................. 29
  - **Creating External DSS Unit Hydrographs** .................... 30
  - **Creating Manual-Entry Unit Hydrographs** ................... 31
  - **Editing Previously Created Unit Hydrographs** ............. 32
  - **Viewing Unit Hydrograph Data** ................................... 32
  - **Deleting Unit Hydrographs** ......................................... 34
  - **Soil Moisture Accounting Units** ................................... 34
# Table of Contents

- **PROJECT ATTRIBUTES** ................................................................. 37
- **IMPORTING HEC-1 DATA** .......................................................... 37

## CHAPTER 5  BASIN MODELS .............................................................. 39

### CREATING AND MANAGING BASIN MODELS .................................................. 39

#### HYDROLOGIC ELEMENTS .............................................................. 42
- **Subbasin** ............................................................................................. 43
- **Reach** .................................................................................................. 43
- **Reservoir** ............................................................................................ 43
- **Junction** ............................................................................................. 43
- **Diversion** ........................................................................................... 43
- **Source** ................................................................................................ 43
- **Sink** ................................................................................................... 43

#### BASIN MODEL SCREEN ........................................................................ 44
- **The Menu Bar** .................................................................................... 44
- **The Toolbar** ....................................................................................... 46

#### CREATING THE ELEMENT NETWORK ....................................................... 48

#### ELEMENT EDITORS ............................................................................... 49

#### SUBBASIN ............................................................................................. 49

#### SUBBASIN LOSS METHODS ................................................................. 50
- **Deficit and Constant** .......................................................................... 51
- **Green and Ampt** ................................................................................ 52
- **Gridded SCS Curve Number** ............................................................... 53
- **Gridded Soil Moisture Accounting** ..................................................... 54
- **Initial and Constant** ............................................................................ 55
- **SCS Curve Number** ............................................................................ 55
- **Soil Moisture Accounting** ................................................................. 57

#### SUBBASIN TRANSFORM METHODS ......................................................... 59
- **Clark Unit Hydrograph** ....................................................................... 59
- **Kinematic Wave** ................................................................................ 60
- **ModClark** .......................................................................................... 63
- **Snyder Unit Hydrograph** ..................................................................... 64
- **SCS Unit Hydrograph** ........................................................................ 65
- **User-Specified S-Graph** ..................................................................... 66
- **User-Specified Unit Hydrograph** ......................................................... 67

#### SUBBASIN BASEFLOW METHODS .......................................................... 68
- **Constant Monthly** ............................................................................. 68
- **Linear Reservoir** ............................................................................... 69
- **Recession** ............................................................................................ 70

#### REACH ................................................................................................ 71
- **Kinematic Wave** ................................................................................ 72
- **Lag** ..................................................................................................... 73
- **Modified Puls** ................................................................................... 74
- **Muskingum** ....................................................................................... 75
- **Muskingum-Cunge 8-Point** ............................................................... 76
- **Muskingum-Cunge Standard** .............................................................. 77

#### RESERVOIR .......................................................................................... 77

#### JUNCTION ........................................................................................... 79

#### DIVERSION .......................................................................................... 79

#### SOURCE .............................................................................................. 80

#### SINK ..................................................................................................... 81

#### GLOBAL EDITORS ................................................................................ 82

#### OBSERVED HYDROGRAPH .................................................................. 83

#### STAGE-DISCHARGE CURVE .................................................................. 83

#### BASIN MODEL ATTRIBUTES ............................................................... 85

#### BACKGROUND MAP ............................................................................ 85
# Table of Contents

## CHAPTER 6  METEOROLOGIC MODELS ................................................................. 88

- Creating and Managing Meteorologic Models ................................................ 88
- Meteorologic Model Screen .............................................................................. 91
- Subbasin List ....................................................................................................... 93
- Evapotranspiration Zones .................................................................................. 94

## PRECIPITATION METHODS ............................................................................. 95
- User Hyetograph .................................................................................................. 95
- User Gage Weighting ......................................................................................... 96
- Inverse-Distance Gage Weights ....................................................................... 98
- Gridded Precipitation ......................................................................................... 101
- Frequency Storm ............................................................................................... 102
- SCS Hypothetical Storm .................................................................................... 103
- Standard Project Storm .................................................................................... 103

## EVAPOTRANSPIRATION METHODS ............................................................... 104
- Monthly Average .............................................................................................. 104

## METEOROLOGIC MODEL ATTRIBUTES ....................................................... 106

## CHAPTER 7  CONTROL SPECIFICATIONS ...................................................... 107

- Creating and Managing Control Specifications ............................................... 107
- Dates and Times ................................................................................................ 110
- Time Interval ...................................................................................................... 111

## CHAPTER 8  PERFORMING SIMULATIONS AND VIEWING RESULTS .......... 112

- Creating and Managing Runs .......................................................................... 112
- Run Configuration and Options ..................................................................... 115
- Components ...................................................................................................... 115
- Ratio Option ....................................................................................................... 117
- Start States Option ........................................................................................... 118
- Save States Option ........................................................................................... 119

## MESSAGE LOG ................................................................................................ 120

## VIEWING RESULTS .......................................................................................... 121
- Global Summary Table ..................................................................................... 127
- Standard Element Results .............................................................................. 122
- Special Soil Moisture Accounting Results ....................................................... 126

## CHAPTER 9  MODEL CALIBRATION ................................................................. 129

- Framework for Model Calibration .................................................................. 129
- Objective Function ........................................................................................... 130
- Peak-Weighted Root Mean Square Error ......................................................... 130
- Sum of Squared Residuals .............................................................................. 131
- Sum of Absolute Residuals ............................................................................ 131
- Percent Error in Peak Flow ........................................................................... 131
- Percent Error in Volume .................................................................................. 132

## SEARCH METHODS ....................................................................................... 132

## INITIAL VALUES AND CONSTRAINTS ............................................................. 132

## PARAMETER SENSITIVITY ............................................................................. 133

## USING THE OPTIMIZATION MANAGER ....................................................... 134
- The Menu Bar .................................................................................................... 134
- The Toolbar ....................................................................................................... 136
- Objective Function ............................................................................................ 136

## Creating Optimization Runs .......................................................................... 137

## Creating and Computing Trials ...................................................................... 137

## Trial Results ..................................................................................................... 138
- Trial Message Log ............................................................................................ 139
- Trial Results Summary .................................................................................... 139
# Table of Contents

<table>
<thead>
<tr>
<th>Section</th>
<th>Page</th>
</tr>
</thead>
<tbody>
<tr>
<td>Flow Comparison Graph</td>
<td>140</td>
</tr>
<tr>
<td>Scatter Graph</td>
<td>141</td>
</tr>
<tr>
<td>Residual Graph</td>
<td>142</td>
</tr>
<tr>
<td>Objective Function Graph</td>
<td>143</td>
</tr>
<tr>
<td>Optimization Schematic</td>
<td>143</td>
</tr>
<tr>
<td>Run Results</td>
<td>144</td>
</tr>
<tr>
<td>Deleting Runs and Trials</td>
<td>145</td>
</tr>
<tr>
<td><strong>CHAPTER 10 EXAMPLE APPLICATION</strong></td>
<td>147</td>
</tr>
<tr>
<td>Problem Statement</td>
<td>147</td>
</tr>
<tr>
<td>Create the Project</td>
<td>149</td>
</tr>
<tr>
<td>Create the Basin Model</td>
<td>151</td>
</tr>
<tr>
<td>Create the Element Network</td>
<td>152</td>
</tr>
<tr>
<td>Enter Element Data</td>
<td>154</td>
</tr>
<tr>
<td>Create the Meteorologic Model</td>
<td>159</td>
</tr>
<tr>
<td>Create Control Specifications</td>
<td>161</td>
</tr>
<tr>
<td>Create and Compute a Run</td>
<td>161</td>
</tr>
<tr>
<td>Viewing Results</td>
<td>162</td>
</tr>
<tr>
<td>Simulate Future Urbanization</td>
<td>164</td>
</tr>
<tr>
<td>Create the Modified Basin Model</td>
<td>165</td>
</tr>
<tr>
<td>Urbanized Simulation Run</td>
<td>165</td>
</tr>
<tr>
<td><strong>APPENDIX A REFERENCES</strong></td>
<td>166</td>
</tr>
<tr>
<td><strong>APPENDIX B PROJECT DSS FILE PATHNAME DESCRIPTORS</strong></td>
<td>167</td>
</tr>
<tr>
<td>Descriptors</td>
<td>167</td>
</tr>
<tr>
<td><strong>APPENDIX C BACKGROUND MAP FILE FORMAT</strong></td>
<td>169</td>
</tr>
<tr>
<td>File Definition</td>
<td>169</td>
</tr>
<tr>
<td><strong>APPENDIX D GRID-CELL FILE FORMAT</strong></td>
<td>171</td>
</tr>
<tr>
<td>File Definition</td>
<td>171</td>
</tr>
<tr>
<td><strong>APPENDIX E PROGRAM LICENSE AGREEMENT</strong></td>
<td>173</td>
</tr>
<tr>
<td>License Text</td>
<td>173</td>
</tr>
<tr>
<td><strong>APPENDIX F GLOSSARY</strong></td>
<td>175</td>
</tr>
<tr>
<td>Word List</td>
<td>175</td>
</tr>
</tbody>
</table>
The U.S. Army Corps of Engineers' Hydrologic Modeling System HEC-HMS is "next generation" software for precipitation-runoff simulation that will supersede the HEC-1 Flood Hydrograph Package. The program is a significant advancement over HEC-1 in terms of both computer science and hydrologic engineering. It is a product of the Corps' Civil Works Hydrologic Engineering Research and Development Program.

The program currently contains most of the watershed runoff and routing capabilities of HEC-1. Capabilities for snow accumulation and melt, flow-frequency curve analysis, reservoir outlet structures, and dam break are under development but not yet incorporated. The flood damage capabilities of HEC-1 will not be included; they are performed separately in the Flood Damage Analysis HEC-FDA software.

Several important new capabilities are available in the program that were not available in HEC-1: continuous hydrograph simulation over long periods of time and distributed runoff computation using a grid cell depiction of the watershed. Continuous simulation may be performed using a simple one reservoir soil moisture representation or a more complex five reservoir model that includes canopy interception, surface depression, soil, and two groundwater layers. Spatially distributed runoff can be computed with the quasi-distributed linear transform (ModClark) of cell-based precipitation and infiltration.

The program is comprised of a graphical user interface, integrated hydrologic analysis components, data storage and management tools, and graphics and reporting facilities. Development utilized a mixture of programming languages including C, C++, and Fortran. The computation engine and graphical user interface are written in object-oriented C++. Hydrologic process algorithms are written in Fortran and have been organized into the libHydro library. Data management is performed using the HecLib library. Although linked into a single executable program, there are clear separations between the interface, simulation engine, and database.

In the spirit and requirements for the United States to use System International measurement units, all computations are performed in metric units. Input data and output results may be U.S. customary or metric and are automatically converted when necessary.

The program was developed by a team of HEC staff and consultants. Elisabeth Pray, HEC, developed the majority of the graphical user interface and integrated the various components to produce the finished program. Paul Ely, contractor, developed the computation engine and hydrologic algorithm library. William Scharffenberg, HEC, contributed to graphical user interface design, managed testing, and wrote this manual. Thomas Evans, HEC, developed the algorithms for storing gridded data.

The program continues to benefit from many individuals who contributed to previous versions. John Peters, HEC, managed the development team until his retirement in 1998. During that time he designed the graphical user interface, managed development, and wrote the first version of this manual. Arthur Pabst, HEC, and Tony Slocum, consultant, provided essential input to the object-oriented design of the program. Slocum also wrote the code for the schematic representation of the basin model. William Charley, HEC, developed the design for the computation engine. David Ford, consultant, provided recommendations for the scope and content of the
optimization manager. Todd Bennett, HEC, provided technical evaluations that led to the design of the soil moisture accounting loss method. Troy Nicolini, HEC, led the Version 1.0 beta testing team and managed the maiden release. Richard Raichle, contractor, developed the soil moisture accounting graphical user interface. Shannon Newbold, contractor, developed the meteorologic model graphical user interface. Several students from the University of California, Davis, working as temporary employees at HEC, provided excellent assistance to the software development, testing, and documentation: Jessica Thomas, Ken Sheppard, Jake Gusman, and Dan Easton.

The program was developed under the HEC "Next Generation Software Development Project" led by the Director, Darryl Davis. Arlen Feldman, Chief of the Hydrology and Hydraulics Technology Division, managed the general design, development, testing, and documentation of the program.
CHAPTER 1

Introduction

This chapter introduces the Hydrologic Modeling System HEC-HMS. Features and major capabilities of the program are described. An overview of the manual explains organization and conventions used to describe actions in the program.

Features

The Hydrologic Modeling System is designed to simulate the precipitation-runoff processes of dendritic watershed systems. It is designed to be applicable in a wide range of geographic areas for solving the widest possible range of problems. This includes large river basin water supply and flood hydrology, and small urban or natural watershed runoff. Hydrographs produced by the program are used directly or in conjunction with other software for studies of water availability, urban drainage, flow forecasting, future urbanization impact, reservoir spillway design, flood damage reduction, floodplain regulation, and systems operation.

The program features a completely integrated work environment including a database, data entry utilities, computation engine, and results reporting tools. A graphical user interface allows the user seamless movement between the different parts of the program. Program functionality and appearance are the same across all supported platforms.

Time-series, paired, and gridded data are stored in the Data Storage System HEC-DSS (HEC, 1994). Storage and retrieval of data is handled by the program and is generally transparent to the user. Precipitation and discharge gage information can be entered manually within the program or can be loaded from previously created DSS files. Results stored by the program in the database are accessible by other HEC software.

Data entry can be performed for individual basin elements such as subbasins and stream reaches or simultaneously for entire classes of similar elements. Tables and forms for entering necessary data are accessed from a visual schematic of the basin.

The computation engine draws on over 30 years experience with hydrologic simulation software. Many algorithms from HEC-1 (HEC, 1998), HEC-1F (HEC, 1989), PRECIP (HEC, 1989), and HEC-IFH (HEC, 1992) have been modernized and combined with new algorithms to form a comprehensive library of simulation routines. Future versions of the program will continue to modernize desirable algorithms from legacy software. The current research program is designed to produce new algorithms and analysis techniques for addressing emerging problems.

Computation results are viewed from the basin model schematic. Global and element summary tables include information on peak flow and total volume. Time-series tables and graphs are available for elements. Customizable graph and report generators are planned for future versions.
Chapter 1  Introduction

Modeling Basin Components

The physical representation of watersheds or basins and rivers is configured in the basin model. Hydrologic elements are connected in a dendritic network to simulate runoff processes. Available elements are: subbasin, reach, junction, reservoir, diversion, source, and sink. Computation proceeds from upstream elements in a downstream direction.

Losses

An assortment of different methods are available to simulate infiltration losses. Options for event modeling include initial and constant, SCS curve number, gridded SCS curve number, and Green and Ampt. The one-layer deficit and constant model can be used for simple continuous modeling. The five-layer soil moisture accounting model can be used for continuous modeling of complex infiltration and evapotranspiration environments.

Runoff Transform

Several methods are included for transforming excess precipitation into surface runoff. Unit hydrograph methods include the Clark, Snyder, and SCS technique. User-specified unit hydrograph ordinates can also be used. The modified Clark method, ModClark, is a linear quasi-distributed unit hydrograph method that can be used with gridded precipitation data. An implementation of the kinematic wave method with multiple planes and channels is also included.

Open-Channel Routing

A variety of hydrologic routing methods are included for simulating flow in open channels. Routing with no attenuation can be modeled with the lag method. The traditional Muskingum method is included. The modified Puls method can be used to model a reach as a series of cascading, level pools with a user-specified storage-outflow relationship. Channels with trapezoidal, rectangular, triangular, or circular cross sections can be modeled with the kinematic wave or Muskingum-Cunge method. Channels with overbank areas can be modeled with the Muskingum-Cunge method and an 8-point cross section.

Analysis of Meteorologic Data

Meteorologic data analysis is performed by the meteorologic model and includes precipitation and evapotranspiration. Six different historical and synthetic precipitation methods are included. One evapotranspiration method is included at this time.

Four different methods for analyzing historical precipitation are included. The user-specified hyetograph method is for precipitation data analyzed outside the program. The gage weights method uses an unlimited number of recording and non-recording gages. The Thiessen technique is one possibility for determining the weights. The inverse distance method addresses dynamic data problems. An unlimited number of recording and non-recording gages can be used to automatically proceed when missing data is encountered. The gridded precipitation method uses radar rainfall data.

Four different methods for producing synthetic precipitation are included. The frequency storm uses statistical data to produce balanced storms with a specific exceedence probability. Sources of supporting statistical data include Technical
Paper 40 (National Weather Service, 1961) and NOAA Atlas 2 (National Weather Service, 1973). The standard project storm implements the regulations for precipitation when estimating the standard project flood (Corps of Engineers, 1952). The SCS hypothetical storm implements the primary precipitation distributions for design analysis using Natural Resources Conservation Service (NRCS) criteria (Soil Conservation Service, 1986). The user-specified hyetograph can be used with a synthetic hyetograph resulting from analysis outside the program.

The evapotranspiration method uses monthly average values with an optional pan coefficient. Additional evapotranspiration methods are planned for future versions.

**Rainfall-Runoff Simulation**

The time span of a simulation is controlled by control specifications. Control specifications include a starting date and time, ending date and time, and computation time step.

A computation run is created by combining a basin model, meteorologic model, and control specifications. Run options include a precipitation or flow ratio, capability to save all basin states at a point in time, and ability to begin a simulation from previously saved states.

Computation results are viewed from the basin model schematic. Global and element summary tables include information on peak flow and total volume. Time-series tables and graphs are available for elements. All graphs and tables can be printed on a Postscript\(^1\)-capable printer.

**Parameter Estimation**

Most parameters for methods included in subbasin and reach elements can be estimated automatically using the optimization manager. Observed discharge must be available for at least one element before optimization can begin. Parameters at any element upstream of the observed flow can be estimated. Four different objective functions are available to estimate the goodness-of-fit between the computed results and observed discharge. Two different search methods can be used to find the best fit between the computed results and observed discharge. Constraints can be imposed to restrict the parameter space of the search method.

**User’s Manual Overview**

The content of this manual is organized to match the use of the program. Certain documentation conventions are utilized to make it easier to read.

**Contents**

This manual is organized as a sequential presentation of specific information on using the program and mirrors the steps in applying the program. Chapter 2 discusses computer requirements and installation. Chapter 3 provides an overview of the steps in applying the program for a modeling project or study. Chapter 4 describes the project and the components it contains, including gages. Chapter 5 discusses basin models. Chapter 6 gives information on meteorologic models. Chapter 7 explains control specifications. Chapter 8 discusses model execution and

\(^1\) All company and product names mentioned in this manual are trademarks or registered trademarks of their respective companies. No express or implied government endorsement is given.
Chapter 1 Introduction


Documentation Conventions

The following conventions are used throughout the manual to describe screens in the program interface. Screen titles are shown in italics. Menus names, menu items, and button names are shown in bold. Menus are separated from submenus with the right arrow ⇒. Data to be typed into an input field on a screen is shown in the courier font. A column heading, tab name, or field title is "shown in double quotes".

The following conventions are used to describe actions with the mouse. Clicking a mouse button means to press and release the indicated button. Double-clicking a mouse button means to press and release the indicated button twice in rapid succession. Holding a mouse button means to press and keep depressed the indicated button. Pressing a button on the graphical user interface means to place the arrow pointer controlled by the mouse over the indicated button and click the left mouse button. Entering data in a field means to place the arrow pointer over the field and click the left mouse button to obtain a cursor and begin data entry.

Many interface screens have a standard set of buttons at the bottom of the screen. The "OK" button stores the data from the screen in memory and closes the screen. The "Apply" button stores the data from the screen in memory but leaves the screen open. The "Cancel" button closes the screen without saving data changes it may have contained. Screens that do not need to save data when closing have a "Close" button. The "Help" button opens the online help to the context-sensitive topic for the current screen.

Definitions of frequently used words are listed in Appendix F.
CHAPTER 2

Installing the Program

This chapter describes the minimum and recommended computer system requirements for running the program. Step-by-step installation procedures are also provided.

Operating System Requirements

The program is multi-platform capable and has been produced for the following computer operating systems:

- Microsoft Windows 2000, 98, and 95
- Microsoft Windows NT 4.0
- Sun Solaris 2.5 or higher

Hardware Requirements and Recommendations

The minimum hardware equipment for a Microsoft Windows installation includes:

- Intel 80486 compatible processor
- 16 MB memory to run the program individually
- 15 MB available hard-disk space
- 15” VGA monitor
- Microsoft compatible mouse

The recommended hardware equipment for a Microsoft Windows installation includes:

- Intel Pentium compatible processor
- 32 MB memory
- 25 MB available hard-disk space
- 17” SVGA monitor
- Microsoft compatible mouse
- Postscript printer
The minimum hardware equipment for a Sun Solaris installation includes:

- SuperSPARC processor
- 64 MB memory to run the program individually
- 28 MB available hard-disk space
- 10 MB available hard-disk space per user
- 17" color monitor
- Mouse

The recommended hardware equipment for a Sun Solaris installation includes:

- UltraSPARC processor
- 128 MB memory
- 28 MB available hard-disk space
- 25 MB available hard-disk space per user
- 19" color monitor
- Mouse
- Postscript printer

Installation Procedure

Installation files for Microsoft Windows and Sun Solaris systems are on the distribution CD-ROM. The installation procedure for Windows computers is automated. Installation on a Windows NT computer requires local administrator privileges. A manual installation procedure is used for Solaris computers and should only be performed by a system administrator.

**Microsoft Windows**

The distribution CD-ROM contains three different install sets in the "\windows" directory for use in different conditions. The primary install set is in the "\windows\cdrom" directory. The internet install set in the "\windows\internet" directory is a single self-extracting file easily transmitted over networks. The diskette install set in the "\windows\diskette" directory can be copied to eight 3½ inch high-density diskettes for use in computers with no CD-ROM drive.

The following steps should be followed to successfully install the program using the CD-ROM and the primary install set:

1. Place the disk in the CD-ROM drive of the computer. Run the "\windows\cdrom\setup.exe" program on the CD-ROM if the installation setup program does not start automatically.

2. Follow the prompts from the installation setup program and accept the default suggestions whenever possible.
3. The installation setup program requests permission to modify environment variables. The program cannot function correctly without setting the environment variables. Ask a system administrator for assistance if the installation setup program cannot be allowed to automatically set the variables.

4. The computer must be restarted before the program can be used.

The following steps should be followed to successfully install the program using the internet install set:

1. Run the internet install program "hec_hms.exe" directly from the CD-ROM or after copying it to a temporary directory.

2. Follow the prompts from the installation setup program and accept the default suggestions whenever possible.

3. The installation setup program requests permission to modify environment variables. The program cannot function correctly without setting the environment variables. Ask a system administrator for assistance if the installation setup program cannot be allowed to automatically set the variables.

4. The computer must be restarted before the program can be used.

The following steps should be followed to successfully install the program using the diskette install set:

1. Copy the contents of each directory in the "\windows\diskette" directory to a separate 3½ inch high-density diskette.

2. Insert the first diskette into the floppy disk drive of the computer.

3. Run the "setup.exe" program on the first diskette.

4. Follow the prompts from the installation setup program and accept the default suggestions whenever possible.

5. The installation setup program requests permission to modify environment variables. The program cannot function correctly without setting the environment variables. Ask a system administrator for assistance if the installation setup program cannot be allowed to automatically set the variables.

6. The computer must be restarted before the program can be used.

**Sun Solaris**

Two files in the "\unix\solaris" directory of the distribution CD-ROM are required to perform the installation. The "hms.tar" file contains all of the files necessary to run the program. The "testdata.tar" file contains three test data sets.

The following steps should be followed to successfully install the program:

1. Create the directory "hms" on your system. Typical locations would be "/usr/hec/hms" or "/usr/hec/bin/hms". This is the location where the program executable files will be installed.
2. Copy the "hms.tar" file from the CD-ROM to the "hms" directory. Use the "tar –xvof hms.tar ." command to extract the files.

3. Several changes will have to be made to the shell file for each account that will use program. For example, the ".cshrc" file in the $HOME directory of each user, for users with the C shell environment.

4. Set the environment variable GALAXYHOME to the "hms" directory.

5. Set the environment variable UNIDIR to the "hms" directory.

6. Set the variable HMSPROJHOME to the directory where the individual user will store project files. The directory can be called anything and may be anywhere on the file system, but it is recommended the directory be called "hmsproj" and be placed in the $HOME directory.

7. Add the "hms" directory to the PATH environment variable.

8. The "tar" command will create a "lib" directory under the "hms" directory. Add that "lib" directory to the LD_LIBRARY_PATH environment variable.

9. Source the ".cshrc" file to affect changes.

10. It is recommended that a copy of the "testdata.tar" file be uncompressed for each user in the directory indicated by their HMSPROJHOME variable.
Overview of the Program

This chapter describes how to work with the program. The functionality of the Project Definition screen is explained. Specific information on data storage is provided. An overview of the steps necessary to obtain simulation results is also included.

Starting the Program

For Microsoft Windows systems there are two ways to start the program. The first option is to select the Programs ⇒ Hec ⇒ HEC-HMS 2.0 menu item from the Start menu in the bottom left corner of the Windows desktop. The second option is to double-click the HEC-HMS 2.0 icon on the Windows desktop. The icon is optionally created during installation.

For Sun Solaris systems, type at the prompt in a command window:

\[\text{hms} \ &\]

The Project Definition screen opens after the program starts and the project that was open the last time the program was used is opened automatically.

Project Definition Screen

The Project Definition screen (Figure 1) is used to create and manage projects. It also provides access to components, analysis tools, and other data sets such as precipitation and discharge gages. A menu bar, the project title and description, and component lists are included in the screen.

The Project Definition screen is one of the two places where the project description can be changed. Change the project description by clicking the left mouse button in the field and typing a new description. Save the project to effect the description change. The other place to change the description is on the Project Attributes screen, see File menu discussion which follows.
Chapter 3  Overview of the Program

The Menu Bar

The File menu contains items for creating and managing projects. An overview of the functions provided in the menu is shown in Table 1. The last four projects to be opened are shown at the bottom of the menu. Click on one of the project names to automatically open the project.

Table 1. File menu functions in the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Project</td>
<td>Create a new project.</td>
</tr>
<tr>
<td>Open Project</td>
<td>Open a listed or unlisted project.</td>
</tr>
<tr>
<td>Save Project</td>
<td>Save the current project.</td>
</tr>
<tr>
<td>Copy Project</td>
<td>Make a copy of the current project.</td>
</tr>
<tr>
<td>Rename Project</td>
<td>Rename the current project.</td>
</tr>
<tr>
<td>Delete Project</td>
<td>Delete a project.</td>
</tr>
<tr>
<td>Project Attributes</td>
<td>Set the project description and other attributes.</td>
</tr>
<tr>
<td>Import HEC-1</td>
<td>Import an HEC-1 file into the current project.</td>
</tr>
<tr>
<td>Exit</td>
<td>Quit the program.</td>
</tr>
</tbody>
</table>

The Component menu contains items for managing model components. An overview of the functions provided in the menu is shown in Table 2.
Table 2. Component menu functions on the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Basin Model ⇒ New</td>
<td>Create a new basin model.</td>
</tr>
<tr>
<td>Basin Model ⇒ Open</td>
<td>Open an existing basin model.</td>
</tr>
<tr>
<td>Basin Model ⇒ Delete</td>
<td>Delete a basin model from the project.</td>
</tr>
<tr>
<td>Basin Model ⇒ Import</td>
<td>Import an existing basin model into the current project.</td>
</tr>
<tr>
<td>Meteorologic Model ⇒ New</td>
<td>Create a new meteorologic model.</td>
</tr>
<tr>
<td>Meteorologic Model ⇒ Open</td>
<td>Open an existing meteorologic model.</td>
</tr>
<tr>
<td>Meteorologic Model ⇒ Delete</td>
<td>Delete a meteorologic model from the project.</td>
</tr>
<tr>
<td>Meteorologic Model ⇒ Import</td>
<td>Import an existing meteorologic model into the current</td>
</tr>
<tr>
<td></td>
<td>project.</td>
</tr>
<tr>
<td>Control Specifications ⇒ New</td>
<td>Create a new control specifications.</td>
</tr>
<tr>
<td>Control Specifications ⇒ Open</td>
<td>Open an existing control specifications.</td>
</tr>
<tr>
<td>Control Specifications ⇒ Delete</td>
<td>Delete a control specifications from the project.</td>
</tr>
</tbody>
</table>

The Data menu contains items for accessing time-series and other data managers. An overview of the functions provided in the menu is shown in Table 3.

Table 3. Data menu functions in the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Precipitation Gages</td>
<td>Open the precipitation gage manager.</td>
</tr>
<tr>
<td>Discharge Gages</td>
<td>Open the discharge gage manager.</td>
</tr>
<tr>
<td>User-Specified Unit Hydrographs</td>
<td>Open the unit hydrograph manager.</td>
</tr>
<tr>
<td>User-Specified S-Graphs</td>
<td>Open the s-graph manager.</td>
</tr>
<tr>
<td>Soil Moisture Accounting Units</td>
<td>Open the soil moisture accounting unit manager.</td>
</tr>
</tbody>
</table>

The View menu contains items for accessing log files. The project log contains information messages generated since the project was opened. The run logs contain information messages generated during the last compute of the list runs. The run logs can also be viewed at the end of a compute or from the View menu of the Basin Model screen.

The Tools menu contains items for working with simulation and optimization runs. An overview of the functions provided in the menu is shown in Table 4.

Table 4. Tools menu functions in the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run Configuration</td>
<td>Create a new run.</td>
</tr>
<tr>
<td>Run Manager</td>
<td>Manage runs including computing them.</td>
</tr>
<tr>
<td>Optimization Run Configuration</td>
<td>Create a new optimization run.</td>
</tr>
<tr>
<td>Optimization Manager</td>
<td>Manage optimization runs including creating trials, specifying parameters, and executing them.</td>
</tr>
</tbody>
</table>
The Help menu contains items for using the online help and displaying information about the program. An overview of the functions provided in the menu is shown in Table 5.

### Table 5. Help menu functions on the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Open the online help to the table of contents.</td>
</tr>
<tr>
<td>Search For Help On</td>
<td>Open the online help to the index.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Open the online help to the topic on how to use the online help system.</td>
</tr>
<tr>
<td>About HEC-HMS</td>
<td>View the program version number and license agreement.</td>
</tr>
</tbody>
</table>

**Components**

The components section of the Project Definition screen contains three lists: basin models, meteorologic models, and control specifications. All components in the project are shown in one of the three lists, depending on type. A checkmark is shown next to current components that are in internal storage. There can only be one current component in each list, but a current component is not required.

A component can be opened by double-clicking it with the left mouse button. This performs the same function as the Component ⇒ Basin Model ⇒ Open menu item, or similarly for meteorologic model and control specifications.

The right mouse button activates a menu for working with the components in each component list. A list can be sorted in alphabetical or reverse alphabetical order. The current component can be moved one position up or down in the list.

**Data Storage**

There are three locations where program data can reside: locally in screen memory, the computation engine in internal memory, and persistent storage. Data passes between locations through the paths shown in Figure 2. Data is copied from the engine every time an interface screen is opened. Consequently, data in screen memory is temporarily independent from internal memory. Pressing the OK or Apply button on a screen saves any data changes to internal storage, overwriting the old values. Pressing the Cancel button closes the screen without saving any data to internal storage. Once a data set is loaded from persistent storage to internal memory, it is also independent until saved back to persistent storage. Persistent data is overwritten every time the computation engine saves data.
Save data to persistent storage by selecting the File ⇒ Save menu item. Only four different program screens have a File menu: Project Definition, Basin Model, Meteorologic Model, and Control Specifications. Selecting the File ⇒ Save menu item on the Control Specifications screen will save the current control specifications and no other components. Likewise, the File ⇒ Save menu item on the Basin Model and Meteorologic Model screens only saves the current basin model or meteorologic model, respectively. However, the File ⇒ Save Project menu item on the Project Definition screen saves all current components, project data such as precipitation and discharge gages, and project settings. A warning screen appears when opening a component while the current component contains changes that have not been saved.

Data can automatically be saved to persistent storage when changing screens. Select the File ⇒ Project Attributes menu item on the Project Definition screen to set this option. Place a check in the "OK and apply automatically save to disk" checkbox on the options tab. Press the OK button to close the screen and then save the project to affect the change.

A data set is automatically provided with a default name when it is created. It is helpful to replace the default name with a more meaningful name. A name must be unique among members of the same class. For example, two basin models cannot have the same name. However, a precipitation and discharge gage can have the same name since they are members of different classes.

**Application Steps**

The program is designed with reusable data sets that can be independently developed. However, some data sets depend on others for important definitions. Gages must be created before they can be used in basin or meteorologic models. A basin model must exist before several of the precipitation methods can be used. A complete set of compatible components must exist before a run can be configured and executed. Consequently, there is a necessary sequence to successfully create and execute a run. The remainder of this chapter provides an overview of the best procedure for obtaining computation results.

**Create a New Project**

Create a new project by selecting the File ⇒ New Project menu item on the Project Definition screen. Enter a project name and, optionally, enter a description and change the storage location. Long descriptions can be easily entered using a text editor accessed by pressing the ... button next to the description field.
Enter Shared Data

Create precipitation gages that will be required for the meteorologic model, followed by discharge gages that will be required for observed flow in the basin model. Select the Data ⇒ Precipitation Gages menu item to open the gage manager. The New Precipitation Record screen will automatically open because no gages have been created yet. Finish creating the gage and then create additional precipitation or discharge gages.

Create unit hydrographs or s-graphs that will be required for the basin model. Select the Data ⇒ User-Specified Unit Hydrographs menu item to open the unit hydrograph manager. The New Unit Hydrograph Record screen will automatically open because no unit hydrographs have been created yet. Finish creating the unit hydrograph and then create additional unit hydrographs or s-graphs.

Create a Basin Model

Create a new basin model by selecting the Component ⇒ Basin Model ⇒ New menu item on the Project Definition screen. Enter a name, optional description, and then press the OK button. Set the basin model attributes to the desired default methods and locate any files. If the optional background map will be used, add it before hydrologic elements are created. Add hydrologic elements to the schematic and connect them into a dendritic network. Use the element or global editors to enter data. Save the basin model.

Create a Meteorologic Model

Create a new meteorologic model by selecting the Component ⇒ Meteorologic Model ⇒ New menu item on the Project Definition screen. Enter a name, optional description, and then press the OK button. The Subbasin List screen automatically opens whenever the list is empty. Select the name of the basin model and press the Add button to load the subbasin names from the basin model into the subbasin list. Press the Close button to continue to the Meteorologic Model screen. Select a precipitation method and enter the required data. If the soil moisture accounting method is used, turn on evapotranspiration in the meteorologic model attributes. When the data for the model is complete, press the OK button to save.

Create Control Specifications

Create new control specifications by selecting the Component ⇒ Control Specifications ⇒ New menu item on the Project Definition screen. Enter a name, optional description, and then press the OK button. Enter the start date, start time, end date, and end time. Select a time interval from the list. Press the OK button to save the control specifications.

Simulate and View Results

Create a new run by selecting the Tools ⇒ Run Configuration menu item on the Project Definition screen. Select one basin model, one meteorologic model, and one control specifications. Enter a name, optional description, and press the OK button to create the run. Select the Tools ⇒ Run Manager menu item on the Project Definition screen. Select a run in the table by clicking it with the left mouse button. Press the Compute button at the bottom on the screen to execute the run. Press the Close button to exit the run manager.
Exiting the Program

Save the project by selecting the File ⇒ Save Project menu item on the Project Definition screen. After the project is saved, exit the program by selecting the File ⇒ Exit menu item. All program screens will automatically close and the program will exit.
CHAPTER 4

Working with Projects

A project serves as a container for the different parts that together form the complete watershed model. This chapter describes the creation and management of projects. Information on the data objects that are shared by more than one component of the project are also included.

Creating and Managing Projects

Create a new project by selecting the File ⇒ New Project menu item on the Project Definition screen (Figure 3). The name (20 character limit) and optional description (1,024 character limit) are entered on the New Project screen (Figure 4). The location where the project will be stored can also be set; the default location is the HMSPROJ directory created during program installation. The last directory in the file path to the storage location will become the project directory; the default directory is the project name with underscores substituted for special characters. It is not possible to change the storage location after a project has been created. Press the OK button to create the project or the Cancel button to abort the process. When the OK button is pressed, the project is created and the Project Definition screen automatically opens the new project.

![Project Definition Screen]

*Figure 3. The Project Definition screen.*
Open a project by selecting the File ⇒ Open Project menu item on the Project Definition screen. The Open Project screen (Figure 5) opens with the project list. The project list contains the names of projects that have been used previously. Select a project by clicking on a row in the table and pressing the Open button, or by double-clicking a row in the table. Click the "Unlisted Project" tab to open a project that is not in the project list (Figure 6). Use the file browser on the right side of the screen to navigate to a directory. The name and description of projects in the current directory are shown in the table on the left side of the screen. Select a project by clicking on a row in the table and pressing the Open button, or by double-clicking a row in the table. Uncheck the "Add to project list" checkbox at the bottom of the screen if to open the project without adding it to the project list.
Delete a project by selecting the **File ⇒ Delete Project** menu item on the *Project Definition* screen. The *Delete Project* screen (Figure 7) opens with a list of all projects in the project list. Select a project by clicking on a row in the table and pressing the **Delete** button, or by double-clicking a row in the table. After a project has been selected to delete, the *Delete Project* screen automatically opens (Figure 8). Select the deletion level and press the **OK** button to continue or the **Cancel** button to abort the process. The first level removes the project name from the project list and leaves all project files completely intact. The second level deletes all files except for external DSS files. The *Open Project* screen will open if the current project is deleted.
Figure 8. Selecting the delete level for a project.

Save the current project by selecting the **File ⇒ Save Project** menu item on the Project Definition screen. Project settings and all current components including basin models, meteorologic models, control specifications, precipitation and discharge gages, runs, and optimization runs and trials will be saved when the project is saved.

Copy a project by first opening the original project and then selecting the **File ⇒ Copy Project** menu item on the Project Definition screen. The Copy Project screen (Figure 9) will open. Enter the name of the new project to be created and optionally a description and storage location; the default storage location is the HMSPROJ directory created during program installation. All files created by the program in the project directory will be copied to the new project. Uncheck the "Add to project list" checkbox near the bottom of the screen to make the project unlisted instead of automatically adding it to the project list.

Figure 9. Saving a copy of a project.

Rename a project by first opening the original project and then selecting the **File ⇒ Rename Project** menu item on the Project Definition screen. The Rename Project screen (Figure 10) will open. Enter the new name and optionally a description and storage location for the new project.
Directories and Files

The program automatically creates and manages many different files, all of which are stored in the project directory. A project directory is automatically created in the computer file system when a new project is created. Even though multiple projects can be stored in the same directory, it is recommended that each project be stored in a separate directory. Separate directories improve file system organization and facilitate archiving by external backup software.

Files Generated by the Program

Each data set or class of data sets is stored in a separate file in the project directory. The names used for components or data sets are automatically converted to filenames. Underscores are substituted for special characters not allowed by the computer file system. For example, a basin model named North Branch would be stored in the file `north_branch.basin`. A complete list of files used by the program is shown in Table 6. A majority of the files are in ASCII format but the user should never need to look at the files. Management functions should always be performed through the program since some information is stored in multiple files. The program may not run correctly when files are unsynchronized because of external management operations.

User-Specified Files

Files that are not automatically created and managed by the program can be added to the project directory by the user. Optional background map files can be added and used by basin models. The grid-cell file required by the ModClark transform method must be created external to the program. These optional and required files can be stored at any location on the computer file system, but it is often convenient to store them in the project directory. Additional supplementary files, related to the project but not used by the program, can also be placed in the project directory and will be ignored. However, when a project is copied, only files used by the program will be copied.
### Table 6. Files stored in the project directory.

<table>
<thead>
<tr>
<th>Filename</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>project-name.hms</td>
<td>List of basin models, meteorologic models, control specifications, and project settings.</td>
</tr>
<tr>
<td>project-name.dss</td>
<td>Project DSS file containing model data, computation results, and optimization results.</td>
</tr>
<tr>
<td>project-name.dsc</td>
<td>Catalog of records in the project DSS file.</td>
</tr>
<tr>
<td>project-name.gage</td>
<td>Definition of precipitation and discharge gages.</td>
</tr>
<tr>
<td>project-name.run</td>
<td>Definition of all runs in the project.</td>
</tr>
<tr>
<td>project-name.log</td>
<td>Messages other than simulation, optimization, and import generated since the project was last opened.</td>
</tr>
<tr>
<td>project-name.out</td>
<td>List of data read from and written to the project DSS file during the last run.</td>
</tr>
<tr>
<td>project-name.smu</td>
<td>Definition of all SMA units.</td>
</tr>
<tr>
<td>basin-name.basin</td>
<td>Basin model element data, network configuration, and model settings.</td>
</tr>
<tr>
<td>met-name.met</td>
<td>Meteorologic model configuration, method data, and model settings.</td>
</tr>
<tr>
<td>control-spec-name.control</td>
<td>Control specifications data.</td>
</tr>
<tr>
<td>run-name.log</td>
<td>Messages produced during the last compute of the run.</td>
</tr>
<tr>
<td>project-name.optrun</td>
<td>Definition of all optimization runs in the project.</td>
</tr>
<tr>
<td>project-name.trial</td>
<td>Definition of all optimization trials in the project.</td>
</tr>
<tr>
<td>opt-trial-name.optim</td>
<td>Results from the last compute of the optimization trial.</td>
</tr>
<tr>
<td>opt-run.log</td>
<td>Messages produced during the last compute of any trial in the optimization run.</td>
</tr>
</tbody>
</table>

### Project DSS File

The project DSS file stores time-series and paired data generated in the project. Time-series data include computation results, optimization results, and manually entered precipitation and discharge gages. Paired data include stage-discharge curves entered for basin model elements, user-specified input ordinates hydrograph values, and reservoir or reach storage-outflow curves. Data is automatically updated when a run is computed or when an edited basin model or gage is saved. Data is also automatically deleted when the run, model, or gage that produced them is deleted.

Time-series or paired data are stored in records. Each record contains only one type of data. Information about the data is stored in a header inside the record. The header for time-series data includes the record name, whether the data is on a regular or irregular time interval, start date and time, end date and time, number of values, measurement units, and data type. The header for paired data includes the record name, number of curves, measurement units of the first series, data type of the first series, measurement units of the second and subsequent series, and data type of the second and subsequent series.

The record name is called the pathname. Each pathname contains seven parts called the A-part, B-part, C-part, D-part, E-part, and F-part. The pathname parts are separated with a slash and may contain spaces. The complete pathname, including
slashes and spaces, can total up to 80 uppercase characters. The following is an example of a pathname:

//SAND CR/FLOW/01JAN1985/1HOUR/OBS/

A consistent naming convention is used for assigning the different pathname parts of the computation results (HEC, 1994). The B-part is assigned the name of the element in the basin model. The C-part is assigned a data descriptor as described in Appendix B. The D-part is assigned the simulation start date. The E-part is assigned the simulation time interval. The F-part is assigned the run name.

**External DSS Files**

External DSS files are all DSS files used in a project except the project DSS file created to store model data and computation results. The external files can store regular or irregular interval precipitation and flow data and can be located anywhere on the computer and shared with other programs. The program automatically determines the data type, units, and interval from the record header. Acceptable data types and units are shown in Table 7 and apply to both regular and irregular time series records.

<table>
<thead>
<tr>
<th>Data Type</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>per-cum</td>
<td>Total precipitation occurring in each time interval with units &quot;mm&quot; or &quot;in&quot;; use for incremental precipitation.</td>
</tr>
<tr>
<td>per-aver</td>
<td>Average flow during each time interval with units &quot;cms&quot; or &quot;cfs&quot;; use for time intervals equal to or greater than 1 day.</td>
</tr>
<tr>
<td>inst-cum</td>
<td>Instantaneous cumulative precipitation at the end of each time interval with units &quot;mm&quot; or &quot;in&quot;; use for precipitation mass curve.</td>
</tr>
<tr>
<td>inst-val</td>
<td>Instantaneous flow at the end of each time interval with units &quot;cms&quot; or &quot;cfs&quot;; use for time intervals less than 24 hours.</td>
</tr>
</tbody>
</table>

**Overview of Gage Data**

Hydrologic models often require time-series of precipitation data for estimating rainfall. A time-series of flow data, often called observed flow or observed discharge, is helpful for calibrating a model and is required for optimization. Time-series data is stored in a project as a gage. The program separates different types of data with different gage types. Both precipitation and discharge gages are similarly managed and subsequent examples will be with precipitation gages.

Gage data only has to be entered one time. The gages are owned by the project and can be shared by multiple basin or meteorologic models. Basin and meteorologic models refer to the gage by name so changes to the gage data are automatically updated everywhere the gage is referenced.

The Gage Manager screen is used to create and manage gages [Figure 11]. It is accessed by selecting the Data ➔ Precipitation Gages menu item on the Project Definition screen. The Data menu contains menu items for precipitation and discharge gages. Selecting one of the menu items on the Data menu will open the Gage Manager screen for that data type.
Creating External DSS Gages

Create a new external DSS gage in the Gage Manager screen by selecting the Edit ⇒ Add Gage menu item. Type a name and optional description for the new gage in the New Record screen (Figure 12). Only precipitation gages can have a latitude and longitude. Click the "External DSS Record" radio button. Press the OK button to continue or the Cancel button to abort the process.
The **DSS Pathname Select** screen opens to select the DSS file and record pathname for the new gage (Figure 13). Enter the name of the DSS file that contains the gage data or press the **Browse** button to navigate to the file. After selecting a DSS filename, enter the pathname by typing it or selecting from the catalog. A catalog of record pathnames in the selected DSS file can be displayed by pressing the **Generate Catalog** button. A pathname can be selected by clicking with the left mouse button in the display area. The catalog display list can be focused by using the filters under the display area. Only pathnames that meet the filter criteria will be shown in the display area. The **Generate Catalog** button must be pressed to update the catalog display after filters are entered. For example, entering *precip* in the C-part filter will only show pathnames with a C-part exactly equal to *precip*. Entering *p* will show all pathnames with a C-part that begins with *p*. Entering *inc* will show pathnames with a C-part that ends in *inc*. More than one filter can be used at a time.

It is not necessary to create multiple gages when the pathname will only be different in the D-part. For example, a precipitation gage with data for several years will usually be stored in multiple records, one for each month. It is not important which record is selected when the external DSS gage is created. The D-part of the pathname will differ between records but the program can automatically find data using the other pathname parts.

![DSS Pathname Select for River Plains](image)

**Figure 13.** Selecting a DSS file and pathname for a new external gage.

### Creating Manual-Entry Gages

Create a new manual entry gage by selecting the **Edit ⇒ Add Gage** menu item on the **Gage Manager** screen. Type a name and optional description for the new gage in the **New Record** screen. Only precipitation gages can have a latitude and longitude. Click the "Manual Entry" radio button. Press the **OK** button to continue or the **Cancel** button to abort the process.
Enter the start date, start time, end date, end time, and time interval for the gage in the *Time Parameters* screen ([Figure 14](#)). Optionally, select a control specifications from the list and press the **Set** button to automatically set the date and time information. Press the **OK** button to continue.

**Figure 14.** Setting time parameters for a new manual entry gage.

Enter the data values for the gage in the *Data Editor* screen ([Figure 15](#)). Press the **OK** button to save the data, close the screen, and return to the *Gage Manager* screen. The time window of the data shown in the editor can be changed by pressing the **Reset Time Parameters** button on the right side of the screen. Data values currently shown in the editor can be graphed by pressing the **Plot** button.
Chapter 4 Working with Projects

Figure 15. Entering manual entry gage data values.

Editing Previously Created Gages

Edit an external DSS gage by clicking on the gage in the Gage Manager screen with the left mouse button and select the Edit ⇒ Gage Source menu item. The DSS Pathname Select screen opens. Change the file or pathname containing the data and press the OK button to save the change. Data values for an external DSS gage cannot be edited in the program.

Edit a manual entry gage by clicking on the gage in the Gage Manager screen with the left mouse button and select the Edit ⇒ Gage Data menu item. The Select Time Window screen opens (Figure 16). Each gage keeps a list of time windows that have previously been used to create or edit data. The list is shown in the Select Time Window screen. Select an existing time window or press the "New Time Window" button to create one. The Data Editor screen opens after a time window is selected. Press the OK button to save the changes to the manual entry gage.
Edit the latitude or longitude of existing precipitation gages by selecting the **Edit ⇒ Latitude/Longitude** menu item. The **Precipitation Gage Location** screen opens to allow the location of any gage to be changed (Figure 17). Use the mouse to click in a cell and enter data. The latitude or longitude will automatically be corrected when the number of seconds or minutes exceeds 60. Discharge gages do not have a location.

**Viewing Gage Data**

View a table of precipitation or discharge gage values by clicking on a gage in the table of the **Gage Manager** screen and selecting the **View ⇒ Table** menu item. Select a time window and press the **OK** button to continue. A typical table is shown in (Figure 18). Print the table by pressing the **Print** button.
The procedure for viewing a graph of gage values is very similar to viewing a table. View a graph by clicking on a gage in the table of the Gage Manager screen and selecting the View ⇒ Graph menu item. A typical graph is shown in Figure 19. The graph can be printed by pressing the Print button.

The DSS filename and record pathname for each gage can be viewed by selecting the View ⇒ Pathnames menu item in the Gage Manager screen. When the Gage File/Pathname List screen opens, it shows the name of the DSS file where the data
for each gage is stored (Figure 20). Manual entry gages are always stored in the project DSS file. Click the "Pathname" radio button near the bottom of the screen to switch from viewing filenames to pathnames. Click the "DSS File Name" radio button to switch back to viewing filenames.

![Figure 20. Viewing the DSS file for each precipitation gage.](image)

**Deleting Gages**

Delete a gage from the project in the Gage Manager screen. Click on a gage in the table and select the Edit ⇒ Delete Gage menu item. A confirmation screen will appear before the deletion is performed.

**Overview of Paired Data**

Hydrologic models often require the use of paired data to describe inputs that are functional in form. Functional data defines a dependant variable in terms of an independent variable. For most cases, the function must be monotonically increasing. Examples of paired data include unit hydrographs and stage-discharge curves. The program separates different types of paired data with different data types. Managers are currently implemented for both unit hydrograph and s-graph paired data. They are similarly managed and subsequent examples will be with unit hydrographs.

Paired data only has to be entered one time. The data are owned by the project and can be shared by multiple basin models. Basin models refer to the data by name so changes to the data are automatically updated everywhere it is referenced.

The Unit Hydrograph Manager screen is used to create and manage unit hydrographs (Figure 21). It is accessed by selecting the Data ⇒ User-Specified Unit Hydrographs menu item on the Project Definition screen. The Data menu contains menu items for user-specified unit hydrographs and user-specified s-graphs. Selecting one of the menu items on the Data menu will open the Manager screen for that data type.
Creating External DSS Unit Hydrographs

Create a new external DSS unit hydrograph in the Unit Hydrograph Manager screen by selecting the **Edit ⇒ Add Unit Hydrograph** menu item. Type a name and optional description for the new unit hydrograph in the **New Unit Hydrograph Record** screen (Figure 22). Select the time interval and flow units for specifying the unit hydrograph ordinates. Click the "external DSS record" radio button. Press the **OK** button to continue or the **Cancel** button to abort the process.
Creating Manual-Entry Unit Hydrographs

Create a new manual-entry unit hydrograph by selecting the **Edit ⇒ Add Unit Hydrograph** menu item on the **Unit Hydrograph Manager** screen. Type a name and optional description for the new unit hydrograph in the **New Unit Hydrograph Record** screen. Click the "Manual Entry" radio button. Press the **OK** button to continue or the **Cancel** button to abort the process.

Enter the data values for the gage in the **Data Editor** screen. Press the **OK** button to save the data, close the screen, and return to the **Unit Hydrograph Manager** screen.
Figure 23. Entering data for a user-specified unit hydrograph.

Editing Previously Created Unit Hydrographs

Edit an external DSS gage by clicking on the unit hydrograph in the Unit Hydrograph Manager screen with the left mouse button and select the Edit ⇒ Source menu item. The DSS Pathname Select screen opens. Change the file or pathname containing the data and press the OK button to save the change. Data values for an external DSS unit hydrograph cannot be edited in the program.

Edit a manual entry unit hydrograph by clicking on the unit hydrograph in the Unit Hydrograph Manager screen with the left mouse button and select the Edit ⇒ Unit Hydrograph Data menu item. The Data Editor screen opens. Press the OK button to save the changes to the manual entry unit hydrograph.

Viewing Unit Hydrograph Data

View a table of ordinates for a unit hydrograph by clicking on a unit hydrograph in the table of the Unit Hydrograph Manager screen and selecting the View ⇒ Table menu item. A typical table is shown in Figure 24. Print the table by pressing the Print button.
Figure 24. Viewing a table of unit hydrograph ordinates.

The procedure for viewing a graph of ordinates for a unit hydrograph is very similar to viewing a table. View a graph by clicking on a unit hydrograph in the table of the Unit Hydrograph Manager screen and selecting the View ⇒ Graph menu item. A typical graph is shown in Figure 25. The graph can be printed by pressing the Print button.
Deleting Unit Hydrographs

Delete a unit hydrograph from the project in the Unit Hydrograph Manager screen. Click on a unit hydrograph in the table and select the Edit ⇒ Delete Unit Hydrograph menu item. A confirmation screen will appear before the deletion is performed.

Soil Moisture Accounting Units

Soil moisture accounting (SMA) units contain storage and maximum infiltration rate specifications. Units are created and managed separately from basin models and subbasin elements that use the SMA loss method. Units must be specified before they can be referenced by a subbasin. Each subbasin that uses a unit can have a different set of initial conditions. Select the Data ⇒ Soil Moisture Accounting Units menu item on the Project Definition screen to access the SMA Unit Editor screen for managing units and entering data (Figure 26).

The SMA unit editor screen uses five tabs for inputting data for the five storage layers: canopy, surface, soil profile, groundwater 1, and groundwater 2. The only required parameter on the "Canopy" tab is the storage capacity. All capacities are entered as uniform depths over the entire area of the unit. Required parameters on the "Surface" tab are storage capacity and soil infiltration maximum rate. Required parameters on the "Soil Profile" tab are storage, tension zone capacity, and percolation maximum rate. Optionally, evapotranspiration can be turned off for any month of the year by pressing the Evaporation button. Required parameters on the "Groundwater 1" tab are storage capacity, percolation maximum...
rate, and storage coefficient. The storage coefficient is used in a linear reservoir to compute the lateral flow out of the layer. Both groundwater layers function similarly except for percolation. Percolation from the groundwater 1 layer enters groundwater 2 and percolation from the groundwater 2 layer is lost from the system.

Create a new SMA unit by selecting the Edit ⇒ Add SMA Unit menu item on the SMA unit editor screen. The Add SMA Unit screen opens (Figure 27). Enter a name and press the OK button.

Figure 26. Managing SMA units and entering data.

Figure 27. Creating a new SMA unit.
Copy a SMA unit by selecting the Edit ⇒ Copy SMA Unit menu item on the SMA Unit Editor screen. The Copy SMA Unit screen opens (Figure 28). Select the "copy from" unit and enter a name for the new unit. Press the OK button to make the copy.

Delete a SMA unit by selecting the Edit ⇒ Delete SMA Unit menu item on the SMA unit editor screen. The Delete SMA Unit screen opens (Figure 29). Select a SMA unit by placing the arrow pointer over a row in the table and clicking the left mouse button. Press the Delete key to delete the SMA unit.
Project Attributes

Project settings and defaults are modified by selecting the **File ⇒ Project Attributes** menu item on the *Project Definition* screen. The *Project Attributes* screen contains six tabs for different types of attributes (Figure 30). New basin and meteorologic models are created with settings and defaults defined in the project attributes but can always be changed in an individual model. Default computation methods for basin models are set on the "Basin Defaults" tab and basin model options on the "Basin Options" tab. Default computation methods for meteorologic models are set on the "Met Defaults" tab and meteorologic model options are set on the "Met Options" tab. The unit system for models is set on the "Units" tab. Project options are set on the "Project Options" tab. Check the "Apply these settings to new projects" checkbox to create new projects with the attributes currently shown on the screen.

![Figure 30. Setting project attributes.](image)

Importing HEC-1 Data

The program can import HEC-1 Version 3.0 (September 1981) or newer input files. Some of the computation options available in HEC-1 are not available in the program. Unrecognized input data is automatically ignored during the import process and reported in the import log. However, the import process is generally successful in separating the input file into component parts for addition to the current project. The job description and initialization data records become control specifications. The hydrograph calculation data records are separated into a basin model and meteorologic model. Precipitation and flow gages are created when necessary. Imported components should always be checked for accuracy.

Import a HEC-1 input file to the current project by selecting the **File ⇒ Import HEC-1 File** menu item on the *Project Definition* screen. The *Open* screen opens to select the input file. Use the navigation tools to locate the input file, select it, and press the **OK** button. The *Import HEC-1 File* screen (Figure 31) opens with the selected file.
shown at the top of the screen. The selected file can be changed by pressing the **Browse** button. Default basin model, meteorologic model, and control specifications names are shown but can be changed. Press the **Import** button to continue or the **Cancel** button to abort the process.

![Figure 31. Importing a HEC-1 input file.](image1)

Messages produced during the import are automatically placed in an import log. The file is automatically displayed at the end of an import (Figure 32).

![Figure 32. Viewing the import log file.](image2)
CHAPTER 5

Basin Models

This chapter describes basin models and how their data is entered and edited. The basin model is one of the components required for a run, along with a meteorologic model and control specifications. The system connectivity and physical data describing the watershed are stored in the basin model.

Creating and Managing Basin Models

Create a new basin model by selecting the Edit ⇒ Basin Model ⇒ New menu item on the Project Definition screen. The name (20 character limit) and an optional description (1,024 character limit) are entered on the New Basin Model screen (Figure 33). Press the OK button to create the basin model or the Cancel button to abort the process. When the OK button is pressed, the program creates the basin model if the name is not already in use and automatically opens the Basin Model screen (Figure 34). A new basin model can also be created by selecting the File ⇒ New Basin Model menu item on the Basin Model screen.

Open an existing basin model by selecting the Edit ⇒ Basin Model ⇒ Open menu item on the Project Definition screen. The Basin Model * Open screen (Figure 35) opens with a list of all basin models in the current project. Select a basin model by clicking on a row in the table and pressing the Select button, or by double-clicking a row in the table. A basin model can also be opened by double-clicking in the basin model component list in the Project Definition screen or by selecting the File ⇒ Open Basin Model menu item on the Basin Model screen.
Figure 34. The Basin Model screen.

Figure 35. Opening a basin model.
Delete a basin model by selecting the Edit ⇒ Basin Model ⇒ Delete menu item on the Project Definition screen. The Basin Model * Delete screen (Figure 36) opens with a list of all basin models in the current project. Select a basin model by clicking on a row in the table and pressing the Delete button, or by double-clicking a row in the table. A basin model can also be deleted by selecting the File ⇒ Delete Basin Model menu item on the Basin Model screen.

Figure 36. Deleting a basin model.

Save a basin model by selecting the File ⇒ Save Basin Model menu item on the Basin Model screen. The current basin model is also saved when the project is saved by selecting the File ⇒ Save Project menu item on the Project Definition screen.

Copy a basin model by first opening the original basin model and then selecting the File ⇒ Save Basin Model As menu item on the Basin Model screen. The Basin Model * Save As screen (Figure 37) will open. Enter the name of the new basin model to be created. Uncheck the “Open new basin model” checkbox near the bottom of the screen to continue working with the original basin model instead of automatically opening the copy.

Rename a basin model by first opening the original basin model and then selecting the File ⇒ Rename Basin Model menu item on the Basin Model screen. The Basin Model * Rename screen (Figure 38) will open. Enter the new name and optional description for the basin model.
Hydrologic Elements

Hydrologic elements are the basic building blocks of a basin model. An element represents a physical process such as a watershed catchment, stream reach, or confluence. Each element represents part of the total response of the watershed to precipitation. Seven different element types have been included in the program: subbasin, reach, reservoir, junction, diversion, source, and sink.

An element uses a mathematical model to describe the physical process. Sometimes the model is only a good approximation of the original physical process over a limited range of environmental conditions. Data availability and the required parameters of a model can also determine fitness. To make the program suitable for many different conditions, most elements have more than one model or method for approximating the physical process. For example, there are three different methods for specifying the input data for a reservoir.
Subbasin

A subbasin is an element that usually has no inflow and only one outflow. It is one of only two ways to produce flow in the basin model. Outflow is computed from meteorologic data by subtracting losses, transforming excess precipitation, and adding baseflow. The subbasin can be used to model a wide range of watershed catchment sizes.

Reach

A reach is an element with one or more inflow and only one outflow. Inflow comes from other elements in the basin model. If there is more than one inflow, all inflow is added together before computing the outflow. Outflow is computed using one of the several available methods for simulating open channel flow. The reach can be used to model rivers and streams.

Reservoir

A reservoir is an element with one or more inflow and one computed outflow. Inflow comes from other elements in the basin model. If there is more than one inflow, all inflow is added together before computing the outflow. Outflow is computed from a user-specified monotonically increasing storage-outflow relationship and the assumption that the water surface is level. The element can be used to model reservoirs, lakes, and ponds.

Junction

A junction is an element with one or more inflow and only one outflow. All inflow is added together to produce the outflow by assuming zero storage at the junction. It is usually used to represent a river or stream confluence.

Diversion

A diversion is an element with two outflows, main and diverted, and one or more inflow. Inflow comes from other elements in the basin model. If there is more than one inflow, all inflow is added together before computing the outflows. The amount of diverted outflow is computed from a user-specified monotonically increasing inflow-diversion relationship. All flow that is not diverted becomes main outflow. Diverted outflow can be connected to an element that is computationally downstream. The diversion can be used to represent weirs that divert flow into canals, flumes, or off-stream storage.

Source

A source is an element with no inflow, one outflow, and is one of only two ways to produce flow in the basin model. The source can be used to represent boundary conditions to the basin model such as measured outflow from reservoirs or unmodeled headwater regions. The boundary condition can also represent contributing area modeled in a separate basin model.

Sink

A sink is an element with one or more inflows but no outflow. Multiple inflows are added together to determine the total amount of water entering the element. Sinks can be used to represent the lowest point of an interior drainage area or the outlet of the basin model.
Basin Model Screen

The Basin Model screen provides a view of the current basin model. It is the screen used to create hydrologic elements in a basin model, connect them into a network, and enter data. It is used to manage basin models, can be used to control simulations, and is the primary method for viewing computation results. Consequently, it is central to working with the program.

The Basin Model screen includes a menu bar, toolbar, element palette, and schematic. The menu bar at the top of the screen provides access to (from left to right) basin model management, hydrologic element management, global data editors, run management, computation results, background map control, and help. The toolbar below the menu bar controls (from left to right) mouse pointer function, hydrologic element icon control, background map control, and run control. The hydrologic element palette on the left side of the screen can be used to create elements. The schematic displays element icons and the optional background map.

The Menu Bar

The File menu contains items for creating and managing basin models, setting basin model attributes, and printing the schematic. An overview of the functions provided in the menu is shown in Table 8.

Table 8. File menu functions in the Basin Model screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Basin Model</td>
<td>Create a new basin model.</td>
</tr>
<tr>
<td>Open Basin Model</td>
<td>Open a basin model.</td>
</tr>
<tr>
<td>Save Basin Model</td>
<td>Save the current basin model.</td>
</tr>
<tr>
<td>Save Basin Model As</td>
<td>Make a copy of the basin model.</td>
</tr>
<tr>
<td>Rename Basin Model</td>
<td>Rename the current basin model.</td>
</tr>
<tr>
<td>Delete Basin Model</td>
<td>Delete a basin model.</td>
</tr>
<tr>
<td>Basin Model Attributes</td>
<td>Set the attributes for the basin model.</td>
</tr>
<tr>
<td>Print Schematic</td>
<td>Print schematic of the basin model.</td>
</tr>
<tr>
<td>Close</td>
<td>Close the Schematic screen.</td>
</tr>
</tbody>
</table>

The Edit menu contains items for creating and managing hydrologic elements in the canvas. An overview of the functions provided in the menu is shown in Table 9.

Table 9. Edit menu functions in the Basin Model screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Select All</td>
<td>Select all of the elements in the basin model.</td>
</tr>
<tr>
<td>Edit Element</td>
<td>Edit the current element.</td>
</tr>
<tr>
<td>New Element</td>
<td>Create a new element.</td>
</tr>
<tr>
<td>Duplicate Element(s)</td>
<td>Duplicate the current element selection.</td>
</tr>
<tr>
<td>Delete Element(s)</td>
<td>Delete the current element selection.</td>
</tr>
</tbody>
</table>

The Parameters menu contains items for all of the global editors. Selecting a menu item will open the appropriate global editor and show data for all of the elements using that method.
The **Simulate** menu contains items for creating and managing runs. An overview of the function provided in the menu is shown in **Table 10**. The last four computed runs are shown at the bottom of the menu. Click on one of the run names to make that run the current run.

**Table 10.** Simulate menu functions in the Basin Model screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Run Configuration</td>
<td>Create a new run.</td>
</tr>
<tr>
<td>Run Manager</td>
<td>Manage runs including computing them.</td>
</tr>
<tr>
<td>Compute</td>
<td>Compute the current run.</td>
</tr>
</tbody>
</table>

The **View** menu contains items for viewing the results of a run. The **Global Summary Table** menu item opens a table of peak flows for all elements in the basin model. The **Message Log** menu item displays all messages generated during the last compute of the current run.

The **Map** menu contains items to control the background map and element icon display in the canvas. An overview of the functions provided in the menu is shown in **Table 11**.

**Table 11.** Map menu functions in the Basin Model screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Icon Style ⇒ Small Icons</td>
<td>Show small element icons.</td>
</tr>
<tr>
<td>Icon Style ⇒ Normal Icons</td>
<td>Show large element icons.</td>
</tr>
<tr>
<td>Icon Style ⇒ Image Icons</td>
<td>Show large image element icons.</td>
</tr>
<tr>
<td>Icon Style ⇒ Names Only</td>
<td>Show element names and no icons.</td>
</tr>
<tr>
<td>Icon Style ⇒ Flow Direction</td>
<td>Turn flow direction arrows on or off.</td>
</tr>
<tr>
<td>Icon Style ⇒ Names</td>
<td>Turn element names on or off.</td>
</tr>
<tr>
<td>Map Toggle ⇒ Boundary Maps</td>
<td>Turn subbasin boundary map on or off.</td>
</tr>
<tr>
<td>Map Toggle ⇒ River Maps</td>
<td>Turn stream map on or off.</td>
</tr>
<tr>
<td>Reset Map Scale</td>
<td>Zoom out to maximum extent.</td>
</tr>
</tbody>
</table>

The **Help** menu contains items for using the online help system and displaying information about the program. An overview of the functions provided in the menu is shown in **Table 12**.

**Table 12.** Help menu functions in the Basin Model screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Open the online help to the table of contents.</td>
</tr>
<tr>
<td>Search For Help On</td>
<td>Open the online help to the index.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Open the online help to the topic on how to use the online help system.</td>
</tr>
<tr>
<td>About HEC-HMS</td>
<td>View the program version number and license agreement.</td>
</tr>
</tbody>
</table>
The Toolbar

The arrow tool is used for selecting and moving elements in the schematic. Only one of the first four tools can be used at a time. Once a tool is selected, the tool remains active until another tool is selected. Select one element by placing the arrow pointer over the desired element icon and clicking the left mouse button. The current element selection is shaded yellow. Select several elements at one time by placing the arrow pointer over a blank place on the schematic. Hold the left mouse button and move the mouse to create a selection box around the element icons. Release the left mouse button to make the multiple elements the current selection. All of the elements in the current element selection are shaded yellow. Move an element by placing the arrow pointer over the element icon. Hold down the left mouse button and move the mouse to drag the element on the schematic. Release the left mouse button to place the element in a new location. The element remains the current selection after the move is complete.

The hand tool is used for moving the schematic. Move the schematic by placing the hand pointer on the canvas. Hold down the left mouse button and move the mouse to drag the schematic. Release the left mouse button to stop moving the canvas.

The positive magnification glass tool is used for increasing the schematic magnification. Zoom on part of the schematic by placing the positive magnification glass pointer on one corner of the zoom area. Hold the left mouse button and move the mouse to create a box [Figure 39]. Release the left mouse button and the schematic is automatically redrawn so the zoom area inside the box occupies the entire schematic display area. Double-click the left mouse button to reset the magnification to view all elements.

The negative magnification glass tool is used for decreasing the schematic magnification. Zoom out by placing the negative magnification glass pointer on one corner of the zoom area. Hold the left mouse button and move the mouse to create a box. Release the left mouse button and the schematic is automatically redrawn. The magnitude of the zoom reduction is the ratio of the size of the zoom area to the schematic display area. Double-click the left mouse button to reset the magnification to view all elements.

The second and set of buttons in the tool bar set the icon style used to display the elements in the schematic; only one display style can be used at a time. The third set of buttons turn background map layers on and off and control the flow direction arrows; these controls can be used independently. Details of the tool functions are summarized in Table 13. All of the buttons perform the same functions as menu items found on the Map menu.
Figure 39. Creating a zoom box to increase magnification.

Table 13. Toolbar functions on the Basin Model screen.

<table>
<thead>
<tr>
<th>Button</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td><img src="image" alt="Small Symbols" /></td>
<td>Sets the icon style to small symbols.</td>
</tr>
<tr>
<td><img src="image" alt="Large Symbols" /></td>
<td>Sets the icon style to large symbols.</td>
</tr>
<tr>
<td><img src="image" alt="Images" /></td>
<td>Sets the icon style to images.</td>
</tr>
<tr>
<td><img src="image" alt="Names Only" /></td>
<td>Sets the icon style to names only.</td>
</tr>
<tr>
<td><img src="image" alt="Background Boundary" /></td>
<td>Turns the optional background boundary map on or off.</td>
</tr>
<tr>
<td><img src="image" alt="Background Stream" /></td>
<td>Turns the optional background stream map on or off.</td>
</tr>
<tr>
<td><img src="image" alt="Flow Arrows" /></td>
<td>Turns the flow link direction arrows on or off.</td>
</tr>
</tbody>
</table>
Creating the Element Network

The hydrologic element network is created and managed from the Basin Model screen. The network is composed of individual hydrologic elements that have been connected to establish the direction water flows from one element to another. The network combines the individual building blocks of hydrologic elements into a representation of the complete response of a watershed to precipitation.

Network creation is a two-step process. The first step is to create the elements and place them on the schematic using one of two available methods. The second step is to establish the network connectivity. Elements can be added, deleted, moved, unconnected, and reconnected after the initial network is finished.

Create an element by placing the arrow pointer over an icon on the element palette. Hold the left mouse button and move the mouse to drag an element icon onto the schematic. Release the mouse button to place the element. An element can also be created by selecting the Edit ⇒ New Element menu item on the Basin Model screen or pressing the right mouse button, when the arrow pointer is not over an element, and selecting the New Element menu item. The arrow pointer changes to a cross-hair pointer. Move the cross-hair pointer over the schematic and click the left mouse button to place the new element.

Connect an element into the network by placing the arrow pointer over the element icon. Press the right mouse button and select the Connect Downstream menu item. The arrow pointer changes to a cross hair pointer. Place the cross-hair pointer over the element icon that will be the downstream element and click the left mouse button. A connection link automatically connects the two elements.

Delete an element in the network by placing the arrow pointer over the element icon. Press the right mouse button and select the Delete Element menu item. A confirmation screen appears before the element is deleted. The element and any connection links to upstream or downstream elements are deleted when the OK button is pressed in the confirmation screen. The current element selection can also be deleted by selecting the Edit ⇒ Delete Element(s) menu item on the Basin Model screen, pressing the delete key on the keyboard, or pressing the right mouse button when the arrow pointer is not over an element and selecting the Delete Element(s) menu item.

Move an element in the network by placing the arrow pointer over the element icon. Hold the left mouse button and move the mouse to drag the element. Release the mouse button to place the element in a new location. Any connection links to upstream or downstream elements automatically adjust.

Duplicate an element in the network by placing the arrow pointer over the element icon. Press the right mouse button and select the Duplicate Element menu item. The arrow pointer changes to a cross-hair pointer. Move the mouse and then click the left mouse button to place the duplicate copy. The current element selection can
also be duplicated by selecting the **Edit $$\Rightarrow$$ Duplicate Element(s)** menu item on the Basin Model screen or pressing the right mouse button when the arrow pointer is not over an element and selecting the **Duplicate Element(s)** menu item.

Disconnect the downstream connection of an element in the network by first placing the arrow pointer over the element icon. Press the right mouse button and select the **Delete Connection** menu item. A confirmation screen appears before the connection is deleted. The link connecting the element to the downstream element disappears after pressing the **OK** button in the confirmation screen.

### Element Editors

Each of the seven types of hydrologic element has an editor for selecting computation methods and entering data. The element editor is the only place where the name and description of the element can be changed. When an element has several computation methods, the element editor is the only place where the method can be changed. The editor can also be used to enter parameter values.

There are three different ways to access the editor for an element. All three methods require that the basin model be open in the Basin Model screen. The first method is to use the mouse to place the pointer over an element and hold down the right mouse button. A menu appears with several items for working with elements on the Basin Model screen. Select the **Edit** item by releasing the right mouse button with the pointer over the **Edit** item to automatically open the editor. The second method is to use the mouse to place the pointer over an element and click the left mouse button. The element becomes the current element and turns yellow. Select the **Edit $$\Rightarrow$$ Element** menu item on the Basin Model screen to automatically open the editor. The third method is to use the mouse to place the pointer over an element. Double-click the left mouse button to open the editor.

### Subbasin

The subbasin element represents a complete watershed. Assumptions are made that reduce the watershed to three separate processes: loss, transform, and baseflow. Part of the precipitation falling on the land surface infiltrates, ultimately into the groundwater to become baseflow or deep percolation. All infiltration processes are represented with a loss method. Rainfall that does not infiltrate becomes direct runoff and moves across the watershed surface or through the upper soil horizons to streams and eventually reaches the watershed outlet. All runoff processes are represented as pure surface routing using a transform method. Groundwater contributions to channel flow are called baseflow and are represented with a baseflow method.

The subbasin editor uses an input screen with tabs to separate the different types of data required to describe the watershed (Figure 40). Each subbasin can only have one loss method, one transform method, and one baseflow method. Input fields for subbasin name, description, and area are above the tab input area.
A flow ratio can be applied to the outflow hydrograph computed using the selected methods and parameters. When a ratio is used, each ordinate in the outflow hydrograph is adjusted by multiplying by the ratio before the results are saved to the project DSS file. The adjusted hydrograph becomes the result for the subbasin and the unadjusted hydrograph is not available for viewing. All downstream computations use the adjusted hydrograph. The flow ratio is unavailable unless it is set on the "Options" tab of the basin model attributes.

Subbasin Loss Methods

All land and water in a watershed can be categorized as either directly-connected impervious surface or pervious surface. Directly-connected imperviousness surface in a watershed is that portion of the watershed for which all precipitation runs off, with no infiltration, interception, evaporation, or other losses. Precipitation on the pervious surfaces is subject to losses. The amount of directly-connected imperviousness surface in a subbasin is specified as the percent imperviousness. A loss method is used to compute losses from precipitation.

A total of seven methods for estimating losses are included in the program: deficit and constant, Green and Ampt, gridded SCS curve number, gridded soil moisture accounting, initial and constant, SCS curve number, and soil moisture accounting. All of the loss methods are compatible with all of the transform methods with the exception of the gridded SCS curve number and gridded soil moisture accounting methods; these methods can only be used with the ModClark transform. Losses are computed as zero when no loss method is selected.
Deficit and Constant

The deficit and constant method uses a one-layer system with recovery to model infiltration. Recovery approximates soil column draining, evaporation, and transpiration processes. A conceptual view of the model is shown in Figure 41. Maximum deficit represents the total storage depth. Initial deficit represents the empty storage depth at the beginning of the simulation. No excess precipitation occurs until the initial deficit storage is filled. Recovery rates can be specified on a monthly basis.

Required parameters are the initial deficit, maximum deficit, loss rate, and recovery rates. The percent imperviousness has a default value of zero and can optionally be increased (Figure 42).

![Conceptual view of the deficit constant method.](Figure 41)
The Green and Ampt method models infiltration by combining an unsaturated flow form of Darcy's law with requirements of mass conservation. An initial loss is included to model interception and depression storage. Excess precipitation is computed using the Green and Ampt equations after the initial loss is satisfied. Required parameters are the initial loss, volumetric moisture deficit, wetting front suction, and conductivity. Volumetric moisture deficit must be in the range 0 to 1. The percent imperviousness has a default value of zero and can optionally be increased (Figure 43).
Gridded SCS Curve Number

The gridded SCS curve number method can be used with the ModClark transform to compute excess infiltration with a different curve number for each grid cell. Curve numbers are specified in the grid-cell file. Required parameters are the initial abstraction ratio, which ranges from 0.427 to 2.28, and potential retention scale factor, which ranges from 0.095 to 0.38 (Figure 44). There is no percent imperviousness with this loss method.
Figure 44. Subbasin using the gridded SCS curve number loss method.

Gridded Soil Moisture Accounting

The gridded soil moisture accounting (SMA) method can be used with the ModClark transform to specify a SMA unit for each grid cell. A SMA unit name is specified for each cell in the grid-cell file. SMA units must be defined on the Data menu of the Project Definition screen before they can be referenced in a subbasin element. Individual grid cells are computed separately so several cells using the same SMA unit can represent a discontinuous region in the subbasin. Required parameters are the initial storage as a percentage of capacity for each layer (Figure 45). The same initial storage percentages are applied for every grid cell in the subbasin. There is no percent imperviousness with this loss method.
Initial and Constant

The initial and constant method represents interception and depression storage with an initial loss. All other losses are represented with a constant loss rate. No excess precipitation occurs until the initial loss is satisfied. Required parameters are the initial loss and the constant loss. The percent imperviousness has a default value of zero but can optionally be increased (Figure 46).

SCS Curve Number

The Soil Conservation Service (SCS), now known as the Natural Resources Conservation Service, developed the empirical curve number method to estimate total excess precipitation for a storm based on cumulative precipitation, soil cover, land use, and antecedent moisture. Incremental excess precipitation is computed using cumulative precipitation and cumulative excess precipitation at the end of each model time step. Required parameters are the initial loss and the curve number, which can range from 0 to 99 but practically must be above 40. The percent imperviousness has a default value of zero and can optionally be increased.
Chapter 5  Basin Models

Figure 46. Subbasin using the initial and constant loss method.

Figure 47. Subbasin using the SCS curve number loss method.
Soil Moisture Accounting

The soil moisture accounting (SMA) method uses a five-layer system with evapotranspiration to model infiltration. A conceptual view of the model is shown in Figure 48. Storage volumes and maximum percolation rates are specified separately from the subbasin in SMA units, which must be defined on the Data menu of the Project Definition screen before they can be referenced in a subbasin. More than one subbasin can use the same SMA unit definition.

Figure 48. Conceptual view of the soil moisture accounting method.
Infiltration computations for each time step are completed before evapotranspiration. Storages are filled for each time step in the following order:

1. Canopy interception
2. Surface depression
3. Soil profile
4. Groundwater 1
5. Groundwater 2

Precipitation first fills the canopy interception storage. After canopy interception is full, precipitation is added to the surface depression storage. Water infiltrates from surface depression into the soil profile at a rate up to the maximum infiltration rate. When the surface depression is full, precipitation above the maximum infiltration rate becomes excess precipitation. Water in the soil profile percolates to the groundwater 1 layer. Currently up to two groundwater layers may be used. Water in groundwater 1 layer moves laterally out of the layer as baseflow and then percolation to the groundwater 2 layer is computed. Water in the groundwater 2 layer moves laterally out of the layer as baseflow and then deep percolation out of the system is computed.

Potential evapotranspiration is satisfied for each time step in the following order:

1. Canopy interception
2. Surface depression
3. Soil profile
4. Soil profile tension zone

Evapotranspiration only occurs from the highest storage on the list that contains water. Potential evapotranspiration is satisfied from one storage at a time until all storages are exhausted or precipitation begins. Evapotranspiration can occur sequentially from more than one storage in the same time step. Water evacuation from the first three layers occurs at the maximum amount necessary to satisfy potential evapotranspiration. A percentage of potential evapotranspiration is used to compute the evacuation from the tension zone, representing the increased difficulty to remove water attached to soil particles. Groundwater does not move up into the soil profile and is not used to satisfy potential evapotranspiration. No evapotranspiration occurs during periods with precipitation. Potential evapotranspiration is computed by the meteorologic model and is independent of the loss method.

Required parameters are the SMA unit and initial storage as a percentage of capacity for each layer [Figure 49]. A SMA unit must be specified in the project before it can be used in the subbasin element. There is no percent imperviousness with this loss method.
Precipitation that does not infiltrate or falls on directly-connected imperviousness surface becomes excess precipitation. While excess precipitation can remain on the watershed in depressions or ponds, it typically moves down-gradient on the watershed land surface and becomes direct runoff. A transform method is used to compute direct runoff from excess precipitation.

Direct runoff for each subbasin can be modeled with one of six different methods. The methods include a conceptual kinematic wave model, the ModClark quasi-distributed linear transform, and empirical unit hydrograph techniques: Clark, Snyder, SCS, and user-specified. All transform methods can be used with all loss methods except that the gridded SCS curve number and gridded soil moisture accounting methods can only be used with the ModClark transform.

**Clark Unit Hydrograph**

The Clark unit hydrograph method explicitly represents translation and attenuation of excess precipitation as it moves across the subbasin to the outlet. Translation is based on a synthetic time-area curve and the time of concentration. Attenuation is modeled with a linear reservoir. Required parameters are the time of concentration and the storage coefficient, both in hours. 

---

**Subbasin Transform Methods**

Precipitation that does not infiltrate or falls on directly-connected imperviousness surface becomes excess precipitation. While excess precipitation can remain on the watershed in depressions or ponds, it typically moves down-gradient on the watershed land surface and becomes direct runoff. A transform method is used to compute direct runoff from excess precipitation.

Direct runoff for each subbasin can be modeled with one of six different methods. The methods include a conceptual kinematic wave model, the ModClark quasi-distributed linear transform, and empirical unit hydrograph techniques: Clark, Snyder, SCS, and user-specified. All transform methods can be used with all loss methods except that the gridded SCS curve number and gridded soil moisture accounting methods can only be used with the ModClark transform.

**Clark Unit Hydrograph**

The Clark unit hydrograph method explicitly represents translation and attenuation of excess precipitation as it moves across the subbasin to the outlet. Translation is based on a synthetic time-area curve and the time of concentration. Attenuation is modeled with a linear reservoir. Required parameters are the time of concentration and the storage coefficient, both in hours.
Figure 50. Subbasin using the Clark unit hydrograph transform method.

**Kinematic Wave**

The kinematic wave method uses the continuity equation and the steady, uniform flow approximation of the momentum equation to transform precipitation to flow. A conceptual model is used that includes up to two rectangular overland flow planes and three channels. At least one flow plane and one channel are required. The conceptual model uses the planes and channels as shown in Figure 51.

Figure 51. Conceptual model of a watershed (left) with the kinematic wave method (right).
Computation begins with the overland flow planes. A hydrograph is developed for the first plane. If a second plane is present, a hydrograph is similarly developed for it. Flow from the planes is combined and then uniformly distributed along the main channel as lateral inflow. If collector channel 1 is present, flow from the planes is uniformly distributed along the collector channel as lateral inflow. Outflow from the collector channel is then uniformly distributed along the main channel as lateral inflow. If two collector channels are present, flow is uniformly distributed as lateral inflow from the planes to collector channel 1, from the first collector channel to collector channel 2, then from the second collector to the main channel (Figure 52).

Required parameters for planes include length, slope, roughness, and percentage of subbasin area (Figure 53). The minimum number of distance steps is automatically determined by the program but can optionally be entered. Required parameters for all channels include length, slope, shape, and bottom width or diameter (Figure 53). Collector channels also require the contributing area. Side slope is only required when the shape is set to "trapezoid". The trapezoid shape allows for triangular, rectangular, and trapezoidal cross sections using the side slope and bottom width parameters. The minimum number of distance steps is also automatically determined by the program for channels but can optionally be entered.

Figure 52. Conceptual model of kinematic wave method using two planes and two collector channels.
Figure 53. Inputting overland flow plane data.

Figure 54. Inputting main and collector channel data.

Channel routing can optionally be performed using the Muskingum-Cunge methodology (Figure 55). The main channel can optionally be described with an 8-point cross-section when
Muskingum-Cunge is used. It is also optional to route upstream flow through the main channel of the subbasin. Upstream elements cannot be connected to the subbasin until the “route upstream hydrograph” checkbox is checked.

**ModClark**

The ModClark method is a quasi-distributed linear transform operating on a grid-cell basis. Excess precipitation for each cell is lagged in time and then routed through a linear reservoir. A grid-cell file contains coordinate information, area, and a travel time index for each cell in the subbasin. The lag time for a cell is computed as the ratio of the cell travel time index to the largest travel time index in the subbasin, multiplied by the time of concentration. All cells in the subbasin have the same reservoir storage coefficient. Required parameters are the time of concentration for the entire subbasin, storage coefficient, and grid-cell file (Figure 56).
Figure 56. Subbasin using the ModClark transform method.

**Snyder Unit Hydrograph**

Snyder originally developed a parametric unit hydrograph technique for estimating peak flow and time base of a hydrograph. The Snyder unit hydrograph method implemented in the program uses the Clark unit hydrograph method to compute ordinates. Clark parameters are estimated from Snyder parameters through an iterative process designed to produce a hydrograph with the peak flow and time base given by the original Snyder technique. Required parameters are the standard lag in hours and the peaking coefficient, which ranges from 0.1 to 1.0 (Figure 57).
SCS Unit Hydrograph

The Soil Conservation Service (SCS), now known as the Natural Resources Conservation Service (NRCS), developed a parametric unit hydrograph technique. It is based on empirical data from small agricultural watersheds across the United States. Parametric equations are used to compute the hydrograph peak and time base from the lag. Hydrograph ordinates are subsequently computed from the peak, time base, and a dimensionless unit hydrograph. One parameter is required, the SCS lag in minutes or hours (Figure 58). The lag is stored internally in minutes.
Figure 58. Subbasin using the SCS unit hydrograph transform method.

**User-Specified S-Graph**

The user-specified s-graph allows an exact specification of the empirical relationship between one unit of excess rainfall and the resulting direct runoff. The relationship is defined using a dimensionless s-graph previously defined in the s-graph manager, accessed from the *Project Definition* screen. The only required parameters is the s-graph and the time lag (Figure 59).
User-Specified Unit Hydrograph

The user-specified unit hydrograph allows an exact specification of the empirical relationship between one unit of excess rainfall and the resulting direct runoff. The relationship is defined using a unit hydrograph previously defined in the unit hydrograph manager, accessed from the Project Definition screen. The only required parameter is the unit hydrograph (Figure 60).
Figure 60. Subbasin using the user-specified unit hydrograph transform method.

Subbasin Baseflow Methods

Water that has infiltrated through the soil in a watershed passes through the unsaturated vadose zone and enters the groundwater. Groundwater is rarely static and slowly moves down-gradient through pore spaces, limestone caverns, or hardrock fissures depending on the geologic formations present locally. Groundwater is the principle source of stream flow during rainless periods and droughts. It returns to the stream channel directly from beneath or may return to the land surface near the stream and travel on the surface a short distance before entering the channel. Shallow groundwater may travel fast enough to contribute to channel flow during precipitation events. Groundwater flow that returns to the stream channel or land surface from underground is called return flow or baseflow. A baseflow method is used to model the return of infiltrated precipitation to the channel.

Baseflow for each subbasin can be modeled with one of three different methods: constant monthly, linear reservoir, and recession. Constant monthly or recession methods can be used in any subbasin. Only subbasins also using the soil moisture accounting or gridded soil moisture accounting loss methods can use the linear reservoir method. Baseflow is computed as zero flow when no baseflow method is selected.

Constant Monthly

The constant monthly method uses a constant baseflow at all simulation time steps that fall within a particular month. Surface flow computed by the transform method is added to the baseflow to produce the total flow. A different baseflow can be
specified for each month. Baseflow values are required for all months that fall during a simulation time window (Figure 61).

**Figure 61.** Subbasin using the constant monthly baseflow method.

### Linear Reservoir

The linear reservoir computes baseflow from groundwater storage and can only be used in conjunction with the soil moisture accounting loss method. Available water from each groundwater layer is transformed to baseflow with a series of linear reservoirs. Required parameters are the storage coefficient and number of reservoirs (Figure 62). The outflow from the final reservoir in the series for a groundwater layer is the baseflow contribution for that layer. Total baseflow is the sum of outflows for the two layers.
Figure 62. Subbasin using the linear reservoir baseflow method.

Recession

The recession method uses an exponentially declining baseflow developed from classical baseflow separation techniques. It is suitable for watersheds where the volume and timing of baseflow is strongly influenced by precipitation events. The input screen for the recession baseflow method is shown in Figure 63. Initial flow at the beginning of the simulation must be specified as flow or flow per unit area. A recession constant describing the rate of baseflow decay is required. The constant is the ratio of baseflow now to the flow one day earlier, and consequently ranges from 0 to 1. Threshold flow is the point on the hydrograph where baseflow replaces overland flow as the source of flow from the subbasin. The threshold must be specified as a flow or as a ratio of the peak flow immediately preceding the initiation of baseflow.
Reach

The reach element can be used to represent the flow of water in open channels. Water requires a certain amount of time to travel down the reach. A flood wave is attenuated by friction and channel storage as it passes through the reach. The process of computing the travel time and attenuation of water flowing in the reach is often called routing.

Travel time and attenuation characteristics vary widely between different streams. The travel time is dependent on characteristics such as length, slope, friction, and flow depth. Attenuation is also dependent on friction, in addition to other characteristics such as channel storage. Many models have been developed under different assumptions and for different stream types. Six models have been included in the program as routing methods for reach elements: kinematic wave, lag, modified Puls, Muskingum, Muskingum-Cunge 8-point section, and Muskingum-Cunge standard section.
**Kinematic Wave**

The kinematic wave method uses the continuity equation and the steady, uniform flow approximation of the momentum equation. Theoretically, the method models flow with translation and no attenuation by computing velocity from flow depth and channel parameters specified by the user. However, the equations are solved using a finite difference approximation and some numerical attenuation is inevitable. Cross-section shapes can be trapezoidal, deep, or circular. Trapezoidal cross sections can be rectangular, triangular, or trapezoidal depending on the channel bottom width and side slope. A deep cross-section can be applied when the flow depth is approximately equal to the channel width. Required parameters include length, energy slope, bottom width or diameter, and Manning’s n (Figure 64). Depending on the shape of the channel, a channel side slope may also be required. The number of routing increments is automatically determined by the program but can optionally be entered.

![Figure 64. Reach using the kinematic wave routing method.](image-url)
**Lag**

The lag method routes channel flow with translation and no attenuation. Inflow is translated an amount of time equal to the lag. Lag time is the only required parameter and can be entered as minutes or hours (Figure 65). The time is stored internally in minutes.

*Figure 65. Reach using the lag routing method.*
Modified Puls

The modified Puls method, also known as storage routing or level-pool routing, is based on an approximation of the continuity equation coupled with an empirical representation of the momentum equation. Required parameters are the storage-outflow curve, number of subreaches, and initial condition (Figure 66). The storage-outflow curve is divided by the number of subreaches and used with the initial condition for all subreaches.

![HMS * Basin Model * Routing Reach](image)

Figure 66. Reach using the modified Puls routing method.
Muskingum

The Muskingum method is an approximation of the continuity equation. Storage is modeled as the sum of prism and wedge storage. During rising stages of a flood, wedge storage is positive and added to prism storage. Wedge storage is negative during falling stages and subtracted from prism storage. Consequently, the method can reproduce hydrographs that result from looped rating curves. Required input parameters are the Muskingum K in hours, Muskingum X which ranges from 0 to 0.5, and the number of subreaches (Figure 67).

Figure 67. Reach using the Muskingum routing method.
Muskingum-Cunge 8-Point

The Muskingum-Cunge 8-point section method uses the same equations and solution technique as the Muskingum-Cunge standard section method. However, the channel is described with eight station-elevation coordinates instead of using a standard circular or prismatic cross-section shape. The channel is divided into left overbank, main, and right overbank partitions. Flow is computed separately in each channel partition. Required parameters include length, energy slope, Manning's $n$ roughness coefficients for each channel partition, and station-elevation data describing the channel shape (Figure 68).

![HMS * Basin Model * Routing Reach](image)

**Figure 68.** Reach using the Muskingum-Cunge 8-point routing method.
Muskingum-Cunge Standard

The Muskingum-Cunge standard section method is based on the continuity equation and the diffusion form of the momentum equation. Routing coefficients are automatically computed by the program from specified parameters. Standard cross-sections can be circular or prismatic. Prismatic shapes including triangular, rectangular, and trapezoidal cross-sections are specified with a combination of channel bottom width and side slope. Required input includes channel shape, length, energy slope, bottom width or diameter, and Manning's n roughness coefficient (Figure 69). Depending on the shape of the channel, a channel side slope may also be required.

![Figure 69. Reach using the Muskingum-Cunge standard routing method.](image)

Reservoir

Many watersheds contain natural depressions such as lakes, ponds, and wetlands that impound water. They may also contain constructed facilities such as reservoirs and detention basins. The reservoir element represents uncontrolled water bodies by assuming a level pool and a monotonically increasing storage-outflow function.

The storage-outflow relationship can be specified from three available methods:

- Storage-outflow
- Elevation-storage-outflow
- Elevation-area-outflow
The storage-outflow method computes outflow directly from the input data. The elevation-storage-outflow method first computes outflow from the storage-outflow input data. Elevation is computed second from the elevation-storage data. The elevation-area-outflow method first computes storage from the elevation-area input data using a conic volume formula. Outflow is computed from the outflow input data and derived storage. Elevation is computed third and area fourth from the computed storage.

Required parameters include the storage method, initial condition, and storage-outflow curve (Figure 70). The initial condition, depending on storage method, can be inflow equals outflow or a reservoir storage, outflow, or elevation value. Switch to other reservoir elements using the selection list containing the element name.

Figure 70. Reservoir element editor.

The storage-outflow input data must span the range of possible values. No extrapolation is used beyond the input data. Outflow cannot be computed when storage falls below the first value in the table or exceeds the last value.
Junction

A stream confluence, also called a stream junction, is any location in the watershed where two or more streams meet and continue downstream as a single stream. The junction element can be used to model a confluence in the stream network. Flow from two or more upstream elements is combined by assuming that there is no storage at the junction. Each junction has a name and description but no parameters (Figure 71). Switch to other junction elements using the selection list containing the element name.

Figure 71. Junction element editor.

The use of a junction element is optional and does not affect simulation results (Figure 72). All elements in the network automatically combine all upstream inflows before performing their own computations. Inclusion of a junction does control what results are available. A results graph always shows the inflow and outflow hydrographs for an element. The outflow hydrograph from a junction is the combination of the inflow hydrographs. Combined inflow is not shown for any other element.

Figure 72. Combining flow with and without a junction.

Diversion

Some streams contain bifurcations that split the flow in the channel (Figure 73). A stream may be braided or a large island may separate the flow. Flow diverted into a flume by a weir is also a bifurcation. A diversion represents a bifurcation with an inflow-diversion curve. The diverted flow is based only on inflow to the diversion. Diverted flow can be returned to the stream network at any element that is downstream from the diversion.
The only required parameter is an inflow-diversion curve (Figure 74). Optionally, a total diversion volume for the entire simulation or the maximum diverted flow can be entered. Switch to other diversion elements using the selection list containing the element name.

**Source**

Springs are a common occurrence in some watersheds. From a modeling standpoint, it may be necessary to construct a watershed model below a lake or to import flow from a separate model. A source element can be used to represent a
point discharge into the stream network. Two methods are available for specifying the outflow from the source: constant flow or variable flow. Flow data must be added to a project as a discharge gage before it can be used as variable flow for a source.

The only required parameter is a discharge gage name or discharge value, depending on the selected method (Figure 75). Optionally, a representative area can be entered. Downstream elements will not be able to compute total volume as depth without a specified area. Switch to other source elements using the selection list containing the element name.

![Figure 75. Source element editor.](image)

A flow ratio can be applied to the outflow hydrograph. When a ratio is used, each ordinate in the outflow hydrograph is adjusted by multiplying by the ratio before the results are saved to the project DSS file. The adjusted hydrograph becomes the result for the source and the unadjusted hydrograph is not available for viewing. All downstream computations use the adjusted hydrograph. The flow ratio is unavailable unless it is set on the "Options" tab of the basin model attributes.

**Sink**

Terminal lakes occur in different contexts in many watersheds; water flows in and exits only by infiltration or evaporation. The sink element can be used to model point sinks with no surface outflow. A sink element is also a convenient terminal element in a basin model. Each sink has a name and description but no parameters (Figure 76). Switch to other sink elements using the selection list containing the element name.
Global Editors

Global editors provide an efficient means for entering and viewing data for elements that use the same computation method. For example, the ModClark transform global editor (Figure 77) only shows the parameters associated with the transform method. Loss and baseflow method data do not appear and subbasins set to use a different transform method are not shown.

A total of twenty-six global editors are available from the Parameters menu on the Basin Model screen. The computation method for an element cannot be changed from a global editor; method changes must be made in the element editor.
Observed Hydrograph

An observed hydrograph can be added to any element in a basin model. All results automatically include the observed hydrograph after it is added. Graphs include a trace for the observed hydrograph with traces of the computed results. Peak flow, total volume, and other summary data for the observed hydrograph are included in a separate section of the summary table. Time-series tables include a column for the observed hydrograph and a column for the difference between the observed and computed hydrographs.

Observed flow data must be added to a project as a discharge gage before it can be used as an observed hydrograph. A basin model must be open in the Basin Model screen to add an observed hydrograph to an element. Add an observed hydrograph by placing the arrow pointer over an element. Press the right mouse button and select the Observed Flow menu item (Figure 78). Select a gage from the list and press the OK or Apply button to save the choice.

![Image of Observed Flow menu](image)

Figure 78. Selecting a gage as observed flow for an element.

Delete an observed hydrograph from an element by placing the arrow pointer over an element. Press the right mouse button and select the Observed Flow menu item. Select the blank entry on the gage selection list or press the Delete button.

Stage-Discharge Curve

A stage-discharge curve can be added to any element in a basin model. All results automatically include stage interpolated from the stage-discharge curve. Graphs include a pair of radio buttons in the lower left corner for switching the view between flow and stage (Figure 79). Summary tables include the peak stage. Time-series tables include a column for computed stage.

Add a stage-discharge curve to an element from the Basin Model screen. Place the arrow pointer over an element. Press the right mouse button and select the Stage-Discharge Table menu item (Figure 80). Enter the stage and discharge data and press the OK or Apply button to save the curve.

Delete a stage-discharge curve from an element by placing the arrow pointer over an element. Press the right mouse button and select the Stage-Discharge Table menu item. Press the Delete button near the bottom of the screen.
Figure 79. Results graph showing stage computed from an elevation-outflow curve.

Figure 80. Entering a stage-outflow curve for an element.
Chapter 5  Basin Models

Basin Model Attributes

Basin model attributes can be set to define default methods, required parameter files, unit system, and element options. The attributes are initially set the same as the project attributes when the basin model is created; basin model defaults can be changed at any time. Set basin model attributes by selecting the File ⇒ Basin Model Attributes menu item on the Basin Model screen (Figure 81).

The Basin Model Attributes screen uses four tabs for entering attribute data: "Defaults", "Files", "Units", and "Options". Settings on the "Defaults" tab include loss method, transform, baseflow, and channel routing. Defaults determine which method is pre-selected when a new element is created in the basin model. The method for an individual element can always be changed from the default. Settings on the "Files" tab include background map and grid-cell files. A background map is optional and the grid-cell file is required when the gridded precipitation method is used. The only setting on the "Units" tab is the unit system. Changing the unit system automatically converts all of the parameter data in the basin model to the new unit system. The "Options" tab is used to activate features that are rarely used or require special care to use correctly.

Background Map

An optional background map with watershed boundaries and stream lines can be added to a basin model (Figure 82). It is only used to provide a visual reference on the in the schematics on the Basin Model screen and is not used for any computations. Two layers are used to store the boundary and stream coordinates separately and provide independent control. The format of the background map file is described in Appendix C.

Set a background map by selecting the File ⇒ Basin Model Attributes menu item on the Basin Model screen (Figure 83). The filename is set on the "Files" tab.
Boundary and stream layers of the background map are turned on or off from the Map ⇒ Map Toggle menu on the Basin Model screen. Layers can also be turned on or off using Basin Model screen toolbar buttons.

Figure 82. Background map with boundary and stream lines.
Figure 83. Setting a background map file.
CHAPTER 6

Meteorologic Models

This chapter describes meteorologic models and how they are entered and edited. The meteorologic model is one of the components required for a run, along with a basin model and control specifications. The precipitation and evapotranspiration data necessary to simulate watershed processes are stored in the meteorologic model.

Creating and Managing Meteorologic Models

Create a new meteorologic model by selecting the Edit ⇒ Meteorologic Model ⇒ New menu item on the Project Definition screen. The name (20 character limit) and an optional description (1,024 character limit) are entered on the New Meteorologic Model screen (Figure 84). Press the OK button to create the meteorologic model or the Cancel button to abort the process. When the OK button is pressed, the program creates the meteorologic model and automatically opens the Meteorologic Model screen (Figure 85). The Subbasin List screen automatically opens on top of the Meteorologic Model screen whenever a model is opened that has an empty subbasin list. Add subbasins to the subbasin list and press the OK button to continue to the Meteorologic Model screen. Select a precipitation method and enter data. Press the OK button to continue. A new meteorologic model can also be created by selecting the File ⇒ New menu item on the Meteorologic Model screen.

Figure 84. Creating a new meteorologic model.
Figure 85. The meteorologic model.

Open a meteorologic model by selecting the **Edit ⇒ Meteorologic Model ⇒ Open** menu item on the *Project Definition* screen. The *Meteorologic Model * Open screen (Figure 86) shows a list of all meteorologic models in the current project. Select a meteorologic model by clicking on a row in the table and pressing the **Select** button or by double-clicking a row in the table. A meteorologic model can also be opened by double-clicking in the display portion of the *Project Definition* screen or by selecting the **File ⇒ Open** menu item on the *Meteorologic Model* screen.

Figure 86. Opening a meteorologic model.
Delete a meteorologic model by selecting the Edit ⇒ Meteorologic Model ⇒ Delete menu item on the Project Definition screen. The Meteorologic Model * Delete screen (Figure 87) shows a list of all meteorologic models in the current project. Select a meteorologic model by clicking on a row in the table and pressing the Delete button, or by double-clicking a row in the table. A meteorologic model can also be deleted by selecting the File ⇒ Delete menu item on the Meteorologic Model screen.

![Figure 87. Deleting a meteorologic model.](image)

Save a meteorologic model by selecting the File ⇒ Save menu item on the Meteorologic Model screen. The current meteorologic model is also saved when the project is saved by selecting the File ⇒ Save Project menu item on the Project Definition screen.

Copy a meteorologic model by first opening the original meteorologic model and then selecting the File ⇒ Save As menu item on the Meteorologic Model screen. The Meteorologic Model * Save As screen (Figure 88) will open. Enter the name of the new meteorologic model to be created. Uncheck the "Open new met model" checkbox near the bottom of the screen to continue working with the original meteorologic model instead of automatically opening the copy.
Chapter 6  Meteorologic Models

Figure 88.  Saving a copy of a meteorologic model.

Rename a meteorologic model by first opening the original meteorologic model and then selecting the File ⇒ Rename menu item on the Meteorologic Model screen. The Meteorologic Model * Rename screen (Figure 89) will open. Enter the new name and optional description for the meteorologic model.

Figure 89.  Renaming a meteorologic model.

Meteorologic Model Screen

The Meteorologic Model screen (Figure 90) includes a menu bar and "Precipitation" and "Evapotranspiration" tabs with a data entry area. Only one precipitation and evapotranspiration method can be defined for each model. Set the "Include evapotranspiration method in model" option in the meteorologic model attributes to allow access to the "Evapotranspiration" tab.
Chapter 6  Meteorologic Models

Figure 90. Meteorologic model.

The **File** menu contains items for managing meteorologic models and model attributes. An overview of the functions provided in the menu is shown in Table 14.

**Table 14. File menu functions in the Meteorologic Model screen.**

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>New Met Model</td>
<td>Create a new meteorologic model.</td>
</tr>
<tr>
<td>Open Met Model</td>
<td>Open a meteorologic model.</td>
</tr>
<tr>
<td>Save Met Model</td>
<td>Save the current meteorologic model.</td>
</tr>
<tr>
<td>Save Met Model As</td>
<td>Make a copy of the current meteorologic model.</td>
</tr>
<tr>
<td>Rename Met Model</td>
<td>Rename the current meteorologic model.</td>
</tr>
<tr>
<td>Delete Met Model</td>
<td>Delete a meteorologic model.</td>
</tr>
<tr>
<td>Met Model Attributes</td>
<td>Set the attributes for the current meteorologic model.</td>
</tr>
</tbody>
</table>

The **Edit** menu contains items for managing data for the various precipitation and evapotranspiration methods. An overview of the functions provided in the menu is shown in Table 15.

**Table 15. Edit menu functions in the Meteorologic Model screen.**

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Row</td>
<td>Insert a row into a table.</td>
</tr>
<tr>
<td>Delete Row</td>
<td>Delete a row from a table.</td>
</tr>
<tr>
<td>Sort by ID</td>
<td>Sort rows alphabetically by the identifier name in the first column.</td>
</tr>
</tbody>
</table>
The Help menu contains items for using the online help and displaying information about the program. An overview of the functions provided in the menu is shown in Table 16.

Table 16. Help menu functions on the Project Definition screen.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Open the online help to the table of contents.</td>
</tr>
<tr>
<td>Search For Help On</td>
<td>Open the online help to the index.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Open the online help to the topic on how to use the online help system.</td>
</tr>
<tr>
<td>About HEC-HMS</td>
<td>View the program version number and license agreement.</td>
</tr>
</tbody>
</table>

**Subbasin List**

Meteorologic input can be computed for all subbasins that are contained in the subbasin list (Figure 91). The list automatically opens when a meteorologic model with an empty subbasin list is opened. Edit the list at any time by pressing the Subbasin List button in the upper right corner of the Meteorologic Model screen.

Subbasins can be added and removed from the subbasin list. Add subbasin names by selecting a basin model name in the "Add subbasin from basin model" list and press the Add button. Selecting the Edit ⇒ Add Subbasin menu item is equivalent to pressing the Add button. Remove a subbasin name from the subbasin list by selecting it in the list with the left mouse button and pressing the Delete button. Selecting the Edit ⇒ Delete Subbasin menu item performs the same function as pressing the Delete button.

![Figure 91: Working with the subbasin list.](image)
Evapotranspiration Zones

An evapotranspiration zone represents an area that is homogenous with respect to evapotranspiration processes. The zone is a conceptual area that has no defined boundaries and can represent a discontiguous region.

A list of evapotranspiration zones is maintained separately from defining the method and parameters for each zone. The list is managed from the Meteorologic Model * ET Zone List screen accessed by pressing ET Zone List button on the "Evapotranspiration" tab of the Meteorologic Model screen (Figure 92). Add a zone to the list by entering a name in the "Add ET Zone to Meteorologic Model" field and pressing the Add button. Selecting the Edit ⇒ Add ET Zone menu item is equivalent to pressing the Add button. Remove a zone name from the evapotranspiration zone list by selecting it in the list with the left mouse button and pressing the Delete button. Selecting the Edit ⇒ Delete ET Zone menu item performs the same function as pressing the Delete button.

![Figure 92. Working with the evapotranspiration zone list.](image)

An evapotranspiration zone, including its method and parameters, can be copied by selecting the Edit ⇒ Copy ET Zone menu item on the Meteorologic Model * ET Zone List screen (Figure 93). Select the zone to copy from the list and enter a name for the new zone. Press the OK button to make the copy and automatically return to the ET Zone List screen.
Precipitation Methods

A variety of precipitation methods are available but only one can be used for each meteorologic model. The gridded precipitation method must be selected when the meteorologic model will be used with basin models that contain subbasin elements set to use the ModClark transform method. The "no precipitation" method can only be used when the meteorologic model will never be paired with basin models that contain subbasin elements.

User Hyetograph

The user hyetograph method can be used to import a subbasin hyetograph from outside the program. An arbitrary analysis technique can be used to compute the hyetograph. The hyetograph must be entered as a precipitation gage on the Data menu of the Project Definition screen before it can be referenced in a meteorologic model. Each subbasin can have only one hyetograph.

Select a gage for each subbasin (Figure 94). Click in a cell to display a list of available gages.
Figure 94.  Entering data for the user hyetograph method.

User Gage Weighting

The user gage weighting method provides complete control over the gages and weighting scheme used for each subbasin. Weight values are computed manually and can be the result of Thiessen, inverse distance, or other analysis. A precipitation hyetograph for each subbasin is computed in a two step process where the mean areal precipitation is computed first and temporally distributed second.

Gages are selected in the "Gages" section (Figure 95). Add a recording gage by pressing the **Recording** button and selecting a gage. Precipitation gages must be created on the **Data** menu of the **Project Definition** screen before they can be referenced as recording gages in the meteorologic model. Add a non-recording, also called a total storm gage, by pressing the **Total Storm** button and entering a gage name. The storm depth is required for non-recording gages and optional for recording gages. A storm depth for recording gages is used to proportionally adjust the gage to match the specified value.
Figure 95. Selecting gages for the user gage weighting method.

An optional index precipitation can be entered for each gage to account for regional precipitation variation. An optional index precipitation can be entered for each subbasin in the "Subbasins" section (Figure 96).

Figure 96. Entering index precipitation for a subbasin.
Figure 97. Entering weights for a subbasin.

Gages and gage weights are entered separately for each subbasin in the "Weights" section. Select a gage from those entered previously in the "Gages" section by clicking with the left mouse in a cell in the "Gage ID" column (Figure 97). Enter total storm gage weights for computing the mean areal precipitation for the selected subbasin. Enter temporal gage weights for computing the temporal distribution of the mean areal precipitation.

Inverse-Distance Gage Weights

The inverse-distance gage weights method is useful when precipitation data contains missing values that should not be set to zero. The subbasin hyetograph is computed for node locations that are selected to represent the subbasin. A quadrant system is drawn centered on the node (Figure 98). A weight for the closest gage, that does not have missing data, in each quadrant is computed as the inverse, squared, distance between the gage and node. The closest gage in each quadrant is determined separately for each time step. The next closest gage in a quadrant is automatically used when the closest gage is missing data.
Figure 98. Computing inverse-distance gage weights from the closest gage in each quadrant to the node.

Enter the gages that will be used in the "Gages" section (Figure 99). At least one recording gage is required. Precipitation gages must be created on the Data menu of the Project Definition screen before they can be referenced as recording gages in a meteorologic model. The precipitation gages must also have a latitude and longitude defined. Non-recording gages can optionally be used for including daily total precipitation and must also be created separately like recording gages. Press the Add Gage button in the center of the screen to select gages. Click with the left mouse button on a cell in the "Gage Type" column to switch the gage type between recording and non-recording. An optional index precipitation can be entered for each gage to account for regional precipitation variation.
Nodes represent the locations in each subbasin where the precipitation hyetograph will be computed. They are specified in the "Nodes" section (Figure 100). Enter a name for each node in the "Node" column, followed by the weight, longitude, latitude, and optional index precipitation. Nodes are defined separately for each subbasin in the subbasin list.
Gridded Precipitation

The gridded precipitation method retrieves gridded records from a DSS file. Gridded records are created separately using the gageInterp or gridLoad programs. Enter the filename of the DSS file or use the Browse button to navigate to it (Figure 101). Enter all four pathname parts. Optionally, replace missing data by placing a check in the "Replace missing data with zero?" checkbox. The run will stop with an error if the option is not set and missing data are encountered. Enter a time shift in the "Time shift in hours" field if the data is in UTC time and the control specifications are in local time. Compute the time shift as UTC time minus the local time.

![Figure 101. Entering data for the gridded precipitation method.](image)

---

**Chapter 6  Meteorologic Models**
Frequency Storm

The frequency storm method can be used to create a balanced, synthetic storm with a known exceedance probability. Automatic adjustments for storm area and series type are based on the exceedance probability. Depth-duration data are usually obtained from publications such as TP-40 (National Weather Service, 1961).

Configure the storm by selecting the exceedance probability from the list [Figure 102]. Set the series type for the desired output. Select the duration of the maximum intensity and the total storm duration. Enter partial-duration point precipitation depths, corresponding to the selected exceedance frequency, for the durations between the maximum intensity and storm durations. Select the percentage of the storm duration that occurs before the peak intensity. Enter a storm area equal to the total drainage area at the point where an exceedance probability will be inferred for computed flow.

![Figure 102. Entering data for the frequency storm method.](image)
SCS Hypothetical Storm

The SCS hypothetical storm method implements the four synthetic rainfall distributions developed by the Natural Resources Conservation Service (NRCS) from observed precipitation events. Each distribution contains rainfall intensities arranged to maximize the peak runoff for a given total storm depth. The four distributions correspond to different geographic regions (Soil Conservation Service, 1986).

Select a storm type from the four choices and enter a storm depth. The same precipitation hyetograph is applied to all subbasins without performing any depth-area reductions.

![Figure 103. Entering data for the SCS hypothetical storm method.](image)

Standard Project Storm

The standard project storm method can be used to compute precipitation for estimating the standard project flood (Corps of Engineers, 1952). The method is appropriate for watersheds in the United States east of 105° west longitude with an area less than 1,000 square miles. New methods in risk-based analysis have generally replaced the standard project flood criteria.

Enter an index precipitation obtained from the reference [Figure 105]. Enter a storm area equal to the total drainage area at the point where the standard project flood will be estimated. Select a temporal distribution type. The "SWD" distribution generally applies only in the desert southwest region of the United States. Enter a transposition factor for each subbasin. The transposition factor represents a ratio of the index precipitation for each subbasin as described in the reference.
Evapotranspiration Methods

The monthly average evapotranspiration method must be selected when the meteorologic model will be used with basin models that contain subbasin elements set to use the soil moisture accounting loss method. The "no evapotranspiration" method should be selected when the soil moisture accounting loss method is not in use. Set the "Include evapotranspiration method in model" option in the meteorologic model attributes to allow access to the "Evapotranspiration" tab.

Monthly Average

The monthly average method can be used to compute combined evaporation and transpiration with a separate rate for each month of the year. An evaporation coefficient is included to correct pan evaporation data.

Enter the monthly evapotranspiration parameters for each zone in the "Evapotranspiration" section [Figure 105]. Enter data for one zone at a time by selecting from the list. Enter a total evapotranspiration depth for each month. Enter an evaporation coefficient. The evapotranspiration depth is multiplied by the evaporation coefficient, which is often equal to the pan coefficient.
Figure 105. Entering evapotranspiration data for a zone.

Select the evapotranspiration zone for each subbasin in the "Subbasins" section (Figure 106). The parameters of the selected zone will be used to compute the evapotranspiration for the subbasin. More than one subbasin can use the same zone definition.

Figure 106. Selecting the evapotranspiration zone for a subbasin.
Meteorologic Model Attributes

Meteorologic model attributes can be set to define the units system and select options. The attributes are initially set the same as the project attributes when the meteorologic model is created and can be changed at any time. Set meteorologic model attributes by selecting the File ➞ Met Model Attributes menu item on the Meteorologic Model screen. (Figure 107).

The Meteorologic Model Attributes screen uses two tabs for entering attribute data: "Units" and "Options". Select the units system on the "Units" tab. Changing the unit system automatically converts all of the parameter data in the meteorologic model. The only setting on the "Options" tab is to include an evapotranspiration method in the model. The "Evapotranspiration" tab cannot be activated until the option is set.

![Figure 107. Setting meteorologic model attributes.](image-url)
CHAPTER 7

Control Specifications

This chapter describes control specifications and how they are entered and edited. The control specifications are one of the components required for a run, along with a basin model and meteorologic model. The starting date and time of a run and also the ending date and time are set in the control specifications. The time interval, also called the computation step, is also included.

Creating and Managing Control Specifications

Create new control specifications by selecting the Edit ⇒ Control Specifications ⇒ New menu item on the Project Definition screen. The name (20 character limit) and an optional description (1,024 character limit) are entered on the New Control Specifications screen (Figure 108). Press the OK button to create the control specifications or the Cancel button to abort the process. When the OK button is pressed, the program creates the control specifications and automatically opens the Control Specifications screen (Figure 109). If the Cancel button is pressed after creating a new control specifications while all input fields are blank, the control specifications will be automatically deleted. Enter data on the screen and press the OK button to continue. New control specifications can also be created by selecting the File ⇒ New menu item on the Control Specifications screen.

![Figure 108. Creating a new control specifications.](image-url)
Open existing control specifications by selecting the **Edit ‒ Control Specifications ‒ Open** menu item on the *Project Definition* screen. The *Control Specifications* ‒ *Open* screen (Figure 110) opens with a list of all control specifications in the current project. Select control specifications by clicking on a row in the table and pressing the **Select** button, or by double-clicking a row in the table. Control specifications can also be opened by double-clicking in the display portion of the *Project Definition* screen or by selecting the **File ‒ Open** menu item on the *Control Specifications* screen.

![Figure 110. Opening a control specifications.](image)

Delete control specifications by selecting the **Edit ‒ Control Specifications ‒ Delete** menu item on the *Project Definition* screen. The *Control Specs ‒ Delete* screen (Figure 111) opens with a list of all control specifications in the current project. Select control specifications by clicking on a row in the table and pressing the **Delete** button, or by double-clicking a row in the table. Control specifications can also be
deleted by selecting the **File ⇒ Delete** menu item on the *Control Specifications* screen.

![Image](image_url)

*Figure 111. Deleting a control specifications.*

Save control specifications by selecting the **File ⇒ Save** menu item on the *Control Specifications* screen. The current control specifications is also saved when the project is saved by selecting the **File ⇒ Save Project** menu item on the *Project Definition* screen.

Copy control specifications by first opening the original control specifications and then selecting the **File ⇒ Save As** menu item on the *Control Specifications* screen. The *Control Specs * Save As* screen (Figure 112) will open. Enter the name of the new control specifications to be created. Uncheck the "Open new control spec" checkbox near the bottom of the screen to continue working with the original control specifications instead of automatically opening the copy.

Rename control specifications by first opening the original control specifications and then selecting the **File ⇒ Rename** menu item on the *Control Specifications* screen. The *Control Specifications * Rename* screen (Figure 113) will open. Enter the new name and optional description for the control specifications.
Dates and Times

A variety of styles can be used to enter the starting or ending date. The day can be entered before or after the month but must be an integer number. A leading zero for days less than 10 is optional. Month designations are not case sensitive but must be entered as text. The year should come last and can be entered as two or four digits. When a two digit year is entered, the century is automatically pre-pended by assuming the intended year is between 90 years in the past and 10 years in the future. The program always determines the current date and time from the computer's internal clock. The following are examples of valid entries for dates:

01Mar72
1 March 1972
march 1, 1972

In all three cases the program would store the date as:

01 Mar 1972
Time is specified as a four-digit number representing the 24-hour clock time. A colon separating the hours and minutes is optional. The following are examples of valid entries for times:

0100
01:00

In both cases the program stores the time as:

01:00

**Time Interval**

The time interval determines the resolution of model results computed during a run. Available intervals range from 1 minute to 24 hours. One interval is selected for each control specifications using the selection list.

Gage data is linearly interpolated to the time interval. Although some methods use an internal time interval, most methods compute using the interval specified in the control specifications. If necessary, run results from individual elements are also linearly interpolated to the control specifications time interval for results reporting.

Gridded data is the only data that is not interpolated. Gridded data must be at a 1-hour intervals and the time interval in the control specifications must be set to 1 hour. Future versions will allow use of gridded data at additional intervals.
CHAPTER 8

Performing Simulations and Viewing Results

This chapter describes runs and how they are created and executed to obtain results. Each run combines a basin model, meteorologic model, and control specifications component with run options to obtain results. Runs can be re-executed at any time to update results when data in a component is changed. The Basin Model screen is used to view results of a run.

Creating and Managing Runs

The run manager is used to manage and execute runs. Select the Simulate ⇒ Run Manager menu item on the Basin Model screen to open the run manager (Figure 114). The screen contains a table listing all of the runs currently defined in the project. Three columns display the name, description, and last compute date and time for each run. Select a run by clicking in the table with the left mouse button. The selected run is highlighted and becomes the current run. The current run can be computed by pressing the Compute button near the bottom of the screen. The run manager can also be accessed by selecting the Tools ⇒ Run Manager menu item on the Project Definition screen.

![Figure 114. The run manager.](image)

Create a new run by selecting the File ⇒ New Run menu item on the Run Manager screen. The name (20 character limit) and an optional description (1,024 character limit) are entered on the Run Configuration screen (Figure 115). Select one component of each type and press the OK button to create the run. The Apply button can be used to create a run without closing the Run Configuration screen so that more than one run can be created in series. A new run can also be created by selecting the Simulate ⇒ Run Configuration menu item on the Schematic screen or...
by selecting the **Tools ⇒ Run Configuration** menu item on the *Project Definition* screen.

![HMS * Run Configuration](image)

**Figure 115. Creating a new run.**

Copy a run by selecting the **File ⇒ Copy Run** menu item on the *Run Manager* screen. The *Run * Copy* screen (Figure 116) will open. Enter the name of the run to be copied in the "Run ID" field or click on a row in the table to automatically copy a run name into the field. Enter the name of the new run in the "New Run ID" field and press the **OK** button to copy the run. Uncheck the "Open new run" checkbox near the bottom of the screen to continue working with the original run instead of automatically making the new run the current run.
Figure 116. Copying a run.

Rename a run by selecting it in the run manager and selecting the File ⇒ Rename Run menu item on the Run Manager screen. The Run * Rename screen (Figure 117) will open. Enter the new name and optional description for the run.

Figure 117. Renaming a run.

Delete a run by selecting the File ⇒ Delete Run menu item in the Run Manager screen. The Run * Delete screen (Figure 118) opens with a list of all runs in the current project. The run shown in the "Run ID" field at the top of the screen is deleted when the OK button is pressed. Enter a run name in the field or click on a row in the table to automatically copy a name into the field.

Options for the current, or selected, run can be set by selecting the Edit ⇒ Run Options menu item on the Run Manager screen. The Run Configuration * Run Options screen (Figure 119) opens. The run description can be changed and the three options can be set: ratio, start-states, and save-states.
Run Configuration and Options

A run has required components and options. The required components are one basin model, one meteorologic model, and one control specifications that must all be compatible. Options are used to specify a precipitation or flow ratio. Saving basin states or starting a run from saved states are also options.

Components

Required run components are a compatible basin model, meteorologic model, and control specifications. However, not all basin models are compatible with all
meteorologic models. No compatibility or partial compatibility is available for some combinations of precipitation, loss, transform, and baseflow method. The primary reason for incompatibilities is the differences between lumped and gridded computation methods.

All precipitation methods can be used with all loss and transform methods. The gridded precipitation method is fully compatible with only the ModClark transform. However, the gridded precipitation method automatically computes an area-weighted average precipitation hyetograph for each subbasin when a lumped parameter transform is used. A basin model grid-cell file is required to compute the hyetograph for lumped parameter transforms when the gridded precipitation method is used. When a precipitation method other than the gridded method is used with the ModClark transform, the same precipitation is applied to every grid cell in a subbasin.

Distinct incompatibilities exist between some loss and transform methods (Table 17). Lumped parameter loss methods can be used with lumped parameter transform methods. Lumped parameter loss methods can also be used with the ModClark transform. Each cell in the subbasin uses the same parameters and initial conditions but tracks cumulative precipitation independently when a non-gridded loss method is used with the ModClark transform. Gridded loss methods can only be used with the ModClark transform.

Table 17. Compatible loss and transform methods.

<table>
<thead>
<tr>
<th>Loss Method</th>
<th>Clark UH</th>
<th>Snyder UH</th>
<th>SCS UH</th>
<th>User UH</th>
<th>ModClark</th>
<th>Kinematic Wave</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deficit and Constant</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Green and Ampt</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Gridded SCS Curve No.</td>
<td></td>
<td></td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Gridded SMA</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Initial and Constant</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>SCS Curve No.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
<tr>
<td>Soil Moisture Accounting</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
<td>.</td>
</tr>
</tbody>
</table>

Distinct incompatibilities exist between some loss and baseflow methods (Table 18). The constant monthly and recession baseflow methods can be used with any loss method. Only the soil moisture accounting and gridded soil moisture accounting loss methods can be used with the linear reservoir baseflow method.
## Table 18. Compatible loss and baseflow methods.

<table>
<thead>
<tr>
<th>Method</th>
<th>Constant Monthly</th>
<th>Linear Reservoir</th>
<th>Recession</th>
</tr>
</thead>
<tbody>
<tr>
<td>Deficit and Constant</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Green and Ampt</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Gridded SCS Curve No.</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Gridded SMA</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
<tr>
<td>Initial and Constant</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>SCS Curve No.</td>
<td>•</td>
<td>•</td>
<td></td>
</tr>
<tr>
<td>Soil Moisture Accounting</td>
<td>•</td>
<td>•</td>
<td>•</td>
</tr>
</tbody>
</table>

### Ratio Option

The ratio option can be used to proportionally adjust the precipitation or flow results produced during the execution of a run. Both a precipitation and flow ratio are available. Set the ratio option on the "Ratio" tab of the Run Configuration * Run Options screen (Figure 120). Select the ratio type, element types, and enter the ratio value.

A precipitation ratio can be applied to adjust the computed hyetograph before beginning loss computations. The precipitation hyetograph is computed for each subbasin as specified in the meteorologic model. Each ordinate of every hyetograph is multiplied by the precipitation ratio to compute an adjusted hyetograph. The adjusted hyetograph is saved to permanent storage and used for loss computations.

![Figure 120. Setting a precipitation ratio for subbasins.](image-url)
A flow ratio can be applied to adjust the computed hydrograph from flow-producing elements before routing computations begin. The hydrograph for the subbasin or source element is computed as specified in the basin model. Depending on the setting of the option, each ordinate of the hydrograph is multiplied by the flow ratio to compute an adjusted hydrograph. The adjusted hydrograph is saved to permanent storage and used for further basin model computations. This option can be set to apply the ratio to subbasins, sources, or both elements.

**Start States Option**

Each basin model has initial conditions that describe the state of each element at the beginning of a run. Examples include initial reservoir storage and initial subbasin baseflow. A basin model can be used in different runs but will always have the same initial conditions.

The start-states option uses states to initialize a run instead of the initial conditions in the basin model. States contain basin model state variable values at a particular time during a previous run. They represent a complete ‘snap shot’ of a basin model responding to a particular meteorologic input at a particular moment in time. Examples of state variables include soil moisture and reach outflow. States must be created by the program during a run and cannot be viewed or edited. The save-states option is used to create states that can be used as start-states.

States allow separate simulation runs to produce continuous results (Figure 121). Run ① begins at A and runs to C without stopping and produces a continuous set of results. Run ② begins at A and runs to B, at which time it saves states. Run ③ begins at B using the saved states and runs to C. The results of run ① at C and run ③ at C are identical. Run ④ begins at A and runs to B. Run ⑤

![Figure 121. Continuous results from separate runs using states.](image-url)
begins at B and runs to C. The results from run c do not match the results from runs b and d because it restarted in the middle of the time window with initial conditions from A. States are useful for breaking long simulations into manageable pieces or performing daily forecast simulations based on conditions at the end of the previous day.

Set the start-states option on the "Start States" tab of the Run Options screen. Select the states from the list by clicking with the left mouse button. The list will only show states saved from runs using the basin model and meteorologic model selected as components in the current run.

**Save States Option**

The save-states option saves the value of all state variables in the basin model at a particular time during a run. State variables describe the conditions that change during a simulation, for example, reservoir storage. States created by the program during a simulation run cannot be viewed or edited. The start-states option can be used to initialize a run with states saved with the save-states option.
Figure 123. Saving basin model states at the end of a run.

Set the save-states option on the "Save States" tab of the Run Options screen (Figure 123). Enter a name (20 character limit) and optional description (1,024 character limit) for the states. Enter the date and time to save the basin model states. Use the "Save at end of run" checkbox to automatically set the date and time to the end of the run. An error will occur if the date and time do not fall within the time window in the control specifications component.

Message Log

The message log contains error, warning, and note entries generated during the compute of a run. Errors are the most serious and cause the run to abort. They are usually caused by missing or inappropriate input data. Warnings are significant but less serious and do not cause the run to abort. They are usually the result of numeric stability or convergence problems and often indicate computed results may not be accurate even though a solution was obtained. Notes are the least serious and can often be ignored. They indicate decisions made by the program while the computing the run that are commonly made in hydrologic analysis. For example, several missing precipitation values in an otherwise complete record would be set to zero and a note logged.
Figure 124. Accessing the message log after a completed run.

View the message log from the Simulate screen by pressing the View Log button (Figure 124). The message log for the current run can be viewed by selecting the View ⇒ Message Log menu item on the Basin Model screen. The message log for any run can be viewed by selecting the run name from the View ⇒ Run Log(s) menu on the Project Definition screen.

Viewing Results

A variety of graphical and tabular results are available after a run is computed. Results are accessed using menu items or toolbar buttons on the Basin Model screen. Requested results are displayed for the current run, which is shown in the bottom right-hand corner of the Basin Model screen. The current run can be selected from the last four computed runs using the Simulate menu. Other runs can be selected by computing them in the run manager.

Global Summary Table

The global summary table contains peak flow information for a simulation. Peak discharge flow, time of peak flow, total flow volume, and upstream drainage area are shown for each element in the basin model (Figure 125). Access the table for the current run by selecting the View ⇒ Global Summary Table menu item on the Basin Model screen. The table can also be accessed from the toolbar on the Basin Model screen.
Figure 125. Global summary results table.

Standard Element Results

Each element in the basin model has three standard displays for viewing computation results. Access results by placing the arrow pointer over the element icon and pressing the right mouse button. Select one of the choices from the View Results menu (Figure 126). When specified, observed hydrograph or stage-discharge data is automatically added to the result displays.
Figure 126. Selecting results for an element.

The **Graph** menu item displays time series information appropriate for each element type [Figure 127]. For example, only subbasin graphs include precipitation hyetographs. A complete listing of the time series displayed for each element is shown in [Table 19]. Use the radio buttons in the lower left corner of the graph for switching between the flow hydrograph and elevation hydrograph.
Figure 127. Standard element results graph.

Table 19. Time-series data on a standard element results graph.

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>Reach</th>
<th>Junction</th>
<th>Reservoir</th>
<th>Diversion</th>
<th>Source</th>
<th>Sink</th>
</tr>
</thead>
<tbody>
<tr>
<td>Baseflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Combined Inflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Runoff</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Diverted Flow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Elevation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Precipitation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Loss</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Individual Inflows</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Outflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Stage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Storage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Figure 128. Standard element results summary table.

The Summary Table menu item displays information on peak rates and total volumes as appropriate for each element type (Figure 128). For example, only diversion summary tables include total diverted flow. A complete listing of the information displayed for each element is shown in Table 20. Use the radio buttons above the computed results section of the summary table for switching between volume and depth units. Volume units show total flow information as a volume. Depth units show the volume as a uniform depth over the total upstream contributing area. Use the selection list in the upper right corner to switch to other elements of the same type.

Figure 129. Standard element results time-series table.
Table 20. Information on a standard element summary table.

<table>
<thead>
<tr>
<th></th>
<th>Subbasin</th>
<th>Reach</th>
<th>Junction</th>
<th>Reservoir</th>
<th>Diversion</th>
<th>Source</th>
<th>Sink</th>
</tr>
</thead>
<tbody>
<tr>
<td>Peak Discharge</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Diversion</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Elevation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Inflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Outflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Stage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Peak Storage</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Baseflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Discharge</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Direct Runoff</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Diversion</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Excess Precipitation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Incremental Precipitation</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Inflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Loss</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>Total Outflow</td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

The **Time Series Table** menu item displays time series data in tabular form as appropriate for each element type (Figure 129). For example, only reservoir time series tables include storage. The time-series data displayed for different element types corresponds to the information shown in the summary table. Use the selection list in the upper right corner to switch to other elements of the same type.

**Special Soil Moisture Accounting Results**

Subbasins set to use the soil moisture accounting loss method have special result displays in addition to the standard displays. The displays include a graph (Figure 130), summary table (Figure 131), and time-series table (Figure 133) to show additional data computed by the method. View results for a subbasin by placing the arrow pointer over a subbasin element icon in the schematic of the Basin Model screen and press the right mouse button. Select from the **View SMA Results** menu item on the Basin Model screen to view the special graph, summary table, or time-series table.

The time-series table can be customized using the **SMA Time Series Table Configuration** screen accessed by selecting the **Edit ⇒ Configure Time Series** menu item on the time-series table (Figure 132). The **Edit ⇒ Standard Table** and **Edit ⇒ User-Defined Table** menu items on the time-series table can be used to switch between the default and customized time-series tables.
Figure 130. Soil moisture accounting subbasin results graph.

Figure 131. Soil moisture accounting subbasin results summary table.
Figure 132. Configuring a soil moisture accounting subbasin time-series table.

Figure 133. Soil moisture accounting subbasin time-series table.
Model Calibration

This chapter describes model calibration using observed discharge. The framework for estimating model parameters is described. Information about the objective functions, search methods, and constraints used to estimate optimal parameter values is included. The optimization manager is described, including the results useful for evaluating the success of the calibration.

Framework for Model Calibration

Model calibration is the process of adjusting model parameter values until model results match historical data. The process can be completed manually using engineering judgment by repeatedly adjusting parameters, computing, and inspecting the goodness-of-fit between the computed and observed hydrographs. Significant efficiencies can be realized with an automated procedure.

The quantitative measure of the goodness-of-fit is the objective function. An objective function measures the degree of variation between computed and observed hydrographs. It is equal to zero if the hydrographs are exactly identical. The key to automated model calibration is a search method for adjusting parameters to minimize the objective function value and find optimal parameter values. A minimum objective function is obtained when the parameter values best able to reproduce the observed hydrograph are found. Constraints are set to insure that unreasonable parameter values are not used.

The iterative calibration procedure, also called optimization, used by the program is outlined in Figure 134. Initial values for all parameters are required at the start of the optimization. A hydrograph is computed at a target element by computing all of the upstream elements. The target must have an observed hydrograph for the entire time period over which the objective function will be evaluated. Only parameters for upstream elements can be optimized. The value of the objective function is computed at the target element using the computed and observed hydrographs. Parameter values are adjusted by the search method and the hydrograph and objective function for the target element are recomputed. This process is repeated until the value of the objective function is sufficiently small, or the maximum number of iterations is exceeded. Results can be viewed after the optimization is complete.
**Objective Function**

Four objective functions are available for measuring the goodness-of-fit between computed and observed hydrographs. The value of two different objective functions cannot be compared because each function is defined differently. The default function is the peak-weighted root mean square (RMS) error.

**Peak-Weighted Root Mean Square Error**

The peak-weighted root mean square (RMS) error objective function is a modification of the standard RMS. It gives greater weight to large errors and lesser weight to small errors, in addition to giving greater overall weight to errors near the peak discharge. A weighting factor based on the average flow is computed to modify the RMS. The factor is greater than one when the flow is greater than average, and between 0.5 and 1.0 when the flow is less than average. The function is defined as follows:
Chapter 9  Model Calibration

\[ Z = \sqrt{\frac{\sum_{t=1}^{n} (Q_O(t) - Q_S(t))^2}{n}} \frac{Q_O(t) + Q_A}{2Q_A} \]  

(eq 1)

\[ Q_A = \frac{1}{n} \sum_{t=1}^{n} Q_O \]  

(eq 2)

where \( Z \) is the objective function, \( Q_O(t) \) is the observed flow at time \( t \), \( Q_S(t) \) is the computed flow at time \( t \), and \( Q_A \) is the average observed flow. The objective function is evaluated for all times \( t \) in the objective function time window.

**Sum of Squared Residuals**

The sum of squared residuals objective function gives greater weight to large errors and lesser weight to small errors. It is the sum of the squared differences between observed and computed flow. The function is defined as follows:

\[ Z = \sum_{t=1}^{n} (Q_O(t) - Q_S(t))^2 \]  

(eq 3)

where \( Z \) is the objective function, \( Q_O(t) \) is the observed flow at time \( t \), and \( Q_S(t) \) is the computed flow at time \( t \). The objective function is evaluated for all times \( t \) in the objective function time window.

**Sum of Absolute Residuals**

The sum of absolute residuals objective function gives equal weight to both small and large differences between the observed and computed hydrographs. It is the sum of the absolute differences between the observed and computed flow. The function is defined as follows:

\[ Z = \sum_{t=1}^{n} |Q_O(t) - Q_S(t)| \]  

(eq 4)

where \( Z \) is the objective function, \( Q_O(t) \) is the observed flow at time \( t \), and \( Q_S(t) \) is the computed flow at time \( t \). The objective function is evaluated for all times \( t \) in the objective function time window.

**Percent Error in Peak Flow**

The percent error in peak flow objective function only considers the computed peak flow and does not account for total volume or timing of the peak. It is the percent difference between the observed and computed peak flows. The function is defined as follows:

\[ Z = 100 \left| \frac{Q_O(\text{peak}) - Q_S(\text{peak})}{Q_O(\text{peak})} \right| \]  

(eq 5)

where \( Z \) is the objective function, \( Q_O(\text{peak}) \) is the peak discharge of the observed hydrograph, and \( Q_S(\text{peak}) \) is the peak discharge of the computed hydrograph.
Percent Error in Volume

The percent error in volume objective function only considers the computed volume and does not account for the magnitude or timing of the peak flow. It is the percent difference between the observed and computed flow volumes in the objective function time window. The function is defined as follows:

\[ Z = 100 \left( \frac{V_O - V_S}{V_O} \right) \]  

(eq 6)

Where \( Z \) is the objective function, \( V_O \) is the volume of the observed hydrograph, and \( V_S \) is the volume of the simulated hydrograph.

Search Methods

Two search methods are available for minimizing an objective function and finding optimal parameter values. The univariate gradient method evaluates and adjusts one parameter at a time while holding other parameters constant. The Nelder and Mead method uses a downhill simplex to evaluate all parameters simultaneously and determine which parameter to adjust. The Technical Reference Manual (HEC, 2000) contains complete technical descriptions of the two methods.

The default method is the univariate gradient method. The univariate gradient method is automatically used when only one parameter is estimated.

Initial Values and Constraints

Initial values are required at the start of an optimization process. Parameter values from the basin model are used as default initial values. However, default values can be changed.

Hard constraints limit the range of values that a parameter can take during optimization. The constraints are used to keep parameter values within reasonable limits. They also preclude values that cause numeric instabilities or errors in computations. For example, hydraulic conductivity cannot be negative. When a search method attempts to use a parameter value outside the range of hard constraints, the value is changed to the constraining value. Values for hard constraints are listed in Table 21.

Soft constraints can be used to limit the range of parameter values within the wider range allowed by hard constraints. For example, the constraints for the Clark storage coefficient can be changed from 0 and 150 hours to 20 and 40 hours. A search procedure can use a parameter value outside the range of soft constraints, but the objective function is multiplied by a penalty factor. The penalty factor is defined with the product summation as follows:

\[ P = 2 \prod_{i=1}^{n} \left( |x_i - c_i| + 1 \right) \]  

(eq 7)

where \( P \) is the penalty factor, \( x_i \) is the parameter value for parameter \( i \), \( c_i \) is the constraint value for parameter \( i \). The product summation is evaluated for \( i \) from one to the number of parameters.
Table 21.  **Hard constraint values.**

<table>
<thead>
<tr>
<th>Parameter</th>
<th>Minimum Constraint</th>
<th>Maximum Constraint</th>
</tr>
</thead>
<tbody>
<tr>
<td>Clark Storage Coefficient</td>
<td>0 hr</td>
<td>150 hr</td>
</tr>
<tr>
<td>Constant Loss Rate</td>
<td>0 mm/hr</td>
<td>300 mm/hr</td>
</tr>
<tr>
<td>Deficit Recovery Factor</td>
<td>0.1</td>
<td>5</td>
</tr>
<tr>
<td>Flow to Peak Ratio</td>
<td>0.0</td>
<td>1.0</td>
</tr>
<tr>
<td>Hydraulic Conductivity</td>
<td>0 mm/mm</td>
<td>250 mm/mm</td>
</tr>
<tr>
<td>Initial Baseflow</td>
<td>0 m³/s</td>
<td>100,000 m³/s</td>
</tr>
<tr>
<td>Initial Deficit</td>
<td>0 mm</td>
<td>500 mm</td>
</tr>
<tr>
<td>Initial Loss</td>
<td>0 mm</td>
<td>500 mm</td>
</tr>
<tr>
<td>Lag (Routing)</td>
<td>0 min</td>
<td>30,000 min</td>
</tr>
<tr>
<td>Manning’s n</td>
<td>0.0</td>
<td>1.0</td>
</tr>
<tr>
<td>Maximum Deficit</td>
<td>0 mm</td>
<td>500 mm</td>
</tr>
<tr>
<td>Moisture Deficit</td>
<td>0.0</td>
<td>1.0</td>
</tr>
<tr>
<td>Muskingum K</td>
<td>0.1 hr</td>
<td>150 hr</td>
</tr>
<tr>
<td>Muskingum x</td>
<td>0.0</td>
<td>0.6</td>
</tr>
<tr>
<td>Number of Steps</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>n-value Factor</td>
<td>0.01</td>
<td>10</td>
</tr>
<tr>
<td>Recession Factor</td>
<td>0.00001</td>
<td>1.00000</td>
</tr>
<tr>
<td>SCS Curve Number</td>
<td>1</td>
<td>100</td>
</tr>
<tr>
<td>SCS Initial Abstraction</td>
<td>0 mm</td>
<td>500 mm</td>
</tr>
<tr>
<td>SCS Lag</td>
<td>0.1 min</td>
<td>500 hr</td>
</tr>
<tr>
<td>Snyder C_p</td>
<td>0.1</td>
<td>1.0</td>
</tr>
<tr>
<td>Snyder Lag</td>
<td>0.1 hr</td>
<td>500 hr</td>
</tr>
<tr>
<td>Time of Concentration</td>
<td>0.1 hr</td>
<td>500 hr</td>
</tr>
<tr>
<td>Wetting Front Suction</td>
<td>0 mm</td>
<td>1,000 mm</td>
</tr>
</tbody>
</table>

**Parameter Sensitivity**

Search methods estimate optimal parameter values but do not indicate which parameters have the greatest impact on the solution. At the conclusion of the optimization, the sensitivity of each parameter with respect to the objective function is estimated. Values of the objective function are computed for parameter values of 0.995 and 1.005 times the optimal value using the following equation:

\[
S = \frac{0.995X - 1.005X}{X}
\]  

(eq 8)

where \( S \) is the sensitivity measure and \( X \) is the final parameter value at the end of optimization. The sensitivity measure is the percent change in the value of the objective function resulting from a 1% increase in the value of the parameter. If a parameter value obtained by multiplying by 0.995 or 1.005 exceeds a hard constraint, the constraint value is used to calculate the sensitivity measure. All other parameter values are held at their solution values to compute the sensitivity for an individual parameter.
Using the Optimization Manager

The Optimization Manager screen (Figure 135) includes a menu bar, toolbar, parameter table, and objective function section. Features of the optimization manager are accessed through the menu bar and toolbar. Each parameter to be estimated has one row in the parameter table. The objective function section contains the settings for evaluating the goodness-of-fit between the computed and observed hydrographs.

![Figure 135. The optimization manager.](image)

Optimization results are obtained through a three-step process. The first step is to create an optimization run. A run is configured by selecting a basin model, meteorologic model, and control specifications. Components must be compatible according to the compatibility rules for runs. The second step is to create and configure a trial. An optimization location, objective function, search method, and parameters can be defined for each trial. The optimization location, an element in the basin model, must have an observed hydrograph. Each run can have more than one trial. Trials within a run are independent and can use different objective functions or parameters. The third step is to execute a trial. Results can be viewed after the trial is executed.

**The Menu Bar**

The Edit menu contains items for managing the parameter table, runs, and trials. An overview of the functions provided in the menu is shown in Table 22.
Table 22. Edit menu functions in the optimization manager.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Insert Row</td>
<td>Insert a row in the parameter table for a new parameter.</td>
</tr>
<tr>
<td>Delete Row</td>
<td>Delete a row from the parameter table.</td>
</tr>
<tr>
<td>Delete Run</td>
<td>Delete an optimization run.</td>
</tr>
<tr>
<td>Delete Trial</td>
<td>Delete an optimization trial.</td>
</tr>
</tbody>
</table>

The **Options** menu contains items for performing special functions. Reset the objective function time window to the time window in the control specifications by selecting the **Use Default Times** item.

The **Simulate** menu contains items for managing the execution of trials. Create a new run by selecting the **Optimization Run Configuration** item. Execute the current trial by selecting the **Optimize** item.

Table 23. View menu functions in the optimization manager.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Trial Message Log</td>
<td>View the message log for the current trial.</td>
</tr>
<tr>
<td>Trial Results</td>
<td>View results for the current trial.</td>
</tr>
<tr>
<td>Parameter Summary</td>
<td>View a summary of results for all trials in all runs that contain a specific parameter.</td>
</tr>
<tr>
<td>Hydrograph Plot</td>
<td>View a hydrograph plot at the optimization location for the current trial.</td>
</tr>
<tr>
<td>Scatter Plot</td>
<td>View a scatter plot at the optimization location for the current trial.</td>
</tr>
<tr>
<td>Residual Plot</td>
<td>View a residual plot at the optimization location for the current trial.</td>
</tr>
<tr>
<td>Objective Function Plot</td>
<td>View a objective function value plot for the current trial.</td>
</tr>
<tr>
<td>Optimization Schematic</td>
<td>Open the optimization schematic to view element results for the current trial.</td>
</tr>
</tbody>
</table>

The **View** menu contains items for accessing log files and optimization results. An overview of the functions provided in the menu is shown in **Table 23**.

The **Help** menu contains items for using the online help and displaying information about the program. An overview of the functions provided in the menu is shown in **Table 24**.

Table 24. Help menu functions in the optimization manager.

<table>
<thead>
<tr>
<th>Menu Item</th>
<th>Function</th>
</tr>
</thead>
<tbody>
<tr>
<td>Contents</td>
<td>Open the online help to the table of contents.</td>
</tr>
<tr>
<td>Search For Help On</td>
<td>Open the online help to the index.</td>
</tr>
<tr>
<td>Using Help</td>
<td>Open the online help to the topic on how to use the online help system.</td>
</tr>
<tr>
<td>About HEC-HMS</td>
<td>View the program version number and license agreement.</td>
</tr>
</tbody>
</table>
The Toolbar

The flow comparison tool opens a graph of the computed and observed flow at the optimization location. The same graph can be accessed by selecting the View ⇒ Hydrograph Plot menu item.

The scatter tool opens a graph of the computed versus observed flow at the optimization location. The same graph can be accessed by selecting the View ⇒ Scatter Plot menu item.

The residual tool opens a graph of the computed flow minus the observed flow at the optimization location. The same graph can be accessed by selecting the View ⇒ Residual Plot menu item.

The objective function tool opens a graph of the value of the objective function at each iteration. The same graph can be accessed by selecting the View ⇒ Objective Function Plot menu item.

The schematic tool opens a schematic view of the basin model above the optimization location for viewing results at locations besides the optimization location. The same view can be accessed by selecting the View ⇒ Schematic menu item.

The optimize button executes the current trial. The trial can also be executed by selecting the Simulate ⇒ Optimize menu item.

The current optimization run is shown on the left side of the screen below the toolbar. Switch to a different run by selecting from the list. The optimization location for the current trial is shown on the right side of the screen below the toolbar. Change the location by selecting an element from the list. The list contains hydrologic elements with observed flow from the basin model in the current optimization run.

Objective Function

The time window over which the objective function will be evaluated is specified in the lower left region of the screen. Default values are taken from the control specifications but can be changed. Reset the default values on the Options menu. The function type is selected from the list of four choices. The value of the objective function for the current trial is also shown. The search method is specified immediately above the objective function section.
Creating Optimization Runs

Create an optimization run with the *Optimization Run Configuration* screen (Figure 136). Select the *Simulate ⇒ Optimization Run Configuration* menu item on the *Optimization Manager* screen. Optionally, change the default optimization run name and enter a description. Select one component of each type and press the *OK* or *Apply* button to create the new optimization run. A new optimization run can also be created by selecting the *Tools ⇒ Optimization Run Configuration* menu item on the *Project Definition* screen.

Creating and Computing Trials

Create a new trial by pressing the *New Trial* button on the *Optimization Manager* screen. Trials are automatically numbered, beginning with 1, for each run. The first trial is automatically created when a new optimization run is created. An optional description for the trial can also be entered.
Chapter 9  Model Calibration

Figure 137. Selecting the hydrologic element parameter.

Add a parameter to the trial by first clicking in the "Hydrologic Element" column with the left mouse button (Figure 137). Select an element from the list of elements upstream from the optimization location. Next select a parameter for the element by clicking in the "Parameter" column. The parameter selection list shows the available parameters for the selected element. The initial value from the basin model is used but can be changed. Click the left mouse button in the "Lock" column to use the initial value instead of estimating the parameter during optimization. Minimum and maximum constraints are initially set to the hard constraints but can be changed to soft constraints by replacing the values. The parameter value and objective function sensitivity are shown after the trial is executed.

The search method and objective function are automatically set to default values when the trial is created. The default search method is the univariate gradient method. The control specifications time window is initially set as the objective function time window. The default objective function is the peak-weighted root mean (RMS) square error. Default values can be changed at any time.

After the trial is configured, press the Optimize button on the toolbar or select the Simulate ⇒ Optimize menu item to execute the current trial.

Trial Results

A variety of results are available for viewing optimization results and evaluating the success of the current trial. The optimization run name and trial number for the current trial are both shown in the Optimization Manager screen at all times.
Trial Message Log

The trial message log contains error, warning, and note entries generated during the optimization. View the trial message log from the Optimization Compute screen by pressing the View Log button [Figure 138]. Entries written to the trial message log are very similar to entries in the run message log. The message log for the current trial can also be viewed by selecting the View ⇒ Trial Message Log menu item on the Optimization Manager screen.

![Figure 138. Viewing the trial message log after an optimization.](image)

Trial Results Summary

View summary information for the current trial by selecting the View ⇒ Trial Results menu item on the Optimization Manager screen [Figure 139]. The objective function type, value, start time, and end time are shown. Differences between the computed and observed results in volume, peak flow, time of peak flow, and time to the center of mass are tabulated.
Figure 139. Summary of trial results.

Flow Comparison Graph

The flow comparison graph shows the computed and observed hydrographs at the optimization location (Figure 140). Vertical lines indicate the start and end times of the objective function. View the graph for the current trial by selecting the View ⇒ Flow Comparison Graph menu item on the Optimization Manager screen or by pressing the toolbar button.
Figure 140. Graph of simulated and observed hydrographs.

Scatter Graph

The scatter graph shows the computed hydrograph ordinates versus observed hydrograph ordinates at the optimization location (Figure 141). A 45 degree line is shown for reference. Points occurring before the peak are included with a different symbol than points after the peak. View the graph for the current trial by selecting the View ⇒ Scatter Plot menu item on the Optimization Manager screen or by pressing the toolbar button.
Figure 141. Scatter graph of simulated and observed hydrographs.

Figure 142. Residual graph of simulated and observed hydrographs.

**Residual Graph**

The residual graph shows the residual flow at the optimization location for each time step (Figure 142). Residual flow is computed as the computed minus observed flow.
Vertical lines are included to show the time of peak and start and end times of the objective function. View the graph for the current trial by selecting the View ⇒ Difference Plot menu item on the Optimization Manager screen or by pressing the toolbar button.

**Objective Function Graph**

The objective function graph shows the value of the objective function at the end of each iteration (Figure 143). The graph can be used to evaluate the convergence of the solution. View the graph for the current trial by selecting the View ⇒ Objective Function Plot menu item on the Optimization Manager screen or by pressing the toolbar button.

![Objective Function Graph](image)

**Figure 143.** Graph of objective function value.

**Optimization Schematic**

The optimization schematic can be used to view results for any element upstream of the optimization location (Figure 144). Place the arrow pointer over an element and press the right mouse button to access a results menu. A graph, summary table, and time-series table are available similar to the run results viewed from the Basin Model screen. View the schematic for the current trial by selecting the View ⇒ Optimizer Schematic menu item on the Optimization Manager screen or by pressing the toolbar button.
Run Results

Results can be viewed for each parameter that has been included in a trial (Figure 145). Results are shown for all trials in all optimization runs that include the parameter. View the run results for a parameter by selecting the View ⇒ Parameter Summary menu item on the Optimization Manager screen.
Determine the results for viewing by first selecting a location from the list of all optimization locations in the project. Next select a hydrologic element from the list of all elements that have been evaluated at the selected location. Finally, select a parameter from the list of all parameters that have been estimated for the selected element. The results for each trial are shown in the table including the trial identifier, start and end date, estimated value, objective function value, volume difference between computed and observed hydrographs, and difference between computed and observed peak flow. Select the "Expanded Table" option to add the initial value, start time, and end time to the table.

The "Parameter optimized value statistics" section in the lower left corner of the screen shows the minimum and maximum optimized parameter values. The computed average value is also shown.

A new parameter value can be automatically transferred to a basin model using the "Set parameter value" section in the lower right corner of the screen. Select a basin model from the list of basin models containing the selected hydrologic element and parameter. Enter a value and press the Apply button to transfer the value to the selected basin model.

**Deleting Runs and Trials**

Delete an optimization trial by selecting the Edit ⇒ Delete Trial menu item on the Optimization Manager screen (Figure 146). Each trial is identified by an optimization location, run identifier, and trial number. Select a trial by clicking on a row in the table with the left mouse button and pressing the Delete button.
Delete an optimization run by selecting the **Edit ⇒ Delete Run** menu item on the **Optimization Manager** screen (Figure 147). Select a run by clicking on a row in the table with the left mouse button and pressing the **Delete** button.
CHAPTER 10

Example Application

The steps necessary to obtain results have previously been described in Chapter 3. This chapter illustrates those steps with an application example.

Problem Statement

This example application uses data from the 5.51 square mile Castro Valley watershed located in northern California. The watershed contains four major catchments (Figure 148). Precipitation data for a storm that occurred on January 16, 1973 is available for three gages in the watershed: Proctor School, Sidney School, and Fire Department. The goal of the example is to estimate the affect of proposed future urbanization on the hydrologic response to the indicated storm.

Application of the program will require creating a new project and entering gage data. A basin model using the initial constant loss, Snyder unit hydrograph transform, and recession baseflow methods will have to be created from the parameter data shown in Table 25, Table 26, Table 27, and Table 28.
Table 25. Subbasin initial and constant loss method and Snyder transform method data.

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>Loss Rates</th>
<th>Transform</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td>Initial ( \text{in} )</td>
<td>Constant ( \text{in/hr} )</td>
</tr>
<tr>
<td>1</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>2</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>3</td>
<td>0.02</td>
<td>0.14</td>
</tr>
<tr>
<td>4</td>
<td>0.02</td>
<td>0.14</td>
</tr>
</tbody>
</table>

Table 26. Subbasin area and baseflow data.

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>Area ( \text{sq.mi} )</th>
<th>Initial Flow ( \text{cfs/sq.mi} )</th>
<th>Threshold ratio-to-peak</th>
<th>Recession constant</th>
</tr>
</thead>
<tbody>
<tr>
<td>ID</td>
<td></td>
<td></td>
<td></td>
<td></td>
</tr>
<tr>
<td>1</td>
<td>0.86</td>
<td>0.54</td>
<td>0.1</td>
<td>0.79</td>
</tr>
<tr>
<td>2</td>
<td>1.52</td>
<td>0.54</td>
<td>0.1</td>
<td>0.79</td>
</tr>
<tr>
<td>3</td>
<td>2.17</td>
<td>0.54</td>
<td>0.1</td>
<td>0.79</td>
</tr>
<tr>
<td>4</td>
<td>0.96</td>
<td>0.54</td>
<td>0.1</td>
<td>0.79</td>
</tr>
</tbody>
</table>

Table 27. Routing criteria for reaches.

<table>
<thead>
<tr>
<th>ID</th>
<th>From</th>
<th>To</th>
<th>Method</th>
<th>Subreaches</th>
<th>Parameters</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>Sub 1</td>
<td>East Brnch</td>
<td>Muskingum</td>
<td>7</td>
<td>( K = 0.6 \ \text{hr} \ \ x = 0.2 )</td>
</tr>
<tr>
<td>2</td>
<td>Sub 3</td>
<td>West Brnch</td>
<td>Modified Puls</td>
<td>4</td>
<td>in = out Table 28</td>
</tr>
</tbody>
</table>

Table 28. Storage-outflow curve for Reach 2.

<table>
<thead>
<tr>
<th>Storage ( \text{ac.ft} )</th>
<th>Outflow ( \text{cfs} )</th>
</tr>
</thead>
<tbody>
<tr>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>0.2</td>
<td>2</td>
</tr>
<tr>
<td>0.5</td>
<td>10</td>
</tr>
<tr>
<td>0.8</td>
<td>20</td>
</tr>
<tr>
<td>1.0</td>
<td>30</td>
</tr>
<tr>
<td>1.5</td>
<td>50</td>
</tr>
<tr>
<td>2.7</td>
<td>80</td>
</tr>
<tr>
<td>4.5</td>
<td>120</td>
</tr>
<tr>
<td>750</td>
<td>1,500</td>
</tr>
<tr>
<td>5,000</td>
<td>3,000</td>
</tr>
</tbody>
</table>

A meteorologic model will have to be created for the precipitation gage data. Thiessen polygon weights (Table 29) will be used for a user gage weighting precipitation method. Total rainfall measured by the Proctor School and Sidney School gages was 1.92 and 1.37 inches, respectively. Storm rainfall is to be distributed in time using the temporal pattern of incremental precipitation from the
Fire Department gage. Fire Department data has been stored in the DSS file
_castro.dss with the following pathname:

/CASTRO VALLEY/FIRE DEPT./PRECIP-INC/16JAN1973/10MIN/OBS/

<table>
<thead>
<tr>
<th>Subbasin</th>
<th>Proctor School</th>
<th>Fire Dept.</th>
<th>Sidney School</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>1.00</td>
<td></td>
<td></td>
</tr>
<tr>
<td>2</td>
<td>0.20 0.80</td>
<td></td>
<td></td>
</tr>
<tr>
<td>3</td>
<td>0.33 0.33 0.33</td>
<td></td>
<td></td>
</tr>
<tr>
<td>4</td>
<td></td>
<td>0.80 0.20</td>
<td></td>
</tr>
</tbody>
</table>

A run for pre-development conditions will be created and executed to determine the
existing condition. Finally, future urbanization will be modeled and results compared
to the existing condition.

Create the Project

Begin by starting the program and creating a new project. Select the File ⇒ New
Project menu item on the Project Definition screen. Enter Castro for the project
name and Castro Valley Urban Study for the description (Figure 149). Project
files will be stored in a directory called Castro, a subdirectory to the HMSPROJ
directory created during installation. Press the OK button to create the project. The
new project name will be added to the project list.

Figure 149. Entering the name and description of the new project.
Set the project attributes before creating gages or components (Figure 150). Select the File ⇒ Project Attributes menu item on the Project Definition screen. On the "Basin Defaults" tab, set the "Loss Method" to initial constant, "Transform" to Snyder UH, "Baseflow" to recession, and "Channel Routing" to Muskingum. On the "Met Defaults" tab, set "Precipitation" to user gage weighting and "Evapotranspiration" to no evapotranspiration. On the "Units" tab, set the units to US Customary for both the basin and meteorologic models. Press the OK button to save and close the attributes.

Create a precipitation gage for the Fire Department data. Select the Data ⇒ Precipitation Gages menu item on the Project Definition screen. The New Gage Record screen opens automatically when no precipitation gages exist. Enter Fire Dept for the gage name and Castro Valley Fire Department for the description (Figure 151). Click the "External DSS Record" radio button and press the OK button to continue to the next screen.
Figure 151. Creating the Fire Department precipitation gage.

Use the file browser to locate the castro.dss file that contains the incremental precipitation data from the Fire Department gage. The file is part of the Castro example project automatically installed with the program. Press the Generate Catalog button to view a list of record pathnames in the DSS file. Select the /CASTRO VALLEY/FIRE DEPT./PRECIP-INC/16JAN1973/10MIN/OBS/ pathname by clicking with the left mouse button. Press the OK button to create the gage and return to the Gage Manager screen. Press the Close button on the Gage Manager screen to complete the creation of the gage.

Create a discharge gage for the observed hydrograph at the watershed outlet using the same procedure as for the precipitation gage. Select the Data ⇒ Discharge Gages menu item on the Project Definition screen. Enter the gage name Outlet and the description Castro Valley Outlet Gage. Click the "External DSS record" radiobutton and press the OK button to continue. Select the castro.dss file and locate the record with the /CASTRO VALLEY/OUTLET/FLOW/16JAN1973/10MIN/OBS/ pathname. Press the OK button to close the DSS Pathname Select screen and the Close button to close the Gage Manager screen.

Create the Basin Model

Begin creating the basin by selecting the Component ⇒ Basin Model ⇒ New menu item on the Project Definition screen. Enter Castro 1 for the name and Existing Conditions for the description [Figure 152]. Press the OK button to create the basin model.
Figure 152. Creating a basin model for existing conditions.

Create the Element Network

The Castro Valley watershed will be represented with four subbasins, two routing reaches, and three junctions. Open the new basin model by double-clicking on it in the Project Definition screen. An optional background map can be added to the basin model by selecting the File ⇒ Basin Model Attributes menu item in the Basin Model screen. The file, called castro.map, is part of the Castro example project automatically installed with the program. Use the following steps to create the element network:

1. Add four subbasin icons. Place the arrow pointer over the subbasin icon on the element palette on the left side of the Basin Model screen. Hold the left mouse button and move the mouse to drag a subbasin icon onto the canvas. Place the icon by releasing the mouse button (Figure 153). Repeat this procedure for the other three subbasins.
2. Add two reach icons using the same procedure used for adding subbasin icons (Figure 154).

3. Add three junction icons using the same procedure used for adding reach icons (Figure 154).

4. Connect Subbasin-2 downstream to Junction-1. Place the arrow pointer over the subbasin icon and press the right mouse button. Select the Connect Downstream menu item. Place the cross hair pointer over the junction icon and click the left mouse button. A connection link shows the elements are connected.
5. Connect the other element icons using the same procedure used to connect Subbasin-2 downstream to Junction-1. Move the element icons as necessary to complete the network (Figure 155). Move an element by placing the arrow pointer over the icon. Hold the left mouse button and move the mouse the drag the icon. Release the mouse button to place the icon. The upper and lower ends of a reach element icon can be moved independently.

Enter Element Data

Enter data for the subbasin elements. The global editors are the most efficient way to enter data for several subbasins that all use the same methods. However, all name changes must be made in the individual element editors. Select the Parameters ⇒ Subbasin menu item on the Basin Model screen. Enter the subbasin areas from Table 26 (Figure 156) then press the OK button to close the screen. Select the Parameters ⇒ Loss Rate ⇒ Initial Constant menu item and enter the loss data from Table 25 (Figure 157). Select the Parameters ⇒ Transform ⇒ Snyder menu item and enter the transform data from Table 25 (Figure 158). Select the Parameters ⇒ Baseflow ⇒ Recession menu item and enter baseflow data from Table 26 (Figure 159).
Figure 155. Subbasin, reach, and junction element icons connected to create the element network.

Figure 156. Entering the subbasin area data.
Change the name of the three junction elements. Open the element editor by placing the arrow pointer over the Junction-1 icon and double-clicking the left mouse button. Change the name to East Branch and press the OK button. Change the name of the Junction-2 and Junction-3 elements to Outlet and West Branch, respectively.
Figure 159. Entering subbasin recession baseflow method data.

Enter data for the reach elements. Open the element editor for Reach-1 and enter the data from Table 27 (Figure 160). Open the element editor for Reach-2. Change the method from Muskingum to modified Puls. A warning screen appears with the message that data for the old method will be lost. This warning makes it more difficult to accidentally change the method and lose data. Enter the number of subreaches from Table 27 and the storage-outflow curve from Table 28 (Figure 161).

Figure 160. Entering Muskingum data for Reach-1.
Add an observed hydrograph to the Outlet element. Place the arrow pointer over the element icon and press the right mouse button. Select the Observed Hydrograph menu item. Select the Outlet gage from the list and press the OK button (Figure 162).

The basin model is complete. Select the File ⇒ Save Basin Model menu item on the Basin Model screen. Close the Basin Model screen by closing the basin model or optionally leave it open. The Basin Model screen automatically opens whenever a basin model is opened from the Project Definition screen.
Create the Meteorologic Model

Begin creating the meteorologic model by selecting the Component ⇒ Meteorologic Model ⇒ New menu item on the Project Definition screen. Enter Gage Weights for the name and Thiessen Gage Weights, 10 Minute Data for the description. Press the OK button to create the meteorologic model; the Meteorologic Model screen automatically opens. The Subbasin List screen opens automatically whenever a meteorologic model is opened and the subbasin list is empty. Add subbasin names to the subbasin list by selecting the Castro 1 basin model and pressing the Add button. Press the OK button to close the Subbasin List screen and continue.

Only precipitation data must be entered since evapotranspiration data is not necessary for this application example. Use the following steps to enter the precipitation data:

1. Add the Fire Department gage to the "Gages" section (Figure 163). Press the Recording button. Select Fire Dept in the Gage Selection List screen by clicking with the left mouse button and pressing the Add button. Press the Close button to close the screen and return to the Meteorologic Model screen.

2. Add the Proctor School and Sidney School non-recording gages to the "Gages" section. Press the Total Storm button and enter Proctor. Press the OK button to create the gage and automatically return to the Meteorologic Model screen. Press the Total Storm button again and enter Sidney. Press the OK button to create the second gage.

3. Enter the total storm depths for the Proctor and Sidney gages of 1.92 and 1.37 inches, respectively.

4. Set the gage weights for each subbasin in the "Weights" section. Select Subbasin 1 from the list and enter the "Total Storm Gage Weight" for each gage listed in Table 29 (Figure 164). Enter a "Temporal Gage Weight" of 1 for the Fire Dept gage.
5. Enter the "Total Storm Gage Weight" data for each of the other three subbasins using the data in Table 29. All subbasins should have a "Temporal Gage Weight" of 1 for the Fire Dept gage.
The meteorologic model is now complete. Press the OK button to close the screen and return to the Project Definition screen.

Create Control Specifications

Begin creating the control specifications by selecting the Component ⇒ Control Specifications ⇒ New menu item on the Project Definition screen. Enter Jan73 for the name and Storm of 16 January 1973 for the description. Press the OK button to create the control specifications; the Control Specifications screen automatically opens.

Enter 16Jan1973 for both the "Starting Date" and "Ending Date" (Figure 165). Enter 0300 for the "Starting Time" and 1255 for the "Ending Time." Select a time interval of 5 minutes from the list. Press the OK button to close the screen and return to the Project Definition screen.

Create and Compute a Run

Begin creating a run by opening the basin model in the Basin Model screen, if it is not already open. Select the Simulate ⇒ Run Configuration menu item to open the Run Configuration screen. Select the Castro 1 basin model, Gage Weights meteorologic model, and Jan73 control specifications by clicking with the left mouse button. Keep the default name Run 1 and enter the description Existing conditions, 16 January 1973 storm (Figure 166). Press the OK button to create the run and return to the Basin Model screen. Back in the Basin Model screen, select the Simulate ⇒ Compute <Run 1> menu item to compute the run. The Compute screen monitors progress and shows the number of errors, warnings, and notes. Close the Compute screen and return to the Basin Model screen.
Viewing Results

Begin viewing results by opening the basin model in the Basin Model screen, if it is not already open. Select the View ⇒ Global Summary Table menu item to view summary results of peak flow for all elements (Figure 167). Print the table or make a note of the computed peak discharge for Subbasin-2.

View complete graphical and tabular results for the Subbasin-2 element. Place the arrow pointer over the Subbasin-2 icon and press the right mouse button. Select the View Results ⇒ Graph menu item (Figure 168). Select the View Results ⇒ Summary Table menu item to view the subbasin element summary table (Figure 169). Select the View Results ⇒ Time Series Table menu item to view the subbasin time-series table (Figure 170).
Chapter 10  Example Application

Figure 167. Viewing the global summary table of run results for existing conditions.

<table>
<thead>
<tr>
<th>Hydrologic Element</th>
<th>Discharge Peak [cfs]</th>
<th>Time of Peak</th>
<th>Total Volume [ac-ft]</th>
<th>Drainage Area [sq mi]</th>
</tr>
</thead>
<tbody>
<tr>
<td>Subbasin-3</td>
<td>300.93</td>
<td>16 Jan 73 0655</td>
<td>59,123</td>
<td>2.170</td>
</tr>
<tr>
<td>Reach-2</td>
<td>161.37</td>
<td>16 Jan 73 1120</td>
<td>36,053</td>
<td>2.170</td>
</tr>
<tr>
<td>Subbasin-4</td>
<td>121.78</td>
<td>16 Jan 73 0650</td>
<td>36,579</td>
<td>0.960</td>
</tr>
<tr>
<td>West Branch</td>
<td>242.89</td>
<td>16 Jan 73 0650</td>
<td>132.73</td>
<td>3.133</td>
</tr>
<tr>
<td>Subbasin-1</td>
<td>182.20</td>
<td>16 Jan 73 0655</td>
<td>51,375</td>
<td>0.860</td>
</tr>
<tr>
<td>Reach-1</td>
<td>153.51</td>
<td>16 Jan 73 0730</td>
<td>51,203</td>
<td>0.860</td>
</tr>
<tr>
<td>Subbasin-2</td>
<td>171.96</td>
<td>16 Jan 73 0655</td>
<td>58,745</td>
<td>1.520</td>
</tr>
<tr>
<td>East Branch</td>
<td>304.52</td>
<td>16 Jan 73 0720</td>
<td>108.95</td>
<td>2.980</td>
</tr>
<tr>
<td>Outlet</td>
<td>546.72</td>
<td>16 Jan 73 0655</td>
<td>242.63</td>
<td>5.510</td>
</tr>
</tbody>
</table>

Figure 168. Viewing a graph of Subbasin-2 run results for existing conditions.
Simulate Future Urbanization

Consider how the Castro Valley Watershed response would change given the effects of future urbanization in Subbasin-2. The meteorologic model and control specifications remain the same, but a modified basin model must be created to reflect anticipated changes to the watershed.
Create the Modified Basin Model

The urbanized basin model can be created by modifying a copy of the existing conditions model. Open the Castro 1 basin model in the Basin Model screen. Select the File ➔ Save Basin Model As menu item. Enter Castro 2 for the basin model name and press the OK button to create the copy. The new basin model will automatically be opened in the Basin Model screen. Change the description to Future Urbanized Conditions in the basin model attributes.

Modify the new basin model to reflect future urbanization. Open the element editor for Subbasin-2 by double-clicking on the icon with the left mouse button. Change the percent imperviousness from 8 to 17 percent, and the Snyder t_p from 0.28 to 0.19. Save the modified basin model.

Urbanized Simulation Run

Open the run manager by selecting the Simulate ➔ Run Manager menu item on the Basin Model screen. Select the File ➔ New Run menu item to open the Run Configuration screen and create the urbanized run. Select the Castro 2 basin model, Gage Weights meteorologic model, and Jan73 control specifications by clicking with the left mouse button. Keep the default name Run 2 and enter the description Urbanized conditions, 16 Jan 1973 storm. Press the OK button to create the run and return to the Run Manager screen. Select Run 2 by clicking with the left mouse button and press the Compute button to execute. Close the Compute and Run Manager screens and return to the Basin Model screen. Compare the peak discharges for the urbanized conditions to the existing conditions at Subbasin 2, East Branch, and Outlet (Table 30).

<table>
<thead>
<tr>
<th>Subbasin 2</th>
<th>East Branch</th>
<th>Outlet</th>
</tr>
</thead>
<tbody>
<tr>
<td>Existing cfs</td>
<td>172</td>
<td>305</td>
</tr>
<tr>
<td>Urbanization cfs</td>
<td>211</td>
<td>337</td>
</tr>
<tr>
<td>Increase %</td>
<td>23</td>
<td>10</td>
</tr>
</tbody>
</table>

Save the project by selecting the File ➔ Save Project menu item on the Project Definition screen. The example application is now complete. Create a new project, open an existing project, or exit the program.
APPENDIX A

References


Appendix B  Project DSS File Pathname Descriptors

APPENDIX B

Project DSS File Pathname Descriptors

The project DSS file stores time-series and paired data generated in the project. Data is stored in blocks called records that are identified with a unique pathname. Predefined descriptors are used in the C-part of the pathname. The appendix describes the C-part descriptors for each data type.

Descriptors

AREA  Computed area for a reservoir element.

ELEVATION  Computed elevation for a reservoir element.

ELEVATION-AREA  An elevation-area curve for a reservoir element.

ELEVATION-FLOW  An elevation-flow curve for a reservoir element.

ET-CANOPY  Computed actual evapotranspiration from the canopy layer in the soil moisture accounting loss method.

ET-POTENTIAL  Potential evapotranspiration for a subbasin element as computed by the meteorologic model.

ET-SOIL  Computed actual evapotranspiration from the soil layer in the soil moisture accounting loss method.

ET-SURFACE  Computed actual evapotranspiration from the surface depression layer in the soil moisture accounting loss method.

EXCESS-CANOPY  Computed incremental precipitation minus canopy interception in the soil moisture accounting loss method.

FLOW  Final computed flow for an element.

FLOW-BASE  Computed baseflow for a subbasin element.

FLOW-COMBINE  Computed total inflow to an element.

FLOW-DIRECT  Surface flow computed by transforming excess precipitation for a subbasin element.

FLOW-DIVERSION  Computed diverted outflow for a diversion element.

FLOW-LOCAL  Local flow at a junction when the basin model is set to compute local flow at junctions.

FLOW-LOCAL-SIM  Computed local flow without blending for a junction when observed flow is present, blending is used, and the basin model is set to compute local flow at junctions.

FLOW-SIM  Computed flow without blending at an element when observed flow is present and blending is used.
INfiltration   Computed infiltration from the surface layer to the soil in the soil moisture accounting loss method. Also, the amount of loss attributed to infiltration in the deficit constant loss method.

Outflow-GW   Computed outflow from a groundwater layer to channel baseflow in the soil moisture accounting loss method.

Perc-soil   Computed percolation from the soil layer to the upper groundwater layer in the soil moisture accounting loss method.

Perc-gw   Computed percolation from the upper groundwater layer to the lower groundwater layer or from the lower groundwater layer out of the system in the soil moisture accounting loss method.

Precip-excess   Incremental precipitation minus losses for a subbasin element.

Precip-cum   Cumulative precipitation for a gage.

Precip-inc   Incremental precipitation for a gage or subbasin element.

Stage   Computed stage for an element when an elevation-outflow curve is used.

Stage-flow   An elevation-outflow curve for an element.

Storage   Computed storage for a reservoir element.

Storage-canopy   Computed storage depth of the canopy layer in the soil moisture accounting loss method.

Storage-elevation   Storage-elevation curve for a reservoir element.

Storage-flow   Storage-flow curve for a reservoir or reach element.

Storage-gw   Computed storage depth of a groundwater layer in the soil moisture accounting loss method.

Storage-soil   Computed storage depth of the soil layer in the soil moisture accounting loss method.

Storage-surface   Computed storage depth of the surface layer in the soil moisture accounting loss method.
Appendix C

Background Map File Format

Watershed boundaries and stream lines can be displayed as a background for hydrologic elements on the Basin Model screen. The use of a background map is optional and not required for any calculations. This appendix describes the background map file format. The file can be produced using available geographic information system (GIS) tools.

File Definition

Watershed boundary and stream line features are both defined in the same file, which is in plain ASCII format. Each feature type is contained in a separate section of the file; it is not important which section is first in the file. Each section begins with the keyword "MapGeo" followed by a colon and either "BoundaryMap" or "RiverMap" (Figure 171).

A map segment defines a list of map coordinates that are connected by a line. A closed segment defines a polygon and an open segment defines a line. Closed segments are used for watershed boundaries and open segments are used for stream lines. Each segment begins with the keyword "MapSegment" followed by a colon and either "Closed" or "Open." The last coordinate in a closed segment is automatically connected to the first coordinate.

Segment coordinates are defined with x-y pairs. Map features are automatically scaled in the Basin Model screen. Coordinates are therefore independent of projection, units, and offset. All segments must be in the same coordinate system.
Appendix C  Background Map File Format

MapGeo: BoundaryMap
MapSegment: closed
582242.875000, 4174922.500000
582220.875000, 4174961.500000
582205.625000, 4175013.750000
581981.000000, 4174672.750000
582025.812500, 4174696.250000
582068.812500, 4174711.000000
MapSegment: closed
582810.125000, 4174024.500000
582874.687500, 4173973.750000
582950.687500, 4173902.750000
582554.000000, 4174000.250000
582667.687500, 4174003.750000
582810.125000, 4174024.500000
MapGeo: RiverMap
MapSegment: open
582750.187500, 4176706.000000
582687.000000, 4176594.000000
582657.375000, 4176468.500000
582613.125000, 4176359.500000
582482.125000, 4174521.500000
582555.250000, 4174377.500000
582555.250000, 4174378.000000
MapSegment: open
582941.500000, 4175098.500000
582920.500000, 4175009.750000
582912.312500, 4174956.500000
582699.375000, 4174540.500000
582618.250000, 4174468.250000

Figure 171. Sample background map file.
Appendix D  Grid-Cell File Format

Grid-Cell File Format

The ModClark transform method requires a grid-cell file. The file defines cells for each subbasin. Parameters for each cell are also included in the grid-cell file. This appendix describes the grid-cell file format. The file can be produced using available geographic information system (GIS) tools.

File Definition

The grid-cell file begins with the keyword "Parameter Order" followed by a colon and parameter keywords indicating the order for reading parameters from the file (Figure 172). The keyword "End" must be on a line by itself after the "Parameter Order" line. Valid parameter keywords are shown in Table 31. Parameter keywords are not case sensitive and are separated by spaces. If the parameter order is not defined, it is assumed to be: Xcoord Ycoord TravelLength Area. The coordinate system of Xcoord and Ycoord used in the file must match the coordinate system used in the gridded DSS precipitation records. Typically the coordinate system will be either hydrologic rainfall analysis project (HRAP) or standard hydrologic grid (SHG).

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Definition</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>XCoord</td>
<td>x-coordinate of the southwest corner of the cell</td>
<td>integer value</td>
</tr>
<tr>
<td>YCoord</td>
<td>y-coordinate of the southwest corner of the cell</td>
<td>integer value</td>
</tr>
<tr>
<td>TravelLength</td>
<td>travel time index from the cell to the subbasin outlet</td>
<td>kilometers</td>
</tr>
<tr>
<td>Area</td>
<td>area of cell within the subbasin</td>
<td>square kilometers</td>
</tr>
<tr>
<td>ScsCn</td>
<td>SCS curve number of the cell</td>
<td>real value (0.0-100.0)</td>
</tr>
<tr>
<td>SmaUnit</td>
<td>Soil moisture accounting unit name</td>
<td>character string</td>
</tr>
</tbody>
</table>

The data for a subbasin begins with the keyword "Subbasin" followed by a colon and the subbasin identifier. One line beginning with the keyword "Grid Cell" follows for each cell in the subbasin. Data for the subbasin ends with the keyword "End". Keywords are not case sensitive and may contain spaces. Blank lines can be included and lines beginning with "#" are ignored as comments. The same grid-cell file can be referenced by more than one subbasin, allowing data for many subbasins to be stored in the same file. The identifier for a subbasin must be exactly the same in the grid-cell file as it is in the basin model.
Parameter Order: Xcoord YCoord TravelLength Area
End:
Subbasin: 85
Grid Cell: 633 359 88.38 3.76
Grid Cell: 634 359 84.51 0.18
Grid Cell: 633 358 85.55 16.13
Grid Cell: 632 358 82.55 12.76
Grid Cell: 625 348 13.75 12.07
Grid Cell: 626 348 17.12 0.09
Grid Cell: 622 347 21.19 3.26
Grid Cell: 623 347 15.56 9.96
End:
Subbasin: 86
Grid Cell: 637 361 59.13 6.79
Grid Cell: 638 361 59.04 6.95
Grid Cell: 636 361 56.68 1.17
Grid Cell: 636 360 55.08 16.38
Grid Cell: 636 347 67.96 2.45
Grid Cell: 637 347 71.72 7.41
Grid Cell: 638 347 72.57 8.78
Grid Cell: 639 347 73.32 0.04
End:

*Figure 172. Sample grid-cell file.*
APPENDIX E

Program License Agreement

Use of the program is governed by a license agreement. The program cannot be used unless the user accepts the terms of the agreement. This appendix gives the full text of the program license agreement.

License Text

This HEC documentation and software were developed at U.S. Federal Government expense and is therefor in the public domain. Components of the HEC software were developed using proprietary commercial productivity software. HEC has executed agreements with the commercial software providers that enable the HEC software to be copied and distributed without restriction. The agreements require that the components of the commercial software used in the HEC applications software be only the runtime form bound in the executable. The commercial portions of the HEC software may not be used for any other applications. Further, the agreements require that users accept the provisions of the copyright restrictions of the commercial software components as noted in the following paragraphs. Please read and accept the provisions by so indicating.

Copyright© 1995 Galaxy Runtime Components by Visix Software, Inc. All Rights Reserved.

Copyright© 1995 AgX Toolmaster Runtime Components by Advanced Visual Systems, Inc. All Rights Reserved.

BY USING OR COPYING THIS SOFTWARE, USER AGREES TO ABIDE BY THE COPYRIGHT LAW AND ALL OTHER APPLICABLE LAWS OF THE U.S., INCLUDING, BUT NOT LIMITED TO, EXPORT CONTROL LAWS, AND THE TERMS OF THE FOLLOWING LICENSE AGREEMENT. HYDROLOGIC ENGINEERING CENTER SHALL HAVE THE RIGHT TO TERMINATE THIS LICENSE IMMEDIATELY BY WRITTEN NOTICE UPON USER'S BREACH OF, OR NONCOMPLIANCE WITH, ANY OF ITS TERMS. USER MAY BE HELD LEGALLY RESPONSIBLE FOR ANY COPYRIGHT INFRINGEMENT THAT IS CAUSED OR ENCOURAGED BY USER'S FAILURE TO ABIDE BY THE TERMS OF THIS LICENSE.

License Agreement

Hydrologic Engineering Center ("HEC") grants to the user the rights to install HEC-HMS (the "Software") (either from a disk copy obtained from HEC, a distributor or another user or by downloading it from a network) and to use, copy and/or distribute copies of the Software to other users, subject to the following terms and conditions:

All copies of the Software received or reproduced by or for user pursuant to the authority of this License Agreement will be and remain the property of HEC. Visix Software, Inc. ("Visix") is acknowledged as the owner of copyright in the Galaxy Run Time Components incorporated in the Software, and as a third-party beneficiary of this License Agreement with the right to enforce the same (with respect to such Run Time Components) in its own name against users.
Appendix E  Program License Agreement

User may reproduce and distribute the Software provided that the recipient agrees to the terms of this License Agreement.

The Software may not be modified, abridged, decompiled or disassembled, and in particular user is prohibited from reproducing, distributing, using, linking or embedding any Galaxy Run Time Components or any part thereof, which are incorporated in the Software under license from Visix in any other software, nor may the user create any other software that makes direct function calls to such Run Time Components.

No part of this License Agreement or of the above copyright notices may be modified, deleted or obliterated from the Software.

No part of the Software may be exported or re-exported in contravention of U.S. export laws or regulations.

THE SOFTWARE IS PROVIDED ON AN "AS IS" BASIS AND WITHOUT WARRANTY. HEC AND VISIX DISCLAIM ALL WARRANTIES, INCLUDING WITHOUT LIMITATION IMPLIED WARRANTIES OF MERCHANTABILITY, OF FITNESS FOR A PARTICULAR PURPOSE AND OF FREEDOM FROM INFRINGEMENT OR RIGHTS OF OTHERS.

Neither HEC or Visix shall be liable to any user for any damage or loss, including without limitation any indirect, consequential, special or exemplary damage or loss, whether or not advised of the possibility of such damage or loss.

Upon request of HEC, the user will execute a written license agreement on the same terms and conditions here set forth.

This License Agreement constitutes the entire agreement between HEC and user relating to the Software, superseding all other agreements or representations, and is offered by HEC for acceptance only without modification in any respect, and will be deemed terminated without further notice upon any breach of its terms and conditions by user.

U.S. Government Use. Where the Products are being delivered to the U.S. Government under a U.S. Government contract or subcontract, use, reproduction and disclosure of the Products by the U.S. Government shall in the first instance, be subject to this Agreement. To the extent that the U.S. Government is not bound by the terms and conditions of this Agreement, its use, reproduction and disclosure of the Products shall be subject to the restrictions set forth in (I) FAR 52.227-14, Alts., II and III, (ii) FAR 52.227-19, or (iii) DFARS 252.227-7013 © (1) (ii), as applicable. For purposes of the FAR, the Products shall be deemed to be "unpublished" and licensed with disclosure prohibitions.

BY PRESSING "ACCEPT" TO CONTINUE OPERATION OF THIS SOFTWARE, THE USER ACKNOWLEDGES ACCEPTANCE OF THIS LICENSE AGREEMENT AND EACH OF ITS TERMS AND CONDITIONS.
Appendix F  Glossary

This glossary contains definitions for words used in a conceptual modeling or programming context. A glossary of words used in a hydrologic engineering context is included in the Technical Reference Manual.

Word List

Checkbox – A small rectangle that is blank when the option is not selected. A small checkmark appears in the rectangle when the option is selected. The state of the checkbox is changed by clicking it with the mouse. It is used to enable an independent option.

Class – A group of objects that are all structurally the same, such as several basin models, several elements, or several precipitation gages. Each object in a class has different data.

Component – A basin model, meteorologic model, or control specifications.

Data Set – Any self-contained object with a name and description including gages, components, elements, and runs.

Element – Any hydrologic element including subbasin, reach, reservoir, junction, diversion, source, and sink.

Field – A rectangular area on a screen for typing input data.

Initial Condition – The value of a state variable at the beginning of a simulation.

Iteration – A sequence of operations that is repeated until a solution is reached.

Keyword – A particular word used at the beginning of a line in a background map or grid-cell file to indicate what information is on the remainder of the line or what information is on the next line.

Parameter – A constant appearing in a mathematical expression, each value of which determines the specific form of the expression.

Radio Button – A small circle that is blank when the option is not selected. The circle is filled when the option is selected. The state of the radio button is changed by clicking it with the mouse. They are used to select from several mutually exclusive options.

Results – Simulation results from the execution of a run.

Run – A combination of one basin model, one meteorologic model, and one control specifications, with options, that are compatible.

State – The value of a state variable at a particular time.

State Variable – A variable which describes the condition of a system and changes during a simulation.
Tab – An input device that has the look of a set of file folders. Each page has an input area with a tab that sticks up at the top of the page. Only one page in the set is shown at a time, the active tab. The active tab is shown slightly raised and is the only page that can accept input.
INDEX

Attributes
- Basin, 14, 44, 50, 81, 85
- Meteorologic, 14, 92, 106
- Project, 9, 13, 37

Background map file, 14, 20, 44, 45, 46, 85, 169
Baseflow, 43, 49, 58, 68, 85, 116
Basin model, 1, 11, 21, 39, 93, 104, 115, 134, 136, 145
Calibration, 129
Clark unit hydrograph, 2, 59, 64
Component, 9, 11, 12, 37, 112, 137
Connecting elements, 48
Constant monthly baseflow, 68, 116
Constraints, 129, 132, 138
Control specifications, 3, 11, 21, 25, 107, 115, 134, 136
Copyright notice, 173
Data storage system HEC-DSS, 1, 18, 21, 22, 23, 30, 50, 81, 101
Date, 3, 14, 22, 25, 107, 110, 112, 120, 145
Deficit and constant loss, 2, 51
Delete
- Basin element, 48
- Basin model, 41
- Control specifications, 108
- Meteorologic Model, 89
- Optimization run or trial, 145
- Project, 18
- Run, 114
Directories, 20
Disconnecting elements, 49
Diversion, 2, 43, 79
Editing Data
- Element, 49
- Gages, 26, 32
- Global, 82
Elements. See Hydrologic Elements
ET zone list, 94
Evaporation coefficient, 104
Evapotranspiration, 2, 14, 34, 57, 88, 91, 104
  Monthly average, 3, 104
Zones, 94
Example application, 147
Execute Run, 112
Exit program, 10, 15
Frequency storm, 2, 102
Gage data, 1, 11, 14, 21, 22, 81, 96, 99
Green and Ampt loss, 2, 52
Grid-cell file, 20, 53, 63, 85, 116, 171
Gridded precipitation, 2, 85, 101, 116
Gridded SCS curve number loss, 2, 53, 59
Gridded soil moisture accounting loss, 54, 59, 68
Hydrologic elements, 1, 14, 42, 48, 49, 145
  Connecting, 48
  Creating, 44, 48
  Deleting, 48
  Duplicating, 48
  Editing, 44, 49
  Move, 48
  Select all, 44
Hydrologic Elements, 138
Importing HEC-1 data, 10, 37
Infiltration, 2, 49
Initial and constant loss, 2, 55
Initial conditions, 34, 74, 78, 116, 118
Initial values, 129, 132
Installation, 5
Interception, 50, 55, 58
Inverse distance gage weighting precipitation, 2, 98
Junction, 2, 43, 79
Kinematic wave routing, 2, 72
Kinematic wave transform, 2, 60
Lag routing, 2, 73
Lakes. See Reservoir
Level-pool routing, 74
Linear reservoir, 35, 59, 63
Linear reservoir baseflow, 69, 116
Loss, 49
Menu bar
- Basin model, 44
  Optimization manager, 134
  Project definition, 10
Meteorologic model, 2, 11, 21, 58, 88, 115, 134
ModClark transform, 2, 20, 50, 53, 63, 95
Modified Puls routing, 2, 74
Muskingum routing, 2, 75
Muskingum-Cunge routing, 2, 62, 76, 77
Objective function, 129, 130, 134, 136, 138
Observed flow, 3, 14, 22, 83, 122, 129, 134
Optimization, 22, 129
  Manager, 3, 11, 134
  Run, 11, 21, 137
Pathname, 21, 24, 31, 101, 167
Ponds. See Reservoir
Precipitation, 2, 14, 88, 95
Program files, 20
Project, 9, 16
Project DSS file, 21
Ratio
  Flow, 3, 117
Index

Precipitation, 3, 117
Source, 81
Subbasin, 50
Reach, 2, 43, 71
Recession baseflow, 70, 116
Reservoir, 2, 43, 77
Rivers. See Reach
Run
  Configuration, 11, 14, 45, 112
  Current, 45, 48, 112, 113, 119, 121
  Manager, 11, 14, 45, 112
Save-states, 114, 119
SCS curve number loss, 2, 55
SCS hypothetical storm, 2, 103
SCS unit hydrograph, 2, 65
Search method, 129, 132, 134, 138
Sensitivity, 133, 138
Sink, 2, 43, 81

Snyder unit hydrograph, 2, 64
Soil moisture accounting loss, 2, 14, 57, 68, 104
Source, 2, 43, 80
Standard project storm, 2, 103
Start-states, 114, 118
Subbasin, 2, 34, 42, 49, 93, 116
  List, 14, 88, 93
Time, 3, 14, 25, 107
Time interval, 3, 14, 22, 25, 107
Toolbar
  Basin Model, 46
  Optimization Manager, 136
Transform, 49
User gage weighting precipitation, 2, 96
User hyetograph precipitation, 2, 95
User-specified unit hydrograph, 2, 67