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Viewing Results 
 
 
   After the model has finished the steady or unsteady flow computations the 

user can begin to view the output.  Output is available in a graphical and 
tabular format.  The current version of the program allows the user to view 
cross sections, profiles, rating curves, hydrographs, X-Y-Z perspective plots, 
detailed tabular output at a single locations, and limited tabular output at 
many cross sections.  Users also have the ability to develop their own output 
tables.   
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Cross Sections, Profiles, and Rating Curves 
 
   Graphical displays are often the most effective method of presenting input 

data and computed results.  Graphics allow the user to easily spot errors in the 
input data, as well as providing an overview of the results in a way that tables 
of numbers cannot. 

 
   Viewing Graphics on the Screen 
 
   To view a graphic on the screen, select Cross Sections, Profiles, or Rating 

Curves from the View menu on the HEC-RAS main window.  Once you 
have selected one of these options, a window will appear with the graphic 
plotted in the viewing area.  An example cross-section plot is shown in Figure 
9.1.  The user can plot any cross section by simply selecting the appropriate 
reach and river station from the list boxes at the top of the plot.  The user can 
also step through the cross section plots by using the up and down arrows.  
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  Figure 9.1  Example Cross Section Plot 

 
   
   An example profile plot is shown in Figure 9.2.  The profile plot displays the 

water surface profile for the first reach in the river system.  If there is more 
than one reach, additional reaches can be selected from the Options menu on 
or the reach button at the top of the window.  

 
   An example rating curve plot is shown in Figure 9.3.  The rating curve is a 

plot of the water surface elevation versus flow rate for the profiles that were 
computed.  A rating curve can be plotted at any location by selecting the 
appropriate reach and river station from the list boxes at the top of the plot.   
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  Figure 9.2  Example Profile Plot 
 

 

 
 

  Figure 9.3  Example Rating Curve Plot 
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Graphical Plot Options 
 
   Several plotting features are available from the Options menu on all of the 

graphical plots.  These options include: zoom in; zoom out; selecting which 
plans, profiles, reaches and variables to plot; and control over labels, lines, 
symbols, scaling, grid options, zoom window location, font sizes, and land 
marks.  In addition to using the options menu at the top of each graphic 
window, if a user presses the right mouse button while the cursor is over a 
graphic, the options menu will appear right at the cursor location.  In general, 
the options are about the same on all of the graphics.   

 
   Zoom In.  This option allows the user to zoom in on a portion of the graphic.  

This is accomplished by selecting Zoom In from the Options menu, then 
specifying the area to zoom in on with the mouse.  Defining the zoom area is 
accomplished by placing the mouse pointer at a corner of the desired zoom 
area.  Then press down on the left mouse button and drag the mouse to define 
a box containing the desired zoom area.  Finally, release the left mouse button 
and the viewing area will display the zoomed-in graphic.  A small window 
showing the entire graphic will be placed in one of the corners of the graphic.  
This window is called the Zoom Window.  The Zoom Window shows the 
entire graphic with a box around the zoomed in area.  The user can move the 
zoom box or resize it in order to change the viewing area. 

 
   Zoom Out. This option doubles the size of the currently zoomed in graphic. 
 
   Full Plot.  This option re-displays the graphic back into its original size 

before you zoomed in.  Using the Full Plot option is accomplished by 
selecting Full Plot from the Options menu. 

 
   Pan.  This option allows the user to move the graphic around while in a 

zoomed in mode.  After zooming in, to move the graphic around, select Pan 
from the Options menu.  Press and hold the left mouse button down over the 
graphic, then move the graphic in the desired direction. 

 
   Animate.  This option was developed for unsteady flow output analysis, but 

can also be used for steady flow output.  This option works with the cross 
section, profile, and X, Y, Z perspective plots.  When this option is selected, a 
window will appear that allows the user to control the animation of any 
currently opened graphics.  The user has the option to too “play” a graphic, 
which means to step through the time sequence of computed profiles.  In a 
steady flow analysis, it can be used to switch between the profiles 
conveniently.  

 
   Plans.  This option allows the user to select from the available Plans for 

plotting.  The default plan is the currently opened plan.  The user can select 
additional plans to view for comparison of results graphically. 

 
   Profiles.  This option allows the user to select which profiles they would like 

to have displayed on the graphic.  This option does not apply to the rating 
curve, it automatically plots all of the profiles. 
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   Reaches.  This option allows the user to select which river reaches they 

would like to have displayed.  This option only applies to the profile plot. 
 
   Variables.  This option allows the user to select whatever variables are 

available for plotting.  The number and type of variables depends on what 
type of graphic is being displayed.  The following is a list of variables that 
can be found on the profile plot: water surface, energy, critical water surface, 
observed water surfaces, reach labels, and left and right main channel bank 
stations, ice cover, left and right levees, pilot channels, sediment elevations, 
and lateral structures.  The cross section plot is has the following eight 
variables: water surface, filled in water surface, energy, critical depth, 
observed water surface, ice cover, Manning’s n values, and pilot channels. 

 
   Labels.  This option allows the user to change the labels at the top of the plot.  

The user can select any or all of the following items to be added to the 
caption: project title, plan title, run date, run time, geometry title, flow title, 
river and reach names, cross section descriptions, cross section river 
stationing, and any user defined additional text. 

 
   Lines and Symbols.  This option allows the user to change the line types, 

line colors, line widths, symbol types, symbol sizes, symbol colors, fill 
patterns, and the line labels.  When the user selects this option, a window will 
appear as shown in Figure 9.4. 

 

 
 
   Figure 9.4  Line and Symbol Options Window   
 
   When the Line and Symbol Options window comes up, it will list only the 

information from the current plot.  When this window is in the "Current Pict 
Line Styles" mode, the user can only change the information for the current 
plot.  If the user wants to change the default line and symbol options for all of 
the plots, they must select Default Line Styles at the top of the window.  
When this option is selected, the user will be able to change the label, line, 
and symbol options for every variable that is plotted in the program.  To use 
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this option, the user finds the variable that they want to change from the list 
on the left side of the window.  Select that variable by clicking the left mouse 
button while over top of the variable.  Once a variable is selected, the options 
that are set for that variable will be highlighted with a red box around each 
option.  The user can change whatever option they want, as well as changing 
the label for that variable.  If a variable does not have a default label, you 
cannot enter one for that variable.   Once the user has made all of the changes 
that they want to all of the desired variables, they should press the OK button.  
The changes will be saved permanently, and any plot that is displayed within 
HEC-RAS will reflect the user-entered changes.  

 
   Scaling.  This option allows the user to define the scaling used for the plot.  

Users are allowed to set the minimum, maximum, and labeling increment for 
the X and Y axis.  Scaling can be set temporarily, or scaling can be set to be 
persistent (scaling stays constant for all cross sections).  Persistent scaling is 
only available for the cross section and rating curve plots. 

 
   Grid.  This option allows the user to overlay a grid on top of the graphic.  

Users have the option to have both major and minor tics displayed, as well as 
a border around the plot. 

 
   Zoom Window Location.  This option allows the user to control which 

corner of the plot that the zoom window will be placed, and the size of the 
window.   

 
   Font Sizes.  This option allows the user to control the size of all of the text 

displayed on the graphic. 
 
   Land Marks.  This option is specific to profile plots.  With this option the 

user can turn on additional labels that will be displayed as land marks below 
the invert of the channel.  Two types of land marks can be displayed, cross 
section river stations or cross section descriptions.  In addition to these two 
variables, once one of the two are displayed, the user can select to edit the 
land mark labels. 

 
   Plotting Velocity Distribution Output 
 
   The user has the option of plotting velocity distribution output from the cross 

section viewer.  Velocity distributions can only be plotted at locations in 
which the user has specified that flow distribution output be calculated during 
the computations.  To view the velocity distribution plot, first bring up a cross 
section plot (select "Cross Sections" from the view menu of the main HEC-
RAS window).  Next, select the cross section in which you would like to see 
the velocity distribution output.  Select Velocity Distribution from the 
Options menu of the cross section window.  This will bring up a pop up 
window (Figure 9.5) that will allow you to set the minimum velocity, 
maximum velocity, and velocity increment for plotting.  In general, it is better 
to let the program use the maximum velocity range for plotting.  Next, the 
user selects Plot Velocity Distribution, then press the "OK" button and the 
velocity distribution plot will appear as shown in Figure 9.6. 
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For details on how to select the locations for computing the velocity 
distribution, see Chapter 7 and 8 of the User’s Manual.  For information on 
how the velocity distribution is actually calculated, see Chapter 4 of the 
Hydraulic Reference Manual. 
 

 
   
   Figure 9.5  Velocity Distribution Options 
 
 

 
 
   Figure 9.6  Velocity Distribution Plot

 9-7 
 



Chapter 9  Viewing Results 
 
   Plotting Other Variables in Profile 
 
   To plot variables other than the water surface in profile, select General 

Profile from the View menu of the main HEC-RAS window.  Any variable 
that is computed at a cross section can be displayed in profile.  An example 
would be to plot velocity versus distance.  Other variables can be selected 
from the Variables option under the Options menu of the plot.  The user can 
plot several different variable types at one time ( e.g., velocity and area versus 
distance),  but the scaling may not be appropriate when this is done.  An 
example of plotting other variables in profile is shown in Figure 9.7. 

 

 
 

 Figure 9.7  General Profile Plot of Variables Versus Distance 
 
 
   Plotting One Variable Versus Another 
 

The rating curve plotting window has the ability to plot other variables 
besides discharge versus water surface elevation.  Any variable that is 
computed at a cross section can be displayed against another computed 
variable (or variables).  An example of this capability is shown in Figure 9.8.  
In this example, Discharge (x-axis) is being plotted against total flow area and 
main channel flow area (y-axis). 
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To plot other variables, the user selects the X Axis Variable and Y Axis 
Variable from the Options menu of the rating curve plotting window.  When 
selected variables to plot, keep in mind that all variables selected for a 
particular axis should have a similar range in magnitude. 

 

 
 

  Figure 9.8  Example of Plotting One Variable Against Other Variables 
 
 
   Sending Graphics to the Printer or Plotter 
 
   All of the graphical plots in HEC-RAS can be sent directly to a printer or 

plotter.  The printer or plotter used depends on what you currently have set as 
the default printer or plotter in the Windows Print Manager.  To send a 
graphic to the printer or plotter, do the following: 

 
   1. Display the graphic of interest (cross section, profile, rating curve, X-

Y-Z, or river system schematic) onto the screen. 
 
   2. Using the available graphics options (scaling, labels, grid, etc.), 

modify the plot to be exactly what you would like printed. 
 
   3. Select Print Current (or just Print on the profile plot) from the File 

menu of the displayed graphic.  When this option is selected, a pop up 
window will appear allowing you to modify the default print options.  
Change any desired options and press the Print button.  The graphic will 
be sent to the Windows Print Manager.  The print manager will then send 
the plot to the default printer or plotter. 
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   Note:  The user can print multiple cross-sections at one time by using the 

Print Multiple option from the File Menu of the cross section and rating 
curve plots.  This option also allows the user to establish how many cross 
sections or rating curves they would like to have printed on each page. 

 
   Sending Graphics to the Windows Clipboard 
 
   All of the HEC-RAS graphics can be sent to the Windows Clipboard.  

Passing a graphic to the clipboard allows that graphic to then be pasted into 
another piece of software (i.e., a word processor or another graphics 
program).  To pass a graphic to the windows clipboard, and then to another 
program, do the following: 

 
   1. Display the graphic of interest on the screen. 
 
   2. Using the options menu, modify the plot to be exactly what you want. 
 
   3. Select Copy to Clipboard from the File menu of the displayed 

graphic.  The plot will automatically be sent to the Windows 
Clipboard.  

   4. Bring up the program that you want to paste the graphic into.  Select 
Paste from the Edit menu of the receiving program.  Once the 
graphic is pasted in, it can be re-sized to the desired dimensions.   

 
   HEC-RAS sends and displays all graphics in a Window's Meta file format.  

Since Meta files are vector based graphics, the graphic can be resized without 
causing the image to distort. 

 
 

Stage and Flow Hydrographs 
 
   If the user has performed an unsteady flow analysis, then stage and flow 

hydrographs will be available for viewing.  To view a stage and/or flow 
hydrograph, the user selects Stage and Flow Hydrographs from the View 
menu of the main HEC-RAS window.  When this option is selected a plot 
will appear as shown in Figure 9.9.  The user has the option to plot just the 
stage hydrograph, just the flow hydrograph, or both as shown in the figure.  
Additionally, there are three tabs on the plot.  The tabs are for plotting (Plot), 
viewing the data in tabular form(Table), and plotting a rating curve of the 
event (Rating Curve).  By default the window comes up in a plotting mode.   

 
   The stage and flow hydrograph plot also has a menu option to select the 

specific node types to be viewed.  By default the plot comes up with a node 
type of cross section selected.  This allows the user to view hydrographs at 
cross sections only.  Other available node types include: Bridges/Culverts; 
Inline Structures; Lateral Structures; Storage Areas; Storage Area 
Connections; and Pump Stations. 
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   There are several options available for viewing this graphic.  These options 

are the same as described previously for the cross section, profile, and rating 
curve plots.  Additionally, this graphic can be sent to the windows clipboard, 
or the printer, as described under the previous plots. 

 
Additional output for the hydrograph plot includes statistics about the 
hydrographs (peak, time to peak, and volume).  Also, the user can 
simultaneously plot observed hydrograph data at locations where they have 
gaged information stored in a DSS file.  The user attaches gaged hydrograph 
information to cross section locations from the Unsteady Flow Data editor. 

 

 
 
   Figure 9.9  Stage and Flow Hydrograph Plot 
    
 
 
X-Y-Z Perspective Plots 
 
   Another type of graphic available to the user is the X-Y-Z Perspective Plot.  

The X-Y-Z plot is a 3-dimensional plot of multiple cross sections within a 
reach.  An example X-Y-Z Perspective plot is shown in Figure 9.10. 
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   Figure 9.9  Example X-Y-Z Perspective Plot 
 
 
   The user has the ability to select which reaches to be plotted, the range of the 

river stations, and which plans and profiles to be displayed.  The plot can be 
rotated left and right, as well as up and down, in order to get different 
perspectives of the river system.  Zoom in and zoom out features are 
available, as well as the ability to move around with scroll bars.  The user can 
choose to overlay the water surface or not.  The user has the ability to overlay 
a grid on the plot, as well as a legend and labels at the top.  The graphic can 
be sent to the printer/plotter or the clipboard just like any other plot.  Sending 
the graphic to the printer or clipboard is accomplished by selecting the Print 
or Clipboard options from the File menu.  The user also has the option to 
reverse the order in which the water surface profiles are displayed.  This 
option allows the user to display the higher water surfaces first, such that the 
lower profiles are not covered up. 
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Tabular Output 
 
   Summary tables of the detailed water surface profile computations are often 

necessary to analyze and document simulation results.  Tabular output allows 
the user to display large amounts of detailed information in a concise format.  
HEC-RAS has two basic types of tabular output, detailed output tables and 
profile summary tables. 

 
   Detailed Output Tables 
 
   Detailed output tables show hydraulic information at a single location, for a 

single profile.  To display a detailed output table on the screen, select 
Detailed Output Table from the View menu of the main HEC-RAS window.  
An example detailed output table is shown in Figure 9.10. 

 

 
 

  Figure 9.10  Example Cross Section Detailed Output Table  
  
   

By default, this table comes up displaying detailed output for cross sections.  
Any cross section can be displayed in the table by selecting the appropriate 
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river, reach and river station from the list boxes at the top of the table.  Also, 
any of the computed profiles can be displayed by selecting the desired profile 
from the profile list box.  Additionally, different plans can be viewed by 
selecting a plan from the plan list box. 

 
   Users can also view detailed hydraulic information for other types of nodes.  

Other table types are selected from the Type menu on the detailed output 
table window.  The following types are available in addition to the normal 
cross section table (which is the default): 

 
   Culvert.  The culvert table type brings up detailed culvert information.  This 

table can be selected for normal culverts, or for culverts that are part of a 
multiple opening river crossing.  An example culvert specific table is shown 
in Figure 9.12. 

 

 
 

  Figure 9.12  Example Culvert Type of Cross Section Table 
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   Bridge. The bridge table type brings up detailed output for the cross sections 
inside the bridge as well as just upstream of the bridge.  The bridge table type 
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can be selected for normal bridge crossings, or for bridges that are part of a 
multiple opening river crossing.  An example of the bridge specific cross 
section table is shown in Figure 9.13. 

 

 
 

  Figure 9.13  Example Bridge Type of Cross Section Table 
 
 
   Multiple Opening.  The multiple opening type of table is a combination of 

the cross section table and the bridge and culvert tables.  That is, if the user 
has defined multiple opening (bridges, culverts, and conveyance areas), then 
this table can be used to view the hydraulic results for each specific opening. 

 
   Inline Structure.  The Inline Structure type of table can be used to view 

detailed output for any inline weirs and/or gated spillways that have been 
entered by the user. 
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   Lateral Structure.  The Lateral Structure type of table can be used for 
viewing detailed output from a lateral weir, gated spillway, culvert, and rating 
curves. 
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Storage Area.  This table provides output about an individual storage area.  
Information includes water surface elevation, total inflow, total outflow, and 
net inflow. 
 
Storage Area Connection.  This table provides detailed information about 
storage area connections.  Storage area connections can consist of weirs, 
gated spillways, and culverts. 

 
Pump Stations.  This table provides detailed information about pump 
stations.  Pump station output includes to and from water surface elevations, 
total flow, flow through each pump group, flow through each pump, head 
difference, and efficiency. 

 
   Flow Distribution In Cross Sections.  The Flow Distribution table type can 

be used to view the computed flow distribution output at any cross section 
where this type of output was requested.  An example of the flow distribution 
table output is shown in Figure 9.14. 

 

 
 

  Figure 9.14  Example of the Flow Distribution Type of Table 
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At the bottom of each of the detailed output tables are two text boxes for 
displaying messages.  The bottom text box is used to display the definition of 
the variables listed in the table.  When the user presses the left mouse button 
over any data field, the description for that field is displayed in the bottom 
text box.  The other text box is used to display any Errors, Warnings, and 
Notes that may have occurred during the computations for the displayed cross 
section. 

 
   Detailed Output Table Options 
 
   Plans.  This option allows the user to select which plan, and therefore output 

file, they would like to view.  This option is available from a list box at the 
upper right hand side of the window. 

 
Under the Options menu of the cross section table window, the user has the 
following options: 

 
   Include Interpolated XS’s.  This option allows the user to either view 

interpolated cross-section output or not. Turning the "include interpolated 
XS’s" option on (which is the default), allows interpolated sections to be 
selected from the river station box.  Turning this option off gets rid of all the 
interpolated sections from the river station selection box, and only the user 
entered cross-sections are displayed. 

 
   Include Errors, Warnings, and Notes in Printout.  This option allows the 

user to have the errors, warnings, and notes information printed below the 
table, when the option to print the table is selected. 

 
   Units System For Viewing.  This option allows the user to view the output in 

either English or Metric units.  It does not matter whether the input data is in 
English or Metric, the output can be viewed in either system. 

 
 
   Profile Summary Tables 
 
   Profile summary tables are used to show a limited number of hydraulic 

variables for several cross sections.   To display a profile summary table on 
the screen, select Profile Summary Table from the View menu of the main 
HEC-RAS window.  An example profile summary table is shown in Figure 
9.15. 
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 Figure 9.15  Example Profile Table 
 

There are several standard table (Std. Tables) types available to the user.  
Some of the tables are designed to provide specific information at hydraulic 
structures (e.g., bridges and culverts), while others provide generic 
information at all cross sections.  The standard table types available to the 
user are: 

 
   Standard Table 1.  The is the default profile type of table.  This table gives 

you a summary of some of the key output variables. 
 
   Standard Table 2.  This is the second of the standard summary tables.  This 

table provides information on the distribution of flow between the left 
overbank, main channel, and right overbank.  This table also shows the 
friction losses, as well as contraction and expansion losses that occurred 
between each section.  Energy losses displayed at a particular cross section 
are for the losses that occurred between that section and the next section 
downstream. 

 
   Four XS Culvert.  This standard table provides summary results for the four 

cross sections around each of the culverts in the model.  The four cross 
sections are the two immediately downstream and the two immediately 
upstream of the culvert.  This table will list all of the culverts in the model for 
the selected reaches. 

 
   Culvert Only.  This standard table provides hydraulic information about the 

culvert, as well as the inlet control and outlet control computations that were 
performed. 
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   Six XS Bridge.  This table provides summary results for the six cross 
sections that make up the transition of flow around a bridge.  The six cross 
sections include the two cross sections just downstream of the bridge; the two 
cross sections inside of the bridge; and the two cross sections just upstream of 
the bridge.  The program will display results for all the bridges in the model 
within the selected reaches.  When viewing this table, on occasion there will 
be no displayed results for the cross sections inside of the bridge.  This occurs 
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only when the user has selected a bridge modeling approach that does not 
compute results inside of the bridge.  This includes: Yarnell’s method; both 
pressure flow equations; and pressure and weir flow solutions. 

 
   Bridge Only.  The bridge only table shows summary information specifically 

for bridges. 
 
   Bridge Comparison.  The bridge comparison table shows the results for all 

of the user selected bridge modeling approaches that were computed during 
the computations.  For example, the program can calculate low flow bridge 
hydraulics by four different methods.  The resulting upstream energy for the 
user selected methods will be displayed in this table. 

 
   Multiple Opening.  This table shows a limited number of output variables for 

each opening of a multiple opening river crossing. 
 
   Four XS Inline Structure.  This table displays summary results of the four 

cross sections immediately around an inline weir and/or gated spillway.  The 
four cross sections are the two immediately upstream and the two 
immediately downstream of the inline weir and/or gated spillway. 

 
   Inline Structure Only.  This table shows the final computed water surface 

and energy just upstream of each of the inline weir and/or gated spillways.  In 
addition to these elevations, the table displays the total flow, the flow over the 
weir, and the total flow through all of the gates. 

 
   Lateral Structure.  This table shows a limited set of output variables for all 

of the lateral weir/spillway structures within the selected reaches. 
 
   Encroachment 1, 2, and 3.  These three standard tables provide various 

types of output for the computations of floodway encroachments. 
 
   HEC-FDA.  This table provides information that can be exported to the HEC 

Flood Damage Analysis (FDA) program.  The table displays total flow, 
channel invert elevation, and water surface elevation. 

 
   HEC-5Q.  This table provides information that can be exported to the HEC-

5Q (river and reservoir water quality analysis) program.  The table displays 
only the specific parameters required by the HEC-5Q program. 

 
   Ice Cover.  This table shows summary output of ice information.  This table 

was designed for performing a study that includes ice cover. 
 
   Junctions.  This summary table provides a limited set of output for all of the 

cross sections that bound a junction.  This table will show this output for all 
of the junctions found in the model. 

 
   Storage Areas.  This table shows a limited amount of output for all of the 

storage areas in the model.  Output includes: water surface elevation; 
minimum storage area elevation; surface area; and volume. 
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Pump Stations.  This table shows a limited amount of output for any of the 
pump stations contained within the model. 

 
   To view one of the types of tables, select the desired table type from the Std. 

Tables menu on the profile summary table.  In addition to the various types 
of profile tables, the user can specify which plans, profiles and reaches to 
include in the table.  The plans, profiles and reaches options are available 
from the Options menu on the profile plot. 

 
   The user also has the ability to turn the viewing of interpolated cross sections 

on or off.  The default is to view all cross-sections, including the interpolated 
ones.  To prevent the interpolated sections from showing up in the table, de-
select Include Interpolated XS's from the Options menu. 

 
   Another feature available to users is the ability to set the number of decimal 

places that will be displayed for any variable of the pre-defined tables.  Once 
a pre-defined table is selected from the Tables menu, select Standard Table 
# Dec Places from the Options menu.  A window will appear displaying the 
current number of decimal places for each variable.  The user can change the 
number of decimal places to what ever they wish. 

 
   User’s also have the ability to view profile output tables in either English or 

metric units.  This is available from the Options menu on the profile tables.  
It does not matter whether the input data is in English or metric, the output 
can be viewed in either system. 

 
   User Defined Output Tables 
 
   A special feature of the profile summary tables is the ability for users to 

define their own output tables.  User defined output tables are available by 
selecting Define Table from the Options menu of the profile table.  When 
this option is selected, a window will appear, as shown in Figure 9.16.  At the 
top of the window is a table for the user selected variable headings (Table 
Column Headings), the units, and the number of decimal places to be 
displayed for each variable.  Below this table is a table containing all of the 
available variables that can be included in your user-defined table.  The 
variables are listed in alphabetical order.  Below the list of variables is a 
message box that is used to display the definition of the selected variable.   

 
   To get a definition of a particular variable, simply click the left mouse button 

once while the mouse pointer is over the desired variable.  The description of 
the variable will show up at the bottom of the window.  To add variables to 
the column headings, simply double click the left mouse button while the 
mouse pointer is over the desired variable.  The variable will be placed in the 
active field of the table column headings.  To select a specific column to 
place a variable in, click the left mouse button once while the mouse pointer 
is over the desired table column field.  To delete a variable from the table 
headings, double click the left mouse button while the mouse pointer is over 
the variable that you want to delete.  The number of decimal places for each 
variable can be changed by simply typing in a new value. 
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 User defined tables are limited to 15 variables.  Once you have selected all of 
the variables that you want, press the OK button at the bottom of the window.  
The profile table will automatically be updated to display the new table. 

 

 
 
   Figure 9.16  User Defined Tables Window 
 
 
   Once you have the table displayed in the profile table window, you can save 

the table headings for future use.  To save a table heading, select Save Table 
from the Options menu on the profile table window.  When this option is 
selected, a pop up window will appear, prompting you to enter a name for the 
table.  Once you enter the name, press the OK button at the bottom of the pop 
up window.  The table name will then be added to a list of tables included 
under the User Tables menu on the profile table window.  To delete a table 
from the list of user defined tables, select Remove Table from the Options 
menu of the profile table window.  When this option is selected, a pop up 
window will appear displaying a list of all the user-defined tables.  Click the 
left mouse button over the tables that you want to delete, then press the OK 
button.  The selected tables will then be deleted from the User Tables menu 
list. 

 
   Sending Tables to the Printer 
 
   To send a table to the printer, do the following: 
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   1. Bring up the desired table from the tabular output (cross section or 
profile tables) section of the program. 
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   2. Select Print from the File menu of the displayed table.  When this 

option is selected, a pop up window will appear allowing you to 
modify the default print options.  Once you have set the printer with 
the desired options, press the Print button.  The table will be sent to 
the Windows Print Manager.  The Windows Print Manager will 
control the printing of the table. 

 
   The profile summary type of tables, allow you to print a specific portion of 

the table, rather than the entire table.  If you desire to only print a portion of 
the table, do the following: 

 
   1. Display the desired profile type table on the screen. 
 
   2. Using the mouse, press down on the left mouse button and highlight 

the area of the table that you would like to print.  To get an entire row 
or column, press down on the left mouse button while moving the 
pointer across the desired row or column headings. 

 
   3. Select Printer from the File menu of the displayed table.  Only the 

highlighted portion of the table and the row and column headings will 
be sent to the Windows Print Manager. 

 
 
   Sending Tables to the Windows Clipboard 
 
   To pass a table to the Windows Clipboard, and then to another program, do 

the following: 
 
   1. Display the desired table on the screen. 
 
   2. Select Copy to Clipboard from the File menu of the displayed table. 
 
   3. Bring up the program that you want to pass the table into.  Select 

Paste from the Edit menu of the receiving program. 
 
   Portions of the profile tables can be sent to the Clipboard in the same manner 

as sending them to the printer. 
 
 
Viewing Results From the River System Schematic 
 
   The user has the option of either bringing up graphics and tables from the 

View menu on the main HEC-RAS window (as discussed above), or from the 
river system schematic (found under geometric data).  Once data have been 
entered, and a successful simulation has been made, the user can interact with 
the river system schematic.  When the left mouse button is pressed over the 
river system schematic, a pop up menu will appear listing options that are 
relevant to the area of the schematic that is located under the mouse pointer.  
An example of this is shown in Figure 9.17. 
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   In Figure 9.17, the pop up menu shown comes up whenever the user presses 

the left mouse button over a cross section.  In this particular example, the 
mouse button was pressed over the cross section located at river station 10.0 
of the Upper reach of Fall river.  As shown in the menu, the user has the 
choice of editing the cross section data; plotting the cross section; plotting the 
profile for the reach containing this cross section; bringing up the XYZ plot 
for that reach; viewing tabular output;  plotting the computed rating curve at 
this cross section; or viewing a picture of the location.  Other pop up menus 
are available for bridges; culverts; junctions; and reach data. 

 

 
 

 Figure 9.17  Geometric Data Window With Pop up Menu 
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Viewing Ice Information 
 
River ice information can be viewed both in a graphical and tabular format. 

 
Viewing Graphical Ice Information on the Screen  
 
To view graphical ice information on the screen, select either Cross Sections, 
Profiles, or X-Y-Z Perspective Plot from the View menu on the HEC-RAS 
main window.  

 
Cross Section Plot. Figure 9.18 is an example cross section plot displaying 
ice. The ice cover is displayed by selecting Variables under the Options 
menu, then selecting the Ice Cover option. The ice thicknesses in the right 
overbank, main channel, and left overbank are displayed. The default color 
and fill pattern can be changed by the user by selecting Lines and Symbols 
under the Options menu. Note that multiple profiles and multiple plans can 
be displayed on the same plot. 
 

 
 

 Figure 9.18  Cross section Plot with ice 
 
 
   Profiles Plot.  An example of a profile plot with ice is shown in Figure 9.19. 

In this case, the WS-EG Profile was selected. As with the Cross Section plot, 
the ice cover is displayed by selecting Variables under the Options menu, 
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then selecting the Ice Cover option. The ice thicknesses in the right 
overbank, main channel, and left overbank are displayed. The default color 
and fill pattern can be changed by the user by selecting Lines and Symbols 
under the Options menu. Note that multiple profiles and multiple plans can be 
displayed on the same plot.  

 

 
 

 Figure 9.19  Profile plot with ice cover 
 
 

Ice information can also be displayed in profile plots by selecting the 
General Profile option and then selecting Variables under the Options 
menu. This provides a number of ice variables, including ice volume in the 
channel, left, and right overbanks; ice thickness in the channel, left, and right 
overbanks; top of ice elevation in the channel, left, and right overbanks; and 
bottom of ice elevations in the channel, left, and right overbanks. These plots 
can all be viewed in different widow sizes and printed.  
 
X-Y-Z Perspective Plot. As with the Cross Section plot, the ice cover is 
displayed by selecting Variables under the Options menu, then selecting the 
Ice Cover option. The ice thicknesses in the right overbank, main channel, 
and left overbank are displayed. The default color and fill pattern can be 
changed by the user by selecting Lines and Symbols under the Options 
menu.  
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Viewing Tabular Ice Information 
 
Tabular information describing the results of the ice calculations can be 
displayed by selecting Profile Summary Table under the View menu on the 
HEC-RAS main window. Ice information is available directly by selecting the 
Ice Cover option under the Std. Tables menu of the Profile Table window.  The 
Ice Cover option provides a table that includes the ice volume, ice thickness, and 
composite Manning’s n value for the main channel, left overbank, and right 
overbank. In addition, the Ice Cover Table includes the water surface elevation 
and the cumulative ice volume starting from the downstream end of the channel. 
An example table of ice information is shown in Figure 9.20.  Tables of ice 
information can also be created using the Define Table option under the Options 
menu of the Profile Table window. 

 

  
 

 Figure 9.20  Ice Cover Table 
 
 

Viewing Data Contained in an HEC-DSS File 
  
 The HEC-RAS software can write and read data to and from the HEC-DSS 

(Data Storage System) database.  The steady flow portion of HEC-RAS can 
read flow data to be used as profile information, and can write water surface 
profiles, storage-outflow information, and rating curves.  The unsteady flow 
portion of HEC-RAS can read complete hydrographs (stage and flow), as 
well as gate settings to be used during a simulation.  Observed data contained 
in a DSS file can be attached to specific cross sections for comparison with 
computed results at those locations, and computed profiles and hydrographs 
are written to the DSS file during an unsteady flow simulation. 
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 Because a DSS file can be used to share information between different HEC 

programs (such as HEC-HMS and HEC-RAS), it is often necessary to be able 
to view data contained within a DSS file.  A DSS viewer is available from 
within the HEC-RAS software.  To bring up the DSS viewer select DSS Data 
from the View menu of the main HEC-RAS window (Or press the button 
labeled DSS on the main window).  When this option is selected a window 
will appear as shown in Figure 9.21. 

 

 
 
   Figure 9.21  HEC-DSS Viewer Window 
 
 As shown in Figure 9.21, the user selects a DSS file by pressing the open file 

button located next to the DSS Filename field.  When a DSS file is selected, a 
list of the available pathnames within that file will show up in the table.  Each 
DSS pathname represents a record of data stored within the DSS file.  The 
user can select one or more DSS pathnames to be plotted and/or tabulated.  A 
pathname is selected by using the left mouse button to select a row(s) in the 
table, then the button labeled Select highlighted DSS Pathnames is pressed 
and the pathname shows up in the lower box.  The final step is to hit the 
Plot/Tabulate Selected Pathnames button, and the data will be plotted.  An 
example plot is shown in Figure 9.22. 

 
 As shown in Figure 9.22 there are two tabs on the window, one says Plot and 

the other says Table.  By default the window comes up plotting the data.  To 
view the data as a table, simply press the table tab. 
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 Figure 9.22  Example Plot From The HEC-RAS DSS Viewer 
 
 
 Data can be viewed from one or more DSS files simultaneously.  The user 

simple opens one DSS file and picks the desired pathnames, then opens 
another DSS file and selects additional pathnames.  When the Plot/Tabulate 
button is pressed, the data from both DSS files will be plotted and/or 
tabulated. 

 
 A few utilities are also available from the DSS viewer.  These utilities 

include: Time Series Importer; Delete Selected Pathnames; and Squeeze the 
DSS file.  The time series importer allows the user to enter regular interval 
time series data into a table, which can then be imported into a DSS file.  To 
use this option select Time Series Import from the Utilities menu of the DSS 
Data Viewer.  When this option is selected a window will appear as shown in 
Figure 9.23. 
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   Figure 9.23  DSS Time Series Data Import Utility 
 
 
 As shown in Figure 9.23, the user first selects a DSS file to import data into.  

Next a DSS Pathname must be entered for the data to be written to the DSS 
file.  The pathname parts are separated with a “/” between each pathname 
part.  Some parts can be left blank, but the B and C part must be entered at a 
minimum.  Next the user enters the date and time of the first data point, as 
well as the interval of the data (the interval is selected from the available DSS 
intervals).  Next the data units and data type are selected from the drop down 
lists.  If the lists do not contain the units of your data you can enter them 
directly into the field.  The data is then entered into the table at the bottom.  
You can cut and paste information into this table, using the standard windows 
keys of Ctrl-C for cut, and Ctrl-V for paste.  There are buttons available to 
perform the following tasks: set the number of rows in the table (the default is 
99); linearly interpolate missing values; delete a row; insert a row; add a 
constant to a highlighted section of the table; multiply the highlighted section 
by a factor; and set a highlighted section to a specific value. 

 
 The utility labeled Delete Selected Paths is used to delete data from the DSS 

file.  The user simply selects the pathnames they want to delete, then selects 
this option from the Utilities menu.  A window will appear to asking if you 
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are sure you want to delete the selected pathnames.  If you answer OK, then 
the data will be deleted from the DSS file. 

 
 The utility labeled Squeeze DSS File is used to compress the DSS file, such 

that it takes significantly less hard disk space.  This is a convenient function if 
you are working with very large DSS files.  To use this option just select 
Squeeze DSS File from the Utilities menu.  A window will come up asking 
you if you want to squeeze the currently opened DSS file.  If you answer OK 
then the file will be compressed. 

 
 

Exporting Results To HEC-DSS 
 
 The HEC-RAS software has the ability to export a limited set of results to a 

HEC-DSS file for both steady and unsteady flow simulations.  When 
performing an Unsteady flow simulation, the program automatically writes 
stage and flow hydrographs to the DSS file, but only for the user-selected 
hydrograph output locations.  Water surface profiles are also automatically 
written to the DSS file.  The profiles are written for the user selected detailed 
output interval, as well as the overall maximum water surface profile (profile 
of the maximum stage at every cross section).   

 
 Once a steady flow or unsteady flow simulation is performed, the user can 

write the following information to a DSS file: water surface profiles; 
computed rating curves; and storage-outflow information.  To export 
computed results to a DSS file the user selects Export To HEC-DSS from 
the File menu of the main HEC-RAS window.  When this option is selected a 
window will appear as shown in Figure 9.24. 

 

 
 Figure 9.24  Export Computed Results to DSS Window 

 9-30 



Chapter 9  Viewing Results 
 
 
 As shown in Figure 9.24, there are three tabs on the window; one for profiles, 

rating curves, and storage outflow.  To export computed water surface 
profiles, select the Profiles tab from the window.  Select the type of profiles 
that you want to export (water surface elevations or flow).  Next select the 
specific profiles to be exported, as well as the reaches that you want to have 
profiles for.  Select how you want the stationing to be labeled.  This is 
accomplished by selecting one of the options under the field labeled Reach 
Starting Station.  The user can have the river stationing labeled in feet or 
miles, and have it start at zero or whatever the magnitude is of the most 
downstream cross section.  The final option is to press the Export Profile 
Data button, and the data will then be written to the DSS file. 

 
 To write computed rating curves to the DSS file select the Rating Curve tab.  

When the rating curve tab is selected, the window will change to what is 
shown in Figure 9.25. 
 

 
 

 Figure 9.25  Exporting Computed Rating Curves to HEC-DSS 
 
 
 As shown in Figure 9.25, to export a computed rating curve to DSS, select the 

river, reach, and river stations that you want to have exported to the DSS file.  
Then simply press the Export Rating Curves button to have the program 
write the data to the DSS file.  If your profiles are not in the order from 
lowest flow to highest flow, turn on the option that says Sort flows in rating 
curve.  This option will ensure that the curve is written in the order of 
increasing flow rate. 

 
 The HEC-RAS program computes cumulative storage volumes for each of 

the water surface profiles.  This information can be used for hydrologic 
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routing in a hydrology model such as HEC-HMS or HEC-1.  The HEC-RAS 
program allows the user to write out storage versus volume information to a 
DSS file.  To use this option select the Storage Outflow tab from the Export 
to DSS window.  When this option is selected a window will appear as shown 
in Figure 9.26. 

 

 
 
   Figure 9.26  Exporting Storage-Outflow Information to HEC-DSS 
 
 As shown in Figure 9.26, the user selects the River, upstream reach, upstream 

river station, downstream reach, and downstream river station to completely 
define a routing reach in which they want to have storage-outflow 
information written to the DSS file.  This can be done for as many reaches as 
you want within the model.  After all of the reaches are defined, simply press 
the button labeled Export Volume Outflow Data to write the information to 
the DSS file. 
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