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C H A P T E R  6

Viewing HEC-RAS Water Surface Profiles

HEC-GeoRAS facilitates the import of water surface profile data exported
from HEC-RAS results.  Inundation area and depth are calculated during
the import process and may be mapped using HEC-GeoRAS.  Mapping
options allow the user to view the extent of inundation for multiple profile
data and determine the depth of inundation for a given event.

Mapping functions are performed in ARCPLOT.

Chapter 6 discusses the options for viewing exported HEC-RAS water
surface profile data.
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Importing an HEC-RAS Export File

Water surface profile results exported from HEC-RAS are imported by
selecting Import RAS Export File from the RASPost menu on the
project manager.  The window shown in Figure 6.1 will be invoked,
allowing the user to select the file to be imported.  Right clicking over the
input box will allow the user to select from a popup list any file with the
.gis extension in the current directory, while pressing the button to the
right of the input field will invoke a file browser.

After selecting the import file, enter the name of a new cross section
coverage to create.  The new cross section coverage will contain the
geometric data from the RAS results.  Water surface elevations from the
user selected water surface profiles will be added to the new cross section
coverage during the import process.  
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Figure 6.2 Create Inundation Coverages/Grids window

Figure 6.1 Import RAS Export File window

Pressing OK  invokes the window shown in Figure 6.2 and allows the user
to select the water surface profile data to process.  The window also
allows the user to select the grid-cell resolution of the depth grid that will
be created.  Pressing OK  will create an inundation coverage and depth
grid for each water surface profile selected and dismiss the windows.

Two coverages will be created for each profile: a polygon coverage
having the prefix f_ and a depth grid having the prefix d_, followed by the
water surface profile name.  A water surface TIN having the prefix t_ will
be created but will be deleted after the water surface coverages have been
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created.  Underscores will replace any blanks in the water surface profile
names.  The coverages are created in the current workspace.  The  files
wsp.menu, wsp_draw.menu, and  tempindex9999 will also be created in
the current directory during this process.  If the files already exist, they
will be overwritten.

Profile names must be 11 characters or less.  Inundation coverages will
not be created for profiles with name longer than 11 characters.

Inundation Mapping

To view the coverages created, select Inundation Mapping  from the
RASPost menu.  The Inundation Mapping window will be displayed
along with a display window.  The display window may be sized to the
user’s preference.

Mapping options are performed in ARCPLOT.

Inundation Mapping Menu

The Inundation Mapping window is organized by function. At the top of
the mapping window are the File and Help menus.   The upper portion of
the window allows the user to select the coverages and corresponding
colors to be displayed.   The lower part of the menu provides the user with
display window options.  The Inundation Mapping window is shown in
Figure 6.3.

File menu options include the Command Line, Print and Exit options,
while the Help menu provides online help for users.

Command Line: Allows the user to issue commands at the Arc Plot
prompt.  Type &RETURN to return to the user interface.

Print : Print provides options for printing inundation map results. 

Exit : Exit dismisses the mapping window and display and quits
ARCPLOT.  The user is returned to the project manger.

Help: Provides an ascii help file for mapping coverages.

ArcDoc: Provides access to the ARC/INFO help system.
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Figure 6.3 Inundation Mapping window

Coverage Display Options
Coverage display options allow the user to select the inundation extent
coverages, background coverages, and the depth grid to be displayed. 
Inundation polygons and depths grids cannot be displayed at the same
time.  The extent of inundation may be viewed as a filled polygon or as a
boundary polygon by selecting Fill  or Bndry, respectively.   These options
may be mixed and matched as desired.

To select the color for the extent of inundation coverages, press the 

button beside the profile name.  A color palette will be displayed.  If the
user dismisses the palette before choosing a color, no color will be
assigned to the coverage.

Selection of the depth grid is performed by right clicking in the input field
or typing the exact name.  A right click will result in a popup list from
which the depth grid may be selected.  Pressing the Depth? button will
allow the user to interactively determine the water depth at a given
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Figure 6.4 Inundation polygons

location.  The water depth and corresponding units will be displayed to
the right of the button.  Use the cross-hairs and left click to select the
location; right click to exit.

Background coverages may be displayed with the inundation coverages by
selecting the corresponding check box.  The Ground Contours, Main
Channel Bank Stations, and Main Channel Invert coverages are the
available background coverages, at this time.  Background coverages will
be displayed behind the inundation polygons but in front of the depth grid. 
Inundation mapping for exported water surfaces is shown in Figure 6.4.

Window Display Options
Window display options allow the user to update the content of the
display window.  The Display:  �Poly  �Grid choice determines whether
the inundation polygons or depth grid will be drawn to the display
window.  The polygons and depth grid may not be displayed
simultaneously.  The remaining display buttons are discussed below.
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Refresh Display: Refreshes the display window with the selected
coverage and display choice options.

ZoomIn: Zooms into the center of the window by a factor of 2.  Use the
left mouse button to select the location to zoomin to.  Right click when
finished zooming.

ZoomOut: Zooms out of the center of the window by a factor of 2. Use
the left mouse button to select the location to zoom to.  Right click when
finished zooming.

ZoomExtent: Allows the user to specify the extent of the view using
cross-hairs to select opposite corners.

FullView : Displays the entire extent of the coverage.

Pan: Allows the user to pan through the image without changing the scale
of the view. Use the left mouse button to select the location to pan to. 
Right click when finished panning.

For each option, a left click perform the operation and a right click quits.

Printing Map Results

Map results displayed in the Inundation Mapping window may be
modified and  printed from the Print Map window.  To access the Print
Map window show in Figure 6.5, select Print  from the File menu on the
Inundation Mapping window.  
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Figure 6.5 Print Map window

At the top of the Print Map window is a menu bar with the File and Help
menus.  The remainder of the menu is dedicated to modifying the page
and presentation of the inundation map for printing.

The File menu options include Preview, Print, Command Line, and Exit,
while the Help menu options provides access to online help.

Preview: Displays the entire page as it will be printed.  Shown in Figure
6.6 is an inundation map displayed using the preview option.

Print : Writes the map to a file and brings up the ARC/INFO printing
interface to print the map file.

Command Line:  Allows the user to issue commands at the ARCPLOT
prompt.  Type &RETURN to return to the user interface.  Only
experienced ARC/INFO users should use this option.
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Figure 6.6 Preview of an inundation map

Exit : Dismisses the Print Map window and returns control to the
Inundation Mapping window.

Help: Displays a help file specific to the printing options

ArcDoc: Accesses the ARC/INFO online help system.

Options provided to the user for modifying the page presentation include
the capabilities for selecting the page and page setup; displaying and
formatting text; displaying a border; and specifying and displaying the
map scale.  Viewing a map presentation before printing a map is
performed using the Preview, while the Print  option writes the map to a
file and accesses the ARC/INFO printing interface.

Page Setup
The type of paper currently selected for printing is displayed near the top
of the Print Map window in the Paper field.  To the right of the Paper
field is the Setup button.  Pressing the Setup button accesses the Page
Setup window shown in Figure 6.7.  The Page Setup window allows the
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user to identify the Paper and Orientation and specify the Page Margins
and Internal Margins.

Paper size options are provided for standard sizes.  The user may select
from the standard paper sizes listed by clicking the right mouse button
while the cursor is over the Paper input box.  The default paper size is
Letter, 8.5 x 11 in.

Paper Standard Size

Letter 8.5 x 11 in

Legal 8.5 x 14 in

B 11 x 17 in

C 17 x 22 in

D 22 x 34 in

E 34 x 44 in

F 44 x 68 in

Orientation choices are Portrait and Landscape.  Portrait specifies that
the first dimension listed after the name is the width of the paper while
Landscape specifies that the second dimension is the paper width. 
Portrait is the default paper orientation.

Page Margins indicate where the Border will be drawn, if so desired.  The
margins are be specified in inches from the papers edge.  One inch Page
Margins are the default.

Internal Margins determine the area available for the map to be displayed. 
The margins are specified in inches inside of the Page Margins.  The
default margins are 1.0 inch from the top page margin and 0.1 inch from
the remaining edges.

The OK  button applies the Page Setup setting and dismisses the window. 
Cancel dismisses the window without changing the setup.

Text
Text options allow the user to enter five labels and specify the format and
location of the text displayed.  The Text Fields on the Print Map window



Chapter 6   Viewing HEC-RAS Water Surface Profiles

6-10

Figure 6.8 Text formatting window

allow the user to type in the labels for the map.  To enter a label, select a
text field using the left mouse button and begin typing.  Text with percent
signs (%) on each side is not allowed, while backward slashes (\) will
result in the text continuing on the next line, much like a carriage return. 
The corresponding checkboxes to the left of the Text Fields determine
which text will be displayed when the Preview and Print  option are used.

The position of the text may be specified by entering the coordinates
manually or by pressing the  button and selecting the text placement

with the cross-hairs provided.  The positioning of the text in relation to the
cross-hairs placement depends upon the justification setting for the text
field.

To format a text field press the Format Text button.  The window shown
in Figure 6.8 will be displayed.  The label text will be displayed on the
left portion of the window with the formatting value displayed in
corresponding fields to the right.

To select a Font, press the right mouse button over a selected font field to
invoke the list of available fonts, or type in the entire name into the field. 
At this time, Courier, Helvetica, Palacio (Palantino), and Times fonts are
available in normal, italic, bold, and bold italic.  Helvetica is the default.

Font Size may be specified by typing in the desired size.  Press the
carriage return after entering the size.  Size 16 pt font is the default.

Justification refers to the alignment of the label in relation to the cross-
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hair position described earlier.  LEFT, CENTER, and RIGHT justification
choices are available.  LEFT justification means that the bottom left-hand
corner of the label will be located at the coordinate position shown on the
Print Map window, while CENTER means the text will be centered above
the position specified, and RIGHT means that the right-hand bottom
corner of the label will be located at the position specified.  Right click
over the Just. field to invoke a popup list or type in the justification choice
as listed above. 

OK  closes the Format Text Fields window, keeping any changes made.

Border 
To display a border when using Preview and Print  select the
corresponding checkbox.  The border will be drawn in black at the Page
Margins specified using Page Setup.

Map Scale
To display the map scale on the printed map, select the corresponding
checkbox.  The map scale will be printed at the bottom left-hand corner,
just below the border.  The Maximum Print Area choice is used to print
the map using the entire display area as determined from the Internal
Margins.  The User Defined Scale provides the user with a response
window for entering a specific scale.  The scale is defined as 1 inch to X
map units, where X is the scale and map units are determined from the
DTM.   The display area is reduced to fit the longest side of the map.

Preview
To preview the map before printing, use the Preview option from the File
menu.  During preview, the map displayed from the Inundation Mapping
window will be shown along with any items that have the corresponding
checkbox checked.

To change the map displayed during preview, select Exit  from the File
menu to return to the Inundation Mapping window.  From the Inundation
Mapping window the user may adjust the map view as desired, before
returning to the Print Map window.

Print
To print the map, select Print  from the File menu.  This will write the
map to a file before accessing the ARC/INFO printing interface.  If the
user wishes to save the map to a file, select the  Yes choice for Write map
to file?.   Otherwise, a temporary file tempprintfile.gra will be used to
print the map.



Chapter 6   Viewing HEC-RAS Water Surface Profiles

6-12

From the printing interface select the file to print and printer Driver
(Window NT) or printer (UNIX) and press Print .  When finished printing
press Quit , to return to the Print Map window.

To print from UNIX, a print queue file must be setup. 

Exit
To exit from the Print Map window, select Exit  from the File menu.  The
user will be returned to the Inundation Mapping window.


