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Appendix E 
 Using HEC-DssVue 

Included within the framework of ResSim is HEC-DssVue, a tool that 
allows you to access data stored in HEC-DSS database files.  With HEC-
DssVue, data may be plotted, tabulated, edited, and manipulated with over 
fifty mathematical functions.  In addition to these functions, HEC-DssVue 
provides several utility functions, such as entering data sets into a 
database, renaming data sets, copying data sets to other DSS database 
files, and deleting data sets.  You can launch HEC-DssVue from any 
ResSim module by choosing HEC-DssVue from the Tools menu. 

DSS files refer to time-series data by pathnames representing records.  
Pathnames are separated into six parts (delimited by slashes "/") labeled 
"A" through "F."  For "regular" time-series records, the naming 
conventions for describing the contents of the six pathname parts are: 

A     Project name 

B     Location or gage identifier 

C     Data variable, such as FLOW or PRECIP 

D     Starting date in the format 01JAN1980. 

E     Time interval 

F     Additional user-defined descriptive information 

With HEC-DssVue, you can select data sets from a list of pathnames (or 
catalog) in the database and visualize the data in tabular or graphical form.  
The list of pathnames can be displayed as a straight list of pathnames, or 
as a list of pathnames separated into parts. You can refine the list by 
searching for either a string in the pathnames or for pathname parts. 

In ResSim, you will use HEC-DssVue mainly as a viewing tool for DSS 
data.  This Appendix will review some of the general functions in HEC-
DssVue.  For further detail, see the HEC-DssVue User's Manual (HEC, 
2003b). 

E.1 The HEC-DssVue Data Selection List Window 
HEC-DssVue is available from any of the ResSim modules.  From the 
Tools menu, select HEC-DssVue.  Figure E.1 shows the main window 
(the Data Selection List) of HEC-DssVue, using the Condensed Catalog 
option from the View menu to list the pathnames of the data records in the 
opened DSS file.  Using the Condensed Catalog option, time-series data 
sets are abridged so that the date range for the entire data set is displayed 
in the “D-part” column. 
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Figure E.1  HEC-DssVue - Data Selection List Window, Condensed 
Catalog Displayed 

From the View menu, you can also choose to view the pathnames using all 
of the Pathname Parts (Figure E.2), in a Pathname List (Figure E.3), or 
with No Pathnames displayed. 

Figure E.2  HEC-DssVue - Data Selection List Window, Pathname 
Parts Displayed 
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Figure E.3  HEC-DssVue - Data Selection List Window, Pathname 
List Displayed 

E.1.1 Menu Options 
Menu options in the HEC-DssVue Data Selection List window allow 
you to search for, select, and edit DSS data sets; control the display of 
pathnames; and access plots and tables, among other tasks.  The HEC-
DssVue menus are as follows: 

File File menu commands are New, Open, and Close.  
The File menu also lists your most recently used files.

Edit Edit menu commands are Undo, Cut, Copy, Paste, 
Delete, Edit Data, and Select All. 

View The View menu allows you to customize the display 
of DSS pathnames and search pathnames.  Available 
commands are Pathname List, Pathname Parts, 
Condensed Catalog, No Pathnames, Refresh 
Catalog, Search pathnames by string, and Search 
pathnames by parts. 

Display Use the Display menu to open plots and tables with 
the Plot and Tabulate commands. 

Utilities The Utilities menu provides access to Math 
Functions, Manual Data Entry (Time-Series and 
Paired Data), and it allows you to Rename Records, 
Copy Records, Duplicate Records, Merge Files, 
Squeeze, and view DSS Status. 
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E.1.2 Menu Buttons 
Menu buttons provide shortcuts to frequently used Menu commands: 

 Opens an HEC-DSS File (same as Open in the File menu). 

 Displays data as a Plot (same as Plot in the Display menu). 

 Displays data in Tabular form (same as Tabulate in the 
 Display menu). 

E.1.3 Data Selection Fields and Buttons 
The HEC-DssVue Data Selection List displays the Filename of the 
opened DSS file.  Displayed beneath the filename are the number of 
pathnames shown in the list, the number of pathnames selected, the 
total number of pathnames in the database file, and the size of the 
database file (in kilobytes). 

The HEC-DssVue Data Selection List also provides a search area 
where you can Search Pathnames (Figure E.4) or Search Parts 
(Figure E.5).  You choose your search option from the View menu. 

 
Figure E.4  Search Pathnames Option 

 

Figure E.5  Search by Parts Option 

Once you have opened a DSS file, its records appear in a list beneath 
the search area. 

The complete pathnames of “selected” records appear in the Selection 
area beneath the list of all records. 

Also, there are five buttons (Figure E.6) at the bottom of the Data 
Selection List window. 

Figure E.6  Data Selection List Buttons 

1. You select a record by highlighting it and clicking the Select 
button.  Until you highlight a pathname, the Select button 
remains inactive. 

2. To de-select the record, you highlight the record in the selected 
list, then click the De-Select button. 
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3. You can also de-select all selected records by clicking the Clear 
Selections button. 

4. The Restore Selections button restores all selections you have 
most recently cleared or de-selected. 

5. You can set the time window with the Set Time Window 
button, and subsequent plots, tables, statistics, etc., will reflect 
the time-series data within that specified time window. 

E.2 Opening a DSS Database File for Browsing 
If you know the name of the DSS database File you wish to browse, you 
can type the File name (including the path) directly into the File Name 
box in the HEC-DssVue Data Selection List to open the DSS file. 

Otherwise, choose Open from the File menu or click the  button to 
select the DSS database File you want. 

An Open HEC-DSS File browser window will open, as shown in 
Figure E.7. 

 
Figure E.7  Open HEC-DSS File Browser 

In the Open HEC-DSS File browser window, use the standard Windows 
controls to browse to the DSS File that you wish to open, then click Open.  

Once you have opened a DSS file, the HEC-DssVue Data Selection List 
window displays the filename, the number of pathnames shown in the list, 
the number of pathnames selected, the total number of pathnames in the 
database file, and the size of the database file (in kilobytes).  The 
individual pathnames display in a table beneath the search area. 
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E.3 Sorting DSS Pathnames by Parts 
You can use the filters provided to sort DSS pathnames by parts. 

Choose Search pathnames by parts from the View menu.  Then, use the 
lists in the Search By Parts section of the HEC-DssVue Data Selection 
List to show the pathnames you want to select from.  Click on the blank 
cell at the top of each list to show the unfiltered list. 

E.4 Selecting DSS Pathnames 
Once you have filtered the listing of pathnames, you can select them by 
double clicking on the desired names in the list (which adds them to the 
box on the bottom of the Data Selection List window).  You can also 
highlight the pathname(s) from the list then click the Select button.  Until 
you select a pathname(s), the Select button remains inactive. 

If you wish to select all of the pathnames, choose Select All from the Edit 
menu. 

E.5 Using Plots and Tables to Visualize DSS Data 
Once the lower box contains all the pathnames you wish to display, you 
can access plots and tables. 

To do this, you can select Plot or Tabulate from the Display menu, or 
you can click on the Plot  button or the Tabulate  button. 

Figure E.8 shows an example plot and Figure E.9 shows the corresponding 
tabulated values produced using HEC-DssVue.  The parameters for the 
plots are labeled and color-coded, date ranges are specified along one axis, 
and the units of measure are specified along the other axis.  You can resize 
the plot window by grabbing the corner of the window and dragging it to 
the desired size.  You can also select the Zoom tool  and then zoom in 
on the data by moving the mouse to a position on the graph, holding down 
the left mouse button, moving the mouse so that the new mouse position 
defines a rectangle of the area to enlarge, then releasing the mouse button.  
To zoom out, just right-click anywhere in the graph area.  To view the 
tabular form of the plot, you can select the Tabulate command from the 
File menu of the Plot window. 

HEC-DssVue tabulates data in a vertical scrolling window that shows the 
ordinate number (starting from the start date/time), the date and time 
stamp, and the values for the selected data sets.  You can view the tabular 
data in plot format by selecting the Plot command from the File menu of 
the Table window. 

In tables produced by the HEC-DssVue Data List Selector, you have 
several options for displaying the tabular data.  From the table’s View 
menu, you can choose to display commas in the number by selecting the 
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Show Commas command.  You can also opt to display Date and Time 
Separately, which will split the date-time stamp into two columns.  
Another option is to display the Date with 4 Digits, instead of the default 
two.  Also, you can set the precision of decimal places for your data by 
selecting Show Decimal Places and selecting the number of decimal 
places you wish to display. 

 
Figure E.8  Example Plot from HEC-DssVue 

Figure E.9  Example Tabulation from HEC-DssVue 
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E.6 Editing Tabular Data in HEC-DssVue 
In HEC-DssVue, 
you can edit the 
tabular data 
directly from a 
tabular data 
window.  Selecting 
Allow Editing 
from the Edit 
menu of the table 
(Figure E.10) 
allows you to 
manually edit the 
data in the table. 

You can also use 
shortcut menu 
commands to edit 
data in tables. 

If you make any 
edits, HEC-DssVue 
prompts you to 
save changes to the 
data set when you 
close the window. 

 

E.7 Performing Math Functions in HEC-DssVue 
To perform math functions in HEC-DssVue: 

1. Select the data set on which you want to perform a math function. 

2. Choose Math Functions from the Utilities menu.  A dialog box 
will appear, as shown in Figure E.11. 

3. As appropriate, select one of the six tabs (Arithmetic, General, 
Time Conversion, Hydrologic, Smoothing, and Statistics).  
You will most likely find that the information available from the 
Statistics tab is very useful when analyzing data and results.  An 
example of the Statistics screen is shown in Figure E.12. 

Figure E.10  Edit Menu -- Allow Editing Option 
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Figure E.11  HEC-DssVue Math Functions Dialog Box 

 

 
Figure E.12  HEC-DssVue Math Functions, Statistics Tab 

 

4. After you have selected the appropriate math function and 
required parameters for the function, click the Compute button. 

5. To view the results, click the Plot or Tabulate button and the 
results will be displayed as a comparison against the original 
data. 
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6. To save the new values in place of the original values, click the 
Save button  (or select Save from the File menu).  HEC-
DssVue will ask you to confirm that you wish to replace the 
original data. 

7. To save the new values as a new record, click the Save As button 
 (or select Save As from the File menu).  A Save As dialog 

box will open, as shown in Figure E.13.  Enter the new pathname 
information and click OK to save the record. 

Figure E.13  HEC-DssVue Save As Dialog Box 

There are many very useful math functions available in HEC-DssVue.  
This Appendix only covers the basic functionality for accessing the 
functions.  The HEC-DssVue User’s Manual (HEC, 2003b) is the primary 
reference for further information and details for using the Math Function 
Utilities. 
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E.8 Entering Time-Series Data Manually in  
HEC-DssVue 

To enter Time-Series data manually: 

1. From the Utilities menu, choose Manual Data Entry, then 
select Time Series....  The Manual Time Series Data Entry 
dialog box (Figure E.14) will open. 

 
Figure E.14  HEC-DssVue Manual Time Series Data Entry 
Dialog Box 

2. Type the Pathname Parts into the A, B, C, and F fields.  
DssVue will define the D-part of the pathname based on the 
dates/times you enter for the data.  You must select an 
appropriate time interval (E-part) from the list.  The complete 
pathname will automatically appear in the Pathname field.  
Alternately, you can enter the pathname into the Pathname field 
and the parts will appear in the Pathname Parts fields. 

3. Enter the Start Date (e.g., 30 Mar 2002). 

4. Enter the Start Time (e.g., 1400). 

5. Enter the Units (e.g., cfs, feet, ...). 
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6. Select a record type from the Type list.  Your options are PER-
AVER, PER-CUM, INST-VAL, and INST-CUM. 

7. Using the Manual Entry tab, the Date/Time fields will fill in 
automatically according to the start date and time you have 
entered; or, using the Automatic Generation tab, enter the End 
Date and End Time. 

8. Using the Manual Entry tab, type the data values into the third 
column; or, using the Automatic Generation tab, enter the Fill 
Value. 

9. To view the data in plot form, click the Plot button. 

10. To save the new time-series record, click Save. 

E.9 Entering Paired Data Manually in HEC-DssVue 
To enter Paired Data manually: 

1. From the Utilities menu, choose Manual Data Entry, then 
select Paired Data.  The Manual Paired Data Entry dialog box 
(Figure E.15) will open. 

 
Figure E.15  HEC-DssVue Manual Paired Data Entry Dialog Box 

2. Type the Pathname Parts into the A, B, C, D, E, and F fields.  
The C-part name should reflect the X curve name - Y curve 
name.  The complete pathname will automatically appear in the 
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Pathname field.  You can also enter the pathname into the 
Pathname field; the parts will appear in the Pathname Parts 
fields. 

3. Select the Number of Curves (Y curves) from the list. 

4. Enter the X Units and the Y Units. 

5. Choose the X Type and Y Type scale from the lists.  Available 
options are:  Linear, Log, and Probability. 

6. In the table, the Y ordinates column will split into individual 
columns according to the Number of Curves you have 
specified.  

7. Type the data values into the X ordinates and Y ordinates 
columns. 

8. To view the data in plot form, click the Plot button. 

9. To save the new time-series record, click Save. 

E.10 Renaming DSS Records in HEC-DssVue 
To Rename a DSS Record: 

1. Select the record(s) either by double-clicking on it or by 
highlighting it then clicking the Select button.  From the Utilities 
menu, select Rename Records.  The Rename Records to dialog 
box (Figure E.16) will open. 

 
Figure E.16  HEC-DssVue Rename Records Dialog Box 

2. Type the new Pathname Parts into the A, B, C, or F fields. 

3. Click OK.  A confirmation message will appear, stating that the 
record(s) has been renamed. 
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E.11 Copying Records into a DSS File in HEC-DssVue 
To Copy records into a DSS file: 

1. Select the record(s) either by double-clicking on it or by 
highlighting it then clicking the Select button.  From the Utilities 
menu, select Copy Records.  The Copy Records into HEC-
DSS File dialog box (Figure E.17) will open. 

 
Figure E.17  HEC-DssVue Copy Records into 
HEC-DSS File Dialog Box 

2. Type in a new DSS filename or select an existing DSS file into 
which you want to copy the record and click Open.  A 
confirmation message will appear, stating that the record has 
been copied to the DSS file you specified. 

E.12 Duplicating Records in HEC-DssVue 
To Duplicate a record: 

1. Select the record(s) either by double-clicking on it or by 
highlighting it then clicking the Select button.  From the Utilities 
menu, select Duplicate Records.  The New pathname parts for 
duplicate records dialog box (Figure E.18) will open. 

 
Figure E.18  HEC-DssVue New Pathname Parts 
for Duplicate Records Dialog Box 

2. Type the new Pathname Parts into the A, B, C, or F fields. 
3. Click OK.  A confirmation message will appear, stating that the 

record(s) has been duplicated. 
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E.13 Merging Records into a DSS File in HEC-DssVue 
To Merge a record into a DSS file: 

1. Select the record(s) either by double-clicking on it or by 
highlighting it then clicking the Select button. 

2. Choose Merge from the Utilities menu.  The Merge (copy all 
records) into HEC-DSS File dialog box (Figure E.19) will 
open. 

 
Figure E.19  HEC-DssVue Merge (copy all records) into  
HEC-DSS File Dialog Box 

3. Type in a new DSS filename or select an existing DSS file into 
which you want to merge the record(s) and click Open.  A 
confirmation message will appear, stating that the record(s) has 
been merged into the DSS file you specified. 

E.14 Squeezing DSS Files in HEC-DssVue 
When you delete or rename records, a HEC-DSS file can accumulate 
inactive space.  The Squeeze command removes inactive space by 
copying all valid data to a new file then renaming the new file to the old 
filename.  The Squeeze command also automatically re-adjusts the 
internal HEC-DSS table sizes to optimize access to data. 

To squeeze a DSS file, open the file and select Squeeze from the Utilities 
menu.  A window will appear indicating the status of the squeeze process, 
as shown by the example in Figure E.20.  When the process is complete, a 
confirmation will appear (Figure E.21) 
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Figure E.20  HEC-DssVue Squeeze Progress Window (Example) 

 
Figure E.21   HEC-DssVue Squeeze Confirmation Message (Example) 

E.15 Viewing DSS Status in HEC-DssVue 
The HEC-DSS File Manager Status window displays the number of 
HEC-DSS files you have accessed during the current session and, for each 
file, the name and location, whether the file is currently open, the first and 
last times you accessed the file, and the total number of accesses.  To view 
DSS Status, select DSS Status from the Utilities window.  The HEC-DSS 
File Manager Status window will open (Figure E.22). 

 
Figure E.22  HEC-DSS File Manager Status Window 

E.16 Deleting Records from a DSS File 
To Delete records from a DSS file: 

1. Select the record(s) either by double-clicking on it or by 
highlighting it then clicking the Select button. 

2. Choose Delete from the Edit menu. 
3. A confirmation message will appear asking you to verify the 

records to be deleted (Figure E.23) 
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4. If the list correctly identifies the record(s) to be deleted, select 
Yes, and a confirmation message will appear (Figure E.24) 
telling you the record(s) has been deleted.  Otherwise, select No, 
and the records will not be deleted. 

 

 
Figure E.23  Confirm List of Records to be Deleted 

 

 
Figure E.24  Confirmation Message that  
Records have been Deleted 

E.17 Undoing Most Recent Revisions 
There may be an occasion where you make a revision to your DSS file and 
then want to “undo” that revision.  An Undo option is available from the 
Edit menu to undo the LAST revision that you made to your DSS file.  For 
example, if you inadvertently delete a record, you can choose to “undo” 
that deletion, and the record will be restored. 

E.18 Printing Plots and Tables in HEC-DssVue 
You can print plots and tables by selecting Print from the File menu of 
the plot and table windows.  For more details on the printing capabilities, 
see Appendix F. 

If you wish to change the appearance or the layout of the plots or tables, 
there are a number of options available to you. 

In the plots, you can change the appearance of the lines by changing the 
line color and background color, and the font and style of the text labels.  
See Chapter 14, Section 14.5.2.2 for additional details for customizing 
plots.
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