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Chapter 4 
Working with Layers 

Layers in ResSim are like transparencies laid one on top of the other, with 
static physical images such as roads, county and state boundaries, rivers, 
subbasins, etc., layered in the display as color pictures.  Each of these 
images, along with its associated data, is a layer. 

4.1 Understanding Layers 
Layers are hierarchical.  Primary (top level) layers include the Time-
Series Icon Layer and the Study Layer (available only in the Watershed 
Setup Module), the Stream Alignment Layer, and Map Layers.  These 
primary layers can contain component layers.  For example, the Stream 
Alignment Layer contains the Stream Nodes, Stream Segments, and 
Stream Junctions.  The Study Layer contains layers for all Reservoirs and 
other Projects, Computation Points, and Impact Areas contained within the 
Study. 

4.1.1 Time-Series Icon Layer 
The Time-Series Icon Layer includes all of the time-series icons for 
your watershed, and it allows you to separate different types of data in 
your map display.  For example, a gage may report stage and 
precipitation (and compute flow from stage).  If you create time-series 
layers named “Stage,” “Flow,” and “Precipitation,” you can then 
place each data set in the appropriate layer. 

ResSim does not use Time-Series Icons for any program needs.  Refer 
to the CWMS User’s Manual (HEC, 2003a) for additional details 
about Time-Series Icons. 

4.1.2 Study Layer 
The Study Layer appears in the Watershed Setup Module only.  The 
Study layer is comprised of all of the projects, impact areas, and 
computation points contained in the watershed. 

The Layer Selector displays Study as a primary layer in the Layer 
tree.  When you click on the root handle for the Study branch, there is 
a layer for Computation Points, Diversions, Names (labels for the 
projects, computation points, and impact areas), Reservoirs, Channel 
Modifications, Levees, Off Channel Storage, Other Projects, and 
Impact Areas.  ResSim creates a layer for each of these items even 
before you have defined any projects, computation points, or impact 
areas. 
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4.1.3 Stream Alignment Layer 
The Stream Alignment Layer contains the Stream Alignment 
representing the river system in the watershed.  The Stream 
Alignment layer includes three component layers:  Stream Nodes, 
Streams Segments (also referred to as stream elements), and Stream 
Junctions.  This layer is available in all ResSim Modules but is only 
available for editing within the Watershed Setup Module. 

4.1.4 Map Layers 
ResSim can display various types of maps and elements in the geo-
referenced map display area.  These maps, displayed as map layers, 
are static physical images.  Examples of map layers include roads, 
county and state boundaries, rivers, subbasins, etc.  Some maps are 
static images, which display as color pictures in the display area.  
Map Layers are not interactive.  Instead, you interact with data 
associated with schematic elements you place in your map display. 

For a description of the map layer formats supported by ResSim, see 
“Importing Maps into ResSim” in Chapter 3, Section 3.4.1. 

4.2 Exploring the Layer Selector 
The Layer Selector is the main 
controller for the organization of 
the various layer types described 
above, including the Study 
Layer, Stream Alignment Layer,  
and Map Layers. 

To access the Layer Selector 
from any module, from the View 
menu, select Layers….   

The Layer Selector window, 
shown in Figure 4.1, opens as a 
separate frame that you can 
minimize to the Windows 
taskbar. 

 
 
 
 
 
 

 
Figure 4.1 Layer Selector 
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4.2.1 The Layer Selector Menus 
Menus in the Layer Selector offer a variety of tools to assist you in 
managing layers. 

The Layers menu (Figure 4.2) offers a 
Close command to close the Layer 
Selector. 

 

 

The Edit menu (Figure 4.3) provides 
tools for rearranging layers, viewing and 
editing layer properties, and adding and 
reloading default toolbar buttons for 
access to individual layers. 

To see all of the available commands in 
the Edit menu, you must first select a 
layer and activate Allow Layer Editing.  
When editing is enabled, a checkbox 
appears next to the menu item as shown 
in Figure 4.3. 

 

 

Figure 4.4 shows the Edit menu as it 
appears with Allow Layer Editing 
turned off and with no layer selected. 

Also note that the current position of an 
individual layer will determine which 
commands are available in the Edit 
menu.  When a layer is already at the 
top, the Move to Top and Move Up 
options will be unavailable.  Likewise, 
if a layer is at the bottom, the Move 
Down and Move to Bottom options 
will not be available. 

 

 
Figure 4.2 
Layers Menu - 
Layer Selector 

 
Figure 4.3  Edit Menu -  
Layer Selector 

 
Figure 4.4  Edit Menu - 
Allow Layer Editing 
Turned Off and No Layer 
Selected 
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The Maps menu (Figure 4.5) allows 
you to add and remove map layers.  
The Map Display Coordinates 
option opens the Geographic Region 
dialog box.  These processes are 
described in “Adding a New Map 
Layer” in Chapter 3, Section 3.4.2.  
You must select a map layer to access 
the Remove Map Layer command. 

 

The View menu (Figure 4.6) gives you 
control over display of the Layer Selector.  
The Expand option expands the “tree” of 
a layer to display its sub-layers (same 
functionality as clicking on the layer’s 
plus- sign box in the tree).  Once you have 
expanded a layer, Expand changes to 
Collapse to close the layer to show only 
the primary layer (same functionality as 
clicking on the minus-sign box in the tree).  Always on Top keeps the 
Layer Selector on top of your desktop so you can leave it open while 
you work, if desired. 

 

4.2.2 The Layer Selector “Tree” 
The Layer Selector uses a tree metaphor for controlling the display 
and organization of layers in the watershed.  The tree metaphor 
represents the hierarchical arrangement of layers in ResSim. 

The top level of the tree is the Layers folder, which contains all of the 
layers in the watershed. Beneath the Layers folder is a tree branch for 
each primary layer, beginning with a plus/minus box, followed by a 
checkbox, then the layer name.   

When you expand a layer (see “Controlling Layer Display” , Section 
4.2.3), its sub-layers display.  If no sub-layers exist, you will see a 
legend for the layer. 

In following sections you will learn how to interact with layers in the 
Layer Selector by using the Menu items, shortcut menus, plus/minus 
boxes, checkboxes, and properties editors. 

 
Figure 4.5  Maps Menu  - 
Layer Selector 

 
Figure 4.6  View Menu - 
Layer Selector 
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4.2.3 Controlling Layer Display 
Beside each Layer branch is a 
plus/minus box, or root 
handle, that serves the same 
function as the 
Expand/Collapse options in 
the View menu.  A plus means 
the layer can be expanded.  
You can click on a plus to 
expand a tree branch to 
display component layers; if 
no component layers exist, 
you will see a legend for the 
layer.  When the root handle is 
a minus, you can click on it to 
collapse the tree branch.  You 
can also expand and collapse 
layers by double-clicking them 
with your mouse.  Figure 4.7 
shows the Layer Selector with 
some of the layers expanded. 

The checkbox turns the 
display of the layer on or off 
(checked indicates the layer is 
active in the display area).  
When not checked, neither the 
primary layer nor the 
components beneath it will display.  When checked, the primary layer 
and all checked component layers will display; however, any 
unchecked component layers beneath it will not display. 

Figure 4.7  Layer Selector - Layers 
Expanded 
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4.2.4 Viewing Layer Legend 
When you click on the 
root handle of a layer 
with no components, the 
legend for the map 
displays. 

The type of legend 
displayed is determined 
by the various file 
formats.  Figure 4.8 
shows the legend for 
Reservoirs. 

 

 

 

 

 

 

 

 

 

4.3 Controlling Layer Organization 
The Layer Selector also controls how layers are arranged in the display 
area.  When you add map layers to the watershed (see “Adding a New 
Map Layer” in Chapter 3, Section 3.4.2), the map layer is added to the 
bottom of the list of maps in the Layer Selector.  You can use the Layer 
Selector to rearrange the order of the primary layers: 

1. Select the layer you would like to move. 
2. From the Edit menu, select Allow Layer Editing. 
3. From the Edit menu, select Move Up to move the layer towards 

the front of the map display, or click Move Down to move the 
layer to the back.   

4. To see your changes, click Apply (to keep the Layer Selector 
open) or click OK to close the Layer Selector. 

Continue to change the position of each layer until the necessary map 
features are visible in the display area. 

 
Figure 4.8  Layer Selector - Map Legend 
for Reservoirs 



ResSim User’s Manual Chapter 4 – Working with Layers 
 

4-7 

4.3.1 Configuring Toolbar Icons to Control Layers 
In the Layer Selector you can also add controls to the Toolbar of the 
main window.  Toolbar buttons provide a shortcut for turning layers 
on and off without having to open the Layer Selector.  Toggling on 
and off the toolbar button functions the same as the checkbox in the 
Layer Selector.  When the button is depressed, the layer is selected for 
display in the map panel.  When the button is up, the layer is turned 
off in the display.  This shortcut is useful when you might want to 
have frequent control over layers that are being displayed. 

Additionally, right-clicking on the toolbar button gives you access to 
various properties editors and allows you to select and deselect layers 
being displayed.  The options available from the shortcut menu 
depend upon the layer type. 

If you hover your mouse over a Toolbar Button, a Tool Tip appears 
with a description of the button. 

Adding toolbar buttons is an optional configuration step, and if you 
want to use toolbar buttons, you must configure them separately in 
each module.  Toolbar buttons are saved when you exit the watershed, 
so you will only have to set them up once. 

To add a toolbar button,  

1. In the Layer Selector, select a layer in the tree. 
2. From the Edit menu, select 

Add Toolbar Button.  The 
Toolbar Button Editor 
opens, as shown in Figure 
4.9. 

3. The name of the layer 
appears by default in the 
Tool Tip field, but you can 
specify a more descriptive 
Tool Tip if desired. 

4. From the Icon list, select an icon to represent the selected 
layer. 

5. Select OK when you are done. 

The toolbar button then appears in the toolbar above the Display 
Area. 

To remove a toolbar icon, select the layer in the Layer Selector, and 
then from the Edit menu, select Remove Toolbar Button.  To 
quickly remove all toolbar buttons that you have defined, select 
Reload Default Button from the Edit menu in the Layer Selector. 

Figure 4.9  Toolbar Button 
Editor 
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4.3.2 Adding Map Layers 
You will find it helpful to add maps to the watershed and the display 
area to provide a geographical reference for time-series icons, the 
stream alignment, and projects in your watershed. 

To add map layers: 

1. From the Edit menu of the Layer Selector, select Allow 
Layer Editing. 

2. From the Maps menu, select Add Map Layer…  This 
command opens a file browser to the default “maps” directory 
in the watershed directory hierarchy.  You must first copy any 
maps you wish to use in the watershed to the “maps” directory 
for your watershed. 

3. From the file browser, choose the map you wish to add. 
4. Click OK. 

The map name now appears in the Layer Selector as a new tree 
branch.  See “Adding a New Map Layer” in Chapter 3, Section 3.4.2 
for more information. 

4.3.3 Removing Map Layers 
To remove a layer from the map display, select the layer in the layer 
selector, and then select Remove Map Layer from the Maps menu. 
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4.3.4 Using Layer Selector Shortcut Menus 
Shortcut menus in the Layer 
Selector offer commonly used 
commands that are also 
available in the Layer 
Selector’s Edit and View 
menus.  Figure 4.10 shows the 
shortcut menu for the Stream 
Alignment layer in the Layer 
Selector. 

The Expand option expands 
the tree of a layer to display its 
component layers.  Collapse 
closes the layer to show only 
the primary layer. 

Move to Top, Move Up, 
Move Down, and Move to 
Bottom allow you to 
rearrange layers.  The current 
position of an individual layer 
will determine which Move 
buttons are available. 

Properties opens a Properties dialog box for the layer. 

 
Figure 4.10  Layer Selector Shortcut 
Menu for the Stream Alignment 
Layer 
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For map layers that you add 
(Figure 4.11), the Change 
Label command is also 
available.  The command 
allows you to change the 
name of the layer in the tree.  
Also, the Show Legend 
command expands the map 
layer tree to display the map 
legend.  The option changes 
to Hide Legend when the 
layer is expanded, allowing 
you to close the branch view 
of legends. 

Reminder:  you must first 
activate Allow Layer 
Editing (in the Edit menu) 
before you can access many 
of the shortcut menu 
commands. 

 

 

4.4 Viewing and Configuring Layer Properties 
The Layer Selector provides three ways to view and configure layer 
properties.  You can: 

� Select a layer in the Layer Selector and then choose Properties from 
the Edit menu. 

� Right-click on a layer in the Layer Selector and then select Properties 
from the shortcut menu. 

� Double click on a layer in the Layer Selector. 

Each of these techniques opens a Properties dialog box specific to the 
layer type; map layers also have additional dialog boxes for configuring 
properties.  For information about configuring the Time-Series Icon Layer, 
refer to the CWMS User’s Manual (HEC, 2003a). 

Figure 4.11  Layer Selector Shortcut 
Menu for a Map Layer 
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4.4.1 Study Layer Properties 
The Study Layer is available only in the Watershed Setup module.  
When you select Properties for the Study layer, the Drawing 
Properties Editor appears (Figure 4.12). 

The Drawing Properties Editor has six tabs that allow you to view and 
edit properties of Reservoirs, Levees, Diversions, Channel 
Modifications, Computation Points, and Impact Areas in your 
watershed. 

 

With the Reservoir tab selected (Figure 4.12), you can choose the Fill 
and Outline Color for the Triangle (which is the “visual” 
representation of the Reservoir) and the Fill and Outline Color and 
the Width of the Storage Reach (which represents the Reservoir 
reach along the stream alignment) of reservoirs in your watershed 
display.  Also, you can choose the Fill Color and Width of the Dam 
element.  When you select Draw Reservoir Triangle with a 
checkmark, the reservoir shape drawn in the Watershed Setup Module 
displays on the map; when it is not checked, the reservoir shape does 
not display.  Likewise, Draw Reservoir Name, when checked, 
displays the reservoir name on the map and hides the name when 
unchecked. The Font… button for the Reservoir Name allows you to 
choose the text font for the name of the reservoir in the map display. 

 

The Levees tab (Figure 4.13) allows you to edit the properties of 
levees in your watershed.  You can specify the Line Color and Levee 
Width.  Draw Levee Name, when checked, displays Levee names on 
the map and hides the names when unchecked.  The Font… button 
for the Levee Name allows you to choose the text font for the name 
of the levee in the map display. 

Figure 4.12  Drawing Properties Editor - Reservoir Tab 
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With the Diversions tab (Figure 4.14), you can select the Line Color 
and Width for the diversion.  You can also select the Fill Color for 
the Diversion Arrowhead.  The arrowhead colors can be different to 
indicate whether or not the diversion is Connected or Disconnected 
(e.g., Connected indicates that the diverted water remains in the 
system and Disconnected indicates that the diverted water is lost to 
the system).  Draw Diversion Name, when checked, displays the 
Diversion names in the display area and does not display when the 
name is unchecked.  The Name Font… button allows you to choose 
the text font for the name of the diversion in the watershed display 
area. 

Figure 4.13  Drawing Properties Editor - Levees Tab 

Figure 4.14  Drawing Properties Editor - Diversions Tab 



ResSim User’s Manual Chapter 4 – Working with Layers 
 

4-13 

The Channel Modification tab (Figure 4.15) allows you to select the 
Line Color and Width of the Channel Modifications.  Draw 
Channel Modification Name, when checked, displays the Channel 
Modification names in the display area and does not display when the 
name is unchecked.  The Name Font… button allows you to choose 
the text font for the names of Channel Modification points in the 
watershed display area. 

The Computation Point tab (Figure 4.16) allows you to select the 
Fill Color and Width of the Computation Points.  Draw 
Computation Point Name, when checked, displays the Computation 
Point names in the display area and does not display when the name is 
unchecked.  The Name Font… button allows you to choose the text 
font for the names of Computation Points in the watershed display 
area. 

Figure 4.15  Drawing Properties Editor - Channel Modification Tab 

Figure 4.16  Drawing Properties Editor - Computation Point Tab 
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The Impact Area tab (Figure 4.17) allows you to display or hide the 
Impact Area name for your watershed.  Draw Impact Area Name, 
when checked, displays Impact Area names on the map and hides the 
names when unchecked.  The Name Font… button allows you to 
choose the text font for the names of Impact Areas in the watershed 
display. 

 

4.4.2 Stream Alignment Layer Properties 
When you select Properties for the Stream Alignment layer, the 
Stream Alignment Properties Editor (Figure 4.18) appears. 

 
Figure 4.18  Stream Alignment Properties Editor 

Figure 4.17  Drawing Properties Editor - Impact Area Tab 
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The Stream Alignment Properties Editor allows you to specify 
Stream Width and Stream Color in your watershed display.  Show 
Stream Name, when checked, displays stream names on the map and 
hides the names when unchecked.  The first Choose Font button 
allows you to choose the text font for the names of streams in the map 
display. When Draw Station Tics is checked, station tics display on 
the map, and you are able to specify the Tic Length and Major Tic 
Length.  Draw Tic Labels, when checked, displays Tic labels on the 
map and hides the labels when unchecked.  The second Choose Font 
button allows you to specify the text font for the Tic Labels.  When 
Draw Station Tics is unchecked, Station Tics do not display on the 
map and the Tic Length, Major Tic Length, Draw Tic Labels, and 
Choose Font options are not available. 

The Stream Alignment Properties Editor’s preview pane allows you to 
view your changes before applying them. 

4.4.3 Map Layers Properties 
Map layers can be any of a number of formats supported by ResSim, 
including ArcView® Shapefiles, AutoCAD® DXF files, raster 
images, U.S Geological Survey (USGS) Digital Line Graphs (DLG) 
files, USGS Digital Elevation Model (DEM) files, ASCII NET TIN 
files, and ArcInfo® DEM files.  Hence, when you select Properties 
for a map layer, the editor that opens is specific to the type of map. 

For example, if the 
map layer you wish 
to configure is a 
USGS Digital Line 
Graph map layer, 
the Properties 
command opens the 
USGS Digital Line 
Graph Editor 
(Figure 4.19). 

 

 

With this Map Layers Properties Editor, you can specify the default 
Color of the map and choose whether or not Nodes, Lines, and Areas 
display in the watershed.  You can also set the Saturation and 
Brightness of the display.  The directory location of the map file in 
your ResSim watershed is shown at the top of the dialog box. 

Appendix C describes additional map layer editors available in 
ResSim. 

Figure 4.19  USGS Digital Line Graph Editor 
for Digital Line Graph (DLG) Map Layer 
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