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Chapter 8 
Developing a Reservoir Network 

A reservoir network represents a collection of watershed elements 
connected by routing reaches.  Elements created in the Watershed Setup 
Module belong to specific watershed configurations, and when you create 
a reservoir network, it references one of those configurations. 

The computation points defined for a configuration in the Watershed 
Setup Module automatically become junctions in the Reservoir Network 
Module.  Your primary task in developing a reservoir network is to 
connect the junctions with routing reaches between junctions. 

This chapter provides an overview of the Reservoir Network Module’s 
screen components and describes the processes for creating a new 
reservoir network, opening an existing reservoir network, making a 
network editable, and adding routing reaches.  ResSim also allows you to 
add additional elements to a reservoir network. 

After you have established your reservoir network connectivity, you will 
need to edit Junction, Reach, and Diversion data (see Chapter 9), define 
and edit the Physical components of Reservoirs in your network (see 
Chapter 10), define Reservoir Operations data (see Chapter 11), define 
Reservoir Systems (see Chapter 12), and define Alternatives (see Chapter 
13).  These steps will prepare your reservoir network to run Simulations 
(see Chapter 14). 
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8.1 Recognizing Reservoir Network Screen 
Components 

The Reservoir Network Module (Figure 8.1) provides the tools you will 
need to develop the connectivity of your reservoir network as well as enter 
and edit physical and operations data.  What follows is a discussion of the 
components and features of the Reservoir Network Module. 

Figure 8.1  Reservoir Network Module Main Window 
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8.1.1 Menu Bar 
The following is an overview of the Reservoir Network Module’s 
Menu Bar tools, which allow you to create and edit the connectivity 
of your reservoir network.  The tools specific to this module will be 
described in more detail in the context of particular tasks later in this 
chapter. 

The File menu (Figure 8.2) allows you to 
Open an existing watershed, Save a 
watershed, Save the Display Area (Map), 
and Exit ResSim. Your most-recently-
used watersheds are listed at the bottom 
of the File menu.  

 

 

 

 

 

The Edit menu (Figure 8.3) provides 
access to the ResSim editors for 
Reservoirs, Reaches, Junctions, 
Diversions, and Reservoir Systems.  
You must select the Allow Network 
Editing command to access the editors. 

 

 

 

In the View menu (Figure 8.4) select 
Zoom to All to restore your watershed 
map view to full size.  Layers opens the 
Layer Selector dialog box.  Unit System 
allows you to customize the display 
(view) settings for your watershed.  If a 
dialog or editor window is open but 
inactive, Restore Windows brings the 
dialog or editor window to the front as the 
active window. 

 

 

Figure 8.2  File Menu 

 
Figure 8.3  Edit Menu  

 
Figure 8.4  View Menu 
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The Network menu (Figure 8.5) 
is unique to the Reservoir 
Network Module.  It allows you to 
create a New network, Open an 
existing network, Save a network 
or Save As a new network, or 
Rename a network.  You can also 
Update Network from 
Configuration and Delete 
Networks. 

The Alternative menu (Figure 
8.6), also available in the Simulation 
Module, provides access to the Alternative 
Editor. 

 

The Reports menu (Figure 8.7) provides 
access to the Reservoir List, Reach List, 
Junction List, and Diversion List.  Also, 
two Advanced reports are available:  the 
Network Summary and the Node List 
reports. 

 

 

As in the other modules, the Tools menu 
(Figure 8.8) provides access to Hec-DssVue 
and to Scripts.  Options allows you specify 
Model Directories, Cache Directory, 
Compute Display, Debug Levels, General 
information (including whether to show a 
confirmation when exiting the program and 
whether to reload last watershed at startup of 
program), and Fonts.  Information provides 
details about client, user, and watershed 
settings as well as server and system 
properties. 

The Help menu (Figure 8.9) displays 
information about the current version of 
ResSim.  About indicates the version, 
revision and build numbers. 

Figure 8.5  Network Menu 

 
Figure 8.6  Alternative 
Menu  

 
Figure 8.7  Reports 
Menu  

 
Figure 8.8  Tools 
Menu 

 
Figure 8.9  Help Menu 
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8.1.2 Network, Configuration, and Lock/Unlock 
In the Reservoir Network Module, your current Reservoir Network 
and Configuration, along with the Lock/Unlock icon , are 
displayed below the Menu Bar and to the right of the Module List, as 
shown in Figure 8.10. 

Figure 8.10  Network, Configuration, and Lock/Unlock 

The Configuration indicates which configuration the current 
Network is based on.  As will be described in Section 8.2, you select 
the Configuration when you setup the Network (using the Network 
menu). 

The Lock/Unlock icon indicates whether or not the Network is 
locked and available for editing.  You can lock and unlock the 
Network by clicking on the icon or by selecting or deselecting Allow 
Editing in the Edit menu. 

8.1.3 Map (Mouse) Tools 
The Map (Mouse) Tools, which appear in the toolbar on the left side 
of the ResSim screen, allow you to interact with objects in the map 
display.  The Reservoir Network Module has three standard Map 
Tools and five network connectivity tools that allow you to establish 
the connectivity of your reservoir network. 

 Pointer Tool 
Right-click with the Pointer Tool to select and access a shortcut menu 
for any schematic element within your map display.  The Pointer Tool 
is available in all ResSim modules. 

 Zoom Tool 
The Zoom Tool allows you to zoom in and out of the display area in 
all modules.  To zoom in, hold the left mouse button down and outline 
the area you want to enlarge.  To zoom out, click the right mouse 
button.  Zooming out using the right click button zooms out by a 
factor of two, positioning the clicked location at the center of the 
screen.  The Zoom Tool is available in all ResSim modules. 

 Pan Tool 
After you have zoomed in with the Zoom Tool, you can use the Pan 
Tool to view watershed areas that fall outside of the ResSim window 
borders.  The Pan Tool is available in all ResSim modules. 
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 Reservoir Tool 
With the Reservoir Tool, you can add reservoirs to your reservoir 
network.  You can also edit reservoir properties, rename, and delete 
reservoirs using commands in the shortcut menu. 

 Diverted Outlet Tool 
The Diverted Outlet Tool allows you to create a diverted outlet from a 
reservoir in your network.  The shortcut menu for this tool provides 
access to the Reservoir Editor and also allows you to rename and 
delete a diverted outlet. 

 Reach Tool 
Use the Reach Tool to draw routing reaches (from upstream to 
downstream) to connect the junctions on the stream alignment.  You 
can also edit reach properties, rename, break, and delete reaches using 
commands in the shortcut menu. 

 Junction Tool 
The Junction Tool allows you to manually insert junctions in your 
reservoir network.  The shortcut menu for this tool allows you to edit 
junction properties, rename and delete junctions. 

 Diversion Tool 
With the Diversion Tool you can add diversions to your reservoir 
network.  You can also edit diversion properties, rename, delete, and 
disconnect outflow of diversion reaches using commands in the 
shortcut menu. 

8.1.4 Display Area 
In the Reservoir Network Module, the display area contains the 
reservoir network connectivity you construct, along with the map 
layers, stream alignment, reservoirs and computation points you have 
established in the Watershed Setup Module for the current network’s 
configuration.  Any other time-series icons, projects, and impact areas 
you established in the Watershed Setup Module will not appear. 

Using the Map (Mouse) Tools to access shortcut menus, you can open 
data editors as well as rename and delete elements in your reservoir 
network directly from the display area. 
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8.2 Defining a Reservoir Network 
With a stream alignment in place and one or more configurations defined, 
you can create a network of reservoirs and routing reaches.  This process 
involves defining a new network and then adding routing reaches. 

8.2.1 Creating a New Reservoir Network 
When you create a new reservoir network, you are defining which 
elements will be included in your network by selecting the 
appropriate watershed configuration.  Once you have created your 
network, you can add additional elements.  Remember, however, that 
any additional elements you add will not be available for use in other 
networks.  If you want the additional elements to be available for 
other networks, you will need to go back to the Watershed Setup 
Module and add the new elements to the appropriate configuration, 
then return to the Reservoir Network Module to create your reservoir 
network using the updated configuration (see Section 8.6, “Updating a 
Reservoir Network”). 

To create a new reservoir network: 

1. From the Network menu, select New.  The Create New 
Reservoir Network dialog box will appear (Figure 8.11). 

 
Figure 8.11  Create New Reservoir Network Dialog Box 

2. Specify a Name for the network and enter a Description.  You 
can click the  button to access a larger text field for your 
description. 

3. From the Configuration list, choose the configuration on 
which this network will be based. 

4. Click New. 
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The Create New Reservoir Network dialog box will close, and you 
will see the name of your new network and its configuration displayed 
below the Menu Bar, to the right of the Module List (see Section 8.1.2 
above). 

In the display area, ResSim will automatically create the reservoirs 
and computation points that were part of the selected configuration as 
elements in the new Reservoir Network.  Reservoirs transfer directly, 
whereas computation points appear as Junctions. 

8.2.2 Opening an Existing Reservoir Network 
To open an existing Reservoir Network for editing: 

1. From the Network menu, select Open.  The Open Reservoir 
Network dialog box will appear (Figure 8.12). 

2. Select the Reservoir Network you want by clicking on it. 
3. Click Open. 

The Open Reservoir Network dialog box will close, and you will see 
the name of your network and its configuration displayed below the 
Menu Bar, to the right of the Module List (see Section 8.1.2 above). 

8.3 Making the Network Editable 
Before you can begin editing your reservoir network, you must ensure that 
the network is editable (“locked”).  To do so, select Allow Network 

Editing from the Edit menu or click the Lock/Unlock button . 

 
Figure 8.12  Open Reservoir Network Dialog Box 
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8.4 Adding Routing Reaches 
Routing reaches are elements that establish the connectivity of the 
reservoir network schematic.  By adding a routing reach between two 
junctions, you can connect the reservoir network so that water will 
transverse through the routing reach from upstream to downstream. 

8.4.1 Drawing Routing Reaches 
Routing Reaches are drawn from upstream to downstream.  You 
connect two adjacent junctions (typically, computation points added 
to the network’s Configuration in the Watershed Setup Module) by 
drawing a routing reach. 

To draw routing reaches: 

1. Select the Reach Tool . 
2. Point to the upstream junction at the upstream end of the reach. 
3. Hold down the CTRL key and click on the junction to start the 

upstream end of the reach. 
4. Release the CTRL key and move the mouse pointer along the 

stream alignment and click on the downstream junction. 

Routing reaches automatically conform to the stream alignment.  You 
can connect routing reaches to existing junctions; otherwise, if you 
begin and/or end a reach elsewhere on the stream alignment, ResSim 
will create new junctions at both/either end of the reach. 

ResSim will automatically constrain a new reach between existing 
junctions (e.g., will not allow a reach to be drawn past an existing 
junction).  If the reach appears to draw past a junction, then the 
junction is not on the stream you think it’s on.  This can occur if the 
computation point (that the junction is based on) is not initially placed 
on the appropriate stream.  To solve this situation, go back to the 
Watershed Setup Module and revise the location of the computation 
point (you may need to delete and recreate the computation point to 
be on the appropriate stream).  After saving your watershed 
configuration, change to the Reservoir Network Module and select 
Update Network from Configuration from the Network menu.  See 
Section 8.6, “Updating a Reservoir Network”, for additional 
information for updating networks. 

Additionally, you may not connect tributaries to the middle of a 
reach; tributaries must connect to a junction. 
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8.4.2 Renaming Routing Reaches 
ResSim automatically names routing reaches according to the names 
of the upstream and downstream junctions.  To rename a reach 
component: 

1. Select the Reach Tool . 
2. Right-click on the routing reach to be renamed. 
3. Select Rename 

from the shortcut 
menu.  The 
Rename Reach 
dialog box will 
appear (Figure 
8.13), allowing 
you to type in a 
new name. 

4. Type in the new 
name and optional 
description. 

5. Click OK to close the Rename Reach dialog box. 

The new name will now appear as a label in the map display. 

8.4.3 Deleting Routing Reaches 
To delete routing reaches: 

1. Select the Reach Tool . 
2. Right-click on the routing reach to be deleted. 
3. Select Delete from 

the shortcut menu.  
A Confirm Delete 
dialog box will 
appear (Figure 8.14). 

4. Click Yes if you are 
sure about the 
deletion. 

 

The routing reach will no longer appear in the map display. 

Figure 8.13  Rename Reach Dialog Box 

 
Figure 8.14  Confirm Delete Reach 
Dialog Box 
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8.5 Viewing Network Reports 
In the Reservoir Network Module, the Reports menu allows you to access 
summary reports pertinent to the elements in your network.  These reports 
summarize your reservoirs, routing reaches, junctions, and diversions.  In 
addition, advanced reports of your network connectivity are also available. 

8.5.1 Viewing the Reservoir List 
The Reservoir List (Figure 8.15) displays the names and descriptions 
of all reservoirs in your network.  For information about printing and 
exporting options available from the report’s Report menu, see 
Appendix F. 

 
Figure 8.15  Reservoir Network Reports: Reservoir List 

8.5.2 Viewing the Reach List 
The Reach List (Figure 8.16) displays the names and descriptions of 
all reaches in your network.  For information about printing and 
exporting options available from the report’s Report menu, see 
Appendix F. 

 

 
Figure 8.16  Reservoir Network Reports: Reach List 
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8.5.3 Viewing the Junction List 
The Junction List (Figure 8.17) displays the names and descriptions 
of all junctions in your network.  For information about printing and 
exporting options available from the report’s Report menu, see 
Appendix F. 

 
Figure 8.17  Reservoir Network Reports: Junction List 

8.5.4 Viewing the Diversion List 
The Diversion List (Figure 8.18) displays the names and descriptions 
of all diversions in your network.  For information about printing and 
exporting options available from the report’s Report menu, see 
Appendix F. 

 
Figure 8.18  Reservoir Network Reports: Diversion List 



ResSim User’s Manual Chapter 8 – Developing a Reservoir Network 
 

8-13 

8.5.5 Viewing Advanced Reports 
Two advanced reports are available from the Reports menu.  The first 
report is the Network Summary (Figure 8.19).  This report provides 
a connectivity summary of all of the elements/nodes in your reservoir 
network.  Details include the Element ID, Name, Function/Upstream 
Element, and Parent/Downstream Element. 

For information about printing and exporting options available from 
the report’s Report menu, see Appendix F. 

 
Figure 8.19  Reservoir Network Reports: Advanced -- Network 
Summary 

 

The second advanced report is the Node List (Figure 8.20).  This 
report provides a summary of all nodes in your reservoir network.  
Details include the Node ID, Name, Key String, Upstream Element 
and Downstream Element. 
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Figure 8.20  Reservoir Network Reports: Advanced -- Node List 

 

For information about printing and exporting options available from 
the report’s Report menu, see Appendix F. 

8.6 Updating a Reservoir Network 
In the Watershed Setup Module, if you make changes (e.g., add, delete, or 
move elements) to the watershed configuration your network is based on, 
you need to update your Reservoir Network to include those changes.  
First, in the Watershed Setup module, from the Watershed menu, select 
Save Configuration (see Figure 8.21). 

 
Figure 8.21  Watershed Setup Module, 
Watershed Menu, Save Configuration  
before Updating Network 
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Next, in the Reservoir Network module, with the network to be updated 
shown in the display area, select Update Network from Configuration 
from the Network menu (see Figure 8.22). 

 
Figure 8.22  Reservoir Network Module, Network Menu, 
Update Network from Configuration 

After the network has been updated, you should see the revisions in the 
display area. 

 You will need to update each Reservoir Network that is based on 
the revised watershed Configuration. 
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