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Chapter 14 
14 Running Simulations 

When you have entered all required data and have created Alternatives, 
you are ready to perform a Simulation.  A Simulation is where you specify 
the time window and time interval parameters for either a single 
Alternative or a group of Alternatives.  After a successful Simulation, you 
can analyze the results, make revisions, and perform additional 
Simulations to better evaluate the reservoir operations in your watershed. 

14.1 Recognizing Simulation Screen Components 
The Simulation Module (Figure 14.1) provides the tools you will need to 
create and run Simulations.  The following is a discussion of the 
components and features of the Simulation Module. 

 

Menu Bar

Module List

Pointer Tool
Zoom Tool

Pan Tool

Display Area

Status Bar

General
Message Bar

Title Bar Simulation Control Panel 

Figure 14.1  Simulation Module Main Window 
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The Title Bar displays the name of the window or dialog box currently 
open in ResSim.  The name of opened watershed displays next to HEC-
ResSim. 

The Simulation Control Panel provides Module-dependent controls that 
execute commands and/or display important dialog boxes.  For more 
detail, see Section 14.1.3. 

The Menu Bar contains menus of commands that you can use in ResSim.  
The items on the menus change as you switch between the various 
Modules, offering Module-specific commands.  You can select a menu bar 
item by clicking on the name of the menu (such as File), then pointing and 
clicking on the item you wish to select.  The Menu Bar is described in 
more detail below. 

The Module List contains all the available Modules of ResSim.  Use this 
list to move between the Watershed Setup, Reservoir Network, and 
Simulation Modules.  By default, the Module List opens to the Module 
most recently used. 

14.1.1 Menu Bar 
The following is an overview of the Simulation Module’s Menu Bar 
tools, which allow you to create and edit Simulations. The tools 
specific to this module will be described in more detail in the context 
of particular tasks later in this chapter. 

The File menu (Figure 14.2) allows 
you to Open an existing watershed, 
Save a watershed, Save Map (saves 
the display area) and Exit ResSim.  
Your most-recently-used watersheds 
are listed at the bottom of the File 
menu. 

 

The Edit menu (Figure 14.3) 
provides access to the Script List, allows 
you to Set the Active Alternative, and 
allows access to editors for Reservoirs, 
Reaches, Junctions, Diversions, and 
Reservoir Systems.  Note that any 
revision you make to these elements 
applies only to the active Alternative.  If 
you want the revisions to apply to 
subsequent Simulations, you must save 
the changes to your base directory (see 
Section 14.7.1). 

Figure 14.2  File Menu 

 
Figure 14.3  Edit Menu 
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In the View menu (Figure 14.4) select Zoom 
to All to restore your watershed map view to 
full size.  Layers... opens the Layers Selector 
dialog box.  Unit System allows you to 
customize the display (view) settings for your 
watershed.  If a dialog or editor window is 
open but inactive, Restore Windows brings 
the dialog or editor window to the front as the 
active window. 

 

The Simulation menu (Figure 14.5) is 
unique to the Simulation Module.  It allows 
you to create a New Simulation, and Open, 
Re-Open, Close, Save, or Delete an 
existing Simulation.  The Edit command 
opens the Simulation Period dialog box, 
while Info allows you to view the name, 
directory path, and user information for the 
current Simulation.  You can also access 
Release Overrides for a Simulation. 

 

 

 

 

The Alternative menu (Figure 14.6), also 
available in the Reservoir Network Module, 
provides access to the Alternative Editor. 

 

The Reports menu (Figure 14.7) provides 
access to the Reservoir Summary, Flow 
Summary, Power Summary, Gates 
Summary, Stage Summary, and Release 
Decision reports, as well as Compute 
logs.  You can also access Network 
reports, including the Reservoir List, 
Reach List, Junction List, Diversion List, 
and the Network Connectivity Summary 
report. 

 

 

Figure 14.4 
View Menu 

Figure 14.5 
Simulation Menu 

 
Figure 14.6 
Alternative Menu 

Figure 14.7 
Reports Menu 



Chapter 14 – Running Simulations ResSim User’s Manual 
 

14-4 

As in the other Modules, the Tools menu 
(Figure 14.8) provides access to Hec-DssVue 
and Scripts.  Options lets you specify 
watershed locations for storing your 
watersheds; specify a directory for caching 
map files; set the colors for compute messages 
and the format of log files; set the level of 
debug messages; choose whether or not you 
want a confirmation message to appear when 
you exit ResSim; and choose whether you 
want the last watershed reloaded at startup of the program.  
Information provides details about client, user, and watershed 
settings as well as server and system properties. 

The Help menu (Figure 14.9) displays 
information about the current version of 
ResSim.  About specifies the version, revision 
and build numbers. 

 

 

14.1.2 Map (Mouse) Tools 
The Map (Mouse) Tools, which appear in a toolbar on the left side of 
the ResSim screen, allow you to interact with objects in the map 
display.  The Simulation Module has three Map Tools and all are 
available in the other ResSim Modules: 

Pointer Tool  
In the Simulation Module, right-click model schematic 
elements in the map display with the Pointer Tool to access 
editors, default and user-defined plots, and release decision 
reports (for reservoirs). 

Zoom Tool 
The Zoom Tool allows you to zoom in and out of the display 
area in all Modules.  To zoom in, hold the left mouse button 
down and outline the area you want to enlarge.  To zoom out, 
click the right mouse button.  Zooming out using the right-click 
button zooms out by a factor of two, positioning the clicked 
location at the center of the screen. 

Pan Tool 
After you have zoomed in with the Zoom Tool, you can use the 
Pan Tool to view watershed areas that fall outside of the 
ResSim window borders. 

 
Figure 14.8 
Tools Menu 

 
Figure 14.9 
Help Menu 
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14.1.3 Simulation Control Panel 
The Simulation Control Panel (Figure 
14.10) displays details about the current 
Simulation and allows you to interact 
with Alternatives. 

Displayed at the top of the panel are the 
Simulation time, Lookback time, and 
End time. 

Below these details is the Simulation 
Tree, which displays the name of the 
current Simulation and its associated 
Alternatives.  The currently active 
Alternative displays as bold, and a 
check mark in the box beside an 
Alternative indicates that it will be 
included in reports.  Right-click on a 
Simulation or Alternative to access their 
shortcut menus. 

When you select an Alternative, the 
Compute button becomes available, 
allowing you to execute a Simulation. 

At the bottom of the Simulation Control 
Panel, the Scripts area displays buttons 
that launch user-created scripts. 

14.1.4 Display Area 
The Display Area displays model schematic objects and map layers 
representing the Active Alternative. 

Model elements of a Reservoir Network will not appear in the display 
area until you have created or opened a Simulation and activated an 
Alternative (see Section 14.4.1). 

Figure 14.10  Simulation 
Control Panel 
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14.2 Creating a Simulation 
Once you have created a reservoir network, entered element data, and 
developed alternatives in the Reservoir Network Module, you can 
configure the model for a Simulation in the Simulation Model. 

To create a new Simulation: 

1. From the Simulation menu, 
select New.  Or, in the 
Simulation Control Panel, 
right-click on the currently-
active Simulation or No 
Simulation folder to access the 
shortcut menu (Figure 14.11).  
Select New. 

2. The Simulation Period dialog 
box will open (Figure 14.12). 

Figure 14.12  Simulation Period Dialog Box 

3. The Name field contains a default name for the Simulation 
based on the current date and time.  You may either accept the 
default or enter a name that is more meaningful to you. 

Figure 14.11  Simulation 
Control Panel Shortcut 
Menu:  New Simulation 
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4. Enter a Start Date and Time specifying when you want the 
Simulation to begin.  It must occur after the Lookback Date. 

5. Enter a Lookback Date and Time.  The Lookback is the 
“warm-up” period before the Simulation begins. 

6. Enter an End Date and Time specifying when you want the 
Simulation to conclude. 

7. Choose a Time Step from the list.  The Time Step is the 
computation interval and can be 15 Minutes, 30 Minutes, 1 
Hour, 3 Hours, 6 Hours, 12 Hours, or 1 Day. 

8. The Alternatives table includes all of the Alternatives you 
have defined in the Reservoir Network Module.  Select one or 
more applicable Alternatives for the Simulation by checking 
the boxes beside them in the Select column.  Ensure the 
Alternatives you select include time-series data for the entire 
Simulation period. 

9. Click OK to close 
the Simulation 
Period dialog box.  
The Creating 
Simulation 
window (Figure 
14.13) will inform 
you of the status as ResSim creates the Simulation you have 
defined. 

The Simulation you have created will now appear in the Simulation 
Control Panel. 

 The Reservoir Network will not appear in the map region until 
you have set an Alternative to Active (see Section 14.4.1). 

 

14.3 Working with Existing Simulations 
If you have previously created a ResSim Simulation, you may want to 
make revisions to the Lookback date and time or End date and time (the 
Start date and time cannot be changed), or you may want to revise data in 
an Alternative (operation rules, reservoir operation zones, etc.).  To 
accomplish this, you will open an existing Simulation. 

 
Figure 14.13  Creating Simulation Window 
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14.3.1 Opening an Existing Simulation 
To open an existing Simulation: 

1. From the Simulation menu, 
select Open.  Or, in the Control 
Panel, right-click on the 
currently-active Simulation or 
No Simulation folder to access 
the shortcut menu (Figure 14.14).  
Select Open. 

2. The Open Simulation dialog 
box will open (Figure 14.15). 

Figure 14.15  Open Simulation Dialog Box 

3. Click on the Simulation you want and select Open. 

 

The time period details of your 
selected Simulation will now appear 
in the Simulation Tree (Figure 
14.16), and the map display will 
now update to show the model 
schematic for the active Alternative 
(see Section 14.4.1 for information 
about setting the alternative to 
active). 

Figure 14.14  Simulation 
Control Panel Shortcut 
Menu:  Open Simulation 

Figure 14.16  Simulation Tree 
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14.3.2 Editing a Simulation 
Once you have created a Simulation, you can use the Simulation 
Period dialog box (Figure 14.12) to edit the Lookback Date and 
Time, the End Date and Time, Time Step, and selected Alternatives.  
You cannot change the Start Date or Time. 

You can access the Simulation Period dialog box two ways: 

� Select Edit from the Simulation menu. 

� Right-click on the Simulation folder at the top of the simulation 
tree in the Simulation Control Panel, then select Edit from the 
shortcut menu. 

14.4 Computing a Simulation 
After you have created a new simulation or have opened an existing 
simulation, you are ready to make one of the alternatives active (if not 
already active) and have ResSim perform the computations. 

14.4.1 Setting the Active Alternative 
Once you have opened a Simulation, the simulation tree will show all 
of the selected Alternatives for the Simulation you have chosen. 

Model elements of a reservoir network will not appear in the display 
area until you set an Alternative to Active.  During the Alternative 
activation process, ResSim makes a copy of the active alternative 
available for the simulation. 

To set the Active Alternative: 

1. Right-click on the 
Alternative you want in 
the simulation tree. 

2. Select Set as Active from 
the shortcut menu (Figure 
14.17). 

The map display will now 
update to show the model 
schematic for the Alternative 
you have set as Active. 

 

 

 

Figure 14.17  Simulation Control 
Panel Shortcut Menu:  Set 
Alternative As Active 



Chapter 14 – Running Simulations ResSim User’s Manual 
 

14-10 

14.4.2 Computing the Simulation 
After inputting all data and parameters as desired, you can compute a 
Simulation. 

In the Simulation Control Panel of the main window of the Simulation 
Module, the simulation tree displays the current Simulation as a 
folder, beneath which is a list of the Alternatives associated with the 
Simulation.  Also shown in the Simulation Control Panel is the time 
information associated with the Simulation. 

To execute a Simulation, you must first set an Alternative as Active.  
Right-click on an Alternative in the Simulation Control Panel and, 
from the shortcut menu, select Set as Active (Figure 14.17). 

The name of the active Alternative appears in bold in the simulation 
tree and the Compute button becomes available.  Also, the model 
schematic for the active 
Alternative will appear in the 
display area. 

To compute a Simulation, either 
click the Compute button in the 
Simulation Control Panel or, in 
the simulation tree, right-click 
on the Alternative and select 
Compute from the shortcut 
menu (Figure 14.18). 

 

 

When you compute a Simulation, a Compute window opens, as 
shown in Figure 14.19.  The Compute window provides Message 
Output that contains information regarding the status of each step of 
the computation process.  The Progress Bar indicates the percentage 
of completion for each step.  When the computation is finished, the 
Progress Bar is completely filled in and reads “100%” along with the 
message “Compute Complete” in the Message Bar of the Compute 
window. 

If there are errors or any problems during the execution process, you 
can review the Message Output Text area of the compute window.  
Also the Compute Log can provide information regarding the type of 
problem that exists (see Section 14.5.1). 

Click Close to close the Compute window. 

Figure 14.18  Simulation Control 
Panel Shortcut Menu:  Compute 
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14.5 Reviewing Simulation Results 
After computing a Simulation, you can review results in many different 
forms.  Compute Messages provide information about each step of the 
computation process.  Plots and Tables in the Simulation Module offer 
detailed views of data and model results.  Reports provide details about 
individual components of the Reservoir Network.  These options for 
viewing your results are described in the following sections. 

14.5.1 Viewing Compute Logs 
If there are errors or any problems during the computation process, 
the Compute Log (Figure 14.20) can provide information regarding 
the type of problem that exists.  To view Compute Logs, select 
Compute from the Reports menu, then select the appropriate 
Alternative. 

Message Output
Text

Message Bar 

Progress Bar 

Figure 14.19  Compute Window 
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Figure 14.20  Compute Log 

You can use the Find and Find Next commands in the Search menu 
to locate specific issues in a log. 

You can customize the appearance of the Compute Log with the 
Colors and Font commands in the Format menu. 

The Colors command allows changes to the Foreground and 
Background colors.  Selecting either one opens the Select Color 
dialog box.  See Appendix D for instructions on how to use the Color 
Chooser tools. 

 

The Font command opens the Select 
Font dialog box (Figure 14.21), which 
allows you to choose the font Type 
and Size.  Also, you can choose 
whether or not to set the appearance to 
Bold and/or Italic characters. 

 

 

 

 

 

 

 

 
Figure 14.21  Select Font 
Dialog Box 
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14.5.2 Using Plots and Tables 
Plots and tables in the Simulation Module offer detailed views of data 
and model results. 

You can access plots using shortcut menus in the Simulation 
Module’s display area. 

To access a Plot from the 
display area, right-click on a 
model element in the map 
display.  The shortcut menu will 
provide a list of one or more 
plot options, as illustrated in 
Figure 14.22. 

Once you have opened a plot, 
you can also tabulate values by 
selecting Tabulate from the 
plot’s File menu. 

 

14.5.2.1 Features of Plots 
ResSim plots offer a variety of information that will assist you 
with reviewing the results of a Simulation.  Included in the 
information available from the default plots are reservoir elevation, 
storage, and release values as well as regulated and unregulated 
(without reservoirs and other projects) flow values.  Figure 14.23 
shows a sample plot illustrating reservoir results from a 
Simulation. 

 
Figure 14.23  Sample Plot of Reservoir Results 

Figure 14.22  Reservoir Shortcut 
Menu -- Plot Simulation Results 
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The plot window displays the location name in the title bar.  Axis 
labels and a color-coded legend identify the data contained in the 
plot. 

When a plot depicts the results of an Alternative, as in Figure 
14.23, a dashed vertical line represents the start time of the 
Simulation.  The Lookback (historic/observed) period occurs prior 
to the start time. 

The Zoom Tool  allows you to view data closely at a specific 
time.  To zoom in, hold the left mouse button down and outline the 
area you want to enlarge.  To zoom out, click the right mouse 
button.  To resize a plot, use the mouse to drag the edges of the 
window.  It is possible to zoom in on one section of the entire plot 
(both the x and y variables simultaneously) or a range for either 
variable.  To zoom in on a section of the plot, outline that area on 
the plot.  To zoom in on a range (for either x or y variable), outline 
the desired range on the respective axis. 

14.5.2.2 Customizing Plots 
You can customize the appearance of plots by using several 
properties editors that you can access from shortcut menus: 

Line Properties:  Right-clicking on a plot line or point will allow 
you to open a Curve Properties Editor to edit line colors, styles, 
and weights, as well as labels and quality symbols. 

Background Properties:  Right-clicking on the background of a 
plot will allow you to open a View Port Editor where you can 
customize the border, background, and gridlines of the plot. 

Axis Properties:  Right-clicking on a plot axis will allow you to 
open an Axis Properties Editor where you can customize the axis 
scale and tic marks. 

Label Properties:  Right-clicking on an axis label or plot legend 
will allow you to open a Label Properties Editor where you can 
add backgrounds and borders to the labels. 
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14.5.2.3 Creating User-Defined Plots 
Since everyone has their own preferences regarding which 
variables to include in the shortcut menu location plot selections, 
the User Defined Plot capability 
offers flexibility. 

To create a User Defined Plot: 

1. Right-click on the element 
where you want the plot to 
appear, and select Plot from 
the shortcut menu (Figure 
14.24).  The default plot for 
that location will appear. 

2. Select Select Variables from 
the Plot Menu.  The Select 
Plot Variables dialog box will appear (Figure 14.25). 

Figure 14.25  Select Plot Variables Dialog Box 

The Available Variables list shows the variables you can choose 
for your User Defined Plot.  The Selected list shows variables you 
have selected. 

To add variables to your User Defined Plot: 

1. Click on the variable in the Available Variables list, then 
click on the appropriate Plot Region or component in the 
Selected list.  This allows you to specify where you want 
variables to appear in your plot. 

 
Figure 14.24  Shortcut Menu 
for an Element 
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2. Click the Add button to add the variable you have chosen to 
the Selected list.  If the added variable reflects different units, 
a separate Y-axis will be automatically added. 

To remove a variable, click on its name in the Selected list then 
click the Remove button. 

You can also Move a Plot Region up or down or Remove it by 
right-clicking on the plot region name and choosing the action 
desired from the shortcut menu, as illustrated in Figure 14.26. 

Figure 14.26  Select Plot Variables:  Region Shortcut Menu 

3. Click the OK button.  The Select Plot Variables dialog box 
will close and your User Defined Plot will open. 

 

To save your User Defined Plot: 

1. From the Plot menu on the 
plot that appears, select 
Save Plot Type... The 
Save Plot Type dialog 
box will appear (Figure 
14.27).  You can specify 
whether you want this 
User Defined Plot to be 
available to All 
Applications or to just 
This Watershed only.  
Enter a Name for the plot. 

 Figure 14.27  Save Plot Type . . . 
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2. Click the Save button.  The Save Plot Type... dialog box will 
close. 

 

The new User 
Defined Plot will 
now be available 
when you select 
User Plots from 
the right-click 
shortcut menu in 
the Display Area 
(Figure 14.28). 

 
 

14.5.2.4 Viewing Data in Tabular Form 
You can view plotted data in tabular form by selecting Tabulate 
from the File menu of the plot.  Figure 14.29 shows an example. 

Figure 14.29  Data in Tabular Form 

The View menu of the Tabular Data window offers four display 
options.  The View Commas option displays commas in numbers 
greater than one thousand.  The Date and Time Separately option 
splits the date and time into two separate columns.  The Date with 
4 Digit Years option displays the year with four digits instead of 
the default two.  Lastly, you can set the decimal precision for data 
using the Show Decimal Places option. 

You can also resize table columns by dragging their borders to the 
desired position with your mouse. 

Figure 14.28  Shortcut Menu:  User Plots 
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14.5.2.5 Printing and Exporting Plots and Tables 
You can print ResSim plots and tables, copy and paste them into 
other applications, and specify export options for plots.  See 
Appendix F for details. 

14.5.3 Viewing Summary Reports 
Summary Reports are available from the Reports menu.  In all 
Summary Reports, the Simulation name and Alternative appear at the 
top of the window, along with the Lookback date and time, the Start 
date and time, and the End date and time. 

Summary Reports also have two menus.  The File menu allows you to 
Print and Close the report (see Appendix F for information about 
printing).  The Options menu lets you Specify the Time to review the 
simulation results for a single time period. 

14.5.3.1 Reservoir Summary Reports 
The Reservoir Summary Report (Figure 14.30) displays 
Average, Maximum, and Minimum result values for pertinent 
reservoir parameters. 

To view the Reservoir Summary Report, select Reservoir 
Summary from the Reports menu. 

Figure 14.30  Reservoir Summary Report 
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14.5.3.2 Flow Summary Reports 
The Flow Summary Report (Figure 14.31) displays Average, 
Maximum, and Minimum values for individual location 
parameters. 

To view the Flow Summary Report, select Flow Summary from 
the Reports menu. 

Figure 14.31  Flow Summary Report 
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14.5.3.3  Power Summary Reports 
The Power Summary Report (Figure 14.32) displays Average, 
Maximum, and Minimum values for individual location 
parameters. 

To view the Power Summary Report, select Power Summary 
from the Reports menu. 

Figure 14.32  Power Summary Report 
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14.5.3.4 Gate Summary Reports 
The Gate Summary Report (Figure 14.33) displays Average, 
Maximum, and Minimum values for individual location 
parameters. 

To view the Gate Summary Report, select Gate Summary from 
the Reports menu. 

Figure 14.33  Gate Summary Report 
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14.5.3.5 Stage Summary Reports 
The Stage Summary Report (Figure 14.34) displays Average, 
Maximum, and Minimum values for individual location 
parameters. 

To view the Stage Summary Report, select Stage Summary from 
the Reports menu. 

Figure 14.34  Stage Summary Report 
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14.5.3.6 Release Decision Reports 
The Release Decision Report (Figure 14.35) displays the Active 
Zone and Active Rules for the reservoir pool, dam, and outlets at 
each time step for each reservoir. 

To view the Release Decision Report, select Release Decision 
from the Reports menu or select Release Decision Report from 
the reservoir’s shortcut menu (right-click on reservoir element). 

Figure 14.35  Release Decision Report 

The File menu allows you to Print and Close the report (see 
Appendix F for information about printing). 

14.5.3.7 Network Reports 
The Reservoir List, Reach List, Junction List, Diversion List, 
and the Network Connectivity Summary report are also available 
from the Reports menu of the Simulation Module.  Refer to 
Section 8.5 in Chapter 8 for more information about Network 
Reports. 



Chapter 14 – Running Simulations ResSim User’s Manual 
 

14-24 

14.6 Calibrating the Model and Editing Data 
You may need to make adjustments as you test and calibrate your 
Simulation model.  In the Simulation Module of ResSim, you can access 
editors that allow you to edit all components of your Reservoir Network, 
modify Alternatives, and fine-tune override controls. 

14.6.1 Using the ResSim Editor Interface 
In the Simulation Module, the ResSim Editor Interface (Figure 
14.36) provides access to editors for Reservoirs, Junctions, Reaches, 
and Diversions, as well as the Alternative Editor, Systems Operations, 
and the Release Overrides Editor.  You can also use the ResSim 
Editor Interface to quickly set Compute Options. 

To access the ResSim Editor Interface, right-click on an Alternative in 
the simulation tree, then select Edit > ResSim. 

Figure 14.36  ResSim Editor Interface 
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14.6.2 Editing Alternative Lookback, Time Series, and 
Observed Data 

To edit references to Time Series and Observed data, you will need to 
access the individual editors for Reservoirs, Junctions, Reaches, and 
Diversions.  To adjust Alternative Lookback data, you will need to 
use the Alternative Editor (see Chapter 13).  You can access each of 
these editors either from the ResSim Editor Interface (Figure 14.36) 
or from the Edit menu of the Simulation Module or Reservoir 
Network Module.  Refer to Chapters 9, 10 and 11 for detailed 
descriptions of the element editors available in ResSim. 

14.6.3 Editing Release Override Values 
Once you have computed a Simulation, the Release Overrides 
Editor (Figure 14.37) allows you to adjust the computed results for 
each time step of the Simulation.  You can access the Release 
Overrides Editor using the Overrides button in the ResSim Editor 
Interface (described above in Section 14.6.1); or, you can select 
Release Overrides (and the appropriate Alternative) from the 
Simulation Menu. 

Figure 14.37  Release Overrides Editor 
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ResSim will use the values you specify for Elevation Target and 
Release Overrides, within the physical limits of the reservoir.  The 
physical rate-of-change and the amount of water available in the 
reservoir may preclude ResSim from using your override values. 

For the Reservoir shown in the list at the top of the editor, there are 
two tabs available for overriding the simulation results:  Elevation 
Target and Release Overrides.  Each tab contains a Date, Time and 
either “Elevation Target” or “Release.”  You can use either one of 
these override capabilities to adjust the simulation results. 

Specifying Elevation Target Overrides: 
Initially, the Target Elevation is based on the elevation values you 
specified for the reservoir’s “guide curve” (Reservoir Editor, 
Operations tab).  This is typically the top of the Conservation pool 
and is commonly referred to as the “target” or “guide curve”.  In 
addition to meeting all of the other rules that you specify for a 
reservoir, ResSim will try to keep the reservoir pool at the guide 
curve elevation.  Therefore, by specifying Elevation Target values 
within this editor, you are inherently overriding the reservoir’s 
release decisions. 

Specifying Release Overrides: 
During a Simulation, ResSim determines the reservoir release 
values based on the rules you specified for the Alternative.  
However, there may be situations where you do not want the 
results to reflect the rules for specific time steps.  Therefore, you 
can enter release values using the Release Overrides tab. 

Editing Override Values 
You can specify Elevation Target and Release Overrides by 
entering single cell values or by revising multiple adjacent values 
using a fill function. 

To revise a single value, double-click in the cell you want to revise 
and enter the new value. 

To revise multiple adjacent values: 

1. Point and click on the first cell, then drag your mouse or shift-
click (hold down the shift key while clicking in other cells) to 
highlight the cells to be revised. 

2. Right-click on the highlighted cells, and select Fill from the 
shortcut menu (Figure 14.38).  The Table Fill Options dialog 
box will open (Figure 14.39) 

3. Select the appropriate fill option in the Table Fill Options 
dialog box (Figure 14.39), then click OK. 
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The revised values will reflect the fill option you selected.  In the 
example shown in Figure 14.39, the Repeat Fill option is selected.  
Therefore, as the table in Figure 14.40 illustrates, all of the 
highlighted cells equal the value of the first cell selected; also, the 
color of the revised values changes from black to blue and the 
mini-plot shows the revised values as a red line.  The mini-plot can 
be viewed in full size when you double-click on it. 

 
Figure 14.38  Release Overrides 
Editor Shortcut Menu:  Fill 
Data Values 

Figure 14.39  Table Fill Options 
Dialog Box 

 
Figure 14.40  Release Overrides Editor Table:  Revised 
Data Values using Repeat Fill Option 
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For those time steps where you do not specify override values, 
ResSim uses the reservoir rules to determine the reservoir release 
values.  After running a simulation using your override values, you 
may decide to no longer use some, or all, of your override values.  
Therefore, you can use the Unspecify and Unspecify All buttons to 
indicate that you want ResSim to determine the release values. 

Use the Unspecify button when you want release values to be based 
on the reservoir rules for some of the override values you have 
specified (override values are in green text after a simulation is 
computed).  Highlight the cells where you have specified override 
values, then press the Unspecify button. 

Use the Unspecify All button when you want all of the release values 
to be based on the reservoir rules and not have any overrides 
specified. 

Use the Import button when you want to use a time series of override 
values.  The Import Overrides Time Series dialog box (Figure 
14.41) will open, which functions exactly like the Select Time Series 
Path dialog box used to select time-series records for an Alternative.  
Refer to Section 13.6 in Chapter 13 for more information. 

Figure 14.41  Import Time Series Dialog Box 
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14.6.4 Setting Compute Options 
You can quickly set Compute Options for an Alternative using the 
ResSim Editor Interface. 

To set Compute Options, access the ResSim Editor Interface by right-
clicking on an Alternative in the simulation tree, then selecting 
Edit>ResSim. 

The ResSim Editor Interface will open.  Compute Options appear 
in the center of this interface (Figure 14.42. 

 
Figure 14.42  ResSim Editor Interface:  Compute Options 

� Check Compute Unregulated Flows if you want ResSim 
to perform additional calculations to determine the 
unregulated conditions in the watershed (e.g., without the 
regulation of reservoirs and projects). 

� Check Compute Holdouts when you want ResSim to 
calculate the amount of water the reservoir stores (as 
opposed to just releasing inflow).  Holdouts indicate the 
effects of reservoir regulation and are most applicable when 
you will be performing a subsequent Flood Impact or Flood 
Damage analysis. 

� Select the Log Level (1-10) to control the amount of 
detailed messages that will be output during the 
computations. 
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14.7 Managing Simulation Data 
ResSim facilitates archiving and sharing of Simulation data.  There are 
two operations involved in managing Simulation data.  You can save your 
data to the base directory to make it available for other Simulations, and 
you can replace data in a Simulation for a specific Alternative with data 
from the base directory. 

14.7.1 Saving Data to the Base Directory 
When you edit model data from the Simulation Module, your changes 
apply only to an individual Alternative and are saved in your 
Simulation directory (see Appendix A for an overview of the ResSim 
directory structure). 

 Important:  If you want your changes to be available for 
subsequent Simulations, you will need to save the data back 
to the Base directory. 

 

To save data to the Base 
directory: 

1. In the Simulation Control 
Panel, right-click on the 
Alternative to access the 
shortcut menu, then 
choose Save to Base 
Directory (Figure 14.43). 
The Save Simulation 
Run Model Parameters 
to Base Directory dialog 
box will appear (Figure 14.44). 

Figure 14.43  Alternative Shortcut 
Menu:  Save to Base Directory 

 
Figure 14.44  Save Simulation Run Model Parameters 
to Base Directory 
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2. Select the appropriate boxes in the Copy Data column beside 
the items you wish to copy from the Simulation directory to the 
Base directory. 

3. Click the OK button to save the Simulation data to the Base 
directory. 

14.7.2 Replacing Data from the Base Directory 
If, while editing Simulation data, you need to revert to the original 
Alternative data, you can replace the changed data in your Simulation 
directory with data from the Base directory. 

To replace Simulation data with 
data from the Base directory: 

1. From the Simulation 
Control Panel, right-click 
on the Alternative to 
access the shortcut menu, 
then choose Replace 
from Base Directory 
(Figure 14.45).  The 
Replace Simulation Run 
Model Parameters from 
Base Directory dialog 
box will appear (Figure 
14.46). 

 
Figure 14.46  Replace Simulation Run Model Parameters 
from Base Directory 

2. Select the appropriate boxes in the Restore Data column 
beside the items you wish to restore from the Base directory to 
the Simulation directory. 

3. Click the OK button to replace the Simulation Alternative data 
you have selected with data from the Base directory. 

Figure 14.45  Alternative 
Shortcut Menu:  Replace from 
Base Directory 
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14.8 Using HEC-DssVue 
Included within the framework of ResSim is HEC-DssVue, a tool that 
allows you to access data stored in HEC-DSS database files. 

When HecDssVue is selected from the Tools menu 
(Figure 14.47) within the Simulation Module, the 
current “simulation.dss” file is opened. 

 

 

In the Main Window of HEC-DssVue, a listing of 
pathnames that are contained in the simulation.dss file 
are provided, as shown in Figure 14.48. 

 

 
Figure 14.48  HEC-DssVue Main Window Showing Pathname Listing 

A screened listing of pathnames can be obtained by selecting a pathname 
part from the lists in the Search by Parts section of the window.  For 
example, if you want a listing of “observed” records, you can select OBS 
from the F-part list, as shown in Figure 14.49.  To obtain an unscreened 
listing of pathnames, select the “blank” area at the top of the list. 

Figure 14.47  
Accessing HEC-
DssVue from the 
Tools Menu 

 
Figure 14.49  Screened Pathname Listing Showing Observed (OBS) Records 
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To select records to be plotted, tabulated, or edited, highlight the desired 
pathnames and click on the Select button.  After one or more records are 

selected, the icons for the graph  and table  become active.  Now, 
you can click on either icon to generate a plot (Figure 14.50) or table 
(Figure 14.51) of the selected records. 

 
Figure 14.50  Example Plot Using HEC-DssVue 

 
Figure 14.51  Example of Tabulated Data Using HEC-DssVue 

For a more detailed description of HEC-DssVue, see Appendix E. 
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