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HEC-RAS Workshop: Hydraulic and Morphological Analysis for Stream Restoration 

HEC-RAS includes several 

hydraulic and morphologic tools 

that can support river restoration 

analyses.  This workshop will 

provide exposure to HEC-RAS 

and several of its capabilities that 

are useful for river restoration 

studies. 

The lower Truckee River flows 

west from Lake Tahoe and is a 

historically productive fishery.  

The Nature Conservancy and the 

Corps analyzed a degraded reach 

for potential restoration 

alternatives to improve habitat 

and encourage biodiversity.  In 

this workshop you will use some tools and perform some analyses to evaluate the hydraulic and 

morphologically feasibility of the design.   

Note:  **The models in this workshop have been modified and the alternative arbitrarily 

designed for the purposes of instruction** 

1. Analysis of Existing Conditions

A. Open and View Project

Open HEC-RAS by selecting the desktop icon:  

Open the 25RestRASwksp.prj file in 

the student directory using the 

File→Open menu 

The “Existing Conditions” plan will 

be active.  A complete HEC-RAS 

model has been constructed for the 

existing conditions.  View the aerial 

photo and the model schematic by 

selecting the Geometric Data icon 

 or the Edit→Geometric Data 

Menu.  
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B. Run Simulation and Estimate Bankfull Discharge 

 

Perform a steady flow run of the model.  Select the Perform Steady Flow Analysis button    

or the Run→Steady Flow Analysis menu. Press the Compute button on the dialog that appears. 

 

View the results using the View Cross Sections   and the View Profiles   buttons or the 

first two items on the View menu.  Profiles 

for 14 flows will plot.   

 

Use the model runs to estimate a bank full 

flow:  __________ cfs 

 

(Note: Profiles have been named with the 

flow associated with them.  You can scroll 

through the cross section plots and click on 

the profile closest to bank full to find the 

corresponding flow.  Additionally, the 

profile plot includes right and left bank 

elevations.) 

 

A frequency curve developed for this reach is included in Figure 1.  
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Figure 1: Flow-frequency relationship for this reach. 
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Based on this relationship, what is the 50% exceedance probability flow (e.g. 2-year flow)?  

__________ cfs 

 

What is the exceedance probability associated with the “bankfull” flow determined from the 

water surface profile analysis?   ______% 

 

What is a possible explanation for the discrepancy between the 2-year flow and the “bankfull” 

discharge? 

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________ 

 

C. Evaluate Restoration Alternative: Overbank Flows 

 

A second HEC-RAS model has been built to simulate the hydraulic conditions of a restoration 

alternative that includes a drop structure (at the downstream end) to reduce the channel slope and 

reintroduced meanders.  The restored reach includes cross sections between 236200 and 243199 

(approximately river stations 1000 ft to 9000 ft).  To access this model open the “Restored 

Channel Conditions” plan by opening the Steady Flow Analysis dialog (with the Perform 

Steady Flow Analysis button        or the Run→Steady Flow Analysis menu) and selecting 

File→Open Plan.  Run the new plan and view the channel geometry, cross sections and profile.   

 

What flow floods the overbanks appreciably along most of the restored reach?  ________ cfs 

 

If the intention of the restoration is to flood the overbanks approximately every other year how 

effective is this design? 

_____________________________________________________________________________ 

 

D. Evaluate Restoration Alternative: Channel Stability  

 

HEC-RAS includes functionalities to investigate channel stability and sediment transport 

behavior of existing or designed channels.  These tools will be used to evaluate the restored 

channel design. 

 

Begin by selecting the Hydraulic Design dialog (depicted in Figure 1) by pressing the 

Hydraulic Design button  or selecting the Run→Hydraulic Design Functions menu.  Make 

sure that the Stable Channel Design function is selected from the Type menu and the Tractive 

Force method (tab) is activated.   

 

This function will be used to evaluate the stability of the designed channel.  A number of 

parameters are already specified. 

 

Use the cross section and profile displays to fill in the fields for flow depth (D) or channel 

bottom width (W).  The slope in the restored reach (S) is 0.001.  Leave the three D75 fields and 

one of the channel dimensions (W or D) open and press the Calculate button.  This tool uses 

Lane’s Method to calculate the minimum sediment size for which the channel configuration will 

be stable.  D75 is the grain size that is coarser than 75% of the material. 
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What are the minimum stable D75’s for a channel like the one proposed: 

 

 Left Bank Channel Bed Right Bank 

 ______mm ________mm _______mm 

 

A grain size distribution for this channel is included in Figure 2. 

 

What is the D75 of this channel?  ____mm 

 

Is the channel likely to degrade?_____  Why or why not?  ______________________________  

    ______________________________ 

What other geomorphic issues should be considered?  ______________________________ 
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Figure 2: Particle size distribution for this reach. 

 

E. Evaluate Restoration Alternative: Sediment Transport Potential 

 

Evaluating the sediment transport potential of a restored channel is another helpful analysis 

HEC-RAS facilitates.  To start this analysis open the Hydraulic Design dialog and select the 

Type→Sediment Transport Capacity menu.  Since the riverbed is mostly gravel select the 

Meyer-Peter Muller (MPM) sediment transport function which was developed for gravel bed 

applications.  
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Since there is uncertainty about the effective discharge (the flow that transports the most 

sediment over time) in this reach, we will evaluate the transport potential for both the 2-year 

event and the previous “bank full” discharge.  To do this click the Profiles button and choose 

1500 cfs and 7000 cfs from the list of profiles.  Calculate the sediment transport potential from 

this reach by pressing the Compute button. 

Plot and view the channel sediment capacity of the reach by pressing the Plot Sediment Profiles   

button. 

 

At what station is the transport suspiciously high?  _________   

Why?_________________________________________ 
     (Note: You can click on the profile nodes to find out what station they correspond to.) 
 

Rescale the plot by zooming in on the rest of the data using the View→Zoom In menu (or right 

click to get the Zoom In feature).   

 

What is the range of channel transport capacities along the restored reach for the 2-yr 

flow?_____________ 

 

For the higher flow where is the most likely region(s) of scour?  _______________________ 

      Deposition?__________________________ 

 

Look at some of the cross sections with high and low transport capacity for the 7000 cfs flow. 

What is causing the transport capacity to be higher in some than others? 

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________ 

 

 

If you have extra time: 

 

Plot the channel velocity and channel area profiles for the reach.  From the main program dialog 

select the View General Profile Plots button   or the View→General Profile Plots menu.  

Choose which variables to plot under the Standard Plots menu.  You can choose specific 

profiles by selecting the Options→Profiles menu? 

 

How do velocity and area trends correspond to sediment capacity along the reach? 

______________________________________________________________________________

______________________________________________________________________________

______________________________________________________________________________ 

 

Try other sediment transport functions for the sediment capacity calculation. 

How sensitive are the calculations to the selected function?  

____________________________________________________________________________ 
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Advanced Exercise:  

Using the Copland Stable Channel Method to  

Evaluate Channel Restoration 
 

If you get stuck, or when you finish, move on to the detailed analysis below. 

Over 100 years ago, farmers ditched a mildly meandering, sand bed river.  Over 

the last century, the 10-mile channel has adjusted to the new alignment.  But 

suburbs have grown around it and the community wants to restore a 1-mile reach 

as the centerpieces of a green-belt bike path and a riparian bird hotspot.   

 

The current reach has the following average dimensions and properties: 

 
Bank Full Discharge 3,000 cfs  d85 0.5 mm 

Bottom Width 350 ft d50 0.3 mm 

Bank Roughness 0.03 d85 0.1 mm 

Slope 0.000008*   

Bank full depth 8 ft   

Side Slopes 3   
 *The channel slope is about half of the valley slope 

 

The landscape architect in charge of the project is proposing a meander channel 

pattern that will double the length of the channel, with the same channel 

dimensions.   

 

How do you expect this design to respond, morphologically?   

______________________________________________________________ 

______________________________________________________________ 

 

 

Follow the steps below to apply the Copeland Method in the HEC-RAS Hydraulic 

Design editor to evaluate the design and make recommendations. 
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Step 1: Open HEC-RAS and the HD Editor 

 

You do not need an HEC-RAS model to run the HD Calculators.  So in this 

workshop, there are no starting files.  Just open HEC-RAS, save a new project and 

give it a name.  Then open the Hydraulic Design editor, save the new file and give 

it a name. 

 

Select Options→Stable Channel Design… from the menu, and click on the 

Copeland tab in this editor. 

 

 
 

Then Populate the data in the main Copeland Tab.  You will have to press the 

Gradation button  to complete this information.   

 

The Copeland Method is ideal for this sort of analysis, because we believe the 

upstream reach is in equilibrium with the project reach, so we expect it will 

compute equilibrium for the existing conditions and give us a portfolio of 

equilibrium conditions for the alternatives. 
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To compute the equilibrium condition for the upstream reach, press the Inflowing 

Sediment Button.  We do not have sediment load 

information, so we are going to define the regional channel characteristic and the 

Copeland method will use the Brownlie transport function to estimate the 

equilibrium flux. 

 

 
 

Press  and . 
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HEC-RAS will generate a suite of equilibrium Slope-Width pairs (and a set of 

hydrodynamics associated with each).  Select the width you want to plot and press 

OK. 

 

Press the Stability Curve 1 button to display the results graphically. 
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The existing conditions plot close to the equilibrium line (slightly aggregational).  

Because we know this reach is roughly in equilibrium, that deviation is probably 

noise from the transport function.   

 

The design doubles the local length which will halve the local slope of half the 

existing slope (0.000004). 

 

How do you expect this design to respond, morphologically?   

 

There is no stable width at a slope of 0.000004.  That is deep in the aggradation 

zone, particularly at the current width.  This is a potentially problematic design, 

and the analysis suggests it will deposit, maybe aggressively. 

 

Can you propose an alternate design? 

 

It is not the nice meandering reach the community is hoping for, but with a 

narrower channel (100 ft) the community could add some sinuosity, dropping the 

slope to 0.00007 (or even 0.0000065 given the offset of the stable, current, 

condition) without inducing dramatic deposition.   

 

W4.2/161




