Mud and Debris Flow Modeling with HEC-RAS Hydrologic Engineering Center (2023)

Initial Debris Flow Workshop: Part 2
Refining Your Model and Improving Stability

In the first part of this workshop we tried to get to a reasonable risk map and timeline as quickly as
possible. In this workshop we are going to try to refine the model and improve the stability

1. Improve the Hydrodynamic Simulation

Open the Options Menu of one of your non-Newtonian Plan Files.
Go to Options=> Computation Options and Tolerances.
Click on the 2D Flow Options tab.

A Unsteady Flow Analysis hes HEC-RAS Unsteady Computation Options and Tolerances
File = Options Help =
General| 20 Flow Options § 10/2D Options | Advanced Time Step Control | 1D Mixed Flow |
: Stage and Flow Qutput Locations ... i
s 9 P B (SWE) [™ Use Coriolis Effects (not used with Diffusion Wave equation)
Flow Roughness Factors ... —L|
Seasonal Roughness Factors ... j Parameter (Default) | Debris Runnout
. . 1|Theta (0.5-1.0) 1 it
Fro
u Automated Roughness Calibration .. 2| Theta Warmup (0.5-1.0) 1 T
W Automated Flow Optimization ... 3| Water Surface Tolerance [max=0.2]{ft) 0.01 0.01
4| Volume Tolerance {ft) 0.01 0.01
Unsteady Encroachments ... 5| Maximum Iterations 20 20
el s 6 | Equation Set Diffusion Wave Diffusion Wave
gag 7| Initial Conditions Time (hrs)
Dam (Inline Structure) Breach ... P 8| Initial Conditions Ramp Up Fraction {(0-1) 0.1 0.1
Sim L 9| Mumber of Time Slices (Integer Value) 1 1
Levee (Lateral Structure) Breach ... L. I—DDDD 10| Turbulence Model None None
SA Connection Breach ... ’— 11| Longitudinal Mixing Coefficdent 0.3 0.3
[ Ds00 12| Transverse Mixing Coefficient 0.1 0.1
Col omp! ion ions and Tolerances ... L 13| smagorinsky Coeffident 0.05 0.05
Cor srval: |5Minute v 14|Boundary Condition Volume Check r r
Map Cutput Options ... Ik e o 15 | Latitude for Coriolis (-90 to 90) . .
Friction Slope Method for Crass Sections = 16| Solver Cores Al Available All Available
Pre P es\_ DWR De g 17 [ Matrix Solver PARDISO (Direct) PARDISO (Direct)
Friction Slope Method for Bridges ... = 18| Convergence Tolerance 0.00001 0.00001
Time — - - a
Initial Backwater Flow Optimizations ... L Mlnlmum Iberah?ns 4 4
20| Maximum Iterations 30 30
Sediment Computation Options and Tolerances ... 22| Bestantiievatio & &
. ) 22| Relaxation Factor 1.3 1.3
Sediment Output Options ... | 23| SOR. Preconditioner Iterations 16 16

Which of these parameters might you want to change?

We usually recommend a warmup or initial conditions window for 2D HEC-RAS
models, why wouldn’t we necessarily use one for this model?
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Our expedited models used the Diffusion Wave model.

Change that to the Shallow Water Flow Equation SWE-ELM

Diffusion Wave

=]

Diffusion Wave

|SWE-EM (stricter momentum)
ASWEALIA (local inertia)

Save your plan AS and give it a new name (e.g. add a “(SWE)” to the name and short id).

From the Simulation (Plan) editor i‘ press the Compute button.

I

How does the stability messages and the Max Errors compare to your Diffusion

Wave simulation?

D1JAN2100 00:06:30 Debris Runnout  Cell # 13441 5028.66 0.703 20

D1JAN2100 00:06:35 Debris Runnout  Cell # 13441 5030.23 1848 21

D1JAN2100 00:06:40 Debris Runnout  Cell # 13440 502590 1592 | 21 M
D1JAN2100 00:06:45 Debris Runnout  Cell # 13441 5029.91 (1213 | 22 ax
D1JAN2100 00:06:50 Debris Runnout  Cell # 13280 5038.30 |0.453 | 20

D1JAN2100 00:06:55 Debris Runnout  Cell # 13441 5028.09 (2.055 | 21 WS E
D1JAN2100 00:07:00 Debris Runnout  Cell # 13441 5028.76  1.892 23

01JAM2100 00:07:05 Debris Runnout Cell # 13268 4983.41  2.727 22 E rro r
D1JAN2100 00:07:10 Debris Runnout — Cell # 13441 5028.26 1553 21

D1JAN2100 00:07:15 Debris Runnout  Cell # 13266 458188 1636 23

D1JAN2100 00:07:20 Debris Runnout  Cell # 13441 5028.18 2717 20

D1JAN2100 00:07:25 Debris Runnout  Cell # 13441 502835 2.611 21

D11AN2100 00:07:30 Debris Runnout  Cell # 13441 502761  3.937 22

D1JAN2100 00:07:35 Debris Runnout  Cell # 13441 5027.33 4765 21

These Water Surface Errors are in feet, do they seem acceptable?

What could you do to improve them?

You selected the time step based on the Courant Condition, why isn’t that time
step appropriate for the whole simulation?
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2. Improving the Model Time Step

Velocities change throughout the model, especially with Non-Newtonian models where flow can
approach 0. Sometimes a variable time step that tries to optimize the Courant dynamically can improve
stability.

To specify a variable time step, press the “...” button next to the Computational Time Step, or select
Options—=>Computation Options and Tolerances and choose the Advanced Time Step Control tab.

Computation Settings

Computation Interval: |5 Second | Mugraph Qutput Interval: |5 Minute j
Mapping Output Interval: |1 Minute — | Detailed Qutput Interval: |5 Minute j
Project DSS Filename: j |d: \Classes\_Non-Mewtonian (Vegas)\Workshops\Try 16\try1 Eﬂ

Select the Adjust Time Step Based on Courant radio button.

{* Adjust Time Step Based on Courant

Maximum Courant: ] 1
Minimum Courant: ID.45

MNumber of steps below Minimum before doubling: l-‘i

Maximum number of doubling base time step: I-’i FU-OU sec
Maximum number of halving base time step: ‘-‘l P-31 sec
Courant Methodology

i+ Velodty/Length (face velodty * dt / cell to cell distance)
" Residence Time (cell outflow = dt / cell volume)

Set the Maximum Courant to 1 for this exercise.
(Note: This can be as high as 2 or 4 for some models, but because we are not too concerned about run
time, we set it for the strictest criteria.)

Then, the Minimum Courant should be a little less than half of the max (to avoid frequent switching.
The final parameter (Max # of halving) is the most important of the remaining three, but you can set
them all to 4.

How did changing the time step affect your iteration and error?

Why?
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3. Evaluate Stability and Cell Connectivity Spatially
The Max Iteration/Water Surface Error in the runtime window can be helpful, but it only tells you the
worst case. You could go search for that cell and fix it, but there might be tens, or hundreds, of other

cells with similar behavior.

Therefore, it is extremely useful to view the iteration behavior and max error spatially.

E Create a Mew Results Map Layer...

Right Click on the Result and select Create New Results Map Layer...]

E- [#] Resulls w =
El- ] Mg
B o5 RASResults Information
B0 4 .
B0 - Plot Results Profile
[ Show 1D Results Table (No 10 Results)
E @& Zoom to Layer
Ell%l NE Remove Layer
B0 ﬂ Removwe Layer and Delete Source Files
- Move Layer 4
E Open Folder in File Explorer
- Show Compute Messages ...
L Create a New Results Map Layer...
Create a New Calculated Layer...
Manage Results Map Layers...
< a View Result in 3D

Expand Additional 2D Variables and add Cumulative Max Iterations and Maximum Water Surface Error
by pressing Add Map.

Map Type Map Output Mode
" Hydraulics Generated for Current View (in memary)
=5 Mws— {* Raster (with Associated Terrain)
o |
4 Maximum Water Surface Emor Point Feature Layer.
“Face Courart Maxmum Stored (saved to disk

" Raster based on Terrain: |Terrain

B Ll B

" Point Feature Layer:
" Polygen Boundary at Value: Min: |0 Max:; |Max

Map Type Layer Name

[ oy, 101 N Rl GBS Cumulative Max terations
Map Type: A Map layer wil be created for Cell Cumulative Max terations. ﬁ
Add Map |

Map Mode: Map results are generated onthefly for the cument view.

Close |

A

Plot these error metrics and identify cells with substantial errors.

These will differ depending on how you drew your polygon.

But they often correspond to ridges or channels or “leaking meshes” that could be improved with break
lines.
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== RAS Mapper

File  Project Tools Help

Selected Layer: Maximum Water Surface Error

- [¥] Results -
Bl [ Mewt

- [] Event Conditions

- [] Geometry

- D Plan

.- [ Depth (012AN2100 00-0 [
D Velocity (Max)

] WSE (Max)

- [] Cumulative Max |terations

.- [#] Maximum Water Surfdcel I
E- [ NN

- [] Event Conditions

B[] Geometry

B-[] Plan

- [¥] Depth (01JaN2100 03:5
-] Velocity (Max)

.- ] WSE (Max)

B[] t2500 v

[ e [ ¥ DY R

£ >

Mes sages | Views | Profile Lines | Active Features 4 | » |

(148574913, 14573995.49 1 pixel = 1.04 ft)

- O *
Ea{'}.'&l::::(--) s EHA 89
Selecled' 'Ilaxlmum Water Surface Enul'—F—;
» %
il ‘L L
~ : ol

Plotting velocity can illustrate where flow is jumping ridges or high ground.
(notice where the velocity gets high at the edge of the wetted area, which is also near high error cells.

Evaluating continuity can also help you evaluate where your mesh needs improvement.
Turn on Continuity Arrows by right clicking on Velocity and selecting Layer Properties.

= RAS Mapper
file Project Tools Help

Selected Layer: Velocity

@A XX &dmw uﬂ*ﬁ\ﬁﬂlﬂlﬂj J»«

— O X

#-[] Plans ~
[] Event Conditions
Results
=[] Hewt
[ Event Conditicns
- [] Geometry
B[] Plen
] Depth (01JAN2100 00:00:00)
- [l Velocity (=
] WSE (Max| o2t
.. [] Cumulativ
[ Mazximum

Layer Properties

Edit Map Parameters

1& Zoomto Layer
& [ Event Con{ > g

B[] Geometry | 6
[ [ Flsn
- [ Depth (01
[ Velocity (|
- C1WSE (Max]
- [] /2500
[ Event Con
B[] Geometry
CIPan
- 1 Depth (Max)
- ] Velocity (Max) "
< >

Add Watch to Layer Values

Remove Layer

Move Layer 3

[E3

Export Layer 3
Export RAS Tiles for Web Mapping

View Map in 3D Viewer

Views | Profile Lines | Active Fea 4 | » |

(1485396.33, 14579858 42 1 pixel = 0.78 ft)

Selecled 'Vehciy'

W \.
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Mud and Debris Flow Modeling with HEC-RAS Hydrologic Engineering Center (2023)

Select the Plot 2D Water Surface Gradient (Arrow WSEL...) This illustrates that the cells with the most
error tend to jump high ground ridges.

j[ E Velocity - Layer Properties

[ Misualization and Information I Features | Source Files I

[~ Label Features with Attribute Column(s)

g —Wector [~ Addtional Options
Point: * Line: Eill [[] Plet Contour At Cursor

Edit |

Hydra =
|| 7| Flot 2D Wwiater Surface Gradient (Arrow: WSEL High-

TOrawiEr vaiTes

Surface

¥ Flot Surfzce

[ Update Legend with View __Histogram |

] Draw Per Face
["] Draw True Face Values (interpolated)
["] Face Low-Elevation Centroid

["] Display Arrival Times as Dates

15; [stretched =l E6t__ || || Pl Model Boundary Defciensies
[] Track Velocity at Cursor
e A j 100%
—Contours / Hillshade
[~ Plot Contours  Interval: m Color:  m—
Edit

[¥ Plet Hillshade  Z Factor: |3 -

CDwSymanogyl Paste Symbology | HﬁetSymanDgyl

L L)
- ] WSE (Max)
Map Layers
echDZD_Basm_DFF'red\cﬂnns_'IB@
[] Google Satellite
- [¢] Terrains
. [¥] Terrain

<

You are looking for cells that should not be connected hydraulically, but have arrows indicating water is
flowing through them. In the image above, we drew a big blue arrow across a high iteration cell which
should not be allowing flow, because it is a ridge. But because two corners of the cell are wet, the
continuity arrows show that water is flowing through it. And because flow should not convey through

this cell, the model is having trouble converging on a solution.

What could you do to fix this?
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4. Improve your Mesh

Finally, now that you understand the regions that your model is struggling, you can improve the mesh.

You have several tools to improve the result, including:
e Breaklines
e Refinement Regions
e n-Value Regions

But in this workshop, you will mostly use Breaklines, which are the most common and versatile tool.

Return to the Geometry tree, Right Click on your Geometry and Save Geometry As.

Geomeines “
- [#] Simple 25f Mesh

&[] Plans p=:  RAS Geometry Properties
- [] Event Conditions i
&[] Resulls r Edit Geometry

- [] Yield2500 @, Validate Geometry
" [ Yield 700 | [[] Save Geometry As...
(- [] Newtonian

: ‘ﬁeIdZE-DD (SwE) ﬁ Delete Geometry
D Event Conditior a

HEE SN = F o T

View Geometry in 30

Give the new Geometry a name like “Refine Geometry”

Expand 2D Flow Areas, and click the pencil to start editing.

Choose the Draw V button and draw break lines along high ground.

ZSelected Layer; Breaklines

- [] Features
[ Frofife Lines™

= [#] Geometries
&l-[] Simple 25ft Mesh
- [#] Refine Geometry
5[] 2D Flow Areas
| L[] Perimeters
- [[] Computation Peints
Breaklines
{ [0 Refinement Ragions
- [[] Boundary Condition Lines

Refining Your Model and Improving Stability (Gibson) 7



Mud and Debris Flow Modeling with HEC-RAS Hydrologic Engineering Center (2023)

Note: When you are trying to draw breaklines along high ground, there ae a couple visualsation options
that can help.

Right Click on the Terrain and select Image Display Properties. Select Plot Contours (experiment with a

good interval) and Update Legend with View options.

Then right click on the velocity result, select Layer Properties and decrease the Opacity (e.g. decreasing

opacity increases transparency) of the velocity result.

BB Terrain - Layer Properties - O *
Visualization and Information |So|.|rce Files I
—Vector Addtional Options

Poink: _l e I Fill- | [] Plot Contour At Cursor

["] Plot raster file outlines
o [] Plot raster file names

I Labe! Features with Attribute Column(s =L [] Plat tile outlines
ek [7] Plot cell outlines (when zoomed in)
uriace [] Plet cell values (when zoomed in)

¥ Plot Surface I ¥ Update Legend with View I Histogram | [] Plot stitch TIN edges
[ Plot Levell stitch TIM edges

%! IStretched LI Edit [] Remove Stitch Rendering
Opacity: T J 100%

—Caontours / Hillshade
¥ Plot Contours  Interval: |D_5 LII Color: —l

¥ Plot Hillshade ZFacmr:|3 vl Edit |

Copy Symbology | Paste Symbology I F{esetSymeIDgyI

Draw a breakline along a ridge or high ground.

Double click to stop drawing when you are done.

You may notice that a few of the cells snap to the breakline but mostly the mesh does not change.
You need to edit the properties and enforce the breakline.

Right Click on the Break Line and select Edit Breakline Properties.

All Enabled Results

Plot Time Series

Plot Property Table

Breakline: Breakline 1 (Test Works
Edit Breakline Properties

Enforce Breakline

Rename Breakline

Delete Selected Point Del, D
Copy Selected Feature Ctrl+C
Zoom to Selected Feature

Invert Selection

Split Selected Line

Filter Selected Line

View/Edit Points

Geospatial Operations

Plot Terrain Profile

Save as Profile Line
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Set the near spacing to the overall spacing (25) and do not any repeats or far spacing.

Right click on the breakline again and choose Enforce Breakline.

Breakline: Breakline 1 (Test Workshop)
7]  Edit Breakline Properties
|ﬁ Enforce Breakline

Rename Breakline

Repeat this process for a couple ridges or high ground locations where you are having continuity and/or
stability issues.

Then press the Stop Editing button, and save your new geometry.
Selected Layer: Breaklines —_—t 9 OO RQxH € 46\“ I_
(=) [v] Features
i [] Profile Lines”
‘- |v] Burnfrez
=)- [v] Geometries
- [] Simple 25ft Mesh
=) [¥] Refine Geometry
[ Rivers
B[] Cross Sections
-] Storage Areas
E-[v] 2D Flow Areas
- [v] Perimeters
- [¥¥] Computation Points

& M1 Bumn Stafinne

Return to the Plan Editor from the main HEC-RAS window by selecting Run->Unsteady Flow or the

Unsteady Plan Button. i‘

Save the Plan AS (under the File menu) and give it a new name.
Then select the dropdown box next to Geometry File.

Choose the new, refined geometry you just made.

Compute and look at your new results.
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A Unsteady Flow Analysis >
File Options Help
Plan: [Yield 2500 (SWE) Short ID: |Yield2500 (SWE)

Geometry File: Refine Geometry LI

Unsteady Flow File: Simple 25ft Mesh
Programs to Run Plan Description
¥ Geometry Preprocessor |_| |

Compare the time series results between the initial run and the refined simulation.

How did it change?

= RAS Mapper B RASMapper Plot - O x | -
File Project Tools Help

Plot ITahIe I |
Selected Layer: Depth

"0 Errers
[] Plans
[_] Event Conditions
(=[] Results
- [] Yield2500
] Event Cenditions
&[] Geometry
[1Plan
i Depth (Max)
- [] Velocity (Max)
+[[] WSE (Max)
[ Yield 700
[] Newtonian
E- [V] Yield2500 (SWE)
[[] Event Conditions
[[] Geometry
[JPlan
i [¥] Depth (Max)
i [] Velocity (01JAN2100 01:48:00)
- WSE (Max)
1+ [[] Cumulative Max Iterations
*-- [[] Maximum Water Surface Error

i) [ Al Enabled Resuits
& EEpfay;! s WSE [No Enabled Maps with Profiles] fin.  Plot Time Series v
Google Satellite Velocity [No Enabled Maps with Profiles] Plot Property Table »
= o Depth 2D Area: Debris Runnout (Refine Geometry)
Courant (Velocity/Length) [No Enabled Maps with Profiles] ] Face #29541
Pressure [No Enabled Maps with Profiles] £ Find.. Ctrl+F
Sediment m Plot Property Table »
Peri - Debris Ru (Refine Y)
£ Find.. Ctel+F

M IViews Profile LimslAch‘ve Featurﬁ] Layer 4 I » Summary Information »

(Dots Hennout iNoemars i Locs/MA | piot Time Series ’

Depth

— Yield2500
== Yield2500 (SWE)

]

| S S T W TR Y ST SN N TN S SN S SN S W1

Depth [feet]

T
01Jan2100 0200

71A0C141 21 1ACTOALA EF 4 iod _ 4 AL &y

If you have extra time

Sometimes a quasi-1D model can be more stable, where a single cell spans a small, steep channel.
Save your Geometry File As, and experiment with this approach.
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