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CHAPTER 2 
 
 

Using HEC-DSSVue:  An Overview 
 
 
With HEC-DSSVue, you can access, view, and manipulate data stored in 
HEC-DSS database files using a variety of utilities and functions available 
from the main HEC-DSSVue screen, shown in Figure 2.1. 
 

 
Figure 2.1  HEC-DSSVue Main Window 

 
This chapter provides an overview of the HEC-DSSVue's main window 
components and their basic functions. 
 
 

2.1 HEC-DSSVue Main Window 
 
The main window of HEC-DSSVue (Figure 2.1) consists of a Menu Bar, 
Tool Bar, Current File Information, Files Tabs, Search Boxes, a list of 
DSS Pathnames, Selection Area, Selection Buttons, and Message Bar.  
The following sections describe these features in detail. 
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2.1.1 Menu Bar 
 
Main menu options in HEC-DSSVue (Figure 2.2) allow you to search for, 
select, and edit HEC-DSS data sets; control the display of pathnames and 
access plots and tables among other tasks.  The HEC-DSSVue main menu 
options are as follows: 
 

 
Figure 2.1  HEC-DSSVue Menu Bar 
 
 File File menu commands include New, Open, Close DSS 

File(s), Print Catalog Preview, Print Catalog, and 
Exit.  The file menu also lists the last six opened files. 

 
 Edit  Edit menu commands are Tabular Edit, Graphical 

Edit, Edit in Excel, Select All, Rename Records, 
Delete Records, Undelete, Duplicate, Copy To, and 
Merge Records.   

 
 View The View menu allows you to customize the display of 

HEC-DSS pathnames, refresh the catalog and search 
pathnames.  Available commands are Pathname List, 
Pathname Parts, Condensed Catalog, No Pathnames, 
Unsorted List, Search pathnames by string, Search 
pathnames by parts, and Refresh Catalog. 

 
 Display Use the Display menu to view data.  Options in this 

menu are Plot, Plot Individual Data Sets, Tabulate, 
Tabulate in Excel, Display Data Options, 
Supplemental Information, Time Window, Charts, 
and NC DWR Duration Hydrograph. 

 
 Groups Use the Group menu to organize selected records into 

groups or view and edit existing Groups.  Group menu 
commands include Save Selected, Get, Plot, Plot 
Individual Sets, Tabulate, Math, and Merge. 

 
 Data Entry The Data Entry menu is used to add data and files to 

records.  Commands include Manual Time Series, 
Manual Paired Data, Manual Text, Import, and 
Export. 

 
 Tools The Tools menu provides tools for manipulating DSS 

records.  These tools include Math Functions, 
Compare, Search for Value, Check File Integrity, 
Squeeze, Script Editor, and Script Selector. 
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 Custom (Optional) If your office has written their own plug-ins, 
those plug-ins can be made available under the Custom 
menu.  The menu name is set from the plug-in.  See the 
Writing Plug-ins Appendix for more information. 

 
 Scripts (Optional) If you use scripts, you can activate the 

Scripts menu from the Script Editor (under Tools) and 
have quick access to your selected scripts from this 
menu. 

 
 Advanced Through the Advanced menu you can create, view, or 

print a Condensed Disk Catalog, Abbreviated Disk 
Catalog, or a Full Disk Catalogs.  Additional options 
are Console Output, DSS Output, Status, Debug, and 
Program Options. 

 
 Help The Help menu contains the About option, which 

displays the HEC-DSSVue version information and 
gives access to the terms and conditions of the software. 

 
2.1.2 Tool Bar 

 
The Tool Bar buttons provide shortcuts to frequently used menu 
commands: 
 
 Opens the Open HEC-DSS File browser that allows you to select 

and open a HEC-DSS file.  This button would be equivalent to 
selecting Open in the File menu. 

 
 Plots the selected data, equivalent to selecting Plot in the Display 

menu. 
 
 Displays the selected data in a table, equivalent to selecting 

Tabulate in the Display menu. 
 
 Graphically edit the selected data, equivalent to selecting 

Graphical Edit in the Edit menu. 
 
 Open the Math Functions dialog with the selected data, equivalent 

to selecting Math Functions in the Tools menu. 
 
 (Optional) Open the selected records in Microsoft Excel, equivalent 

to selecting Tabulate in Excel in the Display menu.  This function 
relies on the Excel plug-in to be installed. 
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2.1.3 File Tabs 
 
Multiple DSS files can be opened and viewed in HEC-DSSVue at the 
same time (Figure 2.3).  Each time you open a new dss file, a tab is 
created with the name of the dss file shown on it.  The pathnames  
 

 
Figure 2.2  File Tabs 
 
displayed are from the selected tab's DSS file.  If more than one file is 
opened, selected pathnames will include the name of the DSS file they are 
from.  For example:  
 

BaldEagleHist.dss://BALDE/FLOW/01DEC1993/1HOUR/BB/. 
 
 

2.1.4 Current File Name 
 
The Current File area displays the information of the selected tab’s DSS 
file.  The File Name box (Figure 2.4) displays the file name and location 
of the selected HEC-DSS file.   
 

 
Figure 2.3  File Name Box 
 

Tip:  If you know the exact location and name of the HEC-DSS 
database file you wish to open, you can type it directly into the 
File Name box (Figure 2.4) and then click the Enter key to 
open it. 

 
Beneath the File Name box (Figure 2.4) is statistical information on the 
pathnames contained in that file.  Pathnames Shown displays the number 
of pathnames available in the DSS file and shown in the DSS Pathname 
list.  Pathnames Selected provides the number of pathnames currently 
selected from the file.  Pathnames in File shows the total number of 
records in the file, including files and images.  And finally, File Size 
displays the amount of disk space the file uses. 
 
 

2.1.5 Search Boxes 
 
Searches of the DSS pathnames can be made by full pathnames or by 
pathname parts.  These search methods are set through the View menu.   
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The selected search method will display a 
checkmark next to the menu option, see 
Figure 2.5. 
 
To search and display all pathnames 
containing a specific text, from the View 
menu click Search pathnames by string 
(Figure 2.6).  Then type the text into the 
Search Pathnames box and click Search.  
The pathnames in the file that contain the 
text will be displayed in the DSS Pathname 
table, see Figure 2.6. 
 
To search using DSS parts, select from the View menu click Search 
pathnames by parts (Figure 2.7).  Six Search By Parts filter boxes will  
 

 
Figure 2.6  Search Pathnames by String 
 
display, one for each DSS part.  The available part names contained in the 
selected DSS file are listed in the filter boxes.  When a part is selected in a 
filter box, only the pathnames that contain the filter text are shown in the 
DSS Pathname table (Figure 2.7). 
 

 
Figure 2.7  Search Pathnames by Parts 
 
 

2.1.6 List of HEC-DSS Pathnames 
 
Once you have opened an HEC-DSS file, its pathnames appear in a pane 
beneath the Search By filters (Figure 2.8).  The pathnames can be 
displayed as a pathname sorted list (Pathname List), by DSS Parts 
(Pathname Parts), in the Condensed Catalog format, with No 
Pathnames* displayed, or as an Unsorted List*.  These options are 
selected from the View menu (Figure 2.5), as described in Section 2.5.1.  
An example of Pathname by Parts is shown in Figure 2.8. 
 

Figure 2.5  View Menu 
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Figure 2.8  List of HEC-DSS Pathnames by Parts 
 

*Note:  The No Pathnames option is typically used to access 
very large databases using only scripted functions.  The 
Unsorted List option can be used to view pathnames in very 
large databases without the time required to sort the 
pathnames. 

 
 

2.1.7 Selected Pathnames 
 
When you select a pathname (see Section 2.6), it appears beneath the list 
of all pathnames in the Selection Area (Figure 2.9).  It includes the name 
of the DSS file followed by the full DSS pathname.  You can change the 
height of the Selection Area by grabbing the separator line between the 
two lists with your mouse, and moving it up or down.  Your mouse pointer 
will change to a double ended arrow when you are over the separator line, 
indicating you can slide the line up or down. 
 

 
Figure 2.9  Selected Pathnames 
 
You can also Quick Select pathnames if the Selection Area is empty by 
just highlighting pathnames from the main list with your mouse, and then 
selecting a function such as plot or tabulate.  The Selection Area must be 
empty to use Quick Select. 
 
 

2.1.8 Selection Buttons 
 
There are five buttons located below the Selection Area (Figure 2.10).  
They are as follows:  
 
 Select You add a pathname to the selection list by 

highlighting it and then clicking the Select  
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Figure 2.10 Select, De-Select, Clear Selections, Restore Selections, and Set Time 

Window Buttons 
 
  button.  The Select button will remain inactive 

until a pathname is highlighted.   
Tip:  You can also select pathnames by 
double-clicking on a pathname in the list 
or clicking on a pathname to highlight it, 
then click and hold the right mouse key 
and drag the pathname to the Selection 
Area. 

 
 De-Select To remove a pathname from the Selection 

Area list, highlight the pathname in the 
Selection Area then click the De-Select 
button.   

Tip:  You can de-select by double-
clicking on a pathname in the Selection 
Area list.   

 
 Clear Selections You can remove all pathnames from the 

Selection Area list by clicking the Clear 
Selections button. 

 
 Restore Selections The Restore Selections button restores all 

selections you have cleared or de-selected 
from the Selection Area list. 

 
 Set Time Window You can set the time window of the data to 

view with the Set Time Window button. 
 
 

2.2 Message Bar 
 
The Message Bar (Figure 2.11) appears at the bottom of the DSSVue 
main window and displays the current status.  Messages displayed in the 
bar include information on current processes or information regarding  
 

 
Figure 2.11  Message Bar 
 
settings within the current DSSVue main window, such as the Time 
Window.  For example, if the Time Window is set, the Time Window 
range will be displayed or if you are copying a large amount of data, the 
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status of the copy will be displayed in the Message Bar during the copy 
process. 
 
 

2.3 Drag and Drop 
 
HEC-DSSVue supports a variety of Drag and Drop operations.  You can 
drag pathnames from the main screen to any open table or plot to add 
those data sets to the table or curve.  You can copy data from one DSS file 
to another by dragging the pathnames of the data sets you want to copy to 
the tab of the file you want to copy to, or to the main window of another 
instance of HEC-DSSVue.  An example is shown in Figure 2.12. 
 

 
Figure 2.12  Copying data from one DSS file to another using Drag and Drop 
 
You can import data into a DSS file by dragging the data or files from 
Windows Explorer onto the HEC-DSSVue screen.  If you have a plug-in 
loaded that recognizes the file extension, that data will automatically be 
imported.  For example, you can drag a ".shef" file or ".ncdc" file to 
import shef data or import climate data from the National Climatic Data 
Center. 
 
You can drag regular files onto HEC-DSSVue and they will be stored in 
the FILE convention in that DSS file.  For example, you can drag a .pdf 
file or .xls file onto HEC-DSSVue to be stored in the DSS file.  When you  
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plot or tabulate those data sets, HEC-DSSVue will launch the native 
application for that data set. 
 
You can also drag pictures (e.g., ".jpg") files on to the main screen to store 
them, and then view them back as a slide show. 
 
 

2.4 File Menu Operations 
 
HEC-DSSVue's File menu allows you to create a New HEC-DSS file, 
Open an existing HEC-DSS file, Close DSS File(s) you have opened, 
show the Print Catalog Preview, Print Catalog, open a recently viewed 
file, and Exit the program.  If you are running HEC-DSSVue in a client-
server mode, you can Open a Remote file or create a New Remote file.  
The following sections discuss these operations in detail. 
 
 

2.4.1 Creating a New HEC-DSS File 
 
To create a new HEC-DSS database file, from the File menu, click New.  
When the Create new HEC-DSS File dialog box opens (Figure 2.13), 
select where you would like to create the file using the Look in list or file 
icons.  Type in a name for the new file in the File name box and then click  
 

 
Figure 2.13  Create new HEC-DSS File Dialog Box 
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the Create button.  A new HEC-DSSVue file will be created in the 
location you selected.  Data can then be added using the tools located 
under the Data Entry menu, copied in through the many different plug-ins 
available, or copied from other DSS files*. 
 

*Note:  If you copy records from an existing file, a new DSS file 
will be created automatically if one does not already exist. 

 
 

2.4.2 Opening an HEC-DSS File 
 
To open a DSS file, from the File menu, click Open.  The Open HEC-
DSS File browser will display, shown in Figure 2.14. 
 

 
Figure 2.14  Open HEC-DSS File Browser 
 

Note:  If you know the name of the HEC-DSS database file you 
wish to open, you can type the file name (including the path) 
directly into the File Name box on the main DSSVue window 
(see Figure 2.1, page 2-1). 

 
From the Open HEC-DSS File browser, use the standard Windows 
controls to browse to the HEC-DSS file that you wish to open, click 
Open.  
 
The name of the file you have selected will now appear in the File name 
box (see Figure 2.1, page 2-1), and the pathnames of the records contained 
in the file will display in the List of HEC-DSS Pathnames. 
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2.4.3 Closing an HEC-DSS File 

 
To close the currently selected HEC-DSS database file, from the File 
menu, click Close.  This will allow some older MS-DOS based programs 
to access the file or for you to rename or delete the file. HEC-DSS will 
automatically close un-accessed file files after about a minute.  They will 
be automatically re-opened on the next access. 
 

Note:  HEC-DSS is a multi-user database system.  Some older 
MS-DOS programs exclusively locked HEC-DSS files.  HEC-
DSS will automatically close un-accessed file files after about a 
minute.  They will be automatically re-opened on the next 
access. 

 
 

2.4.4 Printing the Catalog 
 
You can print the catalog of a DSS file directly (Print Catalog) or you 
can preview what the catalog will look like before you print (Print 
Catalog Preview).  For further printing of DSS catalogs, see Chapter 4. 
 
A catalog for the DSS file consists of a list of the pathnames contained in 
the file, similar to what is displayed in the DSS Pathname list area.  From 
the View menu the user can determine how the catalog will display the 
pathnames.  For example, the catalog could be displayed as a sorted list or 
by pathname parts.  The catalog for the currently selected DSS file can be 
printed or viewed in a separate window. 
 
To preview the catalog in a separate window and then print: 
 
 1. From the File menu, 

click Print Catalog 
Preview, a Properties 
dialog box will open 
(Figure 2.15) that is 
specific for setting up a 
report for printing.  The 
Properties dialog box 
offers various print 
options, on three 
separate tabs. 

 2. The Page tab allows 
you to specify the page 
Orientation, Scaling, 
and Selection; you can 
also choose to print the Figure 2.15  Properties Dialog Box 
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table as ASCII, Repeat Headers on every page, and print the 
Gridlines. 

 3. On the Header/Footer tab, you can type in the header and footer 
you want to appear on your printed pages. 

 4. The Table Title tab offers a default title for the table based on the 
data source.  You may edit this title. 

 5. Once the user has the report setup, click Preview, the Print 
Preview dialog box will open (Figure 2.16). 

 

 
Figure 2.16  Print Preview Dialog Box 

 
 6. To print the catalog, click Print, a Print dialog box will open, 

click OK, and the report will print to the selected printer. 
 
To preview the catalog in a separate window and then print: 
 
 1. From the File menu, click Print Catalog, a Properties dialog box 

will open (see Figure 2.15, page 2-11) that is specific for setting up 
a report for printing.  The Properties dialog box offers various 
print options, on three separate tabs. 

 2. From above, review Steps 2 thru 4 for available print options. 
 3. Click Print, a Print dialog box will open, click OK, and the report 

will print to the selected printer. 
 
 

2.4.5 Exiting HEC-DSSVue 
 
To exit HEC-DSSVue, from the File menu, click Exit.  (If you have 
opened HEC-DSSVue from another application, such as CWMS or 
ResSim, click Close from HEC-DSSVue's File menu.) 
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2.5 View Catalog 
 
The View menu allows you to change the appearance the catalog that is 
associated with a DSS file. 
 
 

2.5.1 Choosing a Display Mode for HEC-DSS Pathnames 
 
To specify the display mode for HEC-DSS Pathnames, choose Pathname 
List, Pathname Parts, Condensed Catalog, or No Pathnames or 
Unsorted List from the View menu.  A Pathname List of HEC-DSS files 
displayed is shown in Figure 2.17. 
 

 
Figure 2.17  HEC-DSSVue - Data Selection List window, Pathname List displayed 
 
You can also view the pathnames as a Pathname Parts List (Figure 2.18). 
 

 
Figure 2.18  HEC-DSSVue - Data Selection List window, Pathname Parts displayed 
 
The Condensed Catalog style (see Figure 2.19, page 2-14) abridges time 
series data sets so that the date span for the entire data set displays in place 
of the "D" part. 
 
The Unsorted List style (see Figure 2.20, page 2-14) displays the 
pathnames without sorting them.  This is useful to see the pathnames in a 
very large database without using the overhead of sorting.  This is also the 
fastest method to show the pathnames in a database. 
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Figure 2.19  HEC-DSSVue - Data Selection List window, Condensed Catalog displayed 
 

 
Figure 2.20  HEC-DSSVue – Data Selection List window, Unsorted List displayed 
 
 

2.5.2 Searching and Filtering HEC-DSS Pathnames 
 
With HEC-DSSVue, you can select specific data sets from a list of 
pathnames (or catalog) in the database.  You can refine the list by 
searching for either a string in the pathnames or for pathname parts.  The 
following sections describe searching and filtering options. 
 

 Searching Pathname Strings 
 
The Search Pathnames by String feature allows you to search for 
records whose pathnames contain specific strings of characters. For 
example, if you search for "FLOW" the list will display only pathnames 
containing the string "FLOW" in the pathname. 
 
To Search Pathnames by String: 
 
 1. From the View menu, click Search Pathnames by string. 
 2.  In the Search Pathnames box (see Figure 2.21, page 2-15), type 

the character string you want to filter the pathnames with.   
 3. Click Search. 
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Figure 2.21  Search Pathnames Box 
 
 

 Filtering HEC-DSS Pathnames by Parts 
 
The Search by Parts feature lets you choose specific pathname parts from 
those available in a HEC-DSS file.  
 
To Search by Parts: 
 
 1. From the View menu, click Search 

pathnames by parts. 
 2. Click on the down arrows beside the 

pathname parts you want to search.  
This allows you to view lists of 
available names in the file (Figure 
2.22).  

 3. When you have a pathname part list 
open, you can scroll through the list 
to locate the pathname part you want.   

 4. Click on a pathname part to select it. 
 5. To return to the previous list, click on the blank field at the top of 

the list. 
 
 

2.5.3 Refreshing the Catalog 
 
The catalog automatically refreshes whenever you add, delete, or rename 
records.  For very large files or network files, a dialog box will be shown 
asking if you want to create a new catalog.  When the catalog is refreshed, 
it re-inventories all records on disk to get a pathname for every record.  To 
generate a new catalog manually, click Refresh Catalog from the Edit 
menu. 
 
 

2.6 Selecting Pathnames 
 
Once you have filtered a HEC-DSS file for the pathnames you want, you 
select specific pathnames to visualize data for or perform a utility function 
on.  When you select a Pathname, it will appear in the Selected 
Pathnames List. 
 
There are several ways to select pathnames: 
 

Figure 2.22 Selecting Pathname 
Parts 
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 ■ Double-click on an individual pathname in the HEC-DSS 
Pathname List. 

 ■ Highlight a pathname in the HEC-DSS Pathname List then click 
Select (Figure 2.10).  Until you select a pathname, the Select 
button remains inactive.   

 ■ Click and drag your mouse to select a series of pathnames, and 
then click Select.  You can also use Ctrl+click to select multiple, 
non-consecutive pathnames. 

 ■ Hold down the Ctrl key and click on pathnames to highlight 
them, or hold down on the shift key to highlight all pathnames 
between mouse clicks, and then click Select. 

 ■ If you wish to select all of the pathnames, click Select All from 
the Edit menu. 

 ■ If no pathnames are selected, you can just highlight one or more 
pathnames and then perform the function that you intended.  If 
pathnames have already been added to the selection box, those 
pathnames will be used instead of the highlighted ones. 

 
 

2.7 De-Selecting Pathnames 
 
To de-select a pathname currently in the Selected Pathnames List: 
 
 1. Click the record's pathname in the Selected Pathnames List to 

select it. 
 2. Click De-Select, the pathname will no longer appear in the 

Selected Pathnames List. 
 
You can also de-select pathnames by double-clicking on a pathname in the 
Selection Area list. 
 
To remove all pathnames from the Selected Pathnames List, click Clear 
Selections.  To restore selections you have cleared, use Restore 
Selections. 
 
 

2.8 Visualizing HEC-DSS Data with Plots and Tables 
 
Once the Selected Pathnames List contains all the pathnames you wish to 
display, you can generate plots and tables. 
 
To create a plot or table from the Display menu, click Plot or Tabulate.  
You can also click the Plot      button or the Tabulate      button. 
 
From a plot window, you can also tabulate data using the Tabulate 
command in the plot's File menu.  Likewise, to open a plot from a table, 
you can use the Plot command in the table's File menu. 
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Examples of the plots and tables HEC-DSSVue can produce are shown in 
Figure 2.23. 
 

 
Figure 2.23  Example Plot and Table 
 
HEC-DSSVue plots are highly customizable.  You can add titles, specify 
colors and patterns of backgrounds and lines, change line styles, add 
markers and callouts, add borders to labels, and customize legends, axes, 
and tic marks.  For more information refer to Chapters 6. 
 
 

2.9 Groups 
 
Data sets can be assembled together in Groups.  Groups provide easy 
access of plotting, tabulating, and editing frequently accessed records 
without having to search for them in the DSS file.  The Groups capability 
is often used when the same time series data sets with different time 
windows are accessed frequently.  The Group information is stored in a 
text file in the User's Application Data area, under HEC-DSSSVue. 
 
The Groups menu option gives you the ability to create groups and access 
previously created groups.  The following sections describe the Groups 
menu options in detail. 
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2.9.1 Creating and Saving Groups 

 
To create a Group: 
 
 1. Select all the records you would like in the group in the Selected 

Area.  If you set a time window, that will be saved along with the 
group 

 2. From the Groups menu, click Save Selected.  The Input dialog 
will appear (Figure 2.24).  Type the group's name in the Enter 
group name box and click OK.  

 

 
Figure 2.24  Input Dialog Box 

 
 3. The Saved Group message (Figure 2.25) will appear when the g 

has been saved.  Click OK. 
 

 
Figure 2.25  Saved Group Message 

 
 4. The group will be saved and listed in the Groups submenus, see 

Figure 2.26. 
 

 
Figure 2.26  Group Submenus 
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2.9.2 Selecting Groups 

 
When a Group is selected, all the records contained in the group are 
added to the Selected Pathnames List.  To select a previously created 
Group, from the Groups menu, point to Get, select the name of the 
Group. 
 
 

2.9.3 Plotting Groups 
 
To plot a group, from the Groups menu, point to Plot, select the name of 
the group.  A plot window will appear plotting all the records contained in 
the group as shown in Figure 2.27 below. 
 

 
Figure 2.27  Group Plot 
 
If you would like to plot a group, but only display one record at a time in 
the plot, from the Groups menu, point to Plot Individual Sets, then the 
name of the group.  A plot window will appear that has a Select Data Set 
list (see Figure 2.28, page 2-20), listing all the records in the group.  The 
first record in the group will be selected in the Select Data Set list and the 
records data will be plotted.  To plot a different record in the group, 
simply select the record in the Select Data Set list and the current data in 
the plot will be replaced with the newly selected data. 
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Figure 2.28  Individual Data Set Plot 
 
 

2.9.4 Tabulate Groups 
 
To tabulate a group, from the Groups menu, point to Tabulate, select the 
name of the group.  A tabulate window will appear tabulating all the 
records contained in the group. 
 
 

2.9.5 Math Groups 
 
You can open the Math Functions Editor for a particular group of 
pathnames (data set) to perform math operations on the data sets within 
the group.  For more detailed information on the Math Functions Editor, 
see Chapter 7.  To use the Math Functions Editor, from the Groups 
menu, point to Math, select the name of the group.  The Math Functions 
Editor will open with the group's pathnames populating the Selected 
Data Set list. 
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2.9.6 Manage Groups 
 
Groups can be edited in the Manage Groups Editor (Figure 2.29).  In the 
Manage Groups Editor you can delete groups, add pathnames to a group, 
change the order of a group's pathnames, remove pathnames, and rename 
groups.  To access this editor, from the Groups menu, click Manage, the 
Manage Groups Editor will open. 
 

 
Figure 2.29  Manage Groups Editor 
 
 

2.10 Data Entry 
 
The Data Entry menu provides tools to add data to HEC-DSS files.  
Commands available through this menu allow you to manually create and 
add time series, paired and text data, and Import or Export data sets to 
and from an HEC-DSS file. 
 
 

2.11 Utilities 
 
The Edit menu provides a means for renaming, deleting, duplicating and 
copying data sets.  Data sets that have been deleted before the HEC-DSS 
file is squeezed can be recovered from the Un-delete dialog in the Edit 
menu.  Two HEC-DSS files can be merged into one using the Merge 
feature. 
 
The Tools menu facilitates additional tools to help manipulate and manage 
the data contained in HEC-DSS files.  These tools include: Math 
Functions, Data and File Comparing, Search, Integrity Check, and 
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Scripting.  You can also remove excess disk space and optimize the file 
with File Squeeze. 
 
The Advanced menu provides access to the traditional HEC-DSS 
catalogs.  From here you can generate, view, and print an abbreviated 
catalog, a condensed catalog or a complete catalog.  You can also view the 
output log, reset the program defaults, and set HEC-DSS options, as well 
as several internal tools. 
 
 

2.12 Custom and Scripting Menus 
 
Menus can be added to HEC-DSSVue's main menu for plug-ins and 
scripting.  The Script Editor has a checkbox to activate the Script menu 
and add the script you are editing to that menu.  This is a convenient way 
to access a large number of scripts that are used frequently. 
 
If you have several customized operations that are preformed through 
plug-ins, you can have those functions show up on a menu that you name. 
 
 

2.13 Plug-Ins 
 
HEC-DSSVue has the capability of accepting Java jar plug-ins.  A plug-in 
is essentially compiled Java code that has been written to extend the 
capability of HEC-DSSVue.  It is similar to a script, but can be more 
powerful and more customizable.  For example, a plug-in might retrieve 
data, decode it and store it into a HEC-DSS file.  Another use might be to 
perform sophisticated math functions on data selected from the main 
screen. 
 
Plug-ins are added by placing the jar plug-in file in the HecDssVue/ 
Plugins directory.  When HEC-DSSVue is executed, it searches this 
directory for available plug-ins and loads them into the program.  Most 
plug-ins will add a button to the main toolbar, adjacent to any script 
buttons.  To remove a plug-in, simply remove its jar file from the Plugins 
directory. 
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