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Foreword 
 
 
 
 
 
The Hydrologic Engineering Center’s Flood Damage Reduction Analysis 
(HEC-FDA) program provides state-of-the-art analysis for formulating and 
evaluating flood damage reduction plans using risk-based analysis 
methods.  It is one of HEC's "Next Generation" (NexGen) of hydrologic 
engineering and water resources planning software.  The NexGen project 
encompasses:  rainfall-runoff analysis (HEC-HMS), river hydraulics (HEC-
RAS), reservoir system analysis (HEC-ResSim), flood damage analysis 
(HEC-FDA), and real-time river forecasting for reservoir operations.  The 
NexGen software has a windows style user interface and operates on 
Windows XP and Windows NT. 
 
The HEC-FDA program replaces HEC's previous PC version Flood 
Damage Analysis package containing programs SID, SIDEDT, FDA2PO 
and EAD (April 1994).  The new HEC-FDA program contains enhanced 
versions of all their features plus risk-based analysis procedure for 
formulating and evaluating flood damage reduction measures. 
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CHAPTER 1  
 
 
 

Introduction 
 
 
Welcome to the Hydrologic Engineering Center’s Flood Damage 
Reduction Analysis (HEC-FDA) computer program.  This program allows 
you to perform plan formulation and evaluation for flood risk management 
studies.  It includes risk analysis methods that follow Federal and Corps of 
Engineers policy regulations (ER 1105-2-100 and  
ER 1105-2-101). 
 
Both economic flood damage and hydrologic engineering analyses are 
performed using a consistent study configuration (streams, damage 
reaches, plans, and analysis years).  Three types of evaluations are 
available:  analysis of damage, project performance by analysis years; and 
equivalent annual damage.  Many output tables and plots are used for 
reporting results.  Computations and display of results are consistent with 
technical procedures described in EM 1110-2-1619. 
 
This chapter discusses the purpose of FDA, gives a brief overview of the 
program requirements, capabilities, and the content of this user's manual. 
 
Contents 
 
 ● Purpose of HEC-FDA 
 ● Program Capabilities 
 ● Overview of User's Manual 
 
 

1.1 Purpose 
 
The FDA program provides the capability to perform an integrated 
hydrologic engineering and economic analysis during the formulation and 
evaluation of flood risk management plans.  The program follows 
functional elements of a study involving coordinated study layout and 
configuration, hydrologic engineering analyses, economic analyses, and 
plan formulation and evaluation.  You use it continuously throughout the 
planning process as the study evolves from the base year without-project 
condition analysis through the analyses of alternative plans over their 
project life.  Hydrologic engineering and economics (flood inundation 
damage analyses) are performed separately, in a coordinated manner after 
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specifying the study configuration and layout, and merged for the 
formulation and evaluation of the potential flood damage reduction plans. 
 
 

1.2 Program Capabilities 
 
FDA is an integrated system of software that is designed for interactive 
use.  The program consists of a graphical user interface (GUI), hydrologic 
engineering and economics components, database and management 
capabilities, graphics and reporting facilities. 
 
 

1.2.1 Computation Procedures 
 
The Corps of Engineers requires the use of risk analysis procedures for 
formulating and evaluating flood damage reduction measures (EM 110-2-
1619, ER 1105-2-101).  These documents describe how to quantify 
uncertainty in discharge-exceedance probability, stage-discharge, and 
damage-stage functions and incorporate it into economic and engineering 
performance analyses of alternatives.  The process applies Monte Carlo 
simulation, a numerical-analysis procedure that computes the expected 
value of damage while explicitly accounting for the uncertainty in the 
basic parameters used to determine flood inundation damage.  HEC has 
developed the FDA computer program to assist in analyzing flood risk 
management plans using these procedures.  Refer to Appendices E and F 
for descriptions of the analysis process used by FDA.  (EM 110-2-1619 
provides more detailed descriptions of the analysis procedures used by 
FDA.) 
 
FDA performs all the computations that were available in the old FDA 
batch program plus risk analysis and other enhancements.  Inventories of 
floodplain structures are used to calculate damage-stage-uncertainty 
information at damage reach index locations.  Expected and/or equivalent 
annual damage are computed in the evaluation portion of the program. 
 
 

1.2.2 Database 
 
FDA uses a relational database to store data and output for reports and the 
database is the central part of FDA.  The xBase format was chosen for the 
program because it is:  1) an adopted industry standard; 2) compatible with 
the file structure found in commercial software; and, 3) functional in the 
multiple platform environments.  The database operations require use of 
internal identifiers to relate the program's data sets.  This presents special 
design considerations to avoid potential database corruption from affects 
of multiple users. 
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1.2.3 User Interface 
 
The interface is designed to make the program easy and efficient to use.  
The interface provides the following functions: 
 
 ● File management 
 ● Data entry and editing 
 ● Data selection and assignments 
 ● Hydrologic and economic analyses 
 ● Tabular and graphical displays of input and output data 
 ● Reporting facilities 
 ● On-line help 
 
 

1.2.4 Data Entry 
 
You can enter data in a variety of ways using FDA.  The most common is 
using text fields on the program's dialog boxes.  This is also called the 
"form" method.  Certain dialog boxes have an alternative data entry called 
"tables."  The same data entered on the form can instead be entered into a 
spreadsheet-like table.  Some dialog boxes have import capabilities.  For 
example, water surface profiles may be imported from the HEC River 
Analysis System package (HEC-RAS, USACE 2002) or Water Surface 
Profiles program (HEC-2, USACE 1991).  The structure inventory can be 
imported from the Structure Inventory for Damage Analysis program 
(HEC-SID, USACE 1989) or from ASCII delimited text files. 
 
 

1.2.5 Analysis Results 
 
A number of analysis results are available for review of computations and 
evaluation of results.  Project performance, damage by analysis years, and 
equivalent annual damage are included in the results.  Output includes 
tables and selected graphics of information by plan, analysis year, stream, 
and damage reach for the entire plan.   Plan comparisons may also be 
performed. 
 
 

1.3 User's Manual Layout 
 
This user's manual is the primary documentation on how to use the FDA 
program. The manual is organized as follows: 
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 ● Chapter 1 provides an introduction to FDA. 
 ● Chapters 2 provides an overview and describes the general layout of 

the FDA program.  Also, provides an overview of the analysis steps 
in FDA and how to define a study. 

 ● Chapter 3 describes the Study Configuration portion of FDA.  
This includes defining the streams, damage reaches, plans, and 
analysis years for a study in FDA. 

 ● Chapters 4 through 7 describe the Hydrologic Engineering 
(HydEng) portion of FDA.  Chapter 4 provides an overview of 
HydEng and describes defining water surface profiles for a study.  
Chapter 5 provides information on defining exceedance probability 
functions.  Chapter 6 describes defining stage-discharge functions.  
Chapter 7 provides information on defining levees in FDA. 

 ● Chapters 8 through 12 describe the Economics portion of FDA.  
Chapter 8 provides an overview of Economics and describes 
defining damage categories.  Chapter 9 provides information on 
defining structure occupancy types.  Chapter 10 describes defining 
structure modules.  Chapter 11 provides information on the 
structure inventory for a study.  Chapter 12 provides information on 
stage-damage functions. 

 ● Chapter 13 provides information on the computation process that is 
available from the FDA. 

 ● Chapter 14 describes the available reports in FDA that are a result 
of the evaluation of plans by analysis years computations. 

 ● Chapter 15 describes further details on the other available FDA 
reports. 

 ● Chapter 16 provides troubleshooting information for FDA. 
 ● Several appendices are included for assistance.  Appendices A and 

B provide references and a glossary, respectively.  Appendix C 
describes procedures for importing water surface profiles.  
Appendix D describes the levee wave overtopping analysis 
procedures.  Appendix E provides details on how to import data 
into an FDA study.  Appendix F provides an overview of the 
economic flood damage procedures.  Appendix G provides an 
overview of ASCII tab delimited files that are available from the 
economic flood damage procedures.  Appendix H describes the 
Monte Carlo Simulation methodology used for computing expected 
and equivalent annual damage. 
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CHAPTER 2  
 
 
 
 

Working with HEC-FDA – An Overview 
 
 
 
HEC-FDA is an interdisciplinary program used to formulate and evaluate 
flood damage reduction plans.  You interact with FDA through a graphical 
user interface (GUI).  The program performs economic (flood inundation 
damage analysis) and hydrologic engineering performance computations 
for plan evaluations. 
 
In FDA terminology, a study is a set of data files associated with a 
planning evaluation.  The study includes all streams and damage reaches 
to be analyzed as part of the study area.  You can perform any or all of the 
analyses available in the FDA program as part of the study.  Only one 
study is open at a time. The files associated with the study contain 
information on plans, analysis years, streams, damage reaches, damage 
categories, structures, etc.  The files are stored together in one 
subdirectory as xBASE formatted database files.  The directory is named 
when a new study is created.  The directory is a subdirectory of the FDA 
directory (c:\Program Files\hec\fda). 
 
During the course of a study, you may formulate and evaluate several 
different plans.  The first plan is always the without-project condition.  
Additional plans may contain levees, reservoirs, channels, non-structural 
measures, and other measures or combinations thereof.  You can easily 
formulate new plans once the basic data are entered.  The results can be 
compared after the analyses of various plans are performed. 
 
This chapter provides an overview of how a study is performed within 
FDA. 
 
Contents 
 
 ● Starting HEC-FDA 
 ● General Layout 
 ● Analysis Steps 
 ● Additional Program Concepts 
 ● Exiting the Program 
 
 

A study is a set of 
data files 
associated with a 
planning 
evaluation. 



Chapter 2 – Working with HEC-FDA – An Overview HEC-FDA User's Manual 

2-2 

2.1 Starting HEC-FDA 
 
When starting FDA, double-click the HEC-FDA icon on your desktop, or 
from the taskbar click Start, point to Programs, point to HEC, and then 
click FDA.  The main window of FDA will appear (Figure 2.1).  You are 
now ready to start using FDA. 

 
 

2.2 General Layout 
 
The FDA main window is organized to allow you to enter data, review 
data, edit data, compute, and view results.  The Menu Bar contains the 
following menus: 
 
 File This menu is used for file management and contains the 

following commands:  New Study, Open Study, Delete 
Study, Normalized Export, Merge, Study Info, and 
Exit. 

 
 Configure This menu is used to enter information about the study 

configuration and contains the following commands: 
Study Streams, Study Damage Reaches, Study 
Analysis Years, and, Study Plan Definition, 

 
 HydEng This menu is where you enter data needed for hydrologic 

and hydraulic analyses. Available commands are:  Study 
Water Surface Profiles, Exceedance-Probability 
Function with Uncertainty, Stage-Discharge 
Functions with Uncertainty, and, Levee Features. 

 
 Economics This menu is used to enter the information needed for 

economic analyses.  Available commands are:  Study 
Damage Categories, Study Structure Occupancy 
Types, Structure Modules, Structure Module 
Assignments, Structure Inventory 
Data,Enter/Edit/View Reach Stage-Damage Function 

Figure 2.1  HEC-FDA Main Window 
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with Uncertainty, Compute Reach Stage-Damage, 
Import, and Export. 

 
 View This menu provides results of the input that you have 

entered.  Available commands are:  List of Streams, 
List of Damage Reaches, List of Plans, List of 
Damage Categories, List of Structure Modules, and, 
List of Structures Occupancy Types. 

 
 Evaluation You compute and evaluate economic and engineering 

performance under this menu item. The computations 
are performed by plans and analysis year or by plan 
equivalent annual damage. Hydrologic engineering 
project performance by plans is also computed. Output 
reports and selected plots are available for viewing 
results and comparing plans.  Available commands are:  
Study Status Report, Evaluation of Plans by Analysis 
Year, Equivalent Annual Damage Analysis, and 
Results. 

 
 Help This menu item allows you to get on-line help, as well as 

display the current version information about FDA. 
 
 

2.3 Analysis Steps 
 
These steps are used in formulating and evaluating plans with FDA: 
 
 ● Define a study (File menu) for both with- and without-project 

conditions.  This is a team effort. 
 
 ● Enter study configuration data (Configure menu).  This is a team 

effort. 
 
 ● Enter hydrology and hydraulics data (HydEng menu).  Performed 

by the hydrologic and hydraulics team members, normally 
concurrent with the economic analyses. 

 
 ● Enter economics data and/or compute aggregated stage-damage 

functions (Economics menu).  Performed by the economics team 
members, normally concurrent with the hydrology and hydraulics 
analyses. 

 
 ● Perform the expected annual damage/equivalent annual damage 

calculations (Evaluation menu).  Normally performed and 
reviewed by the study team. 
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2.3.1 Define a Study 
 
You define a new study or open an existing 
study from the File menu.  Once a study is 
opened, the filename, title, and description of 
the study will always appear on the main 
window.  Figure 2.2 shows the available 
command from the File menu. 
 
 New Study To create a new study, on 

the File menu, click New 
Study, the Create New 
Study dialog box will 
open (Figure 2.3).  The 
Create New Study dialog 
box has a default study filename extension (*.sty), 
directories and drive (c:\Program Files\hec\fda).  You 

can store the study anywhere on the hard disk.  
However, it is recommend the study be a subdirectory 
of the program directory.  The study filename extension 
can not be changed.  Once the filename is entered, a 
new subdirectory is created with that name.  All 
database files are then created. 

 
  After the study information is entered, click Save, the 

Study Information dialog box will open (see Figure 
2.4, page 2-5).  From the Study Information dialog 
box, you provide information about the study including: 
a title; a description; notes about the study; and price 
index information.  The information is used on various 
dialog boxes and reports throughout the program.  You 
choose the numeric monetary units to be used for all 
study data entry and output reports. 

 

Figure 2.2  File Menu 

Figure 2.3  Create New Study Dialog Box 
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  The Monetary Units list (Figure 2.4) allows you three 
choices ($, $1,000's, $1,000,000's) for monetary units.  
For example, $1,000's (the default) indicates all values 
will be in $1000's.  These are used as labels only. 

 
  System Units (Figure 2.4) is a flag indicating that all 

units for the study data entry and output reports will be 
either SI (metric) or English.  These are also used as 
labels only.  No conversions are made in the program. 

 
  Price information allows you to globally adjust the 

price data from the year the damage survey data was 
compiled to an updated year.  In the Surveyed Year 
box (Figure 2.4), enter the year associated with the 
original structure inventory survey flood damage 
values.  It must be a numeric four digit value greater 
than 1900.  It is used as a label only. 

 
  In the Updated Year box (Figure 2.4) enter the price 

year associated with the updated price index.  It is also 
a numeric four digit value.  It must be greater than or 
equal to the surveyed year (default is surveyed year). 

 
  In the Updated Price Index box (Figure 2.4) enter the 

updated price index used to update all economic 
(structure damage) values to present (or other) values.  
It can be any numeric value between 0.00 and 100.00.  
If blank, it is assumed to be the same index value as the 
surveyed year with no adjustments made to the 
economic data.  This value can be overridden by 
damage category, see Chapter 8 for further information. 

 

Figure 2.4  Study Information Dialog Box 
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 Open Study To open an existing study, on the File menu (see Figure 
2.2, page 2-4), click Open Study, the Open Study 
dialog box will open (Figure 2.5).  A list of previously 
defined studies will appear on the dialog box.  You 
double click on the study filename (filenames with the 
extension "*.sty") to retrieve a study. 

 
 Delete Study To delete the open study, on the File menu (see Figure 

2.2, page 2-4), click Delete Study.  A warning message 
will appear asking you if you really want to delete this 
study, click Yes.  All files stored in the study 
subdirectory, and the study filename (".sty") above the 
study subdirectory will be deleted. 

 
 

2.3.2 Study Configuration 
 
Configure is where you configure the physical study layout and define 
plans for analysis for the study.  The data defined are in common with all 
analyses.  You define the study 
streams, damage reaches, plans, 
analysis years as shown in 
Figure 2.6. 
 
When performing a study, it is 
important that all study 
members agree on the study 
configuration.  Hydrologic 
engineers, economists, and study 
managers must work together to develop the configuration.  The study 
configuration consists of those data items that are not likely to change 
during a study.  Chapter 3 contains a more detailed description of the 
study configuration data. 
 
 

Figure 2.5  Open Study Dialog Box 

Figure 2.6  Configure Menu 

Study 
Configuration is 
where you 
configure the 
physical study 
layout and define 
plans for analysis 
for the study.  
This is a team 
effort. 
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2.3.3 Hydrologic Engineering 
 
Hydrologic Engineering (HydEng) is where you define the hydraulics 
and hydrology data needed to evaluate plans (Figure 2.7).  You can 
specify sets of 
water surface 
profiles by stream 
for each plan and 
analysis year to be 
analyzed.  
Exceedance 
probability 
functions, stage-
discharge functions, and levee features are also defined under HydEng.  
Chapter 4 provides further discussion on the hydrologic and hydraulic 
information required by FDA. 
 
 

2.3.4 Economics 
 
Economics (Figure 2.8) is where you define the economic data needed to 
evaluate the defined plans.  The data includes: damage categories; 
structure occupancy types; structure inventory data, and stage-damage 
functions.  Damage categories and structure occupancy types are defined 

for the entire study.  You may enter the stage-damage functions with 
uncertainty directly by plan, year, damage reach, and damage category or 
you may compute the aggregated values based on the structure inventory 
data, water surface profiles, and uncertainty specifications.  Chapter 8 
provides a more detailed description of the economic information required 
by FDA. 
 
 

Figure 2.7  HydEng Menu 

Figure 2.8  Economics Menu 

Hydrologic 
Engineering is 
where you define 
the hydraulics 
and hydrology 
data needed to 
evaluate plans.  
Performed by the 
hydrologic and 
hydraulics team 
members, 
normally 
concurrent with 
the economic 
analyses. 

Economics is 
where you define 
the economic data 
needed to 
evaluate the 
defined plans.  
Performed by the 
economics team 
members, 
normally 
concurrent with 
the hydrology and 
hydraulics 
analyses. 
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2.3.5 Evaluation 

 
Evaluation (Figure 2.9) is 
where you compute results 
for expected annual 
damage, equivalent annual 
damage, and project 
performance by plan and 
analysis year using the risk 
analysis approach.  The 
Evaluation of Plans by 
Analysis Year dialog box (Figure 2.10) provides information on the 
computations of expected annual damage by plan and analysis year.  
Chapter 13 provides further information about the computational 
procedures for FDA. 

 
A series of output reports are available once the computations are 
successfully completed.  The Results submenu (Figure 2.11) provides 
commands for viewing the computation results.  They include expected 
annual damage 
(plans by analysis 
years), equivalent 
annual damage, 
and project 
performance.  You 
may view the 
results of computational information summaries by specifying analysis 
reports by plans, years, streams, and damage reaches.  Chapter 14 provides 
further information on the results available from FDA. 
 
 

Figure 2.9  Evaluation Menu 

Figure 2.10  Evaluation of Plans by Analysis Year Dialog Box 

Figure 2.11  Results Submenu 

Evaluation is 
where you 
compute results 
for expected 
annual damage, 
equivalent annual 
damage, and 
project 
performance by 
plan and analysis 
year using the risk 
analysis 
approach.  
Normally 
performed and 
reviewed by the 
study team. 
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2.4 Program Concepts/Capabilities 
 
 

2.4.1 Normalized Export 
 
A procedure which converts data stored in the database memo fields to 
database tables.  This enables the data to be viewed and manipulated with 
other commercial databases or spreadsheets.  A subdirectory named 
"export" is created under the study subdirectory. 
 
 

2.4.2 Merge 
 
The Merge option allows you to make copies of the database (base copy), 
enter/edit data on the copies (incoming copy), and merge the results from 
the incoming copy back to the base copy.  It's designed for the various 
hydrologic engineering and economics disciplines of the study team to 
work in parallel on separate work stations and to then merge the data 
together for analyses.  It ensures that the resulting merged database does 
not have any inconsistencies or redundant data.  There are different rules 
for the two types of merge - Hydrologic Engineering and Economics. 
 
 HINT:  We strongly recommend that you backup your study prior to 

performing the merge operation. 
 
The first step in Merge is to make a copy of the study .sty file (i.e., 
BearTrng.sty) and the study subdirectory (i.e., BearTrng) which contains 
the database files.  The name that is given to the .sty file must be the same 
name given to the directory (i.e., xxx.sty and xxx), and both must be in the 
same parent directory.  Copying the study files is performed outside the 
HEC-FDA package using other utilities.  The process is: 
 
 ● Create a new directory (xxx), which will store the incoming copy. 
 ● Copy the entire contents of the base copy (BearTrng) into the 

directory "xxx". 
 ● Copy the base copy's study file (BearTrng.sty) to xxx.sty. 
 
Copies may be made to CD-ROM or another medium for different study 
disciplines to use.  We recommend that the incoming copy (xxx) be copied 
to the hard disk when using the study. 
 
Changes to the configuration files (items under the Configure Menu) of 
the incoming copy (xxx) are not allowed and will fail the merge.  Only the 
base copy (BearTrng) can have changes to the configuration files.  These 
changes may be additions only.  If deletions are made to the base copy 
(BearTrng), then the merge will fail. 
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Changes to hydrology/hydraulics (HydEng) data can only be made to the 
incoming copy (xxx).  If changes are made to the base copy (BearTrng) 
and a Hydrology Merge is done, the changes to the base copy (BearTrng) 
will be lost. 
 
The Economic Merge works only with structure information, i.e., the 
structure occupancy type (depth-percent damage functions), structure 
inventory, and direct depth-dollar damage functions.  Additions can be 
made to both the base (BearTrng) and the incoming (xxx) copies.  If the 
name of a data item is the same for the base (BearTrng) copy and the 
incoming (xxx) copy, the latter is ignored.  Editing should be done to the 
base (BearTrng) copy.  When an Economics Merge is done, the stage-
damage functions are cleared from the base (BearTrng) copy. 
 
Damage categories are considered a configuration item for Merge and 
changes should only be made to the base (BearTrng) copy. 
 
 

2.4.3 Save, Add/Update, Cancel, and Close 
 
You save new data/information to the database by pressing the Add or 
Save Button.  The Add Button converts to the Update Button when 
returning to a dialog box where existing data are present.  After editing 
existing data, the Update Button is pressed to save the information to the 
database.  The Cancel Button cancels any changes made to the data and 
returns the dialog box to its original state.  You close a dialog box by 
selecting Close under the File menu. 
 
 

2.4.4 Navigator Button 
 
The Navigation Button, (Figure 2.12) is 
available on several dialog boxes to allow 
quick movement through a data entry 
record list.  Examples of data lists are streams, plans, and damage reaches. 

 
The << symbol places you at the top (first) record of the list, while the >> 
symbol places you at the bottom (last record).  The < (previous) symbol 
and the > (next) symbol move you back one record and forward one 
record in the list, respectively.  The center of the navigation button 
indicates the number of records in the list and which record you are 
presently accessing.  You create a new record (blank out data fields) by 
pressing on the center of the button. 
 
 
 
 

Figure 2.12  Navigation Button 
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2.4.5 Assignments 
 
Computations for expected and equivalent annual damage and project 
performance are performed using the exceedance probability, stage-
discharge, and stage-damage functions.  They must be defined for each 
damage reach index location for each stream, plan, and analysis year.  The 
definition specification is referred to as an assignment in FDA.  The 
capability to define (assign) functions and information to physical stream 
locations (streams, damage reaches) and specific plans (plans, analysis 
years) is an integral part of the program design.  Assignment items are 
located at the top of some of the dialog boxes 
 
For most data items or functions that require assignments, there is a report 
available that list the assignments.  An (*) indicates an assignment is made 
but that some required data are missing.  An (****) indicates that no 
assignment has been made.  A (+) means that the data are out-of-date, i.e., 
the data to generate a function or output report has been changed. 
 
Often it is desirable to use the same function for several plans and or 
analysis years. For example, the without-project condition base year stage-
discharge function for damage reach 1 may be used for Plans A and C for 
both the base year and most likely future year with- and without-project 
conditions. Table 2.1 lists the possible assignment items and associated 
copy combinations permitted for multiple assignments. The program 
filters the copies as shown in the table. 
 

Table 2.1 
Permitted Functions/Features Copying for Different Assignments 

 
HEC-FDA 

Function/Feature 
 

Plan 
Analysis 

Year 
 

Stream 
Damage 
Reach 

Damage 
Category 

Water Surface Profiles Yes Yes No N/A N/A 
Discharge- or Stage-
Probability 

Yes Yes No Yes N/A 

Stage-Discharge Yes Yes No Yes N/A 
Stage-Damage Yes Yes No No No 
Levee Yes Yes No No N/A 

 
Unique functions are copied from one plan to another by the Use Existing 
Function command.  You may use (copy) the entire function assignments 
of one plan to another by selecting the Global Assignment Copy 
command.  For example, you may wish to use the same exceedance 
probability functions, or ratings, or stage-damage for different plans that 
have several damage reaches.  You may use the Global Assignment Copy 
command to perform the assignment operations. 
 
 

An assignment is 
where a function 
is defined for each 
damage reach 
index location for 
each stream, plan, 
and analysis year.  
The capability to 
define (assign) 
functions and 
information to 
physical stream 
locations 
(streams, damage 
reaches) and 
specific plans 
(plans, analysis 
years) is an 
integral part of 
FDA. 
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2.4.6 Non-Modality 
 
A powerful capability of using a graphical user interface is the ability to 
view and interact with multiple dialog boxes at a time.  Version 1.2.4 of 
FDA is primarily non-modal; meaning many of the dialog boxes can be 
opened simultaneously.  However, FDA dialog boxes under the Study 
Configuration men (streams, damage reaches, plans, and analysis years), 
Damage Categories and Structure Occupancy Types under the 
Economics menu are modal-only, i.e., only one dialog box may be active 
or viewable at a time.  This is due to the potential corruption of the 
database if certain operations are performed for these dialog boxes when 
multiple dialog boxes are open. 
 
 

2.4.7 Study Backup 
 
You should keep a current backup of the study subdirectory containing the 
study data.  The .sty file under the main directory should also be included.  
If for some reason your database becomes corrupted, you should delete the 
subdirectory and copy your backup to a new subdirectory of the same or 
different name. 
 
 

2.4.8 Help Menu 
 
Help (Figure 2.13) is where you can find 
information that will help you in using 
FDA and creating a study.  The 
Contents, Search for Help On…, Using 
Help items are standard help options for 
FDA.  Also, About HEC-FDA (Figure 
2.14) provides information on version, 
office location, and view a license 
agreement. 

 

Figure 2.13  Help Menu 

Figure 2.14  About FDA Dialog Box 
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2.4.9 On-line Help 

 
On-line or context sensitive help is available throughout the program.  By 
using the Fl key, on several of the FDA dialog boxes you can retrieve 
specific help on the dialog box or on a data entry item.  By clicking on a 
particular data item of a dialog box, then clicking F1, you will be provided 
with on-line help for that item. 
 
 

2.4.10 Printing 
 
You may choose to print lists of data entry information reports, 
assignments reports, and output reports, and plots.  The program uses the 
operating system printers and printer setup.  Although many dialog boxes 
contain the printer setup menu item, you should modify printer settings 
from the print menu item.  The program does not remember the settings 
selected from the printer setup dialog boxes. 
 
 

2.4.11 Warning Messages 
 
Warning messages are invoked throughout the program to assist with 
data entry and program operations.  A log of warning messages associated 
with program execution is available and recommended for review. 
 
 

2.5 Exiting Program 
 
You exit the program from the File menu.  The study data is then stored in 
a subdirectory under the study file name. 
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CHAPTER 3  
 
 

Study Configuration 
 
 

3.1 General 
 
Study Configuration (Config) contains the data describing the physical 
layout for the study area and plan definition for analysis.  Data includes 
streams, damage reaches, plans and analysis years.  Prior to using  
HEC-FDA, team members must define the physical layout of the study: 
i.e., study streams and damage reach locations.  Next, plans and analysis 
years for the study area are defined.  A study coordinated stream 
stationing convention is required and must be used by all disciplines. 
 
Note:  Hydrologic engineers, economists, and study managers must work 
together to develop the configuration and concur on the information used 
prior to analysis. 
 
Study configuration consists of data items seldom changed during a study.  
Data changes at a later time, may affect other hydrologic engineering or 
economic data previously entered.  For example, discharge-exceedance 
probability, stage-discharge and damage-stage functions are required at 
each damage reach index location for each plan and analysis year to 
perform the Monte Carlo computations.  Adding and deleting study 
configuration data directly affects the functions previously entered or 
those that need entering. 
 
To define the study configuration, all study team members should meet 
and agree on the required information.  Decisions are made on the system 
of units and monetary units (defined in Study Information dialog box, 
see Chapter 2, page 2-5).  Then using maps and other available 
information, team members should decide on the streams, initial damage 
reach delineations, stream station conventions, index locations, analysis 
years, plans, and naming conventions. 
 
The dialog boxes you will use to input data for the study configuration 
have a common Menu Bar.  The Menu Bar contains the following 
common menus, for a description of the Help menu see Chapter 2 
(Section 2.4.8, page 2-12): 
 
 File This menu is used for file management and contains the 

following commands: 

Study 
Configuration 
contains the data 
describing the 
physical layout 
for the study area 
and plan 
definition for 
analysis.  Data 
includes streams, 
damage reaches, 
plans and 
analysis years. 
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 Add/Update: you either update (edit) an existing study 
configuration data item (stream, damage reach, plan) 
information or add a new study configuration data item to 
the study. 

 Close: close the open dialog box; if changes have not been 
saved a warning message will appear. 

 
 Edit This menu is used for editing study configuration data items, 

traversing the records in a study configuration data item list, 
creating study configuration data items, and deleting study 
configuration data items.  The commands available are: 

 Cut/Copy/Paste: the standard cut/copy/paste commands 
 First Record: places you on the first record of the study 

configuration data item list 
 Last Record: places you on the last record of the study 

configuration data item list 
 Next Record: places you on the next record of the study 

configuration data item list 
 Previous Record: places you on the previous record of the 

study configuration data item list 
 New Record: creates a new study configuration data item 

record 
 Delete Record: deletes the selected study configuration 

data item from the list 
 
 View This menu is used to review what study configuration data 

items have been created for the study; there is only one 
command - List of Study Configuration Data Items. 

 
 
Contents 
 
 ● Streams 
 ● Damage Reaches 
 ● Plans 
 ● Analysis Years 
 
 

3.2 Streams 
 
Streams include various water bodies such as rivers, streams, creeks, 
ditches, canals, bayous, lakes, ponds, etc.  Streams are defined for the 
study and are therefore common for all plans and analyses.  A study may 
include one or more streams.  A stream station convention must be 
adopted for the study.  It is used to define damage reach boundaries, 
damage reach index locations, water surface profiles, cross-sectional  

Streams are 
defined for the 
study and are 
therefore common 
for all plans and 
analyses. 
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locations, and structure locations.  Figure 3.1 depicts a stream network for 
a study area. 
 

 3. Enter a nam  list.  The maximum 
len

 4. ecommended) in the Description 

 

Little Creek

Jones Creek
Big 

River

Damage 
Reach 1

Damage 
Reach 2

Damage 
Reach 4

Damage 
Reach 3

Figure 3.1  Stream and Damage Reach Concepts 

3.2.1 Create Streams 
 
To create streams: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Streams. 
 2. The Study Streams dialog box will open (Figure 3.2). 

Figure 3.2  Study Streams Dialog Box 

e (required) in the Stream Name
gth is sixteen (16) characters. 

Enter a description (optional but r
box.  The maximum length is sixty-four (64) characters. 

 5. Click Add, the stream is added, and you can enter additional 
streams if you wish. 
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 6. When you are finished with entering your streams, on the File 
menu, click Close, the Study Streams dialog box will close (see 
Figure 3.2, page 3-3). 

 
Additional ways to create streams are provided from the Study Streams 
dialog box (see Figure 3.2, page 3-3): 
 
 ● On the Edit menu, click New Record, you can now enter a new 

stream from the Study Streams dialog box (see Figure 3.2, page  
  3-3). 

-or- 
 ● From the Navigator Button (see Chapter 2, Section 2.4.4, page  
  2-10), click the center of the button; you can now enter a new 

stream from the Study Streams dialog box (see Figure 3.2, page  
  3-3). 
 
 

3.2.2 Edit Streams 
 
Edit streams that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Streams. 
 2. The Study Streams dialog box will open (Figure 3.3). 

 3. From the Stream Name list select the stream you want to edit and 
make the necessary updates. 

 4. Click Update , the changes are saved for the selected stream. 
 5. When you are finished with editing your streams, on the File menu, 

click Close, the Study Streams dialog box will close (Figure 3.3). 
 
 

Figure 3.3  Study Streams Dialog Box - Update Button 

3.2.3 Delete Streams 
 
Delete streams that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Streams. 
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 2. The Study Streams dialog box will open (see Figure 3.3, page 3-4). 
 3. From the Stream Name list select the stream you want to delete. 
 4. On the Edit menu, click Delete Record.  A warning message will 

appear asking you if you really want to delete the stream.  Click 
Yes, the stream will no longer be available. 

 5. When you are finished with deleting streams, on the File menu, 
click Close, the Study Streams dialog box will close (see Figure 
3.3, page 3-4). 

 
 

3.2.4 List of Streams 
 
To review the streams that you have entered for your study, FDA provides 
a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Streams. 
 2. The Study Streams dialog box will open (see Figure 3.3, page 3-4). 
 3. On the View menu, click List of Streams, the List of Streams 

dialog box will open (Figure 3.4). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List of Streams dialog box will close (Figure 3.4). 
 
 

Figure 3.4  List of Streams Dialog Box 

3.2.5 Data Entry Variables for Streams 
 
Stream Name:  Name of the stream, which is used in subsequent data 
entry pick lists, reports, and plots.  A new stream name can be added to the 
database.  An existing stream name can be selected, updated, or deleted.  
The maximum length is sixteen (16) characters. 
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Stream Description:  Alphanumeric description of the defined stream.  
The maximum length is sixty-four (64) characters. 
 
 

3.3 Damage Reaches 
 
Damage reaches are specific geographical areas within a floodplain.  They 
are used to define consistent data for plan evaluations and to aggregate 
structure and other potential flood inundation damage information by 
stage of flooding.  A damage reach is delineated by the beginning and 
ending stations (river mile, kilometer, etc.) along the stream and extends 
into the floodplain to include the largest flood deemed reasonably 
possible.  Damage reaches are unique to a stream.  They are integral to 
both the hydrologic engineering and economic analyses.  A damage reach 
can be specified for the right or left bank (as looking downstream) or both 
banks.  Delineation of the damage reach must be consistent with flood 
damage reduction measures.  For example, a channel may be analyzed 
with a damage reach covering both banks, but a levee is analyzed for a 
damage reach only along one bank (refer to EM 1110-2-1619 for further 
information on damage reaches). 
 
When delineating damage reaches, consider consistent discharge- or stage-
exceedance probability functions throughout the damage reach, location of 
flood damage reduction measures, and jurisdiction boundaries for 
reporting purposes.  Normally, damage reach delineations evolve through 
the analysis of the without-project (base year) condition and become fixed 
thereafter when the location and magnitude of damage is known and types 
of flood damage reduction measures to be studied are defined.  The same 
damage reaches are used throughout for all the analyses of without- and 
with-project conditions.  Figure 3.1 (page 3-3) shows the delineation of 
damage reaches. 
 
The index location station for a damage reach is specified for several 
reasons: 
 
 1) To facilitate retrieving discharge and or stage probability ordinates 

from the water surface profile. 
 2)  To facilitate retrieving stage-discharge rating curves from the 

water surface profiles. 
 3) To enable the aggregation of stage-damage functions from 

individual structures to the index location.  The index location 
station may be located at any stream station in the damage reach. 

 
 

Damage reaches 
are specific 
geographical 
areas within a 
floodplain.  They 
are used to define 
consistent data 
for plan 
evaluations and to 
aggregate 
structure and 
other potential 
flood inundation 
damage 
information by 
stage of flooding. 

3.3.1 Defining Damage Reaches 
 
Damage reaches should be defined for the following: 
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 1) To represent consistent probability and stage-discharge functions 

along a stream. 
 2) To provide sufficient detail in the results, and 
 3) To facilitate the analysis of levees. 
 
Although there is no limit to the number of damage reaches, the required 
calculation time for expected annual damage is directly proportional to the 
number of damage reaches so it behooves you to define the minimal 
number that is sufficient.  A damage reach containing a levee cannot 
contain structures that are unprotected by the levee.  This may require you 
to define more damage reaches that what you would otherwise define. 
 
The damage reach to which a structure belongs may be defined using one 
of two methodologies: 
 
 1) Let FDA calculate the damage reach using the structure’s stream 

name, station, and bank, or 
 2) Explicitly define the damage reach using the SID Reach Name 

option, see Chapter 11, Section 11.5 (page 11-21) for further 
details. 

 
The first method works well if the damage reaches do not overlap from a 
stream stationing standpoint, however, this is sometimes impossible.  For 
example, levee plans may describe several alignments with different 
setbacks from the stream.  You may wish to define two damage reaches on 
one bank of the stream - one damage reach containing protected and one 
damage reach containing unprotected structures.  This example actually 
contains two problems, one, is that the damage reaches overlap; and, the 
geographic area changes with the plans as a function of the levee 
alignment. 
 
The use of Structure Modules (see Chapter 10) can address the problem 
of the changing geographic area.  The problem of mixed levee protection 
can be addressed by either: the use of stream bank location; the use of SID 
Reach Names, or, the addition of pseudo streams. 
 
If the levee is proposed for only one side of the stream, the protected 
structures are entered as if they are located on one bank whereas the 
unprotected structures are entered as if located on the other bank.  The 
disadvantage of this method is that the structure’s bank location is defined 
based upon levee protection rather than on physical location.  If levees of 
different heights are proposed for each side of the stream, this 
methodology will not work.  The use of pseudo streams requires the 
duplication of hydraulic and hydrologic engineering data.  The use of SID 
Reach Names requires that you define the damage reach name for each 
structure which can be tedious but allows the proper definition of stream  
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bank, does not require the duplication of hydrologic engineering data, and 
facilitates the overlap of two or more damage reaches.  The stream stations 
and water surface profiles (or alternatively, the SID Reference Flood 
Elevation option) are still used to aggregate damage to the index location. 
 
 

3.3.2 Create Damage Reaches 
 
To create damages reaches, at least one stream has to have been created: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Damage 
Reaches. 

 2. The Study Damage Reaches dialog box will open (Figure 3.5). 

 3. From the Stream Name list, select the stream where the damage 
reach is located.  Enter a damage reach name (required) in the 
Reach Name list, the maximum length is sixteen (16) characters. 

 4. Enter a description (optional but recommended) in the Description 
box.  The maximum length is sixty-four (64) characters. 

 5. Enter a value (range of 0.00 to 999,999.99) for the beginning station 
in the Beginning box.  This is the downstream end of the damage 
reach, and must be less than or equal to the ending station. 

 6. Enter a value (range of 0.00 to 999,999.99) for the ending station in 
the Ending box.  This is the upstream end of the damage reach, and 
must be greater than or equal to the beginning station. 

 7. From Bank, select the stream bank (looking downstream) where the 
damage reach is located.  There are three choices:  Left, Right, 
Both, with both being the default selection. 

 8. Enter a value (range of 0.00 to 999,999.99) for the index location 
station in the Index Location box.  This value must be greater than 
or equal to the beginning station, and must be less than or equal to 
the ending station. 

 9. Click Add, the damage reach for that stream is added. 

Figure 3.5  Study Damage Reaches Dialog Box 
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 10. When you are finished with entering your damage reaches, on the 
File menu, click Close, the Study Damage Reaches dialog box 
will close (see Figure 3.5, page 3-8). 

 
Additional ways to create damage reaches are provided from the Study 
Damage Reaches dialog box (see Figure 3.5, page 3-8): 
 
 ● On the Edit menu, click New Record, you can now enter a new 

damage reach from the Study Damage Reaches dialog box (see 
Figure 3.5, page 3-8). 

-or- 
 
 ● From the Navigator Button (see Chapter 2, Section 2.4.4, page  
  2-10), click the center of the button; you can now enter a new 

damage reach from the Study Damage Reaches dialog box (see 
Figure 3.5, page 3-8). 

 
 

3.3.3 Edit Damage Reaches 
 
Edit damage reaches that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Damage 
Reaches. 

 2. The Study Damage Reaches dialog box will open (Figure 3.6). 

 3. From the Stream Name list, select the stream where the damage 
reach is located. 

 4. From the Reach Name list, select the damage reach that you want 
to update. 

 5. Make changes to any of the data entry variables, when finished 
click Update; the changes are saved for the selected damage reach. 

Figure 3.6  Study Damage Reaches Dialog Box - Update Button 
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 6. When you are finished with editing your damage reaches, on the 
File menu, click Close, the Study Damage Reaches dialog box 
will close (see Figure 3.6, page 3-9). 

 
3.3.4 Delete Damage Reaches 

 
Delete damage reaches that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Damage 
Reaches. 

 2. The Study Damage Reaches dialog box will open (see Figure 3.6, 
page 3-9). 

 3. From the Stream Name list select the stream where the damage 
reach is located. 

 4. From the Reach Name list, select the damage reach you want to 
delete. 

 5. From the Edit menu, click Delete Record.  A warning message will 
appear asking you if you really want to delete the damage reach.  
Click Yes, the damage reach will no longer be available. 

 5. When you are finished with deleting damage reaches, on the File 
menu, click Close, the Study Damage Reaches dialog box will 
close (see Figure 3.6, page 3-9). 

 
3.3.5 List of Damage Reaches 

 
To review the damage reaches that you have entered for your study, FDA 
provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Damage 
Reaches. 

 2. The Study Damage Reaches dialog box will open (see Figure 3.6, 
page 3-9). 

 3. On the View menu, click List of Damage Reaches, the List of 
Damage Reaches dialog box will open (Figure 3.7). 

 4. This report can be printed, on the File menu, click Print. 

Figure 3.7  List of Damage Reaches Dialog Box 
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 5. When you are finished reviewing this report, on the File menu, 
click Close, the List of Damage Reaches dialog box will close (see 
Figure 3.7, page 3-10). 

 
 

3.3.6 Data Entry Variables for Damage Reaches 
 
Stream Name:  Select a previously defined stream name where the 
damage reach is located. 
 
Damage Reach Name:  Name of the damage reach, which is used in 
subsequent data entry pick lists, reports, and plots.  A new damage reach 
name can be added to the database.  An existing damage reach name can 
be selected, updated, or deleted.  The maximum length is sixteen (16) 
characters. 
 
Damage Reach Description:  Alphanumeric description of the defined 
damage reach.  The maximum length is sixty-four (64) characters. 
 
Beginning Station:  Beginning station number for downstream end of 
damage reach.  The range of allowable values is from 0.00 to 999,999.99.  
The value must be less than or equal to the ending station. 
 
 
Ending Station:  Ending station number for upstream end of damage 
reach.  The range of allowable values is from 0.00 to 999,999.99.  The 
value must be greater than or equal to the beginning station. 
 
Bank:  Stream bank (looking downstream) where the damage reach is 
located.  The delineation of the bank should consider potential local flood 
damage reduction measures and jurisdictional boundaries.  Some measures 
are typically implemented on only one bank; these include levees and 
walls, and various nonstructural actions.  Channels and upstream storage 
projects reduce flooding for both banks.  There are three hardwired 
choices (Left, Right, Both), with Both being the default. 
 
Left Bank:  Indicates that the damage reach is only along the left bank of 
the stream.  The left bank is defined looking downstream or with the 
current of the stream. 
 
Right Bank:  Indicator that the damage reach is only along the right bank 
of the stream.  The right bank is defined looking downstream or with the 
current of the stream. 
 
Both Banks:  Indicator that the damage reach is delineated spatially over 
both banks of the stream.  The stream cuts through the damage reach.  
Normally used for ponding or storage area reaches. 
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Index Location Station:  A stream station location within a damage reach 
is used to specify discharge-probability, stage-discharge, and stage-
damage functions with uncertainty data for plan evaluations for that 
damage reach.  Also, the index location station (corresponding stream 
station) is used for aggregation of stage-damage functions with uncertainty 
by damage category.  The index location station is defined between the 
beginning and ending station values and where data is normally deemed 
most reliable, such as a streamgage location.  The range of allowable 
values is from 0.00 to 999,999.99.  The value must be greater than or 
equal to the Beginning Station and less than or equal to the Ending 
Station.  The index location does not have to be at a water surface profile 
cross section location. 
 

3.4 Plans 
 
A plan may represent the with- or without project conditions.  The with-
project condition plan consists of one or more flood damage reduction 
measures and actions.  It includes all streams and damage reaches within 
the specified study limits.  A plan exists and is evaluated over an analysis 
period (project life), normally fifty years.  It starts with the base year of 
implementation or operation.  Static hydrologic engineering and economic 
conditions associated with a specified future analysis year are included to 
evaluate the equivalent economic and engineering performance of the plan 
over its project life (Table 3.1).  For further information, refer to  
ER 1105-2-100, ER 1105-2-101, and EM 1110-2-1619. 
 

Table 3.1 
Study Plans and Analysis Years 

A plan is a set 
of one or more 
flood damage 
reduction 
measures or 
actions 
designed to 
operate over a 
period of time 
(project life).  
The plan is 
inclusive of the 
entire study 
area although 
it may have a 
flood damage 
reduction 
measure for a 
single damage 
reach. 

 Analysis Years 
 

Plan Name 
 

Base Year 
Most Likely 
Future Year 

Without Project Conditions 2009 2030 
Plan 1 Levees 2009 2030 
Plan2 Channels 2009 2030 
Plan 3 Nonstructural 2009 2030 
Plan 4 Mixed Measures 2009 2030 

 
In FDA, the without-project condition is a hardwired plan and is 
automatically created when a new study is created. It is always listed first 
and cannot be deleted. The without-project condition is the plan which all 
subsequent plans are compared against. 
 
 

3.4.1 Create Plans 
 
To create plans: 
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 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the Configure menu, click Study Plan 
Definition. 

 2. The Study Plan Definition dialog box will open (Figure 3.8). 
 3. The Without plan has already been defined.  There are two ways to 

add another plan: 

 ● On the Edit menu, click New Record, you can now enter a 
new plan from the Study Plan Definition dialog box 
(Figure 3.8). 

- or - 
 ● From the Navigator Button (see Chapter 2, Section 2.4.4, 

page 2-10), click the center of the button; you can now 
enter a new plan from the Study Plan Definition dialog 
box (Figure 3.8). 

 4. Enter a name (required) in the Plan Name list.  The maximum 
length is sixteen (16) characters. 

 5. Enter a description (optional but recommended) in the Description 
box.  The maximum length is sixty-four (64) characters. 

 6. Click Add, the plan is added, and you can enter additional plans if 
you wish. 

 6. When you are finished with entering your plans, on the File menu, 
click Close, the Study Plan Definition dialog box will close 
(Figure 3.8). 

 
 

Figure 3.8  Study Plan Definition Dialog Box 

3.4.2 Edit Plans 
 
Edit plans that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Plan 
Definition. 

 2. The Study Plan Definition dialog box will open (see Figure 3.9, 
page 3-14). 

 3. From the Plan Name list, select the plan you want to edit and make 
the necessary updates. 

 4. Click Update, the changes are saved for the selected plan. 
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Figure 3.9  Study Plan Definition Dialog Box - Update Button 

 5. When you are finished with editing your plans, from the File menu, 
click Close, the Study Plan Definition dialog box will close 
(Figure 3.9). 

 
 

3.4.3 Delete Plans 
 
Delete plans that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Plan 
Definition. 

 2. The Study Plan Definition dialog box will open (Figure 3.9). 
 3. From the Plan Name list select the plan you want to delete. 
 4. On the Edit menu, click Delete Record.  A warning message will 

appear asking you if you really want to delete the plan.  Click Yes, 
the plan will no longer be available. 

 5. The Without plan cannot be deleted. 
 6. When you are finished with deleting plans, on the File menu, click 

Close, the Study Plan Definition dialog box will close (Figure 
3.9). 

 
 

3.4.4 List of Plans 
 
To review the plans that you have entered for your study, FDA provides a 
report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Plan 
Definition. 

 2. The Study Plan Definition dialog box will open (Figure 3.9). 
 3. On the View menu, click List of Plans, the List of Plans dialog 

box will open (see Figure 3.10, page 3-15). 
 4. This report can be printed, on the File menu, click Print. 
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Figure 3.10  List of Plans Dialog Box 

 5. When you are finished reviewing this report, on the File menu, 
click Close, the List of Plans dialog box will close (Figure 3.10). 

 
 

3.4.5 Data Entry Variables for Plans 
 
Plan Name:  Name of the plan, which is used in subsequent data entry 
pick lists, reports, and plots.  A new plan name can be added to the 
database.  An existing plan name can be selected, updated, or deleted.  The 
maximum length is sixteen (16) characters. 
 
Plan Description:  Alphanumeric description of the defined plan.  The 
maximum length is sixty-four (64) characters. 
 
 

3.5 Analysis Years 
 
Analysis years define damage and project performance information for 
specific time periods during the project life, such as the base year or most 
likely future year.  The analysis year results are used to compute 
equivalent annual damage computations for a plan.  The same analysis 
years are used for all study evaluations.  An analysis year represents a 
static time period or year that the hydrologic engineering and economic 
data must be developed for analyses.  Base year is the first year of the plan 
operation.  The most likely future year is normally a development 
projection for a specific future year, say twenty years out from the base 
year.  The expected annual damage is assumed constant beyond the most 
likely future condition (future analysis year).  The analysis concepts are 
depicted in Figure 3.11 (page 3-16).  The expected annual damage for 
each year in the analysis period is computed, discounted back to present 
value at the beginning of the base year and annualized to get the 
equivalent value over the analysis period (project life).  For further 
information see ER 1105-2-100, ER 1105-2-101, and EM 1110-2-1619. 
 

An analysis year 
represents a static 
time period or 
year that the 
hydrologic 
engineering and 
economic data 
must be developed 
for analyses.  
Base year is the 
first year of the 
plan operation. 
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2030 2050

Most 
Likely 
Future

Expected 
Annual 

Damage

Years

Base 
Year

2009

Analysis Period (Project Life)

The most likely 
future year is 
normally a 
development 
projection for a 
specific future 
year. 

Figure 3.11  Analysis Years 
 

3.5.1 Create Analysis Years 
 
To create analysis: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Configure menu, click Study Analysis 
Years. 

 2. The Study Analysis Years dialog box will open (Figure 3.12). 
 3. Type a value for the first year a plan is implemented and 

operational in the 
Base Year box. 

 4. Type a value for 
the most likely 
future condition 
development 
projection for a 
specific future 
year in the Most Likely Future box. 

 5. Click OK, the Study Analysis Years dialog box will close (Figure 
3.12), and the analysis years have been added to the study. 

 
 

Figure 3.12  Study Analysis Years Dialog Box 

3.5.2 Data Entry Variables for Analysis Years 
 
Base Year:  First year a plan is implemented and operational. 
 
Most Likely Future:  The most likely future condition development 
projection for a specific future year.  This variable is used to compute the 
equivalent annual damage over the analysis period (project life).  
Normally, the most likely future conditions are projected twenty to thirty  
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years out from base year, and it must be greater than base year.  FDA does 
not require you to enter a most likely future year.  If you wish to evaluate 
only the base year, leave the most likely future year blank.  You would 
enter data for only the base year and would not calculate equivalent annual 
damage. 
 
 

3.6 References 
 
 
ER 1105-2-100 
Guidance for Conducting Civil Works Planning Studies 
 
ER 1105-2-101 
Risk-based Analysis for Evaluation of Hydrology/Hydraulics and 
Economics in Flood Damage Reduction Studies 
 
EM 1110-2-1619 
Engineering and Design:  Risk-based Analysis for Flood Damage 
Reduction Studies 
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CHAPTER 4  
 
 

Hydrologic Engineering (HydEng) 
 
 

4.1 General 
 
Hydrologic Engineering (HydEng) is where hydrology, hydraulics, and 
levee data are entered for analysis.  The data includes:  water surface 
profiles, exceedance probability functions (see Chapter 5), stage-discharge 
functions (see Chapter 6), and levee features (see Chapter 7).  Although 
optional, water surface profiles are recommended.  The profiles are 
required when computing aggregated stage-damage uncertainty functions 
at damage reach index locations as specified under Economics (see 
Chapter 8).  The profiles must be consistent with discharge (stage)-
probability and stage-discharge (rating) functions required for each plan, 
analysis year, stream, and damage reach. 
 
The discharge-exceedance probability uncertainty functions can be 
computed using either analytical or graphical procedures.  Stage-
exceedance probability uncertainty functions can also be computed and 
applied.  The stage-discharge uncertainty function may be entered directly 
or the uncertainty specified for a stage and scaled for the other ordinates. 
 
The typical sequence that you would follow in the hydrologic engineering 
section is: 
 
 1) Import the eight water surface profiles.  These can be discharge-

probability profiles from HEC-RAS or HEC-2.  Alternatively, 
import stage-probability (or discharge-probability) profiles from 
some other source using the import from text file capability in the 
economics section.  Also, you can directly enter all of the water 
surface profile data directly in the GUI. 

 
 2) For each damage reach, either retrieve the graphical probability 

functions (see Chapter 5, Section 5.3, page 5-6) from the water 
surface profiles or enter the Log Pearson Type III (see Chapter 5, 
Section 5.2.2, page 5-4) moments.  For discharge-probability 
profiles, you can retrieve either eight points for a graphical curve 
or three points for a synthetic analytical curve.  For stage-
probability profiles, you can retrieve eight points for a graphical 
curve.  You must define the equivalent length of record.  For 
graphical probability functions, you can add additional points to 
better define the function.  By default, the lowest point on a  

Hydrologic 
Engineering is 
where hydrology, 
hydraulics, and 
levee data are 
entered for 
analysis. 
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  graphical probability function is for an exceedance probability of 
.50 and you will need to estimate a value for the .999 exceedance 
probability.  If a reach uses Log Pearson Type III, then you would 
simply enter the moments of the distribution and would not 
retrieve the probability function from the water surface profiles.  
As an alternative to retrieving the graphical probability function 
from the profiles, you can directly enter the function. 

 
 3) For each damage reach that has a discharge-probability function, 

retrieve the stage-discharge function (see Chapter 6) from the 
water surface profiles.  If the reach has a stage-probability 
function, then you do not enter a stage-discharge function.  You 
can add additional points to better define the curve.  By default, 
the highest point on the function represents stage for 0.002 
exceedance probability.  Since HEC-FDA does not extrapolate the 
stage-discharge function, you should estimate a value or values 
for discharges (with uncertainty) that correspond to very rare 
probabilities.  As an alternative to retrieving the stage-discharge 
function from the water surface profiles, you can directly enter the 
function.  Finally, you would need to define the uncertainty about 
the stage-discharge function. 

 
 4) Finally, for damage reaches that have a levee, you would enter the 

top of levee stage (see Chapter 7) at the index location.  You 
optionally could enter additional data for geotechnical failure 
analysis or for exterior-interior stage calculations.  

 
The dialog boxes you will use to input data for the hydrology and 
hydraulics data for a study have a common Menu Bar.  The Menu Bar 
contains the following common menus, for a description of the Help menu 
see Chapter 2 (Section 2.4.8, page 2-12): 
 
 File This menu is used for file management and contains the 

following commands: 
 Save: changes are saved for the hydrologic engineering 

data items (water surface profile sets, exceedance 
probability functions, stage-discharge functions, levees). 

 Use an Existing Function: allows you to copy the selected 
hydrologic engineering data item to a selected 
assignment.  That assignment differs for each individual 
hydrologic engineering data item. 

 Close: close the open dialog box; if changes have not been 
saved a warning message will appear. 

 
 Edit This menu is used for editing hydrologic engineering data 

items, traversing the records in a hydrologic engineering data 
item list, creating hydrologic engineering data items, and  
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  deleting hydrologic engineering data items.  The commands 

available are: 
 Cut/Copy/Paste: the standard cut/copy/paste commands 
 Insert Row: on the dialog boxes that contain tables, this 

command allows you to insert a row above the selected 
row.  To insert a row, you must highlight the row where 
you want to insert a row by clicking on the row number at 
the far left of the table, on the Edit menu, click Insert 
Row.  The new row will be inserted above the selected 
row. 

 Delete Row: on the dialog boxes that contain tables, this 
command allows you to delete a row anywhere in the 
table.  To delete a row, you must highlight the entire row 
by clicking on the row number at the far left of the table, 
on the Edit menu, click Delete Row.  The selected row 
will be deleted from the table. 

 Delete Assignment: this command deletes the assignment 
of a hydrologic engineering data item.  If you only have 
one hydrologic engineering data item, then by deleting 
the assignment you are removing the hydrologic 
engineering data item from the study. 

 Global Assignment Copy: this command allows you to 
assign hydrologic engineering data items to multiple 
plans and analysis years. 

 
 View This menu is used to review what hydrologic engineering data 

items have been created for the study; what assignments have 
been made, display graphically hydrologic engineering data 
items, and display a report of the hydrologic engineering data 
items.  The commands available are: 

 Hydrologic Engineering Data Item Assignments: 
  this command displays a report that gives you 

information on assignments that have been made for the 
hydrologic engineering data items. 

 List of Hydrologic Engineering Data Item: this command 
displays a report that will give you a list of hydrologic 
engineering data items that have been defined for the 
study. 

 Hydrologic Engineering Data Item Plot: this command 
displays a graphical representation of a hydrologic 
engineering data item. 

 Hydrologic Engineering Data Item Report: this command 
displays a report of a hydrologic engineering data item. 
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4.2 Water Surface Profiles 
 
A water surface profile is the stream water surface stage along a stream 
length associated with discharge values of a hypothetical or observed 
event.  In FDA, a water surface profile set must consist of eight flood 
events.  They may be discharge- or stage-based for each stream.  Each 
water surface profile set has stream stations, invert elevations, and 
discharge and stage values.  Stream stationing must be consistent with the 
damage reach and structure location stationing.  It is normally associated 
with water surface profile cross-sectional stations.  Ponding or storage 
areas are defined using a stage-exceedance probability water surface 
profile.  Unsteady flow modeling profiles are also normally stage-
exceedance probability based.  The water surface profile data sets may be 
imported from HEC-RAS (USACE 2002) or HEC-2 (USACE 1991) 
results (see Appendix C), copy (assign) a previously developed water 
surface profile data set from one plan to another, or enter manually. 
 
The default set of eight water surface profiles are for the .50-, .20-, .10-, 
.04-, .02-, .01-, .004-, and .002-exceedance probability flood events.  The 
water surface profile stream station values must increase or be equal from 
downstream to upstream.  At the index location, the discharge and stage 
for each profile must be greater than those from the previous profile.  
Discharge values of the water surface profile analyses are median values.   
 
FDA allows you to change the probability designations from the Study 
Water Surface Profile dialog box (Figure 4.1).  The probability values 
are used for the graphical or synthetic discharge-exceedance probability 
functions if retrieved from water surface profile data. 

 

A water surface 
profile is the 
stream water 
surface stage 
along a stream 
length associated 
with discharge 
values of a 
hypothetical or 
observed event. 

The default set of 
eight water 
surface profiles 
are for the .50-, 
.20-, .10-, .04-, 
.02-, .01-, .004-, 
and .002-
exceedance 
probability flood 
events. 

Figure 4.1  Study Water Surface Profiles Dialog Box 
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Water surface profile sets may be used to develop without- and with-
project condition discharge-probability (synthetic and graphical) functions 
(see Chapter 5) and stage-discharge functions (see Chapter 6) at an index 
location station within a damage reach, this ensures consistency of the 
data.  Water surface profiles are also used to aggregate stage-damage 
functions with uncertainty (see Chapter 12) for individual structures to the 
damage reach index location station. 
 
 

4.3 Importing Water Surface Profile Sets 
 
To import water surface profile sets from HEC-2 or HEC-RAS: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. For each plan, analysis year, and stream combination a water 
surface profile set will be assigned, therefore, you need to a select 
the appropriate plan from the Plan list, the appropriate analysis year 
from the Analysis Year list, and the appropriate stream from the 
Stream list (Figure 4.2). 

 4. On the File menu, click Import, the Import Water Surface 
Profile dialog box will open (Figure 4.3). 

 5. By default, the import is expecting an HEC-RAS file (*.wsp).  From 
the Files of type list, you can choose an HEC-2 (SUMPO) file, 
which has the extension *.smp. 
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Figure 4.2  Assignment Items for a Water Surface Profile Set 

Figure 4.3  Import Water Surface Profiles Dialog Box 

You can import 
water surface 
profile sets from 
HEC-2 or HEC-
RAS. 
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 6. After you have chosen the appropriate extension, the files with that 
extension will be displayed in the Import Water Surface Profile 
dialog box (see Figure 4.3, page 4-5).  Double- click on the file that 
contains your water surface profile set. 

 7. The Import Water Surface Profiles dialog box (see Figure 4.3, 
page 4-5) will close and the table on the Study Water Surface 
Profiles dialog box (see Figure 4.1, page 4-4) will display your 
water surface profile set for the selected plan, analysis year, and 
stream. 

 8. Enter a name (required) in the Profile box (see Figure 4.1, page  
  4-4).  The maximum length is sixteen (16) characters. 
 9. Enter a description (optional but recommended) in the Description 

box (see Figure 4.1, page 4-4).  The maximum length is sixty-four 
(64) characters.  Note:  If you import a water surface profile set 
from HEC-RAS, there is a default description. 

 10. You can enter detailed notes about the water surface profile set.  
Click Notes, the Notes dialog will open (Figure 4.4).  If the water 
surface profile set was imported the Notes dialog box will contain 
the filename from where the water surface profile set was imported.  
When you are finished entering the notes, click OK, the Notes 
dialog box will close. 

 11. From the Study Water Surface Profiles dialog box (see Figure 
4.1, page 4-4), click Save, the water surface profile set is added, and 
assigned to the selected plan, analysis year, and stream. 

 12. When you are finished with creating water surface profile sets, from 
the File menu, click Close, the Study Water Surface Profiles 
dialog box will close (see Figure 4.1, page 4-4). 

 
Appendix C provides information on how to generate the data files you 
will need from HEC-2 or HEC-RAS for importing into FDA.  There is an 
additional way to import water surface profiles from ASCII text files.  For 
further details on the ASCII import, see Chapter 8, Section 8.3.2 (page  
8-7). 
 
 

Figure 4.4  Notes Dialog Box 
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4.4 Edit a Water Surface Profile Set 
 
To edit a water surface profile set: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. Select the appropriate plan, analysis year, and stream (see Figure 
4.2, page 4-5). 

 4. Make changes to any of the data entry variables, add rows (on Edit 
menu, click Insert Row), and delete rows (on the Edit menu, click 
Delete Row).  When finished click Save, the changes are saved for 
the selected water surface profile set. 

 5. When you are finished with editing your water surface profile sets, 
on the File menu, click Close, the Study Water Surface Profiles 
dialog box will close (see Figure 4.1, page 4-4). 

 
By default, FDA provides you with a set of eight probabilities (0.5, 0.2, 
0.1, 0.04, 0.02, 0.01, 0.004, 0.002).  You can change these probability 
values: 
 
 1. On the Edit menu, click Edit Probability Values, the Edit 

Probability Values dialog box will open (Figure 4.5). 

 2. From the Probability Values column, change the probability 
values.  When you are finished, click OK, the Edit Probability 
Values dialog box will close (Figure 4.5).  The table on the Study 
Water Surface Profiles dialog box (see Figure 4.1, page 4-4) will 
reflect the changes you have made. 

 
 
 

Figure 4.5  Edit Probability Values Dialog Box 
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4.5 Delete a Water Surface Profile Set 
 
Since water surface profile sets are assigned to a plan, analysis year, and 
stream, you are deleting the assignment of that particular water surface 
profile set to a plan, analysis year, and stream.  Any water surface profile 
set that is assigned to only one plan, analysis year, stream, and then 
deleted, will be removed from the study.  To delete a water surface profile 
set: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. Select the appropriate plan, analysis year, and stream (see Figure 
4.2, page 4-5); this will give you the water surface profile set you 
wish to delete. 

 4. On the Edit menu, click Delete Assignment, a warning message 
will appear asking you if you really wish to delete this water surface 
profile set assignment.  Click Yes, the water surface profile set is no 
longer assigned to the selected plan, analysis year, and stream. 

 5. When you are finished, on the File menu, click Close, the Study 
Water Surface Profiles dialog box will close (see Figure 4.1, page 
4-4). 

 
 

4.6 List of Water Surface Profile Sets 
 
To review the water surface profiles sets you have entered for your study, 
FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. On the View menu, click List of Water Surface Profiles, the List 
of Water Surface Profiles dialog box will open (see Figure 4.6, 
page 4-9). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List Water Surface Profiles dialog box will close 
(see Figure 4.6, page 4-9). 
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Figure 4.6  List of Water Surface Profiles Dialog Box 
 

4.7 Water Surface Profile Plot 
 
To view a water surface profile set graphically: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. Select the appropriate plan, analysis year, and stream (see Figure 
4.2, page 4-5); this will give you the water surface profile set you 
wish to view graphically. 

 4. On the View menu, click Water Surface Profile Stream Plot, the 
Water Surface Profiles Plot dialog box will open (Figure 4.7). 

 5. When you are finished reviewing the plot, from the File menu, click 
Close, the Water Surface Profiles Plot dialog box will close 
(Figure 4.7). 

 
 

Figure 4.7  Water Surface Profiles Plot Dialog Box 
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4.8 Water Surface Profile Report 

 
To view a water surface profile set in a report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. Select the appropriate plan, analysis year, and stream (see Figure 
4.2, page 4-5); this will give you the water surface profile set you 
wish to view in a report. 

 4. On the View menu, click Water Surface Profile Stream Report, 
the Water Surface Profiles Report dialog box will open (Figure 
4.8). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, on the File menu, click 

Close, the Water Surface Profiles Report dialog box will close 
(Figure 4.8). 

 
 

Figure 4.8  Water Surface Profiles Report Dialog Box 

4.9 Assigning an Existing Water Surface Profile Set to a 
Different Plan, Analysis Year, Stream Combination 

 
You can assign a water surface profile set to another plan, analysis year, 
and stream combination.  There are two ways to accomplish this 
assignment.  The first way is to assign a water surface profile set 
individually: 

4-10 
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 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. Select a plan, analysis year, and stream (see Figure 4.2, page 4-5) 
that does not have an assigned water surface profile set. 

 4. Either click Use an Existing Profile, or on the File menu, click Use 
an Existing Profile, either way, the Copy Water Surface Profiles 
dialog box will open (Figure 4.9). 

 5. Based on the stream selected, FDA uses an automated filtering 
system that will only provide a list of water surface profiles sets that 
are available for the selected stream.  From the table select the 
water surface profile set that you want to assign to the selected plan, 
analysis year, and stream.  Click OK, the Copy Water Surface 
Profiles dialog box will close. 

 6. From the Study Water Surface Profiles dialog box (see Figure 
4.1, page 4-4), click Save, this will save the assignment of the water 
surface profile set to the selected plan, analysis year, and stream. 

 7. You do not need to change the name of the water surface profile set 
unless you make some other kind of change that is specific to that 
plan, analysis year, and stream. 

 
The other way is to assign the water surface profile set to multiple plans 
and analysis years: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. On the Edit menu, click Global Assignment Copy, the Global 
Assignment Copy dialog box will open (see Figure 4.10, page  

  4-12). 
 4. The From box is where you select the plan and analysis year that 

includes the water surface profile set you want to assign.  The To  

Figure 4.9  Copy Water Surface Profiles Dialog Box 
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Figure 4.10  Global Assignment Copy Dialog Box 

  box is the plan and analysis year that you are going to assign the 
water surface profile set to.  In the example (Figure 4.10), the water 
surface profile set for the Without plan and 2009 analysis year, will 
be assigned to Plan 2 and both analysis years (2009 and 2030).  
There is also an All options which allows you to make assignments 
to all plans and all analysis years. 

 5. Once you have made your selections click Copy (Figure 4.10), a 
warning message will appear asking you if this is really what you 
want to do, click Yes, and the warning message closes.  Click 
Close, the Global Assignment Copy dialog box will close (Figure 
4.10).  The assignments are automatically saved. 

 6. To verify that the water surface profile set assignments have been 
made, you need to review the Water Surface Profile Assignments 
report (see Section 4.10). 

 
 

4.10 List of Water Surface Profile Set Assignments 
 
To check to see if your assignments have been done and are correct, you 
need to review the assignment report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 4. On the View menu, click Water Surface Profile Assignments the 
Water Surface Profiles Assignments dialog box will open (see 
Figure 4.11, page 4-13). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, from the File menu, 

click Close, the Water Surface Profile Assignments dialog box 
will close (see Figure 4.11, page 4-13). 
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Figure 4.11  Water Surface Profiles Assignments Dialog Box 
 

4.11 Entering a Water Surface Profile Set Manually 
 
To enter a water surface profile set manually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Study Water Surface 
Profiles. 

 2. The Study Water Surface Profiles dialog box will open (see 
Figure 4.1, page 4-4). 

 3. For each plan, analysis year, and stream combination a water 
surface profile set will be assigned, therefore, you need to a select 
the appropriate plan from the Plan list, the appropriate analysis year 
from the Analysis Year list, and the appropriate stream from the 
Stream list (see Figure 4.2, page 4-5). 

 4. Enter a name (required) in the Profile box (see Figure 4.1, page  
  4-4).  The maximum length is sixteen (16) characters. 
 5. Enter a description (optional but recommended) in the Description 

box (see Figure 4.1, page 4-4).  The maximum length is sixty-four 
(64) characters. 

 6. Depending on the type of water surface profile set click the 
Discharge-Probability tab (default) or the Stage- Probability tab. 

 7. Enter the stream stationing in the Station column, these values must 
increase or be equal from downstream to upstream. 

 8. The invert stage is the stage associated with zero discharge or the 
bottom of the channel and is entered in the Invert Stage column. 

 9. For each probability with will enter a discharge (Q) value and a 
stage (Stage) value for all eight probabilities. 

 10. You can enter detailed notes about the water surface profile set.  
Click Notes (see Figure 4.1, page 4-4), the Notes dialog will open 
(see Figure 4.4, page 4-6).  When you are finished entering the 
notes, click OK, the Notes dialog box will close. 
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 11. Click Save (see Figure 4.1, page 4-4), the water surface profile set 

is added, and assigned to the selected plan, analysis year, and 
stream. 

 12. When you are finished with creating water surface profile sets, on 
the File menu, click Close, the Study Water Surface Profiles 
dialog box will close (see Figure 4.1, page 4-4). 

 
 

4.12 Data Entry Variables for Water Surface Profiles 
 
Plan Name:  Defined in the configuration module of FDA. 
 
Analysis Year:  Defined in the configuration module of FDA and 
represents a static time period or year that the hydrologic engineering and 
economic data must be developed for analyses. 
 
Stream Name:  Defined in the configuration module of FDA. 
 
Water Surface Profile Name:  Required name for the defined water 
surface profile set, which is used in the hydrologic engineering and 
economic analyses.  This name will appear on certain reports and plots.  A 
new water surface profile set can be added, copied, updated, or deleted.  
The maximum length of the name is sixteen (16) characters. 
 
Water Surface Profile Description:  Optional short description of the 
defined water surface profile set will appear on certain reports and plots.  
The maximum length of the name is sixty-four (64) characters. 
 
Water Surface Profile Type:  There are two types of water surface 
profiles.  Discharge-Probability is where the profiles are based on 
discharge values.  The discharge and the associated stage values are 
required for each station and exceedance probability flood event.  Stage-
probability is where the water surface profiles are based on stage values 
only.  The stage values are required for each station and exceedance 
probability flood event. 
 
Station:  Study adopted stations along the stream normally denoted as 
miles (kilometers) above the mouth of the stream.  Must be consistent 
between damage reach boundaries, damage reach index location, water 
surface profiles, and structure location.  The range of allowable values is 
from -999,999.99 to 999,999.99. 
 
Invert Stage:  Stage associated with zero discharge or the bottom of a 
channel.  The range of allowable values is from -300.00 to 30,000.00. 
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Discharge (Q):  The volume of water passing a specific point for a given 
time interval.  For example, 2,000 cubic feet per second or 1,000 cubic 
meters per second.  The range of allowable values is from 0 to 9,999,999. 
 
Stage:  The vertical distance is feet (meters) above or below a local or 
national datum (N.G.V.D. for elevations).  The range of allowable values 
is from -300.00 to 30,000.00. 
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CHAPTER 5  
 
 

Exceedance Probability Functions 
 
 

5.1 General 
 
Economics and performance analyses require an exceedance probability 
function to be defined (assigned) for each plan, analysis year, stream, and 
damage reach.  In order to perform a flood damage analysis that considers 
flood events of all sizes, a relationship between flood magnitude and the 
probability of exceeding that magnitude is needed.  This relationship is the 
exceedance probability function, also known as a frequency curve.  Flood 
event magnitude might be defined in terms of discharge (flow) or stage.  
Exceedance probability functions are edited from the Exceedance 
Probability Functions with Uncertainty dialog box (Figure 5.1).  The 
same functions may be used for several reaches, plans, and analysis years 
but not different streams.  You may retrieve a synthetic or graphical 

exceedance probability function from the water surface profile, enter the 
data manually, or copy an existing exceedance probability function.  You 
may also copy the exceedance probabilities from one plan to another plan.  
An exceedance probability (or frequency) function can be either analytical 
(discharge-probability) or graphical (discharge- or stage-probability). 
 

An exceedance 
probability 
function is the 
relationship 
between flood 
magnitude and 
the probability of 
exceeding that 
magnitude; also 
known as a 
frequency curve. 

Figure 5.1  Exceedance Probability Functions with Uncertainty Dialog Box 
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5.2 Analytical-Exceedance Probability Method 

 
If the discharge-exceedance probability function can be fitted by a Log 
Pearson Type III distribution, FDA considers this to be an analytical 
exceedance probability function.  Analytical methods often apply for 
unregulated discharge-probability functions derived from stream gaged 
data or modeling.  There are two methods of defining analytical discharge-
probability functions.  The default method is to enter the discharges for the 
.50, .10, and .01 exceedance probability events to compute synthetic 
statistics.  The other method is to enter the Log Pearson Type III statistics 
which are the mean, standard deviation, skew, and equivalent record 
length.  For analytical methods, the median discharge-exceedance 
probability functions are used. 
 
For further information refer to ER 1110-2-1450, EM 1110-2-1415, EM 
1110-2-1619.  Another additional source is a document from the 
Interagency Advisory Committee on Water Data, "Guidance for 
Determining Flood Flow Frequency, Bulletin 17B," U.S. Department of 
Interior, U.S. Geological Survey, Office of Water Data Coordination, 
Reston, VA. 
 
 

An  analytical 
exceedance 
probability 
function is where 
a discharge-
exceedance 
probability 
function can be 
fitted by a Log 
Pearson Type III 
distribution.. 

5.2.1 Compute Synthetic Statistics 
 
This uses Bulletin 17B procedures for computing the function and 
uncertainty by defining the function based on the .50, .10, and .01 
exceedance probability discharge values and equivalent record length.  
You can create an analytical exceedance probability function by retrieving 
the .50, .10, and .01 exceedance probability values from the assigned 
water surface profile set for the selected plan, analysis year, stream, and 
damage reach, or you can enter the values manually.  To retrieve from the 
assigned water surface profile set: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
an exceedance probability function will be assigned, therefore, you 
need to a select the appropriate plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 5.2, page  

  5-3). 

Compute 
synthetic statistics 
creates an 
analytical 
exceedance 
probability 
function based on 
.50, .10, and .01 
exceedance 
probability 
discharge values 
(which can be 
retrieved from the 
associated water 
surface profiles) 
and equivalent 
record length. 
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Figure 5.2  Assignment Items for Exceedance Probability Functions 

 4. On the Edit menu, click Synthetic from WSP, the Discharge-
Probability Function - Type Analytical dialog box will open 
(Figure 5.3). 

 5. The discharge values 
for the three (.50, 
.10, .01) exceedance 
probabilities have 
been retrieved from 
the assigned water 
surface profile set. 

 6. You must enter an 
equivalent record 
length in the 
Equivalent Record 
Length (N) box. 

 7. Click Save, the 

 
ype 

Discharge-
Probability
Function - T
Analytical dialog box (Figure 5.3) will close and FDA will 
compute the analytical exceedance probability function with 
uncertainty, which will display in the table on the Exceedance 
Probability Functions with Uncertainty dialog box (see Figure 
5.1, page 5-1). 

 8. Enter a name (required) in the Function box (see Figure 5.1, page 
5-1).  The maximum length is sixteen (16) characters. 

 9. Enter a description (optional but recommended) in the Description 
box (see Figure 5.1, page 5-1).  The maximum length is sixty-four 
(64) characters. 

 10. Click Save, the exceedance probability function is added, and 
assigned to the selected plan, analysis year, stream, and damage 
reach. 

 11. When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 
Probability Functions with Uncertainty dialog box will close (see 
Figure 5.1, page 5-1). 

 
To enter an analytical exceedance probability function using synthetic 
statistics manually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

Figure 5.3 Discharge-Probability Function - 
Type Analytical – Compute 
Synthetic Statistics Dialog Box 
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 2. The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
an exceedance probability function will be assigned, therefore, you 
need to a select the appropriate plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 5.2, page  

  5-3). 
 4. Click Analytical, the Discharge-Probability Function - Type 

Analytical dialog box will open (see Figure 5.3, page 5-3). 
 5. Click Compute Synthetic Statistics (see Figure 5.3, page 5-3); this 

option should be selected by default. 
 6. You will need to enter the discharge values for the three (.50, .10, 

.01) exceedance probabilities. 
 7. You must enter an equivalent record length in the Equivalent 

Record Length (N) box (see Figure 5.3, page 5-3). 
 8. Click Save, the Discharge-Probability Function - Type 

Analytical dialog box (see Figure 5.3, page 5-3) will close and 
FDA will compute the analytical exceedance probability function 
with uncertainty, which will display in the table on the Exceedance 
Probability Functions with Uncertainty dialog box (see Figure 
5.1, page 5-1). 

 9. Enter a name (required) in the Function box (see Figure 5.1, page 
5-1).  The maximum length is sixteen (16) characters. 

 10. Enter a description (optional but recommended) in the Description 
box (see Figure 5.1, page 5-1).  The maximum length is sixty-four 
(64) characters. 

 11. Click Save, the exceedance probability function is added, and 
assigned to the selected plan, analysis year, stream, and damage 
reach. 

 12. When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 
Probability Functions with Uncertainty dialog box will close (see 
Figure 5.1, page 5-1). 

 
 

5.2.2 Log Pearson Type III 
 
This uses Bulletin 17B procedures for computing the function and 
uncertainty (confidence limits) from the mean, standard deviation, skew, 
and equivalent record length.  To enter an analytical exceedance 
probability function using Log Pearson Type III: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 
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 2. The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
an exceedance probability function will be assigned, therefore, you 
need to a select the appropriate plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 5.2, page  

  5-3). 
 4. Click Analytical, the Discharge-Probability Function - Type 

Analytical dialog box will open (see Figure 5.3, page 5-3). 
 5. Click Enter Log Pearson Type III Statistics, the appearance of 

the Discharge-Probability Function - Type Analytical dialog box 
will change 
(Figure 5.4). 

 6. You will need to 
enter the mean 
(Mean (M) 
box), the 
standard 
deviation 
(Standard 
Deviation (S) 
box), the skew 
(Skew (G) box), 
and an 
equivalent 
record length 
(Equivalent 
Record Length 
(N) box). 

 7. Click Save, the Discharge-Probability Function - Type 
Analytical dialog box (Figure 5.4) will close and FDA will 
compute the analytical exceedance probability function with 
uncertainty, which will display in the table on the Exceedance 
Probability Functions with Uncertainty dialog box (see Figure 
5.1, page 5-1) 

 8. Enter a name (required) in the Function box (see Figure 5.1, page 
5-1).  The maximum length is sixteen (16) characters. 

 9. Enter a description (optional but recommended) in the Description 
box (see Figure 5.1, page 5-1).  The maximum length is sixty-four 
(64) characters. 

 10. Click Save, the exceedance probability function is added, and 
assigned to the selected plan, analysis year, stream, and damage 
reach. 

 11. When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 

The Log Pearson 
Type III option 
allows you to 
enter the mean, 
standard 
deviation, skew, 
and equivalent 
record length to 
create the 
analytical 
exceedance 
probability 
function. 

Figure 5.4 Discharge-Probability Function - Type 
Analytical - Log Pearson Type III 
Dialog Box 

 5-5 



Chapter 5 – Exceedance Probability Functions HEC-FDA User's Manual 

Probability Functions with Uncertainty dialog box will close (see 
Figure 5.1, page 5-1). 

 
 

5.3 Graphical Exceedance Probability Method 
 
If the function does not fit the Log Person Type III distribution, the 
graphical approach should be used.  The graphical approach is typically 
applicable for regulated flows, stage-exceedance probabilities (often 
storage based or UNET (Barkau, 1992) unsteady flow modeling results), 
and partial duration functions.  The graphical method uses an approach 
termed order statistics.   For the graphical method, see ETL 1110-2-537, 
or "Uncertainty, A Guide to Dealing with Uncertainty in Quantitative Risk 
and Policy Analysis" by Morgan and Henron.  Figure 5.5 shows the 
Probability Function - Type Graphical dialog box, which is where the 
user will enter the graphical exceedance probability function. 

 
A graphical probability function (discharge- or stage-probability) is 
defined by specifying the discharge- or stage-probability ordinates and the 
equivalent record length that describes the known function.  Once 
specified, ordered events are interpolated from the function based on the 
equivalent record length and error limit curves determined using order 
statistics.  The final graphical discharge- or stage-probability function is 
based on mean or expected values defined by Weibull plotting positions 
along the curve.  The distribution of errors is assumed to be normal about 

A graphical 
exceedance 
probability 
function is 
defined is by 
specifying the 
discharge- or 
stage-probability 
ordinates and the 
equivalent record 
length.  The 
computation in 
FDA to create the 
graphical 
exceedance 
probability 
function is termed 
order statistics. 

Figure 5.5  Probability Function - Type Graphical Dialog Box 
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the specified function.  You may plot or tabulate the function and error 
limit curves (see ETL 1110-2-537). 
 
When entering data to define graphical exceedance-probability functions, 
a number of data points should be used to describe the full range of the 
function.  The uncertainty of these functions is computed using a statistical 
method called ordered events (Morgan and Henrion, 1990).  The method 
determines standard errors of points (estimates) along the curve from the 
relationship of each of the estimates to adjacent points and the slope of the 
function.  The number and distribution of the points affect the uncertainty 
computation results. 
 
For stage-probability functions which have a steep slope in the function 
followed by a very flat slope for rare exceedance probabilities, FDA 
Version 1.2.4 will use the calculated uncertainty about the flat portion of 
the function in the expected annual damage (EAD) and project 
performance computations.  However, when viewing stage-probability 
functions from the FDA graphical user interface (GUI), either graphically 
or in a report, FDA will incorrectly display greater uncertainty about the 
flat portion of the function. 
 
 

5.3.1 Creating a Graphical-Exceedance Probability 
Function 

 
You can create a graphical exceedance probability function by retrieving 
the discharge-exceedance-probability data points from the water surface 
profile set for the selected plan, analysis year, stream, and damage reach, 
or you can enter the values manually.  To retrieve from the assigned water 
surface profile set: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
an exceedance probability function will be assigned, therefore, you 
need to a select the appropriate plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 5.2, page  

  5-3). 
 4. On the Edit menu, click Graphical from WSP, the Probability 

Function - Type Graphical dialog box will open (see Figure 5.6, 
page 5-8). 
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Figure 5.6 Probability Function - Type Graphical Equivalent Record 
Length Dialog Box 

 5. The discharge-exceedance-probability data points have been 
retrieved from the assigned water surface profile set.  Note that this 
is for eight probability events.  The statistics, including the 
uncertainty of the graphical exceedance-probability function, are 
influenced by the entire sample.  Consequently the entire range of 
the function should be defined including an annual return 1-year 
event (0.999) estimated value. 

 6. You need to add an additional point at the 0.999 (1-year) event.  
Select Row 1 (highlighted in blue), click Insert Row (see figure 
5.6, page 5-8); Row 1 will now be a blank row.  In the Exceedance  

  Probability column, enter 0.999, and in the Discharge column type 
the discharge value for the 1-year event. 

 7. You must enter an equivalent record length in the Equivalent 
Record Length (N) box. 

 8. Click Save, the Probability  Function - Type Graphical dialog 
box (Figure 5.6) will close and FDA will compute the graphical 
exceedance probability function with uncertainty, which will 
display in the table on the Exceedance Probability Functions with 
Uncertainty dialog box (see Figure 5.1, page 5-1). 

 9. Enter a name (required) in the Function box (see Figure 5.1, page 
5-1).  The maximum length is sixteen (16) characters. 
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 10. Enter a description (optional but recommended) in the Description 
box (see Figure 5.1, page 5-1).  The maximum length is sixty-four 
(64) characters. 

 11. Click Save, the exceedance probability function is added, and 
assigned to the selected plan, analysis year, stream, and damage 
reach. 

 12. When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 
Probability Functions with Uncertainty dialog box will close (see 
Figure 5.1, page 5-1). 

 
To enter a graphical exceedance probability function manually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
an exceedance probability function will be assigned, therefore, you 
need to a select the appropriate plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 5.2, page  

  5-3). 
 4. Click Graphical, the Probability Function - Type Graphical 

dialog box will open (see Figure 5.6, page 5-8). 
 5. The statistics, including the uncertainty of the graphical 

exceedance-probability function, are influenced by the entire 
sample.  Consequently the entire range of the function should be 
defined including an annual return 1-year event (0.999) estimated 
value.  You will need to enter the discharge-exceedance-probability 
data points in the table. 

 6. You need to add an additional point at the 0.999 (1-year) event.  
Select Row 1 (highlighted in blue), click Insert Row.  Row 1 will 
now be a blank row.  In the Exceedance Probability column, enter 
0.999, and in the Discharge column type the discharge value for the 
1-year event. 

 7. You must enter an equivalent record length in the Equivalent 
Record Length (N) box open (see Figure 5.6, page 5-8). 

 8. Click Save, the Probability Function - Type Graphical dialog 
box (see Figure 5.6, page 5-8) will close and FDA will compute the 
graphical exceedance probability function with uncertainty, which 
will display in the table on the Exceedance Probability Functions 
with Uncertainty dialog box (see Figure 5.1, page 5-1). 

 9. Enter a name (required) in the Function box (see Figure 5.1, page 
5-1).  The maximum length is sixteen (16) characters. 
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 10. Enter a description (optional but recommended) in the Description 
box (see Figure 5.1, page 5-1).  The maximum length is sixty-four 
(64) characters. 

 11. Click Save, the exceedance probability function is added, and 
assigned to the selected plan, analysis year, stream, and damage 
reach. 

 12. When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 
Probability Functions with Uncertainty dialog box will close (see 
Figure 5.1, page 5-1). 

 
 

5.3.2 Eight Data Points versus Nine Data Points 
 
A graphical exceedance-probability function can be defined by retrieving 
the discharge-exceedance-probability data points from the water surface 
profile data for the eight events and then adding an additional point at the 
0.999 (1-year) event.  Figures 5.7 and 5.8 (page 5-10) display the results 
for the exceedance probability function defined entirely by the water 
surface profile data only. 

Note from the plot on Figure 5.8 (page 5-10) that the program does not 
extrapolate beyond the limits of the data, in this case below the 0.5 
exceedance or the 2-year event.  Note also, from Figure 5.7 (page 5-10); 
the range of values for the 0.01 exceedance probability event between plus 
and minus two standard errors is 3,161 to 12,153 cfs. 

Figure 5.7 Exceedance Probability Function Report - Graphical - 
From Water Surface Profiles - Eight Data Points 
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Figure 5.8 Exceedance Probability Function Plot - Graphical - 
From Water Surface Profiles - Eight Data Points 

The statistics, including the uncertainty of the graphical exceedance-
probability function, are influenced by the entire sample.  Consequently 
the entire range of the function should be defined including an annual 
return 1-year event (0.999) estimated value. 
 
Figures 5.9 and 5.10 (page 5-12) display the graphical exceedance-
probability function and error limit values after adding an additional 
discharge of 900 cfs for the 0.999 or 1-year event to help define the lower  

Figure 5.9 Exceedance Probability Function Report - Graphical - 
Nine Data Points 
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Figure 5.10 Exceedance Probability Function Plot - Graphical - Nine 
Data Points 

end of the function.  Note the range of values for the 0.01 exceedance 
probability event between plus and minus two standard errors is now 

 to 11,948 cfs.   The example shows that simply adding an additional 
point on the frequency curve decreases the computed uncertainty 
substantially.  This is because the program assumes nothing is known 
beyond the  most frequent event entered (the 2-year event in the first case).  
Providing additional information throughout the entire sample decreases 
the uncertainty.  The expected annual damage would change even though 
it can be assumed that the 0.01 exceedance probability event is well within 
banks at the reach index location. 

FDA does extrapolate beyond the least frequent event entered if that event 
ore frequent than the 0.002 exceedance probability (500-year) event.  

However, it is important to provide data to the 0.002 or greater event to 
ensure as much accuracy as possible. 

  It is recommended that graphical frequency functions be defined 
between the 1- and 0.001-exceedance probability events. 

3,215

 

is m

 
Note:

 
 

5.3.3 Transform Flow Relationship 
 
A transform flow relationship may be used to define a relationship 
between unregulated and regulated flow, inflow and outflow, or another 
relationship to transform the flow defined by the discharge- or stage-
proba sult 
of rese a

bility function.  This transform flow relationship could be the re
rvoir or ch nnel routing, channel diversion, etc.  Although a  
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graphical curve could represent a regulated probability function, it is better 
to first derive an unregulated curve and use the transform flow function to 
convert the unregulated into a regulated curve.  It specifically allows for 
the isolation of the uncertainty related to the transforming mechanism, 
while maintaining the uncertainty of the discharge-probability function.  
The relationship is entered as x-y paired data.  Uncertainty of the 
dependent variable (regulated flow) is also defined.  The distribution type 
and the distribution parameters are entered for each point on the flow 
transform function. 
 
A transform flow function may describe the unregulated inflow into a 
reservoir and the regulated outflow via routing, and outlet works and/or 
spillway releases.  The uncertainty of this function could be derived from 
a sensitivity analysis of the reservoir routing, varying such parameters as 
the outlet works and spillway ratings, outlet works operation, shape of the 
inflow hydrograph, assumed initial release time, political influences, 
safety issues, etc.  Given the variety of parameters that have an impact on 
the outflow, one m  
situation is asymmetric and dim

 Uncertainty. 
2. The Exceedance Probability Functions with Uncertainty dialog 

 
u 

plan from the Plan list, the 
appropriate analysis year from the Analysis Year list, the 

ure 5.2, page  
 5-3). 

4. Click Analytical or Graphical, the dialog box associated with the 
 will open.  If your analytical 

exceedance probability function is based on synthetic statistics the 

 

A transform flow 
relationship may 
be used to define 
a relationship 
between 
unregulated and 
regulated flow, 
inflow and 
outflow, or 
another 
relationship to 
transform the flow 
defined by the 
discharge- or 
stage-probability 
function. 

ight conclude that the uncertainty distribution for this
inishes in probability at the extremes.  The 

triangular distribution of uncertainty, therefore, may be the most 
appropriate descriptor of this function. 
 
A transform flow function can be entered for either an analytical (if your 
analytical exceedance probability function is based on synthetic statistics 
the transform flow option will not be available) or a graphical-exceedance 
probability function: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with

 
box will open (see Figure 5.1, page 5-1). 

 3. For each plan, analysis year, stream, and damage reach combination
an exceedance probability function will be assigned, therefore, yo
need to a select the appropriate 

appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Fig

 
 

exceedance probability function

transform flow option will not be available 
 5. Click Transform Flow (Reg vs. Unreg), the Transform Flow 

(Regulated vs. Unregulated) dialog box will open (see Figure
5.11, page %-14). 
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 6. If there is uncertainty associated with the function, select a 
distribution type from the Distribution Type box.  When you select
a distribution type the table will expand.  Figure 5.12 shows the 
table for a triangular distribution. 

 

 8. 

 

 10. 

see 

 

 7. Click Save, the Transform Flow (Regulated vs. Unregulated) 
dialog box (Figure 5.11) will close, and returns you to the analytical 
or graphical dialog box. 
From either the analytical or graphical dialog box click Sav
dialog box will close, and return you to the Exceedance 
Probability Functions with Uncertainty dialog box (see Figure 

 5-1). 

e, that 

5.1, page
 9. Click Save, the transform flow relationship for selected exceedance

probability function is saved. 
When you are finished with creating exceedance probability 
functions, on the File menu, click Close, the Exceedance 
Probability Functions with Uncertainty dialog box will close (
Figure 5.1, page 5-1). 

Figure 5.11  Transform Flow Dialog Box 

Figure 5.12  Transform Flow Dialog Box - Triangular Distribution 
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5.4 Delete an Exceedance Probability Function 
 
Since exceedance probability functions are assigned to a plan, analysis 
year, stream, and damage reach, you are deleting the assignment of that 
particular exceedance probability function to a plan, analysis year, stream, 
and damage reach.  Any exceedance probability function that is assigned 
to only one plan, analysis year, stream, damage reach, and then deleted, 
will be removed from the study.  To delete an exceedance probability 
function: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The th Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 3. Select the appropriate plan, analysis year, stream, and damage 
reach; this will give you the exceedance probability function you 
wish to delete (see Figure 5.2, page 5-3). 

 4. On the Edit menu, click Delete Assignment, a warning message 
will appear asking you if you really wish to delete this exceedance 
probability function assignment.  Click Yes, the exceedance 
probability function is no longer assigned to the selected plan, 
analysis year, stream, and damage reach. 

 5. When you are finished, on the File menu, click Close, the 
Exceedance Probability Functions with Uncertainty dialog box 
will close (see Figure 5.1, page 5-1). 

 
 

5.5 List of Exceedance Probability Functions 
 
To review the exceedance probability functions you have entered for your 

g: 
 
 1. 

nu, click Exceedance 

 2. 
 5.1, page 5-1). 

ns dialog 

 4. be printed, on the File menu, click Print. 

ance Probability Functions dialog 

 

 Exceedance Probability Functions wi

study, FDA provides a report.  To access the report do the followin

From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the HydEng me
Probability Functions with Uncertainty. 
The Exceedance Probability Functions with Uncertainty dialog 
box will open (see Figure

 3. On the View menu, click List of Exceedance Probability 
Functions, the List of Exceedance Probability Functio
box will open (Figure 5.13). 
This report can 

 5. When you are finished reviewing this report, on the File menu, 
click Close, the List of Exceed
box will close (see Figure 5.13, page 5-16). 
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Exceedance Probability Function Plot 

 
To view an exceedance probability function graphically: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The Exceedance Probability Functions wi
box will open (see Figure 5.1, page 5-1). 

 3. Select the appropriate plan, analysis year, stream

5.6 

, and damage reach 
(see Figure 5.2, page 5-3); this will give you the exceedance 
probability function you wish to view graphically. 

 4. On the View menu, click Exceedance Probability Function Plot, 
the Exceedance Probability Function Plot dialog box will open 
(Figure 5.14). 

 

th Uncertainty dialog 

Figure 5.13  List of Exceedance Probability Functions Dialog Box 

Figure 5.14 Exceedance Probability Function Plot Dialog Box 
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 5. When you are finished reviewing the plot, on the File m
Close, the Exceedance Probability Function Plot dia

enu, click 
log box will 

5.7 Excee

1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

 2. th Uncertainty dialog 

 3.  stream, and damage reach 

 4. bability Function 
x 

 5. le menu, click Print. 
enu, click 

x 

 

close (see Figure 5.14, page 5-16). 
 
 
dance Probability Function Report 

 
To view an exceedance probability function in a report: 
 
 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 
The Exceedance Probability Functions wi
box will open (see Figure 5.1, page 5-1). 
Select the appropriate plan, analysis year,
(see Figure 5.2, page 5-3); this will give you the exceedance 
probability function you wish to view in a report. 
On the View menu, click Exceedance Pro
Report, the Exceedance Probability Function Report dialog bo
will open (Figure 5.15). 

Figure 5.15 Exceedance Probability Function Report Dialog Box 

To print this report, on the Fi
 6. When you are finished reviewing the report, on the File m

Close, the Exceedance Probability Function Report dialog bo
will close. 
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5.8 Assigning an Existing Exceedance Probability 
Function to a Different Plan, Analysis Year, Stream, 
Damage Reach Combination 

 
You can assign an exceedance probability function to another plan, 
analysis year, stream, and damage reach combination.  There are two ways 
to accomplish this assignment.  The first way is to assign an exceedance 
probability function individually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 Uncertainty dialog 

t have an 
assigned exceedance probability function. 

ick 
ance 

(Figure 5.16). 

 5. Based on the stream selected, FDA uses an automated filtering 
system that will only provide a list of exceedance probability 
functions that are available for the selected stream.  From the table 
select the exceedance probability function that you want to assign to 
the selected plan, analysis year, stream, and damage reach.  Click 
OK, the Copy Exceedance Probability function dialog box will 
close. 

 6. From the Exceedance Probability Functions with Uncertainty 
dialog box (see Figure 5.1, page 5-1) click Save, this will save the 
assignment of the exceedance probability function to the selected 
plan, analysis year, stream, and damage reach. 

 7. You do not need to change the name of the exceedance probability 
function unless you make some other kind of change that is 
specifically for that plan, analysis year, stream, and damage reach. 

 

 2. The Exceedance Probability Functions with
box will open (see Figure 5.1, page5-1). 

 3. Select a plan, analysis year, and stream that does no

 4. Either click Use an Existing Function, or from the File menu, cl
Use an Existing Function, either way, the Copy Exceed
Probability Function dialog box will open 

Figure 5.16  Copy Exceedance Probability Function Dialog Box 
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The other way is to assign an exceedance probability function to multiple
and analysis years: 

 
plans 
 

1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the HydEng menu, click Exceedance 

certainty dialog 

, the Global 

 4. The From box is where you select the plan and analysis year that 
includes the exceedance probability function you want to assign.  
The To box is the plan and analysis year that you are going to 
assign the exceedance probability function to.  In the example 
(Figure 5.17), the exceedance probability function for the Without 
plan and 2009 analysis year, will be assigned to Plan 2 and both 
analysis years (2009 and 2030).  There is also an All options which 
allows you to make assignments to all plans and all analysis years. 

 5. Once you have made your selections click Copy, a warning 
message will appear asking you if this is really what you want to 
do, click Yes, the warning message closes.  Click Close, the Global 
Assignment Copy dialog box (Figure 5.17) will close.  The 
assignments are automatically saved. 

 6. To verify that the exceedance probability function assignments have 
been made, you need to review the Exceedance Probability 
Function Assignments report (see Section 5.9). 

 
 

5.9 List o  
Assig e

 
o che  your assignments have been done and are correct, you 

ent report: 
 

 

Probability Functions with Uncertainty. 
2. The Exceedance Probability Functions with Un 

box will open (see Figure 5.1, page 5-1). 
3. On the Edit menu, click Global Assignment Copy 

Assignment Copy dialog box will open (Figure 5.17). 

f Exceedance Probability Function 
nm nts 

ck to see ifT
need to review the assignm

Figure 5.17  Global Assignment Copy Dialog Box 
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 1. From the FDA main window (see Chapter 2, Section 2.1, F
2.1, page 2-2), on the HydEng menu, click Exceedance 
Probability Functions with Uncertainty. 

 2. The Exceedance Probability F

igure 

unctions with Uncertainty dialog 
box will open (see Figure 5.1, page 5-1). 

 4. 
 5. When you are finished reviewing the report, on the File menu, click 

Close, the Exceedance Probability Function Assignments dialog 
box will close. 

 
 

5.10 Data Entry Variables for Exceedance Probability 
Funct

 
Plan N
 
Stream
 

Dama
 

report

 3. On the View menu, click Exceedance Probability Function 
Assignments the Exceedance Probability Function Assignments 
dialog box will open (Figure 5.18). 

Figure 5.18  Exceedance Probability Function Assignments Dialog Box 

To print this report, on the File menu, click Print. 

ions 

ame:  Select a previously defined plan name. 

 Name:  Select a previously defined stream name. 

Analysis Year:  Select a previously defined analysis year. 
 

ge Reach:  Select a previously defined damage reach. 

Probability Function Name:  Required name for the defined probability 
function, which is used for subsequent data entry pick lists, and labeling 

s and plots.  A new probability function can be added to the 
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database.  An existing probability function can be copied, updated, or 
deleted.  The maximum length is sixteen (16) characters. 

 
probab rs. 
 

compu  Pearson Type III 
 

deviat ent record 
length.  For synthetic or parameter fitting (Compute Synthetic Statistics), 
the computed statistical parameters are mean, standard deviation, skew, 
and equivalent record length.  Also, the discharge is computed.  The 
statistic reported for a non-analytical probability function is the equivalent 
record length. 
 
Analytical Discharge-Probability Function:  A discharge-probability 
function that is fit with an analytical (statistical) distribution.  The 
distribution is defined by statistics which are the mean, standard deviation, 
and skew for the Log Pearson Type III distribution, and the equivalent 
record length.  The function is developed by site specific, hydrologic 
engineering a ned by 

e 
used. 
 
Graph
probab
functio
functi

r hi
 

define
 
Excee nt will 

e c

 
onfi  analytical 
ischarge-probability function developed using the non-central t 

ge-probability or 
 Confidence limit 

ed to define the discharge-probability or stage-probability 

 
Probability Function Description:  Optional description of the defined

ility function, maximum length is sixty-four (64) characte

Probability Function Statistics:  Reports the statistics entered or 
ted for a probability function.  For the Log

distribution, the statistical parameters are mean (first moment), standard
ion (second moment), skew (third moment), and equival

nalysis procedures.  A "synthetic" approach defi
discharges associated with the .50, .10, and .01 probability events that fit 
the Log Pearson Type III distribution through the three points, may also b

ical Discharge- or Stage-Probability Function:  A graphical 
ility function (discharge- or stage-probability) is a non-analytical 
n that is drawn graphically by an eye-fit curve.  This means that the 

on is not fitted by an analytical distribution.  For HEC-FDA, 
cal functions should use Weibull's plotting ons (not median) g ap positi

because the normal distribution is used in the order statistics approach to
 the error bands. 

dance Probability Event:  The probability that a specific eve
eeded in any given year.  For exampleb  ex , the .01 exceedance 

probability event has a .01 probability of occurring in any given year. 

dence Limit Curves:  Error limit curves about anC
d
distribution. Error limit curves about a graphical dischar
stage-probability functions using a normal distribution. 
curves are us

nction's uncertainty. fu
 
Stage:  The vertical distance in feet (meters) above or below a local or 
ational datum (N.G.V.D. for elevations). n
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Discharge (Q):  The volume of water passing a specific point for a give
terval.  For example, 2,000 cubic feet per second or 1,000
 per second. 

n 
time in  cubic 
meters

Log P istribution that defines an 
ical 

param
These  moment), standard deviation 
(second moment), and skew (third moment).  Also, there is an additional 
parameter specified, equivalent record length. 
 
Mean:  The average value of a set of numbers, such as the annual peak 
discharges that have occurred over a period of time.  The first moment 
statistic of a Log Pearson Type III distribution, representing the average of 
the logarithms of peak discharge values. 
 
Compute Synthetic Statistics:  Log Pearson Type III statistics are 
computed based on the discharges associated with the .50, .10, and .01 
exceedance probability events of an adopted probability function.  The 
synthetic statistics are based on equations given in Guidelines for 
Determining Flood Flow Frequency, Bulletin 17B, USGS, September 
1981. 
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CHAPTER 6  
 
 

Stage-Discharge Functions 
 
 

6.1 General 
 
A stage-discharge function is the relationship between the discharge 
(flow) at a river cross-section and the stage (depth) produced by that 
discharge.  This function is needed when the exceedance probability 
function is defined in terms of discharge, in order to transform the 
discharge into stage (and subsequently damage) for each probability.  
From the Stage-Discharge Function with Uncertainty dialog box 
(Figure 6.1) you will enter the information for your stage-discharge 
(rating) functions.  The stage-discharge (rating) function with uncertainty 

is specified for a given plan, analysis year, stream, and damage reach in 
the evaluation of flood damage reduction measures.  Stage-discharge 
functions are required unless a stage-exceedance probability function is 
used.  The same median stage-discharge functions may be used for several 
plans, analysis years, and damage reaches but not different streams. 
 

A stage-discharge 
function (rating 
function) is the 
relationship 
between the 
discharge (flow) 
at a river cross-
section and the 
stage (depth) 
produced by that 
discharge. 

Figure 6.1  Stage-Discharge Function with Uncertainty Dialog Box 
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You may specify an uncertainty (probability density function) type as 
either none (no uncertainty), normal, triangular, or log normal.  You may 
then manually enter the uncertainty by each ordinate or specify "calculate" 
to define the uncertainty for a specific stage.  For this case, the error is 
proportioned to the invert stage for zero discharge and error.  Error values 
above the specified stage are assumed constant (equal to the error for the 
specified stage).  You may tabulate and plot the stage-discharge 
uncertainty functions. 
 
The highest stage value must extend beyond the highest stage affected by 
any flood damage reduction measure.  We recommend including an 
ordinate to the .002 or .001 exceedance probability level.  FDA will not 
extrapolate the rating curve beyond the highest coordinate value that you 
entered. 
 
 

6.2 Creating a Stage-Discharge Function 
 
You can create a stage-discharge function based on the water surface 
profile set for the selected plan, analysis year, stream, and damage reach, 
or you can enter the values manually.  To create a stage-discharge function 
based on the assigned water surface profile set: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. For each plan, analysis year, stream, and damage reach combination 
a stage-discharge function will be assigned, therefore, you need to 
select the appropriate plan from the Plan list, the appropriate 
analysis year from the Analysis Year list, the appropriate stream 
from the Stream list, and the appropriate damage reach from the 
Damage Reach list (Figure 6.2). 

 4. On the Edit menu (see Figure 6.1, page 6-1), click Retrieve from 
WSP, this will automatically create a nine-point stage discharge 
function at the damage reach index location based on the water 
surface profile set for the selected plan, analysis year, stream, and 
damage reach.  The nine ordinates include the invert stage (zero 
discharge) and the eight stage-discharge values from the water 
surface profile set. 

Figure 6.2  Assignment Items for Stage-Discharge Functions 
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 5. From the Distribution Type box (see Figure 6.1, page 6-1), select 
the uncertainty type if your stage-discharge function has 
uncertainty. 

 6. If you have selected an uncertainty from the Define Uncertainty 
box (see Figure 6.1, page 6-1), click Enter by Ordinate to 
manually enter the uncertainty for each ordinate of the stage-
discharge function. 

-or- 
  From the Define Uncertainty box (see Figure 6.1, page 6-1), click 

Calculate, the Set Stage Error for a distribution type dialog box 
will open (Figure 6.3).  Error values above the specified stage are 
assumed constant (equal to the error for the specified stage), this 

value is entered in the Stage Where Error Becomes Constant box 
(Figure 6.3).  You will define an uncertainty for a specific stage; the 
error is proportioned to the invert stage for zero discharge and error, 
this value is entered in the Standard Deviation of Error for 
Entered Stage box (Figure 6.3). 

 7. Click OK, the Set Stage Error for a distribution type dialog box 
will close (Figure 6.3) and you will return to the Stage-Discharge 
Function with Uncertainty dialog box (see Figure 6.1, page 6-1). 

 8. Enter a name (required) in the Function box (see Figure 6.1, page 
6-1).  The maximum length is sixteen (16) characters. 

 9. Enter a description (optional but recommended) in the Description 
box (see Figure 6.1, page 6-1).  The maximum length is sixty-four 
(64) characters. 

 10. Click Save, the stage-discharge function is added, and assigned to 
the selected plan, analysis year, stream, and damage reach. 

 11. When you are finished with creating stage-discharge functions, on 
the File menu, click Close, the Stage-Discharge Function with 
Uncertainty dialog box will close (see Figure 6.1, page 6-1). 

 
To enter a stage-discharge function manually: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

Figure 6.3  Set Stage for a distribution type Dialog Box 
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 2. The Stage-Discharge Function with Uncertainty dialog box will 

open (see Figure 6.1, page 6-1). 
 3. For each plan, analysis year, stream, and damage reach combination 

a stage-discharge function will be assigned, therefore, you need to a 
select the appropriate plan from the Plan list, the appropriate 
analysis year from the Analysis Year list, the appropriate stream 
from the Stream list, and the appropriate damage reach from the 
Damage Reach list (see Figure 6.2, page 6-2). 

 4. Enter the discharge and stage values for your stage-discharge 
function in the table on the Stage-Discharge Function with 
Uncertainty dialog box (see Figure 6.1, page 6-1).  Note it is 
recommended that you include the invert stage (zero discharge) in 
your stage-discharge function. 

 5. From the Distribution Type box (see Figure 6.1, page 6-1), select 
the uncertainty type if your stage-discharge function has 
uncertainty. 

 6. If you have selected an uncertainty from the Define Uncertainty 
box (see Figure 6.1, page 6-1), click Enter by Ordinate to 
manually enter the uncertainty for each ordinate of the stage-
discharge function. 

-or- 
  From the Define Uncertainty box (see Figure 6.1, page 6-1), click 

Calculate, the Set Stage Error for a distribution type dialog box 
will open (see Figure 6.3, page 6-3).  Error values above the 
specified stage are assumed constant (equal to the error for the 
specified stage), this value is entered in the Stage Where Error 
Becomes Constant box (see Figure 6.3, page 6-3).  You will define 
an uncertainty for a specific stage; the error is proportioned to the 
invert stage for zero discharge and error, this value is entered in the 
Standard Deviation of Error for Entered Stage box (see Figure 
6.3, page 6-3). 

 7. Click OK, the Set Stage Error for a distribution type dialog box 
will close (see Figure 6.3, page 6-3) and you will return to the 
Stage-Discharge Function with Uncertainty dialog box (see 
Figure 6.1, page 6-1). 

 8. Enter a name (required) in the Function box (see Figure 6.1, page 
6-1).  The maximum length is sixteen (16) characters. 

 9. Enter a description (optional but recommended) in the Description 
box (see Figure 6.1, page 6-1).  The maximum length is sixty-four 
(64) characters. 

 10. Click Save, the stage-discharge function is added, and assigned to 
the selected plan, analysis year, stream, and damage reach. 

 11. When you are finished with creating stage-discharge functions, on 
the File menu, click Close, the Stage-Discharge Function with 
Uncertainty dialog box will close (see Figure 6.1, page 6-1). 
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6.3 Delete a Stage-Discharge Function 

 
Since stage-discharge functions are assigned to a plan, analysis year, 
stream, and damage reach you are deleting the assignment of that 
particular stage-discharge function to a plan, analysis year, stream, and 
damage reach.  Any stage-discharge function that is assigned to only one 
plan, analysis year, stream, damage reach, and then deleted, will be 
removed from the study.  To delete a stage-discharge function: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. Select the appropriate plan, analysis year, stream, and damage 
reach; this will give you the stage-discharge function you wish to 
delete (see Figure 6.2, page 6-2). 

 4. On the Edit menu, click Delete Assignment, a warning message 
will appear asking you if you really wish to delete this stage-
discharge function assignment.  Click Yes, the stage-discharge 
function is no longer assigned to the selected plan, analysis year, 
stream, and damage reach. 

 5. When you are finished, on the File menu, click Close, the Stage-
Discharge Function with Uncertainty dialog box will close (see 
Figure 6.1, page 6-1). 

 
 

6.4 List of Stage-Discharge Functions 
 
To review the stage-discharge functions you have entered for your study, 
FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. On the View menu, click List of Stage-Discharge Functions, the 
List of Stage-Discharge Functions dialog box will open (see 
Figure 6.4, page 6-6). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List of Stage-Discharge Functions dialog box will 
close (see Figure 6.4, page 6-6). 
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Figure 6.4  List of Stage-Discharge Functions Dialog Box 
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6.5 Stage-Discharge Function Plot 
 
To view a stage-discharge function graphically: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. Select the appropriate plan, analysis year, stream, and damage reach 
(see Figure 6.2, page 6-2); this will give you the stage-discharge 
function you wish to view graphically. 

 4. On the View menu, click Stage-Discharge Function Plot, the 
Stage-Discharge Plot dialog box will open (Figure 6.5). 

 5. When you are finished reviewing the plot, on the File menu, click 
Close, the Stage-Discharge Plot dialog box will close (Figure 6.5). 

 
 

Figure 6.5  Stage-Discharge Plot Dialog Box 
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6.6 Stage-Discharge Function Report 
 
To view a stage-discharge function in a report: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-2). 

 3. Select the appropriate plan, analysis year, stream, and damage reach 
(see Figure 6.2, page 6-2); this will give you the stage-discharge 
function you wish to view in tabular form. 

 4. On the View menu, click Stage-Discharge Function Report, the 
Stage-Discharge Report dialog box will open (Figure 6.6). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, on the File menu, click 

Close, the Stage-Discharge Report dialog box will close (Figure 
6.6). 

 
 

Figure 6.6  Stage-Discharge Report Dialog Box 

6.7 Assigning an Existing Stage-Discharge Function to a 
Different Plan, Analysis Year, Stream, Damage Reach 
Combination 

 
You can assign a stage-discharge function to another plan, analysis year, 
stream, and damage reach combination.  There are two ways to  
accomplish this assignment.  The first way is to assign a stage-discharge 
function individually: 

 6-7 
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 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 
2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. Select a plan, analysis year, stream, and damage reach (see Figure 
6.2, page 6-2) that does not have an assigned stage-discharge 
function. 

 4. Either click Use an Existing Function (see Figure 6.1, page 6-1), 
or from the File menu, click Use an Existing Function, either way, 
the Copy Stage-Discharge Function dialog box will open (Figure 
6.7). 

 5. Based on the stream selected, FDA uses an automated filtering 
system that will only provide a list of stage-discharge functions that 
are available for the selected stream.  From the table select the 
stage-discharge function that you want to assign to the selected 
plan, analysis year, stream, and damage reach.  Click OK, the Copy 
Stage-Discharge Function dialog box will close (Figure 6.7). 

 6. From the Stage-Discharge Function with Uncertainty dialog box 
(see Figure 6.1, page 6-1) click Save, this will save the assignment 
of the stage-discharge function to the selected plan, analysis year, 
stream, and damage reach. 

 7. You do not need to change the name of the stage-discharge function 
unless you make some other kind of change that is specifically for 
that plan, analysis year, stream, and damage reach. 

 
The other way is to assign a stage-discharge function to multiple plans and 
analysis years: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. On the Edit menu (see Figure 6.1, page 6-1), click Global 
Assignment Copy, the Global Assignment Copy dialog box will 
open (see Figure 6.8, page 6-9). 

Figure 6.7  Copy Stage-Discharge Function Dialog Box 
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Figure 6.8  Global Assignment Copy Dialog Box 

 4. The From box (Figure 6.8) is where you select the plan and 
analysis year that includes the stage-discharge function you want to 
assign.  The To box is the plan and analysis year that you are going 
to assign the stage-discharge function to.  In the example (Figure 
6.8), the stage-discharge function for the Without plan and 2009 
analysis year, will be assigned to Plan 2 and both analysis years 
(2009 and 2030).  There is also an All options which allows you to 
make assignments to all plans and all analysis years. 

 5. Once you have made your selections click Copy, a warning 
message will appear asking you if this is really what you want to 
do, click Yes, the warning message closes.  Click Close, the Global 
Assignment Copy dialog box will close (Figure 6.8).  The 
assignments are automatically saved. 

 6. To verify that the stage-discharge function assignments have been 
made, you need to review the Stage-Discharge Function 
Assignments report (see Section 6.8). 

 
 

6.8 List of Stage-Discharge Function Assignments 
 
To check to see if your assignments have been done and are correct, you 
need to review the assignment report: 
 
 1. From the FDA main Window (see Chapter 2, Section 2.1, Figure 

2.1, page 2.2), on the HydEng menu, click Stage-Discharge 
Function with Uncertainty. 

 2. The Stage-Discharge Function with Uncertainty dialog box will 
open (see Figure 6.1, page 6-1). 

 3. On the View menu, click Stage-Discharge Function Assignments 
the Stage-Discharge Function Assignments dialog box will open 
(see Figure 6.9, page 6-10). 

 4. To print this report, on the File menu, click Print. 
 5. When you are finished reviewing the report, on the File menu, click 

Close, the Stage-Discharge Function Assignments dialog box will 
close (see Figure 6.9, page 6-10). 
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Figure 6.9  Stage-Discharge Function Assignments Dialog Box 

 
6.9 Data Entry Variables for Stage-Discharge Functions 

 
Plan Name:  Select a previously defined plan name. 
 
Stream Name:  Select a previously defined stream name. 
 
Analysis Year:  Select a previously defined analysis year. 
 
Damage Reach:  Select a previously defined damage reach. 
 
Stage-Discharge Function Name:  Required name for the defined stage-
discharge function, which is used for subsequent data entry pick lists and 
used on reports and plots.  A new stage-discharge function can be added to 
the database.  An existing stage-discharge function can be copied, 
updated, or deleted.  The maximum length is 16 characters. 
 
Stage-Discharge Function Description:  Optional description of the 
defined stage-discharge function, up to 64 characters. 
 
Normal Distribution:  A two-parameter probability distribution defined 
by the mean and standard deviation.  A symmetrical "bell shaped" curve 
applicable to many kinds of data sets where values are equally likely to be 
greater than or less than the mean.  Also called a Gaussian distribution.  
The distribution is truncated at three standard deviations. 
 
Triangular Distribution:  A three-parameter bounded probability 
distribution defined by the minimum, most likely (mode), and maximum. 
 
Log Normal Distribution:  A two-parameter probability distribution 
defined by the mean and standard deviation.  A non-symmetrical 
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distribution applicable to many kinds of data sets where the majority 
(more than half) of values are less than the mean but values greater than 
the mean can be extreme, such as with stream flow data.  The distribution 
is truncated at three standard deviations. 
 
Discharge (Q):  The volume of water passing a specific point for a given 
time interval.  For example, 2,000 cubic feet per second or 1,000 cubic 
meters per second. 
 
Stage:  The vertical distance in feet (meters) above or below a local or 
national datum (N.V.G.D. for elevations). 
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CHAPTER 7  
 
 

Levee Features 
 
 

7.1 General 
 
Under Levee Features, you specify levee size and failure characteristics, 
interior versus exterior stage relationships associated with the levee, or 
wave overtopping criteria.  The levee, floodwall, or tidal barrier 
characteristics are entered and other relationships are defined depending 
on whether the levee is subject to geotechnical failure or wave action 
(overtopping) which may cause flooding. 

 
As can be seen on the Levee Features dialog box (Figure 7.1), other data 
that describe the characteristics of levees and floodwalls and how they 
affect flooding can be specified. 
 
 

Levee Features, 
is where you can 
specify levee size 
and failure 
characteristics, 
interior versus 
exterior stage 
relationships 
associated with 
the levee, or wave 
overtopping 
criteria. 

Figure 7.1  Levee Features Dialog Box 

7.2 Creating a Levee 
 
A levee or floodwall is defined by selecting the appropriate plan, analysis 
year, stream and damage reach in the Levee Features dialog box (Figure 
7.1).  The stage of the top of the levee or floodwall at the damage reach 
index location is entered in the Top of Levee Stage box (Figure 7.1).  To 
create a levee: 
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 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the HydEng menu, click Levee Features. 

 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1). 
 3. For each plan, analysis year, stream, and damage reach combination 

a levee will be assigned; therefore, you need to a select the 
appropriate plan from the Plan list, the appropriate analysis year 
from the Analysis Year list, the appropriate stream from the 
Stream list, and the appropriate damage reach from the Damage 
Reach list (Figure 7.2). 

 4. Enter a name (required) in the Levee Name box (see Figure 7.1, 
page 7-1).  The maximum length is sixteen (16) characters. 

 5. Enter a description (optional but recommended) in the Description 
box (see Figure 7.1, page 7-1).  The maximum length is sixty-four 
(64) characters. 

 6. Enter the top of the levee (required) or floodwall in the Top of 
Levee Stage box (see Figure 7.1, page 7-1). 

 7. If there is a relationship between the exterior and interior water 
surface stage at a levee, click Exterior/Interior Relationship (see 
Figure 7.1, page 7-1) to define this relationship (see Section 7.2.1). 

 8. Another relationship, water surface stage on the river or exterior 
side of the levee versus the probability of levee failure, can be 
specified by clicking Geotechnical Failure Analysis (see Section 
7.2.2, page 7-5). 

 9. To account for the effects of wave overtopping click Wave 
Overtopping (see Section 7.2.3, page 7-7). 

 10. From the Levee Features dialog box (see Figure 7.1, page 7-1), 
click Save, the levee is added, and assigned to the selected plan, 
analysis year, stream, and damage reach. 

 11. When you are finished with creating levees, from the Levee 
Features dialog box (see Figure 7.1, page 7-1), on the File menu, 
click Close. 

 
 

Figure 7.2  Assignment Items for Levees 

7.2.1 Exterior-Interior Relationship 
 
The exterior-interior relationship feature defines a relationship between 
the water surface stage on the river or exterior side of the levee versus the 
stage in the floodplain or interior side of the levee.  This relationship is 
necessary if the stage in the interior will not reach the same stage that is 
overtopping the levee.  This may be due to floods that result in stages near 
the top of the levee overtopping as designed in a safe, controlled manner, 
or a flood hydrograph volume not sufficient to fill the floodplain to the 
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stage equal to the top of the levee.  In either case, the relationship must be 
developed from hydrologic or hydraulic analyses external to the FDA 
program.  If the relationship is not specified, the assumption is that the 
floodplain fills to the stage in the river (represented by the exterior stage-
discharge function for the reach) for all events that result in stages that 
cause levee failure or are above the top of levee. 
 
To enter an exterior/interior relationship: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1) click Exterior/Interior Relationship. 
 3. The Exterior/Interior Relationship dialog box will open (Figure 

7.3). 

 4. To define the exterior/interior relationship, enter the exterior side of 
the levee (water surface stage on the river) versus the interior side 
of the levee (the stage in the floodplain). 

 5. Once you are finished entering the relationship, click Save, the 
Exterior/Interior Relationship dialog box (Figure 7.3) will close.  
This saves the relationship for the levee, but you must click Save 
from the Levee Features dialog box (see Figure 7.1, page 7-1) to 
save the entire levee definition. 

 
 

A relationship 
between the water 
surface stage on 
the river or 
exterior side of 
the levee versus 
the stage in the 
floodplain or 
interior side of the 
levee, is an 
exterior-interior 
relationship. 

Figure 7.3  Exterior/Interior Relationship Dialog Box 

 Exterior-Interior Relationship Plot 
 
To view an exterior-interior relationship graphically: 
 
 1. From the Exterior/Interior Relationship dialog box (Figure 7.3), 

click Plot, or on the View menu, click Exterior/Interior Plot. 
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 2. The Exterior/Interior Relationship Plot dialog box will open 
(Figure 7.4). 

 3. When you are finished reviewing the plot, on the File menu, click 
Close, this will return you to the Exterior/Interior Relationship 
dialog box (see Figure 7.3, page 7-3). 

 
 

Figure 7.4  Exterior/Interior Relationship Plot Dialog Box 

 Exterior-Interior Relationship Report 
 
To view an exterior-interior relationship report: 
 
 1. From the Exterior/Interior Relationship dialog box (see Figure 

7.3, page 7-3), click Tabulate, or on the View menu, click 
Exterior/Interior Report. 

 2. The Exterior/Interior Relationship Report dialog box will open 
(Figure7.5). 

 
Figure 7.5  Exterior/Interior Relationship Report Dialog Box 
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 3. When you are finished reviewing the report, on the File menu, click 
Close, this will return you to the Exterior/Interior Relationship 
dialog box (see Figure 7.3, page 7-3). 

 
 

7.2.2 Geotechnical Failure Analysis 
 
A relationship between water surface stage on the river or exterior side of 
the levee versus the probability of levee failure may be specified.  This 
feature is used anytime the structural integrity of the levee is in doubt, i.e., 
anytime the levee could fail prior to being overtopped.  This is especially 
the case for existing non-federal levees or older levees that may have 
deteriorated and can no longer be assumed to hold water to the stage 
initially intended.  However, without the benefit of some sort of 
geotechnical analysis, no levee should be assumed to be competent to the 
top of levee.  The geotechnical failure relationships are developed from 
geotechnical analysis according to existing geotechnical guidance.  The 
geotechnical failure relationship is a combined probability of levee failure 
relationship and includes failure modes such as under seepage, slope 
stability, through seepage, surface erosion, etc.  At this time, uncertainty 
about the geotechnical failure relationship is not available. 
 
To enter geotechnical failure: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1) click Geotechnical Failure Analysis. 
 3. The Geotechnical Failure Analysis dialog box will open (Figure 

7.6). 

 4. To define the geotechnical failure relationship enter the exterior 
side of the levee (water surface stage on the river) versus the 
probability of levee failure. 

 5. Once you are finished entering the relationship, click Save, the 
Geotechnical Failure Analysis dialog box will close (Figure 7.6).   

Geotechnical 
failure analysis is 
the relationship 
between water 
surface stage on 
the river or 
exterior side of 
the levee versus 
the probability of 
levee failure.  
This feature is 
used anytime the 
structural 
integrity of the 
levee is in doubt, 
i.e., anytime the 
levee could fail 
prior to being 
overtopped. 

Figure 7.6  Geotechnical Failure Analysis Dialog Box 
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  This saves the relationship for the levee, but you must click Save 
from the Levee Features dialog box (see Figure 7.1, page 7-1) to 
save the entire levee definition. 

 
 

 Geotechnical Failure Analysis Plot 
 
To view the geotechnical failure analysis graphically: 
 
 1. From the Geotechnical Failure Analysis dialog box (see Figure 

7.6, page 7-5), click Plot. 
 2. The Geotechnical 

Failure Analysis 
Plot dialog box 
will open (Figure 
7.7). 

 3. When you are 
finished reviewing 
the plot, on the 
File menu, click 
Close, this will 
return you to the 

Geotechnical 
Failure Analysis 
dialog box (see 
Figure 7.6, page 7-5). 

 
 

Figure 7.7 Geotechnical Failure Analysis Plot 
Dialog Box 
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 Geotechnical Failure Analysis Report 
 
To view a geotechnical failure analysis report: 
 
 1. From the Geotechnical Failure Analysis dialog box (see Figure 

7.6, page 7-5), click Tabulate. 
 2. The Geotechnical 

Failure Analysis 
Report dialog box 
will open (Figure 
7.8). 

 3. When you are 
finished reviewing 
the report, on the 
File menu, click 
Close, this will 
return you to the 
Geotechnical Failure Analysis dialog box (see Figure 7.6, page  

  7-5) 

Figure 7.8 Geotechnical Failure Analysis Report 
Dialog Box 
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7.2.3 Wave Overtopping 
 
Wave overtopping analysis accounts for effects of wave overtopping 
when analyzing levees, floodwalls or tidal barriers.  A wave height versus 
still water stage relationship is specified.  Still water stage corresponds to 
the exterior stage-discharge or stage-frequency function specified for the 
reach.  The uncertainty of wave height is defined by specifying one of 
several error distribution types.  When a levee or floodwall is subjected to 
wave action, a portion of the wave may overtop depending on whether the 
wave strikes the structure.  The volume of water that spills over the levee 
or floodwall is dependent on the effective overtopping height.  Wave 
overtopping relationships may be used to account for these factors.  A 
relationship between effective overtopping height and resulting interior 
stages can also be specified.  These relationships are developed outside the 
FDA program using wave overtopping analyses and overtopping volume 
versus interior stage characteristics.  Appendix D describes these concepts 
and illustrates the wave overtopping data entry requirements in detail. 
 
 

Wave overtopping 
analysis accounts 
for effects of wave 
overtopping when 
analyzing levees, 
floodwalls or tidal 
barriers.  A wave 
height versus still 
water stage 
relationship is 
specified. 

7.3 Delete a Levee 
 
Since levees are assigned to a plan, analysis year, stream, and damage 
reach, if you delete a levee you are deleting the assignment of that 
particular levee from a plan, analysis year, stream, and damage reach. Any 
levee that is assigned to only one plan, analysis year, stream, damage 
reach, and then deleted, will be removed from the study.  To delete a 
levee: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1). 
 3. Select the appropriate plan, analysis year, stream, and damage 

reach; this will give you the levee you wish to delete. 
 4. On the Edit menu, click Delete Assignment, a warning message 

will appear asking you if you really wish to delete this levee, click 
Yes.  The levee is no longer assigned to the selected plan, analysis 
year, stream, and damage reach. 

 5. When you are finished, on the File menu, click Close, the Levee 
Features dialog box will close (see Figure 7.1, page 7-1). 

 
 

7.4 List of Levees 
 
To review the levees you have entered for your study, FDA provides a 
report.  To access the report do the following: 
 

 7-7 



Chapter 7 – Levee Features HEC-FDA User's Manual 

 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1). 
 3. On the View menu, click List of Levees, the List of Levees dialog 

box will open (Figure 7.9). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List of Levees dialog box will close (Figure 7.9). 
 
 

Figure 7.9  List of Levees Dialog Box 

7.5 Assigning an Existing Levee to a Different Plan, 
Analysis Year, Stream, Damage Reach Combination 

 
You can assign a levee to another plan, analysis year, stream, and damage 
reach combination.  There are two ways to accomplish this assignment.  
The first way is to assign a levee individually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1). 
 3. Select a plan, analysis year, stream, and damage reach that does not 

have an assigned levee. 
 4. Either click Use an Existing Levee, or on the File menu, click Use 

an Levee, either way, the Copy Levee dialog box will open (Figure 
7.10). 

 5. Based on the 
stream and 
damage reach 
selected, FDA 
uses an 
automated 
filtering 
system that will only provide a list of levees that are available for 
the selected stream and damage reach.  From the table select the 
levee that you want to assign to the selected plan, analysis year,  

Figure 7.10  Copy Levee Dialog Box 
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  stream, and damage reach.  Click OK, the Copy Levee dialog box 

will close (see Figure 7.10, page 7-8). 
 6. From the Levee Features dialog box (see Figure 7.1, page 7-1) 

click Save, this will save the assignment of the levee to the selected 
plan, analysis year, stream, and damage reach. 

 7. You do not need to change the name of the levee unless you make 
some other kind of change that is specific to that plan, analysis year, 
stream, and damage reach. 

 
The other way is to assign a levee to multiple plans and analysis years: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1,  
  page 7-1). 
 3. On the Edit menu, click Global Assignment Copy, the Global 

Assignment Copy dialog box will open (Figure 7.11). 

 4. The From box is where you select the plan and analysis year that 
includes the levee you want to assign.  The To box is the plan and 
analysis year that you are going to assign the levee to.  In the 
example (Figure 7.11), the levee for the Without plan and 2009 
analysis year, will be assigned to Plan 1 and analysis years 2030.  
There is also an All option which allows you to make assignments 
to all plans and all analysis years. 

 5. Once you have made your selections click Copy, a warning 
message will appear asking you if this is really what you want to 
do, click Yes, and the warning message closes.  Click Close, the 
Global Assignment Copy dialog box will close (Figure 7.11).  The 
assignments are automatically saved. 

 6. To verify that the levee assignments have been made, you need to 
review the Levee Assignments report (see Section 7.6). 

 
 

Figure 7.11  Global Assignment Copy Dialog Box 
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7.6 List of Levee Assignments 
 
To check to see if your assignments have been done and are correct, you 
need to review the assignment report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the HydEng menu, click Levee Features. 
 2. The Levee Features dialog box will open (see Figure 7.1, page  
  7-1). 
 4. On the View menu, click Levee Assignments the Levee 

Assignments dialog box will open (Figure 7.12). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, on the File menu, click 

Close, the Levee Assignments dialog box will close (Figure 7.12). 
 
 

Figure 7.12  Levee Assignments Dialog Box 

7.7 Data Entry Variables for Levee Features 
 
Plan Name:  Select a previously defined plan name. 
 
Stream Name:  Select a previously defined stream name. 
 
Analysis Year:  Select a previously defined analysis year. 
 
Damage Reach:  Select a previously defined damage reach. 
 
Levee Name:  Name (required) for the levee/floodwall for this plan, 
analysis year, stream, and damage reach.  Used for subsequent pick lists 
and reports.  A new levee can be added to the database.  An existing levee 
can be copied, updated, or deleted.  The maximum length is 16 characters. 
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Levee Description:  Description of the defined levee, optional.  The 
maximum length is sixty-four (64) characters. 
 
Top of Levee Stage:  The stage (elevation) of the top of the levee at the 
damage reach's index location (required). 
 
Exterior Stage:  The stream-side stage associated with water surface 
profile stages at the damage reach index location.  Used to define 
relationships of interior stages and levee failure probabilities. 
 
Interior Stage:  The interior stage associated with the exterior stage that 
is required when the levee overtops, but not enough flood volume is 
available to equalize the interior stage with the exterior stage.  A detailed 
hydraulics analysis outside of FDA is required to determine the exterior-
interior relationship.  The corresponding interior stage values are used for 
the damage computations of the interior area. 
 
Probability of Failure:  The probability of the levee failing 
geotechnically for a given exterior stage.  The relationships require 
detailed analyses outside of FDA.  Failure is assumed to be the combined 
conditional probability of failure from such causes as: piping, seepage, and 
under seepage. 
 
Still Water Stage:  The stage corresponding to the exterior stage-
discharge or stage-probability function at the damage reach's index 
location.  Still water stage is associated with the wave height to determine 
wave overtopping conditions and analyses. 
 
Wave Height:  Wave height is in feet (meters) and is associated with the 
still water stage. 
 
Wave Shape Factor:  The ratio of the portion of the wave above the levee 
or floodwall to the total wave height.  It is determined by dividing the total 
height by the wave run-up.  The total height above the levee is determined 
by subtracting the levee crest stage from the exterior stage with wave. The 
wave run-up is assumed equal to two-thirds the wave height if the still 
water stage alone exceeds to top-of-levee or to the full wave height if the 
still water stage is below the top of the levee. 
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CHAPTER 8  
 
 

Economics 
 
 

8.1 General 
 
Economics is where you perform data entry and computations to produce 
stage-damage functions with uncertainty for flood damage reduction.  
First, definition of Study Damage Categories for analysis and reports is 
required.   You may then enter the stage-damage functions with 
uncertainty directly by damage category and damage reach.  However, for 
most studies, the functions are generated using the compute stage-damage 
uncertainty option.  This option requires conventional development of 
structure inventories of structure attributes and specification of 
uncertainties associated with key data.  Water surface profiles, specified 
under HydEng (see Chapter 4), are required to produce the stage damage 
uncertainty functions by damage categories at the damage reach index 
locations.  This is performed by aggregating individual structure stage-
damage functions to the index location by adjusting for the slope in water 
surface profiles.  A detailed description of the methods described in this 
chapter is found in Appendix F. 
 
Structure information is entered under Structure Occupancy Type (see 
Chapter 9) and Structure Inventory (see Chapter 11).  Structure 
Occupancy Type is a subcategory of a damage category (see Section 8.2, 
page 8-3) and provides common information for similar structures.  
Included are depth-percent damage and uncertainty functions for the 
structure, contents, other; structure/content value and structure/other value 
ratios; uncertainties for first floor stage, structure value, structure/content 
value ratio, and structure/other value ratio.  A structure is assigned to a 
structure occupancy type.  Structure inventory information includes the 
structure name, description, stream, stream bank, stream station, structure 
stages, structure and content values, addresses, coordinates, and other data. 
 
The typical sequence you would follow in the economics section is: 
 
 1) Create damage categories, you must at least create one. 
 
 2) For each defined damage category, enter structures occupancy 

types information.  Structure occupancy types are not required. 
 
 3) Create structure modules and assign to a plan, analysis year 

group. 
 

Economics is 
where you 
perform data 
entry and 
computations to 
produce stage-
damage functions 
with uncertainty 
for flood damage 
reduction. 
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 4) If you are using a structure inventory you need to enter the data 

directly or import a structure inventory from an ASCII file. 
 
 5) Finally, you will manually enter, compute, or import stage-

damage functions into your study. 
 
The dialog boxes you will use to input data for damage categories, 
structure occupancy types, and structure modules have a common Menu 
Bar.  The Menu Bar contains the following common menus, for a 
description of the Help menu see Chapter 2 (Section 2.4.8, page 2-12): 
 
 File This menu is used for file management and contains the 

following commands: 
 Add/Update: you either update (edit) an existing 

economics data item (damage categories, structure 
occupancy types, structure modules) information or add a 
new economics data item to the study. 

 Close: close the open dialog box; if changes have not been 
saved a warning message will appear. 

 
 Edit This menu is used for editing economics data items, traversing 

the records in an economics data item list, creating economics 
data items, and deleting economics data items.  The commands 
available are: 

 Cut/Copy/Paste: the standard cut/copy/paste commands 
 First Record: places you on the first record of the 

economics data item list 
 Last Record: places you on the last record of the 

economics data item list 
 Next Record: places you on the next record of the 

economics data item list 
 Previous Record: places you on the previous record of the 

economics data item list 
 New Record: creates a new economics data item record 
 Delete Record: deletes the selected economics data item 

from the list 
 
 View This menu is used to review what economics data items have 

been created for the study; there is only one command - List of 
Economics Data Items. 

 
Contents 
 
 ● Damage Categories 
 ● Import/Export 
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8.2 Study Damage Categories 
 
Damage categories are used to consolidate large numbers of structures into 
specific categories with similar characteristics for analysis and reports.  
Typical damage categories include:  residential, commercial, industrial, 
open space, and public facilities.  Several structure occupancy types, 
discussed later, may be assigned to a study damage category.  For 
example, single family residential and apartments are structure occupancy 
types (subcategories) assigned to the residential damage category.  Figure 
8.1 shows the Study Damage Categories dialog box. 

 
8.2.1 Defining Damage Categories 

 
You should define enough damage categories (maximum of 20) to 
facilitate detailed reporting.  There is a minimal increase in computational 
time for additional damage categories.  The number of damage categories 
should be sufficient to give enough detail but not too numerous to 
complicate data management. 
 
FDA calculates stage-damage on a structure-by-structure basis and 
aggregates the results for each structure to the index location.  The stage-
damage calculations for some categories of damage (emergency costs, 
road damage, and automobile damage) normally do not use structure 
inventory techniques.  However, to include these damage categories in the 
risk analysis, you may calculate the stage-aggregated damage with 
uncertainty outside of FDA and enter the resulting stage-damage as a 
"direct depth-dollar damage" function for a pseudo structure.  Typically, a 
pseudo structure is entered at the index location with either a pseudo first 
floor stage or a first floor stage set to zero.  The depth-dollar damage 
function may be entered either using the normal depth-damage function or 
an elevation-damage function.  If elevations are used, then the first floor 
stage is entered as zero (not blank). 
 
 

Figure 8.1  Study Damage Categories Dialog Box 

Damage categories 
are used to 
consolidate large 
numbers of 
structures into 
specific categories 
with similar 
characteristics for 
analysis and 
reports.  Typical 
damage categories 
include:  
residential, 
commercial, 
industrial, open 
space, and public 
facilities. 
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8.2.2 Create Damage Categories 
 
To create damage categories: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Damage 
Categories. 

 2. The Study Damage Categories dialog box will open (see Figure 
8.1, page 8-3). 

 3. Type a name (required) in the Damage Category list.  The 
maximum length is sixteen (16) characters. 

 4. Type a description (optional but recommended) in the Description 
box.  The maximum length is sixty-four (64) characters. 

 5. The price index is used to update the monetary values of the 
structures assigned to the damage category.  It overwrites the global 
price index value (default value) that was entered when the study 
was created (see Chapter 2, Section 2.3.1, page 2-5).  Type the price 
index for the damage category in the Price Index box (see Figure 
8.1, page 8-3). 

 5. Click Add, the damage category is added, and you can enter 
additional damage categories if you wish. 

 6. When you are finished with entering your damage categories, on the 
File menu, click Close, the Study Damage Categories dialog box 
will close (see Figure 8.1, page 8-3). 

 
Additional ways to create damage categories are provided from the Study 
Damage Categories dialog box (see Figure 8.1, page 8-3): 
 
 ● On the Edit menu, click New Record, you can now enter a new 

damage category from the Study Damage Categories dialog box 
(see Figure 8.1, page 8-3). 

-or- 
 ● From the Navigator Button (see Chapter 2, Section 2.4.4, page  
  2-10), click the center of the button; you can now enter a new 

damage category from the Study Damage Categories dialog box 
(see Figure 8.1, page 8-3). 

 
 

8.2.3 Edit Damage Categories 
 
Edit damage categories that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Damage 
Categories. 

 2. The Study Damage Categories dialog box will open (see Figure 
8.2, page 8-5). 



HEC-FDA User's Manual Chapter 8 - Economics 

 8-5 

 

 3. From the Damage Category list see (Figure 8.1, page 8-3) select 
the damage category you want to edit and make the necessary 
updates. 

 4. Click Update, the changes are saved for the selected damage 
category. 

 5. When you are finished with editing your damage categories, on the 
File menu, click Close, the Study Damage Categories dialog box 
will close (Figure 8.2). 

 
 

8.2.4 Delete Damage Categories 
 
Delete damage categories that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Damage 
Categories. 

 2. The Study Damage Categories dialog box will open (Figure 8.2). 
 3. From the Damage Category list (Figure 8.2) select the damage 

category you want to delete. 
 4. On the Edit menu, click Delete Record.  A warning message will 

appear asking you if you really want to delete the damage category.  
Click Yes, the damage category will no longer be available. 

 5. When you are finished with deleting damage categories, on the File 
menu, click Close, the Study Damage Categories dialog box will 
close (Figure 8.2). 

 
 

8.2.5 List of Damage Categories 
 
To review the damage categories that you have entered for your study, 
FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Damage 
Categories. 

Figure 8.2  Study Damage Categories Dialog Box - Update Button 
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 2. The Study Damage Categories dialog box will open (see Figure 

8.1, page 8-3). 
 3. On the View menu, click List of Damage Categories, the List of 

Damage Categories dialog box will open (Figure 8.3). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List of Damage Categories dialog box will close 
(Figure 8.3). 

 
 

8.2.6 Data Entry Variables for Damage Categories 
 
Damage Category Name:  Required name for the defined damage 
category, which is used for subsequent data entry pick lists.  Also used on 
reports and plots.  A new damage category name can be added to the 
database.  An existing damage category name can be selected, updated, or 
deleted.  The maximum length is 16 characters. 
 
Damage Category Description:  Optional description of the defined 
damage category.  The maximum length is 64 characters. 
 
Price Index:  Optional price index adjustment to damage values for this 
category.  The price index at the damage category level overrides the 
global price index. 
 
 

Figure 8.3  List of Damage Categories Dialog Box 
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8.3 Import/Export Study Data 

 
You may import old HEC-SID structure inventory information into HEC-
FDA using the Economic/Import menu.  You may also import ASCII 
*.txt files from commercial spreadsheets and databases. You may also 
export data to ASCII delimited text files for use in other software such as 
spreadsheets or databases.  Please see Appendix E for a more detailed 
description of the procedures. 
 
 

8.3.1 Import HEC-SID Structure Inventory 
 
For details on the import requirements for an HEC-SID (Structure 
Inventory for Damage Analysis) structure inventory see Appendix E, 
Section E.4 (page E-20).  If you have an HEC-SID data file that meets the 
requirements, from FDA do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, point to Import, click Old 
SID File. 

 2. The Import Structure Inventory dialog box will open (Figure 
8.4). 

 3. From the Stream Name list (Figure 8.4) select the stream where the 
structures are located. 

 4. From the Module Name list select the structure module that will be 
associated with the structures. 

 5. Click Import, the Import Structure Inventory Data browser will 
open (see Figure 8.5, page 8-8).  By default the browser is looking 
for SID input files (*.s).  Select the appropriate file; click Open, the 
Import Structure Inventory Data browser will close. 

 6. The program gives no indication that the import is being done, the 
Import Structure Inventory Data dialog box (Figure 8.4) will 
lose focus (title bar will become gray) when the import is finished. 

 7. On the File menu, click Close, the Import Structure Inventory 
Data dialog box will close (Figure 8.4). 

 

Figure 8.4  Import Structure Inventory Dialog Box 

From HEC-FDA 
you can import 
old HEC-SID 
inventory 
information from 
HEC-SID input 
files (*.s).  See 
Appendix E for 
further details 
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8.3.2 Importing HEC-FDA Study Data 

 
FDA imports data from a text file (*.txt) which contains delimited fields.  
By default, FDA expects the fields to be separated by the tab character; 
you can specify a different field separator.  FDA requires a specific format 
for this file, which is described in Appendix E.  FDA will import the 
following data:  plans, analysis years, streams, damage reaches, damage 
categories, structure occupancy types, structure modules, structures, water 
surface profiles, exceedance probability (frequency) curves, stage-
discharge (rating curves), and levee data.  To import FDA data: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, point to Import, click 
ASCII Tab Delimited. 

 2. The Import Data dialog box 
will open (Figure 8.6).  By 
default the character separating 
fields in the file is a tab.  From 
the Import Data dialog box 
you can select from a pre-
defined list, or enter your own 
field separator by clicking 
Other Character and entering 
a character in the Other 
Character box. 

 3. If you wish to update data that 
is already included in the study, 
click Update Data. 

 4. Click Import, the Import 
Data browser will open (see 
Figure 8.7, page 8-9). 

From HEC-FDA 
you can import 
FDA data from 
ASCII delimited 
files.  By default, 
FDA assumes an 
ASCII tab 
delimited file.. 

Figure 8.6  Import Data Dialog Box 

Figure 8.5  Import Structure Inventory Data Browser 
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 5. By default the browser is looking for text (tab delimited, *.txt) files.  
Select the appropriate file; click Open, the Importing Data Status 
dialog box will open (Figure 8.8). 

 6. The Importing Data Status dialog box (Figure 8.8) will provide 
information on the importing of the data.  Once the import is 
finished, the Importing Data Status dialog box will contain a 
message "Importing of Data was Successful" and the Import Data 
dialog box (see Figure 8.6, page 8-8) and the Import Structure 
Inventory Data browser will close (Figure 8.7). 

 7. After reviewing the information in the Importing Data Status 
dialog box (Figure 8.8), click Close, the Importing Data Status 
dialog will close, and your FDA study now contains data. 

 
 

8.3.3 Exporting HEC-FDA Study Data 
 
All FDA study data can be exported to a text file (*.txt) which contains 
delimited fields.  By default, FDA expects the fields to be separated by the 
tab character; you can specify a different field separator.  FDA will export 
the following data:  plans, analysis years, streams, damage reaches, 
damage categories, structure occupancy types, structure modules, 
structures, water surface profiles, exceedance probability (frequency)  

Figure 8.7  Import Data Browser 

Figure 8.8  Importing Data Status Dialog Box 
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curves, stage-discharge (rating curves), and levee data.  To export FDA 
data: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Export. 
 2. The Export Data dialog box will open (Figure 8.9). 

 3. By default the character separating fields in the file is a tab.  From 
the Export Data dialog box, from the Export Field Separator(s) 
box (Figure 8.10) you can select from 
a pre-defined list, or enter your own 
field separator by clicking Other 
Character and entering a character in 
the Other Character box. 

 4. From the Export Options box 
(Figure 8.11) the user can select all 
FDA study data to be exported (click 
Select All), or the user can select 
individual data items to be exported.  
For example (Figure 8.11) if you only 
wanted to export the structure inventory data, click Deselect All, 
and then click Structures.  Now the only data that will be exported 
from the study would be the structure inventory. 

 5. Now that you are ready, click Export, the Export Data browser 
will open (see Figure 8.12, page 8-10).  FDA by default provides a 
filename of FDA_ExportASCII.txt, you can change this name. 

Figure 8.9  Export Data Dialog Box 

Figure 8.10 Export Field 
Separator(s) Box 

Figure 8.11  Export Options Box 

From HEC-FDA 
you can export 
most study data to 
an ASCII text file.  
By default, the file 
is an ASCII tab 
delimited file. 
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 6. Click Save, the Exporting Data Status dialog box will open 
(Figure 8.13). 

 7. The Exporting Data Status dialog box (Figure 8.13) will provide 
information on the exporting of the data.  Once the export is 
finished, the Exporting Data Status dialog box will contain a 
message "Exporting of Data was Successful" and the Export Data 
dialog box (see Figure 8.9, page 8-10) and the Export Structure 
Inventory Data browser will close (Figure 8.12). 

 8. After reviewing the information in the Exporting Data Status 
dialog box (Figure 8.13), click Close, the Exporting Data Status 
dialog will close, and your FDA study now contains data. 

 

Figure 8.12  Export Data Browser 

Figure 8.13  Exporting Data Status Dialog Box 
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CHAPTER 9  
 
 

Structure Occupancy Types 
 
 

9.1 General 
 
A structure occupancy type describes a class of structures (e.g. single 
family, no basement, raised foundation, one story).  Data entered for a 
structure occupancy type is applied to all the structures assigned to that 
structure occupancy type.  Structures are assigned to an occupancy type in 
the structure inventory editor (see Chapter 11). 
 
Data entered in the structure occupancy type editor (Figure 9.1) include: 
 ● The depth-percent damage functions (structure, content, and other); 
 ● the content-to-structure value ratio – used to estimate the value of 

contents based on a percentage of the value of the structure; and 
 ● the uncertainties in the first floor elevation, value ratios (content to 

structure, and other to structure), and the damage in the depth-
damage functions. 

 
Structure occupancy types are a subcategory of damage categories. 
Several structure occupancy types can be assigned to a single damage 
category.  For example, single-story structures with no basements, single-
story structures with basements, mobile homes, and duplex apartments are 
different structure occupancy types assigned to a residential damage 

A structure 
occupancy type 
describes a class 
of structures (e.g. 
single family, no 
basement, raised 
foundation, one 
story). 

Figure 9.1  Study Structure Occupancy Types Dialog Box 
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category.  Each occupancy type would have unique depth-damage 
functions and uncertainty parameters. 
 
Uncertainty or error distributions associated with estimating the depth-
damage functions, structure values, content value ratios, other value ratios 
and first flood stage are used to develop the total aggregated stage-
damage-uncertainty functions by damage categories for the damage reach.  
The uncertainty of each parameter may be defined using none (no 
uncertainty), normal, triangular or log normal probability density 
functions. 
 
 

9.2 Defining Structure Occupancy Types 
 
Structure occupancy types are defined by damage category, and the same 
structure occupancy type cannot be used for different categories.  
Structure occupancy types contain depth-damage functions where damage 
is defined in percent of value (structure, content, and other).  Structures 
which have a direct depth-dollar damage function assigned to them have a 
structure occupancy type with an FDA internally generated name.  You 
will not normally see the direct damage function occupancy types except 
in the List of All Structure Occupancy Types dialog box (see Section 
9.6, page 9-15).  Although user-defined structure occupancy types can 
apply to one structure, they normally represent a large class of structures 
(i.e., one story, single family residential, wood frame construction, no 
basement). 
 
 

9.3 Create Structure Occupancy Types 
 
To create a structure occupancy type: 
 
 1. From the HEC-FDA main window (see Chapter 2, Section 2.1, 

Figure 2.1, page 2-2), on the Economics menu, click Study 
Structure Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Damage Category list, select the damage category you 
want to create a structure occupancy type for. 

 4. Type a name (required) in the Structure Occupancy Type list.  
The maximum length is sixteen (16) characters. 

 5. Type a description (optional but recommended) in the Description 
box.  The maximum length is sixty-four (64) characters. 

 6. Enter the Structure, and/or Content, and/or Other depth-percent 
damage function for the structure occupancy type.  See Section 
9.3.1 (page 9-3) for more detail on depth-percent damage functions. 
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 7. Enter the Content to Structure Value Ratio (see Figure 9.1, page 
9-1), which represents the maximum content value divided by the 
maximum structure value.  This value is entered as a percentage and 
is used to compute the content value from the structure value if a 
content value is not specified in the structure inventory. 

 8. If you are computing damages to "other" (damage to landscape, 
automobiles, etc), enter the Other to Structure Value Ratio, 
which is the numeric value (in percent) that represents the 
maximum "other" value divided by the maximum structure value. 

 9. From the Define Uncertainty Parameters box, you enter the 
uncertainty or error distributions associated with estimating the first 
floor stage (First Floor Stage), the structure value (Structure 
Value), the content value ratios (Content/Structure Value), and 
the other value ratios (Other/Structure Value). 

 10. Click Add, the structure occupancy type will be added to the study, 
and you can enter additional structure occupancy types if necessary. 

 11. When you are finished entering structure occupancy types, from the 
File menu, click Close. 

 
Additional ways to add new structure occupancy types are provided in the 
Study Structure Occupancy Types dialog box (see Figure 9.1, page 9-1): 
 
 ● From the Edit menu, click New Record, you can now enter a new 

structure occupancy type from the Study Structure Occupancy 
Types dialog box (see Figure 9.1, page 9-1). 

-or- 
 ● From the Navigator Button (see Chapter 2, Section 2.4.4, page  
  2-10), click the center button; you can now enter a new structure 

occupancy type from the Study Structure Occupancy Types 
dialog box (see Figure 9.1, page 9-1). 

 
 

9.3.1 Depth-Percent Damage Functions 
 
Depth-percent damage functions represent the damage caused to a 
structure, contents of a structure, and other for given depths of flooding at 
that structure.  The damage is based on a percentage of the total value of 
the structure, content, and "other" respectively.  The percent-damage is 
multiplied by the structure value, content value, or "other" value to get a 
unique depth-damage function at the structure.  Other can be used to 
compute damage for any other item not accounted for in structure value 
and content value (i.e. automobiles, landscape). 
 
Depth-percent damage functions should always contain a zero damage 
depth, and negative depths are acceptable.  The zero depth is assumed to 
coincide with stage (elevation) of the first floor. 
 

Depth-percent 
damage functions 
represent the 
damage caused to 
a structure, 
contents of a 
structure, and 
other for given 
depths of flooding 
at that structure.  
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In the cases where content or other values are not available, they can be 
computed by FDA as a percentage of the total value of the structure. Enter 
these ratios in the content to structure value ratio and the "other" to 
structure value ratio boxes. The actual value of contents and other may be 
entered for each structure in the structure inventory editor. Doing so will 
override the value computed from the ratios contained in the structure 
occupancy type. 
 
The uncertainty associated with the depth-percent damage function is 
entered by ordinates based on the specified distribution. 
 
 

 Structure 
 
To enter a structure depth-percent damage function for a structure 
occupancy type: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Define Depth-Percent Damage Function box, click 
Structure, the Depth-Percent Damage Function - Structure 
dialog box will open (Figure 9.2). 

 4. Enter the depth-
percent damage 
function ordinates 
using the Depth 
and Damage 
columns. 

 5. If you are entering 
uncertainty data, 
select the 
appropriate error 
distribution in the 
Define 
Uncertainty box 
(Figure 9.2).  The 
proper columns for entering uncertainty parameters will be added to 
the table depending on your choice. 

 6. To view a plot of the structure depth-percent damage function, click 
Plot, or from the View menu click Depth-Percent Function Plot.  
The Depth-Percent Damage Function Plot - Structure dialog box 
will open (see Figure 9.3, page 9-5). 

 7. To view the data that composes the structure depth-percent damage 
function in a tabular form, click Tabulate, or from the View menu  

Figure 9.2 Depth-Percent Damage Function - 
Structure Dialog Box 
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  click Depth-Percent Function Report.  The Depth-Percent 
Damage Function Report - Structure dialog box will open 
(Figure 9.4). 

 8. When you are finished defining the structure depth-percent damage 
function, click Save.  The Depth-Percent Damage Function - 
Structure dialog box will close returning you to the Study 
Structure Occupancy Types dialog box (see Figure 9.1, page 9-1). 

 
 

Figure 9.3 Depth-Percent Damage Function Plot - Structure Dialog 
Box 

Figure 9.4 Depth-Percent Damage Function Report - Structure 
Dialog Box 
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 Content 
 
To enter a content depth-percent damage function for a structure 
occupancy type: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Define Depth-Percent Damage Function dialog, click 
Content, the Depth-Percent Damage Function - Content dialog 
box will open (Figure 9.5). 

 4. Enter the content depth-percent damage function ordinates in the 
Depth and Damage columns. 

 5. If you are entering uncertainty data, click the appropriate error 
distribution.  The proper columns will be added to the table. 

 6. To view a plot of the content depth-percent damage function, click 
Plot, or from the View menu click Depth-Percent Function Plot.  
The Depth-Percent Damage Function Plot - Content dialog box 
will open (see Figure 9.6, page 9-7). 

 7. To view your content depth-percent damage function in a tabular 
form, click Tabulate, or from the View menu click Depth-Percent 
Function Report.  The Depth-Percent Damage Function Report 
- Content dialog box will open (see Figure 9.7, page 9-7). 

 8. When you are finished defining the content depth-percent damage 
function, click Save.  The Depth-Percent Damage Function - 
Content dialog box will close, returning you to the Study 
Structure Occupancy Types dialog box (see Figure 9.1, page 9-1). 

Figure 9.5  Depth-Percent Damage Function - Content Dialog Box 
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Figure 9.6 Depth-Percent Damage Function Plot - Content Dialog 
Box 

Figure 9.7 Depth-Percent Damage Function Report - Content 
Dialog Box 

 
 Other Other 

  
To enter a depth-percent damage function for damageable property other 
than the structure or contents of a building, use the "other" option: 
To enter a depth-percent damage function for damageable property other 
than the structure or contents of a building, use the "other" option: 
  
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 
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 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Define Depth-Percent Damage Function box, click 
Other, the Depth-Percent Damage Function - Other dialog box 
will open (Figure 9.8). 

 4. Enter the other 
depth-percent 
damage ordinates 
in the Depth and 
Damage 
columns. 

 5. If you are 
entering 
uncertainty data, 
select the 
appropriate error 
distribution.  The 
proper columns 
will be added to 
the table for 
entering the uncertainty information. 

 6. To view a plot of your other depth-percent damage function, click 
Plot, or from the View menu click Depth-Percent Function Plot.  
The Depth-Percent Damage Function Plot - Other dialog box 
will open (Figure 9.9). 

 

Figure 9.8 Depth-Percent Damage Function - Other 
Dialog Box 

Figure 9.9 Depth-Percent Damage Function Plot - Other Dialog Box 
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 7. To view the data of your other depth-percent damage function in a 
tabular form, click Tabulate, or from the View menu click Depth-
Percent Function Report.  The Depth-Percent Damage Function 
Report - Other dialog box will open (Figure 9.10). 

 8. When you are finished defining the "other" depth-percent damage 
function, click Save.  The Depth-Percent Damage Function – 
Other dialog box will close (see Figure 9.8, page 9-8) returning you 
to the Study Structure Occupancy Types dialog box (see Figure 
9.1, page 9-1). 

 
 

Figure 9.10 Depth-Percent Damage Function Report - Other Dialog 
Box 

9.3.2 Content to Structure Value Ratio 
 
The content to structure value ratio is the numeric value, in percent, that 
represents the content value divided by the structure value for a particular 
structure occupancy type.  It is used to estimate total content value if the 
structure inventory does not include content value information.  The 
computed content value is then used to proportion the contents depth-
percent damage function. 
 
The actual value of contents may be entered for each structure in the 
structure inventory editor.  Doing so will override the value computed 
from the ratios contained in the structure occupancy type.  Enter the ratio 
as a whole number (i.e. enter 50 for a ratio of 50%). 
 
EGM 04-01 contains generic depth-damage relationships that can be 
applied in the absence of regionally developed relationships.  The content 
damage relationships in EGM 04-01 represent a percentage of structure 
value, not content value.  Therefore, when using the content damage 
relationships from EGM 04-01, enter a value of 100 (100%) as the content 
to structure value ratio in FDA.  The program will still compute content 
damage as a percentage of content value.  However, since the content 

The content to 
structure value 
ratio is the 
numeric value, in 
percent, that 
represents the 
content value 
divided by the 
structure value 
for a particular 
structure 
occupancy type. 
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value is equal to structure value, the result is that content damage becomes 
a percentage of structure value. 
 
 

9.3.3 Other to Structure Value Ratio 
 
The other to structure value ratio is the numeric value, in percent, that 
represents the maximum other value divided by the maximum structure 
value for a particular structure occupancy type.  It is used to estimate total 
value of the property represented by other if the structure inventory does 
not include other value information.  The computed value is then used to 
proportion the other depth-percent damage function.  
 
The actual value of other may be entered for each structure in the structure 
inventory editor.  Doing so will override the value computed from the 
ratios contained in the structure occupancy type.  Enter the ratio as a 
whole number (i.e. enter 50 for a ratio of 50%). 
 
 

The other to 
structure value 
ratio is the 
numeric value, in 
percent, that 
represents the 
maximum other 
value divided by 
the maximum 
structure value 
for a particular 
structure 
occupancy type. 

9.3.4 Define Uncertainty Parameters 
 
Uncertainty, or error distributions, associated with estimating the depth-
damage functions, structure values, content value ratios, other value ratios 
and first flood stage are used to develop the total aggregated stage-
damage-uncertainty functions by damage categories for a damage reach.  
The uncertainty of each parameter may be defined using none (no 
uncertainty), normal, triangular or log normal probability density 
functions. 
 
 

 First Floor Stage 
 
The standard deviation in feet (meters) of the uncertainty in the first floor 
stage estimate of a particular structure occupancy type.  This value is 
based on the procedures/type of surveys used to estimate the first floor 
stage. Values illustrated in Table 9.1 (page 9-11) can be used as a guide. 
 
To enter the error associated with the first floor stage: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. Click First Floor Stage. The Error Associated with First Floor 
Stage dialog box will open (see Figure 9.11, page 9-11). 
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Table 9.1 
Uncertainty Based on Measurement Methods 

 
 

Method 
Contour 
Interval 

(ft) 

Error 
(ft) 

Standard 
Deviation 

(ft) 
Field survey    
 Hand level NA ± 0.2 @ 50’ 0.1 
 Stadia NA ± 0.4 @ 500’ 0.2 
 Conventional level NA ± 0.05 @ 800’ 0.03 
 Automatic level NA ± 0.03 @ 800’ 0.02 
Aerial survey    
 2’ ± 0.59 0.3 
 5’ ± 1.18 0.6 
 10’ ± 2.94 1.5 
Topographic map    
 2’ ± 1.18 0.6 
 5’ ± 2.94 1.5 
 10’ ± 5.88 3 

 
 4. Select the appropriate distribution from the Distribution Type 

group. 

Figure 9.11 Error Associated with First Floor Stage Dialog Box 

 5. Enter the appropriate value(s) in the First Floor Stage Error box 
(Figure 9.11). 

 6. Click OK, the Error Associated with First Floor Stage dialog box 
will close, and return you to the Study Structure Occupancy 
Types dialog box (see Figure 9.1, page 9-1). 

 7. The checkbox next to First Floor Stage will be selected. 
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 Structure Value 
 
The error associated with structure value is entered as the standard 
deviation, in percent of structure value, associated with the uncertainty in 
the structure value estimate for a particular structure occupancy type. 
 
To enter the error associated with the structure value: 
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 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. Click Structure Value; the Error Associated with Structure 
Value dialog box will open (Figure 9.12). 

 4. Select the appropriate distribution from the Distribution Type 
group. 

 5. Enter the appropriate value(s) in the Structure Value Error box. 
 6. Click OK, the Error Associated with Structure Value dialog box 

will close, and return you to the Study Structure Occupancy 
Types dialog box (see Figure 9.1, page 9-1). 

 7. The checkbox next to Structure Value will be selected. 
 
 

Figure 9.12 Error Associated with Structure Value Dialog Box 

 Content/Structure Value 
 
The standard deviation is a percent of the content to structure value ratio.  
It is associated with the error in estimating the ratio.  For example, for a 
content to structure value ratio of fifty percent, an entered standard 
deviation of ten (10) percent would mean that the plus/minus one standard 
deviation range is forty-five to fifty-five percent.  Leave the 
Content/Structure value blank when using the generic content depth-
damage relationships from EGM 04-01. 
 
To enter the error associated with the content/structure value: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. Click Content/Structure Value; the Error Associated with 
Content/Structure Value dialog box will open (see Figure 9.13, 
page 9-13). 
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Figure 9.13 Error Associated with Content/Structure Value Dialog Box 

 4. Select the appropriate distribution type from the Distribution Type 
group. 

 5. Enter the appropriate value(s) in the Content/Structure Value 
Error box. 

 6. Click OK, the Error Associated with Content/Structure Value 
dialog box will close, and return you to the Study Structure 
Occupancy Types dialog box (see Figure 9.1, page 9-1). 

 7. The checkbox next to Content/Structure Value will be selected. 
 

 Other/Structure Value 
 
The standard deviation is a percent of the "other" to structure value ratio.  
It is associated with the error in estimating the ratio.  For example, for a 
"other" to structure value ratio of fifty percent, an entered standard 
deviation of ten (10) percent would mean that the plus/minus one standard 
deviation range is forty-five to fifty-five percent. 
 
To enter the error associated with the other/structure value: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. Click Other/Structure Value; the Error Associated with 
Other/Structure Value dialog box will open (Figure 9.14). 

Figure 9.14 Error Associated with Other/Structure Value Dialog Box 
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 4. If there is uncertainty associated with the other/structure value, 
from the Distribution Type group select the appropriate 
distribution type. 

 5. Enter the appropriate value(s) in the Other/Structure Value Error 
box. 

 6. Click OK, the Error Associated with Other/Structure Value 
dialog box will close, and return the user to the Study Structure 
Occupancy Types dialog box (see Figure 9.1, page 9-1). 

 7. The checkbox next to Other/Structure Value will be selected. 
 
 

9-14 

9.4 Edit Structure Occupancy Types 
 
To edit structure occupancy types that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Damage Category list, select the damage category that 
contains the structure occupancy type you want to edit. 

 4. From the Structure Occupancy Type list, select the structure 
occupancy type you want to edit and make the necessary updates. 

 5. All of the items in Section 9.2 (page 9-2) can be edited for each 
defined structure occupancy type. 

 6. Click Update (Figure 9.15), the changes are saved for the selected 
structure occupancy type. 

 

Figure 9.15 Study Structure Occupancy Types Dialog Box - Update 
Button 
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 7. When you are finished editing the occupancy type, from the File 

menu, click Close. 
 
 

9.5 Delete Structure Occupancy Types 
 
To delete a structure occupancy type that has already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the Damage Category list, select the damage category that 
contains the structure occupancy type that you want to delete. 

 4. From the Structure Occupancy Type list select the structure 
occupancy type you want to delete. 

 5. From the Edit menu, click Delete Record.  A warning message will 
appear asking if you really want to delete the structure occupancy 
type.  Click Yes, the structure occupancy type will no longer be 
available. 

 6. When you are finished with deleting structure occupancy types, 
from the File menu, click Close. 

 
 

9.6 List of All Structure Occupancy Types 
 
To review the structure occupancy types that you entered for a study, 
HEC-FDA provides a report.  To access the report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Study Structure 
Occupancy Types. 

 2. The Study Structure Occupancy Types dialog box will open (see 
Figure 9.1, page 9-1). 

 3. From the View menu, click List of All Structure Occupancy 
Types, the List of All Structure Occupancy Types dialog box will 
open (see Figure 9.16, page 9-16). 

 4. To print this report, from the File menu, click Print. 
 5. When you are finished reviewing this report, from the File menu, 

click Close. 
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Figure 9.16  List of All Structure Occupancy Types Dialog Box 

 
9.7 Description of Structure Occupancy Type Data Entry 

Variables 
 
Damage Category Name:  A previously defined damage category name. 
You must select a damage category before proceeding with the structure 
occupancy type dialog. 
 
Structure Occupancy Type:  Required name given to a similar set of 
structures that is used to define the depth-percent damage function(s) and 
first floor, structure value, content/structure value ratio and other/structure 
value ratio uncertainty of the type of structures.  An existing structure 
occupancy type can be selected, updated, or deleted.  The maximum 
length is sixteen (16) characters. 
 
Structure Occupancy Description:  Optional description of the defined 
structure occupancy type, up to sixty-four (64) characters. 
 
Depth-percent Damage Function:  Depth-percent damage functions 
define the percent of the structure damaged for a range of flood stages at a 
structure.  The percent-damage is multiplied by the structure value to get a 
unique depth-damage function at the structure.  The zero depth is assumed 
to coincide with stage (elevation) of the first floor.  Separate depth-percent 
damage functions for contents and "other" may be developed in a similar 
manner.  Contents and other damage may also be based on the content to 
structure value ratio and the other to structure value ratio.  The uncertainty 
associated with the depth-percent damage function is entered by ordinates 
based on the type of distribution specified.  
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Content to Structure Value Ratio:  The numeric value in percent that 
represents the maximum content value divided by the maximum structure 
value for a particular structure occupancy type.  It is used to compute the 
content value from the structure value if content value does not exist for 
individual structures in the structure inventory. 
 
Other to Structure Value Ratio:  The numeric value in percent that 
represents the maximum other value (damage to landscape, etc) divided by 
the maximum structure value for a particular structure occupancy type. It 
is used to compute the other value from the structure value if the other 
value does not exist for individual structures in the structure inventory. 
 
Error Associated With: First Floor Stage:  The standard deviation in 
feet (meters) of the uncertainty in the first floor stage estimate of a 
particular structure occupancy type.  Based on the procedures/type of 
surveys used to estimate the first floor stage.   
 
Error Associated With: Structure Value:  The standard deviation in 
percent of structure value associated with the uncertainty in the structure 
value estimate for a particular structure occupancy type.  
 
Error Associated With: Content/Structure Value:  The standard 
deviation is a percent of the content to structure value ratio.  It is 
associated with the error in estimating the ratio.  For example, for a 
content to structure value ratio of fifty percent, an entered standard 
deviation of ten (10) percent would mean that the plus/minus one standard 
deviation range is forty-five to fifty-five percent. 
 
Error Associated With: Other/Structure Value Ratio:  The standard 
deviation is a percent of the other to structure value ratio.  It is associated 
with the error in estimating the ratio.  For example, for a other to structure 
value ratio of fifty percent, an entered standard deviation of ten (10) 
percent would mean that the plus/minus one standard deviation range is 
forty-five to fifty-five percent. 
 
 

9.8 References 
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CHAPTER 10  
 
 

Structure Modules 
 
 

 10-1 

10.1 General 
 
The purpose of structure modules is to allow you to vary one or more 
structure characteristics by plan and year or to include or exclude one or 
more structures from a plan/year.  For example, you may have a couple of 
different development scenarios you want to analyze.  What is the 
potential damage if development A is built by the most likely future year 
versus what is it if development B is built?  In this instance, your base year 
would contain neither development A nor development B structures, only 
structures that exist at the base year.  For the most likely future year and 
plan "Development A", you would add in those structures associated with 
"Development A".  For the most likely future year and plan "Development 
B", you would add in those structures associated with "Development B" 
but not those for "Development A".  To allow the selection of structures in 
"Develop A" and "Develop B", those structures are assigned to different 
structure modules than those that exist at the base year. 
 
Another example of varying structure characteristics by plan and year is 
the case of various proposed levee alignments.  For each levee alignment, 
a different number of structures would be protected by the levee.  In  
HEC-FDA, a damage reach that contains a levee protects all structures in 
the reach.  Thus, if you have different levee alignments, some structures 
are protected in one plan but not in the next.  That requires you to change 
the damage reach that a structure belongs to as a function of the flood 
damage reduction plan. 
 
Other examples include analyzing flood proofing (zero damage point 
changes and/or depth-damage function and or first floor stage changes), 
flood warning (depth-damage function changes), etc.  If you do not need 
to change any of your structure’s characteristics by plan or year or do not 
need to include or exclude a structure by plan/year, you can accept default 
values and virtually ignore structure modules. 
 
Structure modules require definition in three areas: 
 
 1. the structure module name, 
 2. the structure module assignment (assign one or more structure 

modules to each plan/year), and 
 3. assign each structure to one structure module 
 

The purpose of 
structure modules 
is to allow you to 
vary one or more 
structure 
characteristics by 
plan and year or 
to include or 
exclude one or 
more structures 
from a plan/year. 
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When a new study is created, the module "Base" is always created and any 
new structure added to the structure inventory is assigned the "Base" 
module.  Also, when new plans and years are added, the "Base" module is 
always assigned to that plan / year.  At structure entry, you may assign any 
existing module to that structure.  Each structure must have a unique 
structure name.  Thus, if the same structure is present in more than one 
module and you want the characteristics of that structure to change, you 
will have to enter it twice with different names. 
 
For example, structure 234 is an existing structure and one of your plans is 
to raise the structure by two feet, you would enter structure 234 twice.  
First, enter it as structure 234 with its present first floor elevation and 
assign it to the No Raise structure module.  Then, enter the same structure 
with a first floor elevation two feet higher, assign it the name 234_R2, and 
assign it to the structure module Raise 2FT.  Both the Base and NoRaise 
structures modules are assigned to the Without Plan and both the Base and 
Raise 2FT structure modules are assigned to the With Plan.  Notice that 
structure 234 cannot be assigned to the Base structure module because the 
Base structure module is used for the With Plan.  If you assigned structure 
234 to the Base structure module, it would be included twice in the With 
Plan because both structure modules (Base and Raise 2FT) are assigned to 
the With Plan. 
 
Figure 10.1 shows the basic data entry dialog box for Structure Module. 
The structure modules are required if structure inventories are to be 
performed.  The definition of the structure modules must be defined prior 
to development of the structure inventories.  The default module is the 

"Base" module normally containing existing structures or structures 
associated with the without-project base year condition.  Plans associated 
with various future conditions will normally have different modules for 
the future year structures.  This enables analysis of alternative future 
development, such as those considering the Federal Emergency 
Management Association’s regulatory program.  Table 10.1 (page 10-3) 
shows an example of possible structure modules used for perhaps 
thousands of structures.  (Note:  Each structure has a “year in place” 
parameter that allows you to define when a structure goes into the 
floodplain. It may be used in place of structure modules to control 
calculations for future development.) 
 

Figure 10.1  Structure Module Dialog Box 
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Table 10.1 
Structure Inventory Module Concepts 

 
Plan 

Description 
 

Base Year 2009 
 

Most Likely Future 2030 
 
Without Project 

 
BASE MODULE 

BASE MODULE + FUTURE A MODULE 
(Adjusted for Regulation program w/o 
project.) 

 
Levee Project 

 
BASE MODULE 

BASE MODULE + FUTURE B MODULE 
(Adjusted for Regulatory program 
development w/Levee.) 

 
Channel Project 

 
BASE MODULE 

BASE MODULE + FUTURE C MODULE 
(Adjusted by Regulatory program 
development w/channel.) 

 
 

10.2 Create Structure Modules 
 
By default, the Base structure module always exists. If you need additional 
structures modules, it is best to add those to the study before adding 
structures.  To create a structure module: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure Module dialog box will open (Figure 10.2). 

 3. The Base structure module has already been defined.  There are two 
ways to add another structure module: 

 ● From the Edit menu, click New Record, you can now 
enter a new structure module from the Structure 
Module dialog box (Figure 10.2). 

-or- 
 ● From the Navigator Button (see Chapter 2, Section 

2.4.4, page 2-10), click the center of the button; you can 
now enter a new structure module from the Structure 
Module dialog box (Figure 10.2). 

 4. Type a name (required) in the Structure Module Name list.  The 
maximum length is sixteen (16) characters. 

 5. Type a description (optional but recommended) in the Description 
box.  The maximum length is sixty-four (64) characters. 

Figure 10.2  Structure Module Dialog Box - Add Button 
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 6. Click Add, the structure module is added, and you can enter 

additional structure modules if you wish. 
 7. When you are finished with entering your structure modules, from 

the File menu, click Close. 
 
 

10.3 Edit Structure Modules 
 
Edit structure modules that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure Modules dialog box will open (Figure 10.3). 

 3. From the Structure Module list select the structure module you 
want to edit and make the necessary updates. 

 4. Click Update (Figure 10.3), the changes are saved for the selected 
structure module. 

 5. When you are finished with editing your structure modules, from 
the File menu, click Close. 

 
 

Figure 10.3  Structure Module Dialog Box - Update Button 

10.4 Delete Structure Modules 
 
Delete structure modules that have already been defined: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure Module dialog box will open (Figure 10.3). 
 3. From the Structure Module Name list select the structure module 

you want to delete.   
 4. From the Edit menu, click Delete Record.  A warning message will 

appear asking you if you really want to delete the structure module.  
Click Yes, the structure module will no longer be available. 

 5. When you are finished with deleting structure modules, from the 
File menu, click Close. 
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10.5 List of Structure Modules 
 
To review the structure modules that you have entered for your study, 
FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure Module dialog box will open (see Figure 10.3, page 

10-4). 
 3. From the View menu, click List of Structure Modules, the List of 

Structure Modules dialog box will open (Figure 10.4). 

 4. This report can be printed, from the File menu, click Print. 
 5. When you are finished reviewing this report, from the File menu, 

click Close. 
 
 

Figure 10.4  List of Structure Modules Dialog Box 

10.6 Creating Structure Module Assignments 
 
By default, the Base structure module is assigned to all defined years and 
plans.  To assign user defined structure modules do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure 

Module 
Assignment 
dialog box will 
open (Figure 
10.5). 

 3. From the Plan 
list, select the 
plan that you 
want to assign a 
structure 
module. 

Figure 10.5 Structure Module Assignment Dialog 
Box 

 10-5 



Chapter 10 – Structure Modules HEC-FDA User's Manual 

10-6 

 4. From the Analysis Year list, select the analysis year that you want 
to assign a structure module. 

 5. From the Structure Module Name list (see Figure 10.5, page 10-4) 
select the structure module that you want to assign to the selected 
plan and analysis year. 

 6. The Save and Cancel buttons will become active, to save the 
assignment of the selected structure module, click Save. 

 7. To check to see if the assignment has been made, view the structure 
module assignment report (see Section 10.7). 

 5. When you are finished with assigning the structure modules, from 
the File menu, click Close. 

 
 

10.7 Report of Structure Module Assignments 
 
To review the structure module assignments that you have made for your 
study, FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Modules. 
 2. The Structure Module Assignment dialog box will open (see 

Figure 10.5, page 10-4). 
 3. From the View menu, click Structure Module Assignments, the 

Structure Module Assignments dialog box will open (Figure 
10.6). 

 4. This report can be printed, from the File menu, click Print. 
 5. When you are finished reviewing this report, from the File menu, 

click Close. 
 

Figure 10.6  Structure Module Assignments Dialog Box 
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CHAPTER 11  
 
 
 

Structure Inventory 
 
 

11.1 General 
 
Structure inventories are performed to develop a record of the attributes of 
unique or groups of structures relevant to flood damage analysis.  The 
information is used to compute an aggregated stage-damage function by 
damage category at the damage reach index location station.  The damage 
categories, stream, and structure occupancy types must be previously 
specified.  Required structure attributes include:  the name for the 
structure; stream station; stream; bank designation; structure value; 
occupancy type; structure module; and structure stages associated with 
ground or first floor.  Optional attributes include:  content value; other 
value; address; coordinates (highly recommended); notes; an image; and 
additional structure stages for basement type flooding. 
 
Structure depth-damage data may also be entered directly for a specified 
structure occupancy type instead of using the general depth-damage 
functions.  Examples would be for unique inventory surveys of 
commercial and industrial structures, and special damage functions for 
traffic or infrastructure.  The "direct" method is chosen from the structure 
occupancy type pick list.  The first flood survey error in feet (meters) must 
be entered along with the stage-direct damage with uncertainty values for 
the structure.  Content stage-direct damage with uncertainty and "other”" 
stage-direct damage with uncertainty are then similarly entered. 
 
From HEC-FDA, you may enter data manually structure by structure from 
a form (see Section 11.2) or from a table (spreadsheet, see Section 11.3).  
You may also import the data from ASCII (*.TXT) files or SID (USACE 
1989) data files as described in Appendix E. 
 
The structures are assigned to a specific damage category (see Chapter 8), 
structure occupancy type (see Chapter 9), stream (see Chapter 3), and 
structure module (see Chapter 10).  The structure module is used to 
specify which plans and analysis years (see Chapter 3) the structure will 
be used for damage analysis. 
 
For further information on developing structure inventories, refer to the 
following USACE reports by Institute for Water Resources: 
 

A structure 
inventory is a 
record of the 
attributes of 
unique or groups 
of structures 
relevant to flood 
damage analysis. 
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 ● "Natural Economic Development Procedure Manual - Urban Flood 
Damage", March 1988, 88-R-2 

 ● "Natural Economic Development Procedure Manual - Urban Flood 
Damage - Volume II:  Primer on Surveying Flood Damage for 
Residential Structures and Contents", October 1991, 91-R-10 

 ● "Catalog of Residential Depth-Damage Functions", May 1992,  
  92-R-3 
 ● "Analysis of Non-Residential Content Value and Depth-Damage 

Data for Flood Damage Reduction Studies", April 1996, 96-R-12 
 

11-2 

11.2 Entering Structure Inventory Data - Form 
 
To create a structure: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Structure Inventory 
Data. 

 2. The Structure Inventory dialog box will open (Figure 11.1). 

 3. By default, FDA is in the "form" mode for structure inventory data 
entry. 

 4. Type a name (required) in the Individual Structure list.  The 
maximum length is sixteen (16) characters.  Each structure must 
have a unique name – two structures cannot have the same name. If 
the same structure is used in more than one module, it must have a 
unique name for each module. 

 5. Type the stream station (required) of where the structure is located 
on a stream in the Stream Station box.  Must be consistent between 
damage reach boundaries, damage reach index location, water 
surface profiles, and structure location.  A valid value for a stream 
station  is from  9,999,999.99 to 9,999,999.99. 

 

Figure 11.1  Structure Inventory Dialog Box - Form 
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11.2.1 Values Associated with a Structure 

 
 6. Type the value of the structure (does not include the content value) 

in the Structure Value box (Figure 11.2).  A valid numeric value 
for the structure value ranges from 0 to 999,999,999. 

 7. Type the value of the contents (does not include the structure value) 
associated with the structure in the Content Value box (Figure 
11.2).  A valid numeric value for the content value ranges from 0 to 
999,999,999.  If left blank, the contents value is computed from the 
content to structure value ratio that is defined in the occupancy type 
and the structure value. If a content value is entered, it will override 
the content value computed from the content to structure value 
ratio. If you enter zero, the content value will be zero. If the content 
damage is defined with a depth-direct dollar function, the content 
value is not used in the calculations. 

 8. Type the value of "other" property (does not include the structure 
value) such as outbuildings associated with the structure in the 
Other Value box (Figure 11.2).  A valid numeric value for the 
content value ranges from 0 to 999,999,999.  If left blank, the 
"other" value is computed from the other to structure value ratio 
that is defined in the occupancy type and the structure value. If an 
"other" value is entered, it will override the "other" value computed 
from the other to structure value ratio. If you enter zero, the content 
value will be zero. If the "other" damage is defined with a depth-
direct dollar function, the "other" value is not used in the 
calculations. 

 9. Determine which stream bank (looking downstream) the structure 
is located on.  From the Bank options (See Figure 11.1, page  

  11-2), select either Left (default) or Right. 
 
 

Structure value is 
the value of the 
structure, and 
does not include 
the content value. 

Figure 11.2  Values Associated with a Structure 

Contents value is 
the value of the 
contents 
associated with 
the structure, does 
not include the 
structure 
(building) value. 

Other value is the 
value of "other" 
property such as 
outbuildings 
associated with 
the structure, does 
not include the 
structure 
(building) value. 

 11-3 

11.2.2 Structure Assignments 
 
 10. From the Damage Category list (Figure 11.3), select the damage 

category (required) associated with the structure. 

 
Figure 11.3  Structure Assignments 
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 11. From the Occupancy Type list (see Figure 11.3, page 11-3), select 
the structure occupancy type (required) associated with the 
structure.  If you select the structure occupancy type of Direct, you 
will need to enter information for the depth-direct dollar damage 
function for that structure.  This information is entered in the 
Define Direct Structure Information box on the Structure 
Inventory dialog box (see Figure 11.1, page 11-2) 

 12. From the Stream list (see Figure 11.3, page 11-3), select the stream 
(required) associated with the structure. 

 13. From the Module list (see Figure 11.3, page 11-3), select the 
structure module (required) associated with the structure. 

 
 

11.2.3 Structure Stages 
 
 14. To enter stages (elevations) associated with the structure, click 

Structure Stages (see Figure 11.1, page 11-2); the Structure 
Stages dialog box will open (Figure 11.4).  From this dialog box, 
the user will enter the stages (elevations) associated with the first 
floor of the structure or the stage (elevation) of the ground at the 
structure. 

 15. By default, First Floor is selected (Figure 11.4), if you are entering 
the stages (elevations) associated with the first floor of the structure, 
type a value in the First Floor Stage box (Figure 11.4).  The value 
must be between -300 to 30,000.  Optionally, the user can enter the 
beginning damage depth in feet (meters) relative to the first floor 
stage where damage begins.  The beginning damage depth is 
normally used in the analysis of structures with basements where 
flood waters enter above basement floor.  The beginning damage 
depth truncates the damage function at the specified depth. For 
example, if damage begins at one foot below the first floor stage, 
the beginning damage depth is set to -1.  Type the value in the 
Beginning Damage Depth box (Figure 11.4). 

The first floor 
stage is the stage 
or elevation of the 
first floor of the 
structure. 

Figure 11.4  Structure Stages Dialog Box - First Floor 

The beginning 
damage depth in 
an optional depth 
in feet (meters) 
relatives to the 
first floor stage 
where damage 
begins; normally 
used in the 
analysis of 
structures with 
basements. 

11-4 
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 16. If you wish to enter the stage (elevation) of ground at the structure, 
click Ground Stage (see Figure 11.4, page 11-4), the Structure 
Stages dialog box will change (Figure 11.5).  In the Ground Stage 
box (Figure 11.5), type the value for the stage (elevation) of the 
ground at the structure, this value must be between -300 to 30,000.  
The user must also define the foundation height, which is the 
distance from the ground stage to the first floor stage.  This value is 
entered in the Foundation Height box (Figure 11.5). 

  Optionally, the user can enter the beginning damage depth in feet 
(meters) relative to the first floor stage where damage begins.  The 
beginning damage depth is normally used in the analysis of 
structures with basements where flood waters enter above basement 
floor.  The beginning damage depth truncates the damage function 
at the specified depth. For example, if damage begins at one foot 
below the first floor stage, the beginning damage depth is set to -1.  
Type the value in the Beginning Damage Depth box (Figure 11.5). 

 
 

The ground stage 
is the stage or 
elevation of the 
ground at the 
structure. 

The foundation 
height is the 
vertical distance 
between the 
ground stage and 
first floor stage at 
the structure 

Figure 11.5  Structure Stages Dialog Box - Ground Stage 

11.2.4 Optional Structure Information 
 
 17. There is also optional information that can be entered for a 

structure.  From the Structure Inventory dialog box (see Figure 
11.1, page 11-2) click Optional Information, the Optional 
Structure Information dialog box will open (see Figure 11.6, page 
11-6).  Definitions of the available items are listed in Section 11.5 
(page 11-18). 

 
 

11.2.5 Direct-Dollar Information for a Structure 
 
 18. If the user has selected a structure occupancy type of Direct, the 

Define Direct Structure Information box (see Figure 11.7, page 
11-6) will be available on the Structure Inventory dialog box (see  

 11-5 
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Figure 11.6  Optional Structure Information Dialog Box 

  Figure 11.1, page 11-2).  FDA assumes the normal distribution for 
first floor stage and you must enter a standard deviation for it even 
if it is zero (no uncertainty).  This value is entered in the First 
Floor Stage Error box (Figure 11.7).  You then enter the direct-
dollar damage versus stage functions and associated uncertainty for 

the structure, contents, and other as shown in Figure 11.7.  The 
direct-dollar functions are normally used to define unique damage 
potential such as some commercial, industrial, infrastructure, and 
pub

 

 Structure 
 
To ent
 
 1. , 

2. irect dollar damage function in the table in the 
Depth and Damage columns. 

Figure 11.7  Define Direct Structure Information 

lic facilities. 

 

er a structure depth-direct dollar damage function: 

From the Define Direct Structure Information box (Figure 11.7)
click Structure, the Depth-Direct Dollar Damage Function - 
Structure dialog box will open (see Figure 11.8, page 11-7). 
Enter the depth-d 

11-6 
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 3. If you are calculating uncertainty, from the 
(Figure 11.8) click the appropriate error distribution.  The table will 
change with columns being adding depending on your choice. 

 4. To view a plot of your structure depth-direct dollar dam
function, click Plot, or from the View menu click 
Dollar Function Plot.  Either way will open the 
Dollar Damage Plot - Structure dialog box will open (Figure 
11.9). 

Define Uncertainty box 

age 
Depth-Direct 

Depth-Direct 

 5. To view the data of your structure depth-percent damage function in 
a report form, click Tabulate, or from the View menu click Depth-
Direct Dollar Function Report.  Either way will open the Depth-
Direct Dollar Damage Function Report - Structure dialog box 
will open (see Figure 11.10, page 11-8). 

Figure 11.8 Depth-Direct Dollar Damage Function - Structure 
Dialog Box 

Figure 11.9 Depth-Direct Dollar Damage Plot - Structure 
Dialog Box 
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 6. When you are finished defining your structure depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damage 
Function - Structure dialog box will close (see Figure 11.8, page  

  11-7) returning you to the Structure Inventory
Figure 11.1, page 11-2). 

 
 

 
To enter a content depth-direct dollar damage function: 
 
 1. From the Define Direct Structure Information

11.7, page 11-6, click Content, the Depth-Direct Dollar Damage 
Function - Content dialog box will open (Figure 11.11). 

 2. Enter the depth-
direct dollar 

 dialog box (see 

 Content 

 box (see Figure 

damage function 
in the table in the 
Depth and 
Damage columns. 

 3. If you are 
calculating 
uncertainty, from 
the Define 
Uncertainty box 
(Figure 11.11) 
click the 
appropriate error 

Figure 11.10 t Dollar Damage Function Report - 
Structure Dialog Box 

tion 

 Depth-Direc

Figure 11.11 Depth-Direct Dollar Damage Func
- Content Dialog Box 
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  distribution.  The table will change with columns being adding 
depending on your choice. 
To view a plot of your content depth-direct dollar damage function,
click Plot, or from the View menu click Depth-Direct Dollar 
Damage Function Plot.  Either way will

 4.  

 open the Depth-Direct 
Dollar Damage Plot - Content dialog box will open (Figure 
11.12). 

 5. To view the data of your content depth-direct dollar damage 
function in a report form, click Tabulate, or from the View menu 
click Depth-Direct Dollar Damage Function Report.  Either way 
will open the Depth-Direct Dollar Damage Function Report - 
Content dialog box will open (Figure 11.13). 

 6. When you are finished defining your content depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damage 
Function - Content dialog box will close (see Figure 11.11, page 

Figure 11.12 Depth-Direct Dollar Damage Plot - Content Dialog 
Box 

Figure 11.13 Depth-Direct Dollar Damage Function Report - 
Content Dialog Box 
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11-8) returning you to the Structure Inventory dialog box (see 
Figure 11.1, page 11-2). 

 
 

 Other 
 
To enter an other depth-direct dollar damage function: 
 
 1. From the Define Direct Structure Information box (see Figure 

11.7, page 11-6), click Other, the Depth-Direct Dollar Damage 
Function - Other dialog box will open (Figure 11.14). 

 2. Enter the depth-

distribution.  The table will change with columns being adding 

4. To view a plot of your other depth-direct dollar damage function, 

th-

ot - 

Figure 

 5. 
r 

n a 

Tabulate, or from the View menu click Depth-Direct Dollar  

Figure 11.14 Depth-Direct 
Other Dialog Box 

direct dollar 
damage function 
in the table in the 
Dep
Damage
columns. 

(Figure 11.14) 
click the 

ate error 

th and 
 

 3. If you are 
calculating 
uncertainty, from 
the Define 
Uncertainty box 

Dollar Damage Function - 

appropri

depending on your choice. 
 

click Plot, or from the View menu click Depth-Direct Dollar 
Damage 
Function Plot.  
Either way will 
open the Dep
Direct Dollar 
Damage 
Function Pl
Other dialog box 
will open (
11.15). 
To view the data 
of your othe
depth-direct 
dollar damage 
function i
report form, click 

Figure 11.15 Depth-Direct Dollar Damage Plot - 
Other Dialog Box 
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  Damage Function Report.  Either way will open the Depth-Di
Dollar Damage Function R

rect 
eport - Other dialog box will open 

 6. When you are finished defining your other depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damage 
Function - Other dialog box will close (see Figure 11.14, page  

  11-10) returning you to the Study Structure Occupancy Types 
dialog box (see Figure 11.1, page 11-2). 

 
 
Additional ways to create structures are provided from the Structure 
Inventory dialog box (see Figure 11.1, page 11-2): 
 
 ● From the Edit m  click New Record, you can now enter a new 

e 

 ● 
  

11.1, page 11-2). 
 
 

11.3 Entering Structure Inventory Data - Table 
 
To create a structure: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the 
Data

 2. The Structure In ee Figure 11.1, 

 3.  

(Figure 11.16). 

Figure 11.16 Depth-Direct Dollar Damage FunctionReport - Other 
Dialog Box 

enu,
structure from the Structure Inventory dialog box (see Figur
11.1, page 11-2). 

-or- 
From the Navigator Button (see Chapter 2, Section 2.4.4, page  
2-10), click the center of the button; you can now enter a new 
structure from the Structure Inventory dialog box (see Figure 

Economics menu, click Structure Inventory 
. 

ventory dialog box will open (s
page 11-2). 
By default, FDA is in the "form" mode for structure inventory data
entry.  If you wish to entry data in the "table" form, from the View  
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  ge 
nventory dialog box changes 

in to a table format (Figure 11.17). 

 data. 
 5. re, from the Edit menu, click New Record.  The 

ture Name dialog box will open (Figure 11.18).  Type a 

each module.  Click OK, the name you entered 
on the bottom of the table as a header for a row in 

 6.  of where the structure is located 
Stream Station cell.  Must be consistent between 
ndaries, damage reach index location, water 
d structure location.  A valid value for a stream 
99,999.99 to 9,999,999.99.  Defaults to the 

's stream station. 

11.3.1 Values Associated with a Structure 
 
 7. of th  

re Value cell (see e 11-13).  A valid 
. 

menu of the Structure Inventory dialog box (see Figure 11.1, pa
11-2), click Table.  The Structure I

Figure 11.17  Structure Inventory Dialog Box - Table 

 4. The "table"
manipulating
To create a structu
FDA Struc
name (required) in
the Enter Struc
Name box.  Th
maximum length i
sixteen (16) 
characters.  Each 

 is not a spreadsheet and has limited capabilities for 

 
tur

e 
s 

e 

structure must have 
a unique name – two structures cannot have the same name. If the 
same structure is used in more than one module, it must have a 
unique name for 
will now appear 
the table. 
Type the stream station (required)
on a stream in the 
damage reach bou
surface profiles, an
station  is from  9,9
previous structure

 
 

Type the value 
in the Structu
numeric value for the structure value ranges from 0 to 999,999,999

Figure 11.18  FDA Structure Name Dialog Box 

e structure (does not include the content value)
Figure 11.19, pag
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 8. Type the 
value of the 
contents 
(does not 
include the 
structure 
value) 
associated with the structure in the Content Value cell (Figure 
11.19).  A valid numeric value for the content value ranges from 0 
to 999,999,999.  If left blank, the contents value is computed from 
the content to structure value ratio that is defined in the occupancy 
type and the structure value. If a content value is entered, it will 
override the content value computed from the content to structure 
value ratio. If you enter zero, the c
co  
content value is not used in the calculations. 

re 

to structure value ratio 
that is defined in the occupancy type and the structure value. If an 
"other" value is entered, it will override the "other" value computed 

tent 
fined with a depth-

direct dollar function, the "other" value is not used in the 

 
 

11.3.2 Structure Stages 

st 

efaults to the previous structure's first floor stage.  
The value must be between -300 to 30,000.  Optionally, the user can 

or stage where damage begins.  The beginning damage 
s 

waters enter above basement floor.  The beginning 

Figure 11.19  Values Associated with a Structure 

ontent value will be zero. If the 
ntent damage is defined with a depth-direct dollar function, the

 9. Type the value of "other" property (does not include the structu
value) such as outbuildings associated with the structure in the 
Other Value cell (Figure 11.19).  A valid numeric value for the 
content value ranges from 0 to 999,999,999.  If left blank, the 
"other" value is computed from the other 

from the other to structure value ratio. If you enter zero, the con
value will be zero. If the "other" damage is de

calculations. 

 
 10. If you are entering the stages (elevations) associated with the fir

floor of the structure, type a value in the First Floor Stage cell 
(Figure 11.20).  D

Figure 11.20  Structure Stages 

enter the beginning damage depth in feet (meters) relative to the 
first flo
depth is normally used in the analysis of structures with basement
where flood 
damage depth truncates the damage function at the specified depth. 
For example, if damage begins at one foot below the first floor  
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  stage, the beginning damage depth is set to -1.  Type the value in 
the Beginning Damage Depth cell (see Figure 11.20, page 11-13).
In the Ground Stage cell (see Figur

 
 11. e 11.20, page 11-13), type the 

value for the stage (elevation) of the ground at the structure, this 
value must be between -300 to 30,000.  The user must also define 
the foundation height, which is the distance from the ground stage 
to the first floor stage.  This value is entered in the Foundation 
Height cell (see Figure 11.20, page 11-13).  Optionally, the user 
can enter the beginning damage depth in feet (meters) relative to the 
first floor stage where damage begins.  The beginning damage 
depth is normally used in the analysis of structures with basements 
where flood waters enter above basement floor.  The beginning 
damage depth truncates the damage function at the specified depth. 
For example, if damage begins at one foot below the first floor 
stage, the beginning damage depth is set to -1.  Type the value in 
the Beginning Damage Depth cell (see Figure 11.20, page 11-13). 

 
 

11.3.3 Struc  
 

mage category associated with the structure. 

 11. a 

 12. 

e 

3. From the Stream Name cell (Figure 11.21), click, a drop-down list 
at list select the stream 

ture Assignments 

 12. From the Damage Category Name cell (Figure 11.21), click, a 
drop-down list of available damage categories will appear.  From 
the list select the da

From the Structure Occupancy Type cell (Figure 11.21), click, 
drop-down list of available structure occupancy types will appear.  
From that list select the structure occupancy type (required) 
associated with the structure.  If you select the structure occupancy 
type of Direct, you will need to enter information for the depth-
direct dollar damage function for that structure. 
From the Structure Module Name cell (Figure 11.21), click, a 
drop-down list of available structure modules will appear.  From 
that list select the structure module (required) associated with th
structure. 

 1

Figure 11.21  Structure Assignments 

of available streams will appear.  From th
(required) associated with the structure. 

 14. From the Bank cell (Figure 11.21), click, a drop-down list of 
available bank locations will appear.  From that list select the bank 
that the structure is located on. 

11-14 
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 15. The Damag
not editable.  The FDA program
damage re
the bank. 

truc

The rest of the table contains the cells for optional information that 
can be entered for a structure.  Definitions of the available items are
listed in Section 11.5 (page 11-18). 

llar Information for a Structure 

e Reach Name cell (see Figure 11.21, page 11-14) is 
 automatically calculates the 

ach name for a structure based on the stream station and 

 
 

11.3.4 Optional S ture Information 
 

 

11.3.5 Direc

 

Stage dialog box will open (Figure 11.23).  FDA assumes the 
normal distribution for first floor stage and you must enter a  

 

 17. 

 
 
t-Do
 
 18. If the user has selected a structure occupancy type of Direct, the 

user will need to enter the appropriate information for the direct-
dollar associated with the structure.  From the Structure 
Occupancy Type cell, Direct should be selected, right-click, and
then drag to the appropriate item in the short-cut menu (Figure 
11.22). 

Figure 11.22  Direct-Dollar Information Shortcut Menu 

 19. To enter the error associated with the first floor stage of the 
structure, click Edit First Flood Stage Error from the shortcut 
menu (Figure 11.22).  The Error Associated with First Floor 

Figure 11.23  Error Associated with First Floor Stage Dialog Box 
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  standard deviation for it even if it is zero (no uncertainty).  This 
value is entered in the stdev box (see Figure 11.23, page 11-15). 

 
en enter the direct-dollar damage versus stage functions and 

ated uncertainty for the structure, contents, and other as shown in 
 11.22 (page 11-15).  The direct-dollar functions are normally used 
ne unique damage potential such as some commercial, industrial
ructure, and public facilities. 

er a structure depth-direct dollar damage function: 

From the shortcut menu (see Figure 11.22, page 11-15), click Edit 
Structure Damage Function, the Depth-Direct Dollar Damage 

You th
associ
Figure
to defi , 
infrast
 
 

 Structure 
 
To ent
 
 1. 

Function - Structure dialog box will open (see Figure 11.8, page 

dollar damage function in the table in the 
Depth and Damage columns. 

.  

your choice. 
 4. To view a plot of your structure depth-direct dollar damage 

function, click Plot, or from the View menu click Depth-Direct 
Dollar Function Plot.  Either way will open the Depth-Direct 
Dollar Damage Plot - Structure dialog box will open (see Figure 
11.9, page 11-7). 

 5. T pth-percent damage function in 

 6. 
e 
e  

 

 Content 
 

 
 1. ure 11.22, page 11-15), click Edit 

Content Damage Function, the Depth-Direct Dollar Damage 

11-7). 
 2. Enter the depth-direct 

 3. If you are calculating uncertainty, from the Define Uncertainty box 
(see Figure 11.8, page 11-7) click the appropriate error distribution
The table will change with columns being adding depending on 

o view the data of your structure de
a report form, click Tabulate, or from the View menu click Depth-
Direct Dollar Function Report.  Either way will open the Depth-
Direct Dollar Damage Function Report - Structure dialog box 
will open (see Figure 11.10, page 11-8). 
When you are finished defining your structure depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damag
Function - Structure dialog box will close (see Figure 11.8, pag

  11-7) returning you to the Structure Inventory dialog box (see 
Figure 11.1, page 11-2). 

 

To enter a content depth-direct dollar damage function: 

From the shortcut menu (see Fig
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Function - Content dialog box will open (see Figure 11.11, page 
11-8). 
Enter the depth-direct dollar damage function in the table in the 
Depth and

 2. 
 Damage columns. 

3. If you are calculating uncertainty, from the Define Uncertainty box 
(see Figure 11.11. page 11-8) click the appropriate error 

 with columns being adding 

g box will open (see Figure 
11.12, page 11-9). 

lar damage 
 the View menu 

 6. 

e 
urning you to the Structure Inventory dialog box (see 

Figure 11.1, page 11-2). 
 
 

 Other 
 
To enter an other depth-direct dollar damage function: 
 
 1. From the shortcut menu (see Figure 11.22, page 11-15), click Edit 

Othe age 
ge  

 2. 

 3. y box 

distribution.  The table will change with columns being adding 
depending on your choice. 

 4. To view a plot of your other depth-direct dollar damage function, 
click Plot, or from the View menu click Depth-Direct Dollar 
Damage Function Plot.  Either way will open the Depth-Direct 
Dollar Damage Function Plot - Other dialog box will open (see 
Figure 11.15, page 11-10). 

 5. To view the data of your other depth-direct dollar damage function 
in 
Depth-Direct Dollar Damage Function Report.  Either way will  

 

distribution.  The table will change
depending on your choice. 

 4. To view a plot of your content depth-direct dollar damage function, 
click Plot, or from the View menu click Depth-Direct Dollar 
Damage Function Plot.  Either way will open the Depth-Direct 
Dollar Damage Plot - Content dialo

 5. To view the data of your content depth-direct dol
function in a report form, click Tabulate, or from
click Depth-Direct Dollar Damage Function Report.  Either way 
will open the Depth-Direct Dollar Damage Function Report - 
Content dialog box will open (see Figure 11.13, page 11-9). 
When you are finished defining your content depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damage 
Function - Content dialog box will close (see Figure 11.11, pag
11-8) ret

r Damage Function, the Depth-Direct Dollar Dam
Function - Other dialog box will open (see Figure 11.14, pa

  11-10). 
Enter the depth-direct dollar damage function in the table in the 
Depth and Damage columns. 
If you are calculating uncertainty, from the Define Uncertaint
(see Figure 11.14, page 11-10) click the appropriate error 

a report form, click Tabulate, or from the View menu click 
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 open the Depth-Direct Dollar Damage Function Report - Other 

udy Structure Occupancy Types 
dialog box (see Figure 11.1, page 11-2). 

11.4 Deleting Structures 

tructures may only be deleted one at a time – there is no global deletion 

you ne
two w
 

. 
 2. he struct.xxx files from a study that 

 
Using Visual dBASE to delete structures is fairly straightforward.  You 

 any 
other f
pack t
 
The se ires several steps: 

 1. 

 2. E 

.  

 4. 
.  

y of your current study.  This will give 
you an inventory with no structures. 

6. Edit the exported structure file or an already existing structure file 
te a delimited text file in the format required for importing 
re inventory. 

ining the new 

 
dialog box will open (see Figure 11.16, page 11-11). 

 6. When you are finished defining your other depth-direct dollar 
damage function, click Save.  The Depth-Direct Dollar Damage 
Function - Other dialog box will close (see Figure 11.14, page  

  11-10) returning you to the St

 
 

 
S
of structures.  It is very tedious to delete more than a few structures.  If 

ed to delete a large number of structures, you can delete them in 
ays: 

 1 Use Visual dBASE to delete records from the struct.dbf file, or 
Export all the structures, copy t
has no data into your current study, and then import a new edited 
list of structures. 

only need to open the struct.dbf file - you do not need to relate it to
iles.  Select the records (structures); mark them for deletion, then 
he file. 

cond method requ
 

Start FDA and open your current study containing records that you 
want to delete. 
Export all of your structures to a delimited text file (see Appendix 
for details). 

 3 Create a new study with no data except for a study title and a price
index year. 
Exit FDA. 

 5 Copy the files struct.dbf, struct.dbt, and struct.mdx from the new
study into the subdirector

 
and crea
a structu

 7. Start FDA and import the delimited text file conta
structure inventory. 
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11.5 Descriptio

y 
.

 
Stream try, 
 k

Struc
occup
left m

 
to uniq
The m
a uniq  
t tu

 
on stru
 
Stream

enote ove the mouth of the stream.  Must be 
onsistent between damage reach boundaries, damage reach index 

ater surface profiles, and structure location.  The range of 
alues is from  9,999,999.99 to 9,999,999.99. 

ructure is located.  
or structures, there are two hardwired choices (Left or Right), with Left 

 
Struc

umeric value ranging from 0 to 999,999,999. 

Conte ssociated with the structure.  

from 0 ed from 
the co e 
and the structure value. If a content value is entered, it will override the 

enter z ined 
with a
calcul
 

associ g) 
value.

n of Structure Data Entry Variables 
 
Damage Category Name:  Select a previously defined damage categor

  For table entry, a pick list is diname splayed by pressing the left mouse 
button. 

 Name:  Select a previously defined stream name.  For table en
 list is displayed by pressinga pic  the left mouse button. 

 
ture Occupancy Type:  Select a previously defined structure 
ancy type.  For table entry, a pick list is displayed by pressing the 
ouse button. 

 
Structure Name:  Required name for the defined structure, which is used

uely identify the structure and is displayed on reports and plots.  
aximum length is sixteen (16) characters.  Each structure must have 
ue name – two structures cannot have the same name.  If the same
re is used in more than one structure module, the structure mus ruc st 

have a unique name for each structure module (see Chapter 10 for details
cture modules). 

 Station:  Study adopted stations along the stream normally 
d as miles (kilometers) abd

c
location, w
allowable v
 
Bank:  Stream bank (looking downstream) where the st
F
being the default. 

ture Value: The value of the structure.  It does not include the 
content value.  A n
 

nt Value:  The value of the contents a
It does not include the structure (building) value.  Numeric value ranging 

 to 999,999,999. If left blank, the contents value is comput
ntent to structure value ratio that is defined in the occupancy typ

content value computed from the content to structure value ratio. If you 
ero, the content value will be zero. If the content damage is def
 depth-direct dollar function, the content value is not used in the 
ations. 

Other Value:  The value of "other" property such as outbuildings 
ated with the structure.  It does not include the structure (buildin
  Numeric value ranging from 0 to 999,999,999.  If left blank, the  
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other value is computed from the other to structure value ratio that is 
efined in the occupancy type and the structure value.  If an other value is 

structu l be zero.  If 
her 

value 
 

Nume u may enter either:  1) the 
round stage and the foundation height, or 2) the first floor stage.  If the 
round stage is entered, you must also define the foundation height which 

ound stage to the first floor stage. 

e 

 the 

floor. 
xample, if dam oot below the first floor stage, the 

round stage and the foundation height, or 2) the first floor 

 

s about the structure. 

tru
 

den
stage-

ea
efaul e year in service to determine if 
e structure should be included in the stage-damage computations for a  

d
entered, it will override the other value computed from the other to 

re value ratio.  If you enter zero, the content value wil
the other damage is defined with a depth-direct dollar function, the ot

is not used in the calculations. 

Ground Stage:  The stage or elevation of the ground at the structure.  
ric value ranging from -300 to 30,000. Yo

g
g
is the distance from the gr
 
Foundation Height:  The vertical distance between the ground stage and 
first floor stage at the structure.  You may enter either:  1) the ground stag
and the foundation height, or 2) the first floor stage.  If the foundation 
height is entered, you must also define the ground stage. 
 
Beginning Damage Depth:  Optional depth in feet (meters) relative to
first floor stage where damage begins.  It is normally used in the analysis 
of structures with basements where flood waters enter above basement 

 It truncates the damage function at the specified depth.  For 
age begins at one fe

beginning damage depth is set to -1. 
 
First Floor Stage:  The stage or elevation of the first floor of the 
structure.  Numeric value ranging from -300 to 30,000.  You may enter 
ither: 1) the ge

stage. 
 
Structure Address:  The Street, City, State, and Zip Code associated with
the structure. 
 
Structure Coordinates:  The UTM or other study adopted coordinates 
associated with the structure location. 
 
Notes:  Optional note
 
S cture Image:  Digital image (picture of the structure) 

Number of Structures:  The number of structures assumed to have 
i tical attributes associated with this structure.  FDA will compute 

damage as if this structure was entered. 
 
Y r in Service:  The year that a structure was built and occupied.  By 

t, FDA assumes 1900.  FDA uses thd
th
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given plan/year.  For example, if the structure’s year in service 
ou are computing stage-aggregated damage for the year 2009, 

is 2030 and 
the 

cture’s stage-damage functions are aggregated, it is normally left 

e 

 entered, then when you compute stage-aggregated 

11.6 Refer

tructure Inventory for Damage Analysis User’s 
anual."  HEC, Davis, CA. 

al - 

SACE 1991a 

uctures and Contents", October 1991, 91-R-10.  IWR, 
lexandria, VA. 

SACE 1992c), Catalog of Residential Depth-Damage Functions", May 

2.  

y
structure would not be included in the computations. 
 
SID Reach Name (SID Compatible data):  The damage reach to which 

is struth
blank.  If entered, then when you compute stage-aggregated damage, you 
must select the Use SID Reaches option.  
 
Reference Flood Elevation (SID Compatible data):  The stage 
associated with the SID reference flood, it is normally left blank.  It can b
used to aggregate damage to the index location in place of using the water 

rface profiles.  Ifsu
damage, you must select the Use SID Ref Flood option. 
 
 
ences 
 
USACE 1989 
USACE (1989). "SID: S
M
 
USACE 1988b 
USACE (1988b), Natural Economic Development Procedure Manu
Urban Flood Damage", March 1988, 88-R-2.  IWR, Alexandria, VA. 
 
U
(USACE (1991a), "Natural Economic Development Procedure Manual - 
Urban Flood Damage - Volume II:  Primer on Surveying Flood Damage 
for Residential Str
A
 
USACE 1992c 
(U
1992, 92-R-3.  IWR, Alexandria, VA. 
 
USACE 1996 
(USACE 1996), "Analysis of Non-Residential Content Value and Depth-
Damage Data for Flood Damage Reduction Studies", April 1996, 96-R-1
IWR, Alexandria, VA. 
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CHAPTER 12  
 
 

Stage-Damage Functions 
 
 

12.1 General 
 
The Corps defines a stage-damage function as the relationship of direct 
economic costs caused by flood inundation to a range of flood stages for a 
given river or damage reach.  Damage reaches are specific geographical 
areas within a floodplain.  Stage-damage functions are different for 
residential structures and non-residential structures.  See Appendix F for 
how a stage-damage function is developed and how uncertainty is applied 
(for further details see EM 1110-2-1619). 
 
HEC-FDA provides two ways to enter stage-damage functions.  You can 
enter stage-damage functions manually (see Section 12.2, page 12-3) from 
the Stage-Damage Function at Index Location with Uncertainty dialog 
box (Figure 12.1).  The stage-damage function with uncertainty is  

A stage-damage 
function is the 
relationship of 
direct economic 
costs caused by 
flood inundation 
to a range of 
flood stages for a 
given river or 
damage reach. 

Figure 12.1 Stage-Damage Function at Index Location with 
Uncertainty Dialog Box 
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specified for a given plan, analysis year, damage category, stream, and 
damage reach.  A complete set of stage-damage functions for all 
categories, damage reaches, and streams must be entered to analyze a 
specific plan for an analysis year.  The uncertainty is defined only by the 
normal probability density function. If there is no uncertainty, you must 
select the normal distribution and enter zeros for the standard deviations – 
don’t leave the uncertainty field blank. 
 
The second way to create stage-damage functions is to let FDA create the 
stage-damage functions automatically.  Section 12.10 (page 12-11) 
provides the steps required within FDA to automatically compute stage-
damage functions.  Appendix F provides an explanation of the calculation 
procedure used to compute stage-damage functions. 
 
The Stage-Damage Function at Index Location with Uncertainty 
dialog box (see Figure 12.1, page 12-1) has a common Menu Bar.  The 
Menu Bar contains the following common menus, for a description of the 
Help menu see Chapter 2 (Section 2.4.8, page 2-12): 
 
 File This menu is used for file management and contains the 

following commands: 
 Save: changes are saved for the stage-damage functions. 
 Use an Existing Function: allows you to copy the selected 

stage-damage function to a selected assignment. 
 Close: close the open dialog box; if changes have not been 

saved a warning message will appear. 
 
 Edit This menu is used for editing stage-damage functions, 

traversing the records in a stage-damage function item list, 
creating stage-damage functions, and deleting stage-damage 
functions.  The commands available are: 

 Cut/Copy/Paste: the standard cut/copy/paste commands. 
 Insert Row: on the Stage-Damage Function at Index 

Location with Uncertainty dialog box from the table, 
this command allows you to insert a row above the 
selected row.  To insert a row, you must highlight the row 
below where you want to insert a row by clicking on the 
row number at the far left of the table, on the Edit menu, 
click Insert Row.  The new row will be inserted above 
the selected row. 

 Delete Row: on the Stage-Damage Function at Index 
Location with Uncertainty dialog box from the table, 
this command allows you to delete a row anywhere in the 
table.  To delete a row, you must highlight the entire row 
by clicking on the row number at the far left of the table, 
on the Edit menu, click Delete Row.  The selected row 
will be deleted from the table. 
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 Delete Assignment: this command deletes the assignment 
of a stage-damage function.  Any stage-damage function 
that it is assigned to only one plan, analysis year, damage 
category, stream, damage reach, and then is deleted, will 
be removed from the study. 

 Global Assignment Copy: this command allows you to 
assign stage-damage functions to multiple plans and 
analysis years. 

 
 View This menu is used to review what stage-damage functions have 

been created for the study; what assignments have been made, 
display graphically stage-damage functions, and display a 
report of the stage-damage functions.  The commands 
available are: 

 Stage-Damage Function Assignments: 
  this command displays a report that gives you 

information on the assignments that have been made for 
the stage-damage functions. 

 List of Stage-Damage Functions:  this command displays a 
report that will give you a list of stage-damage functions 
that have been defined for the study. 

 Stage-Damage Function Plot:  this command displays a 
graphical representation of a stage-damage function. 

 Stage-Damage Function Report:  this command displays a 
report of a stage-damage function. 

 
 

12.2 Entering a Stage-Damage Function Manually 
 
In FDA you can enter stage-damage functions manually or FDA can 
calculate the stage-damage function (see Section 12.9, page 12-10).  If you 
have manually entered stage-damage functions, and then decide to have 
FDA calculate the stage-damage functions, you will lose your manually 
entered stage-damage functions.  Therefore, it is recommended that you 
use on methodology for entering stage-damage functions into a study.  To 
enter a stage-damage function manually: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. For each plan, analysis year, damage category, stream, and damage 
reach combination; a stage-damage function will be assigned.  
Therefore, you need to select the appropriate plan from the Plan 
list, the appropriate analysis year from the Analysis Year list, the 
appropriate damage category from the Damage Category list, the  
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  appropriate stream from the Stream list, and the appropriate 

damage reach from the Damage Reach list (Figure 12.2). 

 4. For stage-damage functions, the uncertainty by default is Normal 
and you can not choose any other uncertainty type.  If there is no 
uncertainty, you must enter zeros for the Standard Deviation of 
Error in the table (see Figure 12.1, page 12-1) - don’t leave the 
uncertainty field blank. 

 5. Enter the stage and damage values for your stage-damage function 
in the table on the Stage-Damage Function at Index Location 
with Uncertainty dialog box (see Figure 12.1, page 12-1). 

 6. Enter a name (required) in the Function box (see Figure 12.1, page 
12-1).  The maximum length is sixteen (16) characters. 

 7. Enter a description (optional but recommended) in the Description 
box (see Figure 12.1, page 12-1).  The maximum length is sixty-
four (64) characters. 

 8. Click Save, the stage-damage function is added, and assigned to the 
selected plan, analysis year, damage category, stream, and damage 
reach. 

 9. When you are finished with creating stage-damage functions, on the 
File menu, click Close, the Stage-Damage Function at Index 
Location with Uncertainty dialog box will close (see Figure 12.1, 
page 12-1) 

 
 

Figure 12.2  Assignment Items for Stage-Damage Functions 

12.3 Delete a Stage-Damage Function 
 
Since stage-damage functions are assigned to a plan, analysis year, 
damage category, stream, and damage reach you are deleting the 
assignment of that particular stage-damage function to a plan, analysis 
year, damage category, stream, and damage reach.  Any stage-damage 
function that it is assigned to only one plan, analysis year, damage 
category, stream, damage reach, and then is deleted, will be removed from 
the study.  To delete a stage-damage function: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

12-4 
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 3. Select the appropriate plan, analysis year, damage category, stream, 

and damage reach; this will give you the stage-damage function you 
wish to delete (see Figure 12.2, page 12-4). 

 4. On the Edit menu, click Delete Assignment, a warning message 
will appear asking you if you really wish to delete this stage-
damage function assignment.  Click Yes, the stage-damage function 
is no longer assigned to the selected plan, analysis year, damage 
category, stream, and damage reach. 

 5. When you are finished, on the File menu, click Close, the Stage-
Damage Function at Index Location with Uncertainty dialog 
box will close (see Figure 12.1, page 12-1). 

 
 

12.4 List of Stage-Damage Functions 
 
To review the stage-damage functions you have entered for your study, 
FDA provides a report.  To access the report do the following: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. On the View menu, click List of Stage-Damage Functions, the 
List of Stage-Damage Functions dialog box will open (Figure  

  12-3). 

 4. This report can be printed, on the File menu, click Print. 
 5. When you are finished reviewing this report, on the File menu, 

click Close, the List of Stage-Damage Functions dialog box will 
close. 

 

Figure 12.3  List of Stage-Damage Functions Dialog Box 
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12.5 Stage-Damage Function Plot 

 
To view a stage-damage function graphically: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. Select the appropriate plan, analysis year, damage category, stream, 
and damage reach (see Figure 12.2, page 12-4); this will give you 
the stage-damage function you wish to view graphically. 

 4. On the View menu, click Stage-Damage Function Plot, the Stage-
Damage Plot dialog box will open (Figure 12.4). 

 5. When you are finished reviewing the plot, on the File menu, click 
Close, the Stage-Damage Plot dialog box will close. 

 
 

Figure 12.4  Stage-Damage Plot Dialog Box 

12.6 Stage-Damage Function Report 
 
To view a stage-damage function in a report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 
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 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. Select the appropriate plan, analysis year, damage category, stream, 
and damage reach (see Figure 12.2, page 12-4); this will give you 
the stage-damage function you wish to view in tabular form. 

 4. On the View menu, click Stage-Damage Function Report, the 
Stage-Damage Function Report dialog box will open (Figure 
12.5). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, on the File menu, click 

Close, the Stage-Damage Function Report dialog box will close. 
 
 

Figure 12.5 Stage-Damage Function Report Dialog Box 

12.7 Assigning an Existing Stage-Damage Function to a 
Different Plan, Analysis Year, Damage Category, 
Stream, Damage Reach Combination 

 
You can assign a stage-damage function to another plan; analysis year, 
damage category, stream, and damage reach combination.  There are two 
ways to accomplish this assignment.  The first way is to assign a stage-
damage function individually: 
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 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 
2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. Select a plan, analysis year, damage category, stream, and damage 
reach (see Figure 12.2, page 12-4) that does not have an assigned 
stage-damage function. 

 4. Either click Use an Existing Function (see Figure 12.1, page 12-1), 
or from the File menu, click Use an Existing Function, either way, 
the Copy Aggregate Stage-Damage Function dialog box will 
open (Figure12.6). 

 5. Based on the stream, damage reach, and damage category selected, 
FDA uses an automated filtering system that will only provide a list 
of stage-damage functions that are available for the selected stream, 
damage reach, and damage category.  From the table select the 
stage-damage function that you want to assign to the selected plan, 
analysis year, damage category, stream, and damage reach.  Click 
OK, the Copy Aggregate Stage-Damage Function dialog box will 
close. 

 6. From the Stage-Damage Function at Index Location with 
Uncertainty dialog box (see Figure 12.1, page 12-1) click Save, 
this will save the assignment of the stage-damage function to the 
selected plan, analysis year, damage category, stream, and damage 
reach. 

 7. You do not need to change the name of the stage-damage function 
unless you make some other kind of change that is specifically for 
that plan, analysis year, damage category, stream, and damage 
reach. 

 
The other way is to assign a stage-damage function to multiple plans and 
analysis years: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

Figure 12.6  Copy Aggregate Stage-Damage Function Dialog Box 
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 3. On the Edit menu, click Global Assignment Copy, the Global 
Assignment Copy dialog box will open (Figure 12.7). 

 4. The From box is where you select the plan and analysis year that 
includes the stage-damage function you want to assign.  The To box 
is the plan and analysis year that you are going to assign the stage-
damage function to.  In the example ( Figure 12.7), the stage-
damage function for the Without plan and 2009 analysis year, will 
be assigned to Plan 2 and both analysis years (2009 and 2030).  
There is also an All options which allows you to make assignments 
to all plans and all analysis years. 

 5. Once you have made your selections click Copy, a warning 
message will appear asking you if this is really what you want to 
do, click Yes, the warning message closes.  Click Close, the Global 
Assignment Copy dialog box will close (Figure 12.7).  The 
assignments are automatically saved. 

 6. To verify that the stage-damage function assignments have been 
made, you need to review the Stage-Damage Function 
Assignments report (see Section 12.8). 

 
 

Figure 12.7  Global Assignment Copy Dialog Box 

12.8 List of Stage-Damage Function Assignments 
 
To check to see if your assignments have been done and are correct, you 
need to review the assignment report: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 4. On the View menu, click Stage-Damage Function Assignments 
the Stage-Damage Function Assignments dialog box will open 
(see Figure 12.8. page 12-10). 

 5. To print this report, on the File menu, click Print. 
 6. When you are finished reviewing the report, on the File menu, click 

Close, the Stage-Damage Function Assignments dialog box will 
close (see Figure 12.8, page 12-10). 
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Figure 12.8  Stage-Damage Function Assignments Dialog Box 
 

12.9 Rename a Stage-Damage Function 
 
If you want to rename a stage-damage function: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Enter/Edit/View 
Reach Stage-Damage Function with Uncertainty. 

 2. The Stage-Damage Function at Index Location with Uncertainty 
dialog box will open (see Figure 12.1, page 12-1). 

 3. For each plan, analysis year, damage category, stream, and damage 
reach combination; a stage-damage function will be assigned.  
Therefore, you need to select the appropriate plan from the Plan 
list, the appropriate analysis year from the Analysis Year list, the 
appropriate damage category from the Damage Category list, the 
appropriate stream from the Stream list, and the appropriate 
damage reach from the Damage Reach list (see Figure 12.2, page 
12-4). 

 4. In the Function box (see Figure 12.1, page 12-1) enter a new name 
for the selected stage-damage function.  HEC recommends the 
name be descriptive of the damage reach, damage category, and 
analysis year. 

 5. Click Save, since FDA creates a new stage-damage function for 
each plan, analysis year, damage category, stream, and damage 
reach combination, then the stage-damage function is renamed.  If 
you rename a stage-damage function that is assigned to more than 
one plan, analysis year, stream, damage reach, and damage 
category, then a warning message will appear (see Figure 12. 9, 
page 12-11) asking you if you want this name change to affect only 
the selected assignment, change the name for all assignments, or 
cancel. 
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Figure 12.9 Renaming an Assigned Stage-Damage Function 
Warning Message 

 
12.10 Compute Stage-Damage Functions 

 
For FDA to compute stage-damage functions the program requires the 
following information and the uncertainty about that information:  depth-
percent damage functions, first floor elevations, and structure and content 
values.  In addition, a complete set of water surface profiles (eight 
profiles) must be available (see Chapter 4, Section 4.2, page 4-4).  
Additionally, it is a good idea to have discharge exceedance probability 
functions and stage- discharge functions for the stage-damage function 
computations (see Appendix F for details). 
 
From the Compute Reach Stage-Damage Function with Uncertainty 
dialog box (Figure 12.10), you specify the plan and analysis year to 
compute the stage-damage function with uncertainty at the damage reach 
index location stations by study damage categories.  In Figure 12.10, 
stage-damage functions are being computed for selected plans and 
analysis years.  To compute stage-damage functions: 

 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Compute Reach 
Stage-Damage Function with Uncertainty. 

 2. The Compute Reach Stage-Damage Function with Uncertainty 
dialog box will open (Figure 12.10). 

Appendix F 
provides an 
explanation of the 
calculation 
procedure used to 
compute stage-
damage functions 
(for further 
details see EM 
1110-2-1619). 

Figure 12.10 Compute Reach Stage-Damage Function with Uncertainty 
Dialog Box 
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 3. Select the plan and analysis years for which you wish to compute 

stage-damage functions.  From the Edit menu, click Select All if 
you wish to compute all plans and analysis years.  By using the 
CTRL and SHIFT keys in combination with your mouse click, you 
can select which ever plan and analysis year you want. 

 4. From the table you can specify whether to perform the analysis with 
or without risk, or use previous applied HEC-SID analyses by 
clicking on the cell under the appropriate column of the table. 

 5. Click Compute, the Aggregate Stage-Damage Computation 
Status dialog box will open (Figure 12.11). 

 6. The Aggregate Stage-Damage Computation Status dialog box 
will provide information on the compute process.  All streams, 
damage reaches, and damage category functions are computed for 
the specified plan and analysis year during a single program 
execution.  The results will overwrite previous results including any 
manually entered stage-damage functions. 

 7. Click Close, the Aggregate Stage-Damage Computation Status 
dialog box will close (Figure 12.11), and you will be returned to the 
Compute Reach Stage-Damage Function with Uncertainty 
dialog box. 

 8. A check mark will be placed in the Execute column of the table and 
a date of execution will appear in the Date of Execution column of 
the table. 

 9. On the File menu, click Close, the Compute Reach Stage-Damage 
Function with Uncertainty dialog box will close (see Figure 
12.10, page 12-11). 

 10. Stage-damage functions that are created by FDA are given a default 
name that is automatically generated, AggDamg######.  An 
example is AggDamg001215, also there is no default description. 

 
 

Figure 12.11 Aggregate Stage-Damage Computation Status Dialog Box 
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12.11 Stage-Damage Compute Options 
 
From the Compute Read Stage-Damage Function with Uncertainty 
dialog box (see Figure 12.10, page 12-11), there are several options you 
can set for the compute.  There are two types of compute options: 
 
 (1) Options that can vary by plan and analysis year, and 
 (2) Options that apply globally to all plans and analysis years. 
 
You must exercise caution when changing options between stage-damage 
computations.  FDA will not mark results as invalid when compute 
options are changed.  Some of the options control calculations (e.g., the 
number of simulations, the use of risk analysis, etc.), and some control the 
output (e.g., detailed stage-damage and Monte-Carlo simulation output by 
structure, etc.).  If a compute option is changed, there is no effect on the 
results but if stage-damage is calculated, the expected annual damage 
results are marked as invalid. 
 
 

12.11.1 Compute Options by Plan and Analysis Year 
 
The options that vary by plan and analysis year are set in the Compute 
Read Stage-Damage Function with Uncertainty dialog box (see Figure 
12.10, page 12-11).  The options that may be set are: 
 
 ● Compute With Risk column (see Figure 12.10, page 12-11).  If 

selected, FDA will use all uncertainties in values (structure, content, 
other), first floor stage, and depth-damage functions to compute 
stage-damage.  If not selected, the stage-damage is computed 
without using any of the uncertainties.  Computing without 
uncertainties reduces computational time and is useful when first 
analyzing the data. 

 
 ● Use SID Reaches column (see Figure 12.10, page 12-11).  If 

selected, FDA will use the SID reach name to determine the 
damage reach to which the current structure’s stage-damage 
function is aggregated.  If not selected, FDA computes the damage 
reach based upon the structure’s stream name, station, and bank and 
the damage reach definitions.  As mentioned earlier, if insufficient 
data is available to determine the damage reach from the selected 
option, FDA tries to determine the damage reach from the 
alternative option. 

 
 ● Use SID Reference Flood column.  If selected, FDA uses the SID 

reference flood water surface profile to aggregate individual 
structure stage-damage functions to the index location.  If not 
selected, FDA uses the eight water surface profiles to aggregate 
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individual structure stage-damage to the index location.  As 
mentioned earlier, if insufficient data is available to aggregate 
stage-damage using the selected option, FDA tries to aggregate 
using the alternative option. 

 
 

12.11.2 Global Compute Options 
 
To set the compute options that are global for all plans and analysis years: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Economics menu, click Compute Reach 
Stage-Damage Function with Uncertainty. 

 2. The Compute Reach Stage-Damage Function with Uncertainty 
dialog box will open (see Figure 12.10, page 12-11). 

 3. On the Options menu, click Compute Options, the Global 
Options for Stage-Damage Computation dialog box will open 
(Figure 12.12). 

 4. From the Global Options for Stage-Damage Computation dialog 
box you can set the following compute and output options for the 
stage-damage calculation: 

 
 ● No. of Monte-Carlo Simulations.  You can set the number of 

Monte-Carlo Simulations at each stage ordinate in the stage 
damage function; default value is 100. 

 
 ● Min Number of Intervals.  With this option you can set the 

range in the number of ordinates in the stage aggregated 
damage function.  The program will determine the actual 
number by determining a stage increment between ordinates 
that is one of the numbers 1, 2, or 5 times some power of ten.  

Figure 12.12 Global Options for Stage-Damage Computation 
Dialog Box 
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For example, it may pick an increment of 1, 2, 5, 10, or 20 
feet between ordinates, but not 3, 4, 6, 8, 11, etc. feet.  The 
range of stages is computed from the discharge-exceedance 
probability and rating curves.  If they are not entered, the 
stages are computed from the water surface profiles.  If none 
of that information is available, FDA cannot determine the 
stages and cannot compute stage-aggregated damage.  The 
maximum number of stage ordinates is sixty.  The default 
value is 20. 

 
 ● Max. Number of Intervals.  With this option you can set the 

range in the number of ordinates in the stage aggregated 
damage function.  The program will determine the actual 
number by determining a stage increment between ordinates 
that is one of the numbers 1, 2, or 5 times some power of ten.  
For example, it may pick an increment of 1, 2, 5, 10, or 20 
feet between ordinates, but not 3, 4, 6, 8, 11, etc. feet.  The 
range of stages is computed from the discharge-exceedance 
probability and rating curves.  If they are not entered, the 
stages are computed from the water surface profiles.  If none 
of that information is available, FDA cannot determine the 
stages and cannot compute stage-aggregated damage.  The 
maximum number of stage ordinates is sixty.  The default 
value is 30. 

 
 ● Trace Level.  This option controls the amount of output 

written to the files FDA_SDmg.out, FDA_SdErrors.out, and 
FDA_SDev.out when stage aggregated damage is computed.  
Default value is 1. 

 
  Output written to the file FDA_SDmg.out includes 

information about the date and time of the compute, study 
name, description, the subdirectory in which the data is stored 
and the plan and analysis year that was computed.  It also 
details the calculation of the range and increment of stages for 
the stage aggregated damage matrix for each damage reach.  
Additional detailed information about each structure is written 
if the trace level is high enough.  All output is cumulative with 
the trace level; if it is written at TraceLevel = 1, then it is 
written at TraceLevel = 5. 

 
  Output written to the file FDA_SdErrors.out includes errors in 

processing structure information (e.g. it cannot determine the 
damage reach; there is no structure occupancy type, etc.). 

 
  Output written to FDA_SDev.out is related strictly to the 

Monte Carlo simulation.  Trace Level must be greater than 
forty-nine (49) to write any information to this file. 
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  You have the option of appending results to several of the 

files.  If you do not append results, the file is initialized before 
each plan/analysis year calculation.  For example, if you don’t 
append results to the file and you compute stage-damage for 
the plan/analysis year combinations of Without plan and 
analysis year 2009 and Without plan and analysis year2030, 
the file will contain results only for the Without plan and 
analysis year2030. The plan/analysis year of Without plan and 
analysis year 2009 is overwritten. 

 
  The following describes the level of output as a function of 

the trace level: 
 
 Trace Level Description 
 
 0 No output is written to the files 

Fda_SDmg.out, Fda_SDev.out, and 
Fda_SdErrors.out.  Data is written to the 
file Fda_StrucDetail.out if you select that 
option. 

 
 >0 Header information is written to each file 

except the Fda_SDev.out file.  The header 
information includes the date/time of 
calculation, study name, description, the 
subdirectory in which the data is stored and 
the plan/year of calculations.  The file 
Fda_SDmg.out contains stage-aggregated 
damage functions with uncertainty for 
structure, contents, other, and total for all 
streams and reaches for the selected 
plan/year.  The file Fda_SdErrors.out 
contains a summary line of structure errors. 

 
 >4 Basic structure information including 

structure name, address, etc. is written to 
the file Fda_SDmg.out.  Those structures 
that have errors are written to the file 
Fda_SdErrors.out.  Each row contains data 
about one structure and indicates the source 
of the problem.  

 
 >9 Tabulation of stage-aggregated damage for 

each structure is written to the file 
Fda_SDmg.out.  It includes structure, 
content, other, and total.  Detailed data 
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validation for all structures is written to 
FDA_SdErrors.out, one structure per row. 

 
 >49 Header information and a detailed table of 

Monte-Carlo simulation results for each 
structure are written to the file 
FDA_SDev.out. 

 
 >99 Internal debug information that is not 

related to the computations is written to the 
files Fda_SDmg.out and Fda_SDev.out. 

 
 ● Write Structural Details.  This option controls the output of 

detailed structure information.  If not selected, FDA will not 
write detailed information for each structure to the file 
FDA_StrucDetail.out.  If selected (default),FDA writes 
detailed structure information to file FDA_StrucDetail.out.  
One row is written for each structure in tab delimited text 
format.  It includes all structure attributes entered by you as 
well as stage, depth, damage at each of the computed water 
surface profile stages. 

 
 ● Append Trace.  If not selected (default), FDA will overwrite 

any existing output written to the files FDA_SDmg.out and 
FDA_SdErrors.out.  If selected, output will be appended to 
existing information. 

 
 ● Append Std Dev Trace.  If not selected (default), FDA will 

overwrite any existing output written to the file 
FDA_SDev.out.  If selected, output will be appended to 
existing information. 

 
 ● Append Structural Details.  If not selected (default), FDA 

will overwrite any existing output written to the file 
FDA_StrucDetail.out.  If checked, output will be appended to 
the existing information. 

 
 ● Import Field Separator(s).  This option defines characters 

which are used to parse fields in delimited text files which are 
imported into FDA.  The TAB character is the preferred 
(default) option and must be used for importing ASCII tab-
delimited text files such as structure inventory files created. 

 
 

12.12 Data Entry Variables for Stage-Damage Functions 
 
Plan Name:  Select a previously defined plan name. 
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Stream Name:  Select a previously defined stream name. 
 
Analysis Year:  Select a previously defined analysis year. 
 
Damage Reach:  Select a previously defined damage reach. 
 
Damage Category:  Select a previously defined damage category. 
 
Stage-Damage Function Name:  Required name for the defined stage-
damage function, which is used for reports and plots.  This name 
associates a stage-damage function with a plan, stream, year, damage 
reach, and damage category.  We recommend the name be descriptive of 
the location (damage reach), type of damage property (damage category), 
and analysis year.  For example, the name "DR1 APT 2009" conveys the 
stage-damage function is for damage reach DR1, damage category 
Apartment, and analysis year 2009.  The maximum length for a given 
stage-damage function name is sixteen (16) characters. 
 
Computed stage-damage functions are automatically assigned a unique 
name such as "AggDamg001215", which can be changed (see Section 
12.9, page 12-10). 
 
Stage-Damage Function Description:  Optional description of the 
defined stage-damage function.  The maximum length is sixty-four (64) 
characters.  Automatically computed stage-damage functions do not have 
a description, but a description can be added. 
 
Stage-Damage Uncertainty:  You may select only the normal 
distribution to define the uncertainty for the stage-damage relationship.  If 
there is no uncertainty, enter zeros (not blanks) for all standard deviations 
of error. 
 
 

12.13 References 
 
EM 1110-2-1619 
Engineering and Design:  Risk-based Analysis for Flood Damage 
Reduction Studies 
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CHAPTER 13  
 
 
 
 

Evaluation 
 
Evaluation is where you may review the study status, perform two types 
of analyses, and view results.  The two analysis options are: 1) 
computation of expected annual damage and project performance 
(Evaluation of Plans by Analysis Year), and 2) computation of equivalent 
annual damage over the specified analysis period (project life) for the 
plan. 

Evaluation is 
where you may 
review the study 
status, perform 
two types of 
analyses, and 
view results.  The 
two analysis 
options are 
computation of 
expected annual 
damage (which 
includes project 
performance, and 
computation of 
equivalent annual 
damage. 

 
In general, data developed and displayed under HydEng and Economics 
represent the best estimates of the median values of the exceedance 
probability, stage, and damage functions for without- and with-project 
conditions.  Uncertainty parameters of the functions are also developed for 
study conditions.  The analyses performed and results displayed use the 
median valued functions and associated uncertainties as input to produce 
expected values as output.  The computational procedure used is Monte 
Carlo.  Appendix H describes the computation procedures in detail. 
 
 
Contents 
 
 ● Study Status Report 
 ● Evaluation of Plans by Analysis Years (calculation of expected 

annual damage and project performance) 
 ● Equivalent Annual Damage Analysis 
 
 

13.1 Study Status Report 
 
The Study Status Report dialog box (see Figure 13.1, page 13-2) 
displays the completeness of the study data by plans and analysis years.  
The report keys off the assignment tables for each of the individual 
functions. 
 
To review that status of the study data: 
 
 1. From the HEC-FDA main window (see Chapter 2, Section 2.1, 

Figure 2.1, page 2-2), on the Evaluation menu, click Study Status 
Report. 
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Figure 13.1  Study Status Report Dialog Box 

 2. The Study Status Report dialog box will open (Figure 13.1). 
 3. The table on the Study Status Report dialog box is organized by 

plan and analysis year.  Each defined analysis year has a separate 
column – Base Year, Most Likely Future Year.  If the data set is 
complete, in the cell will be the string PS$, which is stating that the 
data set is complete.  The characters in the string have the following 
meaning: 

 P in the first character of the string, a P indicates that the 
exceedance probability functions for all streams and damage 
reaches for the selected plan and analysis year are complete 

 S in the second character of the string, an S indicates that the 
stage-discharge functions for all streams and damage 
reaches for the selected plan and analysis year are complete 

 $ in the third character of the string, a $ indicates that the 
stage-damage functions for all streams, damage categories, 
and damage reaches for the selected plan and analysis year 
are complete 

 4. If an asterisk (*) appears in the sting, this is an indication that 
something is wrong with the data set for that plan and analysis year.  
Depending on the location of the asterisk in the string, you will 
need to return to the appropriate function (exceedance probability, 
stage-discharge, stage-damage) and review the data for that plan 
and analysis year. 

 5. Once you have reviewed the plan and analysis years, on the File 
menu, click Close, the Study Status Report dialog box will close. 

 6. It is recommended that you review the Study Status Report dialog 
box (Figure 13.1) before attempting to compute the plan and 
analysis year damage and performance results. 
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13.2 Evaluation of Plans by Analysis Year 
 
The computation of expected annual damage (EAD) is the first step in the 
overall computation process in FDA.  FDA combines the exceedance 
probability functions, stage-discharge functions, and structure inventory 
data to compute EAD.  See Appendix H for further details on the FDA 
computation procedures. 
 
Plan and damage reach project performance analyses are based on target 
standards defined for without-project conditions for the study. There are 
three different cases for determining the target: 
 
 1. For reaches without levees, the target is based on an estimate of the 

stage at which significant damage begins for the without condition, 
 2. For reaches with a levee that have no geotechnical failure, the 

target is the top of levee stage, and 
 3. For reaches with a levee that have geotechnical failure, the target is 

based on both the annual exceedance probability and the 
probability of failure. 

 
For reaches without levees, the standards used by the FDA program are 
based on the residual damage associated with a specific exceedance 
probability event.  Performance targets are essentially the zero damage 
stage but normally consider minor damage to the infrastructure as 
acceptable and significant damage to structures as not acceptable.  
Consistent criteria for comparing the impacts of different measures and 
plans are also a goal.  Experience at HEC has shown that a 5 percent 
residual damage associated with the .01 exceedance probability event is 
normally a good target stage and was adopted as the FDA default.  You 
may enter other values if they are deemed better for your study conditions. 
The same values must be used for all calculations. 
 
Computing expected annual damage: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Evaluation menu, click Evaluation of Plans 
by Analysis Year. 

 2. The Evaluation of Plans by Analysis Year dialog box will open 
(see Figure 13.2, page 13-4). 

 3. The table displays the plans and analysis years that are available for 
computation.  To select all plans and analysis years for 
computation, on the File menu, click Select All.  You can use the 
CTRL key to individually select plans and analysis years for 
computation.  The without project plan must have been successfully 
computed before any other plans can be computed. 

 4. For the without plan, base year; performance target criteria is used 
to compute the plan's annual exceedance probability, long-term risk,  

Computation of 
expected annual 
damage (EAD), 
which also 
includes project 
performance. 
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Figure 13.2  Evaluation of Plans by Analysis Year Dialog Box 

  and conditional non-exceedance probability.  The performance 
target is a stage that is defined by entering values in the Event 
Exceedance Probability and the Percent Residual boxes (Figure 
13.2).  The target stage is the stage at which a percentage of a 
specified event's damages occur.  For example, in Figure 13.2, the 
target criteria can be the stage that results in damage equal to 5% 
(default value) of the damage attributed to the 0.01 (default value) 
Annual Exceedance Probability (AEP) stage. 

 5. If you want to compute without using uncertainty, from the table in 
the Compute With Risk Column (Figure 13.2), click the cell of 
the plan and analysis year that you do not want uncertainty 
computed.  The check mark will clear, and the computation for that 
plan and analysis will not include uncertainty.  The computation 
without uncertainty is performed in the same way as conventional 
studies prior to risk analysis being required.  The computed 
probability function is internally replaced by the expected 
probability function and then used along with the stage-discharge 
and damage-stage functions without uncertainty to compute 
expected annual damage. 

 6. Once you have selected the plans and analysis years you want to 
computer click Compute.  The EAD Computation Status dialog 
box will open (Figure 13.3).  This dialog box will provide you with 
information about 
the compute 
process. 

 7. When the 
compute is 
complete, click 
Close, the EAD 
Computation 
Status dialog box 
will close (Figure 

you to the  

Annual 
Exceedance 
Probability (AEP) 
is the probability 
that flooding will 
occur in any given 
year considering 
the full range of 
possible annual 
floods. 

13.3) and return 
Figure 13.3  EAD Computation Status Dialog Box 
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   of Plans by Analysis Year dialog box (see Figure 13.2, 
page 13-4).  A check mark will appear in the Execute column of the 
table, along with a date stamp of the compute in the Date of 
Execution column of the table. 

 8. On the File menu, click Close, the Evaluation of Plans by 
Analysis Year dialog box will close (see Figure 13.2, page 13-4). 

 9. If anything in the data set for a plan and analysis year has changed, 
when you open the Evaluation of Plans by Analysis Year dialog 
box (see Figure 13.2, page 13-4), the check mark will no longer 
appear in the Execute column for that plan and analysis year, which 
means you need to re-compute. 

 
 

13.3 Equivalent Annual Damage Analysis 
 
The next step in the compute process is the computation of equivalent 
annual damage.  The expected annual damage computation for the base 
and most likely future conditions analysis years of a plan must be 
successfully computed before you can compute equivalent annual damage 
analysis. 
 
The flood damages associated with a plan are calculated in average annual 
equivalent terms (see ER 1105-2-100).  The procedures discount the 
expected annual damage stream to the beginning of the period of analysis 
or the base year.  Future year damage values are linearly interpreted 
between the base and most likely future year conditions and assumed 
constant from the most likely future year to the end of the analysis period.  
The analysis period (project life) is the period of time over which the plan 
has significant beneficial or adverse effects.  It is normally 50 years and is 
not to exceed 100 years. 
 
Computing equivalent annual damage: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Evaluation menu, click Equivalent Annual 
Damage Analysis. 

 2. The Equivalent Annual Damage Analysis dialog box will open 
(see Figure 13.4, page 13-6). 

 3. In the Analysis Period box, you must enter the analysis period in 
years, default is 50 years. 

 4. In the Discount Rate box (see Figure 13.4, page 13-6), you must 
enter the discount rate in percent, default is 7.625 percent. 

 5. The table displays the plans and analysis years that are available for 
computation.  To select all plans and analysis years for 
computation, on the File menu, click Select All.  You can use the 
CTRL key to individually select plans and analysis years for 
computation. 

Evaluation
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Figure 13.4  Equivalent Annual Damage Analysis Dialog Box 

 6. Once you have selected the plans and analysis years you want to 
computer click Compute.  When the compute is comp

 the table, alon
xecution colum

ark will no longer app

lete, a check 
g with a 

n of the 

ear in 

13.4 Refer

mark will appear in the Execute column of
date stamp of the compute in the Date of E
table. 

 7. On the File menu, click Close, the Equivalent Annual Damage 
Analysis dialog box will close (Figure 13.4). 

 8. If the expected annual damage computation has be re-computed for 
a plan, when you open the Equivalent Annual Damage Analysis 
dialog box (Figure 13.4), the check m
the Execute column for that plan, which means you need to re-
compute. 

 
 
ences 
 
ER 1105-2-100 
Guidance for Conducting Civil Works Planning Studies 
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CHAPTER 14  
 
 

Damage by Analysis Year Reports 
 
 
These reports display the results of the evaluation of plans by analysis 
years analyses (see Chapter 13, Section 13.2, page 13-3), and are 
consistent with requirements of Corps planning regulations for 
formulation and evaluation of flood damage reduction plans.  These 
reports are grouped into three areas - general information, damage reach 
summaries, and expected annual damage. 

The Damage by 
Analysis Year 
reports display 
the results of the 
computation of 
expected annual 
damage (EAD).  

To access the damage by analysis year reports: 
 
 1. From the HEC-FDA main window (see Chapter 2, Section 2.1, 

Figure 2.1, page 2-2), on the Evaluation menu, point to Results, 
click Damage by 
Analysis Years. 

 2. The Damage by 
Analysis Year 
dialog box will 
open (Figure 14.1). 

 3. From this dialog 
box, you will 
access the four 
different groups of 
reports that make 
up the results from 
the evaluation of 
plans by analysis 
years analyses. 

Figure 14.1  Damage by Analysis Year Dialog Box 

 
 

14.1 General Information Reports 
 
The General Information Reports 
(Figure 14.2) provide information on 
what plans and analysis years were 
computed for the evaluation of plans 
by analysis years, the Monte Carlo 
computation by plan, analysis year, 
stream, and damage reach, and 
warning information for each 
computation. 

Figure 14.2 General Information 
Reports Box 

 14-1 
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14.1.1 Data Management Summary 

e plans and analysis years that were 
lected for evaluation of plans by analysis years computation. 

 box (see Figure 14.1, 
page 14-1), from the General Information Reports box (see 

rt 

 2. T  
analysis years com

 3. 
icates that the computations for a plan and analysis year 

g 

 4. 
).  Be sure the appropriate 

 

 5. 
nd you will return to the Damage 

 

 
This report provides a summary of th
se
 
To view the Data Management Summary report: 
 
 1. From the Damage by Analysis Years dialog

Figure 14.2, page 14-1), click Data Management Summary.  
Click Display Report, the Data Management Summary repo
(Figure 14.3) will open. 

General 
information 

ovide 
n 

 

reports pr
information o
what plans and 
analysis years 
were computed, 
Monte Carlo 
computation, and
warning 
information. 

Figure 14.3  Data Management Summary 

he report displays information about the
putation.  This reporting is done by plan and 

 evaluation of plans by

analysis year.  You can verify that a particular plan and analysis 
year did get computed, and whether or not uncertainty was also 
computed. 
A sting of asterisks (*****) displayed in the Date of Execution 
column, ind
have not been completed.  A plus-sign (+) indicates that somethin
has changed in the data set for that particular plan and analysis year 
and the computation needs to be redone. 
To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3
printer has been selected, and click OK.  The Print dialog box will
close and the report will print. 
On the File menu, click Close, the Data Management Summary 
report will close (Figure 14.3) a
by Analysis Year dialog box (see Figure 14.1, page 14-1). 
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Monte Carlo Analysis Summary 

 
This report and plot displays the num
performed for a specific plan, analysis year, stream, and da
 
To view the Monte Carlo Analysis Summary
 
 1. From the Damage by Analysis Years

page 14-1), from the General Inform
Figure 14.2, page 14-1), click 

 2. The Report Information box (Figure 14.5) on the 
Analysis Year dialog box (see Figure 14.1, page 14-1) becom
active. 

14.1.2 

ber of Monte Carlo iterations 
mage reach. 

 report and plot: 

 dialog box (see Figure 14.1, 
ation Reports box (see 

Monte Carlo Analysis Summary. 
Damage by 

es 

 3. The Monte Carlo Analysis Summary reports are viewed by plan, 
stream, analysis year, and damage reach.  Therefore, you need to 
select the appropriate plan from the Plan Name list, the appropriate 
analysis year from the Analysis Year list, the appropriate stream 
from the Stream Name list, and the appropriate damage reach from 
the Damage Reach Name list, in the Report Information box 
(Figure 14.5). 

 4. Click Display Report, the Monte Carlo Analysis Summary with 
Uncertainty report will open (see Figure 14.6, page 14-4). 

 5. This report displays the number of Monte Carlo iterations 
performed for a specific plan, analysis year, stream, and damage  

Figure 14.4  Print Dialog Box 

Figure 14.5  Report Information Box 
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Figure 14.6 Monte Carlo Analysis Summary with Uncertainty - Report 

  reach.  The table shows the variation in the expected annual dam

 6. 
 analysis year have not been completed.  A plus-sign (+) 

indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs to be 
redone. 

age 

 

 7. To plot the results of the Monte Carlo computation, on the File 
menu, click Plot, the Monte Carlo Analysis Summary with 
Uncertainty for Damage Reach plot will open (see Figure 14.7, 
page 14-5).  After reviewing the plot, on the File menu, click Close 
the Monte Carlo Analysis Summary with Uncertainty for 
Damage Reach plot will close and return you to the Monte Carlo 
Analysis Summary with Uncertainty report (Figure 14.6). 

 8. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 9. On the File menu, click Close, the Monte Carlo Analysis 
Summary report will close (Figure 14.6) and you will return to the 
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1). 

(Grand Mean) and the Grand Mean Standard Error throughout the 
progression of the iterations performed.  The computations are 
terminated when the grand mean is within an allowable tolerance. 
The procedures are described in Appendix F. 
A sting of asterisks (*****) indicates that the computations for a 
plan and
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Figure 14.7 Monte Carlo Analysis Summary
Plot 

 with Uncertainty -

 
Warning Message Log 

 
The Warning Message Log should be reviewed after 
file and may be edited, i.e. previous run inform
Messages are always appended to this
 
To view the Warning Message Log: 
 
 1. From the Damage by Analysis Years

page 14-1), from the General Information Rep
Figure 14.2, page 14-1), click Warning Message Log
Display Report, the Warning Message Log
open. 

 14-5 

14.1.3 

each run.  It is a text 
ation deleted as desired. 

 file so it can get very large. 

 dialog box (see Figure 14.1, 
orts box (see 

.  Click 
 (Figure 14.8) will 

 
Figure 14.8  Warning Message Log 
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 2. The Warning Message Log (see Figure 14.8, page 14-5) is a text 
file that should be reviewed after each program computation.  It 
provides information such as the rating function was extended, 
damage not zero at the minimum, etc. for each run.  From this 
information you might need to modify the input data used in the 
analysis.  Warning messages are always appended to this file and it 
may get very large.  When viewed, FDA opens WordPad so that 
you can edit and print the file.  If it is not opened by the FDA, you 
can edit the file with any editor or delete the file.  The file is named 
"Fda_WarningMsg.out" and is located in the same subdirectory as 
all of the database files for a study. 

 
 

14.2 Damage Reach Summaries 
 
The Damage Reach Summaries (Figure 14.9) consist of four different 
types of probability function reports:  discharge-probability, stage-

al l

Monte  
as to c  
are the

 
14.2.1 Exceedan

 

plot: 
 
 1. 

 

 2.  the 
 

 3. 
ge reach.  Therefore, you need to 

ropriate 

Damage reach 
summaries 
provide 
information about 
the probability 
functions.  These 
functions are 
"average" curves 
and should not be 
used for 
analytical 
purposes. 

probability, damage-
probability, and 
damage reduced-
probability.  These 
functions are "average" 
curves that are 
c cu ated from those 
generated during the 

 Carlo simulations, and cannot be used for analytical purposes such
ompute expected annual damage.  The Damage Reach Summaries
refore not active when you are not computing uncertainty during 

the computation of EAD (see Section 13.2, pages 13-3 thru 13-5). 
 

ce Probability – Discharge Function 

To view the Exceedance Probability-Discharge Function report and 

From the Damage by Analysis Years dialog box (see Figure 14.1, 
page 14-1), from the Damage Reach Summaries box (Figure
14.9); click Exceedance Probability – Discharge Function. 
The Report Information box (see Figure 14.5, page 14-3) on
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1)
becomes active. 
The Damage Reach Summaries reports are viewed by plan, 
stream, analysis year, and dama
select the appropriate plan from the Plan Name list, the app
analysis year from the Analysis Year list, the appropriate stream 
from the Stream Name list, and the appropriate damage reach from 

Figure 14.9 Damage Reach Summaries Box 
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the Damage Reach Name list, in the Report Information box (see 
Figure 14.5, page 14-3). 

 4. Click Display Report, the Exceedance Probability – Discharge 
Function for Damage Reach report will open (Figure 14.10). 

 5. This report displays the average exceedance probability-discharge 
function generated by the Monte Carlo simulation for the selected 
damage reach.  The analytical procedures used to develop the 
function are described in Appendix G. 

 6. A sting of asterisks (*****) indicates that the computations for a 
plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs to be 
redone. 

Figure 14.10 Exceedance Probability - Discharge Function Report 
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 7. To plot the average exceedance probability discharge function, on 
the File menu, click Plot, the Exceedance Probability – Mean 
Discharge Function for Damage Reach plot will open (Figure 
14.11).  After reviewing the plot, on the File menu, click Close the 
Exceedance Probability – Mean Discharge Function for Damage 

 8. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 9. On the File menu, click Close, the Exceedance Probability - 
Discharge Function for Damage Reach report will close (see 
Figure 14.10, page 14-7) and you will return to the Damage by 
Analysis Year dialog box (see Figure 14.1, page 14-1). 

 
 

14.2.2 Exceedance Probability – Stage Function 
 
To view the Exceedance Probability-Stage Function report and plot: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14.1, 

page 14-1), from the Damage Reach Summaries box (see Figure 
14.9, page 14-6); click Exceedance Probability – Stage Function. 

Reach plot will close and return you to the Exceedance 
Probability Discharge Function for Damage Reach report (see 
Figure 14.10, page 14-7). 

Figure 14.11  Exceedance Probability – Mean Discharge Function - Plot 
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 2. The Report Information box (see Figure 14.5, page 14-3) on the 
Damage by Analysis Year dialog box (see Figure 14.1, page 14
becomes active. 
The Damage Reach Summaries reports are viewed by plan, 
stream, analysis year, and damage reach.  Therefore, you need to 
select the appropriate plan from the Plan Name list, the appropriate 
analysis year from the Analysis Year list, the appropriate stream 
from the Stream Name list, and the appropriate damage reach from
the Damage Reach Name list, in the Report Information box (see 
Figure 14.5, page 14-3). 
Click Display Report, the Exceeda

-1) 

 3. 

 

 4. nce Probability – Stage 
Function for Damage Reach report will open (Figure 14.12). 

 
 5. This report displays the average exceedance probability-stage 

function generated by the Monte Carlo simulation for the selected
damage reach.  The analytical procedures used to develop the 
function are described in Appendix G. 

Figure 14.12 Exceedance Probability - Stage Function Report 
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 6. 
ve not been completed.  A plus-sign (+) 

e 
redone. 

 7. To plot the average exceedance probability stage function, on the 
File menu, click Plot, the Exceedance Probability – Mean Stage 
Function for Damage Reach plot will open (Figure 14.13).  After 
reviewing the plot, on the File menu, click Close the Exceedance 

Probability – Mean Stage Function for Damage Reach plot will 
close and return you to the Exceedance Probability Stage 
Function for Damage Reach report (see Figure 14.12, page 4-9). 

 8. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 9. On the File menu, click Close, the Exceedance Probability - Stage 
Fun

 
 

14.2.3 Excee
 
To vie d plot: 
 
 1.  Damage by Analysis Years dialog box (see Figure 14.1, 

page 14-1), from the Damage Reach Summaries box (see Figure 

A sting of asterisks (*****) indicates that the computations for a 
plan and analysis year ha
indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs to b

Figure 14.13  Exceedance Probability – Mean Stage Function - Plot 

ction for Damage Reach report will close (see Figure 14.12, 
page 14-9) and you will return to the Damage by Analysis Year 
dialog box (see Figure 14.1, page 14-1). 

dance Probability – Damage Function 

w the Exceedance Probability-Damage Function report an

From the
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14.9, page 14-6); click Exceedance Probability – Damage 
Function. 
The Report Information box (see Figure 14.5, page 14-3) on th
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1) 
becomes active. 

 2. 

 3. The Damage Reach Summaries reports are viewed by plan, 
stream, analysis year, and damage reach.  Theref
select the appropriate plan from the Plan Name
analysis year from the Analysis Year list, the appropria
from the Stream Name list, and the appropriate dama

e 

ore, you need to 
 list, the appropriate 

te stream 
ge reach from 

the Damage Reach Name list, in the Report Information box (see 
Figure 14.5, page 14-3). 

 4. Click Display Report, the Exceedance Probability – Damage 
Functions for Damage Reach report will open (Figure 14.14). 

 5. 

damage reach.  The analytical procedures used to develop the 
function are described in Appendix G. 

This report displays the average exceedance probability-damage 
function generated by the Monte Carlo simulation for the selected 

Figure 14.14 Exceedance Probability - Damage Functions Report 
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 6. A sting of asterisks (*****) indicates that the computations for a 
plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something has changed in the data set for that 

 be 

 7. 

 – Mean Damage Function for Damage 

Reach plot will close and return you to the Exceedance 
Probability Damage Functions for Damage Reach report (see 
Figure 14.14, page 14-11). 

 8. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 9. On the File menu, click Close, the Exceedance Probability 
Damage Functions for Damage Reach report will close (see 
Figure 14.14, page 14-11) and you will return to the Damage by 
Analysis Year dialog box (see Figure 14.1, page 14-1). 

 
 

14.2.4 Excee  
 
To vie rt and 
plot: 
 

particular plan and analysis year and the computation needs to
redone. 
To plot the average exceedance probability damage functions, on 
the File menu, click Plot, the Exceedance Probability – Mean 
Damage Function for Damage Reach plot will open (Figure 
14.15).  After reviewing the plot, on the File menu, click Close the 
Exceedance Probability

dance Probability – Mean Damage Reduced

w the Exceedance Probability-Mean Damage Reduced repo

Figure 14.15  Exceedance Probability – Mean Damage Function - Plot 
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 1. From the Damage by Analysis Years dialog box (see Figure 14.1
page 14-1), from the Damage Reach Summaries box (see Figure
14.9, page 14-6); click Exceedance Probability – Mean Da
Reduced. 
The Rep

, 
 

mage 

gure 14.5, page 14-3) on the 
) 

 list, the appropriate 
t, the appropriate stream 

amage reach from 
the Damage Reach Name list, in the Report Information box (see 
Figure 14.5, page 14-3). 

 4. Click Display Report, the Exceedance Probability – Mean 
Damage Reduced for Damage Reach report will open (Figure 
14.16). 

 5. This report 
displays the 
average 
exceedance 
probability-mean 
damage reduced 
values for the 
without-and 
with-project 
conditions and 
th

Appendix F. 

e 

 2. ort Information box (see Fi

 3. 

select the appropriate plan from the Plan Name
analysis year from the Analysis Year lis
from the Stream Name list, and the appropriate d

Damage by Analysis Year dialog box (see Figure 14.1, page 14-1
becomes active. 
The Damage Reach Summaries reports are viewed by plan, 
stream, analysis year, and damage reach.  Therefore, you need to 

mean damage 
reduced 
generated by the 

e associated 

Monte Carlo 
simulation for 
the selected 
damage reach.  
The analytical 
procedures used 
to develop the 
function are 
described in 

 6. A sting of 
asterisks (*****) 
indicates that the 
computations for Figure 14.16 Exceedance Probability - Mean Damag
a plan and 
analysis year  

Reduced Report 
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  ething 
 in the data set for that particular plan and analysis year 

 7. 
 menu, click Plot, the Exceedance Probability 

 

Damage Reach plot will close and return you to the Exceedance 
Probability Mean Damage Reduced for Damage Reach report 
(see Figure 14.16, page 14-13). 

 8. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 9. On the File menu, click Close, the Exceedance Probability Mean 
Damage Reduced for Damage Reach report will close (see Figure 
14.16, page 14-13) and you will return to the Damage by Analysis 
Year dialog box (see Figure 14.1, page 14-1). 

 
 

14.3 Expected Annual Damage 
 

 
catego
years,
 

have not been completed.  A plus-sign (+) indicates that som
has changed
and the computation needs to be redone. 
To plot the average exceedance probability mean damage reduced 
function, on the File
– Mean Damage Reduced for Damage Reach plot will open
(Figure 14.17).  After reviewing the plot, on the File menu, click 
Close the Exceedance Probability – Mean Damage Reduced for 

The Expected Annual Damage reports (see Figure 14.18, page 14-15) 
consist of four primary reports on expected annual damage:  1) by damage

ries, 2) damage reduced and distributed, 3) by plans and analysis 
 and 4) by analysis years. 

Figure 14.17 Exceedance Probability – Mean Damage Reduced - Plot 
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The expected 
annual damage 
reports provide 
information on 
the calculated 
expected annual 
damage. 

Figure 14.18  Expected Annual Damage Box 
 

By Damag
 
To view the By Damage Categories - Plans report: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14.1, 

14.3.1 

page 14-1), from the Expected Annual Damage box (Figure 
14.18); click By Damage Categories in the Summary Type 
section.  This report can be displayed either by plans for a selected 
analysis year or by damage reaches for a selected plan.  To display 
this report by plans, click Plans in the Summary Information 
section (Figure 14.18). 

 2. The Report Information box (see Figure 14.5, page 14-3) on the 
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1) 
becomes active. 

 3. The By Damage Categories - Plans report is viewed by analysis 
year, therefore, you need to select the appropriate analysis year 
from the Analysis Year list, in the Report Information box (see 
Figure 14.5, page 14-3). 

 4. Click Display Report, the Expected Annual Damage by Damage 
C

5. This report displays the total damage by plans for a selected 
analysis year. 

 
 

redone. 

e Categories - Plans 

ategories and Plans report will open (Figure 14.19). 

Figure 14.19 Expected Annual Damage by Damage Categories and Pla
Report 

ns 

 

 6. A sting of asterisks (*****) indicates that the computations for a
plan and analysis year have not been completed.  A plus-sign (+)
indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs to be 

 14-15 



Chapter 14 – Damage by Analysis Year Reports HEC-FDA User's Manual 

 7. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate
printer has been selected, and click OK.  The Print dialog box will 
close and th

 

e report will print. 

ou will return to the Damage by Analysis Year 

 
 

14.3.2 By Damag
 
To vie

.1, 
 

 in 

om the Analysis Year list, in the Report 
ox (see Figure 14.5, page 14-3). 

 4. port, the Expected Annual Damage by Damage 
amage Reaches report will open (Figure 14.20). 

 5. plays the total da  reaches for a 
nd analysis year. 

 8. On the File menu, click Close, the Expected Annual Damage by 
Damage Categories and Plans report will close (see Figure 14.19, 
page 14-15) and y
dialog box (see Figure 14.1, page 14-1). 

e Categories – Damage Reaches 

w the By Damage Categories – Damage Reaches report: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14

page 14-1), from the Expected Annual Damage box (see Figure
14.18, page 1
Type section.
selected anal
display this 
the Summary Informa
The Report Inform
Damage by Anal
becomes active
The By Dam
by plan and ana
appropriate plan
analysis year fr
Information b
Click Display Re
Categories and D

4-15); click By Damage Categories in the Summary 
  This report can be displayed either by plans for a 

ysis year or by damage reaches for a selected plan.  To 
report by damage reaches, click Damage Reaches

tion section (see Figure 14.18, page 14-15). 
 2. ation box (see Figure 14.5, page 14-3) on the 

ysis Year dialog box (see Figure 14.1, page 14-1) 
. 

 3. age Categories – Damage Reaches report is viewed 
lysis year.  Therefore, you need to select the 
 from the Plan Name list, and the appropriate 

Figure 14.20 Expe
Dama

cted Annual Damage by Damage Categories and 
ge Reaches Report 

This report dis
selected plan a

mage by damage
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 14-17 

 . A sting of asterisks (*****) indicates that the computations for a 
plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something has changed in th

6

e data set for that 

 7. log 
te 

close and the report will print. 
 8. On the File menu, click Close, the Expected Annual Damage by 

Damage Categories and Damage Reaches report will close (see 
Figure 14.20, page 14-17) and you will return to the Damage by 
Analysis Year dialog box (see Figure 14.1, page 14-1). 

 
 

14.3.3 Damage Reduced Distribution - Plans 
 
To view the Damage Reduced Distribution - Plans report: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14.1, 

page 14-1), from the Expected Annual Damage box (see Figure 
14.18, page 14-14); click Damage Reduced Distribution in the 
Summary Type section.  This report can be displayed either by 
plans for a selected analysis year or by damage reaches for a 
selected plan.  To display this report by plans, click Plans in the 
Summary Information section (see Figure 14.18, page 14-15). 

 2. T
Damage by Analysis Year

 3. 

 4. 

 5. 
  

ual damage reduced 
by plan in terms of the probability that the damage reduced exceeds 

f .75, .50, and .25.  For example (see 
re is a .75 probability that the damage 

reduced for Plan 1 exceeds 230.51, a .50 probability that it exceeds 

as changed in the data set for that  

particular plan and analysis year and the computation needs to be 
redone. 
To print the report, on the File menu, click Print, the Print dia
box will open (see Figure 14.4, page 14-3).  Be sure the appropria
printer has been selected, and click OK.  The Print dialog box will 

 dialog box (see Figure 14.1, page 14-1) 
becomes active. 
The Damage Reduced Distribution - Plans report is viewed by 
analysis year, therefore, you nee

he Report Information box (see Figure 14.5, page 14-3) on the 

d to select the appropriate analysis 
year from the Analysis Year list, in the Report Information box 
(see Figure 14.5, page 14-3). 
Click Display Report, the Expected Annual Damage Reduced 
and Distributed by All Plans report will open (see Figure 14.21, 
page 14-18). 
This report displays the expected annual damage for the without- 
and with-project conditions for all plans for a selected analysis year.
It also displays the distribution of expected ann

a value for the probabilities o
Figure 14.21, page 14-18), the

322.27 and a .25 probability it exceeds 448.40. 
 6. A sting of asterisks (*****) indicates that the computations for a 

plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something h
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   be 

 7. 
 

ill 
 print. 

ill return to the Damage by Analysis Year dialog 

 
 

14.3.4 Damage Reduced Distribution – Damage Reaches 

To vie es report: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14.1, 

page 14-1), from the Expected Annual Damage box (see Figure 
14.18, page 14-15); click Damage Reduced Distribution in the 
Summary Type section.  This report can be displayed either by 
plans for a selected analysis year or by damage reaches for a 
selected plan.  To display this report by damage reaches, click 
Damage Reaches in the Summary Information section (see 
Figure 14.18, page 14-15). 

 2. 
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1) 

ort is 
e 

particular plan and analysis year and the computation needs to
redone. 
To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriate
printer has been selected, and click OK.  The Print dialog box w
close and the report will

 8. On the File menu, click Close, the Expected Annual Damage 
reduced and Distributed by All Plans report will close (Figure 
14.21) and you w
box (see Figure 14.1, page 14-1). 

 
w the Damage Reduced Distribution – Damage Reach

The Report Information box (see Figure 14.5, page 14-3) on the 

becomes active. 
 3. The Damage Reduced Distribution – Damage Reaches rep

viewed by plan and analysis year.  Therefore, you need to select th
appropriate plan from the Plan Name list, and the appropriate 
analysis year from the Analysis Year list, in the Report 
Information box (see Figure 14.5, page 14-3). 

Figure 14.21 Expected Annual Damage Reduced and Distributed by All 
Plans Report 
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 4. Click Display Report, the Expected Annual Damage Reduced 
and Distributed for the Plan report will open (Figure 14.22). 

 5. This report displays the expected annual damage for the without- 

75, 

 6. 
 year have not been completed.  A plus-sign (+) 

o be 

 7. nt dialog 
sure the appropriate 

 8. On the File menu, click Close, the Expected Annual Damage 
Reduced and Distributed by All Plans report will close (Figure 
14.22) and you will return to the Damage by Analysis Year dialog 
box (see Figure 14.1, page 14-1). 

 
 

14.3.5 By Plan & Analysis Years 
 
To view the By Plan and Analysis Years report: 
 
 1. From the Damage by Analysis Years dialog box (see Figure 14.1, 

Expected Annual Damage
  

Summary T
nd 

 (see Figure 14.23, page 14-20). 

tributed for the 

and with-project conditions by damage reach for the selected plan 
and analysis year.  It also displays the distribution of expected 
annual damage reduced by damage reach in terms of the probability 
that the damage reduced exceeds a value for the probabilities of .
.50, and .25.  For example (Figure 14.22), there is a .75 probability 
that the damage reduced for Plan 1 exceeds 230.51, a .50 
probability that it exceeds 322.27 and a .25 probability it exceeds 
448.40. 
A sting of asterisks (*****) indicates that the computations for a 
plan and analysis
indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs t
redone. 
To print the report, on the File menu, click Print, the Pri
box will open (see Figure 14.4, page 14-3).  Be 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

page 14-1); from the  box (see Figure  
14.18, page 14-15); click By Plan & Analysis Years in the 

ype section. 
 2. Click Display Report, the Expected Annual Damage Plans a

Analysis Years report will open

Figure 14.22 Expected Annual Damage Reduced and Dis
Plan Report 
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 3. This report displays the expected annual damage values for the base 
year and most likely future year by plan. 

 4. A sting of asterisks (*****) indicates that the computations for a 
plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something has changed in the data set for that 
particular plan and analysis year and the computation needs to be
redone. 
To print the report, on the File menu, click Print, the Print dialo

 

g 
e 

 

14.3.6 Analysis Y

To vie
 
 1. 

 2. page 14-3) on the 
) 

 5. 
box will open (see Figure 14.4, page 14-3).  Be sure the appropriat
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 6. On the File menu, click Close, the Expected Annual Damage 
reduced and Distributed by All Plans report will close (Figure 
14.23) and you will return to the Damage by Analysis Year dialog
box (see Figure 14.1, page 14-1). 

 
 

ears 
 

w the Analysis Years report: 

From the Damage by Analysis Years dialog box (see Figure 14.1, 
page 14-1), from the Expected Annual Damage box (see Figure 
14.18, page 14-15); click Analysis Years in the Summary Type 
section. 
The Report Information box (see Figure 14.5, 
Damage by Analysis Year dialog box (see Figure 14.1, page 14-1
becomes active. 

Figure 14.23 Expected Annual Damage by Plans and Analysis Years 
Report 
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 3. The Analysis Years report is viewed by plan, therefore, you need to 
select the appropriate plan from the Plan Name list, in the Report 
Information box (see Figure 14.5, page 14-3). 

 4. Click Display Report, the Expected Annual Damage by Analysis 
Years for Plan report will open (Figure 14.24). 

 

 dialog 
ate 
ill 
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 5. 

 for each stream. 

nd the computation needs to be 
redone. 

7. To print the report, on the File menu, click Print, the Print

This report summarizes expected annual damage by damage reach 
for the base and most likely future years for a selected plan.  It also 
calculates a subtotal of damage

Report 

 6. A sting of asterisks (*****) indicates that the computations for a
plan and analysis year have not been completed.  A plus-sign (+) 
indicates that something has changed in the data set for that 
particular plan and analysis year a

 

Figure 14.24 Expected Annual Damage by Analysis Years for Plan 

box will open (see Figure 14.4, page 14-3).  Be sure the appropri
printer has been selected, and click OK.  The Print dialog box w
close and the report will print. 

8. On the File menu, click Close, the Expected Annual Damage by  
Analysis Years for Plan report will close (Figure 14.24) and you 
will return to the Damage by Analysis Year dialog box (see Figure
14.1, page 14-1). 
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CHAPTER 15  
 
 

Other HEC-FDA Results 
 
 
Once computations are finished, HEC-FDA provides three major groups 
of reports; in Chapter 14 the Damage by Analysis Years reports have 
already been discussed.  The other two groups of reports are the 
Equivalent Annual Damage Analysis and the Project Performance 
reports.  These reports are consistent with requirements of Corps planning 
regulations for formulation and evaluation of flood damage reduction 
plans.  There are also additional FDA reports that are not available directly 
from the FDA interface.  See Section 15.3 (page 15-12) for further details. 
 
 

15.1 Equivalent Annual Damage Analysis Reports 
 
There are three types of reports: 1) data management summary, 2) 
equivalent annual damage reduced and distributed, and 3) equivalent 
annual damage by damage category. 
 
To access the equivalent annual damage analysis reports: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Evaluation menu, point to Results, click 
Equivalent Annual Damage Analysis. 

 2. The Equivalent Annual Damage Analysis dialog box will open 
(Figure 15.1). 

The Equivalent 
Annual Damage 
Analysis reports 
display the results 
of the 
computation of 
equivalent annual 
damage. 

Figure 15.1  Equivalent Annual Damage Analysis Dialog Box 
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 3. From this dialog box, you will access the three different types of 
reports that make up the results from the equivalent annual damage 
analysis computation. 

 
 

15.1.1 Data Management Summary 
 
This report provides a summary of the plans that were selected for the 
equivalent annual damage analysis computation. 
 
To view the Data Management Summary report: 
 
 1. From the Equivalent Annual Damage Analysis dialog box (see 

Figure 15.1, page 15-1), from the General Information Report 
box, click Data Management Summary.  Click Display Report, 
the Data Management Summary report (Figure 15.2) will open. 

 2. The report displays information about the equivalent annual damage 
analysis computation.  This reporting is done by plan and you can 
verify that a particular plan did get computed, and whether or not 
uncertainty was also computed. 

 3. A sting of asterisks (*****)indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 4. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

Figure15.2  Data Management Summary Report 
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 5. On the File menu, click Close, the Data Management Summary 

 

 

15.1.2 Summary Reports 

he two available summary reports can either be displayed by plan or by 

 Reduced and Distribution - Plans 

o view the Reduced and Distribution - Plans report: 

1. From the Equivalent Annual Damage Analysis dialog box (see 

y 

 2. 

 3. port displays equivalent annual damage for the without- and 

l 

Figure 15.3  Print Dialog Box 

report will close (see Figure 15.2, page 15-2) and you will return to
the Damage by Analysis Year dialog box (see Figure 15.1, page 
15-1). 

 

 
T
damage reach.  These two report display the equivalent annual damage 
reduced and distributed, and the equivalent annual damage by damage 
category. 
 
 

 
T
 
 

Figure 15.1, page 15-1), from the Summary Reports box, click 
Reduced and Distribution.  This report can be displayed either b
all plans or by damage reaches for a selected plan.  To display this 
report by all plans, click Plans in the Summary Information box. 
Click Display Report, the Equivalent Annual Damage Reduced 
and Distributed by Plans report will open (see Figure 15.4, page 
15-4). 
This re
with-project conditions and the associated damage reduced for all 
plans.  The report also displays the distribution of equivalent annua
damage reduced by a plan in terms of the probability that the  
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Figure 15.4 Equivalent Annual Damage Reduced and Distributed by 
Plans Report 

  damage reduced exceeds a value for the probabilities of .75, .50, 
and .25.  For example (Figure 15.4), for Plan 1, there is a .75 
probability that the equivalent annual damage reduced is greater 
than 272.31, a .50 probability it is greater than 385.10, and a .25 
probability it is greater than 534.92. 

 4. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 5. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 6. On the File menu, click Close, the Equivalent Annual Damage 
Reduced and Distributed by Plans report will close (Figure 15.4) 
and you will return to the Damage by Analysis Year dialog box 
(see Figure 15.1, page 15-1). 

 
 

 Reduced and Distribution – Damage Reaches 
 
To view the Reduced and Distribution – Damage Reaches report: 
 
 1. From the Equivalent Annual Damage Analysis dialog box (see 

Figure 15.1, page 15-1), from the Summary Reports box, click 
Reduced and Distribution.  This report can be displayed either by 
all plans or by damage reaches for a selected plan.  To display this 
report by damage reaches, click Damage Reaches in the Summary 
Information box. 
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 2. The Report Information box on the Equivalent Annual Damage 
Analysis dialog box (see Figure 15.1, page 15-1) becomes active.  
The Reduced and Distribution – Damage Reaches report is 
viewed by plan; therefore, you need to select the appropriate plan 
from the Plan Name list in the Report Information box. 

 3. Click Display Report, the Equivalent Annual Damage Reduced 
and Distributed for the Plan report will open (Figure 15.5). 

 4. This report displays equivalent annual damage for the without- and 
with-project conditions and the associated damage reduced for the 
selected plan by damage reach.  The report also displays the 
distribution of equivalent annual damage reduced by damage reach 
in terms of the probability that the damage reduced exceeds a value 
for the probabilities of .75, .50, and .25.  For example (Figure 15.5), 
for Plan 1, there is a .75 probability that the equivalent annual 
damage reduced is greater than 272.31, a .50 probability it is greater 
than 385.10, and a .25 probability it is greater than 534.92. 

 5. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 6. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 7. On the File menu, click Close, the Equivalent Annual Damage 
Reduced and Distributed for the Plan report will close (Figure 
15.45) and you will return to the Damage by Analysis Year dialog 
box (see Figure 15.1, page 15-1). 

 
 

Figure 15.5 Equivalent Annual Damage Reduced and Distributed by 
Damage Reaches Report 

 By Damage Categories - Plans 
 
To view the By Damage Categories - Plans report: 
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 1. From the Equivalent annual Damage analysis dialog box (see 
Figure 15.1, page 15-1), from the Summary Reports box, click By 
Damage Categories.  This report can be displayed either by all 
plans or by damage reaches for a selected plan.  To display this 
report by all plans, click Plans in the Summary Information box. 

 2. Click Display Report, the Equivalent Annual by Damage 
Categories and Plans report will open (Figure 15.6). 

 3. This report displays equivalent annual damage for all damage 
categories by plan. 

 4. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 5. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 6. On the File menu, click Close, the Equivalent Annual Damage by 
Damage Categories and Plans report will close (Figure 15.6) and 
you will return to the Damage by Analysis Year dialog box (see 
Figure 15.1, page 15-1). 

 
 

Figure 15.6 Equivalent Annual Damage by Damage Categories and 
Plans Reports 

 By Damage Categories – Damage Reaches 
 
To view the By Damage Categories – Damage Reaches report: 
 
 1. From the Equivalent Annual Damage Analysis dialog box (see 

Figure 15.1, page 15-1), from the Summary Reports box, click By  
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  Damage Categories.  This report can be displayed either by all 
plans or by damage reaches for a selected plan.  To display this 
report by damage reaches, click Damage Reaches in the Summary 
Information box. 

 2. The Report Information box on the Equivalent Annual Damage 
Analysis dialog box (see Figure 15.1, page 15-1) becomes active.  
The By Damage Categories – Damage Reaches report is viewed 
by plan; therefore, you need to select the appropriate plan from the 
Plan Name list in the Report Information box. 

 3. Click Display Report, the Equivalent Annual Damage by 
Damage Categories and Damage Reaches for the Plan report 
will open (Figure 15.7). 

 4. This report displays equivalent annual damage for all damage 
categories by damage reach for the selected plan. 

 5. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 6. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 7. On the File menu, click Close, the Equivalent Annual Damage by 
Damage Categories and Damage Reaches for the Plan report 
will close (Figure 15.7) and you will return to the Damage by 
Analysis Year dialog box (see Figure 15.1, page 15-1). 

 
 

Figure 15.7 Equivalent Annual Damage by Damage Categories and 
Damage Reaches Report 

15.2 Project Performance Reports 
 
The project performance reports display information about the 
hydrologic/hydraulic performance of a plan.  There are three types of  
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reports:  1) a list of target stages by damage reach and analysis year for a 
selected plan, 2) project performance by damage reach for a selected plan 
and year, and, 3) project performance by plan and damage reach for a 
selected analysis year. 
 
To access the project performance reports: 
 
 1. From the FDA main window (see Chapter 2, Section 2.1, Figure 

2.1, page 2-2), on the Evaluation menu, point to Results, click 
Project Performance. 

 2. The Project Performance dialog box will open (Figure 15.8). 

 3. From this dialog box, you will access the three different types of 
reports that make up the results for project performance.  All three 
reports contain some of the same information, below are definitions 
of some the items being reported: 

 Target Stage – For reaches without levees, it is the stage 
typically associated with the start of significant damage for 
the without-project conditions.  In FDA, the criterion for 
calculating the stage is specified under from the Evaluation 
of Plans by Analysis Year dialog box (see Chapter 13, 
Section 13.2, pages 13-3 thru 13-5).  To ensure consistency 
with various damage reaches, the stage is determined as the 
stage associated with the percent of residual damage of a 
specific exceedance probability event.  By default, the 
criterion is set to 5% of the total damage for the 1% event.  
For levees or floodwalls without geotechnical failure, the top 
of the project (levee) is the target stage.  For levees with 
geotechnical failure, there is no single value for the target 
stage and project performance is computed based on the joint 
probability of annual exceedance and probability of 
geotechnical failure. 

 

Figure 15.8  Project Performance Dialog Box 
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 Target Stage Annual Exceedance Probability - The median 
and expected annual exceedance probabilities associated with 
the target stage.  The median value is computed from your 
input functions. It uses either 1) the discharge-probability and 
stage-discharge functions, or 2) the stage-probability 
function.  The expected value is computed from the results of 
the Monte Carlo simulation. 

 
 Long-Term Risk - The probability of the target stage being 

exceeded in a 10-, 30-, and 50- year period. 
 
 Conditional Non-Exceedance Probability by Events - The 

chance of containing the specific .10, .04, .02, .01, .004, and 
.002 exceedance probability event within the target stage, 
should that event occur. 

 
 

15.2.1 Target Stages by Damage Reach 
 
To view the Target Stages by Damage Reach report: 
 
 1. From the Project Performance dialog box (see Figure 15.8, page 

15-8), click Target Stages by Damage Reach. 
 2. The Report Information box on the Project Performance dialog 

box (see Figure 15.8, page 15-8) becomes active.  The Target 
Stages by Damage Reach report is viewed by plan; therefore, you 
need to select the appropriate plan from the Plan Name list in the 
Report Information box. 

 3. Click Display Report, the Project Performance Target Stages by 
Damage Reaches for the Plan report will open (Figure 15.9). 

Figure 15.9 Project Performance Target Stages by Damage Reaches 
Report 
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 4. A sting of asterisks (*****) indicates that the computations for a 

plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 5. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 6. On the File menu, click Close, the Project Performance Target 
Stages by Damage Reaches for the Plan report will close (see 
Figure 15.9, page 15-19) and you will return to the Project 
Performance dialog box (see Figure 15.8, page 15-8). 

 
 

15.2.2 Damage Reach 
 
To view the Damage Reach report: 
 
 1. From the Project Performance dialog box (see Figure 15.8, page 

15-8), click Damage Reach. 
 2. The Report Information box on the Project Performance dialog 

box (see Figure 15.8, page 15-8) becomes active.  The Damage 
Reach report is viewed by plan and analysis year.  Therefore, you 
need to select the appropriate plan from the Plan Name list, and 
you need to select the appropriate analysis year from the Analysis 
Year list in the Report Information box. 

 3. Click Display Report, the Project Performance by Damage 
Reaches for the Plan report will open (Figure 15.10). 

 4. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

Figure 15.10  Project Performance by Damage Reaches Report 
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 5. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

 6. On the File menu, click Close, the Project Performance by 
Damage Reaches for the Plan report will close (see Figure 15.10, 
page 15-10) and you will return to the Project Performance dialog 
box (see Figure 15.8, page 15-8). 

 
 

15.2.3 Plan & Damage Reach 
 
To view the Plan and Damage Reach report: 
 
 1. From the Project Performance dialog box (see Figure 15.8, page 

15-8), click Plan + Damage Reach. 
 2. The Report Information box on the Project Performance dialog 

box (see Figure 15.8, page 15-8) becomes active.  The Damage 
Reach report is viewed by analysis year; therefore, you need to 
select the appropriate analysis year from the Analysis Year list in 
the Report Information box. 

 3. Click Display Report, the Project Performance by Plans and 
Damage Reaches by Analysis Year report will open (Figure 
15.11). 

 4. A sting of asterisks (*****) indicates that the computations for a 
plan have not been completed.  A plus-sign (+) indicates that 
something has changed in the data set for that particular plan and 
the computation needs to be redone. 

 5. To print the report, on the File menu, click Print, the Print dialog 
box will open (see Figure 15.3, page 15-3).  Be sure the appropriate 
printer has been selected, and click OK.  The Print dialog box will 
close and the report will print. 

Figure 15.11  Project Performance by Plans and Damage Reaches Report
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 6. On the File menu, click Close, the Project Performance by Plans 
and Damage Reaches by Analysis Year report will close (see 
Figure 15.11, page 15-11) and you will return to the Project 
Performance dialog box (see Figure 15.8, page 15-8). 

 
 

15.3 Additional Reports not Available from HEC-FDA 
 
When you evaluate plans by analysis years or view evaluation results, 
FDA writes output to several files which are accessed from outside of 
FDA.  The warning message file Fda_WarningMsg.out is accessed from 
the FDA and is described in Chapter 14 (Section 14.1.3, page 14-5).  
Other files are accessed outside of FDA and include a trace file 
(Fda_EadTrace.out) which is described in Chapter 16 (Section 16.2.2, 
page 16-5), an input and output HEC-DSS (Hydrologic Engineering 
Center Data Storage System) file (Fda_EadSimResults.dss, which is not 
available in Version 1.2.4), and an output report file (Fda_Results.txt). 
 
 

15.3.1 Reports Written to a ASCII Tab Delimited File 
 
When you display reports from FDA, not only does FDA display the 
reports, but FDA also writes the report to a text file - FdaResults.txt, in 
ASCII tab delimited format.  This enables you to edit the file from another 
software program for formatting and inclusion in reports.  For example, 
Figure 15.12 displays an example of the FdaResults.txt file for the report 
Expected Annual Damage by Plans and Damage Categories. 

 
All FDA output reports are written to this file except for the general 
information reports.  If the file exists when a study is opened, the file will  

Figure 15.12  FdaResults.txt File 
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 15-13 

be deleted and a new file created.  FDA will then append each report to 
this file until the study is closed.  If you want to save the reports that were 
written to this file, you need to rename or copy the file before re-opening 
the study. 
 
 

15.3.2 Input and Output Functions Written to an HEC-DSS 
File (not available in Version 1.2.4) 

 
When you evaluate plans by analysis years (compute expected annual 
damage), FDA writes several types of data to a HEC-DSS data file.  The 
data written include user input functions such as a graphical probability 
function as well as output such as the relative frequency of expected 
annual damage.  
 
HEC-DSS is a database system designed to efficiently store and retrieve 
scientific data that is typically sequential.  Such data types include, but are 
not limited to, time series data, curve data, spatial-oriented gridded data, 
textual data, and others.  The system was designed to make it easy for 
users and application programs to retrieve and store data.  To view the 
data written by FDA in tabular and graphical format, you can use the HEC 
Data Storage System Visual Utility Engine (HEC-DSSVue) which is 
available from HEC’s website.  
 
For FDA, the HEC-DSS file contains records which contain a function 
with one or more curves.  The record of data is accessed by selecting a 
pathname that uniquely defines the record.  The pathname contains six 
pathname parts each separated by a slash. T he six pathname parts are 
labeled as parts A through F.  For the purposes of FDA, the following 
table (Table 15.1) describes the conventions used: 
 

Table 15.1 
HEC-FDA DSS Record Pathname Parts 

 
Part Description 

A Stream name (e.g. S FORK BEAR) 
B Damage reach name (e.g. SF-8) 
C Function parameters (e.g. FLOW-ELEV, PROB-ELEV) 
D Function parameter qualifiers (e.g. INPUT) 
E Analysis year (e.g. 2009) 
F Plan name (e.g. PLAN 1) 

 
The following example pathname references a stage-aggregated damage 
function for apartments in reach SF-8 for Plan 1: 
 

/S FORK BEAR/SF-8/ELEVATION-DAMAGE/INPUT (APT)/2009/PLAN 1/ 
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By HEC-DSS convention, functions such as a graphical discharge-
probability curve are stored using the paired data convention consisting of 
x and y coordinates that define a curve.  For plotting purposes, the two 
parameters in pathname Part C (if recognized as one of the standard 
parameters) are used to label the axes. Otherwise, the parameter units are 
used as a label.  The following table describes the data that FDA stores in 
the HEC-DSS data file. 
 

Table 15.2 
HEC-FDA Data Stored in an HEC-DSS File 

 
Part C Part D Description 

AEP-PROB_EXCEED  The probability that a given expected annual 
exceedance probability is exceeded. The 
expected annual exceedance is on the X axis 
and the probability of exceedance is on the Y 
axis. 

AEP-RELATIVE_FREQ  The relative probability of annual exceedance 
probability. The annual exceedance is on the 
X axis and the relative probability is on the Y 
axis. 

BLANK-EAD BY CATEGORY  Expected annual damage by damage 
category. (“BLANK” is a place holder since 
this is not true paired data). 

EAD-PROB_EXCEED  The probability that a given expected annual 
damage (EAD) is exceeded. The EAD is on 
the X axis and the probability of exceedance 
is on the Y axis. 

EAD-RELATIVE_FREQ  The relative probability of EAD. The EAD is 
on the X axis and the relative probability is 
on the Y axis. 

ELEVATION-DAMAGE INPUT(category) Stage-Aggregated damage for a given 
damage category as computed by the stage-
damage calculations or entered by the user. 

FLOW-ELEV INPUT The stage-discharge rating curve entered by 
the user. 

PROB-DAMAGE INPUT_EADOLD The probability-total damage derived from 
the input probability, rating, and stage-
damage functions. This contains additional 
coordinates for computational purposes. 

PROB-ELEV INPUT_EADOLD The probability-stage curve derived either 
from the  input discharge-probability and 
stage-discharge or the input stage-probability 
curves. This contains additional coordinates 
for computational  purposes. 

PROB-FLOW INPUT_EADOLD The probability-discharge curve derived from 
the input probability-discharge curve (either 
graphical or Log Pearson Type III). For the 
graphical curve, this contains additional 
coordinates for computational purposes. 

PROB-FLOW INPUT_GRAPHICAL The user input graphical discharge-
probability function. Flow is in CFS. 

PROB-LOG FLOW INPUT_EADOLD The probability-log discharge curve derived 
from the input probability-discharge curve 
(either graphical or Log Pearson Type III). 
This contains additional coordinates for 
computational purposes. Flow is in logarithm 
base 10. 

PROB-LOG FLOW INPUT_GRAPHICAL The user input graphical probability-log 
discharge function. Flow is in logarithm base 
10. 

PROB-STAGE_EVENT_DIST  The computed probability of exceeding a 
target stage for the six events (10%, 4%, 2%, 
1%, .4%, and .2%). 
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Figure 5.13 provides an example of graphically displaying FDA results 
written to an HEC-DSS file through HEC-DSSVue.  Figure 5.13 displays 
the probability of exceeding a given expected annual damage for the 
without condition plus three plans for reach SF-9 and year 2009.  Since 

DSSVUE does not recognize the parameters "EAD" and 
"PROB_EXCEED" in Part C of the pathname, it labels the axes with the 
units "$1,000" and "PROB".  You can change the labels to those shown by 
editing the plot properties or applying a template. 

Figure 15.13  Example Probability of Exceeding a Given EAD 

 
Figure 15.14 (page 15-16) provides another example of graphically 
display FDA results from an HEC-DSS file.  Figure 5.14 (page 15-16) 
displays derived input probability-stage curves for the without condition 
and Plan 1. They were derived from the input discharge-probability and 
stage-discharge functions. 
 
Figure 15.15 (page 15-16) displays derived input probability-damage 
curves for the without condition and Plan 1. They were derived from the 
input discharge-probability, stage-discharge, and stage-damage functions. 
They represent total damage from all damage categories. As was done for 
Figure 15.13, you will have to change the default axis labels by editing the 
plot properties or applying a template. 
 

 15-15 
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Figure 15.14  Example Probability-Stage Curves Derived from Input Data 
 

Figure 15.15 Example Probability-Total Damage 
Curves Derived from Input Data

Figure 15.15  Example Probability-Total Damage Curves Derived from 
Input Data 
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CHAPTER 16  
 
 

Troubleshooting 
 
You may encounter errors when entering data or doing calculations.  In 
HEC-FDA, there are two major calculations, stage-aggregated damage, 
and expected annual damage (EAD).  Both utilize Monte Carlo simulation 
to compute mean values.  This chapter describes error messages and 
recommends ways to diagnose problems when entering data in FDA, or 
calculating expected annual damage and equivalent annual damage.  
Appendix E recommends ways to diagnose problems in the stage-
aggregated damage calculations and in importing data.  Warning and error 
messages can be generated by the GUI, the FDA database code, the 
Codebase database library, and the calculation software.  The messages 
may be displayed in a GUI dialog or they may be written to an output text 
file.  
 
Contents 
 
 ● Error Messages 
 ● Diagnosing Problems 
 
 

16.1 Error Messages 
 
FDA displays many of the warning and error messages to your screen in 
an error dialog box.  Other messages are written to text files including the 
following files that are stored in the study directory:  
Fda_WarningMsg.out and Fda_EadTrace.out.  You can display the file 
Fda_WarningMsg.out from FDA, see Chapter 14, Section 14.1.3 (page 
14-5) for further details.  To view the file Fda_EadTrace.out, you must do 
so outside of FDA using WordPad or a similar program.  This file contains 
trace output in addition to any warning or error messages. 
 
 

16.1.1 General Error Messages 
 
When the program cannot complete a specific task, an error message will 
typically be displayed in a message window.  An example is specification 
of a stage-discharge or stage-damage function where the stage, discharge, 
and/or damage values are not monotonically increasing, FDA will display 
Error 59.  A list of error messages corresponding to error message are 
listed in Table 16.1. 
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Table 16.1 
HEC-FDA Error Messages 

 
Number Error Message 

1 In searching a file, the program attempted to move to a nonexistent record. 
2 An index value is bad. - SD code, 
3 The base module cannot be changed or deleted. 
4 The base plan cannot be changed or deleted. 
5 The last module assignment for a given plan and year cannot be deleted. 

6 

The FORTRAN calculation routines have detected an error. There are several sources of 
information that more clearly explain the problem including: 1) an information dialog box 
displayed from the GUI, 2) an error message written to the warning message log (file 
Fda_WarningMsg.out in the study subdirectory), or 3) an error message in the EAD trace 
output file (file Fda_EadTrace.out). 

7 All damage functions used in a given calculation must have the same type. 
8 A duplicate object name has been encountered. 
9 An enumeration is out of range. - SD code, 

10 While creating or opening a file, a field could not be mapped. 
11 File locked. 
12 A file could not be created. 
13 File error. 
14 Database integrity error - an object was referenced which does not exist. 
15 A file could not be opened. 
16 Filter violation.  A file is positioned on a record which should be filtered out. 

17 A frequency function was found which is not valid.  Must be analytical or graphical, 
stage/discharge or stage/frequency. 

18 Global error is being set for a stage/discharge function which uses coordinate errors. 
19 Coordinate errors are being set for a stage/discharge function which uses global errors. 
20 A file index is being set to a value which is not valid for the file type. 
21 Unless this is a very long term study, there is a bad value in the year list. 
22 The studies cannot be merged.  The configuration files are not compatible. 
23 The calculation cannot be performed.  One of the input functions is incomplete or invalid. 

24 This calculation cannot be performed.  The input function set is not complete or a function 
is invalid. 

25 A data record is not complete. 
26 A code function has been called with an invalid argument. 
27 Invalid probability distribution or distribution type, 

28 WSP data must include the two-year, ten-year, and hundred-year values (.5, .1, and .01 
exceedances). 

29 A character string is too long for the field length. 
30 Cannot get the record.  File is empty or positioned after end of file. 

31 
 
Filter value does not exist (e.g. looking for reaches on a nonexistent stream). 

32 A function was called for a data object for which it is not appropriate. 
33 A reach index station was found which is not in the reach. 
34 Invalid directory or pathname. 
35 A file contains an invalid record. 
36 Frequency function transform flow data is invalid. 
37 An invalid water surface profile has been found. 

38 Calculations have been marked invalid due to more recent data entry.  Recalculation is 
required. 

39 Not enough memory. 
40 A calculation record is missing.  Run the calculations again. 

41 Cannot create analytical frequency function.  There is no discharge data in the water surface 
profile. 
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Table 16.1 (continued) 
HEC-FDA Error Messages 

 
Number Error Message 

42 Search failed.  An object which is being searched for does not exist. 
43 There is no study file open. 
44 A damage category is being referenced which is not in the category list. 
45 A damage function is being referenced which is not in the depth/damage function list. 
46 A necessary file does not exist. 
47 The function which is being assigned does not exist. 
48 A structure inventory module is being referenced which is not in the module list. 
49 A plan is being referenced which is not in the plan list. 
50 A damage reach is being referenced which is not in the reach list. 
51 A stream is being referenced which is not in the stream list. 
52 There is no uncertainty specified for this function, so there are no error limit curves. 
53 An object has not been initialized.  - SD code, 

54 The record is assigned to another plan/year/stream/etc.  Use global replace, or change the 
name. 

55 The record cannot be deleted - it is referenced from another file. 
56 The index stack has become unbalanced.  Please notify HEC. 
57 A stage/frequency function must be graphical. 
58 Reference has been made to a structure error distribution which does not exist. 
59 Invalid function.  Values not monotonically increasing or decreasing. 
60 There is an existing record.  Call replace. 

61 Damage reduced reports require that the without condition be defined.  Run calculations for 
without condition. 

62 This version of the program does not recognize the database version named in the .sty file. 
 
 

16.1.2 Codebase Error Messages 
 
When running the program, if you encounter an error message titled 
"CODEBASE ERROR", you should immediately close the study.  This 
indicates that there is a major problem with the database.  For some 
Codebase errors, the program will display a dialog indicating that the 
program will stop.  For other Codebase errors, the program will continue 
as if nothing was wrong but it will no longer properly access the database 
files and you must close the study.  The primary sources of Codebase 
errors are missing database files or corrupt files.  
 
If a file is missing, the error message will display the name of the missing 
file (there could also be additional files missing).  First, verify that you are 
opening the correct study file (file extension .sty) and that it is located in 
the parent subdirectory of your FDA database.  Next, check the 
subdirectory containing the study database files and verify that all the files 
are there.  The easiest way to do this is to create a new study and compare 
the filenames in the new study with those in your current study.  
Typically, this problem occurs when you copy the study database files 
from one subdirectory to another and don’t select all of the files or you  
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inadvertently delete one or more files.  If a file is missing, you will need to 
copy it from its original location or restore the file from backup.  
 
If a file is corrupt, you will have to restore a valid copy of the file by 
restoring the study from a backup.  If, for some reason, you do not have a 
valid copy of the file, you can replace some files with a copy of the file 
that has no data in it.  This works well if the corrupt file contains 
calculation results such as stage-aggregated damage or expected annual 
damage.  You will lose your previously calculated results, but you can 
recalculate them and continue using your current study.  It will not work if 
the corrupt file contains your input data such as plans, years, discharge-
probability functions, etc.  To replace the file using a copy that has no data 
in it, open a new study and do not enter any data except the study name 
and price index year.  Exit the program and then copy the appropriate files 
from this new study into your current study that has the corrupt file(s).  
The following files contain results and can be replaced with a copy that 
has no data.  You must copy the entire group of files (e.g. all the files for 
stage-aggregated damage results must be copied, not just one of the files). 
 
 ● Stage-aggregated damage files: AGDFDATA.DBF, 

AGDFDATA.DBT, AGDFDATA.MDX, AGDFLOOK.DBF, 
AGDFLOOK.MDX 

 ● Expected and equivalent annual damage and project performance 
files: EADDATA.DBF, EADDATA.DBT, EADDATA.MDX, 
EADLOOK.DBF, EADLOOK.MDX, EQUIV.DBF, EQUIV.DBT, 
EQUIV.MDX, EQUIVCAT.DBF, EQUIVCAT.MDX, 
EQUIVCLC.DBF, EQUIVCLC.DBT, EQUIVCLC.MDX 

 
 

16.2 Diagnosing Problems 
 
There are three basic methods of diagnosing problems. The following are 
sources of information for determining problems: 
 
 ● Missing or Out-of-date Computation Results 
 ● Trace Output 
 
 

16.2.1 Missing or Out-of-Date Computation Results 
 
It is always important to check the Study Status Report (see Chapter 13, 
Section 13.1, page 13-1); the report indicates whether the functions 
required for the computation of expected annual damage are complete for 
all reaches in each plan.  As indicated in the legend, a single asterisk (*) 
means that the specific function or functions are missing or incomplete for 
one or more reaches.  
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The function assignment reports (see Chapter 12, Section 12.8) should be 
checked to see which reach has a missing or incomplete function and the 
problem corrected.  Five asterisks (*****) appearing in the function name 
and description columns in the function assignment reports indicate that 
the function is missing or incomplete for that reach.  
 
When data has changed since the last time computations were made the 
results of that computation become out-of-date.  You can check for this 
condition by checking the Data Management Summary reports for the 
individual analyses (see Chapter 14, Section 14.1.1, page 14-2; and 
Chapter 15, Section 15.1.1, page 15-2).  The FDA program allows you to 
view previous results that are out-of-date but marks the results 
accordingly.  Out-of-date results are indicated by a + in front of the reach, 
plan, or function name and may appear in the function assignment report 
or in any of the result reports. 
 
 

16.2.2 Trace Output 
 
A trace text file (Fda_EadTrace.out) is created whenever a study is 
opened.  If the file already exists, it is deleted and new file created.  FDA 
will then append trace information to this file until the study is closed.  
You cannot view this file from FDA but you can view it from outside the 
FDA program. For the most part, it contains trace information that is 
useful only to program support people.  Occasionally, it will contain an 
error message that cannot be displayed in other places.  Figure 16.1 
display an example of the trace output file. 

 

Open Trace file: D:\WpDoc\NexGen FDA\Documentation\UsersManual\Manual 
2005\Data\Data 2005\Distrib Prev\Test Study\Fda_EadTrace.out 
 Date: 08SEP05    10:22:58 
    -----DSS---ZOPEN:  Existing File Opened,  File: D:\WpDoc\NexGen 
FDA\Documentation\UsersManual\Manual 2005\Data\Data 2005\Distrib Prev\Test 
Study\Fda_EadSimResults.dss 
                       Unit: 71;  DSS Versions - Software: 6-MY, File: 6-MY 
 
***********************************************************************************
***************** 
 
***********************************************************************************
***************** 
 Compute EAD on 08SEP05  14:08:58 for: 
     Plan          Plan 1                                                           
     Year          2009     
     Stream        S Fork Bear                                                      
     Reach         SF-8                                                             
 
***********************************************************************************
***************** 
 
***********************************************************************************
***************** 
 -----DSS---ZWRITE Unit  71; Vers.    2:  /S FORK BEAR/SF-8/PROB-
FLOW/INPUT_GRAPHICAL/2009/PLAN 1/ 
 -----DSS---ZWRITE Unit  71; Vers.    2:  /S FORK BEAR/SF-8/PROB-LOG 
FLOW/INPUT GRAPHICAL/2009/PLAN 1/

Figure 16.1  Trace Output File 

 16-5 
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Appendix A  
 
 
 

References 
 
 
 

A.1 Required Publications 
 
These documents define policy and basic methods directly related to 
hydrologic engineering for flood-damage reduction planning by the Corps 
of Engineers.  They are cited in the text and in this list by number only.  
All are promulgated by the Headquarters, U.S. Army Corps of Engineers 
(HQUSACE), Washington, DC. 
 
EM 1110 2 1415 
Engineering and Design:  Hydrologic Frequency Analysis 
 
EM 1110 2 1416 
Engineering and Design:  River Hydraulics 
 
EM 1110 2 1417 
Engineering and Design:  Flood-runoff Analysis 
 
EM 1110 2 1419 
Hydrologic Engineering Requirements for Flood Damage Reduction 
Studies 
 
EM 1110-2-1619 
Engineering and Design:  Risk-based Analysis for Flood Damage 
Reduction Studies 
 
EM 1110 2 9039 
Engineering and Design:  Hydrologic Engineering Requirements for 
Flood-damage Reduction Studies 
 
ER 1105-2-100 
Guidance for Conducting Civil Works Planning Studies 
 
ER 1105-2-101 
Risk-based Analysis for Evaluation of Hydrology/Hydraulics and 
Economics in Flood Damage Reduction Studies 
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ER 1110-2-1450 
Hydrologic Frequency Estimates 
 
ETL 1110-2-547 
Introduction to Probability and Reliability Methods for Use in 
Geotechnical Information 
 
ETL 110-2-328 
Reliability Assessment of Existing Levees for Benefit Determination 
 
ETL 110-2-537 
Uncertainty Estimates for Non-Analytical Frequency Curves 
 
 

A.2 Other Publications 
 
Barkau 1992 
Barkau, Robert L., 1992.  UNET, One-Dimensional Unsteady Flow 
Through a Full Network of Open Channels, Computer Program; St. Louis, 
MO. 
 
Freeman 1996 
Freeman, Gary E., Copeland, Ronald R., and Cowan, Mark A.  1996.  
"Uncertainty in Stage-Discharge Relationships".  Proceedings, 7th IAHR 
International Symposium on Stochastic Hydraulics, Mackay, Queensland, 
Australia, IAHR.  (in publication). 
 
Interagency Advisory Committee on Water Data 1982 
Interagency Advisory Committee on Water Data.  (1982).  "Guidelines for 
Determining Flood Flow Frequency." Bulletin 17B.  US Department of the 
Interior, U.S. Geological Survey, Office of Water Data Coordination, 
Reston, VA. 
 
Morgan and Henrion 1990 
Morgan, G. and Henrion, M.  (1990).  Uncertainty, a Guide to Dealing 
with Uncertainty in Quantitative Risk and Policy Analysis.  Cambridge 
University Press, New York, NY. 
 
USACE 1977 
USACE (1977).  Information Bulletin:  Metropolitan Chester Creek Basin 
Study, Stage Ii Findings on Alternative Plans for Flood Control.  
Philadelphia District, Philadelphia, PA. 
 
USACE 1978a 
USACE (1978a).  Information Bulletin:  Metropolitan Chester Creek 
Basin Study, Completion of Flood Control Investigations.  Philadelphia 
District, Philadelphia, PA. 
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USACE 1978b 
USACE (1978b).  Water Resources Study:  Metropolitan Chester Creek 
Basin.  Philadelphia District, Philadelphia, PA. 
 
USACE 1986 
USACE (1986).  "Accuracy of Computed Water Surface Profiles." 
Research Document 26.  HEC, Davis, CA. 
 
USACE 1988 
USACE (1988).  "National Economic Development Procedures Manual - 
Urban Flood Damage." Institute for Water Resources, IWR Report 88-R-2, 
Ft. Belvoir, VA. 
 
USACE 1988a 
USACE (1988a).  "Flood Damage Analysis Package, User’s Manual."  
HEC, Davis, CA. 
 
USACE 1989 
USACE (1989).  "SID: Structure Inventory for Damage Analysis User’s 
Manual."  HEC, Davis, CA. 
 
USACE 1991 
USACE (1991).  "HEC 2:  Water Surface Profiles, User's Manual."   
CPD-2A.  HEC, Davis, CA. 
 
USACE 1992a 
USACE (1992a).  "HEC FFA:  Flood Frequency Analysis, User's 
Manual."  CPD-59.  HEC, Davis, CA. 
 
USACE 1992b 
USACE (1992b) "Guidelines for Risk and Uncertainty Analysis in Water 
Resource Planning, Volumes I and II." Institute for Water Resources, IWR 
Report 92-R-1 and IWR Report 92-R-2, Ft. Belvoir, VA. 
 
USACE 1997 
USACE 1997.  "HEC-RAS River Analysis System, User’s Manual," HEC, 
Davis, CA. 
 
USWRC 1983 
USWRC (1983).  Economic and Environmental Principles and Guidelines 
for Water and Related Land Resources Implementation Studies.  U.S. 
Government Printing Office, Washington, DC. 
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Appendix B  
 
 
 

Glossary 
 
 
Aggregated Stage-Damage Function with Uncertainty:  A composite 
median stage-damage function for a damage reach.  The function is 
developed by damage categories at the damage reach index location.  The 
stage-damage functions of individual structures are aggregated using a 
series of water surface profiles to account for the slope in the profiles 
throughout the reach.  Uncertainty, the errors in the damage estimates, 
may also be computed. 
 
Analysis Years:  Analysis years are for determining damage and project 
performance information for specific time periods, such as the base year or 
most likely future year.  The analysis years results for a plan are also used 
to perform equivalent annual damage computations.  The same analysis 
years are used for all study evaluations.  An analysis year represents a 
static time period or year that the HydEng and Economic analysis data 
represent.  Base year is the first year of the plan operation.  The “Most 
Likely Future” condition is a development projection for a specific future 
year, say twenty years out from the base year.  It usually is based on the 
projections of local future development plans. 
 
Analytical Discharge-Probability Function:  A discharge-probability 
function that is fit with an analytical (statistical) distribution.  The 
distribution is defined by statistics which are the mean, standard deviation, 
and skew for the Log Pearson Type III distribution.  The function is 
developed by site specific, hydrologic engineering analysis procedures.  A 
"synthetic" approach defined by discharges associated with the .50, .10, 
and .01 probability events yields Log Pearson Type III distribution 
statistics and frequency function that fit the 3 points specified. 
 
Annual Exceedance Probability (AEP):  The probability that flooding 
will occur in any given year considering the full range of possible annual 
floods. 
 
Bank:  Stream bank (looking downstream) where the damage reach or 
structure is located.  The delineation of the bank should consider potential 
local protection flood damage reduction measures and jurisdictional 
boundaries.  Some measures are typically implemented on only one bank, 
which include levees and walls, and various nonstructural actions.  
Channels and upstream storage projects reduce flooding for both banks.  
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There are three hardwired choices (Left, Right, Both), with Both being the 
default. 
 
Base Year:  First year the plan is implemented and operational. 
 
Beginning Damage Depth:  Optional depth in feet (meters) where 
damage begins.  Normally used in analysis of structures with basements 
where flood waters enter above basement floor.  Truncates damage 
function at below specified depth (stage). 
 
Beginning Station:  Beginning station number for downstream end of 
damage reach.  The range of allowable values is from 0.00 to 999,999.99.  
Value must be less than the Ending Station. 
 
Both Banks:  Indicator that the damage reach is delineated spatially over 
both banks of the stream.  The stream cuts through the damage reach.  
Normally used for ponding or storage area reaches. 
 
Bulletin 17B:  A U. S. Geological Survey publication entitled, 
“Guidelines for Determining Flood Flow Frequency,” by the Hydrology 
Subcommittee, Interagency Advisory Committee on Water Data, revised 
September 1981.  The publication describes procedures for developing 
discharge-frequency functions using stream flow records.  These 
procedures are recommended for all Federal agencies applications. 
 
Compute Synthetic Statistics:  The Log Pearson Type III statistics are 
computed based on the discharges associated with the .50, .10, and .01 
probabilities of an adopted probability function.  The synthetic statistics 
are based on equations given in Guidelines for Determining Flood Flow 
Frequency, Bulletin 17B, USGS, September 1981. 
 
Confidence Limit Curves:  Error limit curves about a Log Pearson Type 
III discharge-probability function developed using the non-central t 
distribution.  Confidence limit curves are used to define the discharge-
exceedance probability function's uncertainty. 
 
Content/Structure Value Ratio Survey Error:  The standard deviation 
as a percent associated with the uncertainty in estimating the content to 
structure value ratio.  For example, for a content to structure value ratio of 
fifty percent, an entered standard deviation of ten (10) percent would mean 
that the ±1 standard deviation range is 45 to 55 percent.  
 
Content to Structure Value Ratio:  The numeric value in percent that 
represents the maximum content value divided by the maximum structure 
value for a particular structure occupancy type.  Used to proportion the 
contents depth-percent damage function from the structure function. 
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Content Value:  The value of the contents associated with the structure.  
Does not include the structure (building) value.  Numeric value ranging 
from 0 to 999,999,999. 
 
Damage:  Economic loss associated with specific flood events.  Value 
may be at a structure, damage reach, or entire study area. 
 
Damage Category:  Used to consolidate large number of structures into 
specific groups of similar characteristics for analysis and reporting 
purposes.  Damage categories are defined for the study. 
 
Damage Reaches:  Damage reaches are spatial floodplain areas.  You use 
damage reaches to define consistent data for plan evaluations and to 
aggregate structure and other potential inundation damage information by 
stage of flooding.  You define a damage reach by the beginning and 
ending stations (river mile, kilometer, etc.) along the stream and extend it 
in the floodplain to include the largest flood deemed possible.  Damage 
reaches are unique to a stream for the entire study.  They are integral to 
both the hydrology and economic analyses.  You may specify a damage 
reach for the right or left bank (as looking downstream) or both.  You 
must delineate the damage reach consistent with flood damage reduction 
measures, i.e., a channel may be analyzed with a damage reach covering 
both banks, but a levee only one. 
 
Depth:  Distance of the water surface straight down to the point of 
interest.  Normally, refers to a value associated with corresponding 
damage from the depth of water. 
 
Depth-Damage Functions:  Relationship of depth of water to damage at a 
structure.  Damage is normally as a percent of the structure or content 
value.  The functions are generic for similar structures and are not tied to 
the structure location. 
 
Depth-Direct Dollar Content Damage:  Relationship of depth and direct 
(actual) content dollar damage values at the structure location. 
 
Depth-Direct Dollar Structure Damage:  Relationship of depth and 
direct (actual) structure dollar damage values at the structure location. 
 
Depth-Percent Damage:  Defines the percent of the maximum structure 
damage for a range of flood stages at a structure.  The percent-damage is 
multiplied by the structure value to get a unique depth-damage function at 
the structure. 
 
Discharge:  The volume of water passing a specific point for a given time 
interval.  For example, 2,000 cubic feet per second or 1,000 cubic meters 
per second. 
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Discharge-Exceedance Probability:  The relationship of peak discharge 
to the probability of that discharge being exceeded in any given year. 
 
Economic Analysis:  The flood damage computational part of a study 
involving specification of damage categories depth-damage functions, 
structure inventory, development of aggregated stage-damage-uncertainty 
functions and analysis of expected and equivalent annual damage. 
 
Effective Wave Height:  The vertical distance between the crest of a 
wave and the preceding wave trough. 
 
Ending Station:  Ending station number for upstream end of damage 
reach.  The range of allowable values is from 0.00 to 999,999.99.  Value 
must be greater than the Beginning Station. 
 
English Units:  Data entry and output reports are English Units and not SI 
Units.  Indicator is for labeling purposes only.  No conversions are 
performed in this program version. 
 
Equivalent Annual Damage:  The damage value associated with the 
without-or-with project condition over the analysis period (project life) 
considering changes in hydrology, hydraulics, and flood damage 
conditions over the life.  Expected annual damage is computed for each 
analysis year and discounted to present worth which is then annualized to 
obtain the equivalent annual damage value.  Rather than compute the 
expected annual damage for each year, it is computed for the base year 
and most likely future years and interpolated for subsequent years.  The 
expected annual damage for years beyond the most likely future 
conditions year is assumed equal to that year. 
 
Equivalent Record Length:  Number of years of a systematic record of 
recorded peak discharges at a stream gage.  For probability functions 
derived at ungaged locations using model or other data, the equivalent 
record length is estimated based on the overall “worth” or “quality” of the 
frequency function expressed as the number of years-of-record.  This 
parameter is important in risk-based analysis because it relates directly to 
the uncertainty of the probability function. 
 
Error Distribution:  A statistical relationship of possible outcomes that 
defines the dispersion or variation of errors about the median or "best 
estimate" of values along a function.  Error or uncertainty distributions are 
used to quantify errors probabilistically when using risk-based analysis.  
The magnitude and range of the distribution can be defined using error 
limit or confidence limit curves above and below the median curve. 
 
Error Distribution Parameters:  Statistics or other values that define 
error probability or uncertainty distributions about stage-discharge or other 
functions.  The parameters are dependent on the type of distribution.  The 
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magnitude and range of the distribution can be defined using error limit or 
confidence limit curves above and below the median curve. 
 
Error Limit Curves:  Curves above and below the median or "best 
estimate" curve that define the distribution of errors about the best 
estimate values.  Error limit curves define the uncertainty of functions and 
are developed by fitting a statistical distribution to known data or the 
results of model sensitivity analyses. 
 
Exceedance Probability Event:  The probability that a specific event will 
occur in any given year.  For example, the .01 exceedance probability 
event has one chance in a hundred or a one percent chance of occurring in 
any given year. 
 
Expected Annual Damage:  The integral of the damage-probability 
function.  In risk-based analysis it is equal to the average or mean of all 
possible values of damage determined by exhaustive Monte Carlo 
sampling of discharge-exceedance probability, stage-discharge, and stage-
damage relationships and their associated uncertainties. 
 
Expected Value:  The mean or average value.  For normal probability 
density functions the expected, median, and mode are the same. 
 
Exterior:  The "exterior" side of the levee or flood wall is the river side 
where the stage-discharge function applies. 
 
First Floor: The normal entry floor of a building. 
 
First Floor Stage:  The stage or elevation of the first floor of the 
structure.  Numeric value ranging from -300 to 30,000. 
 
First Floor Stage Uncertainty:  The error of uncertainty in the first floor 
stage estimate of a particular structure occupancy type.  Based on the 
procedures/type of surveys used to estimate the first floor stage.  A 
normal, triangular, or log normal error distribution may be used. 
 
Flood Damage Reduction:  Measures and actions taken to reduce flood 
damage.  These may include implementation of reservoirs, detention 
storage, channel, diversions, levees and floodwalls, interior systems, flood 
proofing, raising, relocation, and flood warning-preparedness actions. 
 
Flood Inundation Damage:  The damage that results to structures, 
contents, automobiles, traffic, infrastructure, etc. when flood waters covers 
or inundates them. 
 
Flood Risk:  The risk associated with being flooded.  Risk performance 
indicators used in the analysis are 1) the expected annual stage exceedance 
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probability; 2) long-term risk (a .26 probability of the .01 exceedance 
probability event occurring over a thirty year period); and 3) conditional  
probability of non-exceedance (the project has a .95 probability of 
containing the .01 exceedance probability event should it occur). 
 
Flow Transform Relationship:  A relationship that defines the outflow at 
a specific point on a stream or river based on the inflow at that point.  
These functions are used to modify the discharge during at a specific step 
in the risk-based analysis.  An example would be a regulated versus 
unregulated function for a reservoir that could be used instead of a 
regulated discharge-probability function to represent the effect of a 
reservoir. 
 
Foundation Height:  The vertical distance between the ground stage and 
first floor stage at the structure. 
 
Geotechnical Failure Analysis:  Analysis of a non-standard levee that 
has the potential to fail geo-technically before overtopping.  Geotechnical 
failure causes include seepage, piping, and stuffing.  A single relationship 
of exterior levee stage versus probability of geotechnical failure (all 
combinations) are developed external to the program and entered for 
analysis. 
 
Graphical Discharge (or Stage) Probability Function:  A graphical or 
non-analytical discharge- or stage-probability function is one drawn 
graphically by an eye-fit curve.  The function is assumed not fitted by an 
analytical distribution.  For HEC-FDA, graphical functions should use 
Wiebull's plotting positions (not median) since the normal distribution is 
used to represent expected values  in the order statistics approach to define 
the error bands. 
 
Ground Stage:  The stage or elevation of the ground at the structure.  
Numeric value ranging from -300 to 30,000. 
 
HEC-2:  The Hydrologic Engineering Center's Water Surface Profile 
Computations computer program.  The program output may be designed 
to enable ready import of water surface profiles data sets into the HEC-
FDA program. 
 
HEC-RAS:  The Hydrologic Engineering Center’s River Analysis System 
computer program for computing water surface profiles for a series of 
flood events.  The program output may be designed to enable ready import 
of water surface profile data sets into the HEC-FDA program. 
 
HEC-SID:  The Hydrologic Engineering Center's Structure Inventory for 
Damage computer program.  The structure inventory and depth-percent 
damage functions may be imported into the HEC-FDA program. 
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Historic Events:  Observed and sometimes recorded flood events such as 
the 1973 Flood or 1993 Flood. 
 
Hydrologic Engineering:  Hydrology and hydraulic technical studies 
necessary for performing flood damage reduction studies. 
 
Hydrology & Hydraulics:  Hydrology involves the estimation of the 
amount and shape of the runoff response throughout the study area.  It also 
includes the frequency of the events.  Hydraulics involves analysis of 
stream water surface profiles, flood inundation boundaries, and other 
technical studies of stream flow characteristics. 
 
Hypothetical Probability Events:  A series of hydrographs derived from 
rainfall-runoff analysis using hypothetical frequency based rainfall 
patterns.  Rainfall values are normally derived from National Weather 
Service Publications e.g., Technical Papers TP 40 and TP 49. 
 
Image:  Picture stored in digital format for display.  Normally used for 
important structures. 
 
Index Location Station:  A stream station location within a damage reach 
used to specify discharge-probability, stage-discharge, and stage-damage 
functions with uncertainty data for plan evaluations for that damage reach.  
Also, the index location station (corresponding stream station) is used for 
aggregation of stage-damage functions with uncertainty by damage 
category under economic analysis.  The index location station is defined 
between the beginning and ending station values and normally where data 
is deemed most reliable, such as a streamgage location.  The range of 
allowable values is from 0.00 to 999,999.99.  Value must be greater than 
the Beginning Station and less than or equal to the Ending Station. 
 
Interior:  The “interior” side of the levee or flood wall is the floodplain or 
protected side where the stage-damage function applies. 
 
Invert:  Stage associated with zero discharge or bottom of channel.  The 
range of allowable values is from -300.00 to 30,000.00. 
 
Left Bank:  Indicates that the damage reach is only along the left bank of 
the stream.  The left bank is defined looking downstream or with the 
current of the stream. 
 
Levee Overtopping:  Analysis of levee overtopping. 
 
Log Normal Distribution:  A two-parameter probability distribution 
defined by the mean and standard deviation.  A non-symmetrical 
distribution applicable to many kinds of data sets where the majority 
(more than half) of values are less than the mean but values greater than 
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the mean can be extreme, such as with stream flow data.  The distribution 
is truncated at three standard deviations. 
 
Log Pearson Type III Distribution:  Analytical discharge-probability 
functions can be defined (fit) with a statistical distribution such as Log 
Pearson Type III.  The distribution has statistical parameters that define 
the moments of the data about the analytical curve.  For a Log Pearson 
Type III distribution, these statistical parameters are mean (first moment), 
standard deviation (second moment), and weighted skew (third moment).  
Also, an there is an additional parameter, equivalent record length. 
 
Mean:  The average value of a set of numbers, such as the annual peak 
discharges that have occurred over a period of time.  The first moment 
statistic of a Log Pearson Type III analytical discharge-probability 
function, representing the average of the logarithms of peak discharge 
values. 
 
Median:  Value where there is a .5 probability that the actual value is less 
than that value.  The middle value of an ordered list. 
 
Mode:  The most frequently occurring value in a data set. 
 
Monetary Units:  Monetary units used for all study data and output 
reports.  There are three hardwired choices ($'s, $1,000's, and 
$1,000,000's), with $1,000's being the default.  Monetary units are used 
only as labels. 
 
Most Likely Future:  The most likely future condition development 
projection for a specific future year.  Used in equivalent analysis of project 
over it's life.  Normally 25-30 years out from Base Year.  Must be greater 
than Base Year. 
 
Nonstructural:  Nonstructural measures include raising, relocating, flood 
proofing, and regulatory and emergency actions associated with structures 
and damageable property that modify the existing and/or future damage 
susceptibility. 
 
Normal Distribution:  A two-parameter probability distribution defined 
by the mean and standard deviation.  A symmetrical “bell shaped” curve 
applicable to many kinds of data sets where values are equally likely to be 
greater than or less than the mean.  Also called a Gaussian distribution.  
The distribution is truncated at three standard deviations. 
 
Ordered Events:  Ranked events or plotting positions that define a 
graphical discharge- or stage-probability function.  Ordered events are 
used to determine the uncertainty about the discharge- or stage-probability 
function using order statistics.  The Wiebull's plotting positions, which 
represent expected values, should be used. 
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Order Statistics:  Statistical procedure for defining the sample errors of 
events that define a graphical frequency function.  Order statistics are used 
to define the uncertainty (error limit curves) about a graphical frequency 
function defined by Weibull plotting positions (ordered events) for a 
specified equivalent record length.  A normal distribution is used to define 
the errors. 
 
Plan Evaluation:  The assessment of economic and plan performance to 
determine the impact of one or more plans versus the without-project 
condition.  Results may be viewed by specific analysis years or as 
equivalent annual values for the project life. 
 
Plan Formulation:  The development and evaluation of one or more 
measures and actions into a plan designed to reduce flood damage for one 
or more damage reaches. 
 
Plan Performance:  A measure of the hydrologic and/or economic 
efficiency of a flood damage reduction plan.  Performance is measured in 
terms of risk of flooding in a year and over a specified number of years 
and an expected annual flood damage.  Risk-based analysis is used to 
determine plan performance. 
 
Plans:  A set of one or more flood damage reduction measures or actions 
designed to operate over a period of time (project life).  The plan is 
inclusive of the entire study area although it may have a flood damage 
reduction measure for a single damage reach. 
 
Ponding Area:  Storage area usually a lake or pond normally requiring 
stage-frequency functions instead of discharge-frequency functions for 
analyses. 
 
Price Index:  The economic index value associated with the present value.  
Used to globally update the economic (flood damage) values over the base 
price index value.  Numeric, up to 10 digit fixed point value.  If blank, the 
base price index is used and no adjustments are made to the economic 
data. 
 
Price Year:  The price year associated with present updated economic 
(flood damage) values over the base price index.  Numeric four digit 
value.  If blank, the base price year is used.  Global price indices may be 
overwritten for specific damage categories on the Economics/Damage 
Categories data entry screen. 
 
Probability:  The values ranging from zero to one of the number of 
outcomes in an exhaustive set of equally likely outcomes that produce the 
event divided by the total number of outcomes (Frequency divided by 
100). 
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Probability Function:  A discharge- or stage-exceedance probability 
relationship for a reach developed by traditional, site specific, hydrologic 
engineering analysis procedures. 
 
Probability Function Statistics:  Reports the statistics entered or 
computed for an exceedance probability function.  For the Log Person 
Type III distribution, the statistical parameters are mean log (first 
moment), standard deviation (second moment), skew (third moment), and 
equivalent record length.  For synthetic or parameter fitting (Compute 
Synthetic Statistics), the computed statistical parameters are mean, 
standard deviation, skew, and equivalent record length.  Also, the mean 
discharge is computed and is equal to the anti-log of the mean log.  The 
statistics reported for a non-analytical probability function is the 
equivalent record length. 
 
Probability Function Type:  Probability function type is either graphical 
(discharge- or stage-probability).  An analytical discharge-exceedance 
probability function is one that can be fit with an analytical (statistical) 
distribution such as Log Person Type III.  A graphical discharge- or stage- 
exceedance probability function is one that is best fit by a graphical, eye-
fit curve. 
 
Probability Ordinates:  The discharge or stage values corresponding to 
specific probabilities from a discharge- or stage-exceedance probability 
function. 
 
Project Life:  The period of time the plan is assumed in place and 
operational.  Normally fifty years.  The base year is the first year of the 
plan being operational. 
 
Residual Risk:  Flood risk that remains if a proposed flood damage 
reduction project is implemented.  Includes the consequence of capacity 
exceedance. 
 
Right Bank:  Indicator that a damage reach is only along the right bank of 
the stream.  The right bank is defined looking downstream or with the 
current of the stream. 
 
Risk:  The probability that an area will be flooded resulting in undesirable 
consequences. 
 
Risk Analysis:  Approach to evaluation and decision making that 
explicitly, and to the extent practical, analytically, incorporates 
consideration of risk and uncertainty. 
 
SI Units:  Metric units such as meters (stage, heights, etc.) and kilometers 
(distances). 
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Skew:  A statistic used as a measure of the dispersion of the data about the 
mean equal to the number of values times the sum of the cubes of the 
deviations from the mean divided by the number of values minus one, 
times the number of values times two, times the standard deviation cubed.   
The third moment statistic of a Log Person Type III distribution, 
calculated using the mean logarithm, the standard deviation of the logs, 
and the logarithms or peak discharge values. 
 
Stage:  The vertical distance in feet (meters) above or below a local or 
national datum (N.G.V.D. for elevations). 
 
Stage Associated with the Median One-Percent Chance Flood 
Discharge:  The stage where the discharge, taken from the stage-
discharge curve, has a probability (percent chance occurrence), taken from 
the discharge-probability curve, of one-percent. 
 
Stage-Damage:  The relationship of damage to a range of flood stages at a 
structure or the aggregated values of the structure damage by damage 
categories for a range of stages at the damage reach index location station. 
 
Stage-Damage Functions with Uncertainty:  Stage-damage functions 
with uncertainty are computed at each structure and aggregated by damage 
category to damage reach index locations.  Stage is elevation or locally 
referenced stage associated with the structure and index location.  Damage 
is the median estimate of structure, content, or other inundation reduction 
damage associated with the stage of flood waters at the location.  
Uncertainty in the stage-damage function is due to errors in estimating the 
depth-damage function, first floor stage, structure value, and content to 
structure value ratio. 
 
Stage-Damage Uncertainty:  Error (uncertainty) in estimating the stage-
damage values.  The only  error probability density function available is 
normal. 
 
Stage-Direct Dollar Content Damage:  Relationship of depth and direct 
(actual) content damage values at the structure location. 
 
Stage-Direct Dollar Structure Damage:  Relationship of depth and 
direct (actual) structure dollar damage values at the structure location. 
 
Stage-Discharge:  The relationship of stage to a range of discharge values 
at a specific location. 
 
Stage-Discharge Function:  A graphical relationship that yields the stage 
for a given discharge at a specific location on a stream or river.  Referred 
to as a rating function or curve.  These relationships are usually developed 
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by computing water surface profiles for several discharges and plotting the 
stages vs. discharge relationship at a specific stream location. 
 
Stage-Discharge Functions with Uncertainty:  Relationship of the water 
surface stage and discharge.  Uncertainty is the distribution of the errors of 
stage estimates about a specific discharge.  The error probability density 
functions available are normal, log normal, and triangular. 
 
Stage-Probability Water Surface Profiles:  Water surface profiles are 
stage based.  The stage values are required for each station and water 
surface profile analyzed. 
 
Stage-Probability Functions with Uncertainty:  Relationship of water 
surface stage and exceedance probability of occurrence.  Uncertainty is the 
distribution of the errors of stage estimates about a specific ordinate.  The 
ordered statistics approach is used to define the errors of the graphical 
relationship. 
 
Standard Deviation:  A statistic used as a measure of the variation in a 
distribution, equal to the square root of the sum of the squares of the 
deviations from the arithmetic mean divided by the number of values 
minus one.  The second moment statistic of a Log Pearson Type III 
analytical discharge-probability function calculated using the mean 
logarithm and the logarithms of peak discharge values. 
 
Steady Flow:  State where depth in flow is open channel does not change 
during the time interval under consideration, (Chow, Open Channel 
Hydraulics, 1959). 
 
Still Water Stage:  Stage that the water surface assumes if all wave action 
is absent. 
 
Storage Area:  Storage area is a water body such as a lake or pond that 
normally requires a stage-frequency instead of discharge-frequency 
function analysis. 
 
Streams:  Streams are defined for the study and are therefore common for 
all plans and analyses.  They include one or more damage reaches.  They 
are used to aggregate data entry and output report information by the 
stream title.  Streams are generalized to include rivers, creeks, bayous, 
channels, ditches, canals and even ponding areas.  One or more streams 
may be specified as part of the study area.  Several hydraulic routing 
reaches along the stream are normally combined by stream name for 
analysis and reporting purposes.  Water surface profile data are entered by 
streams. 
 
Stream Station:  Study adopted stations along the stream normally 
denoted as miles (kilometers) above the mouth of the stream.  Must be 
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consistent between damage reach boundaries, damage reach index 
location, water surface profiles, and structure location.  The range of 
allowable values is from  9,999,999.99 to 9,999,999.99. 
 
Structure Coordinates:  The x, y spatial coordinates of the location of 
the structure. 
 
Structure Occupancy Type:  The name given to a similar set of 
structures that is used to define the depth-percent damage function and 
first floor, structure value, and content/structure value ratio uncertainty of 
the type of structures.  Each structure is assigned to a structure occupancy 
type.  Several structure occupancy types may be assigned to the specified 
study damage category.  For example:  single-story no basement, single-
story with basement, duplexes, mobile homes are structure occupancy 
types assigned to a residential damage category.  An existing structure 
occupancy type can be selected, updated, and deleted.  The length is 16 
characters. 
 
Structure Value:  The standard deviation in percent of structure value 
associated with the uncertainty in the structure value estimate for a 
particular structure occupancy type.  A normal distribution is used. 
 
Structure Year:  The year the structure is built.  Used for economic 
evaluations.  Important for analysis of base and future analysis years in 
that only structures specified with those or previous years are included in 
the analysis. 
 
Study:  The investigation of with- and without-project conditions 
involving hydrology, hydraulics, economics, plan formulation and 
evaluation.  All the above information is stored under the study directory. 
 
Study Configuration:  The information that is multiple discipline used 
throughout the study.  Includes definition of streams, damage reaches, 
plans and analysis years.  These data are commonly used during H&H 
(hydrology and hydraulics) and Economic analysis.  Definition of the 
study configuration should be a multi-disciplinary activity. 
 
Surveyed Year:  The year associated with the structure survey flood 
damage values used in the structure inventory. 
 
System of Units:  Units of measure for study data and output reports.  
There are two hardwired choices (SI (metric) and English), with English 
being the default.  The units are used only as labels. 
 
Top of Levee Stage:  The stage of the top of the levee, flood wall, or tidal 
barrier that exists at the site or is being evaluated. 
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Total Overtopping Height (HW):  The difference between the levee or 
flood wall stage and the sum of the still water stage and the wave runup.  
Wave runup is assumed equal to wave height if the still water stage is 
below the levee or flood wall and two-thirds wave height if the still water 
elevation is above the levee or flood wall.  These assumptions for wave 
runup are appropriate for non-coastal applications where waves are 
relatively small. 
 
Triangular Distribution:  A three-parameter bounded probability 
distribution defined by the minimum, most likely (mode), and maximum. 
 
Uncertainty:  Measure of imprecision of knowledge of parameters and 
functions used to describe hydraulic, hydrologic, geotechnical and 
economic aspects of a project plan. 
 
Uncertainty Distribution:  A statistical relationship of possible outcomes 
that defines the dispersion or variation of errors about the median or “best 
estimate” of values along a function.  Uncertainty distributions are used to 
quantify errors probabilistically when using risk-based analysis.  The 
magnitude and range of the distribution can be defined using error limit or 
confidence limit curves above and below the median curve. 
 
Uniform Distribution:  A two-parameter bounded probability distribution 
defined by the minimum and maximum that is used for data that varies 
uniformly between the minimum and maximum values. 
 
Unsteady Flow:  The flow condition where depth changes with time 
(Chow, Open-channel Hydraulics, 1959). 
 
Updated Price Index:  A value used to update all economic (structure 
damage) values to present (or other) values.  The range of allowable 
values is from 0.00 to 100.00.  If left blank, the default will be 1.00 and no 
adjustments are made to the economic data. 
 
Updated Year:  The price year associated with the updated price index.  
Must be greater than or equal to the Surveyed Year.  If left blank, the 
default will be the Surveyed Year. 
 
Water Surface Profiles:  Water surface profiles are used to develop 
without- and with-project condition stage-discharge (rating) functions at a 
index location station within a damage reach.  Also, water surface profiles 
are used to aggregate stage-damage functions with uncertainty at a index 
location station within a damage reach.  If provided, the profiles are used 
in the development of discharge- and stage-probability functions, if not, 
the stage-discharge (rating) and discharge- or stage-probability functions 
must be entered directly.  Discharge values used in the water surface 
profile analyses should be median values.  A set of water surface profiles 
is specified for each plan, analysis year, and stream to be analyzed. 
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Wave Height:  The vertical distance between the crest of a wave and the 
preceding wave trough.  Wave height is dependent on still water level. 
 
Wave Overtopping:  The effects of water overtopping a levee or flood 
wall and the associated contribution to flood depth on the interior. 
 
Weighted Skew:  A statistic used as a measure of the dispersion of the 
data about the mean equal to the number of values times the sum of the 
cubes of the deviations from the mean divided by the number of values 
minus one, times the number of values minus two, times the standard 
deviation cubed.  The third moment statistic of a Log Pearson Type III 
analytical discharge-probability function calculated using the mean 
logarithm, the standard deviation of the logs, and the logarithms of peak 
discharge values. 
 
With-Project Condition:  The economic, performance, and other 
conditions associated with implementing a flood damage reduction plan.  
It is compared to the without-project condition.  It includes the base-year 
and static future analysis year periods to determine the equivalent values. 
 
Without-Project Condition:  The condition of the study area for the 
project life analysis period that is anticipated to most likely occur if the 
flood damage reduction measures and actions are not implemented.  It 
includes the base year and static future analysis year periods to determine 
the equivalent values.  It is the basis or baseline condition for evaluating 
the benefits and performance of potential flood damage reduction plans.  
Emphasis is initially placed on defining the without-project base-year 
conditions. 
 
Year in Service:  Year that a particular structure was built or a future year 
when the structure is assumed to be in place.  Used to designate which 
structures are to be used for the specified analysis years.  Only structures 
with year in service dates equal or less than the designated analysis years 
are used. 
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Appendix C  
 
 

Creating Water Surface Profile Data 
 
The HEC-FDA program can import water surface profile data (see 
Chapter 4, Section 4.3, pages 4-5 thru 4-6) generated by the Water Surface 
Profiles (HEC-2) program (USACE, 1991) or the River Analysis System 
(HEC-RAS) program (USACE, 2002).  This appendix provides 
information on how to generate the data files you will need from HEC-2 
or HEC-RAS for importing into FDA. 
 
 

C.1 Creating Water Surface Profile Data from HEC-2 
 
After the HEC-2 program has been used to compute multiple-profiles for 
eight frequency-based flows, the Summary Printout (SUMPO) program is 
used to create a text file of the water surface profile data for importing into 
the FDA program.  The SUMPO program is part of the HEC-2 package. 
 
The SUMPO program is selected as the run command choice in theHEC-2 
Package Menu.  The following steps are taken to create a text file of the 
WSP data to import: 
 
 ● From the SUMPO dialog box, select Create summary tables from 

the menu. 
 
 ● The variables Section Number (SECNO), Total Discharge (Q), 

Minimum Cross-Section Elevation (ELMIN), and Computed Water 
Surface Elevation (CWSEL) are selected, in that order, for the 
summary table. 

 
 ● "O" is selected to write the summary table to a file. 
 
 ● Select all or the appropriate cross-sections for the stream by 

answering the question "Output all cross sections (y/n)?" with "y" 
for yes. 

 
 ● Select the profiles in the same manner by answering the question 

"Output all profiles (y/n)?" with "y" for yes. 
 
 ● Answer "No" to, "Include summary errors in output (y/n)?" and, 

"Append output to output file (y/n)?" 
 
 ● Press <Enter> to generate the report. 
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The file name will be the same as your input data file with an extension of 
.SMP unless it is changed by selecting "Define files & printer width" in 
SUMPO.  Once the table is generated, check the results to see if it 
included the eight profiles and the stations for the stream of interest by 
displaying the file to the console or viewing it with a text viewer or editor.  
An example of a portion of a SUMPO text file is shown in Figure C.1. 

 
 

Figure C.1  Partial Listing of SUMPO Water Surface Profile Data 

               S U M P O                                   
    Interactive Summary Printout                
   for MS DOS/PC DOS micro computers   
   Sept 1988 version (9/89 update)   
   *                                   *  
 
 
  NOTE   Asterisk (*) at left of profile number 
         indicates message in summary of errors  list 
         
  
 SOUTH FORK BEAR CREEK 
 
 Summary Printout 
  
    SECNO       Q       ELMIN     CWSEL   
  
        .80   2790.00    416.50    424.68 
        .80   4030.00    416.50    426.58 
        .80   5530.00    416.50    428.56 
        .80   7100.00    416.50    430.39 
        .80   8100.00    416.50    431.39 
        .80   9550.00    416.50    432.90 
        .80  10620.00    416.50    433.92 
        .80  12870.00    416.50    435.88 
  
        .82   2790.00    416.10    424.81 
        .82   4030.00    416.10    426.70 
        .82   5530.00    416.10    428.67 
        .82   7100.00    416.10    430.48 
        .82   8100.00    416.10    431.47 
        .82   9550.00    416.10    432.95 
        .82  10620.00    416.10    433.95 
        .82  12870.00    416.10    435.85 

C.2 Creating Water Surface Profile Data from HEC-RAS 
 
After HEC-RAS has been executed, program options can be used to create 
a text file of the water surface profile data for importing into the FDA 
program.  Separate data files are created for each plan and stream (reach).  
Error messages will be displayed if more than one stream (reach) or plan 
is included in the file you are attempting to import.  If this happens, return 
to the HEC-RAS program and re-generate the file with one stream (reach) 
and/or plan, as needed.  Note that river tributaries may be designated only 
as separate hydraulic reaches in HEC-RAS.  When importing this data into 
FDA, tributaries are generally considered separate streams and water 
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surface profile data should be imported separately for each stream.  When 
the HEC-RAS analysis has been completed, do the following: 
 
 ● From the HEC-RAS main window, on the View menu click Profile 

Summary Table, the HEC-RAS Profile Output Table – 
Standard Table 1 dialog box will open. 

 
 ● From the HEC-RAS Profile Output Table – Standard Table 1, 

on the Std. Table menu, click HEC-FDA.  Now the dialog box will 
change to the HEC-RAS Profile Output Table – HEC-FDA 
(Figure C.2) 

 
 ● From the Options menu: 
 ► Click Plans, from the Plan Selection dialog box, select the 

appropriate plan. 
 ► Click Profiles, from the Select Profiles dialog box, select the 

appropriate water surface profiles (FDA requires eight 
profiles). 

 ► Click Reaches, from the Select Rivers and Reaches dialog 
box, select the appropriate reach. 

 ► The cross section order needs to be downstream to upstream 
(increasing by station), click Table Cross Section Order.  
From the HEC-RAS dialog box, click Downstream to 
Upstream Order (HEC2 Style). 

Figure C.2  HEC-RAS Profile Output Table for HEC-FDA 
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 ► If you want to save the table with the above options, click 
Save Table.  From the HEC-RAS dialog box enter a 
filename. 

 
 ● Once the table is generated (see Figure C.2, page C-3), check the 

results to see if eight profiles and the stations for the stream of 
interest are included. 

 
 ● To save the profile summary table to a text file, on the File menu, 

click Write to Text File, the Enter Filename browser will open.  
Enter a name in the File name box, the extension of the file will be 
*.txt.  When importing HEC-RAS results, FDA filters files to show 
only those with the extension *.wsp.  You will need to rename the 
profile output table file to use the extension *.wsp before importing 
it into FDA. 

 
Figure C.3 contains an example partial listing of a saved profile summary 
text file that was saved from HEC-RAS. 
 

 
 

Figure C.3 Partial Listing of File from HEC-RAS Profile Output Table 

Profile Output Table - HEC-FDA Silver Creek 
HEC-RAS  Plan: SC Flow 
                                                                                     
# Rivers            = 1  
# Hydraulic Reaches = 2  
# River Stations    = 481  
# Plans             = 1  
# Profiles          = 8  
 
 Reach            River Sta        Profile            Q Total  Min Ch El  W.S. Elev 
                                                        (cfs)       (ft)       (ft) 
                                                                                    
 Silver Lower     39758.           2yr                4000.00      20.60      30.65 
 Silver Lower     39758.           5yr                8500.00      20.60      34.46 
 Silver Lower     39758.           10yr              10500.00      20.60      35.85 
 Silver Lower     39758.           25yr              12000.00      20.60      36.74 
 Silver Lower     39758.           50yr              32000.00      20.60      44.19 
 Silver Lower     39758.           100yr             70000.00      20.60      50.31 
 Silver Lower     39758.           250yr            100000.00      20.60      53.75 
 Silver Lower     39758.           500yr            154000.00      20.60      56.38 
                                                                                    
 Silver Lower     39943.3*         2yr                4000.00      20.89      30.84 
 Silver Lower     39943.3*         5yr                8500.00      20.89      34.65 
 Silver Lower     39943.3*         10yr              10500.00      20.89      36.03 
 Silver Lower     39943.3*         25yr              12000.00      20.89      36.93 
 Silver Lower     39943.3*         50yr              32000.00      20.89      44.42 
 Silver Lower     39943.3*         100yr             70000.00      20.89      50.50 
 Silver Lower     39943.3*         250yr            100000.00      20.89      54.24 
 Silver Lower     39943.3*         500yr            154000.00      20.89      56.82 
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Wave Overtopping Analysis 
 
Wave overtopping analysis accounts for the effects of wave overtopping 
when analyzing levees, floodwalls or tidal barriers.  The purpose is to 
account for damage in the floodplain due to waves spilling over the top of 
new levees or floodwalls and to account for waves when considering 
levees subject to failure. 
 
 

D.1 New Levees and Floodwalls 
 
New levees and floodwalls are generally, by design, not subject to failure 
below their crest.  These structures can be subjected to wave action from 
large rivers, estuaries, or in coastal areas. If wave action is shown to cause 
flood inundation damage, a wave overtopping analysis may be warranted.  
The HEC-FDA program includes a simplified approach to evaluate 
damage caused by wave overtopping. 
 
The steps for creating a new levee are located in Chapter 7, Section 7.2 
(page 7-1).  To account for the effects of wave overtopping: 
 
 1. From the Levee Features dialog box (Figure D.1), click Wave 

Overtopping. 

 
Figure D.1  Levee Features Dialog Box 
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 2. The Wave Overtopping Analysis dialog box will open (Figure 
D.2). 

 3. The Wave Height Functions tab is selected by default, a still water 
level versus wave height relationship needs to be entered in the 
table.  Still water stage corresponds to the exterior stage discharge 
or stage frequency function specified for the damage reach.  The 
still water versus wave height relationship and uncertainty are 
developed outside FDA from historical data and statistical analysis 
or by some other method. 

 4. If there is uncertainty associated with the wave height, from the 
Distribution Type box (Figure D.2) select the appropriate 
uncertainty type.  Then enter the parameters for the uncertainty for 
each wave height. 

 5. To view the still water versus wave height relationship graphically, 
click Plot or on the View menu, click Wave Overtopping Plot, 
either way the Wave Height Plot dialog box will open.  To view 
the still water versus wave height relationship in a report, click 
Tabulate or on the View menu click, Wave Overtopping Report, 
either way the Wave Height Report dialog box will open. 

 6. When a levee or floodwall is subjected to wave action, a portion of 
the wave may overtop depending on whether the wave strikes the 
structure.  The volume of water that spills over the levee or 
floodwall is dependent on the effective overtopping height. 

 7. You now need to enter the parameters for the overtopping of the 
levee.  From the Wave Overtopping Analysis dialog box (Figure 
D.2), click the Overtopping Parameters tab (see Figure D.3, page 
D-3).  Now the user can enter relationships for determining the 
effective overtopping and resulting depth in the floodplain.  The 
Overtopping Parameters tab (see Figure D.3, page D-3) is only  

Figure D.2 Wave Overtopping Analysis Dialog Box - Wave Height 
Functions 
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Figure D.3 Wave Overtopping Analysis Dialog Box - Overtopping 
Parameters 

  available if geotechnical failure relationships have not been defined 
for the levee. 

 8. The relationships that define the overtopping parameters are 
developed outside the FDA program from known wave 
characteristics and hydraulic analyses.  The data in the two tables 
define separate relationships.  The following describes how the 
wave height and these data are used to determine the depth in the 
floodplain due to wave overtopping. 

 
 ● Wave height (R) is determined from the still water level (SE) 

versus wave height and uncertainty relationships for each still 
water level. 

 
 ● If the still water level alone exceeds the top of levee (SD), 

wave runup (RR) is equal to two-thirds of the wave height.  If 
still water level alone (SE) is below the top of levee, wave 
runup is equal to the full wave height. 

 
 RR = 2/3 R ( SE ≥ SD) 
 RR = R ( SE < SD) 
 
 ● The exterior stage with wave (SE) is computed by adding 

runup to still water level. 
 
 SE = SE + RR 
 
 ● The total height above the levee (HW) is determined by 

subtracting the levee crest elevation (SD) from the exterior  

 D-3 



Appendix D- Wave Overtopping Analysis HEC-FDA User's Manual 

D-4 

  stage with wave (SE).  This height is set to zero if the exterior 
stage with wave is equal to or below the top of levee. 

 
 HW = SE - SD (SE > SD) 
 HW = 0 (SE ≤ SD) 
 
 ● The wave shape factor (Z) is equal to the ratio of the portion 

of wave above the levee or floodwall to total wave height and 
is determined by dividing the total height by the wave runup. 

 
 Z = HW/RR 
 
 ● K, is a factor for determining the portion of the total water 

above the top of levee that is effective for overtopping and is 
dependant on the wave shape factor, Z, as defined by the 
entered relationship Z versus K (see Figure D.3, page D-3). 

 
 ● The total effective overtopping height (HO) above the top of 

levee is equal to K times the total height (HW) above the top 
of levee. 

 
 HO = K*HW 
 
 ● The depth of water in the floodplain, referred to as interior 

stage (SI) is the stage on the landward side or interior of the 
levee or  floodwall and is dependant on HO as described by 
the entered relationship HO versus SI (see Figure D.3, page 
D-3). 

 
 9. It should be noted that the relationship HO versus SI should be 

defined for the full range of overtopping heights and interior stages.  
At some point, either by failure or sufficient overtopping, SI should 
equal the levee elevation (SD) plus the quantity (HO minus 2/3 R). 

 
 SI => SD + (HO - 2/3 R) 
 
  The exception would be if there was not sufficient volume available 

to fill the interior area to the same elevation as the exterior still 
water level. 

 10. To view the wave shape factor versus effective overtopping factor 
relationship graphically, click Plot underneath that table, the Wave 
Factor Plot dialog box will open.  To view the wave shape factor 
versus effective overtopping factor relationship in a report, click 
Tabulate underneath that table, the Wave Factor Report dialog 
box will open. 

 11. To view the effective overtopping height versus the interior stage 
relationship graphically, click Plot underneath that table, the 
Interior Stage Plot dialog box will open.  To view the effective 
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overtopping height versus the interior stage relationship in a report, 
click Tabulate underneath that table, the Interior Stage Report 
dialog box will open. 

 12. Once you are finished entering the wave overtopping relationships, 
click Save, the Wave Overtopping Analysis dialog box will close 
(see Figure D.3, page D-3).  This saves the relationship for the 
levee, but you must click Save from the Levee Features dialog box 
(See Figure D.1, page D-1) to save the entire levee definition. 

 
D.2 Levees Subject to Geotechnical Failure 

 
For existing levees or other levees subject to geotechnical failure, a 
relationship between water surface stage on the river or exterior side of the 
levee versus the probability of failure can be defined as described in 
Chapter 7, Section 7.2.2 (page 7-5).  When this is the case, a still water 
level versus wave height relationship may be defined to account for the 
effect of waves contributing to levee failure.  Since the levee has a 
geotechnical failure relationship defined, overtopping parameters will not 
be available. 
 
When a still water level versus wave height relationship is provided, the 
following two scenarios apply. 
 
 ● If a given still water level fails the levee based on the geotechnical 

failure relationship, wave height is ignored and the still water level 
without wave is used to determine interior stage based on an 
exterior versus interior relationship.  If the later relationship is not 
provided, the interior stage is assumed equal to the still water level. 

 
 ● If the still water level does not fail the levee based on the 

geotechnical failure relationship, sampled wave height is added to 
the still water level and compared to the top of levee stage.  If still 
water level plus wave height is equal to or exceeds the top of levee, 
the levee is failed and the still water level without wave is used to 
determine interior stage based on an exterior versus interior 
relationship.  If the later relationship is not provided, the interior 
stage is assumed equal to the still water level. 
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Appendix E  
 
 

Importing HEC-FDA Study Data 
 
 

E.1 HEC-FDA Study Data 
 
HEC-FDA imports several primary data types from delimited files.  By 
default, FDA expects the fields to be separated by the tab character.  These 
data types are the primary reason for importing data but they may 
reference other data types that are assumed to already exist.  For example, 
structure information is primary data, yet each structure references a 
stream which is assumed to already be defined.  However, as part of the 
import process, FDA will add records (if they don’t exist) to the database 
for some related data (such as streams) to facilitate successful transfer of 
data.  Sometimes, this has unintended effects if you have entered the 
wrong name.  FDA imports the following data: 
 
 ● Plans (plan name).  The plan names must be unique. 
 
 ● Years (year).  Enter a maximum of two years, each must be unique.  
 
 ● Streams (stream name).  The stream names must be unique. 
 
 ● Damage reaches (reach name, stations, bank).  The damage reach 

names must be unique.  The index station must be between the 
beginning and ending stations inclusively.  The damage reaches are 
defined by stream, station (river mile), and stream bank (left, right, 
or both).  FDA assigns each structure to a damage reach using either 
the structure's stream, station (river mile), and bank (left or right) 

 
 ● Damage Categories (damage category name).  The names must be 

unique. 
 
 ● Structure Occupancy Types (structure occupancy type name).  The 

names must be unique and be assigned to a damage category.  Each 
damage category may contain one or more structure occupancy 
type.  (Example:  Damage Category SF Residential may have the 
Structure Occupancy Types 1SNB, 1SWB, 2SNB, 2SWB, etc.).  
Structure occupancy types contain the depth-damage functions and 
each structure occupancy type represents a type of dwelling.  For 
example, separate structure occupancy types could represent the 
following: 
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 ■ single family, no basement, wood frame construction; 
 ■ single family, with basement, masonry construction; 
 ■ public building, masonry construction, school; etc. 
 
 FDA will add structure occupancy types for each structure 

occupancy type referenced by the imported structure if that 
structure occupancy type does not exist.  The structure occupancy 
types that are added contain no depth-damage functions, etc.  You 
will have to edit the depth-damage functions or import them later. 

 
 ● Structure modules (Structure module name). 
 
 ● Structures (Structure name).  Each structure must have a unique 

name.  At entry, a structure must be assigned a stream, damage 
category, occupancy type, and structure module (base is default).  
Other parameters may be entered later before the calculation of 
stage-damage.  Structure information includes such items as value 
of structure, contents, and "other,” first floor elevation, and stream 
station (river mile). 

 
 ● Water surface profiles.  Each water surface profile must have a 

unique name.  You may import either discharge or stage profiles. 
 
 

E.2 Requirements for Importing from an ASCII Tab 
Delimited File 

 
FDA imports data from a text file which contains delimited fields. By 
default, FDA expects the fields to be delimited by the tab character and the 
following sections of this appendix assume that you used the tab character 
as the separator.  A different field separator can be specified, see Chapter 
8, Section 8.3.2 (page 8-8). 
 
The file contains a TAB between each field of data.  The first line (row) of 
the file is a header record which contains fieldnames for each field of data.  
The fieldname in field one of the header record is a keyword (see Section 
E.2.1) which identifies the data type.  If the file contains data that FDA 
cannot import (such as structure square footage), you would leave the 
fieldname blank or enter a descriptor which is not a recognizable FDA 
fieldname. 
 

E.2.1 Types of Study Data and Associated Keywords 
 
FDA can import several types of data: plans, years, streams, damage 
reaches, damage categories, structure occupancy types, structure modules,  
structure inventories, water surface profiles, exceedance probability 
(frequency) functions, stage-discharge (rating) functions, and levee data.  
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The header record (row one) for each data type must contain one of the 
correct keywords (Table E.1) in field one.  FDA uses the keyword to 
determine the type of data that will be imported.  Multiple types of data  
 

Table E.1 
HEC-FDA Keywords for Import File 

 
 Keyword Type of Data 
 Plan_Name Plans 
 Year_Name Years 
 Strm_Nme Streams 
 Rch_Name Reaches 
 Cat_Name Damage Categories 
 Occ_Name Occupancy Types 
 Mod_Name Structure Modules 
 Struc_Name Structure inventory 
 WSP_Name Water Surface Profiles 
 WSP_Probability 
 WSP_Station 
 Freq_Name Exceedance Probability Functions 
 Rate_Name Stage-Discharge Functions 
 Levee_Name Levee Data 
 
may be entered in one file although it is usually best to enter different data 
types in separate files.  The header record for each new data type must 
contain the keyword in field one and the fieldnames are included the 
subsequent fields of the header record.  For example, Figure E.1 displays a 
section of an ASCII delimited file that has been setup for importing data 
into FDA. 

 
E.2.2 Format of Data and Fieldnames 

 
The header record which contains the keyword and fieldnames for an FDA 
data type must precede any data associated with that data type.  The 
following rules apply to the keywords and data: 
 
 ● Data for the keyword must be unique for each record (unique 

category names, unique structure occupancy type names, unique 
structure names, etc.). 

Figure E.1  Example ASCII Tab Delimited File for Importing Data 
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 ● The keyword and associated data must be entered.  For example, 
when importing damage categories, the keyword Cat_Name must 
be entered in field one of the header record and a damage category 
name must be entered in field one of the subsequent records that 
define the data for each damage category.  Other fields may be 
omitted unless required by the FDA program.  For example, each 
structure must be assigned to a damage category so each structure 
entry must include a damage category name. 

 
 ● By default, fieldnames and data fields are separated by the TAB 

delimiter, the user can specify other field separators (see Chapter 8, 
Section 8.3.2, page 8-7).  A typical way to create a file for 
importing data into FDA is to enter the data in a spreadsheet 
program such as Excel®.  From the spreadsheet, first save the 
spreadsheet and then save the current Excel® file as "Text (Tab-
delimited) (*.txt)".  The FDA program assumes the extension ".txt" 
for a file that is to be imported, although you can use any extension 
you like. 

 
 ● Other than the keyword (must be in field one of the header record), 

other fields may be entered in any order and data not recognized by 
FDA can be interspersed anywhere. 

 
 ● The fieldnames are entered on the header record. 
 
 ● All data may be in one file but it is advisable to keep the structures 

separate from other types of data such as occupancy codes strictly 
from a visual standpoint and to maintain integrity in the field 
formatting and width. 

 
 ● Numeric data cannot contain commas.  For example, a structure 

value of $12,300 must be entered as 12000 in the delimited text file 
that is imported into FDA. 

 
The following sections describe the required header record format for each 
type of data.  One way to easily get a "template" of the required format for  
each data type is to enter one set of data (such as one damage category, 
one stream, one damage reach, one structure, etc.) and then export the data 
to a tab-delimited text file (see Chapter 8, Section 8.3.3, page 8-9). 
 

E.2.3 Header Record and Fieldnames for Plans 
 
The following fieldnames (identifiers) used to import plans: 
 
 Field Name Description 
 Plan_Name Plan name (sixteen characters maximum); 

required.  Keyword; must be entered in the 
first field. 
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 Plan_Desc Plan description (sixty-four characters 

maximum); optional. 
 
Figure E.2 provides an example of the entry of plans in an ASCII tab 
delimited file that can be imported into FDA. 

 
E.2.4 Header Record and Fieldnames for Analysis Years 

 
The following fieldnames (identifiers) used to import analysis years: 
 
 Field Name Description 
 Year_Name Analysis year, (four characters maximum); 

required.  Keyword; must be entered in the 
first field. 

 
Figure E.3 provides an example of the entry of analysis years in an ASCII 
tab delimited file that can be imported into FDA. 

 
E.2.5 Header Record and Fieldnames for Streams 

 
The following fieldnames (identifiers) used to import streams: 
 
 Field Name Description 
 Strm_Nme Stream name (sixteen characters maximum); 

required.  Keyword; must be entered in the 
first field. 

Figure E.2  Header Record and Data Records for Importing Plans 

Figure E.3 Header Record and Data Records for Importing 
Analysis Years 
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 Strm_Desc Stream description (sixty-four characters 
maximum); optional. 

 
Figure E.4 provides an example of the entry of streams in an ASCII tab 
delimited file that can be imported into FDA. 

 
E.2.6 Header Record and Fieldnames for Damage Reaches 

 
The following fieldnames (identifiers) used to import damage reach data: 
 
 Field Name Description 
 Rch_Name Reach name (sixteen characters maximum); 

required.  Keyword; must be entered in the 
first field. 

 
 Rch_Desc Reach description (sixty-four characters 

maximum); optional. 
 
 Stream_Nme Stream name (sixteen characters maximum); 

required.  Should match a previously entered 
stream. 

 
 Beg_Sta Beginning stream station for this damage 

reach.  It must be less than or equal to the 
ending stream station. 

 
 End_Sta Ending stream station for this damage reach. 

Must be greater than or equal to the beginning 
stream station. 

 
 Bank Stream bank associated with this damage 

reach.  It may be L, Left, R, Right, B, or Both. 
 
 
 Index_Sta Index location stream station for this damage 

reach.  It must be between the beginning and 
ending stream stations inclusively. 

 

Figure E.4  Header Record and Data Records for Importing Streams 
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 SID_Reffld SID reference flood elevation (optional).  This 
is needed only if you are using the SID 
reference flood for aggregating damage to the 
index location. 

 
Figure E.5 provides an example of the entry of damage reaches in an 
ASCII tab delimited file that can be imported into FDA. 

 
 

E.2.7 Header Record and Fieldnames for Damage 
Categories 

 
The following fieldnames (identifiers) used to import damage category 
data: 
 
 Field Name Description 
 Cat_Name Damage category name (sixteen characters 

maximum); required.  Keyword; must be 
entered in the first field. 

 
 Cat_Description Description of damage category (sixty-four 

characters maximum); optional. 
 
 Cost_Factor Price index for damage category.  Overrides 

the global factor entered for the study.  If left 
blank, the price index for the damage category 
is set to undefined and the damage category 
will use the global price index. 

 
Figure E.6  provides an example of the entry of damage categories in an 
ASCII tab delimited file that can be imported into FDA. 

Figure E.5 Header Record and Data Records for Importing Damage 
Reaches 

Figure E.6 Header Record and Data Records for Importing Damage 
Categories 
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E.2.8 Header Record and Fieldnames for Structure 

Occupancy Types 
 
The following fieldnames (identifiers) used to import structure occupancy 
type data: 
 
 Field Name Description 
 Occ_Name Structure occupancy type name (sixteen 

characters maximum); required.  Keyword: 
must be entered in the first field of the header 
record and must be entered for each data 
record that has valid data for the structure 
occupancy type. 

 
 Cat_Name Damage category name (sixteen characters 

maximum). 
 
 Occ_Description Description of structure occupancy type 

(sixty-four characters maximum); optional. 
 
 Parameter See Parameter Code section. 
 
 Start_Data Code name indicating the first column of data 

in depth-damage functions and structure 
uncertainty parameters. 

 
Figure E.7 provides an example of the entry of structure occupancy types 
in an ASCII tab delimited file that can be imported into FDA. 

 
 Structure Occupancy Type Parameter Codes 

 
Parameter codes identify the type of data entered in the current data 
record.  The data record may contain depth, damage, standard deviation in  

Figure E.7 Header Record and Data Records for Importing Structure Occupancy 
Types 
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damage, or structure uncertainties (such as for first floor stage, structure 
value, content value, or other value).  All data pertinent to this parameter 
code are entered in field to the right of the parameter code.  Damage data 
for depth-damage functions may be entered in percent (use the parameter 
code) or in thousands of dollars (append the parameter code with a "$").  
For example, damage for the depth-percent damage function for structure 
damage uses the code S whereas if the damage is in thousands of dollars it 
uses the code S$. 
 
For a given structure occupancy type, all functions must be of the same 
type (either percent damage or dollar damage) and not a combination of 
the two.  The parameter code for damage includes a letter indicating which 
component of damage is entered (S for structure, C for content, O for 
other).  The parameter code for standard deviation of error (or 
maximum/minimum for triangular distributions) includes the component 
(S for structure, etc.) and the distribution (blank is none, N is normal, L is 
log-normal, and T is triangular).  The following lists the valid parameter 
codes and associated descriptions: 
 
 Parameter 
 Code Description 
 STAGE Depth for depth damage function.  May be entered 

only once and then the same depths are used for all 
trailing functions if all functions have the same 
number of values.  For direct dollar depth-damage 
functions, this may be entered as elevation and the 
structure first floor stage set to zero. 

 
 S Structure damage in percent for the structure depth-

damage function.  Use S$ for dollar damage. 
 
 C Content damage in percent for the content depth-

damage function (e.g., inventory).  Use C$ for 
dollar damage. 

 
 O Other damage in percent for "other" depth-damage 

function (e.g.,  equipment, outbuildings).  Use O$ 
for dollar damage. 

 
 SN Standard error in structure damage, normal 

distribution. 
 
 CN Standard error in content damage, normal 

distribution. 
 
 ON Standard error in other damage, normal distribution. 
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 STU Standard error in structure damage above the curve, 
triangular distribution. 

 
 STL Standard error in structure damage below the curve, 

triangular distribution. 
 
 CTU Standard error in content damage above the curve, 

triangular distribution. 
 
 CTL Standard error in content damage below the curve, 

triangular distribution. 
 
 OTU Standard error in other damage above the curve, 

triangular distribution. 
 
 OTL Standard error in other damage below the curve, 

triangular distribution. 
 
 SL Standard error in structure damage, log-normal 

distribution. 
 
 CL Standard error in content damage, log-normal 

distribution. 
 
 OL Standard error in other damage, log-normal 

distribution. 
 
 STRUCT Distributions and errors for the parameters 

associated with structures (first floor, structure 
value, content value, and other value).  There are 
four columns for each uncertainty parameter in the 
preceding order.  The columns contain the 
following data: 

 
 (1) Distribution type (N is normal, LN is log-

normal, and T is triangular). 
 
 (2) Median value (left blank for first floor and 

structure value).  For contents and other, this 
is the ratio of contents (or other) to structure 
value in percent.  For example, if the contents 
value is 35% of the structure value, enter 35. 

 
 (3) Standard deviation of error for normal or log-

normal or the minimum value in the 
triangular distribution. 

 
 (4) Maximum value in the triangular distribution. 
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  The four columns of uncertainty information for the 

first floor stage are entered first followed by the 
structure value, the contents value, and the other 
value. 

 
 

E.2.9 Header Record and Fieldnames for Structure 
Modules 

 
The following fieldnames (identifiers) used to import structure modules: 
 
 Field Name Description 
 Mod_Name Structure  module name (sixteen characters 

maximum); required. 
 
 Mod_Desc Structure module description (sixty-four 

characters maximum); optional. 
 
Figure E.8 (page E-12) provides an example of the entry of structure 
modules in an ASCII tab delimited file that can be imported into FDA. 

 
E.2.10 Header Record and Fieldnames for Structures 

 
The following fieldnames (identifiers) used to import structure data: 
 
 Field Name Description 
 Struc_Name Structure name (sixteen characters maximum); 

required.  Keyword; must be entered in the 
first field.   If there are duplicate structure 
names in the file, the study will contain only 
the last structure with a duplicated name that 
was imported.  Similarly, if the structure name 
matches that of a structure in the study 
already, the structure data in the study will be 
replaced by the imported structure. 

 

Figure E.8 Header Record and Data Records for Importing Structure 
Modules 
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 Cat_Name Damage category name (sixteen characters 
maximum); required. 

 
 Stream_Name Stream name (sixteen characters maximum); 

required. 
 
 Occ_Name Structure occupancy type name (sixteen 

characters maximum); required. 
 
 Station Stream station (or river mile).  It is required 

for aggregating stage-damage functions using 
the water surface profiles. 

 
 Bank Bank location (left or right).  If cell is left 

blank, HEC-FDA assumes the left bank. Valid 
entries are: "L", "Left", "R", or "Right". 

 
 Year Year in service (assumed 1900).  It is used to 

determine if the structure should be included 
in the base year and/or most likely future year 
structure inventory. 

 
 Struc_Val Structure value ($1,000). 
 
 Cont_Val Content value ($1,000).  If left blank, the 

content value is computed from the structure 
value and the content-to-structure value ratio 
contained in the occupancy type. 

  
 Other_Val Other value ($1,000).  If left blank, the other 

value is computed from the structure value 
and the other-to-structure value ratio 
contained in the occupancy type. 

 
 1F_Stage First floor stage (elevation).  You must use 

either (1) the first floor stage, or (2) the 
ground stage and the foundation height. 

 
 Grnd_Stage Stage (elevation) of the ground at the 

structure.  You must use either (1) the first 
floor stage, or (2) the ground stage and the 
foundation height. 

 
 Found_Ht Foundation height (distance from ground to 

first floor).  You must use either (1) the first 
floor stage, or (2) the ground stage and the 
foundation height. 
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 Begin_Damg Beginning damage depth.  If left blank, it is 
assumed to be undefined and it is not used, 
and the beginning damage depth is determined 
from the depth-damage functions.  If entered, 
it is relative to the first floor stage.  For 
example, if damage starts one foot below the 
first floor stage, you would enter -1. 

 
 Street Street address of structure. 
 
 City City. 
 
 State State. 
 
 Zip Zip code. 
 
 North Northing coordinate at structure. 
 
 East Easting coordinate at structure. 
 
 Zone Zone for the above coordinates. 
 
 Num_Struct Number of identical structures this one entry 

represents. 
 
 Notes Miscellaneous notes.   
 
 Mod_Name Module name (assumed base). 
 
 SID_Rch The SID reach name (optional). 
 
 SID_Reffld The SID reference flood elevation (optional). 
 
Figure E.9  (page E-14)provides an example of the entry of structures in 
an ASCII tab delimited file that can be imported into FDA. 
 

E.2.11 Header Record for Water Surface Profiles 
 
The format for importing water surface profiles is somewhat different than 
the other types of data that can be imported using delimited text files.  
Water surface profiles are assigned to a plan, analysis year, and stream 
combination. . One set of water surface profiles may be used for more than 
one plan and/or analysis year.  The water surface profile data is entered 
only once for a given plan, analysis year, and stream combination.  Then, 
the set of water surface profiles is assigned to other plan and analysis year 
combinations that use the same set of water surface profiles on that 
stream.  To accommodate importing data that is assigned, there is more  



Appendix E – Importing HEC-FDA Study Data HEC-FDA User's Manual 

E-14 

 
than header records that contains fieldnames and each header record is 
followed by data.   For water surface profiles, there are three header 
records: 
 
 1. The first header record contains the keyword and fieldnames for the 

water surface profile name, the plan, the year, the stream, the type 
of profile (flow, stage, or assigned), and the notes.  After this header 
record the data records for this particular data will follow. 

 2. The second header record contains the keyword and fieldnames for 
the probabilities associated with each profile.  After this header 
record the data records for this particular data will follow. 

 3. The third header record contains the keyword and fieldnames for 
the stream station, invert stage, and the profile data (flow and/or 
stage).  After this header record the data records for this particular 
data will follow. 

 
 First Header Record and Fieldnames for Water 

Surface Profiles 
 
The following fieldnames are entered in the first header record for a set of 
water surface profiles.  This header record is followed by the data record 
that corresponds to these fieldnames. 
 
 Field Name Description 
 WSP_Name Water surface profile name (sixteen characters 

maximum); required.  Keyword; must be a 
entered in the first field. 

 
 Description Description of this set of water surface 

profiles (sixty-four characters maximum); 
optional. 

Figure E.9  Header Record and Data Records for Importing Structures 



HEC-FDA User's Manual Appendix E – Importing HEC-FDA Study Data 

 E-15 

 
 Plan Plan name (sixteen characters maximum); 

required. The plan name should match one 
that is already stored in the database. 

 
 Year The year, either the base year or the most 

likely future year (four characters); required.  
The year should match one that is already 
stored in the database. 

 
 Stream Stream name (sixteen characters maximum); 

required.  The stream name should match one 
that is already stored in the database. 

 
 Type The type of water surface profile (required).  

The type of profile is one of three types:  
 (1) DISCHARGE_FREQ for a set of 

discharge profiles that contain both 
flow and stage profiles,  

 (2) STAGE_FREQUENCY for a set of 
stage profiles, and  

 (3) ASSIGN to indicate the set of profiles 
with the specified name (WSP_Name) 
are assigned to this plan/year/ stream. 

 
 Notes Notes about this set of profiles (optional). 
 
Figure E.10 provides an example of the entry of a water surface profile set 
in an ASCII tab delimited file that can be imported into FDA. 

 

Figure E.10 All Three Header Records and Data Records for Importing Water 
Surface Profile Sets 
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 Second Header Record and Fieldnames for Water 
Surface Profiles 

 
The following fieldname is entered in the second header record for a set of 
water surface profiles.  This header record is followed by the data record 
that corresponds to this fieldname. 
 
 Field Name Description 
 WSP_Probability Keyword; must be in field one of the header 

record.  It indicates that the next record will 
contain probabilities that are associated with 
each profile (both stage and flow) as 
appropriate.  The probabilities must be above 
the corresponding profile as defined in the 
third header record. 

 
Figure E.10 provides an example of the entry of a water surface profile set 
in an ASCII tab delimited file that can be imported into FDA. 
 
 

 Third Header Record and Fieldnames for Water 
Surface Profiles 

 
The following fieldnames are entered in the third header record for a set of 
water surface profiles.  This header record is followed by the data record 
that corresponds to this fieldnames. 
 
 Field Name Description 
 WSP_Station Keyword; must be in field one of the header 

record.  Stream station at each cross-section in 
the water surface profile model. 

 
 Invert Invert stage at each cross-section in the water 

surface profile model. 
 
 Stage Computed water surface stage at each cross-

section for a specified exceedance probability. 
There are 8 columns, one for each profile. 

 
 Q Computed flow at each cross-section for a 

specified exceedance probability. If you have 
only stage profiles, you would not enter the 
fields “Q”. If entered, there are 8 columns, one 
for each profile. 
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Figure E.10 (page E-15) provides an example of the entry of a water 
surface profile set in an ASCII tab delimited file that can be imported into 
FDA. 
 
 

E.3 Procedure for Updating the Study Data 
 
If your study already includes data, FDA provides an option for updating 
when importing data.  When the update data option (see Chapter 8, 
Section 8.3.2, page 8-8) has been selected FDA will update data that is 
already stored in the study.  For example, if you wanted to update only the 
first floor stage for selected structures, you could create an ASCII tab 
delimited file where the first field of the header record would be 
Struc_Name and the second field would be the fieldname 1F_Stage.  The 
following data records would contain the structure name and the updated 
first floor stage values. 
 
If the update data option has not been selected, and data exists in the 
study, data could be replaced by the import 
 
 

E.4 Importing Data from HEC-SID Data Files 
 
FDA can import data from HEC-SID (Hydrologic Engineering Center’s 
Structure Inventory for Damage Analysis program) input files.  The 
import capability has several requirements and features outlined below: 
 
 ● All of the data must be in one file.  These include the normal Job 

Records such as DC (damage category), and DR (damage reach), 
damage function records such as DF, DP, PC, DD (function name, 
depth, percent damage, dollar damage), and structure inventory 
records such as SL, SD, SO (first floor stage, value of structure, 
contents, and other, etc.). 

 
 ● Do not include damage category records for separating contents 

damage from structure damage (CC records and associated DC 
records for contents only). 

 
 ● Optionally enter damage reach index location station in field DR.10 

(columns 73-80 of the DR record). 
 
 ● Optionally enter the structure stream station in field SO.9 (columns 

65-72 of the SO record). 
 
 ● FDA will calculate the range of stream stations (river miles) for 

each reach if the station is entered in the SO.9 field for each 
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structure.  Upon completion, the beginning and ending stations are 
stored with the reach specifications in the FDA study. 

 
FDA determines all combinations of the depth-damage functions from the 
structure inventory and generates occupancy types from these.  The 
occupancy type names are formed by concatenating the SID damage 
function names.  The same functions for one structure cannot be used for 
another that is in a different damage category. 
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Appendix F  
 
 

Procedures for Computing Stage-
Damage Functions 

 
 

F.1 General 
 
Stage-aggregated damage functions are one of the three primary functions 
used in HEC-FDA to construct a damage-probability function.  The other 
two functions are discharge-exceedance probability and stage-discharge.  
Integration of the damage-probability function produces expected annual 
damage.  The computation of expected annual damage utilizes only the 
stage-total aggregated damage function and not the individual components 
such as structure damage. 
 
The aggregated stage-damage functions must be derived at the index 
location and must be computed (or directly entered) for each plan, 
analysis year, stream, damage reach, and damage category.  In other 
words, for a given plan, analysis year, stream, damage reach, and damage 
category, there is one stage-aggregated total damage function.  Usually, 
this function is computed but it may be entered directly if it has been 
computed using other tools.  The function represents total damage and is 
the sum of the damage inflicted to three components: 
 
 ● Structure 
 ● Contents 
 ● Other (such as outbuildings, landscaping, etc.) 
 
Before computing stage-aggregated damage, you must define several 
items including configuration items (plans, stream, damage reaches, 
analysis years), water surface profiles, damage categories, structure 
occupancy types, and structure attributes.  It is also helpful to define the 
discharge-exceedance probability and stage-discharge functions.  The 
water surface profiles facilitate aggregation of damage from a single 
structure to the index location.  The structure occupancy types describe 
depth-damage functions and some global structure parameters.  The 
structure attributes define the parameters necessary for computing stage-
damage for each structure.  The discharge-exceedance probability and 
stage-discharge functions are used to determine the span of stages at the 
index location for which aggregated damage is computed. 
 



 Appendix F – Procedures for Computing Stage-Damage Functions HEC-FDA User's Manual 

F-2 

 
 
Once all of the above parameters are defined, you may compute stage-
aggregated damage for one or more combinations of plan and analysis 
year.  The computed functions are then used in the computation of 
expected annual damage.  If you change any of the parameters such as a 
structure's first floor elevation, you must re-compute stage-aggregated 
damage and then expected annual damage for all plan/analysis year 
combinations that are dependent upon that structure. 
 
A general overview of what happens when you select a plan/analysis year 
combination and then calculate stage-damage functions in FDA follows: 
 
 (1) For each damage reach, FDA calculates the range of stages at the 

index location.  The stages represent the range from very frequent 
to very infrequent events based on the input functions and the 
uncertainty about those functions.  FDA then calculates the interval 
between stage ordinates in "nice" units (1, 2, or 5 multiplied by 10 
raised to some power).  A maximum of sixty ordinates can be 
selected. 

 
 (2) For the selected plan/analysis year, FDA filters the structures using 

the structure module assignments so that it will process only those 
structures which are assigned to the selected module(s).  It also 
filters the structures based on the "Year in Service". 

 
 (3) FDA processes each of the filtered structures.  It transforms the 

tabulation stages that were determined in Step 1 from the index 
location to the structure.  The transformation uses either the water 
surface profiles or the SID reference flood. 

 
 (4) FDA checks each structure to see if it has invalid data and to see if 

the structure is "out of the floodplain".  FDA will immediately 
proceed to the next structure if either case exists. 

 
 (5) FDA determines the damage category, structure occupancy type, 

and damage reach, and then computes stage-damage at each of the 
tabulation stages for a structure.  Damage is computed for the 
structure, contents, other, and total.  The damage for each 
tabulation stage is then aggregated to the index location.  During 
calculations, the stage-aggregated damage functions are stored in 
memory.  After all of the filtered structures are processed, the 
stage-aggregated damage functions are stored in the FDA study 
files. 
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F.2 Introduction 
 
This Appendix describes and illustrates the calculation procedures used by 
FDA to compute stage-aggregated damage at the index location.  The 
calculations require you to already have entered supporting data.  FDA 
follows the general procedures described previously in the User's Manual 
and illustrated in this Appendix.  Calculations are performed by a 
plan/analysis year combination, if you select more than one plan/analysis 
year combination; FDA processes each one independently and loops 
through all selected combinations. 
 
For discussion purposes in this Appendix, an imaginary study is created on 
Silver Creek.  The study area is divided into five reaches as shown in 
Table F.1.  There is an overlap of reaches SC 2L and SC 2La.  That is, 
they represent the same stream (Silver Creek), station range (20.002 
through 29.998), and bank (Left).  Discussions later on will illustrate 
situations where this can be used to your advantage.  For now, the 
discussion will center on computing stage-damage for several structures 
(located on the right bank) within reach SC 2R.  The index point is located 
at station 25.000 (river mile 25.000).  The stage-damage function for each 
structure is aggregated to the index location. 
 

Table F.1 
List of Damage Reaches for Silver Creek 

 

Reach 
Name 

Beginning 
Station 

Ending 
Sation Bank 

Index 
Location 
Station Description 

SC1 20.000 20.001 Left 20.000 Bottom of study area.  RM 20.000 
SC 2L 20.002 29.998 Left 25.000 Reach SC 2L, Sliver Crk.  Left Bank 
SC 2La 20.002 29.998 Left 25.000 Reach SC 2La, Sliver Crk.  Parrallels Reach 

SC 2L.  Protected by Levee. 
SC 2R 20.000 30.000 Right 25.000 Reach SC 2R, Silver Crk.  Right bank. 
SC 3 29.999 30.000 Left 30.000 Top of study area.  RM 30.0 

F.3 Setting Up the Calculation Procedures 
 
Initially, FDA builds storage locations in memory for the stage-aggregated 
damage functions.  It determines the total number of damage reaches for 
all streams and the number of damage categories.  For each reach, it 
determines the range of stages required to cover the entire range of events 
from frequent to infrequent.  It attempts to determine this range first by 
retrieving the discharge-exceedance probability and stage-discharge 
functions (or stage-probability function).  If these are not available, it 
retrieves the water surface profile information.  If this is not available, 
FDA cannot determine the required range of stages at the index location 
and the calculation procedures will not proceed. 
 

 F-3 
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To initialize and scale the stage-aggregated damage matrix, FDA must 
retrieve the discharge-exceedance probability and stage-discharge 
functions for reach SC 2R.  Table F.2 lists Log Pearson Type III Statistics 
for the hypothetical damage reach SC 2R.  The number of years is the  
 

Table F.2 
Log Pearson Type III Statistics for Damage Reach SC 2R 

 
Mean 3.000 
Standard Deviation 0.200 
Skew 0.400 
Number of Years 50 

 
equivalent length of record and is a measure of the uncertainty in the 
statistics.  FDA computes discharge-exceedance probability curve 
ordinates as shown in Table F.3.  Although these are generated from Log 
Pearson Type III Statistics, they could have been generated from either  
 

Table F.3 
Probability Ordinates, Damage Reach SC 2R 

 
Probability Discharge 95% 5% 

0.9990 312 240 378
0.9900 393 315 464
0.9500 496 413 571
0.9000 567 483 646
0.8000 675 587 758
0.7000 770 679 859
0.5000 970 869 1,080
0.3000 1,243 1,115 1,403
0.2000 1,456 1,297 1,670
0.1000 1,834 1,606 2,168
0.0400 2,377 2,028 2,927
0.0200 2,833 2,369 3,595
0.0100 3,335 2,734 4,355
0.0040 4,081 3,263 5,530
0.0020 4,711 3,698 6,555
0.0010 5,410 4,170 7,725
0.0001 8,306 6,046 12,868

 
synthetic statistics or from graphical coordinates.  For scaling, FDA uses 
the extreme ordinates of flow corresponding to probabilities 0.999 and 
.0001 which represent return intervals of about one and 1,000 years.  For 
risk analysis, discharges corresponding to the 95% (240 cfs) and 5% 
(12,868 cfs) confidence limit curves are used for computing the required 
scaling for stage-damage computations.  Figure F.1 depicts the discharge-
exceedance probability curve with confidence limits. 
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Once the discharge-exceedance probability curve is retrieved and the 
extreme discharge values are determined, the stage-discharge function is 
retrieved and used to determine the corresponding stages.  Figure F.2 
graphs the stage-discharge rating curve for reach SC 2R.  Table F.4 (page 
F-6) lists the stage-discharge ordinates for reach SC 2R.  They were  
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Figure F.2  Stage-Discharge Function for Damage Reach SC 2R 
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Table F.4 
Stage-Discharge Function for Damage Reach SC 2R 

 
Discharge Stage -2 SD +2 SD 

0 200.00 200.00 200.00
970 220.00 218.75 221.25

1,456 225.50 223.91 227.09
1,834 227.80 226.06 229.54
2,377 229.70 227.84 231.56
2,833 230.80 228.88 232.73
3,335 232.00 230.00 234.00
4,081 233.00 231.00 235.00
4,711 234.00 232.00 236.00
7,000 236.50 234.50 238.50
8,000 237.50 235.50 239.50

 
computed from water surface profiles.  Since FDA will not extrapolate the 
rating curve, additional points beyond the standard eight profiles were 
calculated for very high discharges of 7,000 and 8,000 cfs.  Stages are 
interpolated from this table using the extreme discharges of the probability 
function with the extreme stages from the rating curve.  The discharges of 
240 cfs and 12,868 cfs correspond to stages of 204.64 and 239.5.  Note 
that the maximum stage is truncated at the highest value on the rating 
curve for two standard deviations.  FDA then calculates a range of stages 
that meet the following criteria: 
 
 ● encompass the range of stages from 204.64 through 239.5 feet. 
 ● have an interval that is either one, two, or five times ten0 raised to 

some power.  For example, 2.0x10-1 creates an array of stages 0.2 
feet apart. 

 ● have at least twenty but not more than thirty ordinates (this is an 
input option that you can change to allow a maximum of sixty 
ordinates).  For this example, both the minimum and maximum 
number of ordinates was set to thirty. 

 
For example, the stages in the stage-aggregated damage matrix for reach 
SC 2R are computed as: 
 
 ● thirty ordinates 
 ● Minimum stage is 204.0 feet 
 ● Maximum stage is 262.0 feet 
 ● Interval between stages is 2.0 feet 
 
FDA now allocates memory for the array of stages and additional space 
for the corresponding aggregated damage and uncertainty (which will be 
computed) for all damage categories and stores the stages in this block of 
memory.  All reaches are processed in the same manner as reach SC 2R. 
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If the discharge-exceedance probability and/or stage-discharge functions 
are not stored in the database, FDA determines the range of stages from 
the water surface profile information.  However, the default profiles 
include only a range of probability starting at 0.50.  The resulting stage 
range could easily start too high.  For example, if the functions were not 
available for reach SC 2R, the use of profile information would result in 
an array of thirty stages ranging from 219.0 to 248.0 feet at an interval of 
1.0 feet.  This may cause truncation of damage for infrequent events. 
 
 

F.4 Computing Stage-Damage at Individual Structures 
Without Uncertainty 

 
Once memory is allocated for the stage-aggregated damage matrices and 
the range of stages is determined for all reaches and all damage categories, 
FDA begins processing all structures that meet the plan/ analysis year 
filter.  The plan year filter selects all structures which belong to the same 
structure modules that have been assigned.  By default, the Base module is 
always included although it may be an empty module (no structures 
assigned to this module).  By default, each structure is assigned to the 
Base module but it may be overridden.  This section describes the 
processes and calculations at several structures which meet the 
plan/analysis year filter. 
 
 

F.4.1 Calculating the Assumed Water Surface Profile 
Elevations at the Structure 

 
Stage-damage at one structure is computed by calculating the water 
surface profile stages at the structure, determining the depth of flooding, 
and calculating the damage using values (structure, content, other) and 
depth-damage functions.  The assumed stages at the structure correspond 
to the stages in the stage-aggregated damage function at the index location 
after adjusting for the slope of the water surface profile(s) between the 
index location and the structure.  If the calculations use the water surface 
profiles (the eight standard profiles), the stages are adjusted using all eight 
profiles.  If the SID reference flood water surface profile is used, then only 
one profile is used to adjust the stages. 
 
 

 Description of Sample Data - Profiles and Structures 
 
Table F.5 lists the water surface profile stages at three cross-sections 
(station 20.0, 25.0, and 30.0).  Stages are tabulated under their associated 
probability.  For example, at station 25.000 (river mile 25.000), the stage 
for the 0.01 probability event (100 year return interval) is 232.0 feet.   
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Table F.5 
Stage Water Surface Stage Profiles, Without Condition 

 
Station Invert 0.500 0.200 0.100 0.040 0.020 0.010 0.004 0.002
20.000 150.0 158.0 161.2 163.1 164.7 165.9 166.7 167.1 167.3
25.000 200.0 220.0 225.5 227.8 229.7 230.8 232.0 233.0 234.0
30.000 209.0 236.0 246.0 252.0 257.6 261.6 264.6 266.6 267.6
 
Figure F.3 graphically displays these same values.  At the lower end of the 
study area (station 20.000), the profiles are relatively close compared to 
the upper end.  The index location for reach SC 2R is at station 25.000.  

To illustrate the aggregation process, three identical structures are used to 
calculate damage - one at the index location (station 25.000), and one at 
each of the extreme limits of the study (station 20.000 and 30.000).  Table 
F.6 (page F-9) lists the appropriate characteristics for each structure.  The 
first floor stage of each structure is located at the same stage as the 10% 
chance event.  This will help illustrate several points about the calculations 
including using the eight water surface profiles as opposed to just the SID 
reference flood profile, having nonparallel profiles, and the location of 
each structure as defined by the structure station.  Each structure is valued 
at $100,000.  The contents are valued at $50,000 and it is calculated using  
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Table F.6 
Structure Characteristics for Aggregation 

 
Characteristic Structure 

Name R0001 R002 R003 
Station 20.000 25.000 30.00
Structure Value 100 100 100
Content Value   
Other Value   
Bank R R R
Damage Category SF Residential SF Residential SF Residential
Occupancy Type SF OS NB SF OS NB SF OS NB
Stream Silver Creek Silver Creek Silver Creek
Module Base Base Base
First Floor Stage 163.1 227.8 252.0

 
the global "ratio of content-to-structure value" which is defined within 
occupancy type SF OS NB which also contains the depth-percent damage 
functions.  All three structures are located on the right bank. 
 
 

 Calculating Sample Aggregation Stages 
 
To determine the assumed (or aggregated) water surface stages at each 
structure, the water surface profiles are used to generate a family of 
profiles which correspond to the aggregation (tabulation) stages at the 
index location.  For structure R002 which is located at the index location, 
the assumed water surface stages correspond exactly to the aggregation 
stages.  For structures R001 and R003, the assumed stages at the structure 
must be calculated.  For aggregation stages above the rarest event (.002) or 
below the most frequent event (.500), aggregation profiles are parallel to 
the adjacent probability profile (.002 and .500 probability events 
respectively).  Aggregation profiles between these two extremes are 
calculated using simple ratios of the computed water surface profiles.  
Table F.7 (page F-10) lists the aggregation profile stages at river mile 
20.000, 25.000, and 30.000 which correspond to the three hypothetical 
structures.  The lowest profile (.500 probability) is at stage 220.0 at the 
index location.  All aggregation profiles below this minimum are parallel.  
For example, the .500 probability profile drops 62.0 feet from 220.0 at the 
index location to 158.0 feet at station 20.0.  The same is true of the lowest 
aggregation profile which drops from 204.0 feet at the index location to 
142.0 feet at station 20.00.  Aggregation profiles above the maximum 
water surface profile are parallel to the 0.002 probability profile which 
reaches 234.0 feet at the index location.  Aggregation profiles between 
220.0 and 234.0 feet are computed using ratios.  For example, the 
aggregation profile which has a stage of 230.0 feet at the index location 
has stages of 165.03 and 258.69 at river mile 20.000 and 30.000 
respectively.  Figures F.4 (page F-11) and F.5 (page F-12) depict selected  
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water surface profiles and aggregation 
profiles for river miles 20.000 through 
30.000 and 25.000 through 30.000 
respectively.  Note that the aggregation 
profile for a stage of 210.0 at the index 
location actually crosses below the 
invert at river mile 20.000 because the 
water surface slope is much greater than 
the invert. 
 
 

 Aggregation Methodologies 
 
There are two methods for aggregating 
stage-damage to the index location.  The 
difference between the two is the source 
of water surface profiles.  The sources 
are: 
 
 ● The set of eight water surface 

profiles. 
 ● The SID reference flood water 

surface profile. 
 
The use of the eight water surface 
profiles facilitates accurate calculations 
when water surface profiles are not 
parallel.  The use of the SID reference 
flood profile facilitates calculations 
using the old HEC-SID methodologies 
or calculations which require special 
circumstances.  These circumstances 
might include: 
 
 ● No profiles are available and water surface profiles are assumed to 

be flat. 
 ● The profiles in the over-bank area are significantly different than 

those in the channel and a separate "stream" is not used. 
 
Results using the single SID reference flood profile are identical to using 
eight parallel water surface profiles. 
 
 

Table F.7 
Aggregation Profiles at Selected 

Locations 
 

 River Mile (station) 
 20 25 30 

1 142.00 204.00 220.00 
2 144.00 206.00 222.00 
3 146.00 208.00 224.00 
4 148.00 210.00 226.00 
5 150.00 212.00 228.00 
6 152.00 214.00 230.00 
7 154.00 216.00 232.00 
8 156.00 218.00 234.00 
9 158.00 220.00 236.00 

10 159.16 222.00 239.64 
11 160.33 224.00 243.27 
12 161.61 226.00 247.30 
13 163.27 228.00 252.59 
14 165.03 230.00 258.69 
15 166.70 232.00 264.60 
16 167.30 234.00 267.60 
16 169.30 236.00 269.60 
18 171.30 238.00 271.60 
19 173.30 240.00 273.60 
20 175.30 242.00 275.60 
21 177.30 244.00 277.60 
22 179.30 246.00 279.60 
23 181.30 248.00 281.60 
24 183.30 250.00 283.60 
25 185.30 252.00 285.60 
26 187.30 254.00 287.60 
27 189.30 256.00 289.60 
28 191.30 258.00 291.60 
29 193.30 260.00 293.60 
30 195.30 262.00 295.60 

 Data Requirements for Aggregation 
 
The following data are required for aggregation using the eight water 
surface profiles: 
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canDo8profiles = false
canDoSIDprofile = false

canDoSIDprofile = true

canDoSIDprofile = false

canDo8profiles = false

canDo8profiles = true

If Ref. Flood Stage at 
structure and at index location is 

valid and reach is valid

Station at structure is valid 
and Reach is valid and stations 

at index location is valid

Yes

No

Yes

No

Figure F.4  Logic for Testing Data Validity of Aggregation Methodologies 
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 ● The structure must be assigned a valid stream, station, and bank. 

, 

 ● ed which embodies location criteria 

 ● A set of water surface profiles must be entered for the desired plan
analysis year, and stream.  The cross-section stationing must 
include the structure station. 
A damage reach must be defin
of stream, bank, and beginning/ending stations that encapsulate 
those specified for the structure. 

Figure F.5  Logic for Determining Aggregation Methodology 

use8profiles = true
useSIDprofile = false

use8profiles canDo8profiles Aggregate using 8 profiles

canDoSIDprofile Aggregate using SID 
reference flood profiles

Can not aggregate

useSIDprofile canDoSIDprofile

canDo8profiles

Aggregate using SID 
reference flood profiles

Aggregate using 8 profiles

Can not aggregate

Can not aggregate Can not aggregate

Yes Yes

Yes

No

No

Yes

No

Yes

No

Yes

No

No
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The following data are required for aggregation using the SID reference 
flood water surface profile: 
 
 ● SID reference flood water surface stage at the structure. 
 ● SID reference flood water surface stage at the index location. 
 
SID reference flood water surface profile data is normally defined through 
import procedures and include importing either: 
 
 ● An old SID input data file. 
 ● Tab-delimited text file. 
 
The SID reference flood stage may be entered in the GUI for the structure 
but not for the index location - it must be defined either through import or 
using commercial database software such as Visual dBASE. 
 
 

 Selecting the Aggregation Methodology 
 
You select the desired methodology you wish to use for aggregation.  To 
use the SID reference flood for aggregation purposes, the analysis must 
check the box Use SID Ref Flood for each plan/analysis year 
combination.  If the box is not checked, then the eight water surface 
profiles are used.  However, if the structure does not satisfy the data 
requirements for the desired methodology, FDA attempts to use the 
alternate methodology if data is available.  This allows a mixture of 
methodologies within a selected plan/analysis year.  Figure F.4 (page  
F-11) depicts the logic that FDA uses for determining the possible 
aggregation methodologies for the selected structure.  When aggregating 
damage at a structure, FDA determines the possible methodologies using 
the logic of Figure F.4 (page F-11) and then uses the logic of Figure F.5 
(page F-12) for calculation purposes. 
 
 

F.4.2 Computing Damage for One Aggregation Stage 
Without Uncertainty 

 
 

 Overview 
 
Damage is calculated at the structure for each of the stages listed in Table 
F.7 (page F-10).  In this example, the three structures are located at 
stations 20.000, 25.000, and 30.000 and the corresponding stages are 
tabulated.  If a structure is located between any of these stations, FDA will 
make the appropriate interpolations.  The FDA computation algorithm 
assumes the highest stage first (262.00 at the index location) and descends  
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to the lowest (204.00 at the index location).  If calculated damage is zero 
for three consecutive stages, FDA assumes the zero-damage point has 
been reached and terminates calculations for the current structure.  The 
calculation procedures accept as input the basic structure information as 
well as the associated data such as damage category and structure 
occupancy type.  The following data is used as input to the calculations: 
 
 Structure Information 
 ● Stream 
 ● Station 
 ● Bank 
 ● Optional SID data (SID reach name, reference flood stage) 
 ● First Floor Stage (or ground stage and foundation height) 
 ● Beginning damage depth (optional) 
 ● Damage Category Name 
 ● Structure Occupancy Type Name 
 ● Depth-Direct Dollar Damage Functions for this structure 

(optional) 
 ● Module 
 ● Number of Structures 
 ● Values (structure, content, other) 
 ● Year in Service 
 
 Related Information from the following: 
 ● Damage Category 
 ● Price Index (optional) 
 
 ● Structure Occupancy Type 
 ● Depth-Damage Functions (structure and/or content and/or 

other) with optional uncertainty parameters. 
 ● Content to Structure Value Ratio (percent) 
 ● Other to Structure Value Ratio (percent) 
 ● Uncertainty Parameters 
 ● First Floor Stage 
 ● Structure Value 
 ● Content to Structure Value Ratio 
 ● Other to Structure Value Ratio 
 
 ● Streams 
 ● Stream Name 
 
 ● Damage Reaches 
 ● Stream 
 ● Bank (left, right, or both) 
 ● Stations - Beginning and Ending 
 ● Reach Name (Used with SID reach names) 
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Other data/information may be entered for the structure, but it is not 
currently used in the computations.  Some of the above data overlaps.  For 
example, you may define the first floor stage directly, or you may define it 
using the ground stage and the foundation height. 
 
The example data set includes the occupancy type Single Family 
Residential, without basement.  Table F.8 lists the depth-percent damage 
functions for the Single Family, Residential, without basement (SF OS 
NB) structure occupancy type.  The functions are specified for structure  
 

Table F.8 
Single Family, Residential, Without Basement 
Structure Occupancy Type Damage Function 

 
 

Depth 
(feet) 

Structure 
(percent 
damage) 

Contents 
(percent 
damage) 

-1 0 0 
0 5 2 
1 7 5 
2 10 15 
5 25 50 

10 50 80 
15 70 90 
20 80 95 

 
and content but there is no damage to other.  Figure F.6 depicts these same 
functions. 
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Figure F.6 Single Family, Residential, Without Basement Structure 
Occupancy Type Data Function 
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Figure E.7 depicts the FDA stage-damage calculation procedure.  The 
aggregation profiles (shown in Figure F.8 (page F-17), Figure F.9 (page  
F-17) and Table F.7 (page F-10) are used to compute the "Assumed Water 
Surface Elevation at the Structure" (or Aggregation Stage) which is used 
to compute the depth of flooding. Figure F.7 depicts the process for one 
ordinate at one structure without using risk analysis procedures. 

Get Structure 
Information (first 

floor stage, value, 
etc.)

Get Water Surface 
Profiles for 

Structure’s Stream

Select Assumed Water Surface 
Elevation at the Index Location 

(aggregation stage)

Compute the Assumed Water 
Surface Elevations at the 

Structure (aggregation stage) 
using the Aggregation Profiles

Adjust Structure Value for 
price index

Adjust Content Value for price 
index

Adjust Other Value for price 
index

Compute Depth of Flooding 
(assumed WSP stage minus first 

floor stage)

A

Structure Value

Content Value

Other Value

First Floor Stage 
for Structure

A

Compute Percent Damage to 
Structure from depth of flooding 

and depth-damage function

Compute Percent Damage to 
Contents from depth of flooding 

and depth-damage function

Compute Percent Damage to 
Other from depth of flooding and 

depth-damage function

Compute Structure Damage 
(Structure Value times Percent 

Damage)

Compute Contents Damage 
(Contents Value times Percent 

Damage)

Compute Other Damage (Other 
Value times Percent Damage)

Accumulate the Damage for 
Structure, Contents, and Other

Structure Depth-
Damage Function

Contents Depth-
Damage Function

Other Depth-
Damage Function

Figure F.7  Calculating Stage-Damage Without Uncertainty, One Ordinate 
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Figure F.8  Selected Aggregation and Water Surface Profiles RM 20.00 – 30.00 
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 Procedure for Calculating Stage-Damage Without 
Uncertainty 

 
The following section describes the stage-damage calculations depicted in 
Figure F.7 (page F-16) in more detail.  Table F.9 lists and Figure F.10 
(page F-19) graphs results for structure R003.  FDA writes this table to the 
file FDA_SDmg.out if the trace option is set to ten or greater.  In this 
example, the "mean depth" and the "nominal depth" are the same because 
there is no uncertainty in the economic functions.  Some of the following 
narrative describes results for the highest aggregation stage. Table F.9 lists 
results for all stages. 
 

Table F.9 
Stage-Damage Without Uncertainty for Structure R003 

 
Structure:  R0003 
Stream:  Sliver Creek 
Reach:  SC 2R 
Category:  SF Residential 
Address: 
City: 
State: 

 
 

Index 

WS Elev 
@  

Index 

WS Elev 
@  

Structure 

 
Nominal 

Depth 

 
Mean 
Depth 

 
Structure 
Damage 

 
Content 
Damage 

 
Other 

Damage 

 
Total 

Damage 
1 204.00 220.00 -32.00 -32.00 $0.00 $0.00 $0.00 $0.00 
2 206.00 222.00 -30.00 -30.00 $0.00 $0.00 $0.00 $0.00 
3 208.00 224.00 -28.00 -28.00 $0.00 $0.00 $0.00 $0.00 
4 210.00 226.00 -26.00 -26.00 $0.00 $0.00 $0.00 $0.00 
5 212.00 228.00 -24.00 -24.00 $0.00 $0.00 $0.00 $0.00 
6 214.00 230.00 -22.00 -22.00 $0.00 $0.00 $0.00 $0.00 
7 216.00 232.00 -20.00 -20.00 $0.00 $0.00 $0.00 $0.00 
8 218.00 234.00 -18.00 -18.00 $0.00 $0.00 $0.00 $0.00 
9 220.00 236.00 -16.00 -16.00 $0.00 $0.00 $0.00 $0.00 

10 222.00 239.64 -12.36 -12.36 $0.00 $0.00 $0.00 $0.00 
11 224.00 243.27 -8.73 -8.73 $0.00 $0.00 $0.00 $0.00 
12 226.00 247.30 -4.70 -4.70 $0.00 $0.00 $0.00 $0.00 
13 228.00 252.59 0.59 0.59 $6.18 $1.88 $0.00 $8.06 
14 230.00 258.69 6.69 6.69 $33.45 $30.07 $0.00 $63.53 
15 232.00 264.60 12.60 12.60 $60.40 $42.60 $0.00 $103.00 
16 234.00 267.60 15.60 15.60 $71.20 $45.30 $0.00 $116.50 
17 236.00 269.60 17.60 17.60 $75.20 $46.30 $0.00 $121.50 
18 238.00 271.60 19.60 19.60 $79.20 $47.30 $0.00 $126.50 
19 240.00 273.60 21.60 21.60 $80.00 $47.50 $0.00 $127.50 
20 242.00 275.60 23.60 23.60 $80.00 $47.50 $0.00 $127.50 
21 244.00 277.60 25.60 25.60 $80.00 $47.50 $0.00 $127.50 
22 246.00 279.60 27.60 27.60 $80.00 $47.50 $0.00 $127.50 
23 248.00 281.60 29.60 29.60 $80.00 $47.50 $0.00 $127.50 
24 250.00 283.60 31.60 31.60 $80.00 $47.50 $0.00 $127.50 
25 252.00 285.60 33.60 33.60 $80.00 $47.50 $0.00 $127.50 
26 254.00 287.60 35.60 35.60 $80.00 $47.50 $0.00 $127.50 
27 256.00 289.60 37.60 37.60 $80.00 $47.50 $0.00 $127.50 
28 258.00 291.60 39.60 39.60 $80.00 $47.50 $0.00 $127.50 
29 260.00 293.60 41.60 41.60 $80.00 $47.50 $0.00 $127.50 
30 262.00 295.60 43.60 43.60 $80.00 $47.50 $0.00 $127.50 
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Figure F.10  Stage-Damage Without Uncertainty for Structure R003 
 
 (1) Get Structure Information 
 Retrieve structure data from the database.  Includes first floor 

stage, value of structure, contents, and other, etc.  Table F.6 
(page F-9) lists some of the sample structure information. 

 
 (2) Get water surface profiles for the structure's stream 
 Each structure is assigned a stream.  The profiles for the 

current structure are retrieved from the database.  For the 
example, all structures are on "Silver Creek".  If profiles do 
not exist for Silver Creek, the SID reference flood profile 
may be used.  The example structures all use the water 
surface profiles as listed in Table F.5 (page F-8). 

 
 (3) Select Assumed Water Surface Elevation at the Index Location 

(Aggregation Stage) 

 F-19 
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 The assumed (or aggregation) stages are listed in Table F.7 
(page F-10).  The index location is at river mile 25.000.  The 
aggregation stages range from 204.0 to 262.0 feet. 

 
 (4) Compute the Assumed Water Surface Stage at the Structure 

using the aggregation profiles 
 The assumed (or aggregation stages) are calculated at the 

structure using the profiles listed in Table F.5 (page F-8). 
Table F.7 (page F-10) lists the tabulation stages at the index 
as well as at river mile 20.000 and 30.000 which correspond 
to structures R001, and R003.  For example, an aggregation 
stage of 236.0 at the index translates into a stage of 269.6 at 
structure R003.  Stages may be interpolated for any river mile 
between 20.000 and 30.000. 

 
 (5) Adjust structure value for price index 
 The price index is entered as a global value under "File/Study 

Information".  The price index may also be entered by 
damage category and it will over-ride the global value.  If left 
blank (undefined) the global study price index is used.  The 
price index is simply multiplied by the structure value which 
is stored in the database to obtain an updated value for 
calculation purposes.  The value in the database is not 
changed.  For this example, the price index is 1.0 and the 
value for structure R003 is $100k * 1.0 or $100k. 

 
 (6) Adjust contents value for price index 
 Contents value is adjusted in a similar manner to the structure 

value.  The content value must first be determined.  For 
indirect depth-damage functions (using percent damage), it 
can be computed using the ratio of content-to-structure value 
entered with the occupancy types.  This calculation can be 
over-ridden by entering a dollar value at individual 
structures.  At the structure level, if the contents value is left 
blank (undefined), the occupancy code ratio is used.  For 
structures having a direct depth-damage function (damage is 
in thousands of dollars), the content value is not used for 
calculations since damage is computed directly from the 
depth-damage function. 

 
 (7) Adjust “other” value for price index 
 Other value is computed in the same fashion as the contents. 
 
 (8) Compute depth of flooding (assumed WSP stage minus first 

floor stage) 
 The assumed (aggregation) stages computed above are used 

to determine the depth of flooding.  For the example structure 
R003, the aggregation stage of 236.0 at the index location 
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translates into a stage of 269.6 at the structure which 
translates into a depth of 17.6 feet (first floor stage is 252.0 
feet). 

 
 (9) Compute percent damage to structure from depth of flooding 

and depth-damage function 
 The percent structure damage is computed using the depth of 

flooding (17.6 feet) from step 8 and the depth-percent 
damage function from occupancy type “SF OS NB”.  The 
resulting percent structure damage for a depth of 17.6 feet is 
75.2%.  FDA does not extrapolate depth-damage functions 
for depths beyond the defined depth range.  For example, the 
maximum structural damage is 80% of the structure value. 

 
 (10) Compute percent damage to contents from depth of flooding 

and depth-damage function 
 The percent contents damage is computed in a manner 

similar to that for structure damage. 
 
 (11) Compute percent damage to other from depth of flooding and 

depth-damage function 
 The percent other damage is computed in a manner similar to 

that for structure damage. 
 
 (12) Compute structure damage (structure value times percent 

damage) 
 The structure damage is computed using the depth of 

flooding (17.6 feet) from step 8 and the structure value 
($100k) from step 5 and the percent damage (75.2%) for the 
depth of flooding from occupancy type “SF OS NB” from 
step 9.  The resulting damage is:  $100k * 0.752 = $75.2k 

 
 (13) Compute contents damage (contents value times percent 

damage) 
 The contents damage is computed in a manner similar to that 

for structure damage. 
 
 (14) Compute other damage (other value times percent damage) 
 The other damage is computed in a manner similar to that for 

structure damage. 
 
 (15) Accumulate the damage for structure, contents and other. 
 The structure, contents, and other damage is accumulated for 

the selected stream-reach, and category.  When all 
calculations are complete, the results are stored in the 
database for the calculation plan and year and are stored 
separately for each stream-reach, damage category, and type 
(structure, contents, other, and total). 
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F.5 Computing Stage-Damage at One Structure with 
Uncertainty 

 
 

F.5.1 Overview 
 
This section describes the calculation of stage-damage for structures 
whose economic parameters have uncertainty.  The calculations are 
similar to those when there is no uncertainty except that one or more 
parameters or functions are sampled.  When there is no uncertainty, 
calculations are done only once for each assumed (aggregation) stage.  
When uncertainty is included, the calculations must be performed 
repetitively for each assumed water surface stage (and associated depth of 
flooding).  Figure F.11 (page F-23) depicts the calculation procedures for 
one structure with uncertainty.  Although similar to Figure F.7 (page  
F-16), Figure F.11 (page F-23) not only reflects risk analysis computations 
but also depicts the calculation loop for all aggregation ordinates as well 
as multiple iterations when a single structure record represents multiple, 
identical structures. 
 
 

F.5.2 Risk Analysis Calculations 
 
The repetitive risk analysis calculations are done within the simulation 
loop.  FDA makes 100 simulations at each stage but you can change this 
using the Compute Stage-Damage options.  You may specify uncertainty 
parameters for the first floor stage, structure value, content value, other 
value, and damage in the depth-damage functions.  Each of the 
uncertainties is defined by one or more parameters and an associated 
distribution.  Allowable distributions include normal, log-normal, and 
triangular.  For example, to describe the uncertainty in the first floor stage, 
you may define a normal distribution with a standard deviation of 0.3 feet.  
For each simulation, FDA samples this first floor distribution to derive a 
simulated first floor stage with error.  Similar procedures are used for 
values (structure, content, other) and the damage in the depth-damage 
functions. 
 
 

F.5.3 Identical Structures 
 
The calculation loop for identical structures allows you to enter data for 
one structure but specify that it represents several structures which have 
identical characteristics (first floor stage, value, occupancy type, etc.).  
You enter an integer which is greater than one for Number of Structures.   



HEC-FDA User's Manual Appendix F – Procedures for Computing Stage-Damage Functions 

Figure F.11  Calculating Stage-Damage Without Uncertainty for One Structure 
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FDA takes one structure record and iterates the calculation loop "Number 
of Structures" times.  Each iteration is treated as a new structure with full 
Monte-Carlo simulation but uses the same structure information such as 
first floor stage, structure value, occupancy type, etc. 
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F.5.4 Detailed Description of Stage-Damage Calculation 

with Uncertainty 
 
The following section describes in detail the stage-damage calculations 
depicted in Figure F.11 (page F-23).  It is similar to the previous section 
on calculations without uncertainty.  Table F.10 lists the uncertainty 
parameters for this example.  Table F.11 (page F-25) lists results for 
structure R003. 
 

Table F.10 
Uncertainty Parameters for Example Problem 

 
Parameter Distribution Std. Dev. 

First Floor Stage Normal 0.3 feet
Structure Value Normal 10%
Contents Value Ratio Normal 20%
Damage in Depth-Damage Function Normal 5%

 
FDA writes this table to the file FDA_SDmg.out if the trace option is set to 
ten or greater.  In this example, the "mean depth" and the nominal depth 
are not the same because there is uncertainty in the first floor stage.  The 
nominal depth is the depth when no uncertainty is used whereas the mean 
depth is the calculated 
mean depth after Monte-
Carlo simulations.  Some 
of the narrative below 
describes results for the 
highest aggregation stage. 
Figure F.12 depicts the 
computed stage-damage 
with uncertainty function 
for structure R003. 
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 (1) Get structure 

information. 
 Retrieve 

structure data 
from the 
database.  This 
includes first 
floor stage, 
value of 
structure, 
contents, and other, etc.  Table F.6 (page F-9) lists some of the 
sample structure information. 
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Figure F.12 Stage-Damage With Uncertainty for 
Structure R003 
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Table F.11 
Stage-Damage Without Uncertainty for Structure R003 

 
Structure:  R0003 
Stream:  Sliver Creek 
Reach:  SC 2R 
Category:  SF Residential 
Address: 
City: 
State: 

 
 

Index 

WS Elev 
@  

Index 

WS Elev 
@  

Structure 

 
Nominal 

Depth 

 
Mean 
Depth 

 
Structure 
Damage 

 
Content 
Damage 

 
Other 

Damage 

 
Total 

Damage 
1 204.00 220.00 -32.00 -32.00 $0.00 $0.00 $0.00 $0.00 
2 206.00 222.00 -30.00 -30.00 $0.00 $0.00 $0.00 $0.00 
3 208.00 224.00 -28.00 -28.00 $0.00 $0.00 $0.00 $0.00 
4 210.00 226.00 -26.00 -26.00 $0.00 $0.00 $0.00 $0.00 
5 212.00 228.00 -24.00 -24.00 $0.00 $0.00 $0.00 $0.00 
6 216.00 230.00 -22.00 -22.00 $0.00 $0.00 $0.00 $0.00 
7 215.00 232.00 -20.00 -20.00 $0.00 $0.00 $0.00 $0.00 
8 218.00 234.00 -18.00 -18.00 $0.00 $0.00 $0.00 $0.00 
9 220.00 236.00 -16.00 -16.00 $0.00 $0.00 $0.00 $0.00 

10 222.00 239.64 -12.36 -12.36 $0.00 $0.00 $0.00 $0.00 
11 224.00 243.27 -8.73 -8.73 $0.00 $0.00 $0.00 $0.00 
12 226.00 247.30 -4.70 -4.70 $0.00 $0.00 $0.00 $0.00 
13 228.00 252.59 0.59 0.59 $6.18 $1.88 $0.00 $8.06 
14 230.00 258.69 6.69 6.69 $33.45 $30.07 $0.00 $63.53 
15 232.00 264.60 12.60 12.60 $60.40 $42.60 $0.00 $103.00 
16 234.00 267.60 15.60 15.60 $71.20 $45.30 $0.00 $116.50 
17 236.00 269.60 17.60 17.60 $75.20 $46.30 $0.00 $121.50 
18 238.00 271.60 19.60 19.60 $79.20 $47.30 $0.00 $126.50 
19 240.00 273.60 21.60 21.60 $80.00 $47.50 $0.00 $127.50 
20 242.00 275.60 23.60 23.60 $80.00 $47.50 $0.00 $127.50 
21 244.00 277.60 25.60 25.60 $80.00 $47.50 $0.00 $127.50 
22 246.00 279.60 27.60 27.60 $80.00 $47.50 $0.00 $127.50 
23 248.00 281.60 29.60 29.60 $80.00 $47.50 $0.00 $127.50 
24 250.00 283.60 31.60 31.60 $80.00 $47.50 $0.00 $127.50 
25 252.00 285.60 33.60 33.60 $80.00 $47.50 $0.00 $127.50 
26 254.00 287.60 35.60 35.60 $80.00 $47.50 $0.00 $127.50 
27 256.00 289.60 37.60 37.60 $80.00 $47.50 $0.00 $127.50 
28 258.00 291.60 39.60 39.60 $80.00 $47.50 $0.00 $127.50 
29 260.00 293.60 41.60 41.60 $80.00 $47.50 $0.00 $127.50 
30 262.00 295.60 43.60 43.60 $80.00 $47.50 $0.00 $127.50 

 
 (2) Get water surface profiles for the structure’s stream. 
 Each structure is assigned a stream.  The water surface profiles 

for the current structure are retrieved from the database.  For the 
example, all structures are on Silver Creek.  If water surface 
profiles do not exist for Silver Creek, the SID reference flood 
profile may be used.  The example structures all use the water 
surface profiles as listed in Table F.5 (page F-8). 

 
 (3) Compute depth and stage of zero damage. 
 FDA looks at the depth-damage functions (structure, content, 

and other) and the optional Beginning Damage Depth to 
determine the highest depth of zero damage.  For the example  
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 structure occupancy type, this is at a depth of -1 feet.  Normally, 
the Beginning Damage Depth is left blank (undefined).  It may 
be defined by individual structure if the damage functions are 
truncated at some depth.  For example, this typically occurs for 
houses with basements where the damage function may start at 
a depth of -8 feet but water may not enter the basement until it 
reaches a depth of -1 foot.  If some barrier prevented water from 
reaching structure R003 before a depth of 1 foot above the first 
floor, then you would define the Beginning Damage Depth as 
+1.0 foot and FDA would set the damage to zero for all 
aggregation depths of 1 foot or less during the Monte-Carlo 
simulations.  The corresponding stage of zero damage is 
computed during the simulations as the sum of the first floor 
stage with error and the Beginning Damage Depth. 

 
 (4) Select assumed water surface elevation at the index location 

(aggregation stage). 
 The assumed (or aggregation) stages are listed in Table F.7 

(page F-10).  The index location is at river mile 25.000.  The 
aggregation stages range from 204.0 to 262.0 feet. 

 
 (5) Compute the assumed water surface stage at the structure using the 

aggregation profiles. 
 The assumed (or aggregation stages) are calculated at the 

structure using the profiles listed in Table F.5 (page F-8).  Table 
F.7 (page F-10) lists the tabulation stages at the index as well as 
at river mile 20.000 and 30.000 which correspond to structures 
R001, and R003.  For example, an aggregation stage of 236.0 at 
the index translates into a stage of 269.6 at structure R003.  
Stages may be interpolated for any river mile between 20.000 
and 30.000. 

 
 (6) For each identical structure, process the following steps: 
 Normally, the subsequent steps are processed once.  If the 

Number of Structures is set to a value greater than one (1), the 
current structure is processed Number of Structures times to 
facilitate a crude sampling of structures.  For example, if 
processed ten times, it is equivalent to entering ten identical 
structures. 

 
 (7) For each aggregation stage. 
 The following steps are repeated for each assumed 

(aggregation) stage.  The stages are listed in Table F.7 (page  
 F-10). 
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 (8) For each simulation (iteration). 
 The following steps are repeated for each Monte-Carlo 

simulation.  FDA currently does 100 simulations, this can be 
adjusted. 

 
 (9) Sample first floor stage. 
 The first floor stage with uncertainty is computed from the first 

floor stage, the uncertainty distribution and the uncertainty 
parameters.  The uncertainty data is defined with the occupancy 
types (indirect depth-percent damage functions) or the structure 
(direct depth-dollar damage functions).  The uncertainty 
parameters are in the same units as the first floor stage.  For 
structure R003 (first floor stage of 252.0), the uncertainty in the 
first floor stage is modeled using the normal distribution with a 
standard deviation of 0.3 feet.  If a sampled error in the first 
floor stage was one standard deviation from the median, the 
sampled first floor stage would be 252.3 feet. 

 
 (10) Sample structure value. 
 The structure value with uncertainty is computed from the 

structure value, the uncertainty distribution, and the uncertainty 
parameters.  The uncertainty data is defined with the occupancy 
types.  If using direct depth-dollar damage functions, the 
structure value is not sampled because it is built into the 
uncertainty of the damage function.  The uncertainty parameters 
are entered in the percent of structure value.  Table F.10 (page 
F-24) lists the uncertainty parameters for the example data.  For 
structure R003 (value $100,000; occupancy code structure value 
error of 10%) a simulation error of one standard deviation 
would result in a sample structure value of $110,000 ($100,000 
+ $10,000 * 1std.dev.).  The use of uncertainty in percent allows 
structures of different values to use the same occupancy type 
and still maintain reasonable errors about the median value.  For 
example, a $200,000 house using the same example occupancy 
type would have a computed standard deviation of error of 
$20,000. 

 
 (11) Sample contents value. 
 Contents value is sampled in a similar manner to the structure 

value.  The content value must first be determined.  For indirect 
depth-damage functions (using percent damage), it can be 
computed using the ratio of content-to-structure value entered 
with the occupancy types.  This calculation can be over-ridden 
by entering a dollar value at individual structures.  At the 
structure level, if the contents value is left blank (undefined), 
the occupancy code ratio is used to compute contents value 
from the structure value.  If using direct depth-dollar damage 
functions, the contents value is not sampled because it is built 
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into the uncertainty of the damage function.  The uncertainty 
parameters are entered in the percent of contents-to-structure 
value ratio.  The occupancy code for this example has a ratio of 
50% for contents-to-structure value ratio.  For structure R003 
(contents value = $100,000 times 50% = $50,000; occupancy 
code has a contents-to-structure value ratio error of 20%) a 
simulation error of one standard deviation would result in a 
sample contents value of $60,000 (error = $50,000 * (.5 +.5 * .2 
* 1 std.dev.)).  The use of uncertainty in percent allows 
structures of different content value to use the same occupancy 
type and still maintain reasonable errors about the median value.  
For example, a $200,000 house using the same example 
occupancy type would have a computed standard deviation of 
error of $20,000. 

 
 (12) Sample other value. 
 Other value is sampled in the same fashion as the contents. 
 
 (13) Adjust values for price index 
 The price index is entered as a global value and the price index 

may also be entered by damage category and it will override the 
global value.  If left blank (undefined) the global study price 
index is used.  The price index is simply multiplied by the 
structure, contents, and other values to obtain updated values for 
calculation purposes.  The values in the database are not 
changed.  For this example, the price index is 1.0 and the value 
for structure R003 is $100k * 1.0 or $100k (no error in structure 
value).  During Monte-Carlo simulation, the price index is 
multiplied by the values with sampling error. 

 
 (14) Compute depth of flooding (aggregation stage minus sample first 

floor stage). 
 The assumed (aggregation) stages computed above and the 

sampled first floor stage are used to determine the depth of 
flooding.  For the example structure R003, the aggregation stage 
of 236.0 at the index location translates into a stage of 269.6 at 
the structure.  If the sampled first floor stage is 252.3, the depth 
of flooding is 17.3 feet (first floor stage without error is 252.0 
feet and with a one standard deviation of error is 252.3 feet). 

 
 (15) Sample structure damage. 
 The sampled structure damage is computed from the sampled 

depth of flooding, and the sampled depth-damage function.  The 
sampled percent structure damage is computed using the depth 
of flooding (17.3 feet) from Step 14 and the depth-percent 
damage function with uncertainty from structure occupancy 
type SF OS NB.  The resulting percent structure damage for a 
sampled depth of 17.3 feet is 74.6 percent (un-sampled damage 
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function) or 78.3 percent (sampled one standard deviation away 
from the median damage).  FDA does not extrapolate depth-
damage functions for depths beyond the defined depth range.  
For this example of structure R003 using the sampled first floor 
stage (252.3), the sampled structure value ($110,000), and the 
sampled depth-percent damage function (78.3 percent damage), 
the structure damage is computed as: 

 
$110,000 * 78.3% = $86,130. 

 
 This can be compared to the same calculation of structure 

damage without uncertainty which was $75,200.  Obviously, it 
is very rare that the sampled parameters would always be +1 
standard deviation away from the median. 

 
 The procedure for sampling structures using direct depth-dollar 

damage functions is the same as for with indirect depth-damage 
functions with the exception that damage is computed directly 
from sampled depth and sampled direct depth-damage 
functions. 

 
 (16) Sample contents damage. 
 The sampled contents damage is computed in a manner similar 

to that for structure damage. 
 
 (17) Sample other damage. 
 The sampled other damage is computed in a manner similar to 

that for structure damage. 
 
 (18) Compute statistics for this aggregation stage and simulation. 
 The statistics for the current aggregation stage for all 

simulations are computed and stored in memory before the 
aggregation stage is decreased for the next simulations. 

 
 (19) Accumulate the damage for structure, contents and other 
 The structure, contents, and other damage is accumulated in 

memory for the selected stream, damage reach, and damage 
category. 

 
 (20) Write detailed information to ASCII text files. 
 When all simulations are completed for the current structure, 

FDA accumulates the current results in memory and writes 
various levels of calculation results to text files FDA_SDmg.out 
(stage-depth-damage by structure and by damage reach/damage 
category), FDA_StrucDetail.out (individual structure results in a 
tab-delimited text file suitable for import), FDA_SDev.out 
(individual structure Monte-Carlo simulation results), and 
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FDA_SdErrors.out (structure data errors).  These files are 
described in later sections. 

 
 (21) Store results in the database. 
 When all calculations are complete, the results are stored in the 

database for the calculation plan and analysis year and are 
stored separately for each stream, damage reach, damage 
category, and structure occupancy type (structure, contents, 
other, and total).  The EAD calculations utilize only the total 
damage for each damage category - not the individual structure, 
contents and other damage functions. 

 
 

F.6 Aggregating the Stage-Damage Functions to the 
Index Location 

 
The process of using either the eight water surface profiles or the SID 
reference flood water surface profile has been described earlier.  Since the 
calculations are done at each structure at the aggregation stages, the results 
(both damage as well as statistics for uncertainty calculations) are easily 
accumulated to the index location. Table F.12 (page F-31) displays the 
total simulated damage for reach SC 2R.  It includes aggregated damage 
for the three residential structures.  Damage categories Commercial, 
Industrial, and Public do not have damage since only residential structures 
have been entered in this reach. 
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Table F.12 
Total Stage-Aggregated Damage,  

Damage Reach SC 2R 
 

Total Aggregated Damage Matrix. 
Stream:  Sliver Creek 
Reach:  SC 2R 

 Stage Commercial Industrial Public SF Residential 
1 204 0.00 0.00 0.00 0.00 
2 206 0.00 0.00 0.00 0.00 
3 208 0.00 0.00 0.00 0.00 
4 210 0.00 0.00 0.00 0.00 
5 212 0.00 0.00 0.00 0.00 
6 214 0.00 0.00 0.00 0.00 
7 216 0.00 0.00 0.00 0.00 
8 218 0.00 0.00 0.00 0.00 
9 220 0.00 0.00 0.00 0.00 

10 222 0.00 0.00 0.00 0.00 
11 224 0.00 0.00 0.00 0.00 
12 226 0.00 0.00 0.00 0.04 
13 228 0.00 0.00 0.00 20.78 
14 230 0.00 0.00 0.00 100.92 
15 232 0.00 0.00 0.00 180.52 
16 234 0.00 0.00 0.00 219.37 
17 236 0.00 0.00 0.00 259.18 
18 238 0.00 0.00 0.00 295.81 
19 240 0.00 0.00 0.00 322.66 
20 242 0.00 0.00 0.00 342.96 
21 244 0.00 0.00 0.00 360.14 
22 246 0.00 0.00 0.00 372.30 
23 248 0.00 0.00 0.00 381.77 
24 250 0.00 0.00 0.00 386.38 
25 252 0.00 0.00 0.00 386.55 
26 254 0.00 0.00 0.00 386.55 
27 256 0.00 0.00 0.00 386.55 
28 258 0.00 0.00 0.00 386.55 
29 260 0.00 0.00 0.00 386.55 
30 262 0.00 0.00 0.00 386.55 
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Appendix G  
 
 
 
 

Stage-Damage Text Output Files 
 
 
 

G.1 General 
 
This Appendix describes the various ASCII delimited files that are written 
outside of HEC-FDA.  Some of these output files are generated only if 
requested by you.  By default, data is written in a tab-delimited format and 
the files can be easily imported into other software programs.  The stage-
damage results and diagnostic information are written to the following 
output files: 
 
 ● FDA_SDmg.out contains stage-damage functions by damage 

reach, damage category, and optionally by structure.  This is often 
referred to as the Trace Output file (see Section G.2, page G-2). 

 
 ● FDA_SdErrors.out contains structure data validation information 

(see Section G.3, page G-7).  This file lists optionally each 
structure and also summary information.  The output indicates 
invalid data (such as unknown damage reach, damage category, 
etc.) as well as structures that were not included in the calculations 
(structure is out of the flood plain; was placed in service after the 
current calculation year). 

 
 ● FDA_StrucDetail.out contains detailed structure information 

including all of the structure’s data (first floor stage, structure value, 
etc.) as well as damage computed for each of the water surface 
profile probabilities.  The damage is computed without 
uncertainty and does not reflect damage reduction due to levees 
which is computed during the expected annual damage 
simulation.  This is often referred to as the Structural Details file 
(see Section G.5, page G-12). 

 
 ● FDA_SDev.out contains detailed results by structure of the Monte-

Carlo simulations for stage-damage.  This is often referred to as the 
Standard Deviation Trace file (see Section G.4, page G-11). 
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G.2 FDA_SDmg.out 
 
FDA_SDmg.out contains stage-damage functions by damage reach, 
damage category, and optionally by structure and is often referred to as the 
Trace Output file. 
 
 

G.2.1 Basic Output 
 
The output displayed in the FDA_SDmg.out file is controlled by a user 
defined trace level.  In Figure G.1, the basic output is the location of the 
FDA_SDmg.out file, time of creation, study name, study description, 
location of study, plan, and analysis year.  From then on the file is broken 
up into tables; information in the tables is determined by the trace level 
that is set. 

 
Figure G.1  Trace Output File (FDA_SDmg.out) 

================================================================================
File S:\Appendices_Staging\BearTrngSdErrors\FDA_SDmg.out opened on Thu Oct 27 11:40:52 2005

Study:        Bear Creek Example Errors
Description:  S. Fork Bear & Buechel Branch
Pathname:     S:\Appendices_Staging\BearTrngSdErrors
Plan:         Without
Year:         2009

Determine Scaling for all reaches (4)  Using Frequency & Rating Functions.
-----------------------------------------------------------------------------------------------------------
Stream Reach Obs Min 

Stage
Obs Max 
Stage

Min Num 
Ords

Max Num 
Ords

Comp Num 
Ords

Comp Min 
Stage

Comp Max 
Stage

Comp 
Interval 
Stage

Buechel Branch BB-4 488.23 496.95 20 30 20 488.0 497.5 0.5
Buechel Branch BB-5 494.99 503.51 20 30 20 494.5 504.0 0.5
S Fork Bear SF-8 463.04 477.76 20 30 20 463.0 482.0 1.0
S Fork Bear SF-9 473.39 485.19 20 30 26 473.0 485.5 0.5

G.2.2 Trace Level Less than Five 
 
 

 Summary Output for Component 
 
The first set of tables in FDA_SDmg.out (see Figure G.2, page G-3) are 
the stage-aggregated damage functions reported by stream and damage 
reach and does not include the computed standard deviation of error in 
damage.  There are four tables associated with this information and are 
broken out by Structure, Content, Other and Total. 
 
 

G-2 
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Figure G.2  FDA_SDmg.out – Stage-Aggregated Damage by Category 

Structure Aggregated Damage Matrix.
Stream: S Fork Bear
Reach: SF-9

Stage APT AUTO COMM PUB RES
1 473.00 0.00 0.00 0.00 0.00 0.00
2 473.50 0.00 0.00 0.00 0.00 0.00
3 474.00 0.00 0.00 0.00 0.00 0.00
4 474.50 0.00 0.00 0.00 0.00 0.00
5 475.00 0.00 0.00 0.00 0.00 0.00
6 475.50 0.00 0.00 0.00 0.00 0.00
7 476.00 0.00 0.00 0.00 0.00 0.00
8 476.50 10.75 0.01 0.00 0.00 0.00
9 477.00 46.61 0.37 0.00 0.00 0.00

10 477.50 84.60 1.55 0.00 0.00 0.00
11 478.00 166.31 4.94 0.00 0.00 2.98
12 478.50 236.65 10.84 0.00 0.00 20.80
13 479.00 309.97 17.64 0.00 0.00 52.92
14 479.50 397.69 35.32 0.09 0.00 83.96
15 480.00 529.52 61.56 1.07 0.00 118.10
16 480.50 679.04 96.84 3.54 0.00 155.17
17 481.00 817.72 152.69 8.95 0.00 211.71
18 481.50 992.09 224.12 66.75 0.00 290.73
19 482.00 1155.44 278.29 135.16 0.00 349.74
20 482.50 1303.29 308.03 201.57 0.00 402.93
21 483.00 1465.72 327.71 293.71 0.00 471.16
22 483.50 1632.64 347.23 400.76 0.00 549.22
23 484.00 1796.49 365.86 483.86 0.98 615.82
24 484.50 1952.49 373.49 533.89 11.23 671.57
25 485.00 2106.32 373.69 582.15 27.62 735.54
26 485.50 2265.40 373.69 629.69 38.31 812.28

Content Aggregated Damage Matrix.
Stream: S Fork Bear
Reach: SF-9

Stage APT AUTO COMM PUB RES
1 473.00 0.00 0.00 0.00 0.00 0.00
2 473.50 0.00 0.00 0.00 0.00 0.00
3 474.00 0.00 0.00 0.00 0.00 0.00
4 474.50 0.00 0.00 0.00 0.00 0.00
5 475.00 0.00 0.00 0.00 0.00 0.00
6 475.50 0.00 0.00 0.00 0.00 0.00
7 476.00 0.00 0.00 0.00 0.00 0.00
8 476.50 5.77 0.00 0.00 0.00 0.00
9 477.00 25.55 0.00 0.00 0.00 0.00

10 477.50 49.54 0.00 0.00 0.00 0.00
11 478.00 97.68 0.00 0.00 0.00 0.80
12 478.50 140.74 0.00 0.00 0.00 7.31
13 479.00 188.54 0.00 0.00 0.00 21.84
14 479.50 242.58 0.00 7.93 0.00 40.34
15 480.00 313.06 0.00 97.71 0.00 66.18
16 480.50 395.02 0.00 312.34 0.00 95.71
17 481.00 477.84 0.00 1098.04 0.00 130.76
18 481.50 582.32 0.00 1833.88 0.00 171.92
19 482.00 679.55 0.00 2638.34 0.00 206.86
20 482.50 771.07 0.00 3558.72 0.00 244.23
21 483.00 868.61 0.00 4335.69 0.00 287.48
22 483.50 968.66 0.00 5253.52 0.00 330.49
23 484.00 1066.86 0.00 6038.74 9.07 368.08
24 484.50 1157.48 0.00 6527.55 59.96 406.17
25 485.00 1247.41 0.00 6786.20 113.79 446.23
26 485.50 1346.01 0.00 6998.11 151.09 483.84

 



Appendix G – Stage-Damage Output Files HEC-FDA User's Manual 

 

 
Figure G.2 inued) 

G-4 

FDA_SDmg.out – Stage-Aggregated Damage by Category (cont

Other Aggregated Damage Matrix.
Stream: S Fork Bear
Reach: SF-9

Stage APT AUTO COMM PUB RES
1 473.00 0.00 0.00 0.00 0.00 0.00
2 473.50 0.00 0.00 0.00 0.00 0.00
3 474.00 0.00 0.00 0.00 0.00 0.00
4 474.50 0.00 0.00 0.00 0.00 0.00
5 475.00 0.00 0.00 0.00 0.00 0.00
6 475.50 0.00 0.00 0.00 0.00 0.00
7 476.00 0.00 0.00 0.00 0.00 0.00
8 476.50 0.00 0.00 0.00 0.00 0.00
9 477.00 0.00 0.00 0.00 0.00 0.00

10 477.50 0.00 0.00 0.00 0.00 0.00
11 478.00 0.00 0.00 0.00 0.00 0.00
12 478.50 0.00 0.00 0.00 0.00 0.00
13 479.00 0.00 0.00 0.00 0.00 0.00
14 479.50 0.00 0.00 0.00 0.00 0.00
15 480.00 0.00 0.00 0.00 0.00 0.00
16 480.50 0.00 0.00 0.00 0.00 0.00
17 481.00 0.00 0.00 0.00 0.00 0.00
18 481.50 0.00 0.00 0.00 0.00 0.00
19 482.00 0.00 0.00 0.00 0.00 0.00
20 482.50 0.00 0.00 0.00 0.00 0.00
21 483.00 0.00 0.00 0.00 0.00 0.00
22 483.50 0.00 0.00 0.00 0.00 0.00
23 484.00 0.00 0.00 0.00 0.00 0.00
24 484.50 0.00 0.00 0.00 0.00 0.00
25 485.00 0.00 0.00 0.00 0.00 0.00
26 485.50 0.00 0.00 0.00 0.00 0.00

Total Aggregated Damage Matrix.
Stream: S Fork Bear
Reach: SF-9

Stage APT AUTO COMM PUB RES
1 473.00 0.00 0.00 0.00 0.00 0.00
2 473.50 0.00 0.00 0.00 0.00 0.00
3 474.00 0.00 0.00 0.00 0.00 0.00
4 474.50 0.00 0.00 0.00 0.00 0.00
5 475.00 0.00 0.00 0.00 0.00 0.00
6 475.50 0.00 0.00 0.00 0.00 0.00
7 476.00 0.00 0.00 0.00 0.00 0.00
8 476.50 16.52 0.01 0.00 0.00 0.00
9 477.00 72.16 0.37 0.00 0.00 0.00

10 477.50 134.14 1.55 0.00 0.00 0.00
11 478.00 263.99 4.94 0.00 0.00 3.78
12 478.50 377.39 10.84 0.00 0.00 28.11
13 479.00 498.51 17.64 0.00 0.00 74.76
14 479.50 640.28 35.32 8.02 0.00 124.30
15 480.00 842.58 61.56 98.78 0.00 184.27
16 480.50 1074.06 96.84 315.89 0.00 250.88
17 481.00 1295.57 152.69 1106.98 0.00 342.48
18 481.50 1574.41 224.12 1900.63 0.00 462.65
19 482.00 1834.99 278.29 2773.50 0.00 556.60
20 482.50 2074.36 308.03 3760.28 0.00 647.17
21 483.00 2334.32 327.71 4629.39 0.00 758.64
22 483.50 2601.29 347.23 5654.29 0.00 879.71
23 484.00 2863.35 365.86 6522.60 10.05 983.90
24 484.50 3109.97 373.49 7061.44 71.19 1077.74
25 485.00 3353.73 373.69 7368.35 141.41 1181.77
26 485.50 3611.41 373.69 7627.80 189.40 1296.12
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 Summary Output for Component with Uncertainty 
Error 

 
The second set of tables available in FDA_SDmg.out (see Figure G.3, page 
G-6) are the stage-aggregated damage functions by stream, damage reach, 
and damage category.  These functions include the computed standard 
deviation of error and are broken out by Structure, Content, Other, and 
Total. 
 
 

G.2.3 Trace Level Greater than Four 
 
When the trace level is set to five or greater, FDA adds additional 
information by structure to FDA_SDmg.out file, which is displayed in 
Figure G.4. 

 
 

G.2.4 Trace Level Greater than Nine 
 
When the trace level is set to ten or greater, detailed information about 
each structure is provided.  For example, in Figure G.5 (see page G-7), 
detailed structure information for Structure 399 is displayed.  Information 
includes structure name, stream name, damage reach name, damage 
category name, address, water surface elevation at index location, water 
surface elevation at structure, and much more.  The information includes 
Nominal Depth which is the depth of assumed flooding without 
uncertainty.  Nominal depth corresponds to the "aggregation stages", 
where are shown for both the index location and at the structure as 
computed using either the water surface profiles or the SID reference 
flood water surface profile. 
 

Structure: 3192 
Stream: Buechel Branch     Reach: BB-4     Category: APT 
Address: 1-24 BUECH BNK;WILLOW BROOK APT    City:                   State:    
 
Structure: 3193 
Stream: Buechel Branch     Reach: BB-4     Category: APT 
Address: 105-120 BUECH BNK;WILLOW BROOK     City:                   State:    
 
Structure: 3194 
Stream: Buechel Branch     Reach: BB-4     Category: APT 
Address: 89-104 BUECH BNK;WILLOW BROOK AP   City:                   State:    
 
Structure: 3195 
Stream: Buechel Branch     Reach: BB-4     Category: APT 
Address: 25-49 BUECH BNK;WILLOW BROOK APT   City:                   State:    

Figure G.4  FDA_SDmg.out – Trace Level Greater than Four 

 

 G-5 
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Figure G.3  FDA_SDmg.out – Stage-Aggregated Damage by Category with Uncertainty 

Plan Without
Year 2009
Str
Rea

Stored Stage-Damage-Uncertainty Function tage-Damage-Uncertainty Function 
Plan Without
Year 2009

Stored Stage-Damage-Uncertainty Functio

Stream S Fork Bear
Reach SF-9
Damage Cat APT

00
0
0

6 475.50 0.00 0.00
7 476.00 0.00 0.00
8 476.50 5.77 6.38
9 477.00 25.55 7.59
10 477.50 49.54 10.43
11 478.00 97.68 14.19
12 478.50 140.74 16.05
13 479.00 188.54 18.44

20.90
24.75

04
19

18 481.50 582.32 36.12
19 482.00 679.55 40.47
20 482.50 771.07 45.24

868.61 50.55
4
3

24 484.50 1157.48 65.25
1247.41 70.17

8

n

Component Content

Index Stage Damage Std Dev
1 473.00 0.00 0.00
2 473.50 0.00 0.00
3 474.00 0.00 0.
4 474.50 0.00 0.0
5 475.00 0.00 0.0

eam S Fork Bear
h SF-9

Dam ge Cat APT
Com

Ind

475.50 0.00 0.00
476.00 0.00 0.00

8 476.50 10.75 11.18
9 477.00 46.61 9.62

13 479.00 309.97 12.60

.50 992.09 24.05

.00 1155.44 21.87
1303.29 24.34

1952.49 33.32

c
a
ponent Structure

ex Stage Damage Std Dev
1 473.00 0.00 0.00
2 473.50 0.00 0.00
3 474.00 0.00 0.00
4 474.50 0.00 0.00
5 475.00 0.00 0.00
6
7

10 477.50 84.60 14.16
11 478.00 166.31 15.68
12 478.50 236.65 13.77

14 479.50 397.69 13.19
15 480.00 529.52 21.79
16 480.50 679.04 17.08
17 481.00 817.72 20.95
18 481
19 482
20 482.50
21 483.00 1465.72 28.74
22 483.50 1632.64 29.01
23 484.00 1796.49 31.29
24 484.50
25 485.00 2106.32 35.73
26 485.50 2265.40 38.26

14 479.50 242.58
15 480.00 313.06
16 480.50 395.02 27.
17 481.00 477.84 31.

21 483.00
22 483.50 968.66 55.3
23 484.00 1066.86 60.4

25 485.00
26 485.50 1346.01 75.5

Pla
Yea
Str ear
Rea
Dam
Com

Ind

2 473.50 0.00 0.00
3 474.00 0.00 0.00
4 474.50 0.00 0.00

8 476.50 0.00 0.00

0.00

Sto
n Without

Uncertainty Function

r 2009
eam S Fork B
ch SF-9
age Cat APT
ponent Other

ex Stage Damage Std Dev
1 473.00 0.00 0.00

5 475.00 0.00 0.00
6 475.50 0.00 0.00
7 476.00 0.00 0.00

9 477.00 0.00 0.00
10 477.50 0.00 0.00
11 478.00 0.00 0.00
12 478.50 0.00 0.00
13 479.00 0.00 0.00
14 479.50 0.00 0.00
15 480.00 0.00 0.00
16 480.50 0.00 0.00
17 481.00 0.00 0.00
18 481.50 0.00 0.00
19 482.00 0.00 0.00
20 482.50 0.00 0.00
21 483.00 0.00 0.00
22 483.50 0.00 0.00
23 484.00 0.00 0.00
24 484.50 0.00 0.00
25 485.00 0.00 0.00
26 485.50 0.00

red Stage-Damage-
Plan Witho
Stored Stage-Damage

ut
Year 2009
Stream S Fork Bear

age Std Dev
0.00 0.00

2 473.50 0.00 0.00
3 474.00 0.00 0.00
4 474.50 0.00 0.00
5 475.00 0.00 0.00
6 475.50 0.00 0.00
7 476.00 0.00 0.00

2
6
2
4

26.31

9
.25
.51

69.03
.08
.64

26 485.50 3611.41 85.68

-Uncertainty Function 

Reach SF-9
Damage Cat APT
Component Total

Index Stage Dam
1 473.00

8 476.50 16.52 17.1
9 477.00 72.16 15.6

10 477.50 134.14 22.1
11 478.00 263.99 26.0
12 478.50 377.39 24.41
13 479.00 498.51 24.58
14 479.50 640.28
15 480.00 842.58 37.44
16 480.50 1074.06 33.63
17 481.00 1295.57 40.36
18 481.50 1574.41 46.36
19 482.00 1834.99 46.95
20 482.50 2074.36 52.2
21 483.00 2334.32 60
22 483.50 2601.29 63
23 484.00 2863.35
24 484.50 3109.97 74
25 485.00 3353.73 79
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FDA_SdErrors.out 

 
FDA_SdErrors.out contains structure data validation information.   This 
file lists optionally each structure and also summary information.  The 
output indicates invalid data (such as unknown damage reach, damage 
category, etc.) as well as structures that were not included in the 
calculations (structure is out of the flood plain; was placed in service after 
the current calculation year, etc.). 
 
 

Summary Validation Output 
 
The information displayed in the FDA_SdErrors.out file is the errors, 
warnings, and flags generated from processing the structure inventory.  In 
Figure G.6, the information provided includes location of the  

G.3 

G.3.1 

Figure G.5  Example Structure Summary Validation Output 

igure G.6  FDA_SdErros.out – Trace Level Greater than Nine 

tructure

F

S : 399
tream: S Fork Bear
Reach: SF-8
Category: COMM
Address: BASHFORD MANOR MALL             
City:                                 
State:   

Index
WS Elev @ 
Index

S

WS Elev @ Structure 
tructure

Nominal 
epth

Mean 
amage

Content 
amage

Other 
Damage

Total 
S D Depth D D Damage

1 463.00 464.77 -12.22 -12.22 0.00 0.00 0.00 0.00
2 464.00 465.77 -11.22 -11.22 0.00 0.00 0.00 0.00
3 465.00 466.77 -10.22 -10.22 0.00 0.00 0.00 0.00
4 466.00 467.77 -9.22 -9.22 0.00 0.00 0.00 0.00
5 467.00 468.77 -8.22 -8.22 0.00 0.00 0.00 0.00
6 468.00 469.77 -7.22 -7.22 0.00 0.00 0.00 0.00
7 469.00 470.67 -6.32 -6.32 0.00 0.00 0.00 0.00
8 470.00 471.51 -5.48 -5.48 0.00 0.00 0.00 0.00
9 471.00 472.39 -4.60 -4.60 0.00 0.00 0.00 0.00
10 472.00 473.27 -3.72 -3.72 0.00 0.00 0.00 0.00
11 473.00 474.32 -2.67 -2.69 0.00 0.00 0.00 0.00
12 474.00 475.27 -1.72 -1.75 0.00 0.00 0.00 0.00
13 475.00 476.11 -0.88 -0.90 0.00 0.00 0.00 0.00
14 476.00 476.89 -0.10 -0.13 73.06 186.22 0.00 259.28
15 477.00 477.71 0.72 0.70 1,567.31 4,454.61 0.00 6,021.92
16 478.00 478.71 1.72 1.70 4,291.75 10,163.09 0.00 14,454.84
17 479.00 479.71 2.72 2.70 5,201.72 19,665.99 0.00 24,867.71
18 480.00 480.71 3.72 3.70 5,211.95 28,819.37 0.00 34,031.32
19 481.00 481.71 4.72 4.70 6,243.18 33,074.97 0.00 39,318.15
20 482.00 482.71 5.72 5.70 7,734.50 35,066.55 0.00 42,801.05

Study:     Bear Creek Example Errors
Description S. Fork Bear & Buechel Branch
Pathname:  S:\Appendices_Staging\BearTrngSdErrors
Number of Structures Rejected Due To Errors In Stage-Damage Calculations
Numbers are Cumulative for Selected Plan & Year
Plan: Without
Year: 2009
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R
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R
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F
P
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U
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S
I
D
 
R
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R
e
f

 
S
I
D

Total 
Struc U

s
e
d
 

 

N
o
 
Z
e
r
o
 
D
a
m
g

N
o
 
O
c
c
 
O
r
d

M
i
s
s
 
O
c
c
 
O
r
d

D
c
r
e
a
s
 
O
c
c
 
O
r
d

F
l
o
o
d

243 10 12 0 0 3 0 0 5 2 0 0 1 1 1 2 1 1 1 0 0

File S:\Appendices_Staging\BearTrngSdErrors\FDA_SdErrors.out opened on Thu Oct 27 11:40:52 200
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FDA_SdErrors.out file, time of creation, study name, study description, 
and location of study, plan, analysis year, and a summary of the errors that 
occurred when validating the structure data. 
 
Example errors include undefined first floor stage, undefined damage 
category, bad occupancy type data, and more.  An example warning is 
flagging structures that are "out of the floodplain" which indicates that the 
first floor stage is so high that the structure will not contribute any damage 

G.3.2 Trace L

 
om  large depending on the size of the structure inventory.  

s are 
generated by FDA when certain components (i.e., stream, damage reach,  

and is not used in the calculations.  For example, there are a total of 243 
structures of which twelve were rejected from the calculations.  Of those 
twelve, ten structures had bad data. 
 
 

evel Five or Greater 
 
Figures G.7 through G.9 (page G-9) display part of the structure 

ation that is availa  FDA_SdErrors. out.  When the trace level 
ith this option, 

inform ble in
is five or greater, information is provided by structure.  W
FDA_SdErrors.out  

Cum Num 
Struc Struc Na

d ed ai
n

 U
se

d
se

d

 

25 R 446 a 64
26 R 446 b 64
27 R 446 c 0 SF-8 64
28 R 446 d
29 R 446 e
30 R 446 

me D
at

a 
N

ot
 V

al
id

C
om

p 
N

ot
 P

os
s

St
ru

c 
N

ot
 R

et
rv

St
rm

 N
ot

 V
al

id
R

ch
 N

ot
 V

al
id

C
at

 N
ot

 V
al

id
O

cc
 N

ot
 V

al
id

O
cc

 D
at

a 
B

ad
FF

 S
ta

ge
 B

ad
A

gg
D

F 
N

ot
 V

al
i

A
gg

D
F 

N
ot

 S
ca

l
W

SP
 N

ot
 F

ou
nd

St
at

io
ns

 B
ad

St
ru

c 
To

o 
N

ew
St

ru
c 

O
ut

O
f F

Pl
SI

D
 R

ch
 N

am
e

SI
D

 R
ef

 F
lo

od
 U

Stream Name Stream ID

Curr 
Reach 
Name

Curr 
Rch 
ID

Calculated 
Reach Name

Calc 
Rch 
ID

SID 
Reach 
Name

SID 
Rch
ID

x x x S Fork Bear 3 SF-8 64 SF-8 64 SF-8
x x x S Fork Bear 3 SF-8 64 SF-8 64 SF-8

x S Fork Bear 3 SF-8 64
x x x S Fork Bear 3 SF-8 64 SF-8 64 SF-8 64

S Fork Bear 3 SF-8 64 SF-8 64 SF-8 64
f x x x S Fork Bear 3 -901 0 -901

x x x x S Fo
x x S Fo

31 R 446 g rk Bear 3 SF-8 64 0 SF-8 64
32 R 446 h rk Bear 3 SF-8 64 SF-8 64 SF-8 64
33 R 446 i x x S Fork Bear 3 SF-8 64 SF-8 64 SF-8 64
34 R 446 j S Fork Bear 3 SF-9 65 SF-9 65 SF-8 64
35 R 446 k x x x S Fork Bear 3 SF-8 64 SF-8 64 SF-8 64

 Bear 3 SF-8 64 SF-8 64 SF-8 6436 R 446 l x x x S Fork

Figure G.7  Example Structure Computation Errors, Frame 1 
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ot
 

O
cc

 D
at

a
FF

 S
ta

ge
A

gg
D

F
A

gg
D

F 
N

W
SP

 N
o

St
at

io
ns

St
ru

c 
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O
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D
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SI
D

 R
ef
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t R
et

rv
t V

al
id

V
al
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t V

al
id

V
al

id
 B

ad
 B

ad
 N

ot
 V

al
id

ot
 S

ca
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d
t F

ou
nd

 B
ad N

ew
tO

f F
Pl

ai
n

 N
am

e 
U

se
d

 F
lo

od
 U

se
d

Name
Cat 
ID Occ Code Name

Occ 
Code 
ID

Damg 
Occ 
Data

Structure 
Occ Data

Content Occ 
Data

Other 
Occ 
Data

Uses 
FF 
Stage

1st Floor 
Stage

25 R 446 a x x x RES 5 Bob 2 Ds 1156 5 Dd 0 0 1 478.50
26 R 446 b x x x RES 5 Bob 2 D$ 1158 5 $d 0 0 1 478.50
27 R 446 c x RES 5 1BS_1BC_ 44 18 19 0 1 478.50
28 R 446 d x x x RES 5 1BS_1BC_ 44 18 19 0 0 -901.00
29 R 446 e RES 5 1BS_1BC_ 44 18 19 0 1 478.50
30 R 446 f x x x RES 5 1BS_1BC_ 44 18 19 0 1 478.50
31 R 446 g x x x x RES 5 1BS_1BC_ 44 18 19 0 1 478.50
32 R 446 h x x RES 5 1BS_1BC_ 44 18 19 0 1 600.00
33 R 446 i x x RES 5 1BS_1BC_ 44 18 19 0 1 478.50
34 R 446 j RES 5 1BS_1BC_ 44 18 19 0 1 478.50
35 R 446 k x x x RES 5 Bob 3 No Ord 1168 0 0 0 1 478.50
36 R 446 l x x x RES 5 Bob 4 No ZD 1190 x 4 0 0 1 478.50

Zero 

Figure G.8  Example Structure Computations Errors, Frame 2 

can bec e quite
One piece of information that is provided are IDs.  These ID

G-8 
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Cum Num 
Struc Struc Name D

at
a 

N
ot

 V
al

id

ru rm
R

ch
 N

o
t N

O
cc

 N
o

O
cc

 D
at

FF
 S

ta
gD gD

W
SP

 N
at

io
ru ru

c  R Ground Foundation Struc Struc 
WSP 
Starting 

Reach 
Index 

WSP 
Ending Struc Stage 

Max Tab 
Stage At 

ruct
25 R 446 a -901.00
26 R 446 b 901.00
27 R 446 c 495.62
28 R 446 d
29 R 446 e
30 R 446 f
31 R 446 g
32 R 446 h
33 R 446 i 79
34 R 446 j 64
35 R 446 k 0
36 R 446 l 0

C
om

p 
N

ot
 P

os
s

c 
N

ot
 R

et
rv

 N
ot

 V
al

id
t V

al
id

ot
 V

al
id
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al

id
a 

B
ad

ge
 B

ad
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N
ot
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id
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N
ot

 S
ca

le
d

ot
 F

ou
nd

ns
 B

ad
c 

To
o 

N
ew

 O
ut

O
f F

Pl
ai

n
D

 R
ch

 N
am

e 
U

se
d

ef
 F

lo
od

 U
se

d

Year 

St St C
a

A
g

A
g

St St St SI SI
D Stage Height Built Station Station Station Station Zero Damg St

x x x -901.00 -901.00 1900 9.150 0.800 9.253 13.380 -901.00
x x x -901.00 -901.00 1900 9.150 0.800 9.253 13.380 -901.00 -

x -901.00 -901.00 1900 11.000 0.800 9.253 13.380 474.40
x x x -901.00 0.00 1900 9.150 0.800 9.253 13.380 -901.00 -901.00

-901.00 -901.00 1900 9.150 0.800 9.253 13.380 474.40 481.79
x x x -901.00 -901.00 1900 500.000 0.800 -901.000 13.380 -901.00 -901.00
x x x x -901.00 -901.00 1900 500.000 0.800 9.253 13.380 -901.00 -901.00

x x -901.00 -901.00 1900 9.150 0.800 9.253 13.380 595.90 481.79
x x -901.00 -901.00 2030 9.150 0.800 9.253 13.380 474.40 481.

-901.00 -901.00 1900 10.000 0.800 10.124 13.380 474.40 483.
x x x -901.00 -901.00 1900 9.150 0.800 9.253 13.380 -901.00 -901.0
x x x -901.00 -901.00 1900 9.150 0.800 9.253 13.380 -901.00 -901.0

Figure G.9  Ex rame 3 ample Structure Computations Errors, F

damagee category, etc.) are created.  These IDs are an easy way for FDA 
the graphical user interface (GUI).  
 does not exist, for example, a structure 

 Since 

aggregated, and it either the 
calculated damage reach name or the SID reach name); the 
calculated damage area name (calculated by FDA based on the 
stream name, stationing, and back location of the structure), the 
SID reach name (Damage reach name entered by the user for a 
structure), and any error or warnings that occurred during the 
stage-aggregated damage calculation. 

 
• For Structure 446a, a bad structure occupancy type had been 

detected.  In Figure G.8 (page G-8), the column Occ Data Bad is 
checked, and in the column Structure Occ Data the characters  

 5 Dd displayed.  These characters indicate that there are five (5) 
age function, and that the 

unction rather than 

to relate data and are not visible in 
DA will indicate bad data if an IDF

could reference a structure occupancy type that has been deleted. 
the structure occupancy type ID has been deleted, but the structure 
inventory still references that ID, FDA will indicate bad data in 
FDA_SdErrors.out. 
 
For example, in Figures G.7 (page G-8) through G.9, in FDA a stage-
aggregated damage compuation was done for the "Without" plan and 
analysis year 2009.  The options Use SID Reaches and Use SID Ref 
Flood were not used during this comptuation.  There are two damage 
reaches, SF-8 (stations 9.020 – 9.960) and SF-9 (stations 9.960 – 10.363), 
with water surface profiles being calculated at stations 0.800 through 
13.380. 
 

• In Figure G.7 (page G-8) information provided for each structure is 
the stream name; current damage reach name (which is the damage 
reach where a structure's damage is 

ordinates in the structure depth-dam
depth (D) decreases (d) somewhere in the f
increasing. 

 

 G-9 
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• For Structure 466b a bad structure occupancy type has been 
detected.  In Figure G.6 (page G-8), the column Occ Data Bad is 
checked and in the column Structure Occ Data the characters  

 5 $d are displayed.  These characters indicate that there are five (5) 
ordinates in the structure depth-damage function, and that the 
damage ($) decreases (d) somewhere in the function rather than 
increasing. 

 
• Structure 446c provides an example of a structure that is located 

outside the range of the damage reaches.  In Figure G.7 (page  
ed is checked and the column 

 

or stage has been detected for Structure 446d.  In 

been 

 not 

 
te 
e 
 

a 

 

ch 
e used. 

 G-8), the column SID Rch Name Us
Calculated Reach Name is blank.  The structure is located at 
station 11.00 which is outside the range of the stationing provided 
for the two damage reaches, but is within the range of stationing
for the water surface profiles.  Since a damage reach name was 
entered for the SID reach name, FDA will use this as the damage 
reach for Structure 446c. 

 
• A bad first flo

Figure G.8 (page G-8) the column FF Stage Bad has been 
checked, and in column 1st Floor Stage the value -901.00 has 
entered by FDA, indicating that the first floor stage was not 
defined.  -901.00 is used by FDA to indicate that a number has
been defined and usually means that a required field was not 
entered by the user.  It can also mean that a value could not be 
calculated and is undefined. 

 
• Structure 446f provides an example of an invalid damage reach.  

In Figure G.7 (page G-8), the column Rch Not Valid is checked, 
which indicates that FDA did not find or was unable to calculate a 
valid damage reach for Structure 446f.  A zero (0) appears in the
column Calc Rch ID, which means FDA, was unable to calcula
a damage reach since the station location (500.00) of the structur
is outside the range of the damage reaches.  A -901 appears in the
SID Rch ID column, which indicates that the user did not enter 
damage reach name. 

 
• Now, Structure 446g is similar to Structure 446f in that the 

station location of the structure is bad, but for this structure a SID 
Reach Name has been provided by the user.  In Figure G.7 (page 
G-8), for Structure 446g the column SID Rch Name Used is 
checked, therefore, since the structure's station (500.00) is outside
of the range of stations for the water surface profiles (0.800 – 
13.380) and FDA can't compute the damage reach, the SID Rea
Name will b
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• Structure 446h has been tagged "out of the floodplain" and w
not be included in the stage aggregated damage calculation.  In 
Figure G.8 (page G-8), in column 1st Floor Stage, Structure 44

ill 

6h 

of 
e 

value of 481.79 is indicated for the highest tabulation 
stage for aggregating damages for Structure 446h.  This value is 

), 

 the option Use SID Reaches, so FDA 
will use the calculated damage reach name when doing the stage-

, and 

8 

 
 

G.4 FDA_SDev

 Trace L

 fifty (50) or greater, detailed Monte-Carlo 
imulation results by structure are written to FDA_SDev.out.  Figure G.10  

has a first floor stage of 600.00.  In Figure G.9 (page G-9), for 
Structure 446h, column Struc Stage Zero Damg has a value 
595.90 for the zero damage point.  In the column Max Tab Stag
at Struct, a 

far below the zero damage point; therefore, the structure is tagged 
"out of the floodplain". 

 
• The next structure, 446j, does not have any errors, but has two 

different damage reach names.  The calculated damage reach 
names is SF-9 (see Figure G.7, column Calculated Reach Name
while the SID Reach Name provided by the user is SF-8 (see 
Figure G.7, column SID Reach Name).  For this example, 
remember we are not using

aggregated damage calculation. 
 

• Structure 446k has a bad structure occupancy type.  In Figure G.8 
(page G-8), column Structure Occ Data, Content Occ Data
Other Occ Data all contain a value of zero (0), which indicates 
there are no ordinates in the depth-damage functions for this 
structure.  Therefore, there is no damage associated with this 
structure. 

 
• The last structure we will look at in this example is Structure 

446l, which also has a bad structure occupancy type.  In Figure G.
(page G-8), the column Zero Damage Occ Data is checked.  This 
indicates that there is not a zero damage point in one or more of the
depth-damage functions.  Each depth-damage function should have
some depth at which there is no damage. 

 
 

.out 
 
FDA_SDev.out contains detailed results by structure of the Monte-Carlo 
simulations for stage-damage and is often referred to as the Standard 
Deviation Trace file. 
 
 

evel Greater than Forty-Nine 
 

hen the trace level is set atW
s
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File S:\Appendices_Staging\BearTrngSdErrors\FDA_SDev.out opened on Thu Oct 27 15:09:50 2005

ek Example Errors
 Bear & Buechel Branch

dices_Staging\BearTrngSdErrors
t
2009

399
ear

ORD MANOR MALL             
                    

on Results for First Floor Elevation and Values

al 1st 
e

Study:        Bear Cre
Description:  S. Fork
Pathname:     S:\Appen
Plan:         Withou
Year:         

Structure:
Stream: S Fork B
Reach: SF-8
Category: COMM
Address: BASHF
City:             
State:   
Monte Carlo Simulati

Index
Nomin

o

Mean 
1stFloor 
Elev

StdDev 
1stFloor 
Elev

Num of 
Simul

Mean 
Struct 
Value

StdDev 
Struct 
Value

Num 
of 
Simul

Mean 
Content 
Value

StdDev 
Content 
Value

Num of 
Simul

Mean 
Other 
Value

StdDev 
Other 
Value

Num of 
Simul

Mean total 
Value

StdDev 

Flo r El v
Total 
Value

6 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0.1 47 .99 0
2 47 96. 9 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0.0
3 0.476.99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0
4 0.476.99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0
5 476 0..99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0
6 476.99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0.0
7 476.99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0.0
8 476 0..99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0
9 476 0..99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0.0 0

10 476 0.0 0..99 0.00 0.000 0 0.0 0.0 0 0.0 0.0 0 0 0 0 0
11 476.99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 14509.2
12 476.99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 14509.2
13 476.99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 14509.2
14 476 9..99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 1450 2
15 476 9..99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 1450 2
16 476 193.5 100 0 0 100 109928.8 14509..99 477.01 0.206 100 74310.2 7382.4 100 35618.5 12 2
17 47 .996 477.01 0.206 100 74310.2 7382.4 100 35618.5 12193.5 100 0 0 100 109928.8 14509.2

Figure G.10  Example Detailed Monte-Carlo Simulation Results for One Structure 

displays the information for a structure; information includes study name, 
description of the study, location of the study, plan name, analysis year, 
structure name, stream name, and more.  Results that include "mean"
the computed means after the stage aggregated damage calculation is 
finished.  Currently, FDA resets the 

 are 

"seed" number to the initial default 
alue for every stage ordinate, which creates a bias in the results.  If the 

G.5 FDA_S

information including all 
f the structure’s data (first floor stage, structure value, etc.) as well as 

 for each of the water surface profile probabilities.  The 
ted without uncertainty and does not reflect damage 

eduction due to levees which is computed during the expected annual 

 Detailed Structure Output 

formation about the 
ructure inventory.  Figure G.11, which is split into several frames, 

v
seed number were not reset, the computed damage does not always 
increase with increasing stages. 
 
trucDetail.out 

 
DA_StrucDetail.out contains detailed structure F

o
damage computed
damage is compu
r
damage simulation.  This file is often referred to as the Structural 
Details file. 
 

 
The FDA_StrucDetail.out file contains detailed in
st
displays the information available from FDA_StrucDetail.out. 

G-12 
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================================================================================ 
File D:\WpDoc\NexGen FDA\Documentation\UsersManual\Manual 2005\Data\Data 2005\BearTrng\FDA_StrucDetail.out opened on Mon Aug 29 16:17:05 2005 

      
Study:         Beargrass Creek     
Description:   S. Fork Beargrass & Buechel Branch  
Pathname:      D:\WpDoc\NexGen FDA\Documentation\UsersManual\Manual 2005\Data\Data 2005\BearTrng 
Plan:          Without     
Year:          2008     
Struc_Name Stream_Name  Station Bank Year Cat_Name Occ_Name Street City State Zip 
Structure 
Name 

Stream Name Reach 
Name 

Station Bank Year In 
Service 

Damage 
Category 

Occupancy 
Type 

Street City State Zip 

      
3192 Buechel Branch BB-4 500.000 Left 1900 APT A2S_A2C_ 1-24 BUECH BNK;WILLOW BROOK APT 
3193 Buechel Branch BB-4 1.790 Left 1900 APT A2S_A2C_ 105-120 BUECH BNK;WILLOW BROOK 
3194 Buechel Branch BB-4 1.820 Left 1900 APT A2S_A2C_ 89-104 BUECH BNK;WILLOW BROOK AP 
3195 Buechel Branch BB-4 1.800 Left 1900 APT A2S_A2C_ 25-49 BUECH BNK;WILLOW BROOK APT 
3196 Buechel Branch BB-4 1.790 Left 1900 APT A2S_A2C_ WILLOW BROOK APTS CLUBHOUSE 
3197 Buechel Branch BB-4 1.823 Left 1900 APT A2S_A2C_ 65-77 BUECH BNK;WILLOW BROOK APT 
3198 Buechel Branch BB-4 1.840 Left 1900 APT A2S_A2C_ 49-56 BUECH BNK;WILLOW BROOK APT 
3199 Buechel Branch BB-4 1.835 Left 1900 APT A2S_A2C_ 57-65 BUECH BNK;WILLOW BROOK APT 
3215 Buechel Branch BB-5 2.055 Left 1900 COMM 13S_13C_ 4133 BTOWN RD;CHAMPION WINDOWS 
3216 Buechel Branch BB-5 2.950 Left 1900 RES 2BS_2BC_ 2209 FAIRLAND AV. 
3217 Buechel Branch BB-5 2.215 Left 1900 RES 1CS_1CC_ 2222 FAIRLAND AV. 
3218 Buechel Branch BB-5 2.165 Left 1900 RES 1CS_1CC_ 2220 FAIRLAND AV. 
3219 Buechel Branch BB-5 2.160 Left 1900 RES 1CS_1CC_ 2220 FAIRLAND AV. 
3220 Buechel Branch BB-5 2.135 Left 1900 RES 1CS_1CC_ 2216 FAIRLAND AV. 
3221 Buechel Branch BB-5 2.110 Left 1900 RES 2BS_2BC_ 2212 FAIRLAND AV. 
3222 Buechel Branch BB-5 2.090 Left 1900 COMM 83S_83C_ FAIRLAND AV. storage whse. 
3223 Buechel Branch BB-5 2.130 Left 1900 RES 1CS_1CC_ FAIRLAND AV.; BI-30 
3224 Buechel Branch BB-5 2.135 Left 1900 RES 2BS_2BC_ 2215 FAIRLAND AV.; BI-30 
3225 Buechel Branch BB-5 2.150 Left 1900 RES 2CS_2CC_ 2217 FAIRLAND AV.; BI-30 
3226 Buechel Branch BB-5 2.220 Left 1900 RES 2CS_2CC_ 2224 FAIRLAND AV.; BI-30 

 
 
 
 

Figure G.11  Example o

Figure G.11  Example of 

f FDA_StrucDetail.out – Frame 1 

 
 
 

FDA_StrucDetail.out – Frame 2 

Structure 
Name 

Northing Easting Zon

se 
Value Value in 

Database 

e Module Structure 
Value in 
Database 

Structure 
Value 

Content 
Value in 
Database 

Ratio 
Content / 
Structure 
Value in 
Databa

Content 
Value 

Ratio 
Content / 
Structure 

Other Value 
in Database 

Ratio 
Other / 
Structure 

Other 
Value 

        
3192 0 0 1.75 Base 737.8 737.8 368.9 50.0 368.9 50.0 -901.0 -901.0 0.0 
3193 0 0 -901 Base 513.6 513.6 256.8 50.0 256.8 50.0 -901.0 -901.0 0.0 
3194 0 0 -901 Base 517.7 517.7 258.9 50.0 258.9 50.0 -901.0 -901.0 0.0 
3195 0 0 -901 Base 743.9 743.9 372.0 50.0 372.0 50.0 -901.0 -901.0 0.0 
3196 0 0 -901 Base 87.6 87.6 43.8 50.0 43.8 50.0 -901.0 -901.0 0.0 
3197 0 0 -901 Base 538.0 538.0 269.0 50.0 269.0 50.0 -901.0 -901.0 0.0 
3198 0 0 -901 Base 265.0 265.0 132.5 50.0 132.5 50.0 -901.0 -901.0 0.0 
3199 0 0 -901 Base 265.0 265.0 132.5 50.0 132.5 50.0 -901.0 -901.0 0.0 
3215 0 0 -901 Base 75.0 75.0 60.0 50.0 60.0 80.0 -901.0 -901.0 0.0 
3216 0 0 -901 Base 56.7 56.7 28.3 50.0 28.3 50.0 -901.0 -901.0 0.0 
3217 0 0 -901 Base 64.9 64.9 32.5 -901.0 32.5 50.0 -901.0 -901.0 0.0 
3218 0 0 -901 Base 77.3 77.3 38.6 -901.0 38.6 50.0 -901.0 -901.0 0.0 
3219 0 0 -901 Base 34.0 34.0 17.0 -901.0 17.0 50.0 -901.0 -901.0 0.0 
3220 0 0 -901 Base 62.8 62.8 31.4 -901.0 31.4 50.0 -901.0 -901.0 0.0 
3221 0 0 -901 Base 74.2 74.2 37.1 50.0 37.1 50.0 -901.0 -901.0 0.0 
3222 0 0 - 36.0 36.0 28.8 50.0 28.8 80.0 -901.0 -901.0 0.0 901 Base 
3223 0 0 -901 Base 22.7 22.7 11.3 -901.0 11.3 50.0 -901.0 -901.0 0.0 
3224 0 0 -  Base 54.6 54.6 27.3901 50.0 27.3 50.0 -901.0 -901.0 0.0 
3225 0 0 -901 Base 26.8 26.8 13.4 50.0 13.4 50.0 -901.0 -901.0 0.0 
3226 0 0 -901 Base 44.3 44.3 22.2 50.0 22.2 50.0 -901.0 -901.0 0.0 
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Structure atio Total First Floor Ground Foundation Depth at Stage at Depth at SID SID Ref 
Name 

R
Other / 

tructure 
Value 

S
ructur Elevat El ion Height Beginning 

Damage 
Zero 
Damage 

zero 
damage 

Reach 
Name 

Flood Stage 

Value 

Number of 
St es ion evat

       
3192 -0.25 BB-4 493.70 0.0 1106.7 1 492.3 -0.25 492.00
3193 0.0 770.4 1 4 25 0 -0.25 BB-4 494.10 92.3 -0. 492.0
3194 776.6 4 25 5 -0.25 BB-4 494.50 0.0 1 92.5 -0. 492.2
3195 0.0 1115.9 1 492.0 -0.20 491.80 -0.20 BB-4 494.30 
3196 0.0 131.4 1 -0.01 491.99 -0.01 BB-4 494.10 492.0 
3197 0.0 7.0 25  80 1 492.3 -0. 492.00 -0.25 BB-4 494.50
3198 0.0 7.5 1 25 0 39  492.5 -0. 492.25 -0.25 BB-4 494.7
3199 0.0 7.5 1 25  39 492.5 -0. 492.25 -0.25 BB-4 494.70
3215 0.0 5.0 1 0113 502.3 -0. 502.30 0.00 BB-5 502.00 
3216 0.0 5.0 1 00  8 505.0 -3. 502.00 -3.00 BB-5 501.90
3217 0.0 7.3 1 259 504.3 -2. 502.25 -2.00 BB-5 502.60 
3218 0.0 5.9 1 0011 501.5 -1. 500.50 -1.00 BB-5 502.30 
3219 0.0 1.0 1 015 500.0 -0. 499.99 -0.01 BB-5 502.20 
3220 0.0 4.2 1  9 502.3 -2.25 500.25 -2.00 BB-5 502.20
3221 0.0 1.2 1 0011 507.0 -6. 501.00 -6.00 BB-5 502.10 
3222 0.0 4.8 1 01 -5 502.10 6 500.2 -0. 500.20 0.00 BB
3223 0.0 4.0 1 25 -5 502.20 3 504.3 -2. 502.25 -2.00 BB
3224 0.0 1.9 1 00 -5 502.20 8 506.0 -4. 502.00 -4.00 BB
3225 0.0 0.2 1 25 -5 502.20 4 503.8 -1. 502.50 -1.25 BB
3226 0.0 6.4 1 25 -5 502.60 6 503.8 -1. 502.50 -1.25 BB

Structure 
Name 

Stage at 0.5 
Probability 

Stage at 0.
Probabilit

Stage at 0.1 
Probability 

Stage at 0.04 
Probability 

Stage at 0.02 
Probability 

Stage at 0.01 
Probability 

Stage at 
0.004 
Probability 

Stage at 
0.002 
Probability 

Depth at 0.5 
Probability 

Depth at 0.2 
Probability 

2 
y 

 0.5 0.2 0.1 0 0.01 0 0.04 0.02 0. 04 .002 0.5 0.2
3192 491.19 491.92 492.53 92 4. 3 4 .92 493.40 493.71 49 11 494.44 -1.06 -0.3
3193 490.25 491.04 492.07 494. 493.06 493.46 493.89 14 494.73 -2.00 -1.21
3194 490.81 491.59 492.51 493.38 493.78 3 494. 495.13 -0.91494.2 49 -1.69 
3195 490.44 491.22 492.22 493.16 493.57 494.26 494.86 -0.78494.00 -1.56 
319 49 5 491.04 492.07 493.06 493.46 493.89 494.14 494.73 -1.75 -0.966 0.2
3197 4 7 491.64 492.56 41 493. 4 3 .17 -1.38 90.8  493. 81 94.26 494.5 495 -0.61
3198 4 9 491.95 492.81 59 493. 4 3 .39 -1.31 91.1 493. 99 94.45 494.7 495 -0.55
3199 4 9 491.86 492.74 54 493. 4 7 .33 -1.41 91.0 493. 94 94.39 494.6 495 -0.64
3215 4 3 499.56 501.30 58 501. 5 3 .32 -5.07 97.2 501. 73 01.92 502.0 502 -2.74
3216 5 8 516.92 518.41 83 519.05 5 4 .32 10.78 15.7 518. 19.33 519.5 520 11.92
3217 4 4 500.17 501.49 86 502. 5 8 .06 -5.31 98.9 501. 09 02.40 502.5 503 -4.08
3218 4 4 499.85 501.37 69 501. 5 7 .65 -3.46 98.0 501. 88 02.12 502.2 502 -1.66
3219 4 7 499.83 501.36 68 501. 5 5 .62 -2.03 97.9 501. 86 02.10 502.2 502 -0.17
3220 4 5 499.76 501.34 64 501.81 5 6 .51 -4.60 97.6 501. 02.02 502.1 502 -2.50
3221 4 4 499.73 501.32 61 501.78 5 1 .43 -9.46 97.5 501. 01.99 502.1 502 -7.27
3222 4 5 499.71 501.31 60 501.76 8 .38 -2.75 97.4 501. 501.96 502.0 502 -0.49
3223 4 3 499.75 501.33 63 501.80 5 .49 -6.62 97.6 501. 502.02 502.1 502 -4.50
3224 4 5 499.76 501.34 64 501.81 6 .51 -8.35 97.6 501. 502.02 502.1 502 -6.25
3225 4 2 499.79 501.35 66 501.84 1 .57 -5.93 97.8 501. 502.06 502.2 502 -3.96
3226 4 4 500.22 501.50 89 502.13 5 2 .11 -4.71 99.0 501. 02.44 502.6 503 -3.53

Figure le DA_ etai ram

Figure G.11  Examp _StrucD il.o a

 G.11  Examp  of F StrucD l.out – F e 3 

le of FDA eta ut – Fr me 4 
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St
Name 

ructure Depth at   0.1 
bility 

Depth at 0.04 
obabilit

Depth at 0.02 
oba

Depth at 0.01 
y 

Depth at 0.004 
 

Depth at 0.002 
bility

Total 
Dama
.

Total 
Damage at 

ty 

Total 
e at 

Total 
Damage at 
0.04 
Probability 

Proba Pr y Pr bility Probabilit Probability Proba  ge at 
0
Pr

5 
obability 

0.2 
Probabili

Damag
0.1 
Probability 

 0.1 0.04 0.02 0.01 0.004 0.002 0.5 0.2 0.1 0.04
3192 0.28 0.67 1.15 1.46 1.86 2.19 0.0 0.0 88.4 98.5
3193 -0.18 0.81 1.64 1.89 0.0 71.0 1.21 2.48 0.0 49.4 
3194 0.01 0.88 1.28 1.73 1.99 0.0 72.92.63 0.0 57.2 
3195 0.22 1.16 1.57 2.00 2.26 0.0 117.02.86 0.0 87.5 
3196 0.07 1.06 1.46 1.89 2.14 0.0 13.12.73 0.0 9.8 
3197 0.31 1.16 1.56 2.01 2.28 0.0 84.52.92 0.0 65.0 
3198 0.31 1.09 1.49 1.95 2.23 0.0 40.32.89 0.0 32.1 
3199 0.24 1.04 1.44 1.89 2.17 0.0 39.22.83 0.0 31.4 
3215 -1.00 -0.72 -0.38 -0.27 0.0  0.0 -0.57 0.02 0.0 0.0
3216 13.41 13.83 14.33 14.54 1 53.6 56.2 14.05 5.32 50.6 55.9 
3217 -2.76 -2.39 -1.85 -1.67 - 0.0  0.0 -2.16 1.19 0.0 0.0
3218 -0.13 0.19 0.62 0.77 0.0 17.10.38 1.15 0.0 14.2 
3219 1.36 1.68 1.86 2.10 2.25 0.0 12.32.62 0.0 10.8 
3220 -0.91 -0.61 -0.23 -0.09 0.0  5.5 -0.45 0.26 0.0 1.7
3221 -5.68 -5.39 -5.01 -4.89 - 0.0  2.9-5.22 4.57 0.0 2.6
3222 1.11 1.40 1.56 1.76 1.88 0.0 14.82.18 0.0 12.1 
3223 -2.92 -2.62 -2.23 -2.10 - 0.0  0.0 -2.45 1.76 0.0 0.0
3224 -4.66 -4.36 -3.98 -3.84 - 0.0  0.0-4.20 3.49 0.0 0.0
3225 -2.40 -2.09 -1.69 -1.54 - 0.0  0.0-1.91 1.18 0.0 0.0
3226 -2.25 -1.86 -1.31 -1.13 - 0.0  0.0-1.62 0.64 0.0 0.0

Structure 
Name 

Total 
Damage at 
0.02 
Probability 

T
D
0.01 
Probability 

o
D
0.004 
Probability 

o

0.002 
Probability 

u
am

0.5 
Probability 

t
a

Probability 

ge

Probabilit

cture 
age 

ctur
mag

y 

e
e 

Probability 

otal 
amage at 

T tal 
amage at 

T
D

tal 
amage at 

Str
D

cture 
age at 

Struc
Dam
0.2 

ure 
ge at 

Structure 
Dama
0.1 

 at 

y 

Stru
Dam
0.04 
Probabilit

at 

y 

Stru
Da
0.02 
Probabilit

e 
e at 

Structur
Damag
0.01 

 
at 

 0. 0.01 0.004 0.002 0.5 0.2 0.1 0.04 0.02 .01 02 0
3192 115.3 132.4 154.7 172 0.0 0.0 55.8 61.5 70.8 0.0 .8 8
3193 82.6 99.2 108.8 131 0.0 0.0 32.7 44.2 50.6 9.4 .3 5
3194 85.8 103.2 113.7 138 0.0 0.0 36.4 45.3 52.3 1.6 .2 6
3195 139.5 163.9 178.1 211 0.0 0.0 55.3 71.8 83.8 6.9 .6 9
3196 15.7 18.6 20.2 24 0.0 0.0 6.2 8.1 9.5 1.0 .0 1
3197 100.6 118.7 129.6 155 0.0 0.0 41.0 51.9 60.5 0.2 .4 7
3198 48.1 57.2 62.9 76 0.0 0.0 20.2 24.8 29.0 3.9 .1 3
3199 47.1 56.1 61.7 74 0.0 0.0 19.8 24.3 28.5 3.3 .8 3
3215 0.0 0.0 0.0 0 0.0 0.0 0.0 0.0 0.0 0.0 .7
3216 56.4 56.4 56.4 56 30.9 32.2 33.7 33.9 34.0 4.0 .4 3
3217 0.0 0.1 0.2 0 0.0 0.0 0.0 0.0 0.0 0.1 .5
3218 18.0 19.1 19.8 22 0.0 0.0 10.2 11.6 11.6 1.6 .4 1
3219 13.1 13.9 14.1 14 0.0 0.0 6.2 7.2 7.7 8.3 .6
3220 7.6 10.3 12.1 14 0.0 0.0 1.4 4.0 5.5 7.4 .2
3221 3.1 3.3 3.5 3 0.0 0.0 1.7 1.9 2.1 2.2 .8
3222 16.4 18.4 19.5 20 0.0 0.0 1.0 1.3 1.5 1.7 .7
3223 0.0 0.0 0.0 0 0.0 0.0 0.0 0.0 0.0 0.0 .1
3224 0.0 3.3 3.3 3 0.0 0.0 0.0 0.0 0.0 2.2 .4
3225 0.0 0.0 0.0 0 0.0 0.0 0.0 0.0 0.0 0.0 .8
3226 0.0 0.0 1.4 2 0.0 0.0 0.0 0.0 0.0 0.0 .8

Figure G.11  Example of FDA_StrucDetail.out – Frame 6 

Figure G.11  Example of FDA_StrucDetail.out – Frame 5 
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Structure 
Name 

Structure 
Damage at 

S

0.004 
Probability 

D
0.002 
Probability 

nt

0.5 
Probability 

t
age

0.2 
Probability 

e at 
0.1 
Probability 

0.04 
Probability 

C
D
0.02 
Probability 

nt
Dama
0.01 
Proba

Con
m

0.00

Co
a

0.0
o

tructure 
amage at 

Co
Dama

ent 
ge at 

Conten
Dam

 
 at 

Content 
Damag

Content 
Damage at 

ontent 
amage at 

Co ent 
ge at 

bility 

Da

Pro

tent 
age at 
4 

bability 

D

Pr

ntent 
mage at 
02 
bability 

 0.00 0.002 0.5 0.2 0.02 0.01 0.004 0.002 4 0.1 0.04
3192 91.8 102.9 0.0 0.0 6 44.5 52.5 62.8 69.9 32. 36.9
3193 64.5 79.0 0.0 0.0 8 32.1 39.8 44.3 52.3 16. 26.8
3194 67.2 83.5 0.0 0.0 8 33.5 41.6 46.5 54.7 20. 27.5
3195 106.3 128.7 0.0 0.0 2 55.7 67.0 71.8 82.9 32. 45.2
3196 1 14.6 0.0 0.0 6.2 7.6 8.2 9.5 2.0 3.6 5.0
3197 77.4 94.6 0.0 0.0 0 40.1 48.5 52.2 60.8 24. 32.6
3198 37.5 46.3 0.0 0.0 8 19.1 23.4 25.4 29.8 11. 15.4
3199 36.7 45.4 0.0 0.0 5 18.6 22.8 25.0 29.3 11. 14.9
3215 0.0 0.2 0.0 0.0 0.0 0.0 0.0 0.5 0.0 0.0
3216 34.0 34.0 19.7 2 22.4 22.4 22.4 22.4 21.4 22. 22.3
3217 0.2 0.5 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0
3218 11.6 12.6 0.0 0.0 6.4 7.5 8.2 4.0 5.5 9.8 
3219 8.4 8.8 0.0 0.0 5.4 5.6 5.7 4.6 5.1 5.8 
3220 8.6 9.4 0.0 0.0 2.1 2.9 3.4 4.7 0.3 1.5
3221 2.3 2.5 0.0 0.0 1.0 1.1 1.2 1.3 0.9 1.0
3222 1.8 2.0 0.0 0.0 0 14.9 16.6 17.7 18.7 11. 13.5

Figure G.11  Example o A_St etail  – Fram  f FD rucD .out e 7

Structure 
Name 

Other 
Damage at 
0.5 
Probability 

Other 
Damage at 
0.2 
Probability 

Other 
Damage at 
0.1 
Probability 

Other 
Damage at 
0.04 
Probability 

Other 
Damage at 
0.02 
Probability 

Other 
Damage at 
0.01 
Probability 

Other 
Damage at 
0.004 
Probability 

Other Damage at 0.002 Probability 

 0. 0. 0 .0 05 2 .1 0.04 0 2 0.01 0.004 0. 02
3192 . . 0 0.0 0. 0 F g\BB95A.S  0 0 0 0 .0 0 0.0 0.0 .0 E:\DATA\ DA\BearTrn
3193 . . 0 0.0 0. 0 F g\BB95A.S  0 0 0 0 .0 0 0.0 0.0 .0 E:\DATA\ DA\BearTrn
3194 E:\DATA \BearTrn BB95A.S 0.0 0.0 0.0 0.0 0.0 0.0 0.0 0.0 \FDA g\
3195 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3196 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3197 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3198 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3199 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3215 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3216 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3217 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3218 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3219 0.0   0 0 E:\DA A\BearT B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD rng\B
3220 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B
3221 0.0   0 0 E:\DA A\BearT B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD rng\B
3222 0.0   0 0 E:\DA A\Bear B95A.S 0.0 0.0 0.0 0. 0.0 0. 0.0 TA\FD Trng\B

Figure G.11  ple of FDA_StrucDetail.out  Fram  Exam  – e 8
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Appendix H  
 
 
 

HEC-FDA Computation Procedures 
 
 

H.1 Introduction 
 
This appendix describes the computations used by the HEC-FDA package 
to obtain the following analysis variables:  1) exceedance probability 
curves; 2) project reliability; 3) expected annual damage, 4) flood damage 
reduction benefits, and 5) probable flood stages conditional on the 
occurrence of a particular exceedance probability event.  These variables 
are computed from various relationships that represent watershed runoff 
and economic factors important to estimating flood damage (e.g., 
discharge-exceedance probability, stage-discharge and stage-damage 
curves).  The contributing relationships are characterized by both a best 
estimate and the uncertainty in this estimate. 
 
Contents 
 
 ● Monte Carlo Simulation 
 ● Sampling Algorithm for Numerical Integration 
 ● Uncertainty Distributions 
 ● Levee Analysis 
 ● Project Reliability and Flood Risk 
 ● Computation of Equivalent Annual Damage 
 
 

H.2 Monte Carlo Simulation 
 
 

H.2.1 Overview 
 
Monte Carlo simulation (Davis and Rabinowitz 1967) is used in FDA to 
derive the expected annual damage corresponding to a particular 
plan/analysis year for a damage reach.  The expected annual damage 
(EAD) is the mean damage obtained by integrating the damage 
exceedance probability curve for the damage reach.  The damage-
exceedance probability function is obtained from the discharge-
exceedance probability, stage-discharge, and damage-stage functions 
derived at a damage reach index location.  The inclusion of uncertainty for 
these variables requires a numerical integration approach be applied.  
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Without uncertainty, the damage-exceedance probability curve can be 
obtained directly without resorting to numerical simulation approaches. 
 
Monte Carlo simulation is the numerical integration approach.  It relies on 
an exceedance probability analysis of samples of the contributing random 
variables obtained from the generation of random numbers.  Although 
inelegant, the technique is computationally efficient in comparison with 
other techniques as the number of contributing variables exceeds about 
five. 
 
 

H.2.2 Numerical Integration with Monte Carlo Simulation 
 
Expected annual damage is the probability weighted average of all 
possible peak annual damages.  It is also termed the mean or expected 
annual damage.  As a simple example of computing a probability weighted 
average, consider the rolling of a die.  The probability of obtaining any 
outcome of any roll of a die is 1/6, since the probability of obtaining any 
face of the die is considered equally likely (at least if the die is fair).  The 
probability weighted average is then computed as: 
 

 ( 5.3654321
6
16

1

=+++++=∑
=

=

i

i
ii pd )  (1) 

 
where di is the possible outcome of rolling a die, and pi is the probability 
of the outcome.  The probability weighted average or expected outcome of 
3.5 obtained in equation (1) could be obtained by performing a die rolling 
experiment.  The experiment would just involve many trials of rolling the 
die and averaging the outcome.  As the number of trials becomes large the 
average obtained will equal 3.5. 
 
Performing trials with the die is an application of a Monte Carlo 
simulation to obtain an average.  In rolling the die, random integers are 
obtained in the inclusive interval 1 to 6, and a statistical analysis of the 
outcome is performed to obtain an average.  Consequently, Monte Carlo 
simulation or application of Equation 1, are equivalent procedures for 
obtaining the mean or expected value. 
 
Other statistical characteristics of rolling a die could be obtained, such as 
by performing a class category analysis on the outcomes to determined the 
probability of obtaining any outcome.  If this were done, the probability of 
obtaining any die face in a single trial would be found to be 1/6. 
 
This same type of sampling experiment can be performed to obtain EAD.  
Computation of EAD is somewhat more difficult in that damage is a 
continuous random variable, unlike the outcome of rolling a die, which  

H-2 
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has discrete outcomes.  Consequently, damage probability is either stated 
for an interval, or more typically as, the probability of exceeding a 
particular value.  These probabilities are defined by the damage 
exceedance probability function or equivalently, the cumulative 
distribution function as defined by: 
 

  (2) [ ] ( ) ( )dDDfDFdDP
d
∫
∞

==>

 
where D is the annual damage, F(D) is a function defining the damage 
exceedance probability curve, f(D) is the probability density function 
(units of probability per increment of damage), and P[D>d] is read as "the 
probability that D exceeds d." 
 
The probability density function can be used to calculate the EAD or 
equivalently the probability weighted average damage by performing the 
following numerical integration: 
 

  (3) ( )∫ ∑
∞ =

=

Δ=
0 1

~
Ni

i
piDdDDDfEAD

 
 where the integral in equation (3) is approximated by a sum as in equation 
(1), Δp is the probability of damage being in an interval, Di is the midpoint 
damage of this interval, and N is the number of intervals (Figure H.1).  
The approximation turns the integration of a continuous random variable 
into that of a discrete variable much as in the computation of the average 

outcome for rolling a die shown in Equation 1.  The difference between 
the equations is that Equation 1 is exact and the probability is for a  

Figure H.1 Numerical Integration of Probability Density Function to Obtain EAD
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discrete outcome; whereas, Equation 3 is approximate and Δp is an 
interval probability. 
 
The numerical integration is necessary because the damage-exceedance 
probability function is not defined by a continuous analytic function 
making an analytic integration impossible.  Given that an exact analytic 
value cannot be obtained, how good is the approximation provided in 
Equation 3?  The approximation can be made as accurate as possible by 
decreasing the interval Δp, or equivalently, increasing the number of 
intervals shown in Figure H.1 (page H-3). 
 
Recognizing that equal probability increments implies that Δp=1/N, where 
N is the number of increments in Figure H.1 (page H-3), Equation 3 can 
be rewritten as: 
 

 ∑ ∑
=

=

=

=

=Δ=
Ni

i

Ni

i

i
i N

D
pDEAD

1 1
 (4) 

 
 

H.2.3 Computing Expected Annual Damage, Exceedance 
Probability, and Event Probabilities 

 
The inclusion of uncertainty in estimates of the variable contributing to 
damage makes it possible to obtain both a best estimate of expected annual 
damage and a distribution of possible values about this best estimate.  
Additionally, an expected set of exceedance probability functions and 
event conditional stages can be computed as a consequence of providing 
these estimates of uncertainty. 
 
The relationship between estimation uncertainty and the distribution of 
EAD can be understood by considering a sensitivity analysis application to 
computing EAD with a flow-exceedance probability curve, rating curve 
and stage-damage relationship as shown in Figure H.2 (page H-5).  The 
figure shows that high-bound, low-bound and best estimates of each 
relationship are combined to obtain a corresponding range in estimates of 
EAD.  This range in estimates could be thought of as defining a rough 
distribution of possible EAD estimates.  The difficulty with this sensitivity 
analysis approach is that the relative likelihood of the range in estimates is 
not known. 
 
Monte Carlo simulation is used to improve on the sensitivity analysis by 
integrating all possible random occurrences of the contributing 
relationships as shown in Figure H.3 (page H-6).  This differs from the 
basic Monte Carlo application described in the previous section by 
obtaining a random sample of relationships or random functions instead of  

H-4 
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Figure H.3  Monte Carlo Simulation Algorithm for Estimating EAD 
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Figure H.2 EAD Computation Sensitivity Analysis 

obtaining a random sample of individual values.  The algorithm used to 
obtain random samples of each relationship is described later. 
 
The Monte Carlo algorithm used to obtain the distribution and best 
estimate of EAD, expected exceedance probability curves and event 
related conditional stage exceedance probability proceeds as follows: 
 
 1. Obtain a random sample of the contributing relationships 
 Each relationship is sampled to obtain a single realization of the 

discharge-exceedance probability, the stage-discharge (rating) and 
the stage-damage functions. 

 
 2. Compute exceedance probability curves 
 Compute the stage-exceedance probability function by using the 

rating curve to transform the sample discharge-exceedance  

 H-5 
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Figure H.3 Monte Carlo Simulation Algorithm for Estimating EAD 

 probability function into a stage-exceedance probability curve; 
and, compute the damage exceedance probability function by using 
the sample stage-damage function to transform the stage-
exceedance probability curve into a damage-exceedance 
probability function. 

 
 3. Save intermediary results for computing expected exceedance 

probability curves 
 Intermediary results are saved for the computation of expected 

exceedance probability functions by adding discharges, stages and 
damages for specified probabilities to values summed for previous 
simulation. 

 
 4. Save intermediary results for computing event conditional 

stage probabilities 
 Event conditional stages are saved for later estimation of 

conditional stage exceedance probabilities.  The stages are 
conditional on specified exceedance probabilities (e.g., conditional 
on the 0.1, 0.02, 0.01 stage being exceeded).  The stage for each of 
the events of interest is saved in a stage class interval.  For  

 
H-6 
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 example, consider that a stage of 21.56 corresponds to the 0.01 

exceedance probability for the sample stage exceedance 
probability curve obtained in Step 2.  This value is saved in a 
predetermined class interval that may have minimum and 
maximum limits of respectively, 21.0 and 22.0. 

 
 5. Save intermediary results for computation of EAD 
 The EAD for the sample contributing relationships is computed by 

integrating the damage exceedance probability curve.  This value is 
both added to a sum of EAD values from previous iterations and 
saved in a damage class interval. 

 
 6. Repeat sampling Steps 1 through 5 
 Additional samples of exceedance probability curves and EAD are 

obtained by repeating Steps 1 through 5. Sampling ceases when an 
accuracy criterion is met. 

 
 7. Compute expected exceedance probability curves 
 Divide the summed values obtained in Step 3 for discharge, stage 

and damage for each exceedance probability by the number of 
samples. 

 
 8. Compute conditional event stage distributions 
 The process in Step 4 of placing stages in class intervals results in 

an exceedance probability histogram of stages for each exceedance 
probability event of interest.  Table H.1 (page H-8) provides an 
example of some possible results for the 0.01 exceedance 
probability event.  As shown in the table, the exceedance 
probability histogram is converted into an event conditional 
exceedance probability function. 

 
 9. Compute best estimate of EAD and Distribution of EAD 
 The best estimate of EAD is computed as the average of the 

samples summed in Step 5.  The class interval exceedance 
probabilities for EAD are converted to an exceedance probability 
distribution using the same procedure for event conditional stages 
(Table H.1, page H-8). 

 
 In performing this simulation, only the stage versus total damage 

relationship is used to obtain the damage exceedance probabilities 
function and corresponding EAD.  Damage-exceedance probability 
functions and EAD for damage categories are proportioned in the 
same ratio as the traditional (no uncertainty) category damage is to 
the tradition total damage values. 
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Table H.1 
Calculating Event Conditional Stage Exceedance Probability 

from Monte Carlo Simulation Frequencies 
 

Lower 
Limit 
Stage 

Upper 
Limit 
Stage 

 
 

Frequency 

 
Cumulative 
Frequency 

 
Cumulative 
Probability 

 
Exceedance 
Probability 

<21.0 21.0 200 200 0.01 0.99 
21.0 22.0 5000 5200 0.26 0.74 
22.0 23.0 10000 15200 0.75 0.25 
23.0 24.0 5000 20200 0.99 0.01 
24.0 25.0 100 20300 1.0 0.0 
25.0 25.0> 0 20300 1.0 0.0 

 
 

H.2.4 Monte Carlo Simulation Options for Calculating EAD 
 
The Monte Carlo simulation can be expanded to include other contributing 
relationships in the calculation of EAD.  Table H.2 describes the options 
for including other relationships.  Notice that some relationships involve 
uncertainty calculations and others (levee effects and interior stage versus 
exterior stage relationships) are specified without uncertainty.  The  
 

Table H.2 
Contributing Relationships Used in EAD Calculation 

 
Contributing 
Relationship 

Uncertainty Distribution 

Flow/stage frequency curve yes 
Flow transform yes 
Rating curve yes 
Wave overtopping of flood wall or levee yes 
Levee impact on damage no 
1Exterior versus interior stage no 
Stage versus damage yes 

 
 1 Used to directly convert exterior river stage, interior levee failure stage, or with wave overtopping 

 
inclusion of additional relationships does not require any new aspect of 
performing the simulation except to require the creation of additional 
random samples of another relationship.  For example, Figure H.4 (page 
H-9) displays the additional step of using the flow transform to convert a 
reservoir inflow-exceedance probability curve to a regulated exceedance 
probability curve. 
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Figure H.4 Adding Computation of Regulated Outflow to Monte Carlo Algorithm 
for Computing EAD 

 
H.3 Sampling Algorithm for Numeric Integration 

 
 

H.3.1 Overview 
 
Application of Monte Carlo simulation requires a method for producing 
random samples and criteria for determining the number of samples 
needed to obtain a numerical integration with pre-specified accuracy.  The 
algorithms (previously described) produce random samples of the 
contributing relationships that are combined to obtain samples of EAD, 
exceedance probability functions and event conditional stage probabilities.   

 H-9 
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This sampling depends on the algorithm for generating random numbers.  
The generation of random numbers and the random sampling of 
contributing relationships is the means by which Monte Carlo simulation 
performs a numerical integration.  As previously discussed, the numerical 
integration accuracy increases with the number of simulations.  The 
criteria used to determine the number of simulations for a desired level of 
accuracy is described in the next section.  The related problem of 
obtaining a numerically accurate integration of the damage-exceedance 
probability function is also discussed later. 
 
 

H.3.2 Sampling from the Log-Pearson III Distribution 
 
Random samples of a log-Pearson III (LPIII) exceedance probability curve 
are obtained from random samples of the mean and standard deviation of 
the logarithm of the flow, computing a log-normal relationship and 
adjusting for the skew of the distribution.  This scheme produces the same 
sampling variability inherent in the calculation of confidence limits and 
expected probability as described in Bulletin 17B (IACWD, 1982), the 
federal guidelines for performing flood-flow exceedance probability 
analysis. 
 
The random sampling is based on a Bayesian statistical approach for 
assessing uncertainty (Stedinger, 1983).  A goal of Bayesian estimation is 
to develop the distribution of possible population parameters (the posterior 
distribution) by combining statistics of the observed sample (e.g., 
observed stream flows), and other information on the probable range of 
population parameters (the prior distribution).  In this instance, the prior 
distribution is based on the assumption that an equally likely set of parent 
populations could have produced the estimated sample mean, standard 
deviation and resulting log-normal distribution.  The resulting posterior 
distribution of the population mean and standard deviation is given by: 
 

 [ ] ( ) ⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
Φ==>

N
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where X and S are respectively the sample mean and standard deviation  
of the logarithm of flow values obtained from a record length of N years, μ 
is the population mean, Φ( ) is the normal distribution defined by the 
parameters shown, σ is the population standard deviation, and  is the 
chi-square distribution with N-1 degrees of freedom.  Random estimates 
of the log-normal distribution are obtained by generating random  

2
)1( −Nχ
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estimates of normal and chi-square numbers, applying Equations 5 and 6 
to obtain μ and σ and computing the distribution (Figure H.5). 

 
This scheme for computing uncertainty does not account for the effect of 
shape or skew that is a characteristic of the LPIII distribution.  This 
omission of the sampling uncertainty in skew is in keeping with the 
approach taken in the Bulletin 17B guidelines where sampling error is 
only estimated for a log-normally distributed variate.  Consequently, the 
sampling scheme used for the LPIII distribution follows the Bulletin 17B 
method of computing uncertainty for a log-normally distributed variate 
and applying this uncertainty to an LPIII distribution with the same mean 
and standard deviation as the log-normal distribution.  Given this 
estimation of uncertainty, the samplings of the LPIII distribution (see 
Figure H.6, page H-11) proceeds as follows: 
 
 1. Compute log-normal and LPIII distributions from sample 

statistics 
 The log-normal and LPIII distributions are calculated using the 

following frequency factor equations: 
 
 SZXQ p

s +=10log  (7) 
 
 SKXQ PG

S
G ,10log +=  (8) 

Figure H.5 Random Samples of Normal Populations from Population 
Parameters μ, σ 
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H-12 

Figure H.6 Random Selection of LPIII Distribution from Random 
Log-Normal Distribution 

 
 where Qs and Q  are respectively the flows for the log-normal and 

LPIII distribution, Zp is the standard normal deviate and KG,P is the 
LPIII deviate for a sample skew G, and exceedance probability P. 

s
G

 
 2. Randomly select a sample normal distribution 
 Utilize Equations 5 and 6 to obtain a sample of the population 

mean and standard deviation.  Compute the log-normal distribution 
from the population values as: 

 
  (9) σμ p

r ZQ +=10log
 
 3. Calculate the random probabilities resulting from the randomly 

selected normal distribution 
 Compute the random probability associated with the randomly 

selected normal distribution for a discharge with exceedance 
probability computed from Equation 7 as: 
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 where  is the flow value computed by Equation7 for 

exceedance probability P and Φ-1 is the inverse normal distribution 
(i.e., given a flow value, the inverse provides the exceedance 
probability). 

rs
P QQ =

 
 4. Utilize the random probabilities to obtain a random sample of the 

LPIII frequency curve 
 Assign the random probability Pr to a flow value , where 

was obtained from Equation 8.  Compute as many pairs of Pr, 
values as needed to adequately define the sample LPIII 

exceedance probability curve. 

s
G

r
G QQ =

s
GQ
r
GQ

 
 

H.3.3 Random Sampling of Graphical or Non-Analytic 
Relationships 

 
The sampling of non-analytic or graphical relationships is necessarily ad 
hoc because a statistical sampling theory is not available.  The algorithm 
used in this instance applies to any of the other contributing relationships 
used in the computation of EAD: 1) non-analytic stage or graphical 
exceedance probability curves; 2) discharge transforms; 3) rating curves; 
4) wind waves and 5) stage damage relationships. 
 
Random sampling of any of the graphical relationships is done by 
calculating the values for a particular confidence limit (see Figure H.7, 
page H-13).  The algorithm is simply employed by: 1) generating a 
uniform random number between 0 and 1; and 2) calculating the 
confidence limit values for the particular relationship of interest.  For 
example, if 0.95 is the value resulting from the randomly selected value, 
then the 95% chance confidence level confidence limit is calculated as the 
randomly selected relationship for the algorithm described previously.  
Note, that the confidence limit for a contributing relationship is randomly 
selected independently of other confidence limits randomly selected for 
other contributing relationship used in the Monte Carlo simulation. 
 
Classical statistical theory cannot be used to justify sampling possible 
population values from confidence limits as is done with this algorithm.  
Instead, justification for this algorithm must be sought from the sampling 
of the log-Normal distribution described in the previous section, which 
relies on a Bayesian approach.  As was pointed out, the Bayesian approach 
results in the same uncertainty distribution for population values as is 
obtained with a classical statistical approach to obtain the uncertainty  

 H-13 
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Figure H.7  Sampling of Non-Analytic or Graphical Relationships 

distribution used in the 17B guidelines.  In the case of the approach for 
graphical exceedance probability curves, the sampling from confidence 
limits obtained from an uncertainty distribution might be justified in 
analogy with this Bayesian approach. 
 
The difficulty with this algorithm is that the sampling based on confidence 
limit values is very restrictive on the possible shapes of the graphical 
relationship.  This restriction on shape results in some overestimation in 
the variance of the derived distribution of EAD.  However, generalizing 
the shapes used in the sampling algorithm depends on some parametric 
representation of the graphical relationships.  The representation is not 
available, leaving the current algorithm as the best available at this time. 
 
 

H.3.4 Random Sampling of Uncertainty Relationships 
Using a Random Number Generator 

 
The sampling of uncertainty distributions depends on the generation of 
uniform random numbers in the range 0.0 to 1.0 by the linear congruential 
method (Davis and Rabinowitz, 1967) and the transformation of the 
uniform numbers to the distribution desired.  The linear congruential 
method takes the form: 
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where Xn is the previous number selected, Xn+1 is the current number to be 
generated, a and b are constants, m is a constant known as the modulus, 
and "mod" is the modulus or remainder function.  The sequence is started 
for n=1 by a seed value that is set to a default value within the software.  
The selection of the constants and seed value is critical for an effective 
generation's scheme.  This generation scheme, as well as any other using a 
computer algorithm, is considered to produce pseudo-random numbers 
because the sequence repeats with period depending on the selection of the 
constants in equation (11).  The constants are selected as shown in Table 
H.3 to obtain a long period of random numbers that is approximately equal 
to the size of the modulus, m.  The resulting sequence of numbers has 
characteristics that are effective for performing numerical integration with 
Monte Carlo simulation. 
 

Table H.3 
Constants for Linear Congruential Method1 

 
seed 1331124727 

a 65539 
b 0 
m 2147483647 

 1 Constants appropriate for 32-bit machine.  Used in 
Equation 11. 

 
The uniform random numbers can be used to randomly sample the 
graphical relationship directly.  As described in the previous section, a 
number selected at random between 0.0 and 1.0 can be used to select the 
confidence level for selecting a graphical curve. 
 
The application to the LPIII distribution requires that deviates from both a 
normal distribution and a chi-square distribution be obtained from a 
transformation of the numbers randomly sampled from a uniform 
distribution.  The normal deviates can be obtained from the following 
transform due to Box and Muller (1958) (also see, Press et al., 1989): 
 

 ⎥⎦
⎤

⎢⎣
⎡−=

s
sun ii
)ln(2  (12) 

 

 ⎥⎦
⎤

⎢⎣
⎡−= ++ s

sun ii
)ln(2

11  (13) 

 
where ui and ui+1 are numbers randomly selected from a uniform 
distribution defined between -1.0 and 1.0, ni and ni+1 are numbers that will 
be normally distributed, and s is computed as: 
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The application of this transform is accomplished by converting the 
by 

s 

e 

hi-square deviates are obtained by applying the inverse theorem (see 

ive 

orithm 

 

uniform numbers generated over the range 0.0 to 1.0 in Equation 11 
letting ui = 2(Xi) - 1.0.  When the resulting uniformly distributed number
result in s < 1.0, the current pairing is discarded and a new pair is 
generated.  On the average, about 1.27 uniform random variates ar
needed to generate a single normally distributed variate. 
 
C
Mood et al., 1969, theorem 12, Chapter 5).  This theorem is applied by 
interpolating a chi-square variate from a table of the chi-square cumulat
distribution function given a random probability equal to a number 
generated from the uniform distribution using Equation 11.  The alg
used to compute the chi-square distribution was obtained from Press et al. 
1989, pg 160.  The algorithm utilizes the following relationship between 
the chi-square and incomplete gamma function: 
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here N is the period of record used to compute the sample standard 

he 

he numerical integration accuracy of the Monte Carlo simulation 

r the 
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e.  In the 

is the 

he following confidence limit results from asymptotic normality of the 

 

w
deviation of the LPIII distribution, a = (N-1)/2, x = (y/2), and G( ) is t
incomplete gamma function. 
 
 

H.3.5 Numerical Error Tolerance for Simulations 
 
T
improves with the number of simulations.  The accuracy criteria 
developed for the simulation relies on the central limit theorem fo
mean and the asymptotic normality of uncertainty distributions about 
exceedance probability curves.  The central limit theorem (see Mood e
1969) states that the sample mean of any random variable is 
asymptotically normally distributed about the population valu
case of this application of Monte Carlo simulation, the sample EAD 
results from a finite number of simulations, and the population value 
value that would be obtained from an infinite number of simulations (i.e., 
the no numerical error solution). 
 
T
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where MEAD is the average EAD obtained from n simulations, μEAD is the 

1-α is the 

 

numerical error EAD, S is the standard deviation of the damage 
exceedance probability curve estimated after n simulations, and z
standard normal deviate for confidence level α.  This confidence limit can 
be rearranged to produce an error bound of the numerical integration error:
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here ε is a tolerance for the confidence level α.  The error bound is set in 

with 

 similar error bound is computed for exceedance probability function.  In 
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D is 

he error bounds constrain the numerical integration error of the 
 or 
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 by the 

 

H.3.6 Integrating the Damage-Exceedance Probability 

he final computation in an individual Monte Carlo simulation is to 
ple 

 rating 

sed to 

w
the software such that α=0.95, ε=0.01 and n≤500,000.  If the limiting 
number of simulations is reached the computation of EAD terminates 
a warning. 
 
A
this case, the computed quantile (e.g., flow, stage or damage) is the mean 
value derived for the exceedance probability of interest.  The error bound 
focuses on the exceedance probability where the corresponding quantile 
has the largest estimation standard error.  This estimation standard error i
set to S in Equation 17 and computed as part of the simulation.  The 
confidence limit and tolerance are set equal to that used for the error 
bound of EAD.  The simulations will terminate only when the error 
tolerance for both estimating exceedance probability function and EA
met or when the maximum number of simulations is reached. 
 
T
simulation but does not reduce the uncertainty in estimates of EAD
exceedance probability curves.  The uncertainty in estimate is a functio
of the error in models and estimates of parameters as indicated by the 
uncertainty distributions provided.  The uncertainty shown by the 
sensitivity analysis depicted in Figure H.2 (page H-5) is not altered
number of simulations performed.  Rather, the number of simulations 
reduces the numerical error involved in combining the relationships via
the algorithm depicted in Figure H.3 (page H-5). 
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Function to Obtain EAD 
 
T
integrate the damage-exceedance probability function to obtain a sam
value of EADi as shown in Figure H.3 (page H-5).  The damage-
exceedance probability function is not analytic being derived from
curves, stage-damage relationships, etc., that are not analytic.  
Consequently the following trapezoidal integration scheme is u
obtain an estimate of EADi: 
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here fi(D) is the probability density function (PDF) obtained from the ith w

simulation, for annual  damage, D; h is the number of incremental 
intervals of size ΔD used to approximate the differential dD; jD  and jif ,  
are the average values of D and fi(D) over this interval, and th iffere  
of exceedance probabilities over this interval 

e d nce
( ) Dfpp ijjj Δ=− +1 ; and, 

D1p1 and Dhph are end point approximations to the end intervals of 
integration, zero and infinity.  The assumption is made in the softwa
D1 = 0, resulting in D1p1 = 0. 
 

re that 

he trapezoidal rule approximation accuracy improves with increasing 
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T
number of intervals, h.  The number of intervals is determined by 
computing EAD for damage exceedance probability curves determ
a sensitivity analysis such as shown in Figure H.2 (page H-5) prior to 
performing the Monte Carlo simulation.  The sensitivity analysis is 
performed by obtaining damage exceedance probability curves by 
combining confidence limit estimates of the contributing relationsh
the same confidence level.  The confidence limits investigated are 
obtained for confidence levels, 0.5, 0.75, 0.25, 0.9, 0.1, 0.99, 0.01, 
0.001. 
 
T
for each confidence limit investigated in the sensitivity analysis.  The 
recursive procedure involves: 1) selecting an interval size; 2) computin
EAD; 3) dividing the interval size in half, where appropriate, and re-
computing EAD; 4) computing the relative difference between EAD 
values obtained in steps (2) and (3); and 5) determining if the relative
difference in step (4) is less than 1%; if this tolerance is met; then the  
interval used in step (2) is selected; otherwise steps, 2-4 are repeated w
the interval size used in step (3) used in step (2).  The division of interval 
sizes in step (3) is only performed when the interval size reduction will 
make a significant difference to the computation of EAD.  This limits th
number of intervals used which is important to the computational 
efficiency of Monte Carlo simulation.  The more intervals used, th
computational time required to perform a simulation.  Intervals are divided
until the error tolerance is met or the maximum number of 200 is obtained.  
Experience has shown that 200 intervals provide sufficient accuracy given 
the data typically available. 
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H.4 Uncertainty Distributions 
 
 

H.4.1 General 
 
The estimation of uncertainty distributions for the contributing 
relationships will involve a certain amount of judgment, except for the 
case of a flow or stage exceedance probability curve where the uncertainty 
is determined from the length of record.  The judgment used in estimating 
uncertainty for other contributing variables should correspond to the same 
factors contributing to uncertainty in the exceedance probability curves.  
The uncertainty in the exceedance probability functions is due to the 
estimation uncertainty in the parameters, which are the mean and standard 
deviation for the LPIII (the skew being ignored). 
 
This focus on parameter uncertainty effectively examines the uncertainty 
in the mean relationship given a set of scattered observations.  In other 
words, the focus is on the uncertainty in fitting an exceedance probability 
function to an observed set of plotting positions and does not reflect the 
scatter of the plotting positions about the best estimates. 
 
To understand the difference between uncertainty in fitted relationships 
and the uncertainty due to scatter, consider a split sample exceedance 
probability analysis of a gage having 100 years of record.  Estimate both 
pairs of frequency curves and determine the top ranked event from 
separate 50-year records.  In general, the difference between the 1% 
chance flow estimated by the frequency curves will be considerably less 
than the difference between the top ranked events.  The smaller variation 
in the fitted relationships, as compared to the plotting positions, represents 
the difference between uncertainty for best fit relationships and that for 
scatter about these relationships.  If uncertainty in the contributing 
relationships such as rating and stage-damage curves is based on scatter, 
then the specified uncertainty will be too great.  This in turn will probably 
increase the magnitude of the EAD best estimate and certainly increase the 
variance of the EAD distribution. 
 
Therefore, the principle focus of estimating uncertainty should be on the 
potential variation in the best estimate of the contributing relationship.  
Consequently, if a sensitivity analysis is performed to determine the 
uncertainty in a contributing relationship, such as in varying Manning n to 
determine errors in rating curves, then the parameters varied should be 
reasonably likely to occur together.  Combining extreme parameter values 
probably reflects scatter rather than the reasonable variation in a fitted 
relationship. 
 
The error distribution about exceedance probability curves is determined 
by the effective record length and the type of exceedance probability curve 
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specified.  In the case of the LPIII distribution, the uncertainty is 
computed as described previously.  Also, refer to ETL 1110-2-537 (Corps 
of Engineers, 1995) for the method used to calculate the uncertainty 
distribution for non-analytic (graphical exceedance probability curves).  
Normal, log-normal and triangular error distributions are available for 
specifying uncertainty about other contributing relationships, as is 
described in the next two sections. 
 
 

H.4.2 Triangular Error Distribution 
 
The triangular distribution is the simplest available for use with 
contributing relationships that are not exceedance probability functions 
(see Figure H.8, page H-20).  This triangular distribution is specified for 
either: 1) each paired value describing the contributing relationship (e.g., 
discharge- stage function); or 2) for a specified value in the paired 
relationship (e.g., for 1000 cfs corresponding to a stage of 10.0 feet).  In 
the case of the specified value, the bounds on the error distribution are 
linearly interpolated to zero for values less than this specified value and 
remains unchanged for values greater than this value. 
 
The parameters of the distribution are the mode and the range.  The mode 
is the most frequently occurring value, or the peak of the probability 
density function for the triangular distribution.  The range is simply 
defined by the minimum and maximum possible values for the dependent 
variable in the paired relationship.  
 
Inspection of Figure H.8 (page H-20) shows that the triangular distribution 
need not be symmetric.  The effect of the asymmetry is to cause the mean 
or expected value associated with the triangular distribution to be different 
than that for the mode.  Consequently, Monte Carlo simulation will 
produce on the average a contribution relationship that is different than 
might be assumed to occur when specifying the mode as a no uncertainty 
estimate of the relationship. 
 
 

H.4.3 Normal and Log-Normal Distributions 
 
The normal distribution is specified by a mean and standard deviation of 
the errors (see Figure H.9, page H-21).  The log-normal distribution also is 
specified by a mean and standard deviation of the logarithms (base 10) of 
interest.  Consequently, estimation of the errors needs to be performed in 
log space for this distribution.  For example, the paired values of discharge 
and stage should be plotted on log10-log10 scale; and the best fit 
relationship and the errors should be determined from this scale.  The 
relationship is then specified by the untransformed best fit values (i.e. by  
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Figure H.8  Triangular Distribution Application 

taking anti-logs of the best fit) together with the standard errors of the 
logarithms. 
 
The normal distribution is symmetric with respect to the mean.  
Consequently, the mean or expected relationship obtained from the Monte 
Carlo simulation will be the same as the specified relationship.  This 
differs from the average result obtained with an asymmetric triangular 
uncertainty distribution as explained in the previous section and shown in 
Figure H.9.  The estimation of the log-normal distribution is most 
conveniently performed in log-space, thus reducing the problem in 
estimating a normally distributed log variate.  However, the log-normal 
uncertainty distribution is asymmetric when plotted on a linear scale, and, 
like an asymmetric triangular distribution, will result in an average  
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Figure H.9  Normal Distribution of Errors 

relationship that differs from the specified relationship when performing a 
Monte Carlo simulation. 
 
 

H.4.4 Application to Stage versus Damage Relationships 
 
The Monte Carlo simulation algorithm reduces the computational effort 
required by only computing total damage.  However, stage versus damage 
is specified for each damage category with a corresponding uncertainty in 
the estimates. The total damage is easily obtained by aggregating the 
specified (no uncertainty) estimates in the case of triangular and normally 
distributed uncertainty distributions.  Logarithms of the specified 
estimates are added in the case of log-normally distributed uncertainty 
distributions. 
 
The uncertainty distributions are not so easily aggregated.  The 
assumption is made that the uncertainty estimates are uncorrelated.  
Consequently, the standard errors of the normal distribution and the log 
standard errors for the log-normal distribution can be added by summing 
these standard errors squared and taking the square root (variances added).  
The triangular distribution is handled in the same manner in that the 
maximum and minimum ranges are added to obtain the range of an 
equivalent triangular distribution. 
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H.5 Levee Analysis 
 
Computation of damage exceedance probability functions with levees is 
straight forward when the levee only fails due to overtopping, but requires 
some additional computations when geotechnical failure can occur.  The 
computation of the damage exceedance probability curve for levee failure 
due to overtopping only is easily done by setting the zero damage point to 
a stage corresponding to the top of levee.  The integration of the damage 
exceedance probability curved using equation (18) to obtain EAD is then 
applied as without a levee. 
 
The computation of the damage exceedance probability curve when 
geotechnical failure is possible needs to consider the probability of failure 
below the top of levee.  The damage exceedance probability curve is 
calculated in this situation as follows (Figure H.10): 

 
 [ ] ( ) f
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where P[dj-≤ D < dj+1 ] is read as "the probability that the annual damage, 
D, will be in the interval dj-1≤ to dj"; pm is the exceedance probability 
corresponding to the stage that  cannot cause damage due to geotechnical 
or overtopping failure; pj and pj+1 are the exceedance probabilities for 
stages that cause damage corresponding to dj≤ and dj+1 in the absence of 
the levee; and  is the failure probability of the levee for the stage 
with exceedance probability midway between pj and pj+1.  Equation 18 
then can be applied to this damage exceedance probability curve to obtain 
EAD by letting: 

f
jp 2/1+
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Figure H.10  Damage Considering Levee Geotechnical Failure 
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and substituting: 
 
 ( ) ( )12/11 +++ −→− jj

f
jjj ppppp  (21) 

 
 

H.6 Project Reliability and Flood Risk Computations 
 
Reliability is computed as the exceedance probability for a target stage or 
the likelihood of levee failure.  Flood risk is defined as the probability of 
one or more exceedances of the target stage or levee failures in a specified 
number of years. 
 
The target stage is determined by interpolation from the stage versus 
damage relationship using a specified fraction of a damage for a specified 
exceedance probability .  This damage is determined from a damage-
exceedance probability function obtained by combining traditional 
estimates of the contributing relationships (i.e., contributing relationships 
without uncertainty) for the without-project condition. 
 
The exceedance probability for this stage or the levee failure probability is 
specified as both a "median" and “expected” value.  The median value is 
obtained from the stage-exceedance probability curve obtained by the 
traditional (no uncertainty) method.  The expected value is obtained by 
averaging the target stage or levee failure probability over all the Monte 
Carlo simulations. 
 
The risk of flooding one or more times in NR years is computed as: 
 
 ( ) RNpR −−= 11  (22) 
 
where p is either the probability of exceeding the target stage or levee 
failure.  An expected value of R is reported as the average over all Monte 
Carlo simulations. 
 
 

H.7 Computation of Equivalent Annual Damage 
 
Equivalent annual damage is computed by discounting future EAD values 
given the appropriate interest rate and time for discounting.  The 
computation is described in detail elsewhere (HEC, 1984).  This 
computation is applied to not only the best estimate of EAD but to the 
distribution of possible EAD values obtained as part of the Monte Carlo 
simulation.  This results in a distribution of equivalent annual damage. 
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 Inundation Reduction Benefit Computations 
 
Inundation reduction benefits are computed as the difference between 
with-and without-project equivalent annual damage.  This differencing is 
performed between the distribution of equivalent annual damage values 
obtained for both with-and without-project condition resulting in a 
distribution of equivalent annual damage. 
 
The differencing of uncertainty distributions in this manner recognizes 
that irrespective of the plan, the future exceedance probability of events 
causing floods will be the same for all plans.  Consequently, differencing 
these distributions results in the same answer as would be obtained by 
obtaining the distribution of net benefits by performing Monte Carlo 
simulation of damage differences. 
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