HEC-GeoHMS
Geospatial Hydrologic Modeling Extension

User's Manual

Version 10.1
February 2013

Approved for Public Release. Distribution Unlimited.
<table>
<thead>
<tr>
<th>4. TITLE AND SUBTITLE</th>
<th>5a. CONTRACT NUMBER</th>
</tr>
</thead>
<tbody>
<tr>
<td>HEC-GeoHMS</td>
<td></td>
</tr>
<tr>
<td>Geospatial Hydrologic Modeling Extension</td>
<td></td>
</tr>
<tr>
<td>Version 10.1</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>6. AUTHOR(S)</th>
<th>5b. GRANT NUMBER</th>
</tr>
</thead>
<tbody>
<tr>
<td>Matthew J. Fleming, James H. Doan</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>7. PERFORMING ORGANIZATION NAME(S) AND ADDRESS(ES)</th>
<th>8. PERFORMING ORGANIZATION REPORT NUMBER</th>
</tr>
</thead>
<tbody>
<tr>
<td>US Army Corps of Engineers</td>
<td>CPD-77</td>
</tr>
<tr>
<td>Institute for Water Resources</td>
<td></td>
</tr>
<tr>
<td>Hydrologic Engineering Center (HEC)</td>
<td></td>
</tr>
<tr>
<td>609 Second Street</td>
<td></td>
</tr>
<tr>
<td>Davis, CA 95616-4687</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>9. SPONSORING/MONITORING AGENCY NAME(S) AND ADDRESS(ES)</th>
<th>10. SPONSOR/MONITOR’S ACRONYM(S)</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
</tr>
</tbody>
</table>

**12. DISTRIBUTION / AVAILABILITY STATEMENT**
Approved for public release; distribution is unlimited.

13. SUPPLEMENTARY NOTES

**14. ABSTRACT**
The Hydrologic Engineering Center's Geospatial Hydrologic Modeling Extension, HEC-GeoHMS, is a public domain extension to ESRI’s ArcGIS software (ArcView® license) and the Spatial Analyst extension. HEC-GeoHMS is a geospatial hydrology toolkit for engineers and hydrologists. The user can visualize spatial information, document watershed characteristics, perform spatial analysis, delineate subbasins and streams, construct inputs to hydrologic models, and assist with report preparation. Through the use of HEC-GeoHMS a user can easily and efficiently create hydrologic inputs that can be used directly with the Hydrologic Engineering Center's Hydrologic Modeling System, HEC-HMS software.

**15. SUBJECT TERMS**
HEC-GeoHMS, geospatial, hydrology, GIS, HEC-HMS, spatial information, subbasins, streams, data collection, data assembly, terrain data, watershed delineation

**16. SECURITY CLASSIFICATION OF:**

<table>
<thead>
<tr>
<th>a. REPORT</th>
<th>b. ABSTRACT</th>
<th>c. THIS PAGE</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td></td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>17. LIMITATION OF ABSTRACT</th>
<th>18. NUMBER OF PAGES</th>
<th>19a. NAME OF RESPONSIBLE PERSON</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>193</td>
<td></td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th>19b. TELEPHONE NUMBER</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
</tr>
</tbody>
</table>
The HEC-GeoHMS executable code and documentation are public domain software that was developed under a Cooperative Research and Development Agreement by the Hydrologic Engineering Center (HEC) and the Environmental Systems Research Institute, Inc. (ESRI) and using USACE Research and Development funding. The software and documentation were developed with United States Federal Government resources and is therefore in the public domain. This software can be downloaded for free from our internet site (www.hec.usace.army.mil). HEC cannot provide technical support for this software to non-Corps users; however, we will respond to all documented instances of program errors. Documented errors are bugs in the software due to programming mistakes, not model problems due to user-entered data.
Table of Contents

FOREWORD ........................................................................................................................................................... V
ACKNOWLEDGEMENTS ........................................................................................................................................... VII

CHAPTER 1 .......................................................................................................................................................... 1-1
INTRODUCTION ....................................................................................................................................................... 1-1
   Technical Capabilities ........................................................................................................................................ 1-2
   Program Features .......................................................................................................................................... 1-2
   Intended Application of HEC-GeoHMS ........................................................................................................ 1-4
   User's Manual Overview .................................................................................................................................. 1-4

CHAPTER 2 ......................................................................................................................................................... 2-1
HEC-GeoHMS INSTALLATION .......................................................................................................................... 2-1
   Hardware and Software Requirements ........................................................................................................ 2-1
   Installation of HEC-GeoHMS ........................................................................................................................ 2-2
   Loading HEC-GeoHMS .................................................................................................................................. 2-2

CHAPTER 3 ......................................................................................................................................................... 3-1
WORKING WITH HEC-GeoHMS – AN OVERVIEW .......................................................................................... 3-1
   Data Collection ............................................................................................................................................. 3-2
   Data Assembly ............................................................................................................................................ 3-2
   Terrain Preprocessing ................................................................................................................................. 3-3
   HMS Project Setup .................................................................................................................................. 3-3
   Basin Processing ......................................................................................................................................... 3-3
   Stream and Watershed Characteristics ...................................................................................................... 3-3
   Hydrologic Parameters ............................................................................................................................. 3-4
   HEC-HMS Model Files ............................................................................................................................... 3-4

CHAPTER 4 ......................................................................................................................................................... 4-1
DATA COLLECTION .............................................................................................................................................. 4-1
   Data Usage .................................................................................................................................................. 4-1
   Data Types, Descriptions, and Sources ...................................................................................................... 4-2

CHAPTER 5 ......................................................................................................................................................... 5-1
DATA ASSEMBLY .................................................................................................................................................. 5-1
   Terrain Data Assembly ............................................................................................................................... 5-2
   Data Issues .................................................................................................................................................. 5-5
   Hydrologic Coordinate System Specifications .......................................................................................... 5-6

CHAPTER 6 ......................................................................................................................................................... 6-1
TERRAIN PREPROCESSING .............................................................................................................................. 6-1
   Features and Functionality .......................................................................................................................... 6-2
   Data Management ..................................................................................................................................... 6-2
   Terrain Reconditioning ............................................................................................................................... 6-3
   Terrain Preprocessing ............................................................................................................................... 6-7

CHAPTER 7 ......................................................................................................................................................... 7-1
PROJECT SETUP .................................................................................................................................................. 7-1
   Start New Project ...................................................................................................................................... 7-1

CHAPTER 8 ......................................................................................................................................................... 8-1
BASIN PROCESSING ......................................................................................................................................... 8-1
   Basin Merge ............................................................................................................................................... 8-1
   Basin Subdivision .................................................................................................................................. 8-3
### Table of Contents

Subbasin Divide by Maximum Area ................................................................. 8-6
River Merge ........................................................................................................ 8-8
River Profile ........................................................................................................ 8-9
Split Basins at Confluences ............................................................................. 8-10
Batch Subbasin Delineation ............................................................................ 8-11

#### CHAPTER 9 ................................................................................................. 9-1

STREAM AND SUBBASIN CHARACTERISTICS ............................................ 9-1
River Length ...................................................................................................... 9-2
River Slope ........................................................................................................ 9-3
Basin Slope ........................................................................................................ 9-4
Longest Flowpath ............................................................................................ 9-5
Basin Centroid ................................................................................................. 9-6
Centroid Elevation ........................................................................................... 9-7
Centroidal Flow Path ......................................................................................... 9-8

#### CHAPTER 10 ................................................................................................. 10-1

HYDROLOGIC PARAMETER ESTIMATION ................................................... 10-1
Select HMS Processes ...................................................................................... 10-2
River Auto Name ............................................................................................. 10-3
Basin Auto Name ............................................................................................ 10-4
Grid Cell Processing ....................................................................................... 10-5
Subbasin Parameters from Raster .................................................................... 10-6
Subbasin Parameters from Features ................................................................. 10-7
Muskingum-Cunge and Kinematic Wave Parameters ....................................... 10-8
Time of Concentration ..................................................................................... 10-9
CN Lag Method ............................................................................................... 10-10

#### CHAPTER 11 ................................................................................................. 11-1

HYDROLOGIC MODELING SYSTEM ............................................................. 11-1
Map to HMS Units .......................................................................................... 11-2
HEC-HMS Basin Schematic .......................................................................... 11-3
HEC-HMS Basin Schematic .......................................................................... 11-4
HEC-HMS Basin Schematic .......................................................................... 11-5
Add Coordinates .............................................................................................. 11-6
Prepare Data for Model Export ..................................................................... 11-7
Background Shape File .................................................................................. 11-8
Basin Model File ............................................................................................ 11-9
Grid-Cell File ................................................................................................. 11-10
Meteorologic Model ....................................................................................... 11-11
Create HEC-HMS Project ............................................................................ 11-12

#### CHAPTER 12 ................................................................................................. 12-1

UTILITIES ........................................................................................................ 12-1
Assign HydroID ............................................................................................... 12-2
Generate CN Grid ............................................................................................. 12-3
Features to Raster .......................................................................................... 12-4
Generate ASCII Grids ..................................................................................... 12-5
Generate DSS from ASCII Grid ..................................................................... 12-6
Gage Thiessen Polygon .................................................................................. 12-7
Add Latitude and Longitude .......................................................................... 12-8
Change Project Point ....................................................................................... 12-9

#### CHAPTER 13 ................................................................................................. 13-1

EXAMPLE APPLICATION - AMERICAN RIVER BASIN .................................. 13-1
Overview ......................................................................................................... 13-2
Task I. Preprocess the Terrain Model .............................................................. 13-3
Task II. Basin Processing ................................................................................ 13-4
<table>
<thead>
<tr>
<th>Task III. Hydrologic Modeling System</th>
<th>13-33</th>
</tr>
</thead>
<tbody>
<tr>
<td>GRID-CELL PARAMETER FILE FORMAT</td>
<td>A-1</td>
</tr>
<tr>
<td>File Definition</td>
<td></td>
</tr>
<tr>
<td>Grids in HEC-DSS, HRAP, and SHG Grid Systems</td>
<td>B-1</td>
</tr>
<tr>
<td>Contents of a Grid Record in HEC-DSS</td>
<td>B-1</td>
</tr>
<tr>
<td>Storage of Grid Values</td>
<td>B-1</td>
</tr>
<tr>
<td>Grid Header Contents</td>
<td>B-2</td>
</tr>
<tr>
<td>HRAP Grid System</td>
<td>B-2</td>
</tr>
<tr>
<td>SHG Grid System</td>
<td>B-3</td>
</tr>
</tbody>
</table>
Foreword

Developments in Geographic Information System (GIS) tools for hydrologic and hydraulic modeling at the Hydrologic Engineering Center (HEC) resulted from many years of interest in geospatial data usage. The earliest work was in the mid 1970's when HEC developed software based on the concepts developed in the Harvard University's School of Landscape Architecture, Honey Hill Project. That early work culminated with the development of the Spatial Analysis Methodology (HEC-SAM), which included a grid-cell data bank and analysis software for hydrologic and flood damage calculations. That early work had the same concepts as those of today, but the limitations in the computer hardware, GIS software, and data availability made widespread engineering applications difficult.

The current development builds on those early experiences and takes the technology to several practical engineering products including the Hydrologic Engineering Center's Geospatial Hydrologic Modeling (HEC-GeoHMS) extension. HEC resurrected its earlier efforts by reviewing current GIS capabilities in association with Professor David Maidment from the University of Texas. HEC and Dr. Maidment formulated a watershed data structure that would link GIS and hydrologic models. From that time, the definition and content of the GIS and hydrologic data structures evolved into a hydrologic GIS preprocessor, PrePro. Taking advantage of the wealth of terrain and geographic data readily available over the Internet and from government agencies, PrePro delineates streams and watersheds and builds the hydrologic model structure for HEC-HMS. PrePro was the predecessor to HEC-GeoHMS.

The development of PrePro at the University of Texas was partially supported by HEC via the Corps' Civil Works R&D program. The effort also received substantial support from the Texas Department of Transportation as well as support from other national and international agencies. Dr. Maidment, Dr. Olivera, and others at the Center for Research in Water Resources provided valuable assistance for the development of HEC-GeoHMS.

HEC-GeoHMS Version 1.0 was developed to use readily available digital geospatial information to construct hydrologic models more expeditiously than using manual methods. Also, development of basic watershed information will aid the user in estimating hydrologic parameters. After gaining adequate experience with using GIS-generated parameters, users can take steps to streamline the process of hydrologic parameter estimation.

The Wisconsin Department of Natural Resources (WDNR) and Environmental System Research Institute's, Inc. (ESRI) contributed greatly to the development of HEC-GeoHMS Version 1.1. WDNR developed completed HMS models using the hydrologic parameters and topographic parameters for regional regression analysis provided by HEC-GeoHMS Version 1. With this version, users were able to extract more watershed characteristics from digital elevation models (DEM) and GIS data for developing hydrologic parameters. Users
were also able to work with DEMs in a number of coordinate systems and projections. This version introduced tools to recondition the DEMs by imposing a known stream network onto the terrain grid. HEC-GeoHMS Version 1.1 also expanded its scope to develop meteorologic models and control specifications for an HEC-HMS model. HEC-GeoHMS Version 1.1 was the terminal release of the software using ESRI's ArcView 3.x platform.

HEC-GeoHMS Versions 4.2 and 5.0 were the result of continued development by HEC and ESRI to modernize the features and functionality of HEC-GeoHMS Version 1.1 (for ArcView 3.x) to the ArcGIS 9.3 platform (ArcView license). This work was accomplished through a Cooperative Research and Development Agreement (CRADA) between HEC and ESRI and using USACE Research and Development funding.

Only minor enhancements were added to HEC-GeoHMS Version 10.1. The main purpose for development of the new version was the need for a version of the program that worked with ArcGIS version 10.1.
Acknowledgements

HEC-GeoHMS has benefited from many years of research and program development. From an institutional perspective, the University of Texas at Austin has contributed important research, development, and demonstration of concepts. Having that basis for the technology, HEC and Environmental Systems Research Institute, Inc. (ESRI) contributed extensive software development and documentation through a Cooperative Research and Development Agreement (CRADA) to engineer technology into commercial software.

At HEC, James Doan, Matthew Fleming, Bill Scharffenberg, Cameron Ackerman, Jay Pak, Gary Brunner, and Jeff Harris are members of the HEC-GeoHMS development team. From ESRI, Dr. Dean Djokic, Dr. Zichuan Ye, Mr. Sreeresh Sreedhar, and Christine Dartiguenave contributed valuable software insight, development, and programming in conjunction with HEC. This manual was written by James Doan and Matthew Fleming. HEC software implementation is under the guidance of Christopher N. Dunn, Director, Hydrologic Engineering Center.
CHAPTER 1

Introduction

In recent years, advances in Geographic Information Systems (GIS) have opened many opportunities for enhancing hydrologic modeling of watershed systems. With an openness to share spatial information via the internet from government agencies, commercial vendors, and private companies, coupled with powerful spatial algorithms, the integration of GIS with hydrologic modeling holds the promise of a cost-effective alternative for studying watersheds. The ability to perform spatial analysis for the development of lumped and distributed hydrologic parameters not only saves time and effort, but also improves accuracy over traditional methods. In addition, hydrologic modeling has evolved to consider radar rainfall and advanced techniques for modeling the watershed on a grid level. Rainfall and infiltration can be computed cell by cell providing greater detail than traditional basin average methods. These advanced modeling techniques have become feasible because the time-consuming data manipulations can now be generated efficiently using spatial operations in a GIS. For example, the ability to perform spatial overlays of information to compute basin average or grid-based parameters is crucial for computing hydrologic parameters.

HEC-GeoHMS has been developed as a geospatial hydrology toolkit for engineers and hydrologists with limited GIS experience. The program allows users to visualize spatial information, document watershed characteristics, perform spatial analysis, delineate subbasins and streams, construct inputs to hydrologic models, and assist with report preparation. Working with HEC-GeoHMS through its interfaces, menus, tools, buttons, and context-sensitive online help allows the user to expediently create hydrologic inputs that can be used directly with the Hydrologic Engineering Center's Hydrologic Modeling System, HEC-HMS.

Chapter 1 discusses the intended use of HEC-GeoHMS and provides an overview of this manual. Below is an outline of Chapter 1.

Contents

- Technical Capabilities
- Program Features
- Intended Application of HEC-GeoHMS
- User's Manual Overview
Technical Capabilities

Hydrologic modeling has evolved to represent the subbasin in more detail than the traditional approach where hydrologic parameters are averaged over large basins. With the availability of radar rainfall and spatial data, hydrologic modeling using smaller subbasin areas or a grid system has introduced a more detailed representation of the basin. HEC-GeoHMS has been designed to meet the needs of both modeling approaches.

HEC-GeoHMS creates background map files, basin model files, meteorologic model files, and a grid cell parameter file which can be used by HEC-HMS to develop a hydrologic model. The basin model file contains hydrologic elements and their hydrologic connectivity. The basin model file includes subbasin areas and other hydrologic parameters that could be estimated using geospatial data. To assist with estimating hydrologic parameters, HEC-GeoHMS can generate tables containing physical characteristics of streams and watersheds. The grid cell parameter file is required in order to use the ModClark transform method, grid-based precipitation (like radar rainfall), or gridded loss methods.

Features in HEC-GeoHMS Version 10.1 allow the user to analyze DEMs in a number of coordinate systems and projections, including Albers-Equal Area, Universal Transverse Mercator (UTM), Transverse Mercator, Lambert, and the State Plane Coordinate System. An added capability allows users to use a more sophisticated "burning in" technique to impose the stream network onto the terrain. This is accomplished as a gradual step-wise process to better reproduce stream networks and watershed boundaries. With regards to hydrologic parameter estimation, HEC-GeoHMS contains tools to assist the user in estimating initial values of some hydrologic parameters.

Program Features

HEC-GeoHMS 10.1 is a public-domain extension for ArcGIS 10.1 (ArcView® license) and the Spatial Analyst extension. ArcView GIS and its Spatial Analyst extension are available from the Environmental Systems Research Institute, Inc. (ESRI). The following program features illustrate functionality and ease of use for HEC-GeoHMS.

Data Management

HEC-GeoHMS performs a number of administrative tasks that help the user manage GIS data derived from the program. The data management feature tracks GIS data layers and their names. Prior to performing a particular operation, the data manager will offer the appropriate data inputs for operation, and prompt the user for confirmation. Other times, the data management feature manages the locations of various projects and also performs error checking and detection.
Terrain Preprocessing

HEC-GeoHMS allows users to perform terrain preprocessing in either a step-by-step fashion or batch mode. In the step-by-step process, the user often has the opportunity to examine the outputs and make corrections to the dataset, as appropriate. Batch processing will allow terrain preprocessing to be performed unattended.

Basin Processing

The emphasis of the subbasin delineation, processing, and manipulation capability is on flexibility, ease of use, and user interactivity. As the user subdivides a basin or merges many smaller subbasins together, the results of the operation are displayed immediately for the user’s confirmation. The ability to perform subbasin processing interactively is powerful, because the results are presented quickly for the user to make a modeling decision instead of having to reprocess the data. For example, the user can obtain a stream profile and look for significant grade breaks. If a subbasin subdivision at a grade break is desired, the user, using the delineation tool, just clicks on the stream at the grade break. Other tools allow the user to delineate subbasins in a batch mode by supplying a dataset containing point locations of desired outlets.

Hydrologic Parameter Estimation

Users can now compute the Curve Number (CN) and other loss rate parameters based on various soil and land use databases. The curve number can represent an average value for a subbasin or an individual cell for a grid-based subbasin. In addition, watershed and channel characteristics together with a spreadsheet template are linked to HEC-GeoHMS to assist the user with estimation of initial values of time of concentration. Also, basin and channel characteristics can be used to calculate CN Lag and simple prismatic Muskingum-Cunge routing parameters.

HMS Model Support

HEC-GeoHMS produces a number of hydrologic inputs that are used directly in HEC-HMS. In addition, the program supports the estimation of hydrologic parameters by providing tables of physical characteristics for streams and subbasins. While working with HEC-GeoHMS, the user can use other ArcGIS extension programs to perform spatial operations and develop additional parameters for populating the hydrologic model.
Intended Application of HEC-GeoHMS

HEC-GeoHMS is intended to process watershed data after the initial compilation and preparation of terrain data is completed. The assembly of GIS data can be performed using standard GIS software packages that support ARC Grid format. Even though this user’s manual provides some guidance and discussions on the proper approach for assembling data, HEC-GeoHMS is not intended as a tool for data assembly. When assembling data, it is important to understand how to use GIS software to put data of different types and formats into a common coordinate system. A few examples of required data include digital elevation models (DEM), digital stream alignments, and stream gage locations.

When the data assembly is complete, HEC-GeoHMS processes the terrain and spatial information to generate a number of input files for an HEC-HMS model. It is intended that these input files provide the user with an initial HEC-HMS model. The user can estimate hydrologic parameters from stream and subbasin characteristics, gaged precipitation, and stream flow data. In addition, the user has full control in HEC-HMS to modify the hydrologic elements and their connectivity to more accurately represent field conditions.

User's Manual Overview

This manual provides detailed instructions for using HEC-GeoHMS to develop hydrologic inputs for HEC-HMS. The manual is organized as follows:

Chapter 1 - Introduction
Chapter 2 - Instructions for Installing HEC-GeoHMS and Getting Started
Chapter 3 - Overview of the Major Steps in using HEC-GeoHMS
Chapter 4 - Data Collection
Chapter 5 - Issues Related to Data Assembly
Chapter 6 - Terrain Preprocessing
Chapter 7 - Setting up a Detailed HEC-GeoHMS Project
Chapter 8 - Basin Processing
Chapter 9 - Physical Characteristics Extracted for Streams and Subbasins
Chapter 10 - Hydrologic Parameter Estimation
Chapter 11 - Creation of Input Files for HMS
Chapter 12 - Description of Utility Tools
Chapter 13 - Example Application of HEC-GeoHMS
Appendix A - Grid-Cell Parameter File Format
Appendix B - Grids in HEC-DSS, HRAP, and SHG Grid Systems
CHAPTER 2

HEC-GeoHMS Installation

This chapter discusses the hardware and software requirements and installation procedures for HEC-GeoHMS. Prior to installing this software, Microsoft .NET framework should be installed first, and then ArcView GIS version 10.1 and the Spatial Analyst extension should be installed using their installation guides. Below is an outline of Chapter 2.

Contents

- Hardware and Software Requirements
- Installation of HEC-GeoHMS
- Loading HEC-GeoHMS

Hardware and Software Requirements

The minimum hardware and software requirement for using HEC-GeoHMS are similar to those of ArcView GIS. However, when working with GIS, it is important to take into account the size of the datasets as well as the complexity of the analysis when determining adequate computer resources. Even though the program will still work on a slower machine, the user will often experience long computing times. To assure that performance is not being compromised, the following hardware recommendations should be considered with the idea that more computer resources, in terms of central processing unit (CPU) speed, memory, and hard drive space, could improve program performance.

Recommended Hardware Specifications

The recommended hardware specifications are as follows:

- **CPU Speed:** 1.6 GHz recommended or higher
- **Memory/RAM:** 1 GB minimum, 2 GB recommended or higher
- **Hard Drive Space:** Hard drive space available should be at least twenty times the size of the terrain data. For example, if the terrain data takes up 50 MB, then the available hard drive space should be about 1 GB. In many cases, having ample hard drive space available will improve performance because the spatial operations often generate many temporary intermediate files and repeatedly perform file caching.
Installation of HEC-GeoHMS

The Arc Hydro Tools program is required to run HEC-GeoHMS. Arc Hydro will be automatically installed when HEC-GeoHMS is installed. You should make sure to properly uninstall old versions of the software (HEC-GeoHMS and Arc Hydro Tools) prior to installing a new version of HEC-GeoHMS. Removal of software previously installed is performed through the Windows Control Panel using the Add or Remove Programs dialog. This will ensure that all files are unregistered and deleted properly.

The recommended procedure for uninstalling older versions is as follows:

2. Open the Add or Remove Programs dialog from the control panel and remove the following: Water Utilities Application Framework, Arc Hydro Tools, and HEC-GeoHMS.

The recommended procedure for installing HEC-GeoHMS is as follows:

1. Download the software from our web page: www.hec.usace.army.mil.
2. Execute the “HEC-GeoHMS_10.1_Setup.msi” file to run the setup program.
3. Follow the setup instructions on the screen.

The HEC-GeoHMS version 10.1 installation packages will automatically install Water Utilities Application Framework, Arc Hydro Tools, and HEC-GeoHMS version 10.1. By default, Arc Hydro Tools will be installed to the C:\Program Files (x86)\ESRI\WaterUtils directory. HEC-GeoHMS will be installed to the C:\Program Files (x86)\HEC\HEC-GeoHMS directory.

Loading HEC-GeoHMS

Once HEC-GeoHMS is installed, it can be loaded within an ArcMap document. Select the Customize ➔ Toolbars menu option. In the list of toolbars that appears, scroll down and select HEC-GeoHMS as shown in Figure 2-1.
The user can load the Spatial Analyst extension by selecting the **Customize → Extension...** menu item. When properly installed and loaded, the **HEC-GeoHMS** toolbar should look like Figure 2-2.

The Background Processing feature in ArcMap is new for ArcGIS version 10.0 and 10.1. This feature allows geoprocessing tools to run in the background while the user interacts with ArcMap. Background processing must be disabled when GeoHMS tools are used. Select the **Geoprocessing → Geoprocessing Options ...** menu option. Make sure the Enable box is not checked for background processing.
CHAPTER 3

Working with HEC-GeoHMS – An Overview

HEC-GeoHMS is a set of ArcGIS tools specifically designed to process geospatial data and create input files for the Hydrologic Engineering Center's Hydrologic Modeling System (HEC-HMS). It includes integrated data management and a graphical user interface (GUI). Through the GUI, which consists of menus, tools, and buttons, the user can analyze the terrain information, delineate subbasins and streams, and prepare hydrologic inputs.

The relationship between GIS, HEC-GeoHMS, and HEC-HMS is illustrated in Figure 3-1, with the vertical dashed line separating the roles of GIS and watershed hydrology. HEC-GeoHMS provides the connection for translating GIS spatial information into model files for HEC-HMS. The GIS capability is used for data formatting, processing, and coordinate transformation. The end result of the GIS processing is a spatial hydrology database that consists of the digital elevation model (DEM), soil types, land use information, rainfall, etc.

Figure 3-1. Overview of GIS and Hydrology Programs.
Currently, HEC-GeoHMS operates on the DEM to derive subbasin delineation and to prepare a number of hydrologic inputs. HEC-HMS accepts these hydrologic inputs as a starting point for hydrologic modeling. The following steps describe the major steps in starting a project and taking it through the HEC-GeoHMS process.

Contents

- Data Collection
- Data Assembly
- Terrain Preprocessing
- HMS Project Setup
- Basin Processing
- Stream and Watershed Characteristics
- Hydrologic Parameters
- HMS Model Files

Data Collection

With the volume of spatial data available, it is important to identify the data that will meet project needs. Spatial data comes in many formats, resolutions, intended uses, quality, and prices. Prior to collecting data, the project specifications should be thoroughly reviewed for any recommendations. When a project does not specify a particular dataset, review the project's goals and objectives to help define acceptable data in terms of data storage, resolution, and accuracy. In addition, economic factors should be considered to determine the cost effectiveness in collecting and assembling the data or purchasing the data from a vendor. Whether the data are collected or purchased, metadata must also be acquired to provide necessary documentation. Data collection is discussed in greater detail in Chapter 4.

Data Assembly

Data assembly often requires efforts of an experienced GIS user. Because GIS data have many forms and formats, users often need to convert the data into a common format and then into a common coordinate system. For example, data describing the terrain should be in ESRI's ARC Grid format while vector data, such as stream alignments and stream flow gage locations, should be in the shapefile format. By having a common coordinate system, these datasets can be overlaid and spatial operations can be performed. A list of coordinate systems compatible with HEC-GeoHMS is contained in Chapter 5. Often times, datasets are provided in rectangular portions. When assembling data, especially terrain, special efforts are required to ensure that data are continuous along the edges. Terrain data assembly is discussed in Chapter 5.
Terrain Preprocessing

Using the terrain data as input, terrain preprocessing is a series of steps to derive the drainage network. The steps consist of computing the flow direction, flow accumulation, stream definition, and watershed delineation. These steps can be done step by step or in a batch manner. Once these datasets are developed, they are used in later steps for subbasin and stream delineation. It is important to recognize that the watershed and stream delineation in the terrain preprocessing steps is preliminary. Tools are available on the basin processing menu that gives the user the capability to delineate and edit basins in accordance with project specifications.

HMS Project Setup

The HMS Project Setup menu is used to define a study area that will be used to develop the input files for an HEC-HMS project. The user can define an outlet and HEC-GeoHMS will copy all the terrain processing data for the area upstream of the outlet location. Then the user can use tools on the Basin Processing menu to modify the subbasin and stream network, subdivide and merge, to meet the study objectives. Multiple outlets and HMS projects can be defined in the same HEC-GeoHMS project. This would save the user from having to run the terrain preprocessing tools for multiple studies.

Basin Processing

In this step, the user is provided with a variety of interactive and batch-mode tools to delineate subbasins. In the interactive mode, the tools allow the user to see the delineation results, assess outcomes, and accept or deny the resulting delineation. When the user performs interactive basin processing, the program will prompt the user to confirm the results. In the batch mode, the user can supply the outlet locations and the program will delineate subbasins at those locations, but without interaction to view and revise.

Stream and Watershed Characteristics

When the stream and subbasin delineation has been finalized, the user can extract physical characteristics. Physical characteristics for a stream include the length, upstream and downstream elevations, and slope. This information is extracted from the terrain data and stored in attribute tables. Similarly, physical characteristics for a subbasin, such as longest flow lengths, centroidal flow lengths, and slopes, are extracted from terrain data and stored in the attribute tables. These physical characteristic could be exported and used externally to estimate hydrologic parameters.
Hydrologic Parameters

In addition to extracting physical characteristics, the user has the option to estimate initial values of various hydrologic parameters. Hydrologic parameters, such as the curve number and percent impervious area, can be extracted as basin average and grid-based quantities from soil and land use data. Other hydrologic parameters, such as time of concentration, are computed from various datasets that include terrain and precipitation data.

HEC-HMS Model Files

HEC-GeoHMS produces a number of files that can be used directly by HEC-HMS. These files include background shape files, the basin model file, the meteorologic model file, and a project file. When the HEC-GeoHMS generated files are brought into an HEC-HMS project, the user has a partially completed HEC-HMS model. To complete the model, hydrologic parameters need to be estimated and entered into the basin model using HEC-HMS. In addition, the user can add or remove hydrologic elements and their connectivity to reflect difficult modeling areas. Finally, the user needs to develop a meteorologic model to represent the precipitation and a control specifications to define the simulation time window. When these three model components are completed, the user can compute a simulation run and calibrate the hydrologic model.
CHAPTER 4

Data Collection

The purpose of this chapter is to illustrate some of the ways spatial datasets are used in hydrology. By understanding how the datasets are utilized, the user can focus adequate time, effort, and attention on the appropriate dataset. When collecting data, the user can assess the quality of the data and its metadata to insure that they meet project specifications. This chapter also provides a list of data types, descriptions, and possible sources as a starting point for collecting data. Below is an outline of Chapter 4.

Contents

• Data Usage
• Data Types, Descriptions, and Sources

Data Usage

Spatial data are collected and used in a variety of ways. Understanding how data are used provides many important guidelines in data collection. When the data are intended as input in the program, they should be collected with attention given to accuracy, resolution, validity of data source, and quality of documentation. Oftentimes when the best available data are not adequate, the appropriate course of action will be to develop data that meets project specifications instead of putting efforts in correcting "bad" data. Terrain data is critical because HEC-GeoHMS uses it to determine drainage paths and physical characteristics. Other data often serve many useful roles, such as reference information, documentation, and visualization.

Reference data depicting known stream alignments, stream flow gage locations, and drainage boundaries are very helpful for comparing and validating the GIS delineated streams and subbasins. GIS data can be collected and used with existing spatial data to document field conditions. For example, drainage structures, as shown in Figure 4-1, and other field conditions can be photographed and geographically located to more effectively document these facilities and show their spatial relationships. GIS data can be used to visualize multiple datasets. For example, aerial images can be overlaid with subbasin boundaries to see land use patterns and variability.
Data Types, Descriptions, and Sources

The amount of GIS data available through government institutions and data vendors has grown greatly over the years. Some of these data are available for free while others are provided for a fee. Table 4-1 provides a starting point for collecting and searching for GIS data. The list provides brief descriptions of the data used in hydrology and their sources. Additional information on the datasets can generally be found at the respective institution’s web site. Although terrain data is the minimum data requirement to run HEC-GeoHMS, the other datasets contains important information for constructing the hydrologic model. Metadata must also be collected for documentation. At a minimum, the metadata should include the data source and projections information.

Table 4-1. Data Types, Descriptions, and Sources.

<table>
<thead>
<tr>
<th><strong>Digital Elevation Model (DEM)</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>DEMs are typically generated from USGS maps and are available for multiple resolutions. DEM data can be gathered from the USGS National Elevation Dataset (NED) program. Other sources like Light Detection And Ranging (LIDAR) and Interferometric Synthetic Aperture Radar (IFSAR) can also be used. Thirty and 10 meter DEMs are generally used for modeling the terrain because of widespread availability.</td>
</tr>
<tr>
<td>Source</td>
</tr>
</tbody>
</table>

<table>
<thead>
<tr>
<th><strong>Hydrologic Unit Code (HUC)</strong></th>
</tr>
</thead>
<tbody>
<tr>
<td>The HUC contains the major watershed boundaries as published by the USGS. The HUC shows watershed boundaries at 4 levels of detail ranging from local to regional drainage area.</td>
</tr>
<tr>
<td>Source</td>
</tr>
<tr>
<td><a href="http://www.epa.gov/waterscience/ftp/basins/gis_data/huc/">http://www.epa.gov/waterscience/ftp/basins/gis_data/huc/</a></td>
</tr>
</tbody>
</table>
| **Digital Line Graph (DLG)**
| In addition to a line representation of transportation data, such as streets and railroads, DLGs include water features, such as stream networks and irrigation ditches. DLGs are maintained by the United States Geological Survey (USGS).
| Source http://nhd.usgs.gov/

| **Stream Networks**
| Stream networks are maintained by the Environmental Protection Agency (EPA). Many versions of stream networks are available as the River Reach File (RF1).
| Source www.epa.com

| **Streamflow Gage Data**
| Although stream flow gage data are natively non-spatial, the latitude and longitude coordinates of the gage are provided most of the time. The stream flow gage locations can be converted into a GIS dataset by using the coordinate information. The majority of stream flow gages are maintained by the USGS, state governments, and flood control districts.
| Source www.usgs.gov

| **Digital Orthophoto Quarter Quads (DOQQ)**
| Digital aerial photos are available at various resolutions and can be used as a background base map.
| Source Various governmental authorities and commercial vendors.

| **Drainage Facilities Photographs**
| Photographs can be taken of key drainage structures. The photographs often include the areas looking upstream and downstream of the structures as well as the faces of the structures.
| Source Field observations conducted by the modelers.

| **Street Data**
| Street level data that is provided by the US Census Bureau often needs format conversion before it can be accessed through GIS software. A number of data vendors have performed the format conversion as well as other value-added improvements.
| Source United States Census Bureau and commercial vendors.

| **Soil Types Data**
| The Soil Surveys Geographic Database (SSURGO) contains soil data at the county level and the State Soil Geographic Database (STATSGO) contains soil data at the state level.
<table>
<thead>
<tr>
<th>Source</th>
<th><a href="http://soils.usda.gov/survey/geography/">http://soils.usda.gov/survey/geography/</a></th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Land Use/Land Cover</strong></td>
<td></td>
</tr>
<tr>
<td>The USGS Land Use Land</td>
<td></td>
</tr>
<tr>
<td>Cover (LULC) provides</td>
<td></td>
</tr>
<tr>
<td>good coverage but may</td>
<td></td>
</tr>
<tr>
<td>be dated. State GIS</td>
<td></td>
</tr>
<tr>
<td>websites can also be a</td>
<td></td>
</tr>
<tr>
<td>source of land use data.</td>
<td></td>
</tr>
<tr>
<td>Source</td>
<td><a href="http://edc.usgs.gov">http://edc.usgs.gov</a></td>
</tr>
<tr>
<td><strong>USGS National Hydrography Dataset (NHD)</strong></td>
<td></td>
</tr>
<tr>
<td>The NHD contains</td>
<td></td>
</tr>
<tr>
<td>published streams and</td>
<td></td>
</tr>
<tr>
<td>subbasin boundaries</td>
<td></td>
</tr>
<tr>
<td>which are useful for</td>
<td></td>
</tr>
<tr>
<td>verifying delineations</td>
<td></td>
</tr>
<tr>
<td>from HEC-GeoHMS.</td>
<td></td>
</tr>
<tr>
<td>Source</td>
<td><a href="http://nhd.usgs.gov">http://nhd.usgs.gov</a></td>
</tr>
</tbody>
</table>
CHAPTER 5

Data Assembly

The assembly of GIS datasets often requires conversion of file formats and coordinate systems, as well as geographical referencing of non-spatial datasets. In addition to file formatting, data assembly often requires a number of map related transformations to ensure that vector and raster data are in proper alignment and map distortions are minimized. All data layers should have the same datum, projection, and common coordinate system in order to perform spatial analysis.

When data are assembled with GIS software, the user should be aware of the distinctions between various spatial operations. For example, when the user joins various sized terrain tiles into a continuous terrain model, the ArcInfo grid "merge" and/or "mosaic" commands produce different results. The "merge" command will overwrite overlapping areas along the edges with the data that is merged last. However, the "mosaic" command will perform smoothing of data values along the overlapping areas. Recognizing the different approaches for combining terrain is crucial to prevent abrupt changes in elevation along the edges of terrain tiles that could affect drainage path determination. Other data assembly issues include combining various datasets of different resolution, filling data gaps as shown in Figure 5-1, and data resampling techniques. Below is an outline of Chapter 5.

Contents

- Terrain Data Assembly
- Data Issues
- Hydrologic Coordinate System Specifications
Terrain Data Assembly

The growth and availability of seamless terrain data in recent years has provided users with better quality data and minimized the need to manually assemble terrain datasets from small tiles of data. Also, the seamless data has been edge-matched and contains the same coordinate system, datum, and units. However, in some cases where manual assembly of terrain data is required, the user should be aware of many important issues related to the data age, units, coordinate system, datum, etc. Ultimately, the quality of the results depends heavily on the terrain data. Traditionally, continuous terrain data was assembled manually from joining tiles of terrain information as shown in Figure 5-2. Then, data gaps were filled in with interpolated elevation values from neighboring grid cells to make a continuous DEM model as shown in Figure 5-3. However, when terrain data were assembled in this manner, they often contained errors and areas that were problematic for computing drainage patterns from a hydrologic standpoint. Often, terrain data undergoes extensive editing to correct problematic areas. Automated routines are available to fill
depressions in the DEM. The "depressionless" DEM may still not have streams located properly when compared to other map and photo resources. Extensive editing is usually required to create a hydrologically corrected or conditioned DEM. The availability of seamless DEM data from the USGS has dramatically saved time and effort in building quality terrain data; however, there are still many issues surrounding terrain data assembly as discussed below.

<table>
<thead>
<tr>
<th>Walker NW</th>
<th>Magnolia West</th>
<th>Magnolia East</th>
<th>Oklahoma</th>
<th>Tamuna</th>
<th>Outlaw Pond</th>
<th>Splendors</th>
<th>Plum Grove</th>
</tr>
</thead>
<tbody>
<tr>
<td>Waller</td>
<td>Hockley</td>
<td>Rose Hill</td>
<td>Tomball</td>
<td>Spring</td>
<td>Maeden</td>
<td>Mooshuare Hill</td>
<td>Huffman</td>
</tr>
<tr>
<td>Hockley Mound</td>
<td>Warren Lake</td>
<td>Cypress</td>
<td>Saturnus</td>
<td>Aldine</td>
<td>Humble</td>
<td>Harnanton</td>
<td>Crosby</td>
</tr>
<tr>
<td>Brookshire</td>
<td>Katy</td>
<td>Addicks</td>
<td>Hedwig Village</td>
<td>Houston Heights</td>
<td>Settegast</td>
<td>Jacinto City</td>
<td>Highlands</td>
</tr>
<tr>
<td>Fulshear</td>
<td>Richmond North</td>
<td>Clodine</td>
<td>Alief</td>
<td>Bellaire</td>
<td>Park Place</td>
<td>Pasadena</td>
<td>La Porte</td>
</tr>
<tr>
<td>Orchard</td>
<td>Richmond</td>
<td>Sugar Land</td>
<td>Missouri City</td>
<td>Alberta</td>
<td>Pearland</td>
<td>Friends wood</td>
<td>League City</td>
</tr>
</tbody>
</table>

**Figure 5-2.** DEM Tile Quad Names.
Hydrologically Corrected Terrain Model

The preparation of "hydrologically corrected" terrain data often requires much iteration through drainage path computations. To represent the movement of water through the watershed, the "hydrologically corrected" DEM must have the proper accuracy and resolution to capture details of the stream network. The problems often arise when the watershed has low relief and the resolution is not fine enough to delineate the stream network.

The DEM contains elevation averages at regular intervals that may not accurately represent stream locations and watershed boundaries. For example, stream and watershed delineation sometimes does not coincide with published data sources, like those from the USGS National Hydrography Dataset. A "hydrologically corrected" terrain model must represent accurate stream patterns across the DEM. Many factors, such as cell resolution, accuracy, and topographic relief deserve careful consideration because they often affect the quality of the terrain model. In theory, combining GIS datasets of different resolutions is generally not recommended because of the difficulty in assessing the accuracy and the precision of the resulting dataset. In practice, however, combining datasets of various resolutions is necessary due to lack of uniform data and data coverage.
Depressionless Terrain Model

In contrast to the effort required for the "hydrologically corrected" DEM, the "depressionless" DEM is simply constructed using automated algorithms to fill in the sinks or depressions in the assembled DEM. In a depressionless DEM, water moves across the terrain model towards the edge. A depressionless DEM does not address closed basins or substantial non-contributing areas. Because of the complexity and effort required for constructing a hydrologically corrected terrain model, a depressionless terrain model often serves as a simpler substitute in the analysis. For study regions with moderate to high topographic relief, the depressionless terrain model may be adequate for the analysis. For low-relief regions, however, the depressionless terrain model often needs additional work to adequately represent the terrain. For example, a watershed with flat terrain often requires editing to force proper drainage.

Data Issues

Table 5-1 contains a number of issues that might be encountered when assembling terrain data and possible solutions to those problems.

Table 5-1. Data Issues.

<table>
<thead>
<tr>
<th>Data Issues</th>
<th>Descriptions and Potential Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>1. Low-relief terrain</td>
<td>With low-relief terrain, it is often difficult to delineate reliable drainage paths from relative average elevations. Finer resolution terrain data should be considered for the flat region if it is available. However, finer resolution data has its tradeoffs with increased storage and longer computation times. Other possible approaches include imposing the published stream alignment onto the terrain.</td>
</tr>
<tr>
<td>2. Man-made structures</td>
<td>Man-made structures like dams often alter the flow direction because the water surface prevents the mapping of the reservoir bottom. In addition, when the terrain data is filled, the terrain is represented as a flat surface behind the dam. A potential way to deal with this situation would be to put an artificial notch at the dam and carve a stream onto the terrain.</td>
</tr>
<tr>
<td>3. Missing elevation data</td>
<td>Missing elevation data often exist along the edges and can be filled with interpolated values from neighboring elevations. Bad elevation data due to re-sampling effects and other causes can be fixed with spot elevation editing on a cell by cell basis or by region.</td>
</tr>
<tr>
<td>4. Subsidence and impacts</td>
<td>The ground surface may subside due to overdraft of groundwater. Recognizing when the terrain data were developed, the terrain data should be checked for subsidence.</td>
</tr>
<tr>
<td>5. Subsurface flow</td>
<td>Volcanic soils, limestone formations, and canals/tunnels lead to drainage patterns that the terrain cannot reproduce. These difficult features must be handled in HEC-GeoHMS by delineating the subbasin downstream of the feature to avoid the problem areas or by</td>
</tr>
</tbody>
</table>
modifying the terrain to impose the correct drainage patterns.

Hydrologic Coordinate System Specifications

Transforming spatial data into a common coordinate system ensures proper alignment of various datasets for spatial analysis. Coordinate system transformation often leads to map distortions of direction, distance, shape, and area. From a hydrologic perspective, where the terrain and precipitation are important, a suitable coordinate system should preserve area. One possible coordinate system is the Albers Equal Area projection, which preserves area. This coordinate system is defined in Table 5-2.

The user is allowed to analyze terrain data in a number of coordinate systems and projections, including Albers Equal Area, Universal Transverse Mercator (UTM), Transverse Mercator, Lambert, and the State Plane Coordinate System. The user should always verify the terrain data has been projected into a compatible projection before using HEC-GeoHMS.

Table 5-2. Standard Hydrologic Grid Coordinate System.

<table>
<thead>
<tr>
<th>Projection:</th>
<th>Albers Equal-Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>Spheroid:</td>
<td>GRS80</td>
</tr>
<tr>
<td>Datum:</td>
<td>North American Datum, 1983 (NAD83)</td>
</tr>
<tr>
<td>Central Meridian:</td>
<td>96 degrees 0 minutes 0 seconds West</td>
</tr>
<tr>
<td>Latitude of Origin:</td>
<td>23 degrees 0 minutes 0 seconds North</td>
</tr>
<tr>
<td>1st Standard Parallel:</td>
<td>29 degrees 30 minutes 0 seconds North</td>
</tr>
<tr>
<td>2nd Standard Parallel:</td>
<td>45 degrees 30 minutes 0 seconds North</td>
</tr>
<tr>
<td>False Easting:</td>
<td>0.0</td>
</tr>
<tr>
<td>False Northing:</td>
<td>0.0</td>
</tr>
<tr>
<td>Units:</td>
<td>Meters</td>
</tr>
</tbody>
</table>
CHAPTER 6

Terrain Preprocessing

Terrain preprocessing marks the first step in developing an HEC-GeoHMS project. In this step, a terrain model is used as an input to derive eight additional datasets that collectively describe the drainage pattern of the watershed and allows for stream and subbasin delineation. The first five datasets are grid layers that represent the flow direction, flow accumulation, stream network, stream segmentation, and watershed delineation. The next two datasets are vector layers of the watersheds and streams. The last dataset, the aggregated watersheds, is used primarily to improve the performance in watershed delineation.

The terrain data is processed and analyzed using the eight-pour point approach to determine flow paths. This approach uses the steepest slope to define the direction that water flows from one grid cell to one of its eight neighbors. Terrain analysis is computer intensive and some steps may require several hours, depending on the amount of data and computer resources. After terrain preprocessing is completed, the resulting datasets serve as a spatial database for the study. With the information centralized in the spatial database, pertinent datasets can be extracted for subsequent work to build the hydrologic models. Preliminary watershed and stream delineation provides results that can be verified with published information to detect possible errors in the terrain data. If errors are detected, the DEM should be edited. When the DEM has been revised to better represent field conditions, it should be processed again to update the spatial database.

This chapter will discuss terrain preprocessing features and functionality. Below is an outline of Chapter 6.

Contents

- Features and Functionality
- Data Management
- Terrain Reconditioning
- Terrain Preprocessing
Features and Functionality

The Preprocessing menu is shown in Figure 6-1. The menu is designed for the user to start at the top and work down to develop initial stream and subbasin delineations. The **DEM Reconditioning** and **Build Walls** tools are optional and can be used to edit the terrain data using existing stream and subbasin boundaries. Once terrain processing is complete, the data can be extracted to support hydrologic model creation via the **Project Setup** menu.

![Preprocessing Menu](image)

Figure 6-1. HEC-GeoHMS Preprocessing Menu.

Data Management

Data that are introduced or derived by HEC-GeoHMS are managed through role association. For example, when the DEM is added to the ArcMap document, HEC-GeoHMS will associate it with "RawDEM", which is the original DEM. When the Fill tool is used, the program will automatically offer the RawDEM as the default for creating a depressionless DEM. Aside from associating datasets with their intended roles as they are created, data management allows the user the ability to bring in other datasets and assign a role to them. For example, if the user has developed the flow direction and accumulation grid in another program, they can bring these data in as layers and assign their roles. This is a good way to keep track of data as they are generated. Figure 6-2 shows the data management of layers on the left-hand side and the assigned layers on the right-hand side. The "Null" entry for the assigned layer indicates that the appropriate layer has not been created and assigned. When the appropriate layers are created, their names replace the "Null" entry.
Terrain Reconditioning

Many users in the past have used the simple "burning in" techniques to force a stream network on the DEM. This simple "burning in" technique allows the user to abruptly lower only the stream cell elevation by a fixed amount. Similar to the simple "burning in" technique, the new **DEM Reconditioning** method allows the user to lower the elevation of the stream cell and also provides an option to gradually lower the neighboring cells along the stream. This method creates a gradual transition from the overbank to the stream. This method can be used to eliminate the undesirable side effect of fictitious islands near the stream centerline that parallel the stream as shown in **Figure 6-3**.

The **DEM Reconditioning** tool modifies the terrain by lowering grid cells along line features. This function requires two inputs, a grid and a line layer. The function outputs a reconditioned grid. Both input data layers should be in the same projection.
Figure 6-3. Cross-Section View of Burning-In Techniques.
Open the DEM reconditioning tool by selecting the **Preprocessing → DEM Reconditioning** menu option. After opening the tool, the user needs to select the raw DEM, select the stream layer, and name the output DEM. The stream layer can be a published stream network, from the USGS National Hydrography Database, or stream lines delineated by the user using a topographic map. Then the user must set three reconditioning parameters as shown in Figure 6-4.

![DEM Reconditioning Editor](image)

**Figure 6-4.** DEM Reconditioning Editor.

- **Number of Cells for Stream Buffer** – this is the number of cells around the vector line theme for which the smoothing will occur.
- **Smooth Drop in Z Units** – this is the amount (in vertical units) that the grid cells will be lowered. If the number is negative and the **Raise Negative Values** option is checked, then the program will raise the grid cells. This value is used to interpolate a smooth slope in the buffered area between the boundary of the buffer and the dropped/raised vector feature.
- **Sharp Drop in Z Units** – this is the additional amount (in vertical units) that grid cells will be lowered. If the number is negative and the **Raise Negative Values** option is checked, then the program will raise the grid cells. This amount of additional burning/fencing will be on top of the smooth drop.

The original AGREE method was developed with Arc/Info by Ferdi Hellweger at the University of Texas at Austin in 1997. For a full reference to the procedure refer to the web link:

Another useful tool for editing the terrain data is the Build Walls tool. Published subbasin delineations or those from past studies can be used to build walls in the terrain. This will ensure that subbasin delineations from the terrain data are the same as existing datasets. Select the Preprocessing ➔ Build Walls menu option. The Build Walls editor is shown in Figure 6-5. The user must define the input DEM and a polygon layer of subbasin boundaries. Both Input Outer Wall Polygon and Input Inner Wall Feature polygon layers can be defined, but only one is required. The outer wall polygon layer represents the boundary of the entire drainage basin and the inner wall polygon layer represents subbasins within the drainage basin. The Input Breach Line layer is used to represent the stream network. The program will not raise those grid cells located below the breach lines. This allows water to flow out of the fenced-in areas (another option would be to run the DEM Reconditioning tool after running the Build Walls tool). The Inner Wall Height is used to raise grid cells in the input DEM that overlay boundaries from the input Inner Wall Feature layer. The outer wall height will automatically be double the inner wall height. The Inner Wall Buffer and Breachline Buffer are the number of cells around these layers that will be modified.

![Figure 6-5. Build Walls Editor.](image)
After the modified DEM is obtained, users should use the **Fill Sinks** tool to remove potential sinks generated from the reconditioning process.

### Terrain Preprocessing

By applying the GIS algorithms discussed below, the terrain can be processed in a step-by-step process where datasets are derived after each operation. Greater control over the results is possible because the user verifies the results and makes decisions before proceeding. For example, prior to performing the stream definition, it is good practice to use the Identify Contributing Area tool and check the contributing area at several locations. This information on the area can help pick a threshold for adequate stream definition.

### GIS Approach

GIS approaches toward hydrologic analysis require a terrain model that is hydrologically corrected. A hydrologically corrected DEM is one in which all depressions have been filled. The GIS analyzes the depressionless terrain data by applying the 8-point pour model, where water flows across the landscape from cell to cell based on the direction of the greatest elevation gradient. Steps in the analysis include filling depressions or pits, calculating flow direction and flow accumulation, delineating streams with an accumulation threshold, defining streams, segmenting streams, delineating watersheds, processing watershed polygons, processing streams, and aggregating watersheds.

### Depressionless DEM

The depressionless DEM is created by filling the depressions or pits by increasing the elevation of the pit cells to the level of the surrounding terrain. The pits are often considered as errors in the DEM due to re-sampling and interpolating the grid. For example, in a group of three-by-three cells, if the center cell has the lowest elevation compared to its eight neighboring cells, then the center cell's elevation will be increased equaling the next lowest cell. Filling the depressions allows water to flow across the landscape. This assumption is generally valid when a large storm event fills up the small depressions and any incremental amount of water that flows into the depression will displace the same amount of water from the depression.

The steps to fill depressions are shown below.

- **Select** *Preprocessing ➔ Fill Sinks*.
  - The *Fill Sinks* editor is shown in Figure 6-6. The user must specify the Input DEM (also referred to as the Raw DEM).
  - The filled DEM is referred to as the "Hydro DEM". The default name is "Fil", which can be overwritten by the user.
  - The Fill Threshold option can be used to fill only those sinks that have a depth lower than the user specified threshold. Currently, all sinks must
be filled when developing an HEC-GeoHMS project; therefore the Fill Threshold field must be left empty.

- A "Deranged Polygon" is used to define areas that will not be filled. Currently, all sinks must be filled when developing an HEC-GeoHMS project; therefore a deranged polygon layer should not be selected.
- The Use IsSink field check box should not be checked.
- Press **OK**.

![Fill Sinks Tool](image)

**Figure 6-6.** Fill Sinks Tool.

The hydrologically corrected DEM is used as the starting point for delineating subbasins and river reaches. With the step-by-step approach, each step begins with the program offering a list of inputs that will be used to produce the output grid or vector layer. If the step-by-step procedure is performed in a sequential order, the program will automatically offer the correct data input for processing. In a few instances, when certain steps are repeated or performed out of order, it would be important to verify that the appropriate datasets are used.

**Flow Direction.** This step defines the direction of the steepest descent for each terrain cell. Similar to a compass, the eight-point pour algorithm specifies the following eight possible directions:

1 = east, 2 = southeast,
4 = south, 8 = southwest,
16 = west, 32 = northwest,
64 = north, 128 = northeast.
The steps to compute flow directions are shown below.

- Select **Preprocessing → Flow Direction.** The *Flow Direction* editor is shown in Figure 6-7.
- Confirm that the input of the "Hydro DEM" is the hydrologically corrected DEM (filled DEM).
- The name of the output flow direction grid is defined in the "Output Flow Direction Grid" field. "Fdr" is the default name that can be overwritten by the user.

![Flow Direction Editor](image)

*Figure 6-7. Flow Direction Editor.*

- If you used the Build Walls tool to fence in an external wall then use the same outer wall polygon for the **Input Outer Wall Polygon** layer. Otherwise, do not select an input outer wall polygon layer.
- Press **OK.**

The result of the Flow Direction operation is shown in Figure 6-8.
Flow Accumulation. This step determines the number of upstream cells draining to a given cell. Upstream drainage area at a given cell can be calculated by multiplying the flow accumulation value by the grid cell area.

The steps to compute flow accumulation are shown below.

- Select Preprocessing → Flow Accumulation. The Flow Accumulation editor is shown in Figure 6-9.
- Select the "Input Flow Direction Grid".
- The name of the output flow accumulation grid is defined in the "Output Flow Accumulation Grid" field. "Fac" is the default name that can be overwritten by the user.
- Press OK.

The result of the Flow Accumulation operation is the "Fac" grid, as shown in Figure 6-10.
Stream Definition. This step classifies all cells with a flow accumulation greater than the user-defined threshold as cells belonging to the stream network. The user-specified threshold may be specified as an area in distance units squared, e.g., square kilometers, or as a number of cells. The flow accumulation for a particular cell must exceed the user-defined threshold for a
stream to be initiated. The default is one percent (1%) of the largest drainage area in the entire DEM. The smaller the threshold chosen, the greater the number of subbasins delineated in a following step.

The steps to compute stream definition are shown below.

- Select **Preprocessing ➔ Stream Definition**. The *Stream Definition* editor is shown in Figure 6-11.

![Stream Definition Editor](image)

**Figure 6-11.** Stream Definition Editor.

- Make sure the "Input Flow Accumulation Grid" is selected.
- Enter the stream threshold as "Number of cells to define stream" or "Area SqKm to define stream".
- The name of the output stream grid is defined in the "Output Stream Grid" field. "Str" is the default name that can be overwritten by the user.
- Press **OK**.

The result of the Stream Definition operation is the "Str" grid as shown in Figure 6-12.
Stream Segmentation. This step divides the stream grid into segments. Stream segments, or links, are the sections of a stream that connect two successive junctions, a junction and an outlet, or a junction and the drainage divide.

The steps to compute stream segments are shown below.

- Select **Terrain Preprocessing → Stream Segmentation**. The **Stream Segmentation** editor is shown in Figure 6-13.
- Select the "Input Stream Grid" and “Input Flow Direction Grid”.
- Enter a name for the "Output Stream Link Grid". "StrLnk" is the default name that can be overwritten by the user.
- Do not specify a "Input Sink Watershed Grid" and a "Input Sink Link Grid". These are not needed for an HEC-GeoHMS project.
- Press **OK**.

The stream segmentation operation results in many stream segments as shown in Figure 6-14.
Figure 6-13. Stream Segmentation Editor.

Figure 6-14. Stream Segmentation Operation Result.
**Catchment Grid Delineation.** This step delineates a subbasin for every stream segment.

The steps to delineate watersheds are shown below.

- Select **Preprocessing ➔ Catchment Grid Delineation.** The **Catchment Grid Delineation** editor is shown in Figure 6-15.
- Select the "Input Flow Direction Grid" and the "Input Link Grid" (this is the stream link grid).
- Enter a name for the "Output Catchment Grid". "Cat" is the default name that can be overwritten by the user.
- Press **OK**.

![Catchment Grid Delineation Editor](image)

**Figure 6-15.** Catchment Grid Delineation Editor.

The watershed delineation operation results in many subbasins as shown in Figure 6-16.
Catchment Polygon Processing. This step creates a vector layer of subbasins using the catchment grid computed in the previous step.

The steps to create a polygon subbasin layer are shown below.

- Select Preprocessing \(\rightarrow\) Catchment Polygon Processing. The Catchment Polygon Processing editor is shown in Figure 6-17.
- Select the "Input Catchment Grid".
- Enter a name for the polygon subbasin layer in the "Output Catchment" field. "Catchment" is the default name that can be overwritten by the user.
- Press OK.

The catchment polygon processing operation creates a polygon subbasin layer as shown in Figure 6-18.
**Drainage Line Processing.** This step creates a vector stream layer.

The steps to vectorize stream segments are shown below.

- Select **Preprocessing → Drainage Line Processing**. The *Drainage Line Processing* editor is shown in Figure 6-19.
Figure 6-19. Drainage Line Processing Operation.

- Select the "Input Stream Link Grid" and the "Input Flow Direction Grid".
- Enter a name for the “Output Drainage Line” layer. "DrainageLine" is the default name that can be overwritten by the user.
- Press OK.

The stream layer is shown in Figure 6-20.

Figure 6-20. Drainage Line Processing Result.
Watershed Aggregation. This step aggregates the upstream subbasins at every stream confluence. This is a required step and is performed to improve computational performance for interactively delineating subbasins and to enhance data extraction when defining a HEC-GeoHMS project. This step does not have any hydrologic significance.

The steps to aggregate watersheds are shown below.

- Select Preprocessing → Adjoint Catchment Processing. The Adjoint Catchment Processing editor is shown in Figure 6-21.
- Select the "Input Drainage Line" and "Input Catchment" layers.
- Enter a name for the “Output Adjoint Catchment” layer. "AdjointCatchment" is the default name that can be overwritten by the user.
- Press OK.

![Adjoint Catchment Processing Editor](image)

Figure 6-21. Adjoint Catchment Processing Editor.
CHAPTER 7

Project Setup

The Project Setup menu is responsible for extracting data that will be used to develop the necessary information to create an HEC-HMS project. The approach for extraction involves specifying a control point at the downstream outlet. This location represents the downstream boundary for the HEC-HMS project. After defining the downstream outlet, HEC-GeoHMS will extract data from the datasets created using the terrain preprocessing tools (discussed in Chapter 6) for the drainage area upstream of the outlet. Then HEC-GeoHMS can be used to refine the subbasin and stream delineations, extract physical characteristics of subbasins and streams, estimate model parameters, and prepare input files for HEC-HMS. Multiple project outlets can be defined in the same project; these projects are managed through two feature classes: project points and project area. The management of these projects allows recreation of a study area with different thresholds and allows the user to delete unneeded projects and related files easily and conveniently.

Start New Project

To define a new project name and create a directory to contain extracted data and related files, go to the Project Setup menu. The user should already be zoomed into the area where the outlet will be defined before selecting these menu options.

- Select Project Setup \(\rightarrow\) Start New Project.
- Accept the default names "ProjectArea" and "Project Points" or enter a new name for these layers. The project area layer is used to show the upstream drainage area for the outlet point and the project point layer shows the location of the outlet point.
- The Define a New Project editor will open as shown in Figure 7-1.
- Enter the project name and description.
- Select the method of generating the project. Select "Original Stream Definition" from the dropdown menu as shown in Figure 7-1.

Another option for the threshold is "A New Threshold", which allows the user to specify a new threshold for the project. As mentioned before, the threshold is used to classify all flow accumulation cells with a flow accumulation greater than the user-defined threshold as cells belonging to the stream network. A smaller threshold will result in more streams and subbasins. The user-specified
threshold may be specified as an area in distance units squared, e.g., square miles, or as a number of cells. The flow accumulation for a particular cell must exceed the user-defined threshold for a stream to be initiated.

![Define a New Project Editor](image)

**Figure 7-1.** Define a New Project Editor.

- Choose a location to store all datasets. Initially, the program will clip all datasets created from the terrain preprocessing steps and store them in the project data directory. Additional datasets created by HEC-GeoHMS tools will be stored in this directory as well.
- Press **OK**.

A message window will open, as shown in Figure 7-2, that shows the directory where the project data will be saved. In addition, the message window lists two additional steps that must be followed in order to generate the project. The steps must immediately follow or the new project will not be generated. Therefore, the user should already be zoomed into the area where the outlet will be defined before the **Define a New Project** editor is opened.
Figure 7-2. Steps for Creating a New Project.

- Select the (Add Project Points) tool.
- Specify the outlet point for the project area as shown in Figure 7-3.

Figure 7-3. Specify Outlet Location.

- Select Project Setup → Generate Project.
- The first time the Generate Project option is selected, a data management editor will open letting the user verify the correct datasets are associated to the required project layers. Click the OK button after checking the data.
- The map will automatically zoom to the area upstream of the outlet point and the drainage area will be shaded. The Generate Project editor will open asking if the user wants to create a project for the shaded area. Press the Yes button.
- The New Project Layer Names editor will open as shown in Figure 7-4. The user can accept the default names or overwrite them with customized names.

A new data frame will be created and the name will be set to the project name. All the terrain preprocessing data for the project area will be extracted and
imported into the new data frame. Additional projects can be generated from the original set of preprocessed data. As illustrated Figure 7-5, the user can generate multiple projects from the original set of preprocessed data by creating multiple outlets. The benefit of this setup is that it allows the user to preserve the original data and work on multiple projects.

Figure 7-4. Editor for Naming Datasets Created for the New Project.
Figure 7-5. Two Outlets Defined within a HEC-GeoHMS Project.
CHAPTER 8

Basin Processing

After the terrain preprocessing is completed and a new project has been created, the Basin Processing menu can be used to revise the subbasin delineations. Customized subbasin and routing reach delineations should include points where information is needed, i.e., stream flow gage locations, flood damage centers, environmental concerns, and hydrologic and hydraulic controls. The tools described in this chapter will allow the user to interactively combine or subdivide subbasins as well as to delineate subbasins to a set of points.

This chapter will discuss the tools for subbasin delineation that are available from the Basin Processing menu. Below is an outline of Chapter 8.

Contents

- Basin Merge
- Basin Subdivision
- Subbasin Divide by Maximum Area
- River Merge
- River Profile
- Split Basins at Confluences
- Batch Subbasin Delineation

Basin Merge

Under the Basin Processing menu, the Basin Merge menu item merges multiple subbasins together into one subbasin. This tool works interactively by presenting the result of the operation and giving the user options to accept or cancel the operation. Below are rules and a list of steps for using the merge tool.

Rules!

- The subbasins must share a common confluence or
- The subbasins must be adjacent in an upstream and downstream manner.
• More than two subbasins are permitted.

**Steps**

• Make the subbasin layer active.
• Use the *select* tool and select the two subbasins as shown in Figure 8-1.

![Figure 8-1. Merge Selected Subbasins.](image)

• Select **Basin Processing → Basin Merge**.
• The result of the merged subbasin is displayed with a prompt for confirmation of the results. Press *Yes* to accept the resulting merged subbasin or *No* to cancel the merge operation.

The result of the merged basin is shown in Figure 8-2.

![Figure 8-2. Basin Merge Result.](image)
Basin Subdivision

A basin can be subdivided with the **Subbasin Divide** tool. The tool tip can be viewed by placing the pointer tool over the **Subbasin Divide** tool. A subbasin can be subdivided on the existing or non-existing stream network.

**Method 1: Basin Subdivision on Existing Stream**

An existing basin can be subdivided into two basins on an existing stream.

- Zoom in to the area of interest as shown in Figure 8-3. Make the stream grid (default name is "Str") layer visible. The "Str" grid layer represents the grid cells that compose the visible stream network. The existing streams are shown as blue lines in the river layer.

![Figure 8-3. Zoom in Prior to Basin Subdivision.](image)

- Select the **Subbasin Divide** tool.
- Click on the cell of interest as shown in Figure 8-4.
A few seconds later, the map zooms out and the subdivided basins are highlighted. The *Project Points* editor opens prompting the user to name the new subbasin outlet. Accept the default name for the new basin outlet or overwrite it in the text box.

- Press **OK** to make the delineation permanent.

The result of the operation is shown in Figure 8-5.

**Method 2: Basin Subdivision without Existing Stream**

When an existing stream does not extend upstream far enough, the user can use the same *Subbasin Divide* tool to delineate a new subbasin. In this case, the
flow accumulation grid can be used to see the detailed stream network. For example, in Figure 8-6, the blue line (if document is in color) is the river layer. The river layer is positioned on top of the flow accumulation grid. The detailed stream is visible in the flow accumulation grid. In this grid, the value is determined by the number of upstream cells that flow into a particular cell. A value of zero is indicative of a grid cell located on the subbasin divide.

Figure 8-6 shows that the stream network extends past the river layer. You can modify the legend to see more detail in the flow accumulation grid if needed. When subdividing a basin at a point that is not on the existing stream, the program will trace a new stream segment downstream from the specified point to the existing stream.

- Zoom in to the area of interest and make the flow accumulation layer visible.
- With the **Subbasin Divide** tool selected, click on a grid cell in the flow accumulation grid that is part of the detailed stream network.
- Accept the default name for the outlet or overwrite it in the text box and press **OK**.
Subbasin Divide by Maximum Area

The Subbasin Divide by Maximum Area tool allows the user to quickly subdivide subbasins using a maximum area threshold. The program will subdivide all subbasins, or the selected subbasins, so that the user-defined maximum drainage area is not exceeded. Figure 8-7 shows a subbasin with an approximate drainage area of 3.3 square miles. The Subbasin Divide by Maximum Area tool was used to subdivide this subbasin so that no subbasin drainage area was larger than 0.1 square miles, Figure 8-8.
Figure 8-7. Subbasin Prior to use of the Subbasin Divide by Maximum Area Tool.

Figure 8-8. Sub-Divided Subbasins After use of the Subbasin Divide by Maximum Area Tool.
Steps

- Use the select tool and select one or multiple subbasins. If no subbasins are selected then all subbasins will be edited.
- Select Basin Processing → Subbasin Divide by Maximum Area.
- Specify the maximum area threshold by entering the number of grid cells or area as shown in Figure 8-9.

![Subbasin Divide by Maximum Area](image)

Figure 8-9. Enter the Number of Cells or Area to Set the Maximum Area Threshold.

River Merge

When subbasin merges and subdivisions are performed, stream segments are often created. As an example, the result of merging two subbasins into one subbasin can result in multiple river segments. When creating an HEC-HMS project, these two segments will be treated as separate routing reaches. If the user intends to model routing with multiple reaches, the user will need to develop routing parameters for both reaches. However, if the user intends to model the routing with a single reach, then the user will need to merge both stream segments.

Steps

- Make the river layer active.
- Select the two stream segments with the Select tool.
- Select Basin Processing → River Merge.
- Confirm the merge by pressing the Yes button. The selected stream segments become one segment.
River Profile

The river profile tool provides information on slopes and grade breaks that can be useful for selecting delineation points. The river profile is created by extracting elevation values from the terrain model along the stream line. Creating the river profile can be performed using the River Profile tool.

Steps

- Make the river layer active.
- Select the Profile tool.
- Confirm the correct data layers are associated to the required datasets in the River Profile editor as shown in Figure 8-10.

![River Profile Editor](image)

Figure 8-10. River Profile Editor.

- Click on a stream segment (river layer) in the map to open a profile like the one shown in Figure 8-11.

![River Profile](image)

Figure 8-11. River Profile.
Split Basins at Confluences

The Split Basins at Confluences tool allows the user to subdivide a subbasin at all confluences. For the situation shown in Figure 8-12, this tool should be used instead of the interactive Subbasin Divide tool.

![Figure 8-12. Subdivide Basin at Confluence.](image)

**Rules!**
- Only one basin can be selected.
- This tool can be used in a basin having multiple confluences.

**Steps**
- Activate the subbasin layer.
Select the subbasin containing the confluences with the Select tool as shown in Figure 8-12.

Select Basin Processing → Split Basin at Confluences.

Confirm the split subbasins by pressing the Yes button.

The operation created three subbasins as shown in Figure 8-13. One subbasin is created for each stream segment.

Figure 8-13. Subbasins Subdivided at Confluence.

Batch Subbasin Delineation

Subbasin delineation may also be accomplished through batch processing; this requires a point layer be created that contains the desired outlet locations. It is important to recognize that the batch subbasin delineation operates on the existing delineation by further delineating with the new outlet points. There are two methods for creating the batch point layer.

Method 1: Batch Point Tool

Use the Batch Point Generation tool from the Arc Hydro Tools toolbar to place points on the map. This tool will automatically create a batch point layer. To use this tool effectively, turn on the flow accumulation grid, zoom in until grid cells in the stream network are visible, and place the point within a stream grid cell.

Rules!

- The delineation points should be located on the stream network.
Steps

- Click on the **Batch Point Generation** tool. Then click in the map to add a batch point.

- In the **Batch Point Generation** editor enter a name and description for the batch point as shown in Figure 8-14. The "BatchDone" and "SnapOn" options can be used to turn on (select 1) or off (select 0) batch processing and stream snapping for that point. The "Type" should be set to "Outlet".

![Batch Point Generation Editor](image)

Figure 8-14. Batch Point Generation Editor.

The batch point layer contains the essential fields shown in Figure 8-15. These fields provide instructions and information for the program to perform batch subbasin delineation. The field headings and values are discussed in Table 8-1.

<table>
<thead>
<tr>
<th>BatchPoint</th>
<th>OID</th>
<th>Name</th>
<th>Description</th>
<th>BatchDone</th>
<th>SnapOn</th>
<th>SrcType</th>
</tr>
</thead>
<tbody>
<tr>
<td>Point</td>
<td>1</td>
<td>Batchpoint1</td>
<td>TribA</td>
<td>0</td>
<td>1</td>
<td>Outlet</td>
</tr>
</tbody>
</table>

Figure 8-15. Batch Point Attribute Table.
**Table 8-1.** Batch Point Fields, Descriptions, and Values.

<table>
<thead>
<tr>
<th>Field Headings</th>
<th>Descriptions</th>
<th>Possible Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Shape</td>
<td>Standard requirement for noting the feature type (point, line, polygon).</td>
<td>Point</td>
</tr>
<tr>
<td>OID</td>
<td>Standard identifier for tracking the number of points generated</td>
<td>Integer</td>
</tr>
<tr>
<td>Name</td>
<td>The name of the outlet location (can be edited by the user).</td>
<td>Text</td>
</tr>
<tr>
<td>Descript</td>
<td>The description of the outlet location (can be edited by the user).</td>
<td>Text</td>
</tr>
<tr>
<td>BatchDone</td>
<td>An indicator if batch processing has been performed for the points.</td>
<td>&quot;0&quot; indicates that batch processing has not been performed. &quot;1&quot; indicates that batch processing has been performed. &quot;-1&quot; indicates that batch processing has been performed unsuccessfully.</td>
</tr>
<tr>
<td>SnapOn</td>
<td>A flag that can be set to enable snapping of the user-specified point to the stream.</td>
<td>&quot;1&quot; enables snapping. &quot;0&quot; disables snapping.</td>
</tr>
</tbody>
</table>

The Arc Hydro Batch Point Generation tool does not save the batch point layer in the HMS project directory (i.e., the same directory as the subbasin and river layers). Instead, the batch point layer is saved to the same directory used to store terrain preprocessing output. Therefore, the batch points created by Arc Hydro must be imported into the HMS project directory. The following steps show how to import Arc Hydro batch points into the HMS project directory.

**Steps**

- Select points from an existing point layer using the **Select** tool. The points must be selected in order for them to be imported.
- Select the **Basin Processing → Import Batch Points** menu option.
- Enter a name for the "Batch Point" layer and press **OK**.

To process the batch points after they have been imported, select **Basin Processing → Delineate Batch Points**.

**Method 2: Import Batch Points**

This method is useful when the user already has an existing point layer containing points of interest, stream flow gage locations, and/or previous hydrologic model outlet locations. The user can import the existing point features into the batch point layer.
**Steps**

- Select points from an existing point layer using the [Select tool. The points must be selected in order for them to be imported.](#)
- Select the **Basin Processing** → **Import Batch Points** menu option.
- Enter a name for the "Batch Point" layer and press **OK**.
- To process the batch points in the batch point layer, select **Basin Processing** → **Delineate Batch Points**.
CHAPTER 9

Stream and Subbasin Characteristics

HEC-GeoHMS computes several topographic characteristics of streams and subbasins that can be used for estimating hydrologic parameters. The user should compare and verify the physical characteristics with published information prior to estimating the hydrologic parameters. The stream and subbasin physical characteristics are stored in attribute tables, which can be exported for use with a spreadsheet and other programs.

This chapter will discuss the tools for extracting topographic characteristics of streams and subbasins. These tools are available from the Characteristics menu on the HEC-GeoHMS toolbar. A list of the physical characteristics extracted for the streams and subbasins are summarized in Table 9-1. These characteristics are saved to the attribute tables of the stream and subbasin layers. Below is an outline of Chapter 9.

Contents

- River Length
- River Slope
- Basin Slope
- Longest Flowpath
- Basin Centroid
- Centroid Elevation
- Centroidal Longest Flowpath

<table>
<thead>
<tr>
<th>Data Management</th>
</tr>
</thead>
<tbody>
<tr>
<td>River Length</td>
</tr>
<tr>
<td>River Slope</td>
</tr>
<tr>
<td>Basin Slope</td>
</tr>
<tr>
<td>Longest Flowpath</td>
</tr>
<tr>
<td>Basin Centroid</td>
</tr>
<tr>
<td>Centroid Elevation</td>
</tr>
<tr>
<td>Centroidal Longest Flowpath</td>
</tr>
</tbody>
</table>
Table 9-1. Physical Characteristics.

<table>
<thead>
<tr>
<th>Data Layer</th>
<th>Physical Characteristics</th>
<th>Attribute Table Heading</th>
</tr>
</thead>
<tbody>
<tr>
<td>Stream Layer</td>
<td>Length</td>
<td>RivLen</td>
</tr>
<tr>
<td></td>
<td>Upstream elevation</td>
<td>ElevUP</td>
</tr>
<tr>
<td></td>
<td>Downstream elevation</td>
<td>ElevDS</td>
</tr>
<tr>
<td></td>
<td>Slope</td>
<td>Slp</td>
</tr>
<tr>
<td>Subbasin Layer</td>
<td>Area</td>
<td>Shape_Area</td>
</tr>
<tr>
<td></td>
<td>Subbasin average slope</td>
<td>Basin Slope</td>
</tr>
<tr>
<td>Centroid Layer</td>
<td>Centroid location</td>
<td>Elevation</td>
</tr>
<tr>
<td></td>
<td>Centroid elevation</td>
<td></td>
</tr>
<tr>
<td>Longest Flowpath Layer</td>
<td>Location of the longest flowpath</td>
<td></td>
</tr>
<tr>
<td></td>
<td>Longest flow length</td>
<td>LongestFL</td>
</tr>
<tr>
<td></td>
<td>Upstream elevation</td>
<td>ElevUS</td>
</tr>
<tr>
<td></td>
<td>Downstream elevation</td>
<td>ElevDS</td>
</tr>
<tr>
<td></td>
<td>Slope between endpoints</td>
<td>Slp</td>
</tr>
<tr>
<td></td>
<td>Length to project outlet</td>
<td>LengthDown</td>
</tr>
<tr>
<td></td>
<td>Elevation at 10% of Longest Flow Path (from the outlet)</td>
<td>Elev10</td>
</tr>
<tr>
<td></td>
<td>Elevation at 85% of Longest Flow Path (from the outlet)</td>
<td>Elev85</td>
</tr>
<tr>
<td></td>
<td>Slope along the longest flow path based on points 10% and 85%</td>
<td>Slp1085</td>
</tr>
</tbody>
</table>

| Centroidal Flowpath Layer | Location of the centroidal flowpath | CentroidalFL |

**River Length**

This step computes the river length for selected or all routing reaches in the river layer. A field named "RivLen" is added to the river layer’s attribute table and populated with values. The units of "RivLen" are taken from the units of the DEM.

**Steps**

- Select **Characteristics** \(\rightarrow\) **River Length**.
- Make sure the river layer is selected in the **River Length** editor as shown in Figure 9-1.
- Press **OK**.
River Slope

This step extracts the upstream and downstream elevation of a river reach and computes the slope. The upstream and downstream elevation and slope are added to the river layer’s attribute table with the column headings: "ElevUP", "ElevDS", and "Slp".

Steps

- Select Characteristics → River Slope.
- Make sure the raw DEM and river layer are selected in the River Slope editor as shown in Figure 9-2.
- Press OK.

- If the vertical units for the DEM are not specified in the spatial reference information, the program will assume that the vertical units are the same as the horizontal units as shown Figure 9-3.
Basin Slope

This function computes the average basin slope in the watershed. If computed, this will be used for the computation of the CN Lag time parameter (found under the Parameters menu). The Basin Slope tool operates on a selected set of subbasins in the subbasin layer. If no subbasin has been selected, the function processes all the subbasins. The basin slope is determined by averaging values from a slope grid for each subbasin. The slope grid can be created using the Terrain Preprocessing → Slope tool on the Arc Hydro Tools toolbar.

Steps

- Make sure a slope grid is available in the data frame.
- Select Characteristics → Basin Slope.
- Select the subbasin layer and slope grid in the Basin Slope editor as shown in Figure 9-4.
- Press OK.
The subbasin layer's attribute table will contain a column named "BasinSlope" that will be populated with the average slope computed using the selected slope grid.

**Longest Flowpath**

The Longest Flowpath tool computes a number of physical characteristics: the longest flow length, upstream elevation, downstream elevation, and slope between the endpoints. These characteristics are stored in the longest flow path layer.

**Steps**

- Select **Characteristics → Longest Flowpath**.
- The **Longest Flowpath** editor is shown in Figure 9-5. Select the raw DEM, flow direction grid, and the subbasin layer. Then enter a name for the longest flow path layer or accept the default name.
- Press **OK**.
- If the vertical units for the DEM are not specified in the spatial reference information, the program will assume that the vertical units are the same as the horizontal units.

![Longest Flowpath Editor](image)

When finished, the longest flow path layer is added to the data frame. This layer’s attribute table contains the following fields:
• DrainID: HydroID of the associated subbasin.
• LengthDown: Length from the beginning of the longest flow path feature to the subbasin outlet.
• LongestFL: Length of the longest flow path.
• Slp: Slope of the longest flow path.
• ElevUP: Elevation at the upstream end of the longest flow path in map units.
• ElevDS: Elevation at the downstream end of the longest flow path in map units.
• Elev10: Elevation at 10 percent of the longest flow path length.
• Elev85: Elevation at 85 percent of the longest flow path length.
• Slp1085: Slope of the longest flow path between points located at 10 and 85 percent of the longest flow path length.

Interactive Longest Flow Path
The Interactive Longest Flow Path tool can be used to define the longest flow path for a subbasin. This tool can be used to replace the longest flow path created by the Characteristics → Longest Flowpath tool. To use this tool, click the Interactive flow path button and then click on a point in the subbasin where you think the longest flow path begins. The program will trace the longest flow path from this point to the subbasin outlet. The program shows the user the flow path for the location selected and allows the user to accept or reject the updated longest flow path. If the flow path is replaced, then attribute information will be updated and the program will remove the existing longest flow path for the selected subbasin and replace it with the interactive longest flow path.

Basin Centroid
The Basin Centroid tool will identify the centroid of each subbasin. The function will operate on the selected set of subbasins or all subbasins. The basin centroid location can be estimated in four ways. Three methods may be used to define the centroid, each one using a different algorithm and thus providing a different result. The quality of the results is a function of the shape of the subbasin and should be evaluated after they are generated. The fourth method is user-specified, where the user moves the centroid to the desired location after it is created. Sometimes, the centroid is located on the subbasin boundary and therefore should be moved or a different method should be used.
Steps

- Select Characteristics → Basin Centroid
- Select the basin centroid method as shown in Figure 9-6. Press OK.

![Basin Centroid](image)

Figure 9-6. Basin Centroid Methods.

Method 1: Center of Gravity Method

The **Center of Gravity** method computes the centroid as the center of gravity of the subbasin. If the center of gravity is outside the subbasin, it is snapped to the closest boundary.

- Select **Center of gravity**.
- Make sure the subbasin layer is selected and enter a name for the output centroid layer in the *Basin Centroid* editor as shown in Figure 9-7.
- Press **OK**.
The result is a new point layer that shows subbasin centroids.

**Method 2: Longest Flow Path Method**

The Longest Flow Path method computes the centroid as the midpoint of the longest flow path within the subbasin.

- Select **Longest flow path**.
- Make sure the subbasin and longest flow path layers are selected and enter a name for the centroid layer in the *Basin Centroid* editor as shown in Figure 9-8.
- Press **OK**.

*Figure 9-7. Basin Centroid Editor for Center of Gravity Method.*
Method 3: 50% Area Method

The 50% Area method computes the centroid as the point having a contributing area equal to 50% of the area of the subbasin.

- Select 50 percent area.
- Make sure the flow accumulation grid, subbasin, and river layers are selected and enter a name for the centroid layer in the Basin Centroid editor as shown in Figure 9-9.
- Press OK.
The result is a new point layer that shows subbasin centroids.

**Method 4: User-Specified Centroid Location**

When the three previous methods do not produce satisfactory estimates of the centroid, the user can manually edit the centroid layer to move the centroid to a more suitable location.

- Select **Editor → Starting Editing** on the Editor toolbar.

- Select the centroid layer as shown in Figure 9-10. Press **OK**.
Select the **Edit** tool on the **Editor** toolbar. Then select the centroid to be moved. Make sure that only the centroid point is selected and not other layers in the map. You can set the centroid layer as the only selectable layer to prevent unintentionally selecting features in other layers.

The pointer turns into a double arrow when a centroid is selected.

Click and drag the centroid to another location as shown in Figure 9-11.
• To stop editing and save the changes, select **Editor** ⇒ **Stop Editing**.
Centroid Elevation

This operation computes the elevation for each centroid point using a DEM. The elevations are stored in the centroid layer’s attribute table.

**Steps**

- Select **Characteristics → Centroid Elevation**.
- Select a DEM (the Raw DEM does not have to be selected) and centroid layers in the **Centroid Elevation** editor as shown in Figure 9-12.
- Press **OK**.

![Centroid Elevation Editor](image)

**Figure 9-12.** Centroid Elevation Editor.

- If the vertical units for the DEM are not specified in the spatial reference information, the program will assume that the vertical units are the same as the horizontal units.

When finished, the "Elevation" field in the centroid layer's attribute table will be populated.
Centroidal Flow Path

This operation computes the centroidal longest flowpath by projecting the centroid onto the longest flowpath. The centroidal longest flowpath is measured from the projected point on the longest flowpath to the subbasin outlet as shown in Figure 9-13.

![Diagram showing Centroidal Flow Path](image)

**Figure 9-13. Centroidal Longest Flowpath.**

**Steps**

- Select **Characteristics → Centroidal Longest Flowpath**.
- Select the subbasin, centroid, and longest flow path layers in the **Centroidal Longest Flowpath** editor as shown in Figure 9-14. Then enter a name or accept the default name for the centroidal longest flow path layer.
- Press **OK**.

The result of the centroidal longest flowpath operation is a centroidal longest flowpath layer. The attribute table contains a field named "CentroidalFL" that is populated with the length of the centroidal flow path line.
**Figure 9-14.** Centroidal Longest Flowpath Editor.
CHAPTER 10

Hydrologic Parameter Estimation

After the physical characteristics of streams and subbasins have been extracted, users have the option to estimate a number of hydrologic parameters. Parameters can be estimated as subbasin average and grid-based values using soil and land use databases. Other hydrologic parameters, such as time of concentration and Muskingum-Cunge routing parameters can be obtained from the terrain, surveyed data, and precipitation data.

The program can assist in estimating a number of parameters for the loss methods, Muskingum-Cunge and kinematic wave routing parameters, subbasin time of concentration, and subbasin lag time. Tools on the Parameters menu will populate the attribute tables for the subbasin and river layers. This information will be contained in the HEC-HMS model file generated by HEC-GeoHMS, thus saving the user time when parameterizing the model. The user should compare and verify these estimated hydrologic parameters against published information. Parameter values computed using GIS data sources should be treated as initial estimates. Calibration and validation of the HEC-HMS model should be used to refine model parameters.

This chapter will discuss the tools for estimating hydrologic parameters that are available from the Parameters menu. Below is an outline of Chapter 10.

Contents

- Select HMS Processes
- River Auto Name
- Basin Auto Name
- Grid Cell Processing
- Subbasin Parameters from Raster
- Muskingum-Cunge and Kinematic Wave Parameters
- TRSS Flow Path Segments
- TRSS Flow Segment Parameters
- TRSS Export Tt Parameters to Excel
- CN Lag Method
• Subbasin Parameters from Features
• Muskingum-Cunge and Kinematic Wave Parameters
• Time of Concentration
• CN Lag Method

**Select HMS Processes**

This tool allows the users to select the HEC-HMS modeling methods that will be used in the study. This information is saved in attribute tables for the subbasin and river layers and will be included in the HEC-HMS project files created by HEC-GeoHMS.

**Steps**

- Go to **Parameters → Select HMS Processes**.
- Verify that the subbasin and river layers are selected.
- From the dropdown menus, the user can select Loss, Transform, and Baseflow methods for the subbasins and a Route method for the river reaches as shown in Figure 10-1.

![Select HMS Processes](image)

**Figure 10-1.** Select HMS Processes.

**River Auto Name**

This process names reaches in sequence from upstream to downstream. The naming convention combines the letter "R" and a number. For example, the upstream reach starts with R500 and then R490, R480, R470, etc. are the reach
names proceeding downstream. The intent of this tool is to quickly name the reaches. The user should change the default names to a more descriptive name.

**Steps**

- Select **Parameters → River Auto Name**.
- Confirm that the river layer is selected and press **OK**.

The river auto name operation creates a "Name" column in the river layer's attribute table as shown in Figure 10-2.

![Figure 10-2. River Auto Name Result.](image)

The following steps can be used to edit the names in the attribute table.

- From the **Editor** toolbar, select **Editor → Start Editing**.
- Select the river layer.
- Open the river layer's attribute table.
- Select a field in the "Name" column and revise it.
- When finished, select **Editor → Stop Editing**.
- The user is prompted to save the edits.

**Basin Auto Name**

This process names the subbasins in sequence from upstream to downstream. The naming convention combines the letter "W" and a number. For example, the upstream subbasin starts with W500 and then W490, W480, W470, etc. are the subbasin names proceeding downstream. The intent of this tool is to quickly name subbasins. The user should change the default names to more descriptive names.

**Steps**

- Select **Parameters → Basin Auto Name**.
- Confirm the subbasin layer is selected and press **OK**.
The basin auto name operation creates a "Name" column in the subbasin layer’s attribute table as shown in Figure 10-3.

**Grid Cell Processing**

The **Grid Cell Processing** tool should only be used if the user plans on using gridded precipitation, like radar rainfall, and gridded loss methods. This tool is not necessary if using precipitation gage data or hypothetical storms. The grid cell processing tool creates a grid-based representation of the basin. This tool should be used after the user has revised the subbasin names.

This tool creates a grid cell polygon layer, which divides the project area into grid cells. The grid is intersected with the subbasin layer to determine grid cell locations and areas within each subbasin. HEC-GeoHMS supports two pre-defined grid geometries: the Standard Hydrologic Grid (SHG) and the Hydrologic Rainfall Analysis Project (HRAP). Radar rainfall data from the National Weather Service is reported in the HRAP grid format; however, tools available from HEC can convert the radar data to the SHG format. More details on the selection of a grid format are available in Appendix B.

The grid cell processing tool creates a number of new layers. A new polygon layer showing the grid intersected with the subbasin polygons will be added to the project data frame. In addition, the grid cell processing tool will create a new data frame and populate it with three layers. All three layers are projected to the SHG or HRAP coordinate system. The layers include a polygon layer of the grid, polygon layer of the subbasin boundaries, and polygon layer of the intersection between the grid and subbasin boundaries.

As mentioned, the grid cell processing tool will create a new polygon layer showing the grid intersected with the subbasin polygons and add it to the project data frame. This grid cell polygon layer contains the following fields:

- Cell_Area: Grid cell area chosen by the user.
- Cell_ID: Unique identifier for each grid cell polygon.
- Name: Name of the subbasin the cell is located within.
- Cell_X: x coordinate of the cell.
- Cell_Y: y coordinate of the cell.
- Mod_Area: Area of each polygon in square kilometers
- FlowLength: Average distance in kilometers of all the DEM cells in the grid polygon to the subbasin’s outlet.

Steps

- Select Parameters → Grid Cell Processing. The Grid Cell Processing editor is shown in Figure 10-4.

![Grid Cell Processing](image)

**Figure 10-4.** Grid Cell Processing Editor.

- Select the **SHG** or **HRAP** grid cell method. In most cases the SHG method should be used. This option allows the user to select the grid size and the SHG projection preserves area, which is important when estimating hydrologic parameters.

- If the SHG grid cell method is selected, then the user must select the SHG grid cell resolution from the dropdown menu. A grid-cell resolution of 2000 meters is often suggested when working with radar rainfall data. At that resolution, a grid cell has an area of four square kilometers if it resides entirely within a subbasin. A smaller grid cell resolution can be used to capture heterogeneous watershed characteristics, like impervious area. The resolution of the
parameter grids must match the resolution of the grid cell defined by the grid cell processing tool.

- The SHG grid uses the Albers Equal-Area projection by default. Do not change the default projection.

- Press OK.

- Verify the subbasin layer and flow direction grid are selected in the Grid Cell Processing editor as shown in Figure 10-5. If the user developed a flow length grid then it should be selected; however, it is not required. In most cases, the flow length grid will be set to "null". If created by the user, the flow length grid should contain the distance from the grid cell to the subbasin outlet. Enter a name for the new "Grid Cell Intersection" layer and press the OK button.

![Figure 10-5. Grid Cell Computation Editor.](image)

- Verify the "Projected Subbasin Layer" is selected and enter a name for the "Grid Cell Layer" in the Grid Cell View editor, shown in Figure 10-6. The "Projected Subbasin Layer" will automatically be created by the program and named using the subbasin layer name with "Proj" appended to the end. The "Grid Cell Layer" is a polygon layer of the grid.

- Press the OK button.

![Figure 10-6. Grid Cell View Editor.](image)
The grid cell processing tool will create a new data frame and populate it with three layers. All three layers are projected to the SHG or HRAP coordinate system. The layers include a polygon layer of the grid, polygon layer of the subbasin boundaries, and polygon layer of the intersection between the grid and subbasin boundaries as shown in Figure 10-7.

A new polygon layer showing the grid intersected with the subbasin polygons will be added to the project data frame. The attribute table contains information that will be used by HEC-HMS when processing gridded data. This includes grid cell location, polygon area, and travel length. The travel length is the average distance from the grid cell to the subbasin outlet as shown Figure 10-8. The travel length is used by HEC-HMS when the ModClark transform method is selected.

The grid cell layer’s attribute table, shown in Figure 10-9, stores the results for each grid cell.

![Figure 10-7. Intersection between Subbasins and SHG Grid.](image)
Figure 10-8. Flow Length Displayed for Each Grid Cell.
Subbasin Parameters from Raster

This tool operates on a raster layer and computes the average hydrologic parameters for each subbasin. This tool is similar to the Zonal Statistics tool located on the Spatial Analyst Tools toolbox and can be used to compute initial parameter estimates for loss methods in HEC-HMS.

Table 10-1 contains parameters currently supported by HEC-GeoHMS. These are added to the attribute table for the subbasin layer based on the selected HMS Process. Only parameters that could be estimated using geospatial data are added to the attribute table. Remaining parameters will have to be entered manually into the HEC-HMS model and then determined by calibrating the HEC-HMS model to historic rainfall-runoff events. The grid layers used to estimate these parameters can be downloaded from various internet sources, see Chapter 4, or generated from vector datasets using the Feature to Raster tool on the Spatial Analyst toolbar or the Features to Raster tool accessible from the Utility menu on the HEC-GeoHMS Project View toolbar.

The Select HMS Processes tool should be used to define the Loss method before using the Subbasin Parameters from Raster tool. The Subbasin Parameters from Raster editor will only include parameters that can be estimated for the select loss method. By default, the Total Storm Precipitation and 2-Year Rainfall will be included. Parameters estimated using the Subbasin Parameters from Raster tool will automatically populate the subbasin layer’s attribute table. HEC-GeoHMS will export this information to the HEC-HMS basin model file.

Steps

- Select Hydrologic Parameters → Subbasin Parameters from Raster. The Subbasin Parameters from Raster editor is shown in Figure 10-10. The parameter grids included in Figure 10-10 are for the Initial and Constant loss method. Different input parameter grids would be included if another loss method was selected.
• Select the subbasin layer and all grid layers available for computing basin average parameters. The grids are developed by the user and should be added as layers in the data frame in order to be visible from the dropdown. The grids should be in the same projection as the subbasin layer.

• Press **OK**.

![Subbasin Parameters From Raster](image)

**Figure 10-10.** Subbasin Parameters from Raster Editor.

The subbasin averaged hydrologic parameters are stored in the subbasin layer’s attribute table and will be exported to the HEC-HMS basin model file.
Table 10-1. Parameters Contained in the Subbasin Layer's Attribute Tables.

<table>
<thead>
<tr>
<th>HEC-HMS Modeling Method</th>
<th>Parameter</th>
<th>Parameter Tag in Subbasin Layer’s Attribute Table</th>
</tr>
</thead>
<tbody>
<tr>
<td>Initial+Constant Loss Method</td>
<td>Initial Loss</td>
<td>InitLoss</td>
</tr>
<tr>
<td></td>
<td>Constant Loss</td>
<td>ConstLoss</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>SCS Curve Number Loss Method</td>
<td>Initial Abstraction</td>
<td>InitAbst</td>
</tr>
<tr>
<td></td>
<td>Curve Number</td>
<td>BasinCN</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>Deficit Constant Loss Method</td>
<td>Initial Deficit</td>
<td>IDeficit</td>
</tr>
<tr>
<td></td>
<td>Maximum Deficit</td>
<td>MaxDeficit</td>
</tr>
<tr>
<td></td>
<td>Constant Loss</td>
<td>LossRate</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>Green and Ampt Loss Method</td>
<td>Initial Loss</td>
<td>InitLoss</td>
</tr>
<tr>
<td></td>
<td>Moisture Deficit</td>
<td>WetDeficit</td>
</tr>
<tr>
<td></td>
<td>Wetting Front Suction</td>
<td>WFSuction</td>
</tr>
<tr>
<td></td>
<td>Saturated Hydraulic Conductivity</td>
<td>HyConduct</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>Smith Parlange Loss Method</td>
<td>Initial Content</td>
<td>InitContent</td>
</tr>
<tr>
<td></td>
<td>Residual Content</td>
<td>ResiContent</td>
</tr>
<tr>
<td></td>
<td>Saturated Content</td>
<td>SatContent</td>
</tr>
<tr>
<td></td>
<td>Bubbling Pressure</td>
<td>BubbPress</td>
</tr>
<tr>
<td></td>
<td>Pore Distribution</td>
<td>PoreDist</td>
</tr>
<tr>
<td></td>
<td>Saturated Hydraulic Conductivity</td>
<td>SatConduct</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>Soil Moisture Accounting Loss Method</td>
<td>Canopy Storage</td>
<td>MaxCanopS</td>
</tr>
<tr>
<td></td>
<td>Surface Storage</td>
<td>MaxSurfS</td>
</tr>
<tr>
<td></td>
<td>Soil Storage</td>
<td>MaxSoilS</td>
</tr>
<tr>
<td></td>
<td>Tension Storage</td>
<td>SoilTensS</td>
</tr>
<tr>
<td></td>
<td>Ground Water 1 Storage</td>
<td>GW1MaxS</td>
</tr>
<tr>
<td></td>
<td>Ground Water 2 Storage</td>
<td>GW2MaxS</td>
</tr>
<tr>
<td></td>
<td>Maximum Infiltration</td>
<td>MaxSurfI</td>
</tr>
<tr>
<td></td>
<td>Soil Percolation</td>
<td>MaxSoilPer</td>
</tr>
<tr>
<td></td>
<td>Ground Water 1 Percolation</td>
<td>GW1MaxPer</td>
</tr>
<tr>
<td></td>
<td>Ground Water 2 Percolation</td>
<td>GW2MaxPer</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>Exponential Loss Method</td>
<td>Initial Loss</td>
<td>InitLoss</td>
</tr>
<tr>
<td></td>
<td>Percent Impervious</td>
<td>PctImp</td>
</tr>
<tr>
<td>SCS Unit Hydrograph Method</td>
<td>Basin Lag</td>
<td>BasinLag</td>
</tr>
<tr>
<td>Clark Unit Hydrograph Method</td>
<td>Time of Concentration</td>
<td>Tc</td>
</tr>
<tr>
<td></td>
<td>2Year Rainfall</td>
<td>Rain2Yr</td>
</tr>
<tr>
<td>Snyder-Tulsa Method</td>
<td>Percent Channelization</td>
<td>PctChannel</td>
</tr>
<tr>
<td>Snyder-Fort Worth Method</td>
<td>Percent Urbanized</td>
<td>PetUrban</td>
</tr>
<tr>
<td></td>
<td>Percent Sand</td>
<td>PetSand</td>
</tr>
<tr>
<td>Specified Hyetograph Meteorologic Model</td>
<td>Total Storm Precipitation</td>
<td>TotStormP</td>
</tr>
<tr>
<td></td>
<td>Precipitation Gage</td>
<td>PrecipGage</td>
</tr>
</tbody>
</table>
Subbasin Parameters from Features

This function operates on polygon features and computes the average hydrologic parameter for each subbasin. The subbasin layer’s attribute table is populated with the computed average parameter values. Before the Subbasin Parameters from Features tool can be used, the user must import the parameter feature layer into the HEC-GeoHMS project geodatabase and assign unique IDs to each feature. The parameter feature layer must be in the same projection as the HEC-GeoHMS project.

- Use ArcCatalog and import the parameter layer into the HEC-GeoHMS project geodatabase (same geodatabase as the subbasin layer). After the parameter layer has been imported, use the Add Data button and add it to the project data frame.
- Select Utility → Assign HydroID. From the Assign HydroID editor, shown in Figure 10-11, choose the Input Feature layer and check the box to overwrite existing HydroIDs. Press OK. After this step, the attribute table for the parameter layer will contain a new column named “HYDROID” and the column will be populated with unique values.

![Assign HydroID Editor](image)

Figure 10-11. Assign HydroID Editor.

Steps for using the Subbasin Parameter from Features tool

- Select Parameters → Subbasin Parameters from Features. The Subbasin Parameters from Features editor is shown in Figure 10-12.
- Select the Input Subbasin layer.
- Select the Input Parameter layer.
- Select the Parameter Tag.
The parameter tag is used by the program for populating the subbasin layer’s attribute table. A unique parameter tag is associated with each parameter. The list of parameter tags is controlled by the selected HMS process.

Table 10-1 lists all the parameter tags and associated parameters. For example, the parameter tag selected in Figure 10-12 is **PCTIMP**. This is the parameter tag for percent impervious area.

- Select the attribute field in the parameter layer to be averaged for each subbasin.
- Press **OK**.

![Subbasin Parameters From Features](image)

**Figure 10-12.** Subbasin Parameters from Features Editor.

The selected parameter in the Parameter Field is now estimated as an average quantity over each subbasin. An attribute field is populated with data in the subbasin layer’s attribute table. This information will be exported to the HEC-HMS basin model file.

**Muskingum-Cunge and Kinematic Wave Parameters**

This tool facilitates manual entry of Muskingum-Cunge and Kinematic Wave routing parameters. In most cases, the user will not be able to get accurate channel geometry from the DEM, which is often too coarse. However, the user can use as-built drawings, photos, survey data, and other information that show channel shape and geometry as shown in Figure 10-13. This information can provide a basis for the user to specify channel dimension, shape, and other parameters.
Steps

- Select at least one river segment.
- Select Parameters → Muskingum-Cunge and Kinematic Wave Parameters.
- Choose the River layer.
- Enter the bottom width of the channel, channel side slopes, and the channel’s roughness coefficient (Manning’s n) as shown in Figure 10-14. The user must enter the bottom width in the units of the HMS model because unit conversion will not be performed.
This function creates or updates the following attribute fields in the river layer.

- ChnShapeMusk: Muskingum-Cunge channel shape.
- ChnShapeKine: Kinematic Wave channel shape.
- ChnWidth: Channel width.
- ChnSdSlp: Channel side slope.
- ChnManN: Channel Manning’s n.

**Time of Concentration**

The time of concentration is estimated in accordance to the Natural Resource Conservation Service (NRCS) TR-55 methodology. The following information is required to estimate travel time: two-year 24-hour rainfall amount, slopes, flow distance of precipitation excess on the land’s surface for the three NRCS flow regimes - sheet flow, shallow concentrated flow, and channel flow. These inputs are used to populate a Microsoft Excel template spreadsheet. Users are encouraged to check and overwrite these GIS derived parameters as well as provide additional inputs, such as Manning’s roughness coefficient, channel cross-sectional area, and wetted perimeter. Users have full control over the spreadsheet to make changes to parameters and even equations, as appropriate.

The spreadsheet is launched from a HEC-GeoHMS menu. Oftentimes, HEC-GeoHMS is unable to locate Excel because of the various directories in which Excel can be installed. The user can help HEC-GeoHMS locate Excel by opening the Excel template, named “tcV3.xls”, before selecting Parameters ➔
**TR55 Export to Excel.** If HEC-GeoHMS was installed to the default location then this file is located in the following directory, C:\Program Files\HEC\HEC-GeoHMS\bin.

The user should estimate the two-year 24-hour rainfall before running the TR-55 tools. The "Rain2Yr" field in the subbasin layer’s attribute table should be populated. These values could be entered manually or the Subbasin Parameters from Raster or Subbasin Parameters from Features tools could be used. To be consistent with the TR-55 method, the precipitation intensity value should be in inches.

**TR55 Flow Path Segments**

This tool is used to define different flow regimes along the longest flow path. This tool places two points along the longest flow path for each subbasin. If no subbasin is selected, the function processes all the subbasins. The first point, AA, marks the break between sheet flow and shallow concentrated flow. Point AA is located about 100 feet from the watershed divide along the longest flow path. The second point, BB, marks the break between shallow concentrated flow and channel flow. Point BB is by default located where the longest flow path first encounters the channel. The user should manually edit the location of these points; however, they must fall on top of the longest flow path.

**Steps**

- Select **Parameters → TR55 Flow Path Segments**.
- Select the subbasin, river, and longest flow path layers in the **TR55 Flow Path Segments** editor, as shown in Figure 10-15. Enter a name for the new “Flow Break Points” layer or accept the default name.
- Press **OK**.

![Figure 10-15. TR55 Flow Path Segments Editor.](image-url)
The tool creates the flow break point layer as shown in Figure 10-16. This layer contains a field titled "Name" which indicates whether the point is an "AA" or a "BB" point.

![Figure 10-16. Flow Path Break Point Computation Result.](image)

Once these points are placed by the program, the user has the flexibility to move them using the editing tools. The points must be located along the longest flow path.

### TR55 Flow Segment Parameters

This tool calculates the length and slope for the TR55 flow paths. It operates on a selected set of subbasins. If no subbasins are selected, the tool processes all the subbasins.

The tool extracts the elevations from the terrain at the starting and ending points of the longest flow paths and at the AA and BB flow break points. Lengths are measured along the longest flow path between the four points of interest. The following fields are created or updated in the longest flow path layer.

- **ChSlopeFpf**: Slope for the TR55 channel flow segment (ft/ft) between point BB and the end of the channel.
- **ChLengthFt**: Length of the TR55 channel flow segment (between the BB flow break point and the outlet of the sub basin) (ft).
- **ShSlopeFpf**: Slope for the TR55 shallow flow (overland flow) segment (ft/ft) between most remote point and AA.
- **ConShLengthFt**: Length of the TR55 concentrated shallow flow segment (between AA and BB flow break points) (ft).
- **ConShSlopeFpf**: Slope for the TR55 concentrated shallow flow segment (ft/ft) between point AA and BB.
- ShLengthFt: Length of the TR55 shallow flow (overland flow) segment (between start of the longest flow path and the AA flow break point) (ft).

Export TR55 Data

This function exports the data for the TR55 flow segments to a Microsoft Excel template workbook. The function operates on a selected set of subbasins in the subbasin layer. If no subbasin has been selected, the tool processes all the subbasins.

In the Excel spreadsheet, as shown in Figure 10-17, the blue areas (if the document is displayed in color) contain the data brought in from HEC-GeoHMS. The user can overwrite them if necessary, but those changes will not be transferred back to HEC-GeoHMS. The green areas contain data; however, the user should verify and edit these values to better reflect field conditions. The white and yellow areas contain computed values; therefore they should not be modified in any way. They will be recomputed whenever there are changes to the blue and green areas.

![Figure 10-17. TR55 Travel Time Computation Spreadsheet.](image-url)

The Excel spreadsheet will be stored automatically in the project directory within a folder named "XLSFiles". Once the travel time of each subbasin is
estimated, the user can press the calculator button, to transfer
the travel times back to HEC-GeoHMS.

The tool updates the following fields in the subbasin layer's attribute:

- Tc: Basin time of concentration (hours).
- BasinLag: Basin lag (hours), computed as 0.6*Tc.
- LagMethod: Method used for lag computations. The entry will be "TR55" for basins in which the TR55 method was used.

## CN Lag Method

The **CN Lag Method** tool computes the basin lag time according to the equation below. This equation is based on the curve number method as described in the NRCS National Engineering Handbook, 1972 and was developed for application to watersheds of less than 2000 acres. The tool operates on a selected set of subbasins in the subbasin layer. If no subbasin has been selected, the function processes all the subbasins.

The user must populate the “BasinCN” and “BasinSlope” fields in the subbasin layer’s attribute table before using this tool. The **Subbasin Parameters from Raster** or **Subbasin Parameters from Features** tools can be used to estimate these parameters. A slope grid can be computed using the Slope tool on the Terrain Preprocessing menu (Arc Hydro Tools toolbar) or the Slope tool accessible from the Spatial Analyst toolbar.

\[
\text{Lag} = \frac{(L^{0.8} \times (S+1)^{0.7})}{(1900 \times Y^{0.5})}
\]

Where:  
- Lag = basin lag time (hours)  
- L = hydraulic length of the watershed (feet)

\[
S = \frac{1000}{\text{CN}} - 10 \quad \text{CN values between 50 and 95 are appropriate for this equation.}
\]

\[
Y = \text{basin slope (%)}
\]

This tool creates or updates the following fields in the subbasin layer’s attribute table:

- BasinLag: Basin lag (hours).
- LagMethod: Method used for lag computations. For subbasins in which the CN lag method was used, the entry will be "CNLag".
CHAPTER 11

Hydrologic Modeling System

HEC-GeoHMS develops a number of hydrologic inputs for HEC-HMS: background shape files, basin model file, grid-cell parameter file, and meteorologic model files. This chapter will discuss the tools for generating HEC-HMS model files. Below is an outline of Chapter 11.

Contents

- Map to HMS Units
- HMS Data Check
- HEC-HMS Basin Schematic
- HMS Legend
- Add Coordinates
- Prepare Data for Model Export
- Background Shape File
- Basin Model File
- Grid Cell File
- Meteorologic Model
- Create HEC-HMS Project

Map to HMS Units

This step converts the physical characteristics of reaches and subbasins to a user-selected unit system. The user has the option to convert the map units to English or International System (SI) units.

Steps

- Select HMS → Map to HMS Units.
- Select English or SI from the dropdown menu as shown in Figure 11-1 and press OK.
• Press **OK** in the confirmation message box.

The unit conversion operation results in additional columns added to the attribute table for the subbasin and river layers. The new columns will end in “HMS”. For example, a column named "Area_HMS" is added to the subbasin layer’s attribute table. The units for the data in this column will be square miles or square kilometers, depending on the selected unit system.

### HMS Data Check

This step checks the datasets for consistency in describing the hydrologic structure of the model. For example, the program checks to make sure unique names were used for river reaches and subbasins. In addition, the program checks that rivers reaches and centroids are contained within a subbasin. This is needed for placement of the hydrologic element names and the hydrologic element connectivity. In general, the program keeps track of the relationship between the stream segments, subbasins, and outlet points. These checks are necessary because the relationships between hydrologic elements may have been broken by unintentional use of subdivide and merge tools.

The program produces a file, “SkelConsChk.txt”, which contains the summary of the data check. This step does not fix any of the problems; however, the user can fix the problems manually using HEC-GeoHMS or HEC-HMS.

### Steps

- Select **HMS → HMS Check Data**.
- Press **Yes** in the **HMS Check Data** dialog, Figure 11-2, to open the check data log file.
Figure 11-2. HMS Check Data Dialog.

Figure 11-3 shows an example summary check data file. Problems identified can be fixed using HEC-GeoHMS or HEC-HMS.

Figure 11-3. Check Data Result Summary.
HEC-HMS Basin Schematic

The HMS basin schematic is the GIS representation of the HEC-HMS model. This tool will build a simple hydrologic network that contains HEC-HMS model elements and shows their connectivity. This step creates an HMS Link layer, which shows the connectivity, and the HMS Node layer, which shows subbasin and junction node locations. Node locations for subbasins are placed at the centroid of the subbasin.

Steps

- Select **HMS** → **HMS Schematic**.
- Review the input layers and make sure the correct layers are selected in the **HMS Schematic** editor, shown in Figure 11-4. Accept the default or enter a new name for the "HMS Link" and "HMS Node" layers and press **OK**.

![HMS Schematic Editor](image)

Figure 11-4. HMS Schematic Editor.

- Press **OK** at the confirmation message.

The HMS schematic with ArcGIS symbols is shown in Figure 11-5.
Figure 11-5. Initial HMS Schematic with the Regular Legend.

HMS Legend

This tool uses the HEC-HMS element icons to represent point and line features in the HMS Node and HMS Link layers. The user has the option to toggle between the **HMS Legend** and the **Regular Legend**.

**Steps**

- Select HMS → Toggle Legend.
- The user can toggle between HMS Legend and Regular Legend.

The schematic with the **HMS Legend** is shown in Figure 11-6.
Add Coordinates

This step attaches geographic coordinates to features in the HMS Node and HMS Link layers. The coordinates are added to the attribute tables. The attachment of coordinates allows GIS data to be exported to a non-proprietary ASCII format and still preserves the geospatial information.

Steps

- Select HMS → Add Coordinates.
- Press OK.

Figure 11-7 shows the attribute table for the HMS Node layer. The "CanvasX" and "CanvasY" fields contain the coordinate location for the hydrologic elements. The HMS Link layer contains additional information that describes orientation and flow direction for reach elements.
Prepare Data for Model Export

An HMS basin model file contains the hydrologic data structure, which includes the hydrologic elements, their connectivity, and related parameters. HEC-GeoHMS can export some of the hydrologic parameters to the HMS basin model file; however, the user must finish parameterizing the basin model once it is imported into HEC-HMS.

Steps

- Select **HMS → Prepare Data for Model Export**.
- Press **OK**.

This tool will gather parameter data stored in the attribute tables for the subbasin and river layers and prepare it for export to the HEC-HMS basin model file.

Background Shape File

Background shape files capture the geographic information of the subbasin boundaries and stream reaches. HEC-HMS contains options for adjusting the display properties of shape files, polygons and line properties.

Steps

- Select **HMS → Background Shape File**.
• Make sure to select the subbasin and river layers in the Background Shape File editor, Figure 11-8. Press OK.

![Background Shape File Editor](image)

**Figure 11-8.** Background Shape File Editor.

• The shape files will automatically be saved to the same directory as the project folder.

The HEC-HMS User's Manual shows how to load background shape files. The shape files should be copied from the HEC-GeoHMS project directory to the HEC-HMS project directory before loading the files into an HEC-HMS project. This should help in managing model files and make it easier to pass an HEC-HMS project from one computer to another.

**Basin Model File**

The basin model captures the hydrologic elements, their connectivity, and related geographic information in an ASCII text file that can be loaded into an HEC-HMS project.

**Steps**

• Select **HMS → Basin Model File**.

• Make a note of the filename and its location and press **OK**.

An example basin model file, in ASCII format, is shown in Figure 11-9. This file can be imported directly into an HEC-HMS project. The HEC-HMS User’s Manual describes how to import basin model files into an existing HEC-HMS project.
Grid-Cell File

This tool generates the grid cell parameter file that HEC-HMS requires in order to use gridded precipitation, a gridded loss method, or the ModClark transform method. The Grid Cell Processing step is required before the grid cell file can be created. You can access the Grid Cell Processing tool by selecting Parameters → Grid Cell Processing.

HEC-GeoHMS will create an ASCII file that contains the gridded subbasin information and automatically save it to the project directory. Appendix A describes the format of the grid cell file. The grid-cell parameter file contains the x and y coordinates, grid cell area, and travel length to the subbasin outlet for each grid cell. The coordinates refer to the lower left corner of the grid cell. Appendix B shows how to compute the grid cell coordinates for both the SHG and HRAP grids. Figure 11-10 shows an example grid cell file. This file is divided into blocks of text for each subbasin. Each block of text lists the grid cells located in the subbasin and the coordinates, area, and travel length of each grid cell.

Figure 11-9. Example HEC-HMS Basin Model File.
Figure 11-10. Example Grid Cell Parameter File.

Steps

- Select HMS → Grid Cell File.
- Make a note of the filename and its location and press OK.

The grid cell file should be copied from the HEC-GeoHMS project directory to the HEC-HMS project directory. This should help in managing model files and make it easier to pass an HEC-HMS project from one computer to another.

Meteorologic Model

It is not necessary to create meteorologic model files in HEC-GeoHMS; however, the tool is available and can be useful for creating the User Gage Weights and Inverse Distance meteorologic models. HEC-GeoHMS contains three options for creating a meteorologic model, as shown in Figure 11-11. All three meteorologic model options create a meteorologic model file (*.met extension) and a gage file (*.gage extension). The gage file contains a list of precipitation gages used by the meteorologic model.
When **Specified Hyetograph** is selected, HEC-GeoHMS will create meteorologic models that use the Specified Hyetograph method. The specified hyetograph option allows the user to specify a total storm depth for each subbasin. The user needs to enter information in the "TotStormP" field in the subbasin layer’s attribute table, as shown in Figure 11-12. This can be done manually or by using the **Subbasin Parameters from Raster** tool available from the **Parameters** menu. The user should also populate the “PrecipGage” field in the subbasin layer’s attribute. This field is used to associate a precipitation gage to each subbasin. If no gage is identified then the program will assign a gage name to each subbasin.

---

**Figure 11-11.** Options for Creating a Meteorologic Model.

**Figure 11-12.** Attribute Table for Subbasin Layer.
Steps for Specified Hyetograph Meteorologic Model

- Select HMS → Met Model File → Specified Hyetograph.
- Make sure the subbasin layer is selected in the Meteorologic Model Definition editor, shown in Figure 11-13, and press OK.

Steps for Gage Weights Meteorologic Model

The Gage Weights option will create a meteorologic model for the Gage Weights method. This option requires the user to have created a Thiessen polygon layer. The following steps show how to create a Thiessen polygon layer.

- Using ArcCatalog, import the precipitation gages into the HEC-GeoHMS project geodatabase (import into the same location as the subbasin layer). Also, make sure the precipitation gages are in the same projection as the subbasin layer and the precipitation gage layer’s attribute table contains a field titled “name”.
- Assign a unique hydro ID to each precipitation gage. Select Utility → Assign HydroID.
- Choose the precipitation gage layer in the list and check the box to overwrite existing hydro IDs in the Assign HydroID editor, as shown in Figure 11-14. Press OK.
• Select Utility → Gage Thiessen Polygon.
• Make sure the raw DEM and precipitation gage layers are selected and enter a name for the Thiessen polygon layer in the Gage Thiessen Polygon editor, as shown in Figure 11-15.

![Gage Thiessen Polygon Editor](image1)

Figure 11-15. Gage Thiessen Polygon Editor.

• An example Thiessen polygon layer is shown in Figure 11-16.

![Thiessen Polygons](image2)

Figure 11-16. Thiessen Polygons.
• Select HMS → Met Model File → Gage Weights.
• Make sure the correct subbasin and Thiessen polygon layers are selected in the Weighted Gage editor, shown in Figure 11-17, before pressing the OK button.

![Weighted Gage Editor](image)

Figure 11-17. Weighted Gage Editor.

• A window will open letting the user define the name and location of the meteorologic model file. The gage file will be saved using the same name. Accept the default name when creating only one meteorologic model.

• A new polygon layer will be created that shows the intersection of the subbasin layer and the Thiessen polygon layer. This layer shows the gages used to compute the basin average precipitation for each subbasin.

Steps for Inverse Distance Meteorologic Model

The Inverse Distance option will create a meteorologic model for the Inverse Distance method. This option requires the user to have a precipitation gage layer. The following steps show how to prepare a precipitation gage layer and use the Inverse Distance meteorologic model tool.

• Using ArcCatalog, import the precipitation gages into the HEC-GeoHMS project geodatabase (import into the same location as the subbasin layer). Also, make sure the precipitation gages are in the same projection as the subbasin layer and the precipitation gage layer’s attribute table contains a field titled “name”.

• Assign a unique hydro ID to each precipitation gage. Select Utility → Assign HydroID.

• Choose the precipitation gage layer in the list and check the box to overwrite existing hydro IDs in the Assign HydroID editor, as shown in Figure 11-14. Press OK.

• Select Utility → Add Latitude Longitude.

• Make sure the precipitation gage layer is selected in the Add Latitude Longitude editor, shown in Figure 11-18, and press OK.

Latitude and longitude coordinates will be added to the precipitation gage layer's attribute table.
Use the Add Latitude Longitude tool to also assign coordinates to the centroid layer.

The inverse distance meteorologic model can be created after the coordinate information is added to the precipitation gage and centroid layers. Select HMS → Met Model File → Inverse Distance.

Make sure the correct subbasin, subbasin centroid, and precipitation gage layers are selected in the Inverse Distance editor, shown in Figure 11-19, before pressing the OK button.

A window will open letting the user define the name and location of the meteorologic model file. The gage file will be saved using the same name. Accept the default name when creating only one meteorologic model.

Create HEC-HMS Project

You do not have to use the Create HEC-HMS Project tool to create an HEC-HMS project. You can use HEC-HMS to create a project and then import the basin model and background map shape files. The Create HEC-HMS Project tool creates a subdirectory and copies all HEC-HMS project files that were created by HEC-GeoHMS to this subdirectory. This includes the basin,
meteorologic, gage, grid cell, and background map files. It also creates the *.HMS file that contains the HEC-HMS project information.

**Steps**

- Select **HMS → Create HEC-HMS Project**.
- Choose a directory for the HEC-HMS project and select the **Basin**, **Met**, and **Gage** files to be copied to the project location in the **Create HMS Project** editor, shown in Figure 11-20. Then create a simulation run by defining the **Run Name**, Start and End times and the simulation **Time Interval**. Press **OK**.

![Create HMS Project](image)

**Figure 11-20.** Select Project Location Editor.

Once imported into HEC-HMS, parameters not estimated from GIS data will need to be defined. In addition, quality control of the input generated by HEC-GeoHMS should be performed before computing simulations and viewing results from the HEC-HMS model.
CHAPTER 12

Utilities

Tools available from the Utilities menu assist in the estimation of hydrologic parameters. You do not have to use these tools to create an HEC-HMS project. This menu contains tools for creating a curve number grid, parameter grids, Thiessen polygons, and a tool for extracting the latitude and longitude coordinates for a point layer.

Contents

- Assign HydroID
- Generate CN Grid
- Features to Rasters
- Generate ASCII Grid
- Generate DSS from ASCII Grid
- Gage Thiessen Polygon
- Add Latitude Longitude
- Change Project Point

Assign HydroID

The Assign HydroID tool should be used for GIS layers that were not created by HEC-GeoHMS, like rain gage and land use layers. This tool will create HydroIDs, a unique identifier, for each feature in the selected layer.

Steps

- Select Utility → Assign HydroID.
- Select the Input Feature Class and check the box to Overwrite HydroID in the Assign HydroID editor as shown in Figure 12-1.

Figure 12-1. Assign HydroID Editor.
Chapter 12 - Utilities

Generate CN Grid

The Generate CN Grid tool is useful for creating curve number grids. In order to use this tool you must create a polygon layer that merges both land use and soil type data. The following description shows how to create a land use / soil type layer.

Before merging land use and soil type polygon layers together, the attribute table for both layers must contain specific column headings. Figure 12-2 shows an example soil type polygon layer. Notice the attribute table contains columns named “PctA”, “PctB”, “PctC”, and “PctD”. These columns contain the percentage of each hydrologic soil group (A, B, C, and D) in the soil layer polygons. The user must add these columns to the soil layer and populate the attribute table. This information can be found using the State Soil Geographic (STATSGO) database or the county Soil Survey Geographic (SSURGO) database. Both soil databases are available from the Natural Resources Conservation Service, http://soils.usda.gov/. Figure 12-3 shows an example land use polygon layer. Notice the attribute table contains a column named “Landuse”. This column contains a unique numerical value for each land use type. The user must add this column and populate the attribute table. Any land use layer can be used, publicly available or user created.

Use the Union tool to merge the land use and soil type layers. The union tool will include attributes from both layers in the merged dataset. The Union tool is available from the Analysis Tools → Overlay toolbox. Figure 12-4 shows the attribute table of the land use / soil type layer after the union operation. Notice the attribute table contains "Landuse", "PctA", "PctB", "PctC", and "PctD" columns.
Figure 12-2. Soil Layer with Attribute Table.
The Generate CN Grid tool also requires a lookup table that relates land use and hydrologic soil groups to a curve number. The user is required to create the curve number lookup table. Figure 12-5 shows an example lookup table. The lookup table must have fields named "LUValue", "A", "B", "C", and "D". The "LUValue" column refers to the land use type. Numbers should correlate to those in the "Landuse" column from the land use/soil type layer. Columns
“A”, “B”, “C”, and “D” refer to the hydrologic soil group. These columns should contain a curve number that is appropriate for the land use and hydrologic soil group combination. For example, row 1 in Figure 12-5 shows a curve number of 61 will be assigned to polygons that have a land use of 1 with a hydrologic soil group of A.

![Example Curve Number Lookup Table](image)

**Figure 12-5. Example Curve Number Lookup Table.**

The **Generate CN Grid** tool can be used after the merged land use and soil type layers and curve number lookup table have been created.

**Steps**

- Select **Utility → Generate CN Grid**.
- Select the Hydro DEM, curve number polygon layer (land use/soil type layer), and the curve number lookup table in the **Generate CN Grid** editor as shown in Figure 12-6. Enter a name for the curve number grid and press **OK**.

![Generate CN Grid Editor](image)

**Figure 12-6. Generate CN Grid Editor.**
The program will automatically add a "CN" field to the land use/soil type attribute table and populate it with the computed curve number. Figure 12-7 shows an example curve number grid created by the **Generate CN Grid** tool. This grid could be used to estimate the average curve number for each subbasin.

![Curve Number Grid Computed by the Generate CN Grid Tool.](image)

**Figure 12-7.** Curve Number Grid Computed by the Generate CN Grid Tool.
Features to Raster

The **Features to Raster** tool can be used to convert a polygon layer to a raster coverage. This can also be done using the **Feature to Raster** tool on the **Spatial Analyst** toolbar. An example is used to describe the use of this tool. For this example, a land use layer was reprojected to the same projection as the SHG layer. The land use layer contains an impervious area estimate for each polygon, as shown in Figure 12-8. The **Zonal Statistics** tool on the **Spatial Analyst** toolbar was used to estimate the average impervious area value for each 500 meter grid cell in the SHG layer, as shown in Figure 12-9. The **Feature to Raster** tool was used to create a raster coverage with the same extents and cell size of the SHG layer.

**Steps**

- Select the **Utility → Features to Rasters**.
- The **Select features for converting to raster** editor is shown in Figure 12-10.
- Choose the parameter that the new raster coverage will represent in the **Tag Name** drop down list. The list of names in the tag name list corresponds to the parameter names in the subbasin layer’s attribute table. If the polygon coverage you want to convert to a raster does not correspond to one of the options in the list then choose any tag name.
- Select the **Feature** input field to open another widow that will let you select the polygon layer to convert to a raster coverage.
- The **Field Name** input field is used to select the field from the selected layer’s attribute table. This field will be used as the “value” in the raster coverage.
- Enter a name for the new raster coverage in the **Output Name** field.
- Choose an existing dataset to set the extents of the new raster coverage. If trying to create a parameter grid for import into HEC-DSS then it is important that the SHG or HRAP layer is used to set the extent of the new raster coverage.
- Finally, set the cell size. If trying to create a parameter grid for import into HEC-DSS then the cell size must be the same cell size used in the Grid Cell Processing step.
Figure 12-8. Land Use Layer with Percent Impervious Area.
Figure 12-9. SHG layer with Impervious Area Assigned to each Grid Cell.

Figure 12-10. The Select Features for Converting to Raster Editor.
Generate ASCII Grids

The Generate ASCII Grids tool will create an ASCII grid file that can be imported into HEC-DSS. Precipitation and parameter grids must be in HEC-DSS format in order to be used by HEC-HMS. The Generate ASCII Grids tool lets the user choose the parameter for export and then it looks for specific attributes in the Grid Cell Intersection layer (this layer is created by the Grid Cell Intersect tool). These attributes must have specific column headings so that they are recognized, see Table 10-1. The user must add these column names and then compute an average parameter value for each grid cell. There are a number of ways for manually populating the grid cell intersect layer. The following example shows one approach for populating the grid cell intersect layer with percent impervious data.

- Figure 12-11 shows a 500 meter SHG grid (created by the Grid Cell Intersect tool) on top of the subbasin boundary layer. Figure 12-12 shows an impervious area grid for this same area.

- The zonal statistics tool, Spatial Analysis → Zonal Statistics, was used to compute the average grid cell value for each 500 meter SHG grid cell.

A new field titled "PctImp" was added to the grid cell intersect layer. This field was populated with output from the zonal statistics tool, as shown in Figure 12-13. Figure 12-14 shows the grid cell intersect layer with the "PctImp" (percent impervious area) field displayed. The difference in Figure 12-12 and Figure 12-14 is the resolution of the grid. The original percent impervious grid had a grid cell size of 50 meters, whereas the grid cell intersect layer has a grid cell size of 500 meters.

Another option is to use the Subbasin Parameters From Raster or Subbasin Parameters From Features tools to populate the Grid Cell Intersect layer attribute table. Instead of selecting the Input Subbasin layer the user would choose the Grid Cell Intersect layer. This tool will automatically populate the grid cell intersect layer’s attribute table.
Figure 12-11. Grid Cell Layer Displayed on Top of Subbasin Boundary.
Figure 12-12. Percent Impervious Grid.

Figure 12-13. Grid Cell Intersect Layer with Percent Impervious Area.
Steps

- Select Utility → Generate ASCII Grids.

- Select the parameter tag to create the ASCII grid and the input grid cell layer intersection layer, shown in Figure 12-15. The list of parameter tags reflects the loss method selected using the Select HMS Processes tool (this tool should be used before running the Generate ASCII Grids tool). The attribute table for the grid cell intersect layer should contain the appropriate field names. Press OK.
The ASCII file will be saved to the HEC-GeoHMS project directory, the same location as the geodatabase storing the subbasin layer. The ASCII file is required for the next tool on the Utility menu, **Generate DSS from ASCII Grid**. This tool is discussed in the next section. The ASCII file created by HEC-GeoHMS will be in the same projection as the selected grid, HRAP or SHG. Standard GIS tools can also be used to create ASCII grid files that can be imported into HEC-DSS. The **Raster to ASCII** tool, available from the **Conversion Tools** toolbox, is a more generic tool that can be used to convert a grid in ESRI Grid format to an ASCII grid file. The user must create a raster coverage before using the **Raster to ASCII** tool. It is important that the raster coverage be in the same projection as the grid system, SHG or HRAP. Appendix B provides more detail for both projections. In addition, the grid coverage must have the same extents and cell size as the grid cell layer. The grid cell layer is created by the **Grid Cell Processing** tool. The grid cell layer shows the grid extents before the intersection with the subbasin boundary, as shown in Figure 12-16. The layer is automatically added to the "GridCell" data frame.
Generate DSS from ASCII Grid

This tool converts a grid in ASCII format to a grid in HEC-DSS format. Grids must be in HEC-DSS format before they can be used by HEC-HMS. To open this tool, select Utility → Generate DSS from ASCII Grid.

The Generate DSS from ASCII Grid editor is shown in Figure 12-17. At the top of the editor, the user is required to select an ASCII grid file and choose an existing or create a new HEC-DSS file. Then, the user can enter pathnames for describing the data. The A-part pathname is used to describe the grid format, either HRAP or SHG. If the SHG system is used then also include the cell size, like SHG500. The B-part pathname is used to describe the project area. This could be the name of the drainage basin. The C-part name is used to identify the data type. The D- and E-part names are necessary if dealing with time-series data, like precipitation data. If working with parameter grids, like curve number, then leave the D- and E-part fields empty. The format for these fields is "ddmmmyyyy:tttt" (01Jan2000:0100). Finally, the F-part name is used to describe how the data was created, like "estimated" or "observed". The "Data Unit", "Data Type", and "Grid Type" fields contain drop down lists. Refer to the HEC-HMS User’s Manual for a description of required units, data types, and C-part pathnames.
The **Gage Thiessen Polygon** tool will create Thiessen polygons given a point layer. These polygons could then be used to compute gage weights for determining subbasin average precipitation. The attribute table for the precipitation gage layer must contain “name” and “HYDROID” fields. HydroIDs can be added using the Assign HydroID tool, available from the Utility menu.

**Steps**

- Select **Utility → Gage Thiessen Polygon**.
- Select the input Raw DEM, input precipitation gage layer, and enter a name for the output Thiessen polygon layer in the **Gage Thiessen Polygon** editor, shown in Figure 12-18. Press **OK**.

---

**Figure 12-17.** ASCII Grid to DSS Editor.
Figure 12-18. Gage Thiessen Polygon Editor.

Figure 12-19 shows a Thiessen polygon layer created using five precipitation gages. The Thiessen polygon layer can be used to compute the weights to apply to each gage when computing subbasin average precipitation.

Figure 12-19. Thiessen Polygons Created by the Gage Thiessen Polygon Tool.
Add Latitude and Longitude

The **Add Latitude Longitude** tool will add latitude and longitude coordinates to any point layer. The only requirement for this tool is a point layer.

Steps

- Select **Utility → Add Latitude Longitude**.
- As shown in Figure 12-20, choose a point layer and press **OK**.

![Add Latitude Longitude Editor](image)

*Figure 12-20. Add Latitude Longitude Editor.*

This tool will automatically add the latitude and longitude coordinates to the point layer's attribute table, as shown in Figure 12-21.

![Attributes of raingages](image)

*Figure 12-21. Latitude and Longitude Coordinates Added to the Rain Gage Layer.*

Change Project Point

A project point is added when the Subbasin Divide tool is used to define a new subbasin outlet. By default, this point will be treated as a junction. The point can be changed to a Reservoir, Diversion, or Source element by using the Change Project Point tool.
Steps

- Select the new hydrologic element type for the project point,

- Press the **Change Project Point** button,

- Place the mouse pointer on the project point and click the left mouse button.

- Enter a name and description for the project point in the **Add HMS Element** editor, shown in Figure 12-22.

The attribute table for the Project Points layer will be updated after the project point type is changed. The attribute field “HyElemType” will show the updated element type.

![Add HMS Element](image)

**Figure 12-22.** Enter the Project Point Name and Description in the Add HMS Element Editor.
CHAPTER 13

Example Application - American River Basin

The purpose of this chapter is to illustrate the major steps in the development of a hydrologic model using HEC-GeoHMS Version 10.1. The study watershed is a portion of the American River Basin, just east of Sacramento, California. The watershed consists of 4,817 square kilometers (1,860 square miles). The digital elevation model has been assembled to represent the watershed terrain. In addition, stream flow gages have been compiled into a data layer of gage locations and will be used as delineation points.

Overview

This chapter provides a detailed example of how to perform a drainage analysis on a digital terrain model for the development of an HEC-HMS model. The following tasks will be performed in the presentation of this example. Processing times for most tasks are shown based on an Intel® Core™ i7 CPU with 8.00 GB of memory. Beside the hardware specifications, the terrain grid size is the most important factor in determining the time required to perform most of the operation.

The sample data for this exercise includes the DEM ("amerriver_dem") and gage outlet locations ("hec1ga"). The sample data can be downloaded from the HEC-GeoHMS webpage, http://www.hec.usace.army.mil/software/hec-geohms/download.html. The completed project is also available from the HEC-GeoHMS webpage.

Task I. Preprocess the Terrain Model

Open a new empty ArcMap project.
Make sure the ArcHydro and HEC-GeoHMS toolboxes have been loaded into ArcToolbox.
Load the HEC-GeoHMS toolbar.
Load the terrain data.
Save the project.
Perform drainage analysis using the 8-pour point approach.
Extract project specific data.
Task II. Basin Processing

Revise subbasin delineation.
Extract physical characteristics of streams and subbasins.
Develop hydrologic parameters.
Develop HMS inputs.

Task III. Hydrologic Modeling System

Setup an HMS model with inputs from HEC-GeoHMS.

Task I. Preprocess the Terrain Model

1. Open a new empty ArcMap project as shown in Figure 13-1.

![Figure 13-1. Create a New Empty ArcMap Project.](image)

2. Make sure the ArcHydro and HEC-GeoHMS toolboxes have been loaded into ArcToolbox (Figure 13-2).
3. Load the HEC-GeoHMS toolbar.

   - Select **Customize → Extensions…** and turn on Spatial Analyst.
   - Select **Customize → Toolbars** and check the **HEC-GeoHMS toolbar**.

When properly installed and loaded, the HEC-GeoHMS toolbar is shown Figure 13-3.

4. Load the terrain data.
   - Add data to the **Layers** data frame
   - Click the **Add Data** button and add the terrain data, amerriver_dem.
   - View the properties of the terrain by right-clicking on the terrain data and selecting **Properties**. Note that there are about ten million cells (2834 rows * 3662 columns) at a thirty meters resolution (Figure 13-4). This covers a rectangular area of 9340 sq km (3606 sq mi), which encompasses this study watershed of 4817 sq km (1860 sq mi).
The coordinate system for the data frame will be set to the terrain data's coordinate system because this was the first dataset added to the ArcMap document.

5. Save the project.
   - Save the project to a new empty directory on the local computer. No other ArcMap document should be in this directory. For this example, the project was named "AmericanRiver" and saved to the "C:\AmericanRiver" directory. The location of the project is important because subsequent derived datasets are stored in this directory.

6. Perform drainage analysis using the 8-point pour approach.
   **A. Fill Sinks**
   - Select **Preprocessing → Fill Sinks**.
   - Confirm that the DEM input is "amerriver_dem". The output Hydro DEM is "Fil" as shown in Figure 13-5.
Press OK. This step takes about 15 seconds. The filled DEM is shown in Figure 13-6.

**Figure 13-6.** Fill Sinks Grid.

### B. Flow Direction

- Select **Preprocessing → Flow Direction**.
- Confirm that the input Hydro DEM is "Fil". The output Flow Direction Grid is "Fdr".
• Press **OK**. This step takes about 6 second. The flow direction grid is shown in Figure 13-7.

![Figure 13-7. Flow Direction Grid.](image)

**C. Flow Accumulation**

- Select **Preprocessing → Flow Accumulation**.
- Confirm that the input Flow Direction Grid is "Fdr". The output Flow Accumulation Grid is "Fac".
- Press **OK**. This step takes about 47 seconds. The flow accumulation grid is shown in Figure 13-8.
The above screen does not appear complete, but it is. Zoom-in to a part of the basin to display the details of the grid cells that make up the flow accumulation grid as shown in Figure 13-9. The grid cell value is computed by summing the total number of grid cells that flow into each grid cell. Grid cells with a value of 0 are located on the topographic divide and grid cells with a large value make up the stream network.

**Figure 13-9.** Flow Accumulation Grid Showing Detailed Stream Network.

### D. Stream Definition

- Select **Preprocessing → Stream Definition.**
• Confirm that the input Flow Accumulation Grid is "Fac". The output Stream Grid is "Str".
• Accept the default Stream Threshold as shown in Figure 13-10 and press OK. This step takes less than 7 seconds.

![Figure 13-10. Define the Stream Threshold.](image)

Zoom-in to see the grid cells that make up the stream definition grid as shown in Figure 13-11.

![Figure 13-11. Stream Definition Grid.](image)

E. Stream Segmentation
• Select Preprocessing → Stream Segmentation.
• As shown in Figure 13-12, confirm that the input Flow Direction Grid is "Fdr" and Stream Grid is "Str". The output Stream Link Grid is "StrLnk".

• Press OK. This step takes less than 5 seconds.

![Stream Segmentation Editor](image)

**Figure 13-12.** Stream Segmentation Editor.

**F. Catchment Delineation**

• Select Preprocessing → Catchment Grid Delineation.

• Confirm that the input Flow Direction Grid is "Fdr" and Link Grid is "StrLnk". The output Catchment Grid is "Cat".

• Press OK. This step takes less than 11 second. The catchment grid is shown in Figure 13-13.
G. Catchment Polygon Processing

- Select Preprocessing → Catchment Polygon Processing.
- Confirm that the input Catchment Grid is "Cat". The output Catchment layer is "Catchment".
- Press OK. This step takes less than 10 seconds. The catchment polygons are shown in Figure 13-14.
H. Drainage Line Processing

- Select Preprocessing → Drainage Line Processing.
- Confirm that the input Stream Link Grid is "StrLnk" and Flow Direction Grid is "Fdr". The output Drainage Line is "DrainageLine".
- Press OK. This step takes less than 30 seconds. The drainage lines are shown in Figure 13-15.

![Figure 13-15. Drainage Lines.](image)

I. Watershed Aggregation

- Select Preprocessing → Adjoint Catchment Processing.
- Confirm that the input Drainage Line is "DrainageLine" and Catchment is "Catchment". The output Adjoint Catchment is "AdjointCatchment".
- Press OK. This step takes less than 20 seconds. The aggregated catchment layer is shown in Figure 13-16.
7. Extract project specific data.

In the next step, the study area is defined by identifying an outlet. HEC-GeoHMS will extract data for the drainage area upstream of the defined outlet. A new ArcMap data frame will be populated with the project specific data. Tools on the **Project Setup** menu can be used to interactively delineate the project area and create input files for an HEC-HMS project.

- Add the stream flow gage layer called "hec1ga" to the Data Frame to help determine the outlet location.
- Make the "hec1ga" layer active and identify the gage shown in Figure 13-17.
• The identified gage has a drain area of about 493 sq. miles. This can be found in the attribute table for the hec1ga layer. Look in the "DRAIN_AREA" column.

• Zoom closely in on this gage and make the "Strlnk" layer visible as shown in Figure 13-18.

• Now analyze the watershed that drains to this stream gage.
• Select Project Setup → Start New Project.
• Press OK in the Start New Project window. Accept the default names for the Project Area and Project Point layers.
• The Define a New Project editor is shown in Figure 13-19. Enter "ProjAmer" as the project name.
• Enter "GeoHMS of American River" as the project description.
• Press OK.
Figure 13-18. Location of Stream Gage.

Figure 13-19. Define a New Project Editor.
• Read the information in the **Start New Project** window before closing it.

• Select **Add Project Points**, and click on the cell located at the gage to specify the outlet location as shown in Figure 13-20.

![Figure 13-20. Define Study Outlet.](image)

• Name the outlet point "Outlet_Amer" and accept "Outlet1" for the description (Figure 13-21).

![Figure 13-21. Project Points Editor.](image)

• Press **OK**.

• Select **Project Setup → Generate Project**.

• Verify the proper data layers are used as shown in Figure 13-22 and press **OK**.
The basin upstream of the selected outlet will become highlighted, and the program will prompt you to create a project of the area.

Press **Yes** to create a project for the highlighted area.

Press **OK** to accept the default names in the *Generate Project* window.

If the user wants to see the extracted catchment relative to the entire watershed, activate the Layers data frame and turn on the *ProjectArea* layer.

Figure 13-22. Define Project Data.
The pertinent datasets are extracted for the area above the outlet and added to the **ProjAmer** data frame (Figure 13-24). These datasets will be used for additional basin processing, extracting basin characteristics, and developing HEC-HMS inputs.

![Figure 13-23. Project Area to be Extracted.](image1)

**Figure 13-23.** Project Area to be Extracted.

![Figure 13-24. Project Data Frame with Extracted Data.](image2)

**Figure 13-24.** Project Data Frame with Extracted Data.
Task II. Basin Processing

8. Revise subbasin delineation.

A. Merge Basins

This process merges selected subbasins into one.

- Select the four subbasins shown in Figure 13-25 with the Select Features tool.
- Select Basin Processing → Basin Merge.
- Press Yes to accept the resulting merged subbasin.

Figure 13-25. Highlighted Subbasins to be Merged.

The result of the merged subbasin is shown in Figure 13-26.

Figure 13-26. Merged Subbasin.
B. Subdivide a Basin

- Add the hec1ga layer to the ProjAmer data frame (drag and drop from the Layers data frame to the ProjAmer data frame).
- Zoom in on the gage location shown in Figure 13-27 and make the "Str" grid visible.

![Subdivide Subbasin at Stream Gage Location.](image)

**Figure 13-27.** Subdivide Subbasin at Stream Gage Location.

- With the **Subbasin Divide** tool, \( \mathbb{A} \), click on the cell shown in Figure 13-28 to subdivide the subbasin.

![Subdivide by Clicking the Subbasin Divide Tool on the Stream Network.](image)

**Figure 13-28.** Subdivide by Clicking the Subbasin Divide Tool on the Stream Network.
• Use the default names in the **Project Points** dialog as shown in Figure 13-29.

![Project Points dialog](image)

**Figure 13-29.** Name the Subbasin Outlets using the Project Points Editor.

• Press **OK**.

The result of basin subdivision is shown in Figure 13-30.

![Subbasin subdivision](image)

**Figure 13-30.** New Subbasin Created by the Subbasin Divide Tool.

C. **Obtain River Profile**

• Select the **River Profile** tool, ![River Profile tool](image).

• Verify that the proper data layers are used as shown in Figure 13-31.
Click on the highlighted river segment, as shown in Figure 13-32, to view the river profile.
9. Extract physical characteristics of streams and subbasins.

The physical characteristics of streams and subbasins are extracted and saved in attribute tables.

A. River Length

- Select Characteristics → River Length.
- Press OK after making sure the river layer is selected.
- A "RivLen" column in the attribute table is updated with estimates of the river length (Figure 13-33).

![Figure 13-33. Attribute Table for the River Layer.](image)

B. River Slope

- Select Characteristics → River Slope.
- Press OK after making sure the DEM and river layer are selected.
- "Slp", "ElevUP", and "ElevDS" columns are updated in the river layer's attribute table (Figure 13-34).

![Figure 13-34. Slope Attributes for the River Layer.](image)

C. Longest Flow Path
• Select Characteristics → Longest Flowpath.
• Review the input and output data layers as shown in Figure 13-35. Press OK. This step takes about 40 seconds.

Figure 13-35. Longest Flowpath Editor.

The results of the longest flow path operation are shown in Figure 13-36.

Figure 13-36. Longest Flow Path Layer.

The longest flow path computation also stores the physical parameters in the attribute table as shown in Figure 13-37.
D. Basin Centroid

- Select Characteristics → Basin Centroid.
- Select the Center of Gravity Method (Figure 13-38).
- Make sure the subbasin layer is selected and accept the default name for the basin centroid layer. Press OK.

A new data layer is created to represent the centroid locations as shown in Figure 13-39.
E. Centroid Elevation
   - Select Characteristics $\rightarrow$ Centroid Elevation.
   - Make sure the raw DEM and centroid layer are selected and press OK.

An elevation field is added to the centroid layer’s attribute table.

F. Centroidal Longest Flowpath
   - Select Characteristics $\rightarrow$ Centroidal Longest Flowpath.
   - Make sure the subbasin, centroid, and longest flow path layers are selected. Accept the default name for the centroidal longest flow path and press OK.

A new data layer is created to represent the centroidal flow paths as shown in Figure 13-40.
10. Develop hydrologic parameters.

A. Select HMS Processes

- Select Parameters $\rightarrow$ Select HMS Processes.
- Make sure the subbasin and river layers are selected and press OK.
- Select Initial+Constant for Loss Method, Clark for Transform Method, None for Baseflow Method, and Lag for Route Method (Figure 13-41).
- Press OK.
B. River Auto Name

- Select Parameters → River Auto Name.
- Make sure the river layer is selected and press OK.

This step creates a "Name" column in the river layer’s attribute table as shown in Figure 13-42. In a real study, you should manually edit the names.

C. Basin Auto Name

- Select Parameters → Basin Auto Name.
- Make sure the subbasin layer is selected and press OK.
This step creates a "Name" column in the subbasin layer’s attribute table as shown in Figure 13-43. In a real study, you should manually edit the names.

![Subbasin36](image)

**Figure 13-43.** Subbasin Names.

11. Develop HMS inputs.

   A. Map to HMS Units

   - Select **HMS → Map to HMS Units**.
   - Select **English** from dropdown menu as shown in Figure 13-44.
   - Press **OK**.

![Select unit type for HMS Model](image)

**Figure 13-44.** Select the Units System.

The results of the unit conversion are added columns to attribute tables for the subbasin (Figure 13-45) and river (Figure 13-46) layers. The added columns contain the ending “_HMS”.

![Subbasin36](image)

![Subbasin36](image)
Figure 13-45. Area Field Added to the Subbasin Layer's Attribute Table.

Figure 13-46. Elevation and Length Fields Added to the River Layer's Attribute Table.

B. HMS Check Data

- Select HMS → HMS Check Data.
- Make a note of the file name and its location, Figure 13-47. Press Yes to review the file.

Figure 13-47. Location of the Check Data File.
The output file, "SkelConsChk.txt", contains the results of the data check. A portion of the file is shown in Figure 13-48.

Figure 13-48. Portion of the Check Data File.

C. HMS Schematic

- Select HMS → HMS Schematic.
- Review the input and output datasets as shown in Figure 13-49. Press OK.

Figure 13-49. HMS Schematic Editor.

The HMS schematic with the regular legend symbols is shown in Figure 13-50.
Figure 13-50. Schematic with Regular Legend Symbols.

D. HMS Legend

- Select **HMS \(\rightarrow\) Toggle HMS Legend \(\rightarrow\) HMS Legend**.
- The user can toggle between the **HMS Legend**, as shown in Figure 13-51, and the **Regular Legend**.

Figure 13-51. Schematic with HMS Legend Symbols.
E. Add Coordinates
This step attaches geographic coordinates to hydrologic elements in the HMSNode and HMSLink layers. The coordinates are saved to the attribute tables. The attachment of coordinates allows GIS data to be exported to a non-proprietary ASCII format and still preserve the geographic information.

- Select HMS → Add Coordinates.
- Press OK.

F. Prepare Data for Model Export
The Prepare Data for Model Export tool assembles the required HMS data for export to ASCII format.

- Select HMS → Prepare Data for Model Export.
- Press OK.

G. Background Shape Files
The background shape file option captures the geographic information of the subbasin boundaries and the stream network.

- Select HMS → Background Shape File.
- Make sure the subbasin and river layers are selected and press OK.
- A window will open stating the shape files were successfully created. Press OK. These shape files are automatically saved in the project directory.

H. Basin Model File
The basin model file captures the hydrologic elements, their connectivity, and related geographic information in an ASCII text file that can be read by HEC-HMS.

- Select HMS → Basin Model File.
- Make a note of the file name and its location. Press OK.

Additional HEC-HMS project files can be created by HEC-GeoHMS; however, they are not necessary. The basin model file and background map files can be imported into an existing HEC-HMS project.
Task III. Hydrologic Modeling System

12. Setup an HEC-HMS model with inputs from HEC-GeoHMS.

The user should create the HEC-HMS project first and then copy the background map files and basin model file to the HEC-HMS project folder. If other HEC-HMS project files were created by HEC-GeoHMS then these should be copied as well.

- Start the HEC-HMS program.
- Select File → New….
- Enter a project name of "American River Example" and a description of "GIS Application of HEC-GeoHMS to the American River Basin" as shown in Figure 13-52.
- Choose a directory to save the project.
- Select U.S. Customary for the unit system.
- Press the Create button.

![Create a New Project](image)

**Figure 13-52.** Create a new HEC-HMS Project.

Use Windows Explorer to copy the basin model file and the background shape files to the newly created HEC-HMS project folder. The folder will have the same name as the project, "American River Example".

- To import the basin model file created by HEC-GeoHMS select File → Import → Basin Model … (Figure 13-53).
Figure 13-53. Import a Basin Model File into an Existing HEC-HMS Project.

- Navigate to the correct location and select the basin model file, "ProjAmer.basin".
- Press the Select button.

You should notice a Basin Models folder is added to the Watershed Explorer. The ProjAmer basin model is contained in this folder. When you select the ProjAmer basin model in the Watershed Explorer, the basin model map will open in the desktop area, as shown in Figure 13-54.
Select the View → Maximum Extents menu option to open the Maximum Extents editor (Figure 13-55).

Choose an extents method of Union of All Elements and a buffer of 25 percent.

Click the OK button and the map will automatically resize. The element network will look similar to the HEC-GeoHMS project.
Figure 13-55. Set the Map Extents using the Maximum Extents Editor.

- Add the background shape files by selecting View → Background Maps.
- Click the Add button in the Background Maps window (Figure 13-56).

Figure 13-56. Add Background Maps using the Background Maps Editor.
• Make sure the file type is ESRI Shapefile (*.shp) and navigate to the directory where the background shape files are located as shown in Figure 13-57.

![Select Shape File](image)

Figure 13-57. Select the Shape File to Add as a Background Map.

• Select the subbasin shape file and press the Select button. The shape file will be automatically added to the basin model map. Next, add the river shape file to the map. The Background Maps editor can be used to order the shape files so that the river lines are drawn on top of the subbasin polygons and to edit the draw properties of the lines and polygons. Figure 13-58 shows the basin model map after importing the background shape files.
The next step in creating the HEC-HMS model is to enter subbasin and routing element parameters. Parameters could be estimated from previous studies or from a regional analysis. Then the model should be calibrated to historic rainfall-runoff events.
APPENDIX A

Grid-Cell Parameter File Format

The ModClark transform method requires a grid-cell file. The file defines cells for each subbasin. Parameters for each cell are also included in the grid-cell file. This appendix describes the grid-cell file format. The file can be produced using available geographic information system (GIS) tools.

File Definition

The grid-cell file begins with the keyword "Parameter Order" followed by a colon and parameter keywords indicating the order for reading parameters from the file (Figure A-1). The keyword "End" must be on a line by itself after the "Parameter Order" line. Valid parameter keywords are shown in Table A-1. Parameter keywords are not case sensitive and are separated by spaces. If the parameter order is not defined, it is assumed to be: Xcoord, Ycoord, TravelLength, and Area. The coordinate system of Xcoord and Ycoord used in the file must match the coordinate system used in the gridded DSS precipitation records. Typically the coordinate system will be either Hydrologic Rainfall Analysis Project (HRAP) or Standard Hydrologic Grid (SHG).

<table>
<thead>
<tr>
<th>Parameter Order: Xcoord Ycoord TravelLength Area</th>
</tr>
</thead>
<tbody>
<tr>
<td>End:</td>
</tr>
<tr>
<td>Subbasin: 85</td>
</tr>
<tr>
<td>Grid Cell: 633 359 88.38 3.76</td>
</tr>
<tr>
<td>Grid Cell: 633 358 85.55 16.13</td>
</tr>
<tr>
<td>Grid Cell: 632 358 82.55 12.76</td>
</tr>
<tr>
<td>Grid Cell: 625 348 13.75 12.07</td>
</tr>
<tr>
<td>Grid Cell: 626 348 17.12 0.09</td>
</tr>
<tr>
<td>Grid Cell: 622 347 21.19 3.26</td>
</tr>
<tr>
<td>Grid Cell: 623 347 15.56 9.96</td>
</tr>
<tr>
<td>End:</td>
</tr>
<tr>
<td>Subbasin: 86</td>
</tr>
<tr>
<td>Grid Cell: 637 361 59.13 6.79</td>
</tr>
<tr>
<td>Grid Cell: 638 361 59.04 6.95</td>
</tr>
<tr>
<td>Grid Cell: 636 361 56.68 1.17</td>
</tr>
<tr>
<td>Grid Cell: 636 360 55.08 16.38</td>
</tr>
<tr>
<td>Grid Cell: 636 347 67.96 2.45</td>
</tr>
<tr>
<td>Grid Cell: 637 347 71.72 7.41</td>
</tr>
<tr>
<td>Grid Cell: 638 347 72.57 8.78</td>
</tr>
<tr>
<td>Grid Cell: 639 347 73.32 0.04</td>
</tr>
</tbody>
</table>

Figure A-1. Sample Grid-Cell Parameter File.
Table A-1. Parameter Keyword Definitions.

<table>
<thead>
<tr>
<th>Keyword</th>
<th>Definition</th>
<th>Units</th>
</tr>
</thead>
<tbody>
<tr>
<td>XCoord</td>
<td>x-coordinate of the southwest corner of the cell</td>
<td>integer value</td>
</tr>
<tr>
<td>YCoord</td>
<td>y-coordinate of the southwest corner of the cell</td>
<td>integer value</td>
</tr>
<tr>
<td>TravelLength</td>
<td>travel time index from the cell to the subbasin outlet</td>
<td>kilometers</td>
</tr>
<tr>
<td>Area</td>
<td>area of cell within the subbasin</td>
<td>square kilometers</td>
</tr>
</tbody>
</table>

The data for a subbasin begins with the keyword "Subbasin" followed by a colon and the subbasin identifier. One line beginning with the keyword "Grid Cell" follows for each cell in the subbasin. Data for the subbasin ends with the keyword "End". Keywords are not case sensitive and may contain spaces. Blank lines can be included and lines beginning with "#" are ignored as comments. The same grid-cell file can be referenced by more than one subbasin, allowing data for many subbasins to be stored in the same file. The identifier for a subbasin must be exactly the same in the grid-cell file as it is in the basin model.
APPENDIX B

Grids in HEC-DSS, HRAP, and SHG Grid Systems

Contents of a Grid Record in HEC-DSS

HEC-DSS records, including grid records, consist of a block of sequential data with an associated header array describing the data in the block. In a time-series record, the sequence represents the variation of a parameter’s value through time at a fixed location. In a grid record, the sequence represents the variation of a parameter’s value over a region of the earth’s surface for a single interval of time. The header array of a grid record contains information about the parameter values (their units and some summary statistics) and the two-dimensional array in which they are stored (the number of rows and columns in the array, and the location of the grid in geo-referenced coordinates).

The contents of the header are described below for three types of grids. All grid headers contain basic parameter and grid extent information. In addition, the headers for HRAP grids and Albers equal-area grids (including SHG grids) contain additional descriptive information.

Storage of Grid Values

In the DSS file, grid parameter values are stored in a single array, starting with the value in the minimum-x, minimum-y (or lower left) cell in the two-dimensional array. The values proceed by row in increasing column numbers and increasing row numbers, as illustrated in the Figure B-1.

![Figure B-1. One-Dimensional Array Storing Two-Dimensional Grid of Parameter Values.](image)
Grid Header Contents

The contents of the grid header array are as follows:

<table>
<thead>
<tr>
<th>Field</th>
<th>Type</th>
<th>Size (integers)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Info Flat Size</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Grid Type</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Grid Info Size</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Start Time</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>End Time</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Data Units</td>
<td>Text</td>
<td>3</td>
</tr>
<tr>
<td>Data Type</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Lower Left Cell X</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Lower Left Cell Y</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Number of Cells X</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Number of Cells Y</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Cell Size</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Compression Method</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Compressed Array Size</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Compression Scale Factor</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Compression Base</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Max Data Value</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Min Data Value</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Mean Data Value</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Number of Ranges</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Range Limit Table</td>
<td>Float</td>
<td>20</td>
</tr>
<tr>
<td>Range Counts</td>
<td>Integer</td>
<td>20</td>
</tr>
<tr>
<td>HRAP Headers append the following</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Data Source</td>
<td>Text</td>
<td>3</td>
</tr>
<tr>
<td>Albers Headers (including SHG) append the following</td>
<td></td>
<td></td>
</tr>
<tr>
<td>Projection Datum</td>
<td>Integer</td>
<td>1</td>
</tr>
<tr>
<td>Projection Units</td>
<td>Text</td>
<td>3</td>
</tr>
<tr>
<td>First Standard Parallel</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Second Standard Parallel</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Central Meridian</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Latitude of Origin</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>False Easting</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>False Northing</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>X Coordinate of Cell (0,0)</td>
<td>Float</td>
<td>1</td>
</tr>
<tr>
<td>Y Coordinate of Cell (0,0)</td>
<td>Float</td>
<td>1</td>
</tr>
</tbody>
</table>

HRAP Grid System

The Hydrologic Rainfall Analysis Project (HRAP) grid is a square-celled grid based on a Polar Stereographic map projection with the following parameters.

Units: Meters

Datum: Sphere (radius = 6371.2 km)
Standard Parallel: 60º 0' 0" North
Central Meridian: 105º 0' 0" West

The mesh (cell) size of the grid is 4.7625 km, and the grid Y axis is aligned parallel with the central meridian (105º W). The grid is registered so that the North Pole lies exactly 400 cells in the positive X direction and 1600 cells in the positive Y direction from the grid origin. Equivalently, the lower left corner of cell number (401, 1601) is located at the North Pole.

Examples

As examples of cell identification in the HRAP system, indices of cells containing points in the western U.S. and the eastern U.S. are given.

Western US:

The location 121º 45′ west, 38º 35′ north (near Davis, California) projects to 260,174 m easting, 2,143,782 m northing, in the specified polar stereographic projection. In the HRAP system the indices of the cell containing this point are

\[ i = 54 \]
\[ j = 450 \]

Eastern US:

The location 76º 30′ west, 42º 25′ north (near Ithaca, New York) projects to 4,410,804 m easting, 3,018,420 m northing, in the specified polar stereographic projection. In the HRAP system the indices of the cell containing this point are

\[ i = 926 \]
\[ j = 633 \]

SHG Grid System

The standard hydrologic grid (SHG) is a variable-resolution square-celled map grid defined for the conterminous United States. The coordinate system of the grid is based on the Albers equal-area conic map projection with the following parameters.

Units: Meters
Datum: North American Datum, 1983 (NAD83)
1st Standard Parallel: 29º 30′ 0” North
2nd Standard Parallel: 45º 30′ 0” North
Central Meridian: 96º 0’ 0” West
Latitude of Origin: 23º 0’ 0” North
False Easting: 0.0
False Northing: 0.0

Users of the grid can select a resolution suitable for the scale and scope of the study for which it is being used. For general-purpose hydrologic modeling with NEXRAD radar precipitation data, HEC recommends 2000m cells, and HEC computer programs that use the SHG for calculation will select this cell size as a default. HEC will also support the following grid resolutions: 10,000 m, 5,000 m, 1,000 m, 500 m, 200 m, 100 m, 50 m, 20 m, 10 m. The grids resulting from the different resolutions will be referred to as SHG-2km, SHG-1km, SHG-500m and so on. A grid identified as SHG with no cell-size indication will be assumed to have 2km cells.

For identification, each cell in the grid has a pair of integer indices (i, j) indicating the position, by cell count, of its southwest (or minimum-x, minimum-y) corner, relative to the grid’s origin at 96W, 23°N. For example, the southwest corner of cell (121, 346) in the SHG-2km grid is located at an easting of 242000 m and a northing of 692000 m. To find the indices of the cell in which a point is located, find the point’s easting and northing in the projected coordinate system defined above, and calculate the indices with the following formulas:

\[ i = \text{floor}(\text{easting} / \text{cell size}) \]
\[ j = \text{floor}(\text{northing} / \text{cell size}) \]

Where floor(x) is the largest integer less than or equal to x.

**Examples**

As examples of cell identification in the SHG system, indices of cells containing points in the western US and the eastern US will be given in the 1km, 2km, and 500 m SHG grids.

**Western US:**

The location 121° 45’ west, 38° 35’ north (near Davis, California) projects to 2185019 m easting, 2063359 m northing, in the specified Albers projection. In the SHG-2km system the indices of the cell containing this point are:

\[ i = \text{floor}(\, -2185019 / 2000 ) = \text{floor}(\, -1092.5 ) = -1093 \]
\[ j = \text{floor}(\, 2063359 / 2000 ) = \text{floor}(\, 1031.7 ) = 1031 \]

In the SHG-1km grid the indices are (-2186, 2063), and in SHG-500m they are (-4371, 4126).
Eastern US:

The location 76° 30' west, 42° 25' north (near Ithaca, New York) projects to 1583506 m easting, 2320477 m northing, in the specified Albers projection. In the SHG-2km system the indices of the cell containing this point are

\[ i = \text{floor} \left( \frac{1583509}{2000} \right) = \text{floor} \left( 791.8 \right) = 791 \]

\[ j = \text{floor} \left( \frac{2320477}{2000} \right) = \text{floor} \left( 1160.2 \right) = 1160 \]

In the SHG-1km grid the indices are (1583, 2320), and in SHG-500m they are (3167, 4640).