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Foreword 

The U.S. Army Corps of Engineers’ Statistical Software Package (HEC-
SSP) is software that allows you to perform statistical analyses of 
hydrologic data.   

The first official version of HEC-SSP (version 1.0) was released in 
August of 2008.   

The HEC-SSP software was designed by Mr. Gary Brunner, Mr. Jeff 
Harris, Dr. Beth Faber, and Mr. Matthew Fleming.  The HEC-SSP user 
interface was programmed by Mr. Mark Ackerman, and the 
computational code was programmed by Mr. Paul Ely.  This manual 
was written by Mr. Gary Brunner and Mr. Matthew Fleming.   
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Introduction 

Welcome to the U.S. Army Corps of Engineers Statistical Software 
Package (HEC-SSP) developed by the Hydrologic Engineering Center.  
This software allows you to perform statistical analyses of hydrologic 
data.  The current version of HEC-SSP can perform flood flow 
frequency analysis based on Bulletin 17B, “Guidelines for Determining 
Flood Flow Frequency” (1982), a generalized frequency analysis on not 
only flow data but other hydrologic data as well, and a volume-
duration frequency analysis on high and low flows.   

The HEC-SSP software system was developed as a part of the 
Hydrologic Engineering Center's "Next Generation" (NexGen) 
development of hydrologic engineering software.  The NexGen project 
encompasses several aspects of hydrologic engineering, including 
rainfall-runoff analysis, river hydraulics, reservoir system simulation, 
flood damage analysis, and real-time river forecasting for reservoir 
operations. 

This chapter discusses the general philosophy of HEC-SSP and gives a 
brief overview of the capabilities of the software system.  An overview 
of this manual is also provided. 

Contents 
• General Philosophy of the HEC-SSP 

• Overview of Program Capabilities 

• Overview of This Manual 
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General Philosophy of the HEC-SSP 

HEC-SSP is an integrated system of software, designed for interactive 
use in a multi-tasking environment.  The system is comprised of a 
graphical user interface (GUI), separate statistical analysis 
components, data storage and management capabilities, mapping, 
graphics, and reporting tools. 

Over a period of many years, the Hydrologic Engineering Center has 
supported a variety of statistical packages that perform frequency 
analysis and other statistical computations. Historically, the programs 
that received the most use within the Corps of Engineers were HEC-
FFA (Flood Frequency Analysis) and STATS (Statistical Analysis of Time 
Series Data).  FFA incorporates Bulletin 17B procedures that have 
been adopted by the Corps for flow frequency analysis.  The STATS 
software package is used for statistical analysis of time series data.  
STATS can provide either analytical or graphical frequency analysis, 
specified by the user.  STATS has the capability of computing monthly 
and annual maximum, minimum, and mean values along with 
computing a volume-duration analysis.  Two other packages that used 
to receive a lot of use within the Corps of Engineers are REGFRQ 
(Regional Frequency Computation) and MLRP (Multiple Linear 
Regression Program).  REGFRQ performs regional frequency analysis 
and MLRP is a multiple linear regression analysis tool. 

The goal of HEC-SSP is to ultimately combine all of the statistical 
analyses capabilities of HEC-FFA, STATS, REGFRQ and MLRP.  The 
current version of HEC-SSP supports performing flood flow frequency 
analyses based on Bulletin 17B Guidelines, generalized frequency 
analyses, and volume-duration frequency analyses.  New features and 
additional capabilities will be added in future releases.   

 

Overview of Program Capabilities 

HEC-SSP is designed to perform statistical analyses of hydrologic data.  
The following is a description of the major capabilities of HEC-SSP. 

User Interface 

The user interacts with HEC-SSP through a graphical user interface 
(GUI).  The main focus in the design of the interface was to make it 
easy to use the software, while still maintaining a high level of 
efficiency for the user.  The interface provides for the following 
functions: 
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• File management 

• Data entry, importing, and editing 

• Statistical analyses 

• Tabulation and graphical displays of results 

• Reporting facilities 

Statistical Analysis Components 

Flow Frequency Analysis (Bulletin 17B) – This component of the 
software allows the user to perform annual peak flow frequency 
analyses.  The software follows guidelines in Bulletin 17B, “Guidelines 
for Determining Flood Flow Frequency,” by the Interagency Advisory 
Committee on Water Data. 

Generalized Frequency Analysis – This component of the software 
allows the user to perform annual peak flow frequency analyses by 
various methods.  Additionally the user can perform frequency analysis 
of variables other than peak flows, such as stage and precipitation 
data. 

Volume-Duration Frequency Analysis – This component of the software 
allows the user to perform a volume-duration frequency analyses on 
daily flow data. 

Data Storage and Management 

Data storage is accomplished through the use of "text" files (ASCII and 
XML), as well as the HEC Data Storage System (HEC-DSS).  User input 
data are stored in flat files under separate categories of study, 
analyses, and a data storage list.  Gage data are stored in a project 
HEC-DSS file as time series data.  Output data is predominantly stored 
in HEC-DSS, while a summary of the results is written to an XML file.  
Additionally, an analysis report file is generated whenever a 
computation is made.  This report file is written to a standard ASCII 
text file. 

Data management is accomplished through the user interface.  The 
modeler is requested to enter a Name and Description for each study 
being developed.  Once the study name is entered, a directory with 
that name is created, as well as a study file.  Additionally a set of 
subdirectories is created with the following names: Bulletin17bResults, 
GeneralFrequencyResults, VolumeFrequencyAnalysisResults, Layouts, 
and Maps.  As the user creates new analyses, an analysis file is 
created in the main project directory.  The interface provides for 
renaming and deletion of files on a study-by-study basis. 
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Graphical and Tabular Output  

Graphics include a map window, plots of the raw data, and frequency 
curve plots.  The map window can be used to display background map 
layers.  Locations of the data being analyzed can be displayed on top 
of the map layers.  Once data are brought into HEC-SSP, they can be 
plotted for visual inspection.  The frequency curve plots shows the 
results of the analyses, which include the analytically computed curve, 
the expected probability curve, confidence limits, and the raw data 
points plotted based on the selected plotting position method.  Tabular 
output consists of tables showing the computed frequency curves, 
confidence limits, and summary statistics.  All graphical and tabular 
output can be displayed on the screen, sent directly to a printer (or 
plotter), or passed through the Windows Clipboard to other software, 
such as a word-processor or spreadsheet. 

A report file is available for each analysis.  This report file includes the 
input data, preliminary results, all of the statistical tests (Low and High 
Outliers, Broken Record, Zero Flows Years, Incomplete Record, 
Regional Skews, and Historic Information), and final results.  This 
report file is similar to the FFA output file. 

 Overview of This Manual 

This user's manual is the primary documentation on how to use HEC-
SSP.  The manual is organized as follows: 

• Chapters 1-2 provide an introduction and overview of HEC-SSP, as 
well as instructions on how to install the software. 

• Chapter 3 provides an overview on how to use the HEC-SSP 
software in a step-by-step procedure, including a sample problem 
that the user can follow.   

• Chapter 4 explains in detail how to enter and view data. 

• Chapter 5 provides a detailed discussion on how to perform the 
Bulletin 17B flow frequency analysis.  Additionally, this chapter 
describes all of the output capabilities available for displaying and 
printing the results. 

• Chapter 6 provides a detailed discussion on how to use the 
generalized frequency analysis editor. 

• Chapter 7 provides a detailed discussion on how to use the 
volume-duration frequency analysis editor. 

• Appendix A contains a list of references. 

• Appendix B has a series of example analyses that demonstrate the 
various capabilities of performing a Bulletin 17B flow frequency 
analysis, performing a general frequency analysis, and performing 
a volume-duration frequency analysis. 
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• Appendix C contains a detailed description or how to customize the 
graphical plots in HEC-SSP. 
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Installing HEC-SSP 

You install HEC-SSP using the program SETUP.EXE.  The Setup 
program installs the software and the example applications.  This 
chapter discusses the hardware and system requirements needed to 
use HEC-SSP, how to install the software, and how to uninstall the 
software. 

Contents 
• Hardware and Software Requirements 

• Installation Procedure 

• Uninstall Procedure 
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Hardware and Software Requirements 

Before you install the HEC-SSP software, make sure that your 
computer has at least the minimum required hardware and software.  
In order to get the maximum performance from the HEC-SSP 
software, recommended hardware and software is shown in 
parentheses.  This version of HEC-SSP will run on a microcomputer 
that has the following: 

• Intel Based PC or compatible machine with Pentium processor or 
higher (a Pentium 4 or higher is recommended).  

• A hard disk with at least 100 megabytes of free space  

• A CD-Rom drive (or CD-R, CD-RW, DVD), if installing from a CD. 

• A minimum of 512 megabytes of RAM (1 Gigabyte or more is 
recommended). 

• A mouse. 

• Color Video Display (Recommend running in 1152x864 or higher, 
and as large a monitor as possible).  Recommend at least a 17” 
monitor. 

• MS Windows NT 4.0, 2000, XP, or Vista (or later versions).  

Installation Procedure 

Installation of the HEC-SSP software is accomplished through the use 
of the Setup program.   

To install the software onto your hard disk do the following: 

1. Insert the HEC-SSP CD into your CD drive (or download the 
software from our web page: www.hec.usace.army.mil). 

2. The setup program should run automatically if installing from a CD.  
When downloading from the web page you will need to save the 
setup file in a temporary directory and then execute the “HEC-
SSP10_Setup.exe” file to run the setup program. 

3. If the setup program does automatically run from the CD, use the 
windows explorer to start the HEC-SSP10_Setup.exe program on 
the CD. 

4. Follow the setup instructions on the screen. 

The setup program automatically creates a program group called HEC.  
This program group will be listed under the Programs menu, which is 
under the Start menu.  The HEC-SSP program icon will be contained 
within the HEC program group, within the HEC-SSP subdirectory.  The 
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user can request that a shortcut icon for HEC-SSP be created on the 
desktop.  If installed in the default directory, the HEC-SSP executable 
can be found in the C:\Program Files\HEC\HEC-SSP\1.0 directory with 
the name "SSP.EXE".   

The HEC-SSP User’s Manual and example data sets are also installed 
with the software.  The User’s Manual can be viewed by selecting 
User’s Manual from the Help menu.  You must have Adobe Acrobat 
Reader to view the user’s manual.  This viewer can be obtained for 
free from the Adobe web page.   

A zip file containing the example data sets described in Appendix B 
have been installed in the “…\Examples” folder within the program 
directory. You can install the example data sets by selecting the 
Install Example Data option from the Help menu.  After selecting 
the Install Example Data menu option, a window will open for you to 
choose a location to install the example data sets.  The program will 
create a subdirectory within your chosen folder called SSP_Examples.  
A project file called “SSP_EXAMPLES.ssp” will be contained in the 
SSP_Examples folder.  You can load the test data sets by using the 
Open Study option from the File menu and then use the file chooser 
to select this file. 

Uninstall Procedure 

The HEC-SSP Setup program automatically registers the software with 
the Windows operating system.  To uninstall the software, do the 
following: 

• From the Start Menu select Control Panel. 

• Select Add/Remove Programs from within the Control Panel folder. 

• From the list of installed software, select the HEC-SSP program and 
press the Remove button. 

• Follow the uninstall directions on the screen and the software will 
be removed from your hard disk.   
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Working With HEC-SSP - An Overview 

HEC-SSP is an integrated package of statistical analysis modules, in 
which the user interacts with the system through the use of a 
Graphical User Interface (GUI).  The current version is capable of 
performing flow frequency analyses based on the Bulletin 17B 
“Guidelines for Determining Flood Flow Frequency,” dated March 1982, 
generalized frequency analyses, and volume-duration frequency 
analyses.  This chapter provides an overview of how a Bulletin 17B 
flow frequency analyses can be performed with the HEC-SSP software.  
General frequency and volume-duration frequency analyses can be 
developed in a similar manner as outlined for the Bulletin 17B analysis.    

In HEC-SSP terminology, a Study is a set of files associated with a 
particular set of data and statistical analyses being performed.  The 
files for a study are categorized as follows:  study information, data 
list, and analysis data. 

Contents 
• Starting HEC-SSP 

• Overview of the Software Layout 

• Steps in Performing a Bulletin 17B Frequency Analysis 
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Starting HEC-SSP 

When you run the HEC-SSP Setup program, a new program group 
called HEC and program icon called HEC-SSP are created.  They 
should appear in the start menu under the section called All 
Programs.  The user also has the option of creating a shortcut on the 
desktop.  If a shortcut is created, the icon for HEC-SSP will look like 
the following: 

 

HEC-SSP 1.0 

Figure 3-1.  The HEC-SSP Icon. 

To Start HEC-SSP from Windows: 
• Double-click on the HEC-SSP Icon.  If you do not have an HEC-SSP 

shortcut on the desktop, go to the Start menu and select All 
Programs  HEC  HEC-SSP  HEC-SSP 1.0. 

Overview of the Software Layout 

When you first start HEC-SSP, you will see the main window as shown 
in Figure 3-2, except you will not have any study data on your main 
window.  As shown in Figure 3-2, the main window is laid out with a 
Menu Bar, a Tool Bar, and four window panes.   

The upper right pane (which represents most of the window area) is 
the Desktop Area (Referred to as the “Desktop” from this point in the 
manual).  This area is used for displaying maps, data editors, and 
analysis windows.   

The upper left pane is called the Study Explorer.  The Study Explorer 
acts like an explorer tree into the study.  The top level of the tree is 
the study (Clarion River in this example).  Below the study is an 
analyses branch, a data branch, and a map branch.  Under the 
analyses branch, the first level is the types of analysis in the current 
study.  Under each analysis type will be the current user-defined 
analyses for that type.  The data branch lists all of the available data 
sets that have been brought into the current study.  Generally, a data 
set represents a piece of data at a specific gage location.  For 
example, all of the peak annual flows at a single gage would be stored 
as a single data set.  When an analysis is created, the user selects a 
data set to be used for that particular analysis.  The Map branch of the 
tree contains any maps the user has put together for the study.  By 
default there is automatically a “Base Map” listed under the maps 
folder.   
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The lower left pane, and associated tabs, also belongs to the study 
explorer.  This window is used to show additional information about 
items selected in the study explorer tree.  The tabs are used to switch 
to different views within the study explorer window.  The first tab, 
labeled Study, shows the explorer view of the study.  The second tab, 
labeled Maps, lists the available maps and map layers associated with 
each map.  The last tab, labeled Files, shows all of the files that make 
up the current study. 

Figure 3-2.  The HEC-SSP Main Window. 

 

The lower right pane is called the Message Window.  This window is 
used to display messages from the software as to what it is doing.   

 

 

 

 

 

Study Explorer 

Desktop Area 

Message Window 
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At the top of the HEC-SSP main window is a Menu bar with the 
following options: 

File:  This menu is used for file management.  Options available under 
the File menu include New Study, Open Study, Save Study, Save 

Study As, Close Study, Study Properties, 
Export, Recent Studies, and Exit.   The Study 
Properties option is used to describe the 
study and to set the units system.  The 
Export option is used to export HEC-SSP 
results, stored in the study DSS file, to 
another DSS file. The Recent Studies option 
lists the most recently opened studies, which 
allows the user to quickly open a study that 
was recently worked on. 

 

 

 

 

Edit:  This menu is used for applying the Cut, Copy, and Paste 
clipboard features to data in editable fields and tables.   

 

 

 

 

View:  The View menu allows the user to control display of the 
toolbars and the study windows.   
The user can also toggle between 
viewing all of the panes or just the 
Main View Pane.  The View menu 
also has options for saving the 
current layout (currently opened 
windows and their sizes and 
locations) and restoring a previous 
saved layout.  The final option on 
the View menu is to set the study 
display units.  This option allows 
the user to switch viewing output 
between English and metric units.   
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Maps:  This menu is used to set the Default Map Properties 
(Coordinate system, extents,  etc…), 
define a new map, add map layers 
to the study, and remove a map.  
Additionally, this menu has the 
following options available: Map 
Window Settings (allows the user to 
turn map layers on and off), Zoom 
To Entire Map Extents, Save Map 
Image, Import, and Export.  The 
Zoom To Entire Map Extents option 
displays the entire set of map layers 
within the map window.  The Save 
Map Image option can be used to 
save the current view of the map to 
a file.  The import and export 
options currently support importing 
and exporting a stream alignment to 

the map window.  Later versions of the software will have additional 
import and export options. 

 

Data:  This menu allows the user to define a new data set, open an 
existing data set with the data editor, and 
delete any existing data sets from the data 
list.  Other options include opening a plot and 
table of the data. 
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Analysis:  This menu is used to create the various statistical analyses 
available in the software.  Each statistical analysis is saved as a 
separate file containing the information that is pertinent to that 

specific analysis type.   The current options 
under this menu item include New, Open, 
Delete from Study, Save, Save As, 
Rename, and Compute Manager.  The 
compute manager allows the user to select 
one, several, or all of the analyses, and 
then have them all recomputed. 

 

 

 

 

Results:  This menu allows the user to graph and tabulate any of the 
existing analyses that have been computed.  Additionally, the user can 

request to view the report file from a 
computed analysis.   Users must select at 
least one analysis in the Study Tree before 
selecting either Graph, Table, or Report.  If 
more than one analysis of the same type are 
selected (this is accomplished by holding 
down the control key while clicking on the 
various analyses), the Graph option will plot 
the results from all analyses that are 

selected in the same plot.  However, when multiple analyses are 
selected, the Table and Report option bring up separate windows for 
each of the selected analyses.  The Default Plot Line Styles menu 
option lets the user change the default line styles applied to different 
data types that are plotted in a graph.  For example, the user can 
change the default line style for high outliers so that they are 
displayed as black triangular data points when a plot is opened.           

 

Tools:  This menu includes HEC-DSSVue, Options, Console Output, 
and Memory Monitor.  The Hec-DSSVue option brings up the Hec-

DSSVue program and automatically loads the 
current study DSS file.   Hec-DSSVue is a 
DSS utility to tabulate, graph, edit, and enter 
data into DSS.  The Options menu item 
brings up an options window that allows the 
user to set default HEC-SSP options.  
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Window:  This menu includes Tile, Cascade, Next Window, Previous 
Window, Window Selector, and Window.  All these options are used to 
control the appearance of the windows in the Desktop area.  When 

more than one window is open 
(such as a data editor, and 
various analysis windows), 
these menu items will help the 
user organize the windows, or 
quickly navigate to a specific 
window.   The Tile option can 
be used to organize all of the 
currently opened windows in 
either a vertical or horizontal 
tile.  The Cascade option puts 
one window on top of the next 

in a cascading fashion.  The Next Window option brings the next 
window in the list of currently opened windows to the top.  The 
Previous Window brings the last window that was on top back to the 
top.  The Window Selector option brings up a pick list of the currently 
opened windows and allows you to select the one you want.  The 
Window option has a sub menu list of all the opened windows and 
allows you to select one.  

 

Help:  This menu allows the user to open the HEC-SSP User’s Manual, 
install example data sets, read the terms and conditions of use 
statement, and display the current version information about HEC-
SSP.                                                    

 

 

Also on the HEC-SSP main window is a Tool Bar.  The buttons on the 
tool bar provides quick access to the most frequently used options 
under the HEC-SSP File and Edit menus.   
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Steps in Performing a Bulletin 17B Frequency Analysis 

There are five main steps in performing a Bulletin 17B flow frequency 
analysis with HEC-SSP.  Similar steps are required when performing a 
generalized frequency or volume-duration analysis.  

• Starting a new study 

• Adding a Background Map (Optional) 

• Importing, Entering, and Editing Data 

• Performing the Bulletin 17B Frequency Analysis 

• Viewing and Printing Results 

Starting a New Study 

The first step in performing a Flow Frequency analysis with HEC-SSP is 
to establish which directory you wish to work in and to enter a title for 
the new study.  To start a new study, go to the File menu and select 
New Study.  This will bring up a New Study window as shown below. 

 
Figure 3-3.  New Project Window. 

As shown in Figure 3-3, the user is required to enter a name for the 
study, select a directory to work in (a default location is provided), and 
select the desired units system.  Adding a description of the study is 
optional.  Once you have entered all the information, press the OK 
button to have the information accepted.  After the OK button is 
pressed, a subdirectory will be created under the user chosen 
directory.  The subdirectory will be labeled the same name as the 
user-entered study name.  This study directory is where the project 
file, as well as other study files and directories will be located.  
Additionally, a default map window will appear in the Main View Pane.  
However, the map window will be blank when it first opens.   
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Adding a Background Map  

By default, when you start a new project in HEC-SSP a default map 
window (called Base Map) will open in the Desktop window.  Having a 
background map is optional in HEC-SSP.  Not having a map does not 
prevent the user from importing and entering data, or performing an 
analysis and viewing results.  The map is mostly a visual aid of the 
study area.  Additionally, when you bring in gage data you can enter 
the map coordinates of the gage and it will show up on the map.  Once 
a gage is located on the map you can right click on it and get a pop-up 
menu for viewing the data, or graphing and tabulating the results. 

To add a map layer to the default map, go to the Maps menu and 
select Add Map Layers.  When this option is selected a file chooser 
window will appear, as shown in Figure 3-4, allowing the user to select 
map layers to bring into the map.  The Create Copy option on the 
window will make a copy of the selected map and place it in the Maps 
subdirectory of the study folder. 

Figure 3-4.  Add Map Layers File Chooser. 

Currently, the HEC-SSP software can load the following types of map 
layers: USGS DLG, AutoCAD DXF, shapefile, Raster Image, USGS DEM, 
Arc Info DEM, ASCII NetTIN, and Mr Sid.   

An example map is shown in Figure 3-5.  This map is an Arc Info DEM 
that was exported in the ASCII file format. 
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Figure 3-5.  Example Background Map. 

 

If more than one map layer is going to be used to make up a map, 
then it is up to the user to ensure that all map layers are in the same 
coordinate system.  HEC-SSP does not perform coordinate system 
projections.  Also, HEC-SSP can not always determine the coordinate 
system for all map layers entered.  However, under the Maps menu is 
an option called Default Map Properties.  This menu option can be 
used to set the default coordinate system for the map layers displayed 
in HEC-SSP.  The user should set the default coordinate system first 
and then bring in map layers to the study. 

Importing, Entering, and Editing Data  

Before any analyses can be performed, the user must bring data into 
the HEC-SSP study.  For a peak flow frequency analysis following 
guidelines in Bulletin 17B, the data must consists of peak annual flow 
data.  To bring data into HEC-SSP go to the Data menu and select 
New.  This will bring up the data editor as shown in Figure 3-6. 
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Figure 3-6.  HEC-SSP Data Editor. 

 

As shown in Figure 3-6, the Data Editor has fields for the Name, Short 
Identifier, and the Description of the data at the top of the window.  
Additionally it lists the study DSS file name that the data will be stored 
in once it is brought into the study.  The study DSS file is always 
labeled the same name as your study with the .DSS file extension. 

The Data Editor contains two tabs, Data Source and Details.  The 
Data Source tab is shown first.  This tab is used for selecting and 
defining a source for bringing data into the HEC-SSP study.  Currently, 
there are four ways to bring data into an HEC-SSP study: import from 
another HEC-DSS file, import data from the USGS web site, import 
from a Microsoft Excel spreadsheet, and manually entering the data 
into a table.  All of these methods will import data into the study DSS 
file. 

For this example, only importing data from the USGS website will be 
shown.  For a complete description of the data editor see Chapter 4, 
Using the Data Editor.  To import data from the USGS website, first 
select the USGS Website option from the list of four options available 
in the Location panel.  Next, select Annual Peak Data as the data 
type.  The next step is to press the button labeled Get USGS Station 
ID’s by State.  When this button is pressed a pop-up window will 
appear (Figure 3-7) allowing the user to select a state from which to 
get data. 
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Figure 3-7.  Window to Select a State for Downloading Data. 

Once a state is selected, press the OK button and a list of the available 
gages from that state will appear in a pick list as shown in Figure 3-8.  
Check the boxes for all of the gages you would like to import and then 
press the Import to Study DSS File button.  Once the import button 
is pressed, a process will begin in which the data will be downloaded 
from the USGS website and saved in the study DSS file.  HEC-SSP will 
automatically name the data when importing multiple gages at one 
time.  The USGS import process will download annual peak flow data, 
annual peak stage data, and the USGS data quality codes.  Therefore, 
for each gage location you request, multiple DSS records will be 
written to the study DSS file.  

Figure 3-8.  Example of Choosing Gages from a USGS State List to Import. 
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In addition to the data itself, any metadata that is available will be 
downloaded and stored with the data.  The metadata can be viewed 
from the Details Tab on the Data Editor.  An example of metadata on 
the Details tab is shown in Figure 3-9. 

Figure 3-9.  Example Metadata on the Details Tab. 

 

As shown in Figure 3-9, the metadata consists of the State, County, 
Stream, Location, Drainage Area, DA Units, Gage Operator, USGS 
Gage No., Gage Datum, HUC (Hydrologic Unit Code), Vertical Datum, 
and a description field.  Additionally, the coordinate location of the 
data is shown.  The coordinate location consists of Coordinate System, 
Coordinate ID, Horizontal Datum, Datum Units, Coordinate X Value, 
and Coordinate Y Value.  Most of the USGS data is retrieved with the 
Latitude/Longitude coordinate system as shown in the example. 

If the metadata does not download automatically, the user has the 
option to enter any of the information by hand.  Metadata is not 
generated automatically for any of the other three data sources.  
Therefore, entering the metadata is required if the user wants the data 
to be carried along with the study. 

After the data is imported into the study, the user can select any one 
of the gages from the drop down list located in the Name field at the 
top of the Data Editor.  The user has the option to change the name of 
the data, enter a short identifier, and put in a longer description of the 
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data.  Additionally, at the bottom of the data editor is a Plot and 
Tabulate button.  If you press the Plot button you will get a plot of the 
peak flow data for that gage.  If you press the Tabulate button you 
will get a table containing the data. 

Once you are satisfied with the data and metadata that have been 
imported, press the OK button to close the Data Editor and save the 
data.  The Apply button is used to accept the data for use in the 
computations, without closing the editor.  The Cancel button will close 
the editor and not apply anything that was done while in the data 
editor. 

 If the data has coordinate location information, it will then be plotted 
on top of the background maps.  The software will 
convert the coordinates of the point data to the 
default coordinate system of the base map. The 
user can interact with the plotted points.   by right 
clicking on the gage icon and a pop-up menu will 
appear as shown to the left.  The user has the 
option to edit the data, plot the data, tabulate it, 
rename the label, or delete the data. 

Performing the Bulletin 17B Flow Frequency Analysis 

To perform a Bulletin 17B flow frequency analysis, go to the Analysis 
menu and select New  Bulletin 17B Flow Frequency.  This will 
bring up a blank Bulletin 17B Analysis editor.  As shown in Figure 3-
10, the user must enter a name for the analysis, a description 
(optional), and select a flow data set (gage data stored in project DSS 
file).  The DSS File Name and Report File are automatically filled in by 
the program.  For now, the DSS File Name will be the study DSS file 
and the report file will have the same name as the analysis.  

The analysis window contains three tabs: General, Options, and 
Tabular Results. The General tab contains settings for Generalized 
Skew, Expected Probability Curve, Plotting Positions, Confidence limits, 
and a Time Window Modification.  Default settings are already 
established for each of the options on the General tab; however, the 
user can change the default settings.   

The Options tab contains information on Low Outlier Threshold, 
Historic Period Data, and User-Specified Frequency Ordinates.  These 
options are not required for most analyses but may be necessary 
depending upon the data. 

A detailed description of each of the Bulletin 17B settings and options 
can be found in Chapter 5, Performing a Bulletin 17B Flow Frequency 
Analysis.  Once all of the settings and options have been selected, the 
user presses the Compute button to have the computations 
performed.  When the computations have finished a message window 
will pop-up stating Compute Complete.  Press the OK button on the 
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message window to close the window.  Once the computations have 
finished the user can begin to look at output. 

 Figure 3-10.  Bulletin 17B Flow Frequency Analysis Editor. 

Viewing and Printing Results 

Tabular output can be found by selecting the Tabular Results tab.  
When this tab is pressed, a set of tables will appear as shown in Figure 
3-11.  The primary table on the Tabular Results tab consists of 
percent chance exceedance, computed flow frequency curve, the 
expected probability adjusted curve, and the 5 and 95 percent 
confidence limits.  The second table (bottom left) contains general 
statistics about the data, such as the mean, standard deviation, 
station skew, regional skew, weighted skew, and the adopted skew of 
the analysis.  The third table (bottom right) contains the number of 
historic events, high outliers, low outliers, zero or missing values, 
systematic events in the data set, and the number of years in the 
historic period.   The table can be sent to the printer by pressing the 
Print button at the bottom of the analysis window. 

 



Chapter 3  Working with HEC-SSP – An Overview 

3-16 

Figure 3-11.  Tabular Results of Bulletin 17B Editor. 

 

Graphical output can be obtained by pressing the Plot Curve button at 
the bottom of the analysis editor.  When this button is pressed, a plot 
will appear like the one in Figure 3-12.  This plot contains the 
computed frequency curve, the expected probability adjusted curve, 
the confidence limits, and the data points plotted by the user-selected 
plotting position method.  Additionally, a plot caption is listed at the 
top.  The plot caption is by default the user-defined name of the 
analysis.  The user can modify the plot properties by selecting the 
Edit Plot Properties menu option.  A plot properties window will 
open that lets the user change the line style for each data type, 
change the axis labels, modify the plot title, and edit other plot 
properties.  The user can also edit line styles by placing the mouse on 
top of the line or data point in the plot or legend and clicking the right 
mouse button.  Then select the Edit Properties menu option in the 
pop-up menu.  The plot can be printed or sent to the windows 
clipboard by using the Print and Copy to Clipboard options found 
under the File menu. 
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Figure 3-12.  Example Flow Frequency Curve Plot. 

 

The final piece of output available from a flow frequency analysis is a 
text report file.  The report file lists all of the input data and user 
settings, plotting positions of the data points, intermediate results, 
each of the various statistical tests performed (i.e. high and low 
outliers, historical data, etc…), and the final results.  This file is often 
useful for understanding how the software arrived at the final 
frequency curve.  Press the View Report button at the bottom of the 
analysis editor to view the report file.  When this button is pressed, a 
window will appear containing the text report as shown in Figure 3-13. 
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Figure 3-13.  Example Report File From Bulletin 17B Frequency Analysis. 
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C H A P T E R   4   

Using the HEC-SSP Data Editor 

The HEC-SSP Data Editor is used to import, enter, and view data and 
the corresponding metadata used in an HEC-SSP study.  The current 
version of HEC-SSP can be used to import annual peak data (flow and 
stage), daily data, hourly data, and real time data.  Future versions of 
HEC-SSP will allow for other data types as other analyses are made 
available in the software. 

Contents 
• Developing a New Data Set 

• Importing Data from an HEC-DSS File 

• Importing Data from the USGS Website 

• Importing Data from an Excel Spreadsheet 

• Entering Data Manually 

• Metadata 

• Plotting and Tabulating Data 
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Developing a New Data Set 

Before any analyses can be performed in HEC-SSP, the user must 
import or enter data into the study.  Importing, entering, and viewing 
data is accomplished in the Data Editor.  To open the data editor go 
to the Data menu and select New from the list of options.  This will 
bring up a data editor as shown in Figure 4-1. 

Figure 4-1.  HEC-SSP Data Editor. 

 

As shown in Figure 4-1, at the top of the editor, the user can enter a 
Name for the new data set.  The user does not have to enter a name 
when importing a data set from the USGS or an HEC-DSS file.  The 
program will automatically name the data.  The user can rename a 
data set by selecting the data set in the tree and clicking the right 
mouse button.  A pop-up menu should open with a Rename menu 
option.  The Data menu also contains a Rename menu option; 
however, the data set must be selected in the tree before this option is 
active.  Optionally, the user can also enter a short identifier (limited to 
16 characters) and a Description of the data set.  The study DSS file 
name is provided.  The DSS file is used for storing the data for the 
study.   

The Data Editor contains two main tabs, Data Source and Details.  
The Data Source tab is used for importing or entering data manually 
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while the Details tab is used to describe the data (i.e. metadata).  The 
Data Source tab contains four options for getting data into the study 
DSS file: Importing from an existing HEC-DSS file, importing from the 
USGS Website, importing from an Excel spreadsheet, and entering the 
data manually. 

Importing Data from an HEC-DSS File 

To import data from an HEC-DSS file into the HEC-SSP study DSS file, 
first select the HEC-DSS radio button on the data editor.  Selecting 
HEC-DSS will change the view of the Data Editor to look like Figure 4-
2. 

Figure 4-2.  Data Editor with HEC-DSS Import Option. 

 

As shown in Figure 4-2, the user first selects a DSS file to import from 
by typing the path and name or by choosing the file browser at the 
end of the input field.  Once a DSS file is selected, the table of 
pathnames will be filled with the records that are contained in that 
DSS file.  The user can reduce the number of listed pathnames by 
selecting pathname parts to filter in the pathname part selection area 
just above the table.  Any pathname part can be used to filter the list 
down to a more manageable number of pathnames to select from.  
The user can then select pathnames to import by double clicking on 
one or more of the listed pathnames in the table.  Each selected 



Chapter 4  Using the HEC-SSP Data Editor 

4-4 

pathname will show up in the list below the table.  Once the user has 
selected all of the pathnames that they want to import, pressing the 
Import to Study DSS File button enacts the import process.  An 
HEC-SSP data set will be developed for each pathname that was 
selected. 

Importing Data from the USGS Website 

The second way to import data into HEC-SSP is to use the USGS 
Website option.  When this option is selected, the data editor will look 
like Figure 4-3. 

Figure 4-3.  HEC-SSP Data Editor with USGS Website Import Option. 

 

The first step in using the USGS import option is to select a data type 
to import (e.g. Annual Peak Data).  Next the user should select the 
Get USGS Station ID’s by State button.  Selecting this button will 
bring up a small window that allows the user to select a state in which 
to acquire data, as shown in Figure 4-4. 
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Figure 4-4.  Window to Select a State for Importing USGS Data. 

Once the user selects a state and presses the OK button, a process 
will begin in which all of the gage locations for that state will be 
downloaded from the USGS website.  A listing of all the gages for that 
state will then show up in the table at the bottom of the data editor.  
An example of the data editor with a list of USGS gages is shown in 
Figure 4-5. 

Figure 4-5.  Data Editor with USGS Gages Listed in Table. 

 

The next step is to select the desired gages for importing into the HEC-
SSP study.  The user can filter the list to a smaller number of gages by 
using the filter drop down boxes at the top of the table.  To select a 
gage for importing, simply check the box in the left hand column for 
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each gage location that is to be imported.  After all of the desired 
locations are selected, press the Import to DSS File button to import 
the data into the study DSS file.  Pressing this button will start a 
process of downloading data from the USGS website.  For each 
selected location, the software will download whatever data is 
available.  Generally, when “Peak Annual Data” is selected, the 
software will download Peak Annual Flows, Peak Annual Stages, and 
Data Quality Codes for each location.  Therefore, multiple records will 
be written to the study HEC-DSS file for each gage location.  The data 
quality codes can be viewed from HEC-DSSVue, which is available 
from the tools menu.  For an explanation of the codes, please visit the 
USGS website. 

Warning: all data download from the USGS website should be 
reviewed to ensure it is appropriate before any analyses are performed 
on the data.  Some data stored on the USGS website are estimated 
not measured.  The user should check the data on the USGS website 
and be aware of the quality of all the data before using it.  HEC-SSP 
will import the annual peak flow and stage quality codes to the study 
HEC-DSS file (the program does not import quality codes for daily, 
instantaneous, and real time data).  The quality code records can be 
viewed using HEC-DSSVue and will have a pathname C-part of “CODE-
PEAK FLOW” or “CODE-PEAK STAGE”.  A description of the quality 
codes for annual peak flows is contained in Table 4-1 and a description 
of the quality codes for annual peak stages is contained in Table 4-2.  

 

Table 4-1.  Quality Codes for USGS Annual Peak Flow Data. 

Code Description 

1 Discharge is a Maximum Daily Average 
2 Discharge is an Estimate 
3 Discharge affected by Dam Failure 

4 Discharge less than indicated value which is Minimum 
Recordable Discharge at this site 

5 Discharge affected to unknown degree by Regulation or 
Diversion 

6 Discharge affected by Regulation or Diversion 
7 Discharge is an Historic Peak 
8 Discharge actually greater than indicated value 

9 Discharge due to Snowmelt, Hurricane, Ice-Jam or Debris 
Dam breakup 

A Year of occurrence is unknown or not exact 
B Month or Day of occurrence is unknown or not exact 

C All or part of the record affected by Urbanization, Mining, 
Agricultural changes, Channelization, or other 

D Base Discharge changed during this year 
E Only Annual Maximum Peak available for this year 
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Table 4-2.  Quality Codes for USGS Annual Peak Stage Data. 

Code Description 

1 Gage height affected by backwater 
2 Gage height not the maximum for the year 
3 Gage height at different site and(or) datum 
4 Gage height below minimum recordable elevation 
5 Gage height is an estimate 
6 Gage datum changed during this year 

 

Importing Data from an Excel Spreadsheet 

The third option for importing data into HEC-SSP is MS Excel.  When 
this option is selected, the data editor will change as shown in Figure 
4-6.  Currently, only annual peak flows can be imported when using 
this option.  Use the HEC-DSS or USGS options if you need to import 
data other than annual peak flows. 

Figure 4-6.  Data Editor with MS Excel Import Option Selected. 

 

The first step in importing data from an Excel spreadsheet is to select 
browse  at the end of the Excel File field.  Once an Excel file is 
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selected, a data view window will pop-up showing the data contained 
in the selected spreadsheet.  An example Excel Data viewer is shown 
in Figure 4-7. 

Figure 4-7.  Example Excel Data Viewer. 

 

The next step is to highlight the date and flow data values for each 
value to be imported into the study (only highlight the data, not the 
column headings).  The data must be in a format of Date in the first 
column and Peak Annual Flow in the second column.  The date must 
be in the Day, Month, Year format (ddmmyyyy) as shown in Figure 4-
7.  Next press the OK button and the data will be placed in the table at 
the bottom of the editor.  The last steps before importing the data is to 
specify the units of the data, and each of the pathname parts for 
storing the data in the study DSS file.  Enter units of cfs for data in 
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cubic feet per second or units of cms for data in cubic meters per 
second.  The final step is to press the Import to Study DSS File 
button, and the data will be imported. 

Entering Data Manually 

The last option for getting data into the study is to enter the data 
manually.  When the Manual option is selected, the window will 
change to what is shown in Figure 4-8.  Currently, only annual peak 
flows can be imported when using this option.  Use the HEC-DSS or 
USGS options if you need to import data other than annual peak flows. 

Figure 4-8.  Data Editor with Manual Data Entry Option Selected. 

 

To enter data manually, the user enters a name for the data set at the 
top, along with a short identifier and a description (optional).  A 
starting date and time must be entered.  The units of the data must 
also be defined; enter units of cfs for data in cubic feet per second or 
units of cms for data in cubic meters per second.  The last step before 
entering the data is to specify the pathname parts for how the data 
will be stored into the study DSS file.  This requires the user to enter a 
label for the A, B, and F part of the DSS pathname.  The C and E part 
are automatically set by the program.  Once all of the data labeling is 
completed, the data can be entered into the table at the bottom of the 
editor.  The user must enter the Date, Time, and data Value for each 
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peak flow value to be entered.  After a Date, Time, and Value are 
entered into a row, a new row will be generated in the table when the 
user leaves the Value field.  The date must be in the Day, Month, Year 
format (ddmmyyyy).  Once all of the data are entered into the table, 
the user presses the Import to Study DSS File button and the data 
will be stored in the study DSS file. 

Metadata 

When downloading data from the USGS website, in addition to the raw 
data, the software will also attempt to download any metadata 
available for each gage location.  The metadata will show up on the 
Details tab of the editor.  The user can view the metadata by 
selecting the Details tab, as shown in Figure 4-9. 

Figure 4-9.  Details Tab on the HEC-SSP Data Editor. 

 

As shown in Figure 4-9, the metadata consists of the State, County, 
Stream, Location, Drainage Area, DA Units, Gage Operator, USGS 
Gage No., Gage Datum, HUC (Hydrologic Unit Code), Vertical Datum, 
and a description field.  Additionally, the coordinate location of the 
data is shown.  The coordinate location consists of Coordinate System, 
Coordinate ID, Horizontal Datum, Datum Units, Coordinate X Value, 
and Coordinate Y Value.  Most of the USGS data is in the 
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Latitude/Longitude coordinate system as shown in the example.  If 
coordinate system data are entered, data icons and text labels will 
show up on the background map at the specified locations. 

If the metadata does not download automatically, the user has the 
option to enter any of the information by hand.  Metadata is not 
generated automatically for any of the other three data acquisition 
methods.  Therefore, entering the metadata is required if the user 
wants the data to be carried along with the study. 

Plotting and Tabulating the Data 

After the data is imported into the study, the user can select any one 
of the data sets in the study tree.  A pop-up menu will open when 
clicking the right mouse button while a data is selected.  The pop-up 
menu contains options to change the name, plot, and tabulate the 
data.  These options are also available from the Data menu; however, 
the data must be selected in the tree before these options are 
available.  If you select the Plot option, you will get a plot similar to 
the one shown in Figure 4-10. 
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Figure 4-10.  Plot of Peak Annual Flow Data Download from USGS Website. 

 

If you select the Tabulate option, a table will pop-up with the data 
listed as shown in Figure 4-11. 
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Figure 4-11.  Table Containing a Listing of Peak Annual Flow Data. 
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C H A P T E R   5   

Performing a Bulletin 17B Flow Frequency 
Analysis 

The current version of HEC-SSP allows the user to perform flow 
frequency analyses based on Bulletin 17B, Guidelines for Determining 
Flood Flow Frequency (March 1982).  This chapter discusses in detail 
how to perform a Bulletin 17B flow frequency analysis with HEC-SSP. 

Contents 
• Starting a New Analysis 

• General Settings, Options, and Computations 

• Viewing and Printing Results 
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Starting a New Analysis 

A flow frequency analysis can be started in two ways within the 
software, either by right clicking on the Bulletin 17B folder in the study 
explorer and selecting New, or by going to the Analysis menu and 
selecting New and then Bulletin 17B Flow Frequency.  When a new 
flow frequency analysis is selected, the Bulletin 17B Editor will appear 
as shown in Figure 5-1. 

Figure 5-1.  Bulletin 17B Flow Frequency Analysis Editor. 

 

The user is required to enter a Name for the analysis, while a 
Description is optional.  An annual peak flow data set must be 
selected from the available data sets stored in the current study DSS 
file (see chapter 4 for importing data into the study).  Once a Name is 
entered, and a flow data set is selected, the DSS File Name and 
Report File will automatically be populated.  The DSS filename is by 
default the study DSS file.  The report file is given the same name as 
the analysis with the extension “.rpt”.   
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General Settings, Options, and Computations 

Once the analysis name and flow data set are selected, the user can 
begin setting up the analysis.  Three tabs are contained on the Bulletin 
17B editor.  The tabs are labeled General, Options, and Results.   

General Settings 

The first tab contains general settings for performing the flow 
frequency analysis (Figure 5-1).  These settings include: 

• Generalized Skew 

• Expected Probability Curve 

• Plotting Positions 

• Confidence Limits 

• Time Window Modification 

 

Generalized Skew 

There are three options contained within the generalized skew setting: 
Use Station Skew, Use Weighted Skew, and Use Regional Skew.  The 

default skew setting is 
Use Station Skew.  
With this setting, the 
skew of the computed 
curve will be based 
solely on computing a 
skew from the data 
points contained in the 
data set.  No weighting 
will be performed to 
compute the final skew.   

 

The Use Weighted Skew option requires the user to enter a 
generalized regional skew and a Mean-Square Error (MSE) of the 
generalized regional skew.  This option weights the computed station 
skew with the generalized regional skew.  The equation for performing 
this weighting can be found in Bulletin 17B (equation 6).  If a regional 
skew is taken from Plate I of Bulletin 17B (the skew map of the United 
States), the value of MSE = 0.302.   

The last generalized skew option is Use Regional Skew.  When this 
option is selected, the user must enter a generalized regional skew 
and an MSE for that skew.  The program will ignore the computed 
station skew and use only the generalized regional skew. 
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Expected Probability Curve 

This setting has two options: compute the expected probability curve 
and do not compute the expected probability curve.  The default 

setting is to have the expected 
probability curve computed.  When 
computed, this curve will be shown 
in both the result tables and the 
plots as an additional curve to the 
computed curve.  The expected 
probability adjustment is an 

attempt to correct for a certain bias in the frequency curve 
computation due to the shortness of the record.  Please review the 
discussion in Bulletin 17B about the expected probability curve 
adjustment for an explanation of how and why it is computed.  The 
use of the expected probability curve is a policy decision.  It is most 
often used in establishing design flood criteria.  The basic flood 
frequency curve without the expected probability curve adjustment is 
the curve used in computation of confidence limits, risk, and in 
obtaining weighted averages of independent estimates of flood 
frequency discharge (WRC, 1982). 

Plotting Positions 

Plotting positions are used for plotting the raw data points on the 
graph.  There are four options for plotting position methodologies 

within HEC-SSP: Weibull, Median, Hazen, 
and user entered coefficients.  The default 
method is the Weibull plotting position 
formula.  The generalized plotting position 
equation is: 

)1(
)(

BAn
AmP
−−+

−
=  

 

Where: m = rank of flood values with the largest equal to 1. 

  n = number of flood peaks in the data set. 

A & B = constants dependent on which equation is used 
(Weibull A and B=0; Median A and B = 0.3; and 
Hazen A and B=0.5). 

Plotting positions are estimates of the exceedance probability of each 
data point.  Different methods can give very different values for the 
probabilities of the highest and lowest points in the data set.  In the 
Bulletin 17B methodology, the plotting of data on the graph by a 
plotting position method is only done as a guide to assist in evaluating 
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the computed curve.  The plotting position method selected does not 
have any impact on the computed curve. 

Confidence Limits 

Confidence limits provide a measure of the uncertainty in the 
computed discharge for a given 
exceedance probability.  The 
computation of confidence limits is 
outlined in Bulletin 17B appendix 
9.  By default, HEC-SSP calculates 
the 90 percent confidence interval 
(i.e. the 5% and 95% confidence 
limits).  The confidence limits 
must be entered in decimal form 
(i.e. 95% = 0.95, and 5% = 
0.05).  The user has the option to 

override the default values and enter whatever values they would like 
for the confidence limits. 

Time Window Modification 

This option allows the user to narrow the time window used for the 
analysis.  The default is to use all of the annual peak flow data 

contained in the 
selected data set.   
The user can enter 
either a start date 
for the analysis, 
and end date, or 
both a start and 
end date.  If a start 
and/or end date 

are used, they must be dates that are encompassed within the data 
stored in the selected data set.  The date range for the selected data 
set is shown in the editor just above the Start Date field. 
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Options 

In addition to the general settings, there are also several options 
available to the user for modifying the computations of the frequency 
curves.  These options include:  

• Low Outlier Threshold 

• Historic Period Data 

• User-Specified Frequency Ordinates 

 

When the Options tab is selected, the Bulletin 17B Editor will appear as 
shown in Figure 5-2. 

Figure 5-2.  Bulletin 17B Editor with Options Tab Selected. 
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Low Outlier Threshold 

High and low outlier tests are based on the procedures outlined in 
Bulletin 17B.  The calculated outlier magnitudes, by the Bulletin 17B 

procedures, are used as default 
values for the high and low 
outlier thresholds in HEC-SSP.  
The user has the option to 
enter a different value for the 
low outlier threshold.  If a 

value is entered for the low outlier threshold, then this value will 
override the computed value from Bulletin 17B procedure.  Further 
discussion of outlier thresholds can be found in Bulletin 17B and the 
HEC-SSP Statistical Reference Guide.  To use the low outlier threshold, 
simply check the box and enter the value. 

Historic Period Data 

Any historic data that provides reliable estimates of flood peaks 
outside the systematic record should be used in order to modify and 

improve the frequency 
computations.   Flood 
information outside of the 
systematic record can 
often be used to extend 
the record of the largest 
events to a historic period 
much longer than that of 
the systematic record.  
HEC-SSP uses historic data 
as recommended in 
Bulletin 17B.  To use 
historic data in HEC-SSP, 
check the box labeled Use 
Historic Data.  The user 
can enter a starting year 
for the historic period, 

ending year for a historic period, and a high threshold value.  If the 
user enters a high threshold value, then any value in the systematic 
record greater than that value will also be treated as a historical flood 
peak.   The user can also enter historic flood peaks that are not 
contained in the systematic record.  This is done in the table at the 
bottom labeled Historic Flood Peaks.  All years must be entered as 
water year values (October 1 through September 30).  If a start year 
is not entered, then the assumed start year is the earliest year of the 
systematic record and any historical values that have been entered.  If 
an end year is not entered, then the assumed end year is the latest 
year in the systematic record and any entered historic values.  Further 
discussion of the use of historical data can be found in Bulletin 17B 
and the HEC-SSP Statistical Reference Guide. 
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Note:  The program treats all data in the data set as systematic data.  
If historic events are included in the data set, then the user can define 
the analysis time window (General tab – Time Window Modification) so 
that it only bounds the systematic record.  Then define the historic 
events in the Historic Events table.  Instead of using the Time Window 
Modification option, another option is to enter a High Threshold value 
so that the historic data point(s) would be treated as historic data 
(rather than part of the systematic record).  Please see test example 6 
in Appendix B for an example of using the historic data adjustment.   

User Specified Frequency Ordinates 

This option allows the user to change the frequency ordinates used in 
computing the resulting frequency curves and confidence limits.  The 

default values listed in 
percent chance 
exceedance are 0.2, 0.5, 
1, 2, 5, 10, 20, 50, 80, 
90, 95, and 99.  Check the 
box next to Use Values 
from Table below to 
change or add additional 
values.  Once this box is 
checked, the user can 

add/remove rows and edit the frequency values.  To add or remove a 
row from the table, select the row(s), place the mouse over the 
highlighted row(s) and click the right mouse button.  The pop-up menu 
contains options to Insert Row(s) and Delete Row(s).  The 
program will use the default values, even if they are not contained in 
the table, when the Use Values from Table below option is not 
checked.  Finally, all values in the table must be between 0 and 100. 

Compute 

Once the new analysis has been defined, and the user has all of the 
settings and options the way they want them, performing the 

computations is simply a matter of pressing the 
Compute button at the bottom of the Bulletin 17B 

Editor.   

Once the compute button is pressed, the flow frequency computations 
are performed.  If the computations are successful, the user will 
receive a message that says Compute Complete.  At this point, the 
user can begin to review the results of the flow frequency analysis. 
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Viewing and Printing Results 

The user can view output from the flow frequency analysis directly 
from the Bulletin 17B Editor.  The output consists of tabular results, a 
frequency curve plot, and a report documenting the data and 
computations performed. 

Tabular Output 

Once the computations for the flow frequency analysis are completed, 
the user can view tabular output by opening the Tabular Results tab.  
When this tab is pressed, the results will be displayed as shown in 
Figure 5-3. 

Figure 5-3.  Bulletin 17B Editor with Tabular Results Tab Active. 
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Output on the results tab consists of three tables: Frequency Curves, 
System Statistics, and Number of Events.  The Frequency Curve 
output table contains the percent chance of exceedance ordinates, the 
computed Log Pearson III frequency curve, the expected probability 
adjusted frequency curve, the 5% chance of exceedance confidence 
limit, and the 95% chance of exceedance confidence limit.  The 
System Statistics table contains the mean of the data in log space, 
standard deviation in log space, station skew, user entered regional 
skew, weighted skew (weighted between station skew and regional 
skew), and the adopted skew for the analysis.  The Number of 
Events table tabulates the number of historic events, high outliers, 
low outliers, zero or missing values, systematic events, and the 
number of years in the historic period (this value only comes into play 
if the user entered historic data). 

The tabular results can be printed by using the Print button at the 
bottom of the Bulletin 17B Editor.  When the print button is pressed, a 
window will appear giving the user options for how they would like the 
table to be printed. 

Graphical Output 

Graphical output of the frequency curves can be obtained by pressing 
the Plot Curve button.  When the Plot Curve button is pressed, a 
frequency curve plot will appear in a separate window as shown in 
Figure 5-4.  The user can modify the plot properties by selecting the 
Edit Plot Properties menu option.  A plot properties window will 
open that lets the user change the line style for each data type, 
change the axis labels, modify the plot title, and edit other plot 
properties.  The user can also edit line styles by placing the mouse on 
top of the line or data point in the plot or legend and clicking the right 
mouse button.  Then select the Edit Properties menu option in the 
pop-up menu. 
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Figure 5-4.  Example Frequency Curve Plot. 

 

The frequency curve plot can be sent to the printer by selecting the 
Print option from the File menu at the top of the window.  Additional 
printing options available from the File menu are Page Setup, Print 
Preview, and Print Multiple (used for printing multiple graphs on the 
same page).  The graphic can also be sent to the Windows Clipboard 
by selecting Copy to Clipboard from the File menu.  Additionally, the 
plot can be saved to a file by selecting the Save As option from the 
File menu.   When the Save As option is selected, a pop-up window will 
appear allowing the user to select a directory, enter a filename, and 
select the format for saving the file.  Currently, four file formats are 
available for saving the graphic to disk, windows metafile, postscript, 
JPEG, and portable network graphic. 

The data contained within the plot can also be tabulated by selecting 
Tabulate from the File menu.  When this option is selected, a 
separate window will appear with the data tabulated.  Additional 
options are available from the File menu for saving the graphics 
options as a template (Save Template) and applying previously 
saved templates to the current graphic (Apply Template).   

The Edit menu on the graphic window contains several options for 
customizing the graphic.  These options include Plot Properties, 
Configure Plot Layout, Default Line Styles, and Default Plot Properties.  
Also, a pop-up menu will appear with further customizing options when 
the user right-clicks on a line on the graph or the legend. 
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The graphic customizing capabilities within HEC-SSP are very powerful, 
but are also somewhat complex to use.  The code used in developing 
the plots in HEC-SSP is the same code that was used for developing 
graphics in HEC-DSSVue and several other HEC software programs.  A 
separate write-up on Customizing Graphics can be found in Appendix C 
of this manual.  Please refer to that appendix for details on using the 
graphics customizing options. 

Viewing the Report File 

When the Bulletin 17B computations are performed, the computations 
module writes a report file of the statistical computations.  The report 
file lists all of the input data and user settings, plotting positions of the 
data points, intermediate results, each of the various statistical tests 
performed (i.e. high and low outliers, historical data, etc…), and the 
final results.  This file is often useful for understanding how the 
software arrived at the final frequency curve.   

Press the View Report button at the bottom of the Bulletin 17B 
Analysis window to view the report file.  When this button is pressed a 
window will appear containing the text report as shown in Figure 5-5. 
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Figure 5-5.  Example of the Bulletin 17B Report File. 
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C H A P T E R   6   

Performing a Generalized Frequency 
Analysis 

The current version of HEC-SSP allows the user to perform generalized 
frequency analyses of flow and stage data, as well as other data types.   
The user can choose between different analytical distributions as well 
as perform a graphical fit to the data.  This chapter discusses in detail 
how to use the Generalized Frequency analysis editor with HEC-SSP. 

Contents 
• Starting a New Analysis 

• General Settings and Options 

• Analytical Frequency Analysis 

• Graphical Frequency Analysis 

• Viewing and Printing Results 
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Starting a New Analysis 

A generalized frequency analysis can be started in two ways, either by 
right clicking on the Generalized Frequency Analysis folder in the study 
tree and selecting New, or by going to the Analysis menu and 
selecting New and then Generalized Frequency Analysis.  When a 
new generalized frequency analysis is selected, the Generalized 
Frequency editor will appear as shown in Figure 6-1. 

Figure 6-1.  Generalized Frequency Analysis Editor. 

 

The user is required to enter a Name for the analysis, while a 
Description is optional.  A data set (flow, stage, or other) must be 
selected from the available data sets stored in the current study DSS 
file (see chapter 4 for importing data into the study).  Once a Name is 
entered and a data set is selected, the DSS File Name and Report 
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File will automatically be filled out.  The DSS filename is by default the 
study DSS file.  The report file is given the same name as the analysis 
with the extension “.rpt”.   

General Settings and Options 

Once the analysis name and data set are selected, the user can begin 
to perform the computations.  Contained on the Generalized Frequency 
editor are four tabs.  The tabs are labeled General, Options, 
Analytical, and Graphical.  This section of the manual explains the 
use of the General and Options tabs.  

General Settings 

The first tab contains general settings for performing the frequency 
analysis (Figure 6-1).  These settings include: 

• Log Transforms 

• Plotting Positions 

• Confidence Limits 

• Time Window Modification 

Log Transform 

There are two options contained within the Log Transform setting: Use 
Log Transform and Do not use Log 
Transform.  If the user selects Use Log 
Transform then the logs of the data will 
be taken first.  The frequency analysis 
will be performed on the logs of the 
data.  If the user selects Do not use 
Log Transform, then the frequency 

analysis will be performed on the raw data values without taking the 
logs of the data.   The default setting is Use Log Transform.    
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Plotting Positions 

Plotting positions are used for plotting the raw data points on the 
graph.  There are four options for plotting position methodologies 

within HEC-SSP: Weibull, Median, Hazen, 
and user entered coefficients.  The default 
method is the Weibull plotting position 
formula.  The generalized plotting position 
equation is: 

)1(
)(

BAn
AmP
−−+

−
=  

 

Where: m = rank of flood values with the largest equal to 1. 

 n = number of flood peaks in the data set. 

A & B = constants dependent on which equation is used 
(Weibull A and B=0; Median A and B = 0.3; and 
Hazen A and B=0.5). 

Plotting positions are estimates of the exceedance probability of each 
data point.  Different methods can give very different values for the 
probabilities of the highest and lowest points in the data set.  In the 
Generalized Frequency methodology, the plotting of data on the graph 
by a plotting position method is only done as a guide to assist in 
evaluating the computed curve.  The plotting position method selected 
does not have any impact on the computed curve. 

Confidence Limits 

Confidence limits provide a measure of the uncertainty in the 
computed value for a given 
exceedance probability.  The 
computation of confidence limits is 
outlined in Bulletin 17B appendix 
9, and is applied in the same 
manner here in the generalized 
frequency analysis.  By default, 
HEC-SSP calculates the 90 percent 
confidence interval (i.e. the 5% 
and 95% confidence limits).  The 
confidence limits must be entered 

in decimal form (i.e. 95% = 0.95, and 5% = 0.05).  The user has the 
option to override the default values. 
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Time Window Modification 

This option allows the user to narrow the time window used for the 
analysis.  The 
default is to use all 
of the data 
contained in the 
selected data set.   
The user can enter 
either a start date 
and end date or 
both a start and 

end date.  If a start and/or end date are used, they must be dates that 
are encompassed within the data stored in the selected data set.  The 
date range for the selected data set is shown in the editor just above 
the Start Date field. 

Options 

In addition to the general settings, there are also several options 
available to the user for modifying the computations of the frequency 
curves.  These options include:  

• Low Outlier Threshold 

• Historic Period Data 

• User-Specified Frequency Ordinates 

• Output Labeling 

 

When the Options tab is selected, the Generalized Frequency editor 
will appear as shown in Figure 6-2. 
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Figure 6-2.  General Frequency Editor with Options Tab Selected. 

Low Outlier Threshold 

High and low outlier tests are based on the procedures outlined in 
Bulletin 17B, and are applied in the same manner in the Generalized 

Frequency Analysis.  The 
calculated outlier magnitudes, 
by the Bulletin 17B procedure, 
are used as default values for 
the high and low outlier 
thresholds in HEC-SSP.  The 

user has the option to enter a different value for the low outlier 
threshold.  If a value is entered for the low outlier threshold, then this 
value will override the computed value from the Bulletin 17B 
methodology.  Further discussion of outlier thresholds can be found in 
Bulletin 17B and the HEC-SSP Statistical Reference Guide.  To use the 
low outlier threshold, simply check the box and enter the value. 
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Historic Period Data 

Any historic data that provides reliable estimates outside the 
systematic record should be used in order to modify and improve the 
frequency computations.  Information outside of the systematic record 
can often be used to extend the record of the largest events to a 
historic period much longer than that of the systematic record.  HEC-
SSP uses historic data as recommended in Bulletin 17B. This 

calculation is applied in the 
same manner in the 
Generalized Frequency 
Analysis.    To use historic 
data, check the box 
labeled Use Historic 
Data.  The user can enter 
a starting year for the 
historic period, ending 
year for a historic period, 
and a High Threshold 
value.  If the user enters a 
high threshold value, then 
any data in the systematic 
record greater than that 
value will also be treated 
as a historical annual 

maximum.   The user can also enter historic data that are not 
contained in the systematic record.  This is done in the table at the 
bottom labeled Historic Events.  All years must be entered as water 
year values (October 1 through September 30).  If a start year is not 
entered, then the assumed start year is the earliest year of the 
systematic record and any historical values that have been entered.  If 
an end year is not entered, then the assumed end year is the latest 
year in the systematic record and any entered historic values.  Further 
discussion of the use of historical data can be found in Bulletin 17B 
and the HEC-SSP Statistical Reference Guide. 

Note:  The program treats all data in the data set as systematic data.  
If historic events are included in the data set, then the user can define 
the analysis time window (General tab – Time Window Modification) so 
that it only bounds the systematic record.  Then define the historic 
events in the Historic Events table.  Instead of using the Time Window 
Modification option, another option is to enter a High Threshold value 
so that the historic data point(s) would be treated as historic data 
(rather than part of the systematic record).  Please see test example 6 
in Appendix B for an example of using the historic data adjustment. 
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User Specified Frequency Ordinates 

This option allows the user to change the frequency ordinates used in 
computing the resulting frequency curves and confidence limits.  The 

default values listed in 
percent chance 
exceedance are 0.2, 0.5, 
1, 2, 5, 10, 20, 50, 80, 
90, 95, and 99.  Check the 
box next to Use Values 
from Table below to 
change or add additional 
values.  Once this box is 
checked, the user can 

add/remove rows and edit the frequency values.  To add or remove a 
row from the table, select the row(s), place the mouse over the 
highlighted row(s) and click the right mouse button.  The pop-up menu 
contains options to Insert Row(s) and Delete Row(s).  The 
program will use the default values, even if they are not contained in 
the table, when the Use Values from Table below option is not 
checked.  Finally, all values in the table must be between 0 and 100. 

Output Labeling 

This option allows the user to change the default labels for data 
contained in the output 
tables and plots.  The user 
can change both the name 
of the data as well as how 
the units of the data are 
labeled. 
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Analytical Frequency Analysis 

Once the new analysis has been defined and the user has all of the 
general settings and options the way they want them, the user can 
choose between performing an Analytical Frequency analysis or a 
Graphical Frequency analysis.  This section of the manual describes 
how to use the Analytical Frequency analysis option. 

When the user selects the Analytical tab on the Generalized 
Frequency Analysis editor, the window will appear as shown in Figure 
6-3.  As shown, three additional tabs will appear on the screen: 
Settings, Tabular Results, and Plot. 

 
Figure 6-3.  Analytical Analysis Tab of the Generalized Frequency Editor. 
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Settings 

The Settings tab contains additional settings for the analytical 
frequency analysis.  These settings include: 

• Distribution 

• Generalized Skew 

• Expected Probability Curve 

 

Distribution   

This option allows the user to select from available analytical 
distributions to perform the frequency analysis.  The current version of 
HEC-SSP contains five distribution choices: None, Normal, LogNormal, 

Pearson III, and LogPearson 
III.   If the user has selected 
to transform the data to log 
space (General tab), then the 
only available choices for 
distribution will be None, 
LogNormal, and LogPearson 
III.  If the user did not select 

the option to transform the data to log space (General tab), then the 
only available choices for distribution will be None, Normal and 
Pearson III. 

Generalized Skew   

There are three options contained within the generalized skew setting: 
Use Station Skew, Use Weighted Skew, and Use Regional Skew.  The 

default skew setting is 
Use Station Skew.  
With this setting, the 
skew of the computed 
curve will be based 
solely on computing a 
skew from the data 
points.   

The Use Weighted 
Skew option requires 
the user to enter a 

generalized regional skew and a Mean-Square Error (MSE) of the 
generalized regional skew.  This option weights the computed station 
skew with the generalized regional skew.  The equation for performing 
this weighting can be found in Bulletin 17B (equation 6).  If a regional 
skew is taken from Plate I of Bulletin 17B (the skew map of the United 
States), the value of MSE = 0.302.   
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The last generalized skew option is Use Regional Skew.  When this 
option is selected, the user must enter a generalized regional skew 
and an MSE for that skew.  The program will ignore the computed 
station skew and use only the generalized regional skew. 

Expected Probability Curve   

This setting has two options: Compute the expected probability curve 
and do not compute the expected probability curve.  The default 
setting is to have the expected probability curve computed.  When 
computed, this curve will be shown in both the tables and the plots as 

an additional curve to the 
computed curve.  The 
expected probability 
adjustment is an attempt to 
correct for a certain bias in the 
frequency curve computation 
due to the shortness of the 

record.  Please review the discussion in Bulletin 17B about the 
expected probability curve adjustment for an explanation of how and 
why it is computed.  The use of the expected probability curve is a 
policy decision.  It is most often used in establishing design flood 
criteria.  The basic flood frequency curve without the expected 
probability curve adjustment is the curve used in computation of 
confidence limits, risk, and in obtaining weighted averages of 
independent estimates of flood frequency discharge (WRC, 1982). 

Compute 

Once the new analysis has been defined, and the user has all of the 
General, Options, and Settings information selected the way they 

want, performing the computations is simply a matter 
of pressing the Compute button at the bottom of the 

Generalized Frequency editor. 

Once the compute button is pressed, the frequency computations are 
performed.  If the computations are successful, the user will receive a 
message that says “Compute Complete”.  At this point, the user can 
begin to review the results of the Analytical Frequency computations. 

Tabular Results 

The Tabular Results tab will bring up a table of results for the 
Analytical Frequency analysis.  An example of the results tab is shown 
in Figure 6-4. 
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Figure 6-4.  Tabular Results Tab for Analytical Analysis. 

 

As shown in Figure 6-4, the window contains three tables.  The top 
table contains results of the computed frequency curve.  The very left 
column of the top table is the Percent Chance Exceedance for all the 
computed values.  The next three columns in the top table contain the 
computed frequency curve and the 95% and 5% confidence limits that 
correspond to that computed curve.  The last three columns of the top 
table contain a computed frequency curve and confidence limits for an 
analysis based on user-adjusted statistics for the mean, standard 
deviation, adopted skew, and equivalent years of record.  User entered 
adjusted statistics are an option that the user can set on the Plot tab, 
which is discussed in detail in the next section of this manual.  If the 
user has not entered adjusted statistics, then these columns will be 
empty. 



 Chapter 6  Performing a Generalized Frequency Analysis 

 6-13 

Two additional tables are shown at the bottom of the window: System 
Statistics and Number of Events.  The System Statistics table 
consists of the mean, standard deviation, station skew, user entered 
regional skew, weighted skew (weighted between station skew and 
regional skew), and the adopted skew for the analysis.  The Number 
of Events table contains the number of historic events, high outliers, 
low outliers, zero or missing values, systematic events, and the 
number of years in the historic period (this value only comes into play 
if the user entered historic data). 

Additionally, the lower right portion of the table will show if Log 
Transform is On or Off, and which analytical distribution was selected 
for the analysis. 

Plot 

In addition to tabular results, a Plot tab is available for viewing a 
graphical plot of both the computed frequency curve, as well as a 
computed curve based on any user-adjusted statistics.  When the Plot 
tab is selected the window will change to what is shown in Figure 6-5. 

  
Figure 6-5.  Plot Tab of the Generalized Frequency Analytical Analysis. 
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As shown in Figure 6-5, the plot contains the computed frequency 
curve, 95 and 5% confidence limits, and raw data points plotted by the 
user selected plotting position method.  The computed statistics for the 
frequency curve are shown in a table on the right side of the window.  
Below the computed statistics is a table labeled “User Statistics”.  
There is a check box and a data entry field for the Mean, Standard 
Deviation, Adopted Skew, and Equivalent Years of Record.  The user 
can enter values into any or all of these fields.  Turning on the check 
box then enacts that field to be used in computing a curve with the 
user entered statistic overriding the computed value from the raw 
data.  The user statistics option allows the user to see how the curve 
would change if any or all of the statistics were different.  When data 
is entered into the user statistics fields, and the check boxes are 
turned on, the user must press the compute button again in order for 
the computations to be performed with the user entered statistics.  
After the compute button is pressed, both the plot and the table on the 
Tabular Results tab will be updated to reflect any user entered 
statistics. 

Graphical Frequency Analysis 

In addition to an analytical frequency analysis which uses a statistical 
distribution fit to the data, the user has the option to graphically fit a 
curve to the data.  A graphical fit can be very useful when the 
available analytical distributions do not provide a good fit to the data.  
One example of when a graphical frequency analysis is most 
appropriate is when plotting a frequency curve for flow data that is 
downstream of a flood control reservoir.  Analytical frequency 
distributions are often not appropriate for fitting flow data that is 
significantly regulated by upstream reservoirs.  In general, a portion of 
the flow frequency data for a highly regulated stream will be very flat 
in the zone in which upstream regulation can control the flows for a 
range of frequencies.  This type of data lends itself to a graphical fit 
analysis over the use of an analytical equation.  Another example of 
using a graphical fitting technique over an analytical curve is when 
trying to compute a frequency curve to annual peak stage data at a 
point on a river.  Often the stages will flatten out with decreased 
frequencies when flows go out into the overbank and floodplain area.  
Again, this type of data is fitted much better using a graphical fit curve 
instead of an analytical distribution. 

When the Graphical tab is selected, the editor will display a plot and 
table as shown in Figure 6-6.  In the plot, the data will be plotted 
using the user selected plotting position method.  The table to the 
right of the plot allows the user to enter data values for the frequency 
ordinates defined on the Options tab.  When the user enters values in 
this table, those values will be plotted as a line on the plot after the 
Compute button is pressed.  The idea is to enter values in the table 
that will create a best fit line of the data, based on the user’s 
judgment. 
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Figure 6-6.  Graphical Analysis Tab of the Generalized Frequency Editor.  

Viewing and Printing Results 

The user can view output for the frequency analysis directly from the 
Generalized Frequency editor (Tabular and Graphical output) or by 
using the plot and view buttons at the bottom of the editor.  The 
output consists of tabular results, an analytical frequency curve plot, a 
graphical frequency curve plot, and a report documenting the data and 
computations performed. 

Tabular Output 

Once the computations for the analytical frequency analysis are 
completed, the user can view tabular output by selecting the Tabular 
Results tab under the Analytical analysis tab.  The details of this 
table were discussed under the analytical analysis option above. 
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The tabular results can be printed by using the Print button at the 
bottom of the Generalized Frequency editor.  When the print button is 
pressed, a window will appear giving the user options for how they 
would like the table to be printed. 

Graphical Output 

Graphical output of the analytical frequency curve can be obtained by 
selecting either the Plot tab under the analytical analysis tab, or by 
pressing the button labeled Plot Analytical Curve at the bottom of 
the general frequency editor.  When the Plot Analytical Curve button is 
pressed, a frequency curve plot will appear in a separate window as 
shown in Figure 6-7. 

Figure 6-7.  Analytical Analysis Frequency Curve Plot. 

 

The analytical frequency curve plot can be sent to the printer by 
selecting the Print option from the File menu at the top of the 
window.  Additional printing options available from the File menu are 
Page Setup, Print Preview, and Print Multiple (used for printing 
multiple graphs on the same page).  The graphic can also be sent to 
the Windows Clipboard by selecting Copy to Clipboard from the File 
menu.  Additionally, the plot can be saved to a file by selecting the 
Save As option from the File menu.   When the Save As option is 
selected, a pop-up window will appear allowing the user to select a 
directory, enter a filename, and select the format for saving the file.  
Currently four file formats are available for saving the graphic to disk: 
windows metafile, postscript, JPEG, and portable network graphic. 
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The data contained within the plot can also be tabulated by selecting 
Tabulate from the File menu.  When this option is selected, a 
separate window will appear with the data tabulated.  Additional 
options are available from the File menu for saving the plot options as 
a template (Save Template) and applying previously saved templates 
to the current plot (Apply Template).   

The Edit menu contains several options for customizing the graphic.  
These options include Plot Properties, Configure Plot Layout, Default 
Line Styles, and Default Plot Properties.  Also, a pop-up menu will 
appear with further customizing options when the user right-clicks on 
a line on the graph or the legend.  The graphic customizing capabilities 
within HEC-SSP are very powerful, but are also somewhat complex to 
use.  The code used in developing the plots in HEC-SSP is the same 
code that was used for developing graphics in HEC-DSSVue and 
several other HEC software programs.  A separate write-up on 
Customizing Graphics can be found in Appendix C of this manual.  
Please refer to that appendix for details on using the graphics 
customizing options. 

A plot of the graphical frequency curve can be obtained by pressing 
either the Graphical tab, or by pressing the button labeled Plot 
Graphical Curve at the bottom of the general frequency editor.  
When the Plot Graphical Curve button is pressed, a frequency curve 
plot will appear in a separate window as shown in Figure 6-8.  All of 
the same options for tabulating, printing, and sending results to the 
windows clipboard are available for this plot as they are for the 
analytical frequency curve plot. 
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Figure 6-8. Graphical Analysis Frequency Curve Plot. 

Viewing the Report File 

When the General Frequency analysis computations are performed, 
the computations module writes a report file.  The report file lists all of 
the input data and user settings, plotting positions of the data points, 
intermediate results, each of the various statistical tests performed 
(i.e. high and low outliers, historical data, etc…), and the final results.  
This file is often useful for understanding how the software arrived at 
the final frequency curve.   

To view the report file press the View Report button at the bottom of 
the General Frequency analysis window.  When this button is pressed, 
a window will appear containing the text report as shown in Figure 6-
9. 
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Figure 6-9.  General Frequency Analysis Report File 
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C H A P T E R   7   

Performing a Volume-Duration Frequency 
Analysis 

The current version of HEC-SSP allows the user to perform a volume-
duration frequency analysis of flow data.  The user can choose 
between different analytical distributions as well as perform a 
graphical fit to the data.  This chapter discusses in detail how to use 
the volume-duration frequency analysis editor with HEC-SSP. 

Contents 
• Starting a New Volume-Duration Frequency Analysis 

• General Settings and Options 

• Extracting the Volume-Duration Frequency Data 

• Analytical Frequency Analysis 

• Graphical Frequency Analysis 

• Viewing and Printing Results 
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Starting a New Volume-Duration Frequency Analysis 

A volume-duration frequency analysis can be started in two ways 
within the software, either by right clicking on the Volume-Frequency 
Analysis folder in the study explorer and selecting New, or by going to 
the Analysis menu and selecting New and then Volume-Frequency 
Analysis.  When a new volume-frequency analysis is selected, the 
Volume-Duration Frequency editor will appear as shown in Figure 7-1. 

  Figure 7-1.  Volume-Duration Frequency Analysis Editor. 

 

The user is required to enter a Name for the analysis; while a 
Description is optional.  A data set (daily average flow) must be 
selected from the available data sets stored in the current study DSS 
file (see chapter 4 for importing daily flow data into the study).  Once 
a Name is entered and a data set is selected, the DSS File Name and 
Report File will automatically be filled out.  The DSS filename is by 
default the same name as the study DSS file.  The report file is given 
the same name as the analysis with the extension “.rpt”.  
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General Settings and Options 

Once the analysis name and data set are selected, the user can begin 
defining the analysis.  Five tabs are contained on the Volume-Duration 
Frequency editor.  The tabs are labeled General, Options, Duration 
Table, Analytical, and Graphical.  This section of the manual 
explains the use of the General and Options tabs.  

General Settings 

The first tab contains general settings for performing the frequency 
analysis (Figure 7-1).  These settings include: 

• Log Transforms 

• Plotting Positions 

• Maximum or Minimum Analysis 

• Year Specification 

• Time Window Modification 

 

Log Transform 

There are two options contained within the Log Transform setting: Use 
Log Transform and Do not use Log 
Transform.  If the user selects Use Log 
Transform, then the logs of the data 
will be computed first, and the frequency 
analysis will be performed on the logs of 
the data.  If the user selects Do not use 
Log Transform, then the frequency 

analysis will be performed on the raw data values without taking the 
logs of the data.  The default setting is Use Log Transform.    
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Plotting Positions 

Plotting positions are used for plotting the raw data points on the 
graph.  There are four options for plotting position within HEC-SSP: 

Weibull, Median, Hazen, 
and user entered 
coefficients.  The default 
method is the Weibull 
plotting position method.   

 

 

 

 

 

 

 

 

The generalized plotting position equation is: 

)1(
)(

BAn
AmP
−−+

−
=  

Where: m = rank of flood values with the largest equal to 1. 

  n = number of flood peaks in the data set. 

A & B = constants dependent on which equation is used 
(Weibull A and B=0; Median A and B = 0.3; and 
Hazen A and B=0.5). 

Plotting positions are estimates of the exceedance probability for each 
data point.  Different methods can give different values for the 
probabilities of the highest and lowest points in the data set.  The 
plotting of data on the graph by a plotting position method is only 
done as a guide to assist in evaluating the computed curve.  The 
plotting position method selected does not have any impact on the 
computed curve. 
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Maximum or Minimum Analysis 

A volume-frequency analysis can be performed using annual maximum 
or minimum flows.  A maximum flow analysis could be used for 
determining the amount of reservoir storage required for a flood of 
specific frequency.  A minimum flow, or low flow analysis, could be 
used determine if a river could supply a given demand.  A low flow 
analysis could also be beneficial for water quality and reservoir storage 

projects. There 
are two options 
contained in the 
Maximum or 
Minimum Analysis 
section.   If 
Analyze 
Maximums is 

selected, then the program will extract annual maximum volumes for 
all durations.  The program will extract annual minimum volumes for 
all durations if Analyze Minimums is selected.  

Year Specification 

This option allows the user to define the beginning and ending date for 
what will be considered as the analysis year for extracting the data.  
These dates are used for extracting the annual maximum or minimum 
flows, in order to get one value for each analysis year.  It is important 
to choose a start date that captures all flood events from a certain 

hydrologic regime.  If high 
flows generally occur 
between November and 
May, then the year should 
not start between theses 
months.   This will minimize 
the possibility that the same 
flood event is used for the 
consecutive years.  There 
are three options contained 
in the Year Specification 
section.   If Water Year is 

selected, the program uses a starting date of October 1 and an ending 
date of September 30.  If Calendar Year is selected, the program 
uses a starting date of January 1 and an ending date of December 31.  
The Other option lets the user define the starting date.  One way to 
determine when the year should begin is to plot each year of record on 
top of one another, as shown in Figure 7-2.  This data set is from an 
area that experiences both snowmelt floods and summer/fall rain 
floods.  Starting the year on January 1 would be more appropriate for 
this data set because a few large flood events occurred around 
October 1.                
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Figure 7-2.  Plot Showing when Flood Events Typically Occur. 

Time Window Modification 

This option allows the user to narrow the time window used for the 
analysis.  When left unchecked, the program will use all of the data 
contained in the selected data set.  The user can enter either a start or 
end date or both a start and end date.  If a start and/or end date are 
used, they must be dates that are included within the selected data 
set.  The date range for the selected data set is shown in the editor 

just above the Start 
Date field.    

An additional option at 
the bottom of the time 
window modification 
section allows the user 
to define a shorter 
duration, a Season, 
within the year in 
which the program 
extracts maximum or 
minimum flows.  This 
option allows the user 
to analyze floods that 
typically occur during a 
specific season, like 
snowmelt floods.  
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When left unchecked, the program will examine all flow records during 
the year.  The season start and end dates must be entered using a two 
digit day followed by the month, example 15May.  The season start 
and end dates must fall within a year as defined in the Year 
Specification.  The user must enter both start and end dates to define 
the season subset. 

Options 

In addition to the general settings, there are also several options 
available to the user for modifying the computation of the volume-
frequency curves.  These options include:  

• Flow-durations 

• User-Specified Frequency Ordinates 

• Output Labeling 

 

When the Options tab is selected, the Volume-Duration Frequency 
editor will appear as shown in Figure 7-3. 

Figure 7-3.  Volume-Duration Frequency Editor with Options Tab Selected. 

 

 

 

 

 



Chapter 7  Performing a Volume-Duration Frequency Analysis 

7-8 

Flow-Durations 

This option lets the user define which durations are used in the 
volume-frequency analysis.  The program will extract annual maximum 

or minimum volumes based on 
the durations defined in this 
table.  The default durations are 
1, 3, 7, 15, 30, 60, 120, and 
183 days.  Check the box next 
to Change or add to default 
values to change or add 
additional durations to the 
analysis.  Once this box is 
checked, the user can 
add/remove rows and edit the 
duration values.  To add or 
remove a row from the table, 
select the row(s), place the 
mouse over the highlighted 
row(s) and click the right 

mouse button.  The pop-up menu contains options to Insert Row(s) 
and Delete Row(s).  The program will use the default durations, even 
if they are not contained in the table, when the Change or add to 
default values option is not checked.   

User Specified Frequency Ordinates 

 This option allows the user to 
change the frequency ordinates 
used for creating result tables and 
graphs.  The default values listed 
in percent chance exceedance are 
0.2, 0.5, 1, 2, 5, 10, 20, 50, 80, 
90, 95, and 99.  Check the box 
next to Use Values from Table 
below to change or add 
additional values.  Once this box 
is checked, the user can 
add/remove rows and edit the 
frequency values.  To add or 
remove a row from the table, 
select the row(s), place the 
mouse over the highlighted 
row(s) and click the right mouse 
button.  The pop-up menu 

contains options to Insert Row(s) and Delete Row(s).  The 
program will use the default values, even if they are not contained in 
the table, when the Use Values from Table below option is not 
checked.  Finally, all values in the table must be between 0 and 100. 
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Output Labeling 

This option allows the user to change the default labels for data 
contained in the output tables and plots.  The user can change both 
the name of the data and how the units of the data are labeled.   

  

 

 

 

 

 

 

Duration Table 
The user can extract the volume-duration data once settings have 
been defined on the General and Options tabs.  When the Duration 
Table tab is selected, the Volume-Duration Frequency editor will 
appear as shown in Figure 7-4.  The program will compute the annual 
maximum or minimum average flows for the durations specified on the 
Options tab when the user presses the Extract Volume-Duration 
Data button at the bottom of the Duration Table.   

The program computes the maximum/minimum flows by evaluating 
the flow record one year at a time.  For each duration, the program 
computes an annual time-series of average flow.  The program begins 
computing the average flow values at a specific number of days after 
the beginning of the year.  The number of days is determined by the 
duration.  For example, for a 15-day duration, the program begins 
computing the 15-day average flow 15 days after the beginning of the 
year.  If water year is chosen, then the program begins computing the 
average 15-day flow on October 15.  The 15-day flow on October 15 is 
an average of flow from October 1 through October 15.  This approach 
is an attempt to prevent a scenario in which the same flow event 
causes maximum/minimum flows in consecutive years; however, it is 
possible to miss a maximum/minimum value using this approach.  The 
maximum 15-day flow could occur on October 10.  If the water year 
begins on October 1, then the program will not use this value.  This is 
why it is important to choose an appropriate annual starting date.  
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Figure 7-4.  Volume-Duration Table. 

 

The user must Compute the analysis before viewing a plot of the 
volume-duration data.  The plot created by pressing the Plot 
Duration Data button, located at the bottom of a Volume-Duration 
Frequency editor, shows the annual maximum/minimum volumes 
plotted using the user specified plotting position method, as shown in 
Figure 7-5.   
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Figure 7-5.  Plot of Volume-Duration Data.   

Analytical Frequency Analysis 

The user can choose between performing an Analytical Frequency 
Analysis or a Graphical Frequency Analysis once settings have been 
defined on the General and Options tabs.  The Duration Data does not 
have to be extracted before computing an analysis.  The program will 
automatically extract the duration data when the Compute button is 
pressed.  This section of the manual describes how to compute and 
view results for an Analytical Frequency Analysis. 

When the user selects the Analytical tab on the Volume-Duration 
Frequency editor, the window will appear as shown in Figure 7-6.  As 
shown, four additional tabs will appear on the screen: Settings, 
Tabular Results, Plot, and Statistics. 
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Figure 7-6.  Analytical Tab of the Volume-Duration Frequency Editor. 

Settings 

In addition to settings on the General and Options tabs, there are 
more options on the Settings tab the user must define in order to 
perform an Analytical Frequency analysis on the volume-duration data.  
These settings include: 

• Distribution 

• Expected Probability Curve 

• Skew 

 

Distribution   

This option allows the user to select a distribution to perform the 
frequency analysis.  The current version of HEC-SSP contains five 

distribution choices: None, Normal, LogNormal, 
Pearson III, and LogPearson III.  If the user has 
selected the Use Log Transform option, 
located on the General tab, then the available 
choices for distribution are None, LogNormal, 
and LogPearson III.  If the user has selected 
the Do not use Log Transform option, located 
on the General tab, then the distribution 

choices are None, Normal, and Pearson III. 
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Expected Probability Curve   

This setting has two options, Compute Expected Prob. Curve and 
Do Not Compute Expected Prob. Curve.  The default setting is to 

have the expected probability 
curve computed.   When 
computed, this curve will be 
shown in both the result table 
and the plot as an additional 
curve to the computed curve.  
The expected probability 

adjustment is an attempt to correct for a certain bias in the frequency 
curve computation due to the shortness of the record.  Please review 
the discussion in Bulletin 17B about the expected probability curve 
adjustment for an explanation of how and why it is computed.  The 
use of the expected probability curve is a policy decision.  It is most 
often used in establishing design flood criteria.  The basic flood 
frequency curve without the expected probability curve adjustment is 
the curve used in computation of confidence limits, risk, and in 
obtaining weighted averages of independent estimates of flood 
frequency discharge (WRC, 1982). 

Skew   

The skew option is only available whenever the analytical distribution 
is set to PearsonIII or LogPearsonIII.  There are three options 

contained within the 
skew setting, Use 
Station Skew, Use 
Weighted Skew, 
and Use Regional 
Skew.  The default 
skew setting is Use 
Station Skew.   
With this setting, 
the skew of the 
computed curve will 
be based solely on 
computing a skew 
from the data 
points.   

The Use Weighted 
Skew option 
requires the user to 
enter a generalized 

regional skew and a mean-square error (MSE) of the generalized 
regional skew.  This option weights the computed station skew with 
the generalized regional skew.  The equation for performing this 
weighting can be found in Bulletin 17B (equation 6).  If a regional 
skew is taken from Plate I of Bulletin 17B (the skew map of the United 
States), the value of MSE = 0.302.   
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The Use Regional Skew option requires the user to enter a 
generalized regional skew and a mean-square error (MSE) of the 
generalized regional skew.  The program will ignore the computed 
station skew and use only the generalized regional skew. 

Compute  

Press the Compute button, located at the bottom of the Volume-
Duration Frequency editor, once options have been set 
on the General, Options, and Settings tabs.  If the 
compute is successful, the user will receive a message 

that says Compute Complete.  At this point, the user can review 
results from the analytical analysis by selecting the Tabular Results 
and Plot tabs. 

Note: the volume-duration frequency analysis will identify low and 
high outliers using guidelines in Bulletin 17B; however, the program 
will not remove outliers and recompute the statistics.   

Tabular Results 

The Tabular Results tab contains a table of results for the analytical 
frequency analysis.  An example of the results table is shown in Figure 
7-7.  The top portion of this table contains volumes from the analytical 
frequency curve for each duration and frequency ordinate defined on 
the Options tab.  The Statistics of the analytical frequency curves are 
contained below the frequency curve ordinates.  The statistics include 
the mean, standard deviation, station skew, regional skew, weighted 
skew, adopted skew, number of years of record, and number of years 
with zero or missing flow.   

User-adjusted statistics can be defined by the user on the Statistics 
tab.  If the user has not entered statistics on the Statistics tab, then 
the results table will look similar to Figure 7-7.  If the user does enter 
statistics on the Statistics tab, then the results table will include the 
adjusted mean, adjusted standard deviation, and adjusted skew.  If 
specified by the user, the program will use the user-adjusted statistics 
when computing the analytical curves.  
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Figure 7-7.  Tabular Results for a Volume-Frequency Analysis. 

Plot 

In addition to tabular results, a Plot tab is available for viewing 
results, as shown in Figure 7-8.  The results graph includes the 
systematic annual maximum/minimum volumes, plotted using the 
specified plotting position method, and the analytical frequency 
curves.  The analytical frequency curves are based on the computed 
statistics or user-adjusted statistics if they are defined on the Statistics 
tab.  
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Figure 7-8.  Plot of Analytical Results for a Volume-Frequency Analysis. 

Statistics 

As discussed in EM 1110-2-1415, a necessary step in a volume-
frequency analysis is to make sure the analytical frequency curves are 
consistent across all durations (USACE, 1993).   In some situations, 
frequency curves from different durations might cross one another.  
The Statistics tab contains tools allowing the user to modify the 
mean, standard deviation, and skew to make sure frequency curves do 
not cross one another.   

When the user selects the Statistics tab, the window will appear as 
shown in Figure 7-9.  The upper portion of the Statistics tab contains a 
plot of the computed and user-adjusted statistics.  The user has the 
option of choosing the parameter to be plotted in the comparison 
graph.  Computed statistics are plotted as black data points and user-
adjusted statistics are plotted as blue data points.  The first table, 
Sample Statistics, contains the statistics computed from the 
systematic data.  In addition, the adopted skew value in this table can 
be the station skew, weighted skew, or regional skew.  The adopted 
skew is set by the user on the Settings tab.  The lower table is where 
the user enters the adjusted statistics.  Before entering adjusted 
statistics, the user must check the box in column 1.  User-adjusted 
statistics entered in this table are used when the program computes 
the analytical frequency curve.         
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Figure 7-9.  Statistics Tab in the Volume-Duration Frequency Editor. 

Graphical Frequency Analysis 

In addition to an analytical frequency analysis, which uses a statistical 
distribution to fit the data, the user has the option to graphically fit the 
data.  A graphical fit to data can be very useful when the available 
analytical distributions do not provide a good fit.  One example of 
when a graphical frequency analysis is more appropriate is when 
plotting a frequency curve for flow data that is downstream of a flood 
control reservoir.  Analytical frequency distributions are often not 
appropriate for fitting flow data that is significantly regulated by 
upstream reservoirs.  In general, a portion of the flow frequency data 
for a highly regulated stream will be very flat in the zone in which 
upstream regulation can control the flow.  This type of data lends itself 
to a graphical fit.   

When the Graphical tab is selected on the Volume-Duration 
Frequency editor, the window will appear as shown in Figure 7-10.  As 
indicated, two additional tabs will appear on the screen, Curve Input 
and Plot.   



Chapter 7  Performing a Volume-Duration Frequency Analysis 

7-18 

Figure 7-10.  Graphical Curve Table for a Volume-Duration Frequency Analysis. 

Curve Input 

The user manually enters the frequency ordinates for all durations in 
the table on the Curve Input tab.  As previously mentioned, the 
number of frequency ordinates and durations are set on the Options 
tab.  The idea is to enter values in the table that will create a best fit 
line of the data, based on the user’s judgment.  Data entered in the 
graphical curve table will be plotted as a line in the graph on the Plot 
tab after the Compute button is pressed.  

Plot 

The graphical analysis Plot tab is available for viewing results, as 
shown in Figure 7-11.  The results graph includes the historic annual 
maximum/minimum flows, plotted using the specified plotting position 
method, and the user-defined graphical curve, which was entered in 
the table on the Curve Input tab. 
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Figure 7-11.  Plot Tab for a Graphical Analysis. 

Viewing and Printing Results – Volume-Duration Frequency 
Analysis 

The user can view output for the frequency analysis directly from the 
Volume-Duration Frequency editor (Tabular and Graphical output) or 
by using the plot and view report buttons at the bottom of the editor.  
The output consists of tabular results, an analytical frequency curve 
plot, a graphical frequency curve plot, and a report documenting the 
data and computations performed. 

Tabular Output 

Once the computations for the analytical frequency analysis are 
completed, the user can view tabular output by opening the Tabular 
Results tab under the Analytical analysis tab.  The details of this 
table were discussed above.  The tabular results can be printed by 
using the Print button at the bottom of the Volume-Duration 
Frequency editor.  When the print button is pressed, a window will 
appear, giving the user options for how the table is to be printed. 
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Graphical Output 

Graphical output can be opened by selecting one of the plot buttons at 
the bottom of the Volume-Duration Frequency editor or by selecting 
the Plot tab under the Analytical or Graphical tabs.  There are three 
plot buttons at the bottom of the Volume-Duration Frequency editor, 
Plot Duration Data, Plot Analytical Curve, and Plot Graphical Curve.  
Pressing the Plot Duration Data button will open a new window 
containing a graph showing the systematic data plotted using the user-
defined plotting position method.  Pressing the Plot Analytical Curve 
button will open a new window containing a graph with both the 
systematic data and the computed analytical frequency curves, as 
shown in Figure 7-12.  Pressing the Plot Graphical Curve button will 
open a new window containing a graph with both the systematic data 
and the user-defined frequency curves.  

Figure 7-12.  Plot of Systematic Data and Analytical Frequency Curves.  

 

All plots opened by selecting one of the plot buttons at the bottom of 
the Volume-Duration Frequency editor contain menu options for 
printing, editing, and saving the plots.   

Plots can be sent to the printer by selecting the Print option located 
on the File menu.  Additional printing options available from the File 
menu are Page Setup, Print Preview, and Print Multiple (used for 
printing multiple graphs on the same page).  The plot can also be sent 
to the Windows Clipboard by selecting Copy to Clipboard from the 
File menu.  Additionally, the plot can be saved to a file by selecting the 
Save As option from the File menu.  When the Save As option is 
selected, a pop-up window will appear allowing the user to select a 
directory, enter a filename, and select the format for saving the file.  
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Currently four file formats are available for saving the plot to disk: 
windows metafile, postscript, JPEG, and portable network graphic.  The 
data contained within the plot can also be tabulated by selecting 
Tabulate from the File menu.  When this option is selected, a 
separate window will appear with the data tabulated.  Additional 
options are available from the File menu for saving the plot properties 
as a template (Save Template) and applying previously saved 
templates to the current plot (Apply Template).   

The Edit menu contains several options for customizing the plot 
properties.  These options include Plot Properties, Configure Plot 
Layout, Default Line Styles, and Default Plot Properties.  Also, the user 
can right-click on a line or data point in the plot area or in the legend 
and a pop-up menu will open with customization options.  The graphic 
customizing capabilities within HEC-SSP are very powerful, but are 
also somewhat complex to use.  The code used in developing the plots 
in HEC-SSP is the same code that was used for developing graphics in 
HEC-DSSVue and several other HEC software programs.  A separate 
write-up on Customizing Graphics can be found in Appendix C of this 
manual.  Please refer to that appendix for details on using the graphics 
customizing options. 

Viewing the Report File 

Computational results for a volume-duration frequency analysis are 
written to a report file.  The report file lists all of the input data and 
user settings, plotting positions of the data points, intermediate 
results, each of the various statistical tests performed (i.e. high and 
low outliers, historical data, etc…), and the final results.  This file is 
often useful for understanding how the software arrived at the final 
frequency curves.  Press the View Report button at the bottom of the 
Volume-Duration Frequency editor to open the report, as shown in 
Figure 7-13. 
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Figure 7-13.  Volume-Duration Frequency Report. 
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A P P E N D I X  B   

Example Data Sets 

The input and output for eleven example data sets are provided to 
illustrate the use of selected options and to assist in verifying the 
correct execution of the program.     

The first six example data sets are the same examples that were found 
in the HEC-FFA program documentation.  The first six examples were 
duplicated with a Bulletin 17B and General Frequency analysis.  This 
manual only shows these examples using the Bulletin 17B analysis; 
however, the example data sets show that results are the same 
whether a Bulletin 17B or General Frequency analysis was performed. 
As shown in the example data sets, the HEC-SSP software produces 
the same results as HEC-FFA for these six data sets.  All of these test 
examples are provided with the software as a single HEC-SSP study 
labeled “SSP Examples”.  You can install this study on your computer 
by selecting the Help Install Example Data menu option.  After 
opening this study for the first time on your computer, you must 
compute each example before viewing tabular and graphical results.     

A brief description of each test example is provided.  In most cases the 
weighted skew option was selected, and a regional skew value was 
entered from the generalized skew map of the United States provided 
within Bulletin 17B (Plate 1).   

The example problems shown in this section are entitled: 

1. Fitting the Log-Pearson Type III Distribution. 

2. Analysis with High Outliers. 

3. Testing and Adjusting for a Low Outlier. 

4. Zero Flood Years. 

5. Confidence Limits and Low Threshold Discharge. 

6. Use of Historic Data and Median Plotting Positions. 

7. Analyzing Stage Data. 

8. Using User-Adjusted Statistics. 

9. General Frequency - Graphical Analysis. 

10. Volume-Duration Frequency Analysis, Maximum Flows.  
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11. Volume-Duration Frequency Analysis, Minimum Flows.  

When the “SSP Examples” study file is open, the screen will appear as 
shown in Figure B-1. 

 

Figure B -1.  SSP Examples Study. 

 

As shown in Figure B-1, there are 6 Bulletin 17B analyses, 9 General 
Frequency analyses, and 2 Volume-Frequency analyses in this study.  
The following sections document each of the example data sets. 
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Example 1: Fitting the Log-Pearson Type III Distribution 

The input data for the HEC-SSP Example 1 is the same as that for 
Example 1 in Appendix 12, Guidelines for Determining Flood Flow 
Frequency, Water Resources Council Bulletin 17B.  Example 1 
illustrates the routine computation of a frequency curve by the Bulletin 
17B methodology.   

The data for this example is from Fishkill Creek in Beacon, New York.  
The period of record used for this example is from 1945 to 1968.  To 
view the data from HEC-SSP, right-click on the data record labeled 
“FISHKILL CREEK – BEACON- FLOW” in the study tree and then 
select Tabulate.  The data will appear as shown in Figure B-2. 

 
Figure B-2.  Tabulation of the Peak Flow Data for Fishkill Creek. 
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To plot the data for this example, right-click on the data record again 
and then select Plot.  A plot of the data will appear as shown in Figure 
B-3. 

Figure B-3.  Plot of the Fishkill Creek Data. 

 

A Bulletin 17B and a General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 1, either double-click on the analysis labeled FFA Test 1 
from the Study Explorer, or from the Analysis menu select open, then 
select FFA Test 1 from the list of available analyses.  When FFA Test 1 
is selected, the Bulletin 17B analysis editor will appear as shown in 
Figure B-4. 
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Figure B-4.  Bulletin 17B Analysis Editor with Test Example 1 Data Set. 

 

Shown in Figure B-4 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example a value of 0.6 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The Weibull plotting position method was selected, as well as 
the default Confidence Limits of 0.05 (5 percent chance exceedance) 
and 0.95 (95% chance exceedance).  Shown in Figure B-5 is the 
Bulletin 17B editor with the Options Tab selected. 
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Figure B-5.  Bulletin 17B Editor with Options Tab Selected for Test Example 1. 

 

As shown in Figure B-5, none of the available options for modifying the 
frequency analysis were selected for this example.  These options 
include changing the Low Outlier Threshold and using Historic 
Data.  Additionally, the option to override the default Frequency 
Ordinates was not selected. 

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab.  The analysis window should look like Figure B-
6. 
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Figure B-6.  Bulletin 17B Analysis Window with Results Tab Shown for Test Example 1. 

 

As shown in Figure B-6, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 

 Confidence Limits (5% and 95% chance exceedance curves) 

On the bottom, left side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom, right side of the results tab is 
a Number of Events table showing the number of historic events used 
in the analysis, number of high outliers found, number of low outliers, 
number of zero or missing data years, number of systematic events in 
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the gage record, and the historic record length (if historic data was 
entered). 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-7. 

Figure B-7.  Plotted Frequency Curves for Test Example 1. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 
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In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-8 
is the report file for test example 1. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis.  The user should 
review the report file to understand how HEC-SSP performed the 
Bulletin 17B frequency curve calculations. 
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Figure B-8.  Test Example 1 Report File. 
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Example 2: Analysis with High Outliers 

The input data for the Example 2 is the same as that for Example 2 in 
Appendix 12, Guidelines for Determining Flood Flow Frequency, Water 
Resources Council Bulletin 17B.  Example 2 illustrates the application 
to data with a high outlier.  

The data for this example is from Floyd River in James, Iowa.  The 
period of record used is from 1935 to 1973.  To view the data from 
HEC-SSP, right-click on the data record labeled “FLOYD RIVER-
JAMES IA-FLOW” in the study explorer and then select Tabulate.  
The data will appear as shown in Figure B-9. 

 
Figure B-9.  Tabulation of the Peak Flow Data for the Floyd River. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
10. 

Figure B-10.  Plot of Floyd River Data 

 

A Bulletin 17B and General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 2, either double-click on the analysis labeled FFA Test 2 
from the study pane, or from the Analysis menu select open and then 
select FFA Test 2 from the list of available analyses.  When FFA Test 2 
is selected, the Bulletin 17B analysis editor will appear as shown in 
Figure B-11. 
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Figure B-11.  Bulletin 17B Analysis Editor with Test Example 2 Data Set. 

 

Shown in Figure B-11 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example a value of -0.3 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The Weibull plotting position method was selected, as well as 
the default Confidence Limits of 0.05 (5 percent chance exceedance) 
and 0.95 (95% chance exceedance).  Shown in Figure B-12 is the 
Bulletin 17B editor with the Options Tab selected. 
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Figure B-12.  Bulletin 17B Editor with Options Tab Selected for Test Example 2. 

 

As shown in Figure B-12, the Historic Period Data option has been 
selected to reflect the fact that the 1953 flood peak of 71,500 cfs is 
known to be the largest flood since 1892. When the analysis was 
originally performed on this data set, the 1953 event was found to be 
a high outlier.  (The reader may replicate this result by unchecking the 
“Use Historic Data” box, hitting the Compute button, and reviewing the 
Tabular Results tab.)  High outliers should not be eliminated from an 
analysis, as they are valuable pieces of the flow record.  However, 
when a high outlier is found in a data set, it suggests that the event 
might actually be the largest in a much longer period of record.  The 
analyst should always try to locate and incorporate historic information 
to define a longer record and improve the quality of the frequency 
analysis.  Since it was known that the 1953 event was the largest 
value since 1892, the year 1892 is entered as the Start Year for the 
historic period.  Additionally, a High Threshold Value of 70,000 cfs 
was entered.  By entering the High Threshold Value of 70,000 cfs, the 
1953 flood of 71,500 cfs was removed from the systematic record and 
treated as a historic data value during the historic data adjustment 
calculations performed by HEC-SSP and outlined in Bulletin 17B, 
Appendix 6.  Since no End Year was entered for the historic period, the 
last year of the systematic data set will be used as the End Year. 
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Other features on this tab include the Low Outlier Threshold and the 
option to override the default Frequency Ordinates, neither of which 
are selected in this example. 

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab.  The analysis window should look like Figure B-
13. 

Figure B-13.  Bulletin 17B Editor with Results Tab Selected for Test Example 2. 

 

As shown in Figure B-13, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 
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 Confidence Limits (5% and 95% chance exceedance curves) 

On the bottom left-hand side of the results tab is the System Statistics 
table for the observed station data (mean, standard deviation, station 
skew) and regional adjustment (regional skew, weighted skew, and 
adopted skew).  Also on the bottom right-hand side of the results tab 
is the Number of Events table showing the number of historic events 
used in the analysis, number of high outliers found, number of low 
outliers, number of zero or missing data years, number of systematic 
events in the gage record, and the historic record length (if historic 
data was entered). 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-14. 

Figure B-14.  Plotted Frequency Curves for Test Example 2. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
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the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-15 
is the report file for test example 2. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis.  The user should 
review the report file to understand how HEC-SSP performed the 
frequency curve calculations. 
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Figure B-15.  Test Example 2 Report File. 

 

 



 Appendix B  Example Data Sets 

 B-19 

Example 3: Testing and Adjusting for a Low Outlier 

The input data for Test 3 are the same as that for Example 3 in 
Appendix 12 of the WRC Guidelines.  Test 3 illustrates the application 
to data with a low outlier.  Note that the program automatically 
screens for low outliers and, if low outliers are found, outputs the 
preliminary results in the report file in order to allow for comparison 
with the final results. 

The data for this example is from Back Creek in Jones Springs, West 
Virginia.  The period of record used for this example is from 1929 to 
1973.  To view the data, right-click on the data record labeled “BACK 
CREEK-JONES SPRINGS, WV-FLOW” in the study pane and then 
select Tabulate.  The data will appear as shown in Figure B-16. 

 
Figure B-16.  Tabulation of the Peak Flow Data for Back Creek. 
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To plot the data for this example, right-click on the data record and 
select Plot.  A plot of the data will appear as shown in Figure B-17. 

Figure B-17.  Plot of Back Creek Data. 

 

A Bulletin 17B and General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 3, either double-click on the analysis labeled FFA Test 3 
from the study explorer, or from the Analysis menu select open and 
then select FFA Test 3 from the list of available analyses.  When FFA 
Test 3 is selected, the Bulletin 17B analysis editor will appear as shown 
in Figure B-18. 
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Figure B-18.  Bulletin 17B Analysis Editor with Test Example 3 Data Set. 

 

Shown in Figure B-18 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example, a value of 0.5 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The Weibull plotting position method was selected, as well as 
the default Confidence Limits of 0.05 (5 percent chance exceedance) 
and 0.95 (95% chance exceedance).  Shown in Figure B-19 is the 
Bulletin 17B editor with the Options Tab selected. 
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Figure B-19.  Bulletin 17B Editor with the Options Tab Selected for Test Example 3. 

 

As shown in Figure B-19, none of the available options for modifying 
the frequency curve were selected for this test example.  These 
options include the Low Outlier Threshold and Historic Period 
Data.  Additionally, the option to override the default Frequency 
Ordinates was not selected. 

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed a message window will pop-up 
stating Compute Complete.  Close this window and select the 
Tabular Results tab.  The analysis window should look like Figure B-
20. 
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Figure B-20.  Bulletin 17B Editor with the Results Tab Selected for Test Example 3. 

 

As shown in Figure B-20, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 

 Confidence Limits (5% and 95% chance exceedance curves) 

On the bottom left-hand side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom right-hand side of the results 
tab is a table of Number of Events showing the number of historic 
events used in the analysis, number of high outliers found, number of 
low outliers, number of zero or missing data years, number of 
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systematic events in the gage record, and the historic record length (if 
historic data was entered).   

In this analysis, the software detected 1 low outlier in the systematic 
record.  As recommended in Bulletin 17B, if a low outlier is detected, 
then that data point will be removed and the Conditional Probability 
Adjustment will be used to recalculate the frequency curve and then 
the statistics without that point.  Review the report file to see the 
original statistics, computed curves, the low outlier test, and 
recomputed curves. 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-21. 

Figure B-21.  Pot for Test Example 3. 

 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
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the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-22 
is the report file for test example 3. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-22.  Report File for Test Example 3.  
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Example 4: Zero-Flood Years 

The input data for Test 4 are the same as that for Example 4 in 
Appendix 12 of the WRC Guidelines.  Test 4 illustrates the application 
to data that includes several zero flow years. 

The data for this example is from Orestimba Creek in Newman, 
California.  The period of record used for this example is from 1932 to 
1973.  To view the data from HEC-SSP, right-click on the data record 
labeled “ORESTIMBA CREEK-NEWMAN, CA-FLOW” in the study 
explorer and then select Tabulate.  The data will appear as shown in 
Figure B-23. 

 
Figure B-23.  Tabulation of the Peak Flow Data for Orestimba Creek. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
24.  The years with peak flows measuring zero are visible. 

Figure B-24.  Plot of Orestimba Creek Data. 

 

A Bulletin 17B and General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 4, either double-click on the analysis labeled FFA Test 4 
from the study explorer, or from the Analysis menu select open, then 
select FFA Test 4 from the list of available analyses.  When FFA Test 4 
is selected, the Bulletin 17B analysis editor will appear as shown in 
Figure B-25. 
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Figure B-25.  Bulletin 17B Analysis Editor with Test Example 4 Data Set. 

 

Shown in Figure B-25 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example a value of -0.3 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The Weibull plotting position method was selected, as well as 
the default Confidence Limits of 0.05 (5 percent chance exceedance) 
and 0.95 (95% chance exceedance).  Shown in Figure B-26 is the 
Bulletin 17B editor with the Options Tab selected. 
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Figure B-26.  Bulletin 17B Editor with the Options Tab Selected for Test Example 4. 

 

As shown in Figure B-26, none of the available options for modifying 
the frequency curve were selected for this test example.  These 
options include the Low Outlier Threshold and Historic Period 
Data.  Additionally, the option to override the default Frequency 
Ordinates was not selected. 

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab.  The analysis window should look Figure B-27. 
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Figure B-27.  Bulletin 17B Editor with the Results Tab Selected for Test Example 4. 

 

As shown in Figure B-27, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 

 Confidence Limits (5% and 95% chance exceedance curves) 

On the bottom left-hand side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom right-hand side of the results 
tab is a table of Number of Events showing the number of historic 
events used in the analysis, number of high outliers found, number of 
low outliers, number of zero or missing data years, number of 
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systematic events in the gage record, and the historic record length (if 
historic data was entered).    

As noted earlier, there were 6 zero values in this record, and also a 
low outlier.  A zero value causes difficulty because the first step in 
fitting a Log Pearson III distribution is computing the base-10 log of 
each flow value, which is undefined for zero.  Bulletin 17B 
recommends removing the zero values (and the low outlier) from the 
systematic record to compute a preliminary frequency curve, and then 
adjusting that curve with the Conditional Probability Adjustment.  The 
final frequency curve and statistics are shown in the table, and the 
preliminary calculations can be reviewed in the report file.  

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-28. 

Figure B-28.  Plot of Test Example 4 Results. 
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The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-29 
is the report file for test example 4. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-29.  HEC-SSP Report File for Test Example 4. 
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Example 5: Confidence Limits and Low Threshold Discharge 

This test illustrates the use of user-entered confidence limits.  
Probabilities of .01 and .99 were entered for the computed confidence 
limit curves.  This data set also includes two very low values, the 
higher of which is just above the default low outlier threshold.  This 
example therefore also demonstrates the use of a user-entered low 
outlier threshold set to be higher than both values.   

The data for this example is from Kaskaskia River in Vandalia, Illinois.  
The period of record used for this example is from 1908 to 1970.  To 
view the data from HEC-SSP, right-click on the data record labeled 
“KASKASKIA RIVER-VANDALIA, IL-FLOW” in the study explorer 
and then select Tabulate.  The data will appear as shown in Figure B-
30. 

 
Figure B-30.  Tabulation of the Peak Flow Data for Kaskaskia River. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
31. 

Figure B-31.  HEC-SSP Plot of  the Kaskaskia River Data. 

 

A Bulletin 17B and General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 5, either double-click on the analysis labeled FFA Test 5 
from the study explorer, or from the Analysis menu select Open and 
then select FFA Test 5 from the list of available analyses.  When FFA 
Test 5 is selected, the Bulletin 17B analysis editor will appear as shown 
in Figure B-32. 
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Figure B-32.  Bulletin 17B Analysis Editor for Test Example 5. 

 

Shown in Figure B-32 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example a value of -0.4 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The default method of Weibull plotting positions was selected.  
The default values for confidence limits (.05 and .95) were changed to 
0.01 (1 percent chance exceedance) and 0.99 (99% chance 
exceedance).  Shown in Figure B-33 is the Bulletin 17B editor with the 
Options Tab selected. 
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Figure B-33.  Bulletin 17B Editor with the Options Tab Shown for Test Example 5. 

 

As shown in Figure B-33, a Low Outlier Threshold of 2000 was 
entered. In the initial computation with this data (which the reader can 
reproduce by Computing without the “Use Low Outlier Threshold” box 
checked), the default low outlier threshold was 1,253 cfs, just below 
the second lowest value of 1,270 cfs.  A look at the statistics and 
computed frequency curve from that run shows that the 1,270 cfs 
value is well below the computed curve and with a station skew of -
0.21 the frequency curve does not fit the upper data well.  By choosing 
to also censor the 1,270 cfs value with a threshold of 2000 cfs, the fit 
is improved.  None of the other available options, such as Historic 
Period Data and the option to override the default Frequency 
Ordinates, were selected for this test example.  

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab from the analysis window.  The analysis window 
should look Figure B-34. 
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Figure B-34.  Bulletin 17B Editor with the Results Tab Selected for Test Example 5. 

 

As shown in Figure B-34, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 

 Confidence Limits (1% and 99% chance exceedance curves) 

On the bottom left-hand side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom right-hand side of the results 
tab is a table of Number of Events showing the number of historic 
events used in the analysis, number of high outliers found, number of 
low outliers, number of zero or missing data years, number of 
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systematic events in the gage record, and the historic record length 
(only if historic data was entered). 

With the user-defined low-outlier threshold of 2000 cfs, there are 2 
low-outliers detected.  The analysis report shows the program omitted 
these values and used the Conditional Probability Adjustment to 
recompute the resulting frequency curve and statistics.  The report file 
(described below) includes the preliminary computation before 
removal of outliers and the default and user-defined outlier thresholds, 
as well as the final frequency curve and statistics. 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-35. 

Figure B-35.  Plot of the Frequency Curve Results for Test Example 5. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
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window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-36 
is the report file for test example 5. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-36.  Report File for Test Example 5. 
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Example 6: Use of Historic Data and Median Plotting Position 

This test demonstrates how to use historic information to improve a 
flow frequency analysis.  A historic flood peak of 15,000 cfs which 
occurred in 1843 is included in the analysis.  This value is the highest 
known value up to the present time (1974 for this example), even 
though the systematic record stopped in 1955.   

The data for this example is from Ridley Creek in Moylan, 
Pennsylvania.  The period of record used for this example is from 1932 
to 1955.  To view the data from HEC-SSP, right-click on the data 
record labeled “RIDLEY CREEK-MOYLAN, PA-FLOW” in the study 
explorer and then select Tabulate.  The data will appear as shown in 
Figure B-37. 

 
Figure B-37.  Tabulation of the Peak Flow Data for Ridley Creek. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
38. 

Figure B-38.  Plot of the Ridley Creek Data. 

 

A Bulletin 17B and General Frequency analysis have been developed 
for this example.  To open the Bulletin 17B analysis editor for test 
example 6, either double-click on the analysis labeled FFA Test 6 
from the study explorer, or from the Analysis menu select open, then 
select FFA Test 6 from the list of available analyses.  When FFA Test 6 
is selected, the Bulletin 17B analysis editor will appear as shown in 
Figure B-39. 
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Figure B-39.  Bulletin 17B Analysis Editor for Test Example 6. 

 

Shown in Figure B-39 are the general settings that were used to 
perform this frequency analysis.  As shown, the Skew option was set 
to use the Weighted Skew.  To use the weighted skew option, the 
user must enter a value for the Regional Skew and the Regional Skew 
Mean Square Error (MSE).  This selection requires the user to either 
look up a value from the generalized skew map of the United States, 
which is provided with Bulletin 17B, or develop a value from a regional 
analysis of nearby gages.  In this example a value of 0.4 was taken 
from the generalized skew map of the U.S. from Bulletin 17B.  Bulletin 
17B suggests using a Regional Skew MSE of 0.302 whenever regional 
skew values are taken from the map. 

Also for this example, the Expected Probability Curve option was 
selected to be computed in addition to the Log Pearson III computed 
curve.  The Median plotting position method was selected, as well as 
the default Confidence Limits of 0.05 (5 percent chance exceedance) 
and 0.95 (95% chance exceedance).  Shown in Figure B-40 is the 
Bulletin 17B editor with the Options Tab selected. 
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Figure B-40.  Bulletin 17B Analysis Editor with Options Tab Shown for Test Example 6. 

 

As shown in Figure B-40, the Historic Period Data option has been 
selected to reflect a historical flood event of 15,000 cfs in 1843 and an 
analysis period from 1843 to 1974.  Historic data is used to account for 
historic flood events large enough to be relevant to the analysis and 
not contained in the systematic data record.  The additional 
information provided by historic data can improve the flood frequency 
analysis, especially when the data collection period for a given area is 
relatively short. Information for a Historic Flood Peak has been 
entered to account for a peak flow of 15,000 cfs in the 1843 water 
year.  The Historic Period Start Year has been left blank.  By default 
this value will be the earliest year found in the historic flood peak data 
or the systematic record.  Therefore for this example, 1843 will 
automatically be used for the Start Year of the Historic Period.  An End 
Year of 1974 has been entered.  The systematic record for the gage 
ended in 1955, however when this analysis was performed in 1974, no 
other flood peaks of consequence had been observed between 1955 
and 1974.  Therefore, 1974 is set as the End Year for the historic 
period analysis. 
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Other features on this tab include the Low Outlier Threshold and the 
option to override the default Frequency Ordinates.  Neither option 
is selected in this example. 

Once all of the General and Optional settings are set or selected, the 
user can press the Compute button to perform the analysis.  Once the 
computations have been completed a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab from the analysis window.  The analysis window 
should look Figure B-41. 

Figure B-41.  Bulletin 17B Editor with the Results Tab Selected for Test Example 6. 

 

As shown in Figure B-41, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Expected Probability Curve 
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 Confidence Limits (5% and 95% chance exceedance curves) 

On the bottom left-hand side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom right-hand side of the results 
tab is a table of Number of Events showing the number of historic 
events used in the analysis, number of high outliers found, number of 
low outliers, number of zero or missing data years, number of 
systematic events in the gage record, and the historic record length (if 
historic data was entered). 

This example reports one historical flood event, and a historical period 
of 132 years, between 1843 and 1974.  The reported statistics reflect 
the use of the historical data adjustment outlined in Bulletin 17B 
Appendix 6.  The report file (described below) shows the initial 
computation of the statistics and frequency curve before the historical 
data was used, and the resulting statistics and frequency curve after 
the historical data is taken into account. 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Curve button 
at the bottom of the analysis window.  A plot of the results for this test 
example is shown in Figure B-42. 
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Figure B-42.  Plot of the Frequency Curve Results for Test Example 6. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-43 
is the report file for test example 6. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 



Appendix B  Example Data Sets 

B-50 

the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 

Figure B-43.  HEC-SSP Report File for Test Example 6. 
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Example 7: Analyzing Stage Data 

This example demonstrates how to use the General Frequency analysis 
to analyze stage data.  The data for this example is from the Cedar 
Rapids, Iowa stream gage (gage id 05464500).  The period of record 
used for this example is from 1851 to 2007.  In addition to the 
systematic record, an historic flooding event occurred in June 2008.  
To view the data, right-click on the data record labeled “CEDAR 
RAPIDS, STAGE DATA” in the study explorer and then select 
Tabulate.  The data will appear as shown in Figure B-44. 

 
Figure B-44.  Tabulation of the Peak Stage Data for Cedar Rapids, Iowa. 

 

To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
45. 
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Figure B-45.  Plot of the Cedar Rapids Data. 

 

A General Frequency analysis has been developed for this example.  
To open the General Frequency analysis editor for test example 7, 
either double-click on the analysis labeled STAGE ANALYSIS TEST 7 
from the study explorer, or from the Analysis menu select open, then 
select STAGE ANALYSIS TEST 7 from the list of available analyses.  
When test 7 is opened, the General Frequency analysis editor will 
appear as shown in Figure B-46.  For this analysis, the Use Log 
Transform option was selected, the Weibull plotting position method 
was selected, the default Confidence Limits were selected, and no 
modification was made to the time window. 
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Figure B-46.  General Frequency Analysis Editor for Test Example 7. 

 

Shown in Figure B-47 is the General Frequency analysis editor with the 
Options Tab selected.  The Historic Period Data option has been 
selected to reflect a historical flood event that produced a peak stage 
of 31.12 feet in June of 2008.  The Historic Period Start Year has 
been left empty.  By default this value will be the earliest year found in 
the historic flood peak data or the systematic record.  Therefore for 
this example, 1851 will automatically be used for the Start Year of the 
Historic Period.  This Historic Period End Year has also been left 
empty.  By default this value will be the last year found in the historic 
flood peak data or the systematic record.  Therefore for this example, 
2008 will automatically be used for the End Year of the Historic Period. 

Other features on this tab include the Low Outlier Threshold, an 
option to override the default Frequency Ordinates, and Output 
Labeling.  The changes made to these options include adding the 0.1 
percent frequency ordinate and the data name was changed from 
STAGE-ANNUAL PEAK to Stage.    
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Figure B-47.  General Frequency Analysis Editor with Options Tab Shown for Test 
Example 7. 

 

Once all of the General and Optional settings are set or selected, the 
user can choose to perform an Analytical or Graphical analysis.  In this 
example, an analytical analysis was performed on the peak stage data.  
Shown in Figure B-48 is the Settings tab for the analytical analysis.  
As shown, the distribution selected for this example is LogPearsonIII.  
The Skew option was set to Use Station Skew and the Do Not 
Compute Excepted Probability option was selected.  
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Figure B-48.  General Frequency Analysis Editor with Settings Tab Shown for Test 
Example 7. 

 

Press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab within the analytical analysis.  The tabular 
results window should look Figure B-49. 
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Figure B-49.  General Frequency Editor with Tabular Results Tab Selected for Test 
Example 7. 

 

As shown in Figure B-49, the Frequency Curve table contains the 
following results: 

 Percent Chance Exceedance 

 Computed Curve (Log-Pearson III results) 

 Confidence Limits (5% and 95% chance exceedance curves) 

The frequency curve table contains results based on the data, 
systematic and historic, and results based on user-adjusted statistics.  
In this example no user-adjusted statistics were defined, therefore 
these columns are empty.  On the bottom left-hand side of the results 
tab is a table of System Statistics for the observed station data (mean, 
standard deviation, station skew) and regional adjustment (regional 
skew, weighted skew, and adopted skew).  Also on the bottom right-
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hand side of the results tab is a table of Number of Events showing the 
number of historic events used in the analysis, number of high outliers 
found, number of low outliers, number of zero or missing data years, 
number of systematic events in the gage record, and the historic 
record length (if historic data was entered). 

This example reports one historical flood event, and a historical period 
of 158 years, between 1851 and 2008.  The reported statistics reflect 
the use of the historical data adjustment outlined in Bulletin 17B, 
Appendix 6.  The report file (described below) shows the initial 
computation of the statistics and frequency curve before the historical 
data was used, and the resulting statistics and frequency curve after 
the historical data is taken into account. 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Analytical 
Curve button at the bottom of the analysis window.  A plot of the 
results for this test example is shown in Figure B-50. 

Figure B-50.  Plot of the Frequency Curve Results for Test Example 7. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
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send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-51 
is the report file for test example 7. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-51.  Report File for Test Example 7. 
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Example 8: Using User-Adjusted Statistics 

This example demonstrates how to use the General Frequency analysis 
and enter user-adjusted statistics.  The data for this example is from 
an analysis that computed local runoff for the Rio Grande at 
Albuquerque.  The data includes unregulated daily average flows 
generated by rainfall-runoff from areas downstream of upstream 
reservoirs.  The period of record used for this example is from 1944 to 
2000.  To view the data, right-click on the data record labeled 
“Annual Daily Average Peak Flows Local Runoff at Albuquerque” 
in the study explorer and then select Tabulate.  The data will appear 
as shown in Figure B-52. 

 
Figure B-52.  Tabulation of the Peak Stage Data for Example 8. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
53. 

Figure B-53.  Plot of Data for Example 8. 

 

A General Frequency analysis has been developed for this example.  
To open the General Frequency analysis editor for test example 8, 
either double-click on the analysis labeled LOCAL RUNOFF AT 
ALBUQUERQUE TEST 8 from the study explorer, or from the 
Analysis menu select open, then select LOCAL RUNOFF AT 
ALBUQUERQUE TEST 8 from the list of available analyses.  When 
test 8 is opened, the General Frequency analysis editor will appear as 
shown in Figure B-54. 
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Figure B-54.  General Frequency Analysis Editor for Test Example 8. 

 

Shown in Figure B-53 are the general settings that were used to 
perform this frequency analysis.  For this analysis, the Use Log 
Transform option was selected, the Weibull plotting position method 
was selected, the default Confidence Limits were selected, and no 
modification was made to the Time Window.   
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Shown in Figure B-55 is the General Frequency analysis editor with the 
Options Tab selected.  Features on this tab include the Low Outlier 
Threshold, an option to use Historic Data, an option to override the 
default Frequency Ordinates, and Output Labeling.  All defaults 
settings were selected for this example.     

Figure B-55.  General Frequency Analysis Editor with Options Tab Shown for Test 
Example 8. 

 

Once all of the General and Optional settings are set or selected, the 
user can choose to perform an Analytical or Graphical analysis.  In this 
example, an analytical analysis was performed.  Shown in Figure B-56 
is the Settings tab for the analytical analysis.  As shown, the 
distribution selected for this example is LogPearsonIII.  The Skew 
option was set to Use Station Skew and the Do Not Compute 
Excepted Probability option was selected.  
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Figure B-56.  General Frequency Analysis Editor with Settings Tab Shown for Test 
Example 8. 

 

Press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Plot tab within the analytical analysis.  The analytical plot window 
should look Figure B-57. 
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Figure B-57.  The Plot Tab for Test Example 8. 

 

As shown in Figure B-57, the Plot tab contains a graph of the 
systematic data, the computed frequency curve, and the confidence 
limits.  The right side of the plot tab contains a table of Computed 
Statistics and User Statistics.  The user has the option to enter a 
mean, standard deviation, adopted skew, and equivalent years of 
record in the User Statistics table.  The Compute button must be 
pressed after User Statistics have been entered in order for the 
program to compute a frequency curve using the user statistics.   

As mentioned at the beginning of this example, the annual peak flows 
were based on daily averaged flows.  In order to compute an 
instantaneous peak flow frequency curve, a relationship between daily 
averaged flows and the corresponding instantaneous peak flows was 
developed.  This was done by plotting daily averaged flow and the 
corresponding instantaneous peak flow for selected flood events.  
Using this relationship, a Mean of 3.731 was computed and entered in 
the User Statistics table and the analytical analysis was recomputed.   
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Figure B-58 shows that the frequency curve computed from the user-
adjusted statistics is added to the graph.  Figure B-58 also shows that 
the user does not have to enter values for all statistics in order for the 
program to compute a user-adjusted frequency curve.  The program 
will use statistics computed from the systematic and historic data if the 
statistics are not defined in the User Statistics table.  In this example, 
the program used the computed statistics for standard deviation, 
adopted skew, equivalent years of record and the user-defined mean 
of 3.731 when computing the user-adjusted frequency curve.  

Figure B-58.  Plot Tab with User-Adjusted Statistics and Frequency Curves for Test 
Example 8. 

 

Select the Tabular Results tab to see information for both the 
computed and user-adjusted frequency curves.  As shown in Figure B-
59, the Frequency Curve table contains the percent chance 
exceedance, computed curves (Log-Pearson III results), and the 
Confidence Limits (5% and 95% chance exceedance curves) for both 
the computed and user-adjusted statistics.  
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On the bottom left-hand side of the results tab is a table of System 
Statistics for the observed station data (mean, standard deviation, 
station skew) and regional adjustment (regional skew, weighted skew, 
and adopted skew).  Also on the bottom right-hand side of the results 
tab is a table of Number of Events showing the number of historic 
events used in the analysis, number of high outliers found, number of 
low outliers, number of zero or missing data years, number of 
systematic events in the gage record, and the historic record length (if 
historic data was entered). 

Figure B-59.  General Frequency Editor with Results Tab Selected for Test Example 8. 

 

In addition to the tabular results, a graphical plot of the computed 
frequency curves can be obtained by pressing the Plot Analytical 
Curve button at the bottom of the analysis window.  A plot of the 
results for this test example is shown in Figure B-60. 
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Figure B-60.  Plot of the Frequency Curve Results for Test Example 8. 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-61 
is the report file for test example 8. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-61.  Report File for Test Example 8. 
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Example 9: General Frequency – Graphical Analysis 

This example demonstrates how to create a Graphical Analysis within a 
General Frequency analysis.  The data for this example is from an 
analysis that computed regulated flow for the Rio Grande at 
Albuquerque.  The data includes regulated daily average flows from 
upstream reservoirs routed downstream to Albuquerque.  The period 
of record used for this example is from 1974 to 2002.  To view the 
data, right-click on the data record labeled “Annual Daily Average 
Peak Flows Rio Grande at Albuquerque” in the study explorer and 
then select Tabulate.  The data will appear as shown in Figure B-62. 

 
Figure B-62.  Tabulation of the Peak Stage Data for Example 9. 
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To plot the data for this example, right-click on the data record and 
then select Plot.  A plot of the data will appear as shown in Figure B-
63. 

Figure B-63.  Plot of Data for Example 9. 

 

A General Frequency analysis has been developed for this example.  
To open the General Frequency analysis editor for test example 9, 
either double-click on the analysis labeled REGULATED FLOW RIO 
GRANDE TEST 9 from the study explorer, or from the Analysis menu 
select open, then select REGULATED FLOW RIO GRANDE TEST 9 
from the list of available analyses.  When test 9 is opened, the General 
Frequency analysis editor will appear as shown in Figure B-64. 
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Figure B-64.  General Frequency Analysis Editor for Test Example 9. 

 

Shown in Figure B-64 are the general settings that were used to 
perform this frequency analysis.  For this analysis, the Use Log 
Transform option was selected, the Weibull plotting position method 
was selected, the default Confidence Limits were selected, and no 
modification was made to the Time Window.   
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Shown in Figure B-65 is the General Frequency analysis editor with the 
Options Tab selected.  Features on this tab include the Low Outlier 
Threshold, an option to use Historic Data, an option to override the 
default Frequency Ordinates, and Output Labeling.  All defaults 
settings were selected for this example.     

Figure B-65.  General Frequency Analysis Editor with Options Tab Shown for Test 
Example 9. 

 

Once all of the General and Optional settings are set or selected, the 
user can choose to perform an Analytical or Graphical analysis.  In this 
example, a graphical analysis was performed.  Shown in Figure B-66 is 
the Graphical analysis tab.  As shown, a graph containing the 
systematic data and graphical curve is on the left side and a table 
containing the user-entered frequency curve is on the right side of the 
window.  The user must manually enter a peak value for each 
frequency ordinate and then press the Compute button before the 
program plots the graphical curve.  For this example, a reservoir 
model was used to route synthetic hydrographs through the reservoir 
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network upstream of Albuquerque using current operating criteria.  
This was done for the 0.2, 0.5, 1.0, 2.0, 10, 20, and 50 percent 
events.  Output from the model was input into the Frequency 
Ordinates table.  For the more frequent events (10 year and below), 
the graphical curve was fit to the data visually.  This example shows 
how a reservoir network can influence the frequency curve.  Notice 
how the frequency curve is flat for the 20 through the 1 percent 
chance events.  The reservoir network is able to control flooding in this 
range.  This example also shows that as flood events become larger, 
the reservoir network has less influence on controlling downstream 
flooding.  

Figure B-66.  Graphical Tab Shown for Test Example 9. 

 

A graphical plot of the graphical frequency curve can be obtained by 
pressing the Plot Graphical Curve button at the bottom of the 
analysis window.  A plot of the results for this test example is shown in 
Figure B-67. 
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Figure B-67.  Plot of the Frequency Curve Results for Test Example 9. 

 

The graphical results can be sent to the printer or the windows 
clipboard for transfer into another piece of software.  To print the 
graphical results, first bring up the graphical plot and then select Print 
from the File menu.  To send the graphic to the windows clipboard, 
select Copy to Clipboard from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-68 
is the report file for test example 9. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, and additional calculations needed.  
Different types and amounts of information will show up in the report 
file depending on the data and the options that have been selected for 
the analysis. 
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Figure B-68.  Report File for Test Example 9. 
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Example 10: Volume-Duration Frequency Analysis, Maximum 
Flows 

This example demonstrates how to perform a Volume-Duration 
Frequency analysis for maximum flows.  The data for this example was 
derived from an analysis where a time-series of daily average 
unregulated flows were computed for the Rio Grande at Albuquerque.  
The period of record for this example is from 1941 to 2002.  To view 
the data, right-click on the data record labeled “Rio Grande at 
Albuquerque UNREGULATED” in the study explorer and then select 
Plot.  The data will appear as shown in Figure B-69. 

Figure B-69.  Plot of Daily Average Flow for Example 10. 

 

A Volume-Duration Frequency analysis has been developed for this 
example.  To open the Volume-Duration Frequency analysis editor for 
test example 10, either double-click on the analysis labeled RIO 
GRANDE AT ALBUQUERQUE UNREGULATED FLOW TEST 10 from 
the study explorer, or from the Analysis menu select open, then 
select RIO GRANDE AT ALBUQUERQUE UNREGULATED FLOW 
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TEST 10 from the list of available analyses.  When test 10 is opened, 
the Volume-Duration Frequency analysis editor will appear as shown in 
Figure B-70. 

Figure B-70.  Volume-Duration Frequency Analysis Editor for Test Example 10. 

 

Shown in Figure B-70 are the general settings that were used to 
perform this frequency analysis.  For this analysis, the Use Log 
Transform option was selected, the Weibull plotting position method 
was selected, Analyze Maximums was selected, the Calendar Year 
option was selected, and no modification was made to the Time 
Window.   

Shown in Figure B-71 is the Volume-Duration Frequency analysis 
editor with the Options Tab selected.  Features on this tab include an 
option to override the default Flow-duration values, an option to 
override the default Frequency Ordinates, and Output Labeling.  
Both the flow-duration and frequency ordinate tables were modified.     
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Figure B-71.  Options Tab Shown for Test Example 10. 

 

Once all of the General and Optional settings are set or selected, the 
user can extract the volume-duration data from the time-series of 
daily flows.  Select the Duration Data tab and press the Extract 
Volume-Duration Data button at the bottom of the table.  The table 
should then fill with the flow-duration values, as shown in Figure B-72. 
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Figure B-72.  Volume-Duration Data Table for Test Example 10. 

 

Once the data has been extracted, the user must choose to perform an 
Analytical or Graphical analysis.  In this example, an analytical 
analysis was performed.  Shown in Figure B-73 is the Settings tab for 
the analytical analysis.  As shown, the distribution selected for this 
example is LogPearsonIII.  The Skew option was set to Use Station 
Skew and the Do Not Compute Excepted Probability option was 
selected.  
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Figure B-73.  Settings Tab Shown for Test Example 10. 

 

Press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab within the analytical analysis.  The results table 
should look Figure B-74.  The top portion of the results table contains 
the percent chance exceedance for all durations (the report contains 
confidence limits).  The bottom portion of the results table contains the 
statistics for all duration. 
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Figure B-74.  Tabular Results Tab for Test Example 10. 

 

As shown in Figure B-75, the Plot tab contains a graph of the 
systematic data and the computed frequency curves.  Notice how 
some of the frequency curves look like they might cross if the lines 
were extended.  The Statistics tab can be used to modify the 
computed statistics to ensure that the frequency curves are consistent.   
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Figure B-75.  Plot Tab for Example 10. 

 

For this example, the standard deviation and the adopted skew values 
were modified to make sure the volume-duration frequency curves 
were consistent.  As shown in Figure B-76, the check boxes next to 
mean, standard deviation, and adopted skew were checked and then 
user-adjusted statistics were entered into the table for all durations.  
The Compute button must be pressed after adjusted statistics have 
been entered in order for the program to recompute the frequency 
curves using the user-adjusted statistics.  Figure B-77 shows the Plot 
tab after the user-adjusted statistics were entered on the Statistics 
tab.  Results on the Tabular Results tab will also update when user-
adjusted statistics are entered on the Statistics tab.    
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Figure B-76.  Statistics Tab for Test Example 10. 
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Figure B-77.  Plot Tab for Example 10 After the Statistics were Adjusted on the Statistics 
Tab.  

 

In addition to the Tabular Results and Plot tabs, graphical plots can be 
opened by selecting the Plot Duration Data or Plot Analytical 
Curve buttons at the bottom of the analysis window.  A plot of the 
results for this test example is shown in Figure B-78. 
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Figure B-78.  Plot of the Frequency Curve Results for Test Example 10. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-79 
is the report file for test example 10. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-79.  Report File for Test Example 10. 
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Example 11: Volume-Duration Frequency Analysis, Minimum 
Flows 

This example demonstrates how to create a low flow Volume-Duration 
Frequency analysis.  The data for this example was downloaded from 
the USGS.  It is comprised of daily average flow for the Chattahoochee 
River at Cornelia, Georgia.  Drought conditions were occurring in the 
region at the time of this analysis.  Among other things, a low flow 
analysis can be used to determine the severity of a drought.  The 
period of record for this example is from 1957 to 2007.  To view the 
data, right-click on the data record labeled “CHATTAHOOCHEE 
RIVER-CORNELIA, GA-FLOW” in the study explorer and then select 
Plot.  The data will appear as shown in Figure B-80.   

Figure B-80.  Plot of Daily Average Flow for Example 11. 

 

A Volume-Duration Frequency analysis has been developed for this 
example.  To open the Volume-Duration Frequency analysis editor for 
test example 11, either double-click on the analysis labeled LOW 
FLOW VOLUME-DURATION ANALYSIS TEST 11 from the study 
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explorer, or from the Analysis menu select open, then select LOW 
FLOW VOLUME-DURATION ANALYSIS TEST 11 from the list of 
available analyses.  When test 11 is opened, the Volume-Duration 
Frequency analysis editor will appear as shown in Figure B-81. 

Figure B-81.  Volume-Duration Frequency Analysis Editor for Test Example 11. 

 

Shown in Figure B-81 are the general settings that were used to 
perform this frequency analysis.  For this analysis, the Use Log 
Transform option was selected, the Weibull plotting position method 
was selected, Analyze Minimums was selected, and the Calendar 
Year option was selected.  The Calendar Year option was selected 
because low flows are possible in late September, early November.  
Starting the year on January 1 minimizes the possibility of using the 
same low flow event in multiple years.  An end date of 31 December 
2007 was entered in the Time Window Modification.  This end date 
was specified because not all the data for the summer of 2008 was 
available at the time of the analysis.    
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Shown in Figure B-82 is the Volume-Duration Frequency analysis 
editor with the Options Tab selected.  Features on this tab include an 
option to override the default Flow-duration values, an option to 
override the default Frequency Ordinates, and Output Labeling.     

Figure B-82.  Options Tab Shown for Test Example 11. 

 

Once all of the General and Optional settings are set or selected, the 
user can extract the volume-duration data.  Select the Duration Data 
tab and press the Extract Volume-Duration Data button at the 
bottom of the table.  The table should then fill with the flow-duration 
values, as shown in Figure B-83. 
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Figure B-83.  Volume-Duration Data Table for Example 11. 

 

Once the data has been extracted, the user must choose to perform an 
Analytical or Graphical analysis.  In this example, an analytical 
analysis was performed.  Shown in Figure B-84 is the Settings tab for 
the analytical analysis.  As shown, the distribution selected for this 
example is LogPearsonIII.  The Skew option was set to Use Station 
Skew and the Do Not Compute Excepted Probability option was 
selected.  
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Figure B-84.  Settings Tab Shown for Test Example 11. 

 

Press the Compute button to perform the analysis.  Once the 
computations have been completed, a message window will pop-up 
stating Compute Complete.  Close this window and then select the 
Tabular Results tab within the analytical analysis.  The results table 
should look Figure B-85.  The top portion of the results table contains 
the percent chance exceedance for all durations (the report contains 
confidence limits).  The bottom portion of the results table contains the 
statistics for all duration. 
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Figure B-85.  Tabular Results Tab for Test Example 11. 

 

As shown in Figure B-86, the Plot tab contains a graph of the 
systematic data and the computed frequency curves.  Notice how 
some of the frequency curves look like they might cross if the lines 
were extended.  The Statistics tab can be used to modify the 
computed statistics to ensure that the frequency curves are consistent.   

Note: the volume-duration frequency analysis will identify low and 
high outliers using guidelines in Bulletin 17B; however, the program 
will not remove outliers and recompute the statistics.   
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 Figure B-86.  Plot Tab for Test Example 11. 

 

For this example, the standard deviation and the adopted skew were 
modified to make sure the volume-duration frequency curves were 
consistent.  As shown in Figure B-87, the check boxes next to mean, 
standard deviation, and adopted skew were checked and then user-
adjusted statistics were entered into the table for all durations.  The 
Compute button must be pressed after adjusted statistics have been 
entered in order for the program to recompute the frequency curves 
using the user-adjusted statistics.  Figure B-88 shows the Plot tab 
after the user-adjusted statistics were entered on the Statistics tab.  
Results in the Tabular Results table will also update when user-
adjusted statistics are entered on the Statistics tab.    
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Figure B-87.  Statistics Tab for Test Example 11. 
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Figure B-88.  Plot Tab for Test Example 11. 

 

In addition to the Tabular Results and Plot tabs, graphical plots can be 
opened by selecting the Plot Duration Data or Plot Analytical 
Curve buttons at the bottom of the analysis window.  A plot of the 
results for this test example is shown in Figure B-89. 
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 Figure B-89.  Plot of the Frequency Curve Results for Test Example 11. 

 

The tabular and graphical results can be sent to the printer or the 
windows clipboard for transfer into another piece of software.  To print 
the tabular results, select Print from the bottom of the analysis 
window.  To send the tabular results to the windows clipboard, 
highlight the data you want to send to the clipboard and then press 
the Control-C key sequence.  To print the graphical results, first bring 
up the graphical plot and then select Print from the File menu.  To 
send the graphic to the windows clipboard, select Copy to Clipboard 
from the File menu. 

In addition to the tabular and graphical results, there is a report file 
that shows the order in which the calculations were performed.  To 
review the report file, press the View Report button at the bottom of 
the analysis window.  When this button is selected a text viewer will 
open the report file and display it on the screen.  Shown in Figure B-90 
is the report file for test example 11. 

The report file contains a listing of the input data, preliminary results, 
outlier and historical data tests, additional calculations needed, and 
the final frequency curve results.  Different types and amounts of 
information will show up in the report file depending on the data and 
the options that have been selected for the analysis. 
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Figure B-90.  Report File for Test Example 11. 
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A P P E N D I X  C   

Customizing Plots 

The graphic customizing capabilities within HEC-SSP are very powerful, 
but are also somewhat complex to use.  The software used in 
developing the plots in HEC-SSP is the same code that was used for 
developing graphics in HEC-DSSVue and several other HEC software 
programs.  This appendix documents how to customize plots in a 
generic manner.  The example plots in this section are from HEC-
DSSVue, not HEC-SSP.  Figure C-1 shows a sample plot illustrating 
raw and revised data for stage and flow at a location called Beech 
Creek Station.   

Figure C-1.  Plot Window 
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Menu Bar
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ZoomTool
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With the Pointer Tool , you can access shortcut menus that allow 
you to customize features of your plots using the plot window’s editing 
tools.  The following sections discuss these tools in detail.  The Zoom 

Tool  allows you to view data closely at a specific time.  To zoom 
in, select the Zoom Tool then “draw” a rectangle around the section of 
the plot you wish to enlarge.  To zoom out, right-click anywhere in the 
display area using the Zoom Tool.   

If you wish to keep the plot window on top of your desktop so you can 
view it while working in other windows, you can select Always on Top 
from the View menu.  A check mark indicates this option is active. 

Customizing Plots: Overview 

Plot properties editors allow you to configure default properties for 
plots as well as customize individual plots.  Figure C-2 shows the 
features of plots you can configure.   

 

 

  
Figure C-2.      Configurable Features of Plots   
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Title: Optionally, you can add a title to the plot display. 

Panel Background Color: You can specify the background color of 
the plot window (light grey is the default). 

Curve/Line Properties: You can choose the line and point styles, 
add labels, and specify symbols to indicate quality. 

Marker:  You can add markers on the X and Y axes and customize the 
appearance of these markers. 

Spacer:  You can specify the distance between viewports, between a 
viewport and the legend, and the width of side margins. 

Callout: You can add descriptive callouts at specific points along a 
line. 

Viewport: You can customize the border around the viewport, the 
background color and pattern, and the appearance of gridlines.  You 
can also specify the number, size, and content of viewports.  

Label: You can add borders and backgrounds to axis and legend 
labels. 

Axis:  You can specify either a linear or log axis type, specify the axis 
scale, and customize tic marks. 

Legend: You can add titles to the plot legend and specify whether the 
legend appears below or to the right of the plot. 

 

Using Plot Editors 

Several different editing interfaces allow you to either set defaults for 
all plots or specify properties of individual plots.  Figure C-3 shows 
three examples: the Default Plot Properties Editor, the Plot Properties 
Editor, and the Viewport Properties Editor.   
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Figure C-3. Examples of Plot Properties Editors 

As Figure C-3 illustrates, the editors can look almost identical to each 
other.  Therefore, it is necessary for you to understand what the 
editors do and how to access the correct editor for your purpose. 
 

Setting Defaults vs. Customizing Individual Plots 

Plot editors and tools fall into two categories in terms of function: 
either they allow you to specify defaults for all plots you create, or 
they allow you to customize individual plots.   

Across these two functional categories, the plot editors and tools either 
allow you to edit a variety of plot properties, or they can be specialized 
editors that allow you to edit a single property. 

To configure the default appearance of all plots, you need to use the 
Default Plot Properties Editor and Default Line Style Options 
Editor.  All settings you specify in these editors will apply to all new 
plots you open.  You can access these editors only from the Edit menu 
of plots.   

To customize individual plots, you can use the Plot Properties Editor 
and the Configure Plot Editor, both accessed from the Edit menu of 
a plot window.  Also, using right-click shortcut menus, you can access 
specialized editors for individual plot features.  The Viewport 
Properties Editor is an example of a specialized editor.  
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Additionally, once you have customized an individual plot, you can 
export its settings as a Template that you can apply to other plots.  
To create a template based upon a plot, you will use the Export 
Properties option in the File menu of the plot window. 

Likewise, you can import Templates to apply previously defined 
properties to an individual plot. To apply a template to a new plot, you 
will use the Import Properties option in the File menu of the new 
plot window. 
 

Accessing Editors  

You can access properties editors from shortcut menus (Figure C-4) 
and from the Edit menu in the plot window (Figure C-5).  

 

Figure C-4. Shortcut Menu 
 

Figure C-5. Edit Menu 

You will use these menus according to whether you are defining 
properties for an individual plot or setting default properties for all 
plots you create. 

Use shortcut menus to edit specific components of an individual plot.  
For example, if you want to edit axis label properties on a plot, right-
click on the axis label to access the shortcut menu for the label (Figure 
C-4), then select the Edit Properties command for the label. 

Use the Edit menu of a plot window to access the Plot Properties 
Editor, Default Line Style Options Editor, Default Plot Properties 
Editor, and Configure Plot Editor.  These editors, discussed below, 
allow you to edit a variety of plot properties.   
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Recognizing Plot Editors and Tools 

Following is an overview of the editing tools that allow you to 
customize plots.  Later sections provide more detailed instructions on 
editing specific plot properties using these tools. 

 
Plot Properties Editor 

The Plot Properties Editor (Figure C-6) is accessed from the Edit 
menu of a plot, and allows you to configure multiple display properties 
of an individual plot, including the Curves, Axis, the plot Title, 
Gridlines, border and background Patterns of the viewport, Marker 
Lines, Legend, and properties of the plot window panel.   

 

Figure C-6. Plot Properties Editor 

When you customize properties of a plot using the Plot Properties 
Editor, your changes apply only to that individual plot unless you 
export the plot’s properties. 
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To access the Plot Properties Editor, from the Edit menu, choose Plot 
Properties. 

Individual Plot Property Editors 

When you want to edit a specific property of a plot without launching 
the Plot Properties Editor, you can use individual plot property editors 
instead.  These individual plot property editors correspond to the tabs 
of the Plot Properties Editor.   

To access an individual plot property editor, right-click on the element 
you want to edit, and then select Edit Properties from the shortcut 
menu. 

For example, if you right-click inside the 
gridded plot area, called the viewport, you 
will see the Viewport shortcut menu (Figure 
C-7).  When you choose Edit Properties, the 
Viewport Properties Editor will open (Figure 
C-8). 

The Viewport Properties Editor lets you 
edit only properties associated with the 
viewport, using the same Patterns and 
Gridlines tabs as appear in the Plot Properties Editor. 

 

Figure C-8. Viewport Properties Editor 

Other individual properties editors are the Title Properties Editor, 
Axis Properties Editor, Curve Properties Editor, Label Properties 

 

Figure C-7. 
Viewport Shortcut 
Menu 
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Editor, Marker Properties Editor, Legend Properties Editor, and 
the Spacer Properties Editor.  

The only plot property you cannot edit using an individual property 
editor is the color of the plot window panel.   

Configure Plot Editor 

The Configure Plot Editor (Figure C-9) is accessed from the Edit 
menu of a plot and allows you to customize the layout of an individual 
plot.  You can add and remove axes and add, remove, arrange the 
order of, and set the weight of viewports in the plot window. 

 

Figure C-9. Configure Plot Editor 

 

When you customize the layout of a plot using the Configure Plot 
Editor, your changes apply only to that individual plot unless you 
export the plot’s properties. 

To access the Configure Plot Editor, from the Edit menu click 
Configure Plot Layout.  
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Default Line Style Options Editor 

With the Default Line Style Options editor (Figure C-10), you can 
specify the default line and fill styles, as well as labels, used across all 
plots for specific parameters. 

   

 

Figure C-10. Default Line Style Options Editor 

To access the Default Line Style Options Editor, from the Edit menu, 
choose Default Line Styles. 
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 Default Plot Properties Editor 

The Default Plot Properties Editor (Figure C-11) allows you to 
configure the default display properties of all plots you create.  
Properties you can configure include the border and background of the 
Viewport, the Title, Grid lines, Labels, Axis, Marker Lines, Legend, and 
miscellaneous properties of the plot window panel. 

 

Figure C-11. Default Plot Properties Editor 

When you customize plot properties using the Default Plot Properties 
Editor, your changes apply to all plots you create. 

To access the Default Plot Properties Editor, from the Edit menu, click 
Default Plot Properties. 
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Customizing Plot Titles 

You can add titles to individual plots and configure default properties 
for all plot titles. 

To add or edit a title on an individual plot, you can either: 

• From the Edit menu, choose Plot Properties.  When the Plot 
Properties Editor opens, select the Title tab.   

Or 

• Right-click in the blank area 
above the plot (below the 
menu bar) with the Pointer 

Tool , and then select Edit 
Properties from the shortcut 
menu (Figure C-12).  The Title 
Properties Editor will open. 

To specify the appearance of titles for all of your plots, from the Edit 
menu, click Default Plot Properties, then select the Title tab of the 
Default Plot Properties editor. 

Whether you are using the Plot Properties Editor, the specialized Title 
Properties Editor, or the Default Plot Properties Editor, the worksheet 
for editing plot title properties is the same.   

Figure C-13 shows the Title Properties Editor.  This editor contains the 
same fields as the Title tab of the Plot Properties Editor and the Default 
Plot Properties Editor. 

 

 

Figure C-12. Shortcut 
Menu-Edit Properties 
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Figure C-13. Edit Title Properties 

To specify a title for the plot, select Custom.   In the Title panel, type 
the title you want in the Title box.  From the Alignment list, select the 
alignment for the plot title.  Your choices are Center, Left, or Right.  
From the Size list, select the text size for the title.  The Sample box 
provides a preview of your plot title.  The Border group allows you to 
add a border around the title.  You can specify the Color, line Style, 
and line Weight.  The Background group lets you add a background 
Color and/or Pattern behind your plot title.  Click Apply to save your 
changes and continue adjusting the appearance of the title.  Click OK 
when you are finished. 

Customizing Curves  

You can customize line and point styles, add labels, and specify 
symbols to indicate data quality in your plots.  Additionally, you can 
specify the parameter-based default curve styles used across all plots. 

There are three different ways to edit plot curves, depending on 
whether you wish to customize one or more curves in an individual 
plot or specify defaults for all plots. 
 

Customizing Curves in Individual Plots 

To customize all curves in an individual plot, from the Edit menu, 
choose Plot Properties.  When the Plot Properties Editor opens, 
select the Curves tab.   

To customize a specific 
curve in an individual 
plot, right-click on the line 
or curve you wish to edit 

with the Pointer Tool , 
then select Edit 
Properties from the 
shortcut menu (Figure C-
14).  The Edit Curve 
Properties Editor will 
open. 
 

The Curves tab of the Plot Properties Editor and the Edit Curve 
Properties Editor are nearly identical with two exceptions:   

First, at the top of the Curves tab of the Plot Properties Editor, there is 
a list of all curves contained in the plot.  In contrast, when you open 

 

Figure C-14. Shortcut Menu--Curve 
Properties 
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the Edit Curve Properties Editor, it deals only with the curve you 
selected when you launched the editor; therefore, there is no list of 
curves. 

Second, the Curves tab of the Plot Properties Editor has a Remove Line 
button, whereas the Edit Curve Properties Editor does not. 

Despite these differences, both the Edit Curve Properties Editor and 
the Curves tab of the Plot Properties Editor allow you to edit Style, 
Label, and Quality Symbols.  (You can edit Quality Symbols only if the 
plot has quality set for its data.)    

Specifying Parameter-Based Default Curve Styles 

To specify parameter-based default curve styles for all of your plots, 
from the Edit menu, click Default Line Styles.  The Default Line Styles 
Options Editor gives you a way to edit line styles from the Line Styles 
box (Figure C-15).  You can specify the default, parameter-based 
curve styles used for all plots.   

 

Figure C-15. Default Line Style Options Editor: Detail of Line 
Styles Box 

The Line Styles box displays typical data types with default line and fill 
styles predefined. 

You can edit all of these fields, change default line and fill styles for 
existing types, and add new data types to the list.  At this time, there 
is no delete option. 
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Name and Parameter 
To edit an existing name or parameter, highlight it, and then enter the 
new name or parameter.  The name corresponds to the “C” part of 
HEC-DSS pathnames.  The parameter associates data sets to be 
plotted in the same viewport.  For example, FLOW-IN and FLOW-OUT 
are different “C” parts, but both are FLOW data sets and are to be 
plotted in the same viewport. 

Type 
To change the data type associated with a Name and Parameter, click 
the down-arrow and select from the list. 

Line Number 
The Line Number column indicates the number of lines associated with 
a data type.  See Adding New Data Styles below. 

Line/Fill 
The Line/Fill property determines how curves associated with a 
particular name/parameter/type combination will appear in all plots.  
To specify the Line/Fill, select the row, and then customize the Line 
and Point properties.   

Adding New Data Styles 
To add a new data type: 

From the File menu of the Default Line Style Options Editor, 
choose New.  The New Data Type dialog box will open (Figure C-16). 

Select a parameter from the 
Parameter list.  

Enter a name in the Name box. 

From the Type list, select the 
data type. 

In the Number of Lines box, 
enter the number of curves you 
want to add for this new data 
type. 

If you want to reverse the Y-
axis, select Y Axis Reversed. 

Click OK to close the dialog box. 

The Line Styles box will now display the new data type you have 
added, repeated as many times as you specified in the Number of 
Lines box (reflected in the Line Number column).  You can customize 
the new data types as described above. 

 

Figure C-16. New Data Type 
Dialog Box 
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To save your changes, from the File menu, click Save.  To close the 
Default Line Styles Options Editor, from the File menu, click Close.  

Specifying Line and Point Styles of Curves 

Figure C-17 shows the curve Line and Point Style worksheet.  This 
worksheet is available from the Curves tabs of the Edit Curve 
Properties Editor, the Plot Properties Editor, and the Default Line 
Styles Options Editor.   

 

Figure C-17. Curve Line and Point Style Editing 
Interface 

The Style tab has three main groups, Line, Point, and Missing Value 
Symbols which allow you to customize line and point styles, and a 
symbol that can be shown for missing values.  Beneath the Point 
group, the Sample box provides a preview of the way your line and 
point choices will look.    

To define line styles for curves: 

1. In the Line group, click Custom. 

2. Select the color, style, and weight you want for the line.   
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3. You can display lines with fill above or below, or without fill.  
Figure C-18 shows a plot with line fill below, whereas Figure C-
19 shows the same plot without line fill. 

4. Select if you want the curve drawn in a stair-stepped style, or 
linear with a line drawn directly between each point. 

5. Select if you want a line drawn to interpolate where there are 
missing values. 

 

Figure C-18. Plot with Line 
Fill 

 

Figure C-19. Plot without 
Line Fill 

To define point styles for curves: 

1. In the Point group, click Custom. 

2. Choose the Style, Line Color, and Fill 
Color you want.  The Line Color is 
the “border” around the point 
symbol, whereas the Fill Color is the 
color inside the point symbol.  
Figure C-20 shows an example of a 
dark line color and a light fill color. 

3. In the Size box, specify the size of 
the point (in pixels) either by 
selecting a size from the list or by 
typing in a number from 1-45. 

4. Automatic Symbol Drawing allows the plot to compute how to 
draw the points so they do not overlap. As you zoom in the plot 
will draw more points because you are increasing the distance 
between points. This will continue until all points on the curve 
are drawn.  

5. Draw Symbols on Data Points allows you to specify how to draw 
the points so they don’t overlap.  If you set the Skip box to one 
(1), then it will draw one point, skip the next, then draw the 
third, etc.  The Offset box allows you to say how many points 
on the curve to initially skip before drawing points. 

 

 

Figure C-20 Example 
Line and Fill Colors 
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To define missing value symbols for curves: 

1. In the Missing Value Symbol group, click Custom. 

2. Choose the Style, Line Color, and Fill Color you want.  The Line 
Color is the “border” around the point symbol, whereas the Fill 
Color is the color inside the point symbol. 

3. In the Size box, specify the size of the point (in pixels) either 
by selecting a size from the list or by typing in a number from 
1-45. 

4. This will place the selected symbol on each missing value. 

Customizing Curve Labels 

Figure C-21 shows the curve Label worksheet, available from the 
Curves tabs of the Edit Curve Properties Editor, the Plot Properties 
Editor, and the Default Line Styles Options Editor.  This worksheet 
allows you to customize curve labels. 
 

 

Figure C-21. Curve Label Editing Interface 

To customize curve labels: 

1. Select Custom. 

2. Enter the text you want to appear in the curve label in the 
Label Text box. 
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3. In the Alignment list, click Left, Center, or Right to select the 
alignment of the curve label. 

4. To set the position of the label, from the Position list, click 
Above, Center, or Below. 

The Sample box provides a preview of the way your labels will look.    

Customizing Curve Quality Symbols 

Figure C-22 shows the curve Quality Symbols worksheet, available 
from the Curves tabs of the Edit Curve Properties Editor, the Plot 
Properties Editor, and the Default Line Styles Options Editor.  This 
worksheet allows you to customize curves for plots that have quality 
set for their data. 

 

Figure C-22. Curve Quality Symbols Editing Interface 
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To customize quality symbols: 

1. Choose Custom. 

2. Select a symbol Style, Line Color, Fill Color, and Size for each 
quality of data. 

Customizing Viewport Properties 

Viewports are the gridded areas in the plot window that contain plot 
curves.  You can customize the border around the viewport, the 
background color and pattern, and the appearance of gridlines. 
 

Customizing Viewport Borders and Background  

To customize the borders and backgrounds of viewports in an 
individual plot, you can either: 

From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Patterns tab.   

Or 

Right-click in a blank area inside the 

viewport with the Pointer Tool , and 
then select Edit Properties from the 
shortcut menu (Figure C-23).  When the 
Viewport Properties Editor opens, select 
the Patterns tab. 

To specify the default border and 
background of viewports for all of your 
plots, from the Edit menu, click Default Plot Properties.  When the 
Default Plot Properties Editor opens, choose the Viewport tab. 

Figure C-24 shows the Edit Viewport Properties Editor with the 
Patterns tab selected.  This worksheet, accessed from the shortcut 
menu, contains the same items as the Patterns tab of the Plot 
Properties Editor and the Viewport tab of the Default Plot Properties 
Editor. 

 

Figure C-23. Shortcut 
Menu--Viewport 
Properties 
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Figure C-24. Viewport Properties Editor--
Patterns Tab 

The Patterns (or Viewport) tab has two main groups, Border and 
Background, which allow you to customize border and background of 
the viewport, respectively.  Beneath the Border group, the Sample box 
provides a preview of the way the viewport border and background will 
look.    

1. Select Custom in the Border group and choose the Color, Style, 
and Weight for the border you want to appear around the plot 
viewport. 

2. Select Custom in the Background group and choose the Color 
and Pattern you want for the background. 

Click Apply to save your changes and continue adjusting the 
appearance of the border and background.  Click OK when you are 
finished. 

Customizing Viewport Gridlines 

To customize gridlines of viewports in an individual plot, you can 
either: 

From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Gridlines tab.   

Or 
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Right-click in a blank area inside the viewport with the Pointer Tool 

, and then select Edit Properties from the 
shortcut menu (Figure C-25).  When the 
Viewport Properties Editor opens, select the 
Gridlines tab. 

To specify viewport gridlines for all of your 
plots, from the Edit menu, select Default 
Plot Properties.  When the Default Plot 
Properties Editor opens, choose the Grids 
tab. 

Figure C-26 shows the Viewport Properties Editor with the Gridlines tab 
selected.  This worksheet, accessed from the shortcut menu, contains 
the same items as the Gridlines tab of the Plot Properties Editor and 
the Grids tab of the Default Plot Properties Editor. 

By default, the plot viewport displays gridlines only for the Major X 
Grid and Major Y Grid.  The default color is light gray.  To change the 
appearance of Major X and Y gridlines, select Custom and make your 
selections for Color, Style, and Weight. 

By default, the Minor X Grid and Minor Y Grid are set to None and do 
not display in the plot viewport. If you want to display gridlines for the 
Minor X Grid and Minor Y Grid, select Custom and make your 
selections for Color, Style, and Weight. 

Click Apply to view your changes without closing the editor.  Click OK 
when you are finished. 

 

 

 

Figure C-25. 
Shortcut Menu--
Viewport Properties 
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Figure C-26. Viewport Properties Editor--
Gridlines Tab 

Adding and Customizing Marker Lines 

You can add marker lines on your plot’s X and Y axes and customize 
the appearance of these markers.   
 

Adding Markers 

To add a marker: 

Right-click on the location in the plot where you want the marker to 
appear. 

From the Viewport shortcut menu (Figure C-27), point to Add Marker, 
and then click either On X-Axis 
or On Y-Axis. 

The marker will now appear in 
the plot. 

 
 

 

Figure C-27. Shortcut Menu: 
Add Marker 
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Deleting Markers 

To delete a marker line in a plot, right click 

on it with the Pointer Tool , and then 
click Delete from the Marker Line shortcut 
menu (Figure C-28). 

 
 

 

Customizing Markers 

To edit the properties of a marker in an individual plot, you can 
either: 

From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Marker tab.  This worksheet is available only if 
a marker exists in the plot.  Choose the marker you want to edit from 
the Marker Lines list. 

Or 

With the Pointer Tool , right-click on the marker you want to edit.  
From the Marker Line shortcut menu, select Edit Properties (Figure C-
28).  The Edit Marker Line Properties Editor will open. 

To specify the default appearance of markers for all of your plots, from 
the Edit menu, click Default Plot Properties.  When the Default Plot 
Properties Editor opens, choose the Marker Lines tab. 

The interfaces for the specialized Edit Marker Line Editor and the 
Default Plot Properties Editor are very similar.  However, the Plot 
Properties Editor interface differs in two ways.  First, the Marker 
worksheet is available only if a marker exists in the current plot.  
Second, at the top of the editing panel there is a Marker Lines list 
containing all markers that exist in the current plot.   

You can edit the line style and label of a marker using two editing 
tabs.  Figure C-29 shows the Edit Marker Line Properties Editor with 
the Style worksheet selected, while Figure C-30 shows the Label/Value 
worksheet.  The Marker Line tabs in the Plot Properties Editor and the 
Default Plot Properties Editor share the same two worksheets. 
 

 

Figure C-28. Shortcut 
Menu—Marker Line 
Properties 
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Figure C-29. Marker Line 
Properties Editor—Style Tab 

 

Figure C-30. Marker Line 
Properties Editor—Label/Value 
Tab 

To edit the line style for markers: 

1. Select the Style tab. 

2. Choose Custom. 

3. Select the Color, Style, and Weight for the marker line. 

4. You can display marker lines with fill Above or Below, or 
without fill.  Figure C-31 shows 
a plot with line Fill Above and a 
hatched pattern selected. 

The Sample box provides a preview of 
the way the marker line will look.    

Click Apply to save your changes 
without closing the editor.   

To add a label to a marker line: 

1. Select the Label/Value tab. 

2. Choose Custom. 

 

Figure C-31. Marker 
Line with Fill Above 
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3. In the Label Text box, enter the text you want to appear in the 
label. 

4. From the Alignment list, select the justification of the label--
Left, Center, or Right. 

5. To set the position of the label, from the Position list, select 
either Above, Center, or Below. 

6. For the Date value, enter the date in 
the format DDMMYYYY (e.g., 
21Dec1993).  You can also click the 

 button to access the Calendar 
Tool (Figure C-32) to select the date. 

7. For the Time value, enter the time in 
24-hour military format (e.g., for 
5:08 pm, enter “1708”). 

The Sample box provides a preview of the 
way the marker line will look.    

Click Apply to save and view your changes 
without closing the editor.  Click OK when 
you are finished editing marker line 
properties. 
 

Editing Callouts 

You can add descriptive callouts at specific 
points along a curve (Figure C-33).  To do 
this: 

Right-click on the location on the curve where 
you want the callout to appear.  

From the shortcut menu (Figure C-34), point 
to Add Callout. 

In the Add Callout dialog 
box (Figure C-35), enter 
the text you want to 
appear in the callout, and 
then click OK. 

 

Figure C-32. 
Calendar Tool 

 

Figure C-33. 
Callout 

 

Figure C-34. Shortcut Menu: Add 
Callout 
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To hide all callouts in a plot, right-click on a curve in the plot.  From 
the shortcut menu, 
click Hide Callouts. 

Once you have hidden 
callouts, Hide Callouts 
in the shortcut menu 
changes to Show 
Callouts, allowing you 
to return callouts to 
the plot display. 

To permanently 
remove all callouts from the plot, right-click on a curve in the plot to 
access the shortcut menu, then click Clear Callouts. 
 

Customizing Axes 

You can choose either a linear or log axis type, specify the axis scale, 
modify tic marks, and customize axis labels.  Probability plots are 
generated for paired data sets with a type of “PROB”, and cannot be 
changed without changing the data type. 

Changing Axis Type 

By default, plots display using a linear scale (Linear Axis), in which the 
axis increases and decreases by x.  You can also use the log scale, 
which allows you to view curves that grow exponentially in a near 
straight line because the axis increases or decreases by the log (x).  
For example, you might wish to use the log scale when the axis has 
evenly-spaced major tics with values of 1,10,100,1000, and so on, 
such as in a performance history plot showing many years of data. 

To change the axis type of an 
individual plot, right-click on an 
axis.  From the Axis Tics shortcut 
menu, point to Set Axis Type, and 
then select the axis type from the 
submenu (Figure C-36).  
Depending on the axis type, you 
can click either Log Axis or Linear 
Axis. 

Specifying Axis Scale 

You can specify the axis scale and tic interval for individual plots.  To 
do this, you can either: 

 

Figure C-35  Add Callout Dialog Box 

 

Figure C-36. Shortcut Menu - 
Set Axis Type 
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From the Edit menu, click Plot Properties.  When the Plot Properties 
Editor opens, select the Axis tab.  From the Axis worksheet, select the 
axis you want to edit from the Axis list.  Once you have this set, click 
the Scale tab to access the Scale worksheet. 

Or 

Right-click on the axis with the Pointer 

Tool .  From the Axis Tics shortcut 
menu (Figure C-37), click Edit 
Properties.  When the Edit Axis 
Properties Editor opens, choose the 
Scale tab. 

Figure C-38 shows the Plot Properties 
Editor with the Axis tab selected and the Scale worksheet open.  The 
Axis worksheets of the Plot Properties Editor and the Default Plot 
Properties Editor are nearly identical, except for the Axis list on the 
Plot Properties Editor.  The Scale and Tics sub-worksheets are 
available in all three editors.  

 

Figure C-38. Plot Properties Editor--Scale Worksheet 

 

 

Figure C-37. Shortcut 
Menu—Axis Tics  
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With the Scale worksheet, you can specify the range of the scale, the 
amount of the scale that is visible, and the tic intervals.   

If the Auto box is checked, the plot will automatically select the scale.  
Otherwise, as you zoom in and out of the plot, its view values change 
while the minimum and maximum scale range values remain fixed: 

• Maximum: enter the value of the maximum range of the scale. 

• Minimum: enter the value of the minimum range of the scale. 

• View Maximum: enter the maximum visible range of the 
scale.  

• View Minimum: enter the minimum visible range of the scale.   

Tic intervals are the distances between tics on the axis scale:   

• Major Tic Interval:  specify the distance between each major 
tic. 

• Minor Tic Interval:  specify a value less than or equal to the 
major tic value. 

You can also choose to reverse the axis and invert the data by 
selecting Reverse (Invert) Axis.  If the data set is paired, you can 
switch the X and Y axis, so what is plotted on the X axis becomes 
plotted on the Y axis instead. 

Click Apply to save and view your changes without closing the editor.   

Click OK to save your changes and close the editor. 

Modifying Tic Marks 

You can modify the color of tic marks, choose whether or not major 
and minor tic marks display, and specify whether labels display.  

To modify tic marks in an individual plot, you can either: 

• From the Edit menu, click Plot Properties.  When the Plot 
Properties Editor opens, select the Axis tab.   From the Axis 
worksheet, select the axis you want to edit from the Axis list.  
Once you have this set, choose the Tics tab to set tic marks. 

Or 

• Right-click on the axis with the Pointer Tool .  From the Axis 
Tics shortcut menu (Figure C-37), click Edit Properties.  When 
the Edit Axis Properties Editor opens, choose the Tics tab. 
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To specify default settings for axis tics in all of your plots, click Default 
Plot Properties from the plot Edit menu.  When the Default Plot 
Properties Editor opens, choose the Axis tab, then the Tics tab. 

Figure C-39 shows the Tics worksheet of the Edit Axis Properties 
Editor.  The Tics worksheet is nearly identical on the Edit Axis 
Properties Editor, Plot Properties Editor, and Default Plot Properties 
Editor.  However, at the top of the Plot Properties Editor is an Axis list 
containing all of the axes available for editing in the current plot.  In 
the Plot Properties Editor, you must choose an axis to edit before you 
can make any changes. 

By default, plot axes display major tic marks with labels.  To turn off 
these options, click to clear the 
Use major tick marks and Use 
tick mark labels check boxes. 

You can also select Use minor tic 
marks.  

To change tic color, select the 
color you want from the Tic Color 
list. 

Click Apply to save and view 
changes without closing the 
editor. 

Click OK to save your changes 
and close the editor.  

 

Customizing Axis Labels 

You can add borders and backgrounds to axis labels. 

To customize axis labels in an individual plot, you can either: 

• From the Edit menu, click Plot Properties.  When the Plot 
Properties Editor opens, select the Axis tab.  On the Axis 
worksheet, select the axis you want to edit from the Axis list.  
Once you have this set, select the Label tab to set axis label 
properties.   

Or 

 

Figure C-39. Axis Properties 
Editor--Tics Tab 
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• Right-click on the axis label with the Pointer Tool .  From 
the G2d Label shortcut menu 
(Figure C-40), click Edit Properties.  
The Edit Label Properties Editor will 
open. 

To specify default settings for axis labels 
in all of your plots, select Default Plot 
Properties from the plot Edit menu.  When 
the Default Plot Properties Editor opens, 
choose the Axis tab, then the Label tab. 

Figure C-41 shows the Edit Label Properties Editor.  The same 
worksheet is available on the Label tabs of the Plot Properties Editor 
and Default Plot Properties Editor, with one difference.  The Plot 
Properties Editor has an Axis list containing all of the axes available for 
editing in the current plot.   

 

Figure C-41. Label Properties Editor 

The Label worksheet has two groups, Border and Background, which 
allow you to customize border and background of the label, 
respectively.  Beneath the Border group, the Sample box provides a 
preview of the label.   

To add a border around the axis label, choose Custom in the Border 
group, and then select the Color, Style, and Weight for the borderline. 

To add a background to the axis label, choose Custom in the 
Background group, and then select a Color and Pattern.  

Click Apply to save and view your changes without closing the editor.  
Click OK when you are finished editing axis label properties. 
 

 

Figure C-40. G2d 
Label Shortcut Menu 
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Customizing Legends 

As Figure C-42 illustrates, you can add titles to the top of plot legends 
and add text and graphics to the right and left sides.  You can also 
specify whether the legend appears below or to the right of the plot. 

 

 

Figure C-42. Customizing Legends 

To add legend labels to an individual plot, you can either: 

• From the Edit menu, click Plot Properties.  When the Plot 
Properties Editor opens, select the Legend tab.   

Or 

• Right-click in a blank area inside the 
legend panel of the plot with the 

Pointer Tool .   From the Legend 
Panel shortcut menu (Figure C-43), 
click Edit Properties. The Edit Legend 
Properties Editor will open. 

To specify default settings for all of your 
plot legends, from the Edit menu, click Default Plot Properties.  When 
the Default Plot Properties Editor opens, choose the Legend tab. 

Whether you are using the Plot Properties Editor, Edit Legend 
Properties Editor, or Default Plot Properties Editor, the worksheet for 
editing legend titles is the same.   

Figure C-44 shows the Legend Properties Editor.  This worksheet, 
accessed from the shortcut menu, contains the same fields as the 
Legend worksheets of both the Plot Properties Editor and the Default 
Plot Properties Editor. 

 

Figure C-43. 
Shortcut Menu - 
Legend Panel  
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Figure C-44. Legend Properties Editor 

In the Legend Title box, enter the title you want to appear along the 
top of the legend box. 

In the Left Block Area and Right Block Area groups, you can specify 
the Icon and Text you want to appear on either side of the legend 
block. 

If you wish to display icons, type the exact paths and filenames of the 
icon in the Icon field.  (The path is the location on your computer.) 

Enter any text you want to display in the Text boxes. 

Click Apply to view your changes without closing the editor.  Click OK 
to save your changes and close the editor. 
 

Customizing Window Panels 

You can customize the color and spacing of the window “panel” in 
which plots are displayed; you can also choose whether the plot 
legend displays horizontally along the bottom of the plot panel or 
vertically along the right side.   

To customize panel properties of an individual plot, from the Edit 
menu, click Plot Properties.  When the Plot Properties Editor opens, 
select the Misc. tab.   
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To specify panel properties for all of your plots, from the Edit menu, 
click Default Plot Properties.  When the Default Plot Properties Editor 
opens, choose the Misc. tab. 

Whether you are using the Plot Properties Editor or the Default Plot 
Properties Editor, the Misc. worksheet is the same.  Figure C-45 shows 
the Misc. worksheet of the Default Plot Properties Editor. 

 

Figure C-45. Default Plot Properties Editor--Misc. Tab 

You can also edit the legend layout and spacer size from individual 
property editors accessed from shortcut menus, as discussed below. 
 

Customizing the Panel Background Color 

To customize the panel background color, click the down arrow beside 
the Panel Background Color field to select the color you want.   There 
is no individual property editor available for customizing the panel 
background color.  
 

Customizing the Legend Layout 

If you want the plot legend to display horizontally along the bottom of 
the plot panel, in the Legend Layout group, select Horizontal.   If you 
want the plot legend to display vertically along the right side of the 
plot panel, select Vertical.   

Another way to adjust the position of the legend for an individual plot 
is to use the Legend Panel shortcut menu (Figure C-46).   
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To access the Legend Panel shortcut menu, with the pointer tool right-
click on a blank area inside of the 
legend panel in the plot window panel.  
If the legend is currently positioned 
horizontally, you can click Move To 
Right, which will cause the legend to 
display vertically.  If the legend is 
currently positioned vertically, you can 
click Move to Bottom, which will cause 
the legend to display horizontally. 

 

Customizing the Horizontal Spacer Size 

In the Plot Properties Editor and Default Plot Properties Editor, 
horizontal spacer size refers to the space between viewports in plots 
with multiple viewports.  In single-viewport plots, it is the “margin” 
space between the right side of the viewport and the edge of the 
window panel.   

To specify the horizontal spacer size using the Misc. tab of the Plot 
Properties Editor or Default Plot Properties Editor, in the Horizontal 
Spacer Size group, select Custom, then either select the pixel size 
from the list or enter a value less than 50. 

You can also use the Spacer shortcut menu 
(Figure C-47) to customize both horizontal 
and vertical spacer size for an individual plot.   

To access the Spacer shortcut menu, right-
click on a blank space on the plot panel.  Click 
between viewports if you want to adjust 
vertical spacing between viewports, or to the 
right of a viewport to adjust horizontal 
spacing.   

From the Spacer 
shortcut menu, click Edit 
Properties.  The Edit 
Spacer Properties dialog 
box will open (Figure C-
48).   

To specify the spacer 
size, enter a value less 
than 50. 

 

 

 

Figure C-46 Legend 
Panel Shortcut Menu 

 

Figure C-47. 
Spacer Shortcut 
Menu 

 

Figure C-48. Edit Spacer Properties 
Dialog Box 
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Customizing Plot Layout  

The Configure Plot Editor (Figure C-49) displays plot components in a 
“tree” structure and allows you to customize the layout of an individual 
plot.  You can add and remove axes as well as add, remove, arrange 
the order of, and set the weight of viewports in the plot window panel. 

 

Figure C-49. Configure Plot Editor 

When you customize the layout of a plot using the Configure Plot 
Editor, your changes apply only to that individual plot unless you 
export the plot’s properties. 

To access the Configure Plot Editor, from the Edit menu, select 
Configure Plot Layout. 
 

Adding and Removing Viewports 

To add a new viewport to a plot, from the Configure Plot Editor’s Edit 
menu click Add Viewport.  The new viewport will appear at the bottom 
of the “tree” in the Selected Data Sets box. 

To remove a viewport, you can either: 

• Click on the name of the viewport in the Selected Data Sets 
“tree.” From the Edit menu, click Remove Viewport. 
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Or 

• Right-click on the 
viewport’s name in 
the Selected Data 
Sets “tree.” From 
the shortcut menu 
(Figure C-50), click 
Remove. 

 

 

Setting Viewport 
Weights 

You can customize the relative sizes of viewports in your plots.  To do 
this: 

1. From the Edit menu of 
the Configure Plot Layout 
Editor, click Set Viewport 
Weights.  The Set Plot 
Viewport Weights dialog 
box will open. 

2. In the Set Plot Viewport 
Weights dialog box 
(Figure C-51), you can 
specify the relative size 
of each viewport as a 
percentage value, with 
all of the weights adding up to 100%. Figure C-51 shows four 
viewports of equal weight at 25% each. 

Note that the Set Plot Viewport Weights dialog box offers the same 
right-click shortcut menu commands as are available in all tables.  You 
can cut, copy, and paste data cells; insert, append, and delete rows; 
and print and export.  For more information, refer to the section on 
tabular data in the Utilities chapter. 

Click Apply to save and view your changes without closing the dialog 
box.  Click OK to save your changes and close the dialog box. 
 

Adding and Removing Axes 

By default, viewports have a left Y-axis.  You can also add a right Y-
axis, remove both the left and right Y-axes, and add a new left Y-axis 

 

Figure C-50. Shortcut Menu--
Remove Viewport 

 

Figure C-51. Set Plot Viewport 
Weights Dialog Box 



 Appendix C  Customizing Plots 

 C-37 

if you have previously removed it.  Viewports can have a maximum of 
two axes, and you cannot remove an axis when a data set is 
associated with it. 

To add an axis to a viewport, you can either: 

• Click on the viewport’s name in the tree in the Selected Data 
Sets box.  From the Edit menu, choose Add Axis. 

Or 

• Right-click on the viewport’s 
name in the tree in the 
Selected Data Sets.  From the 
shortcut menu (Figure C-52), 
click Add Axis. 

The tree now displays another axis 
for the viewport you selected.   

 

To remove an axis that has no data associated with it, you can either: 

• Click on the name of the axis you wish to remove in the tree in 
the Selected Data Sets box.  From the Edit menu, click Remove 
Axis. 

Or 

• Right-click on the axis you wish to remove in the tree in the 
Selected Data Sets box.  From the shortcut menu, click 
Remove.   

The selected axis will no longer display in the tree. 
 

Arranging Viewports and Axes 

You can rearrange the vertical order of viewports in a plot window and 
move axes (with their associated data sets) to different viewports.   

To move a viewport or axis, 

1. From the tree in the Selected Data Sets box, right-click on the 
name of a viewport or axis you want to move.   

2. From the shortcut menu, click Move Up or Move Down from the 
shortcut menu.   

 

Figure C-52. Shortcut Menu 
- Add Axis 
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3. Either click OK or Apply for the change to take effect in the plot 
window. 

Note that you cannot move individual data sets in the Configure Plot 
Layout Editor.  You can move only the axis with which a data set is 
associated. 

Reversing Axes (Invert Data) 

To reverse the direction of an axis so that the data is inverted, right-
click on the name of the axis in the tree.  From the shortcut menu, 
click Reverse.  Either click OK or Apply for the change to appear in the 
plot window.   

Exporting and Importing Templates 

After you have customized a plot, you can save its settings as a 
template for use in other plots. 

Generally, you will use templates when scripting plots.  For example, 
every day you generate a plot of flow, stage, and precipitation via a 
script, and then apply a template that has all of the correct formatting, 
such as viewport placement, size, line colors, and fills.   For more 
information about using templates with scripts, refer to the chapter on 
Scripting.   

To create a template from a plot: 

1. From the File menu, click 
Export Properties.  

2. From the Export Plot 
Template dialog box 
(Figure C-53), specify 
whether you want the 
template to be available 
for All Applications or This 
Watershed only, and then 
give the template a Name. 

3. Click OK to save the 
template and close the 
dialog box. 

To apply (import) a template you 
have created to another plot currently open: 

 

Figure C-53. Export Plot 
Template Dialog Box 
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1. From the File menu, click Import Properties. 

2. In the Import Plot 
Template dialog 
box (Figure C-
54), specify 
whether you want 
to use a template 
available for All 
Applications or for 
This Watershed 
only. 

3. A list of available 
templates will 
display.  Choose 
the template you 
want by clicking 
on its name.   

4. When you select a 
template, its 
name will display 
in the Name field. 

5. Click OK to apply 
the template to the current plot and close the dialog box. 

Additional Viewing Options for Plots 

The File menu of plots (Figure C-55) 
contains several commands that allow you 
to view plot data in tabular form, save 
plots, and copy and paste plots into other 
applications such as Microsoft Word, 
Excel, and Visio. 

 

 

 

 

 

 

Figure C-54. Import Plot Template 
Dialog Box 

 

Figure C-55. File Menu 
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Viewing Data in Tabular Form 

To view plot data in tabular form, from the File menu, click Tabulate.  
A dialog box will open displaying the data in tabular form (Figure C-
56). 

 

Figure C-56. Data in Tabular Form 

For more information about tables, refer to the chapter on Utilities. 

Saving Plots  

You can save a plot as an image (JPEG), a Windows Metafile (*.wmf), 
as Portable Network Graphics (*.png), or other formats.   

To do this, from the File menu, click Save As.  From the Save dialog 
box (Figure C-57), select the location where you want to save the plot, 
enter a filename in the File name box, and select the file type you 
want from the Files of type list, then click Save.  



 Appendix C  Customizing Plots 

 C-41 

 

Figure C-57. Save Dialog Box 

 

Copying Plots to the Clipboard  

Use Copy to Clipboard from the File menu to copy a plot to the 
clipboard.  You can then paste the plot as an image into another 
application such as Microsoft Word, Excel, or Visio.  
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Printing Plots 

The Print command, available from the File menu of plots, opens a 
standard, Windows-style print dialog box. 

From the File menu, click Page 
Setup.  The Page Setup dialog 
box will open (Figure C-58).  
Here you can set the page 
Orientation, Page Margins, 
Page Numbers, and Printer 
Scale.   

Set Margins opens the Printer 
Margins dialog box (Figure C-
59).  
 

 

Figure C-59. Printer Margins 
Dialog Box 

 

Figure C-58. Page Setup Dialog 
Box 
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To view the plot as it will be printed, from the File menu, click Print 
Preview.  Figure C-60 
shows an example. 

Finally, the Print 
Multiple command 
allows you to print 
several plots on one 
page.   The Print 
Multiple dialog box 
(Figure C-61) shows 
all of the currently 
open plots in the 
Available Plots box.  
To select plots for 
printing, double-click 
on the plots in the 
Available Plots box 
and the selected plots 
will move to the 
Selected Plots box. 

Next, use the slider 
bars to specify the 
number of plots you 
wish to appear 
horizontally and 
vertically on the page.  The grid to the right of the sliders reflects your 
choices.  

 

Figure C-61. Print Multiple Dialog Box 

 

Figure C-60. Example Print Preview of a 
Plot 
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Figure C-62 shows a preview of the plots set up above.  From the Print 
Multiple dialog box, you can also use the Page Setup and Print Preview 
commands.  The two commands are available from the File menu of 
the Print Multiple dialog box. 

 

Figure C-62. Print Multiple Preview  
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