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Statistical Software Package, HEC-SSP
Software Distribution and Availability Statement

The HEC-SSP executable code and documentation are public domain and were developed by
the Hydrologic Engineering Center for the U.S. Army Corps of Engineers. The software was
developed with United States Federal Government resources, and is therefore in the public
domain. This software can be downloaded for free from the HEC internet site
(www.hec.usace.army.mil). HEC does not provide technical support for this software to
non-Corps users. However, we will respond to all documented instances of program errors.
Documented errors are bugs in the software due to programming mistakes not model
problems due to user-entered data.
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Introduction

Version 1.0 of the Statistical Software Package (HEC-SSP) was completed in August 2008
and released for general use shortly thereafter. Several new features have been added and
improvements to existing features have been completed to the program since that time.
These include improvements to importing data into a study, adding an option to edit
existing data, improved customization of report graphs, and the addition of a new type of
summary report. A number of enhancements were added to the volume-duration frequency
analysis so that outliers and historical data are now accounted for when computing the
analytical frequency curves.

The HEC-SSP development team has also continued careful and systematic testing of the
program since the last release. The results of this testing in combination with reports from
users have allowed the identification and repair of various bugs. Some of the bugs that
were fixed are described in this document.

Installation

The installation program and all documentation are available on the HEC web site at
http://www.hec.usace.army.mil/. This new release is installed independently of any
previous versions of the program so you will need to remove Version 1.0 if you do not want
to use it anymore. However, you may keep different versions of the program installed for
parallel use or testing if you choose to do so. This new version will automatically open
projects developed with any previous version of the program. However, once a project has
been opened in Version 1.1, it may not be possible to open it with older versions of the
program.

The new installation package is designed to be easy to use. It will take you through the
steps of selecting a directory for the program files and making other settings. Use the
following steps to install the program on the Microsoft Windows® operating system:

1. Download the installation package from the HEC website to a temporary
folder on the computer. If the software was provided to you on a CD-ROM
or other media, insert it in the appropriate drive.

2. Run the installation program. In Windows Explorer, double-click the icon
for the installation program. You must have administrator privileges to
run the installer.

3. Follow the on-screen prompts to install the program.

New Capabilities

In Version 1.1, the user has the option to set the number of decimal digits shown in result
tables and summary reports. Select the Tools>Options menu option and then open the
Results tab. Figure 1 shows the editor for controlling the number of decimal digits.

The Data Editor was renamed to the Data Importer, and the Metadata Editor was created.
These and other improvements were made to make it easier to import data into a study and
to view/edit metadata. These improvements include:
a) The manually data entry editor was improved so that data can be easily pasted
into the table.
b) The USGS data importer lets the user choose flow or stage data, and the
importer adds the USGS quality codes to the study tree if they are available.


http://www.hec.usace.army.mil/
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c)

d)

e)

The Excel data importer is more flexible, so that data other than flow data can be
imported.

A text file importer was added that allows the user to import data from a comma
delimited text file.

The Metadata Editor was added to allow the user to view, define, and edit
metadata after the data was already imported into the study. The Metadata
Editor is very similar to the Details tab on the Data Importer. To open the
Metadata Editor, click the right mouse button on top of a data set in the Data
folder. Choose the Edit Metadata option from the shortcut menu.

Murmber of decimal digits to show in results
Flowe Digits: zE
Precipitation Digits: 2|E
Stage Digits: 3|E
Statistics Digits: 4%
Wolurme Digits: 0
Ok ] [ Cancel
Figure 1. Editor for Setting the Number of Decimal Digits.

In Version 1.0, the user could not edit data values once they were imported into a study.
An edit option is available in Version 1.1. After opening data table (click the right mouse
button while the data is selected in the study tree and select the tabulate option), select the
Edit>Allow Editing menu option. To save any edits, select the File>Save menu option.

A new summary report has been added that combines all the statistical results and

frequency

curve ordinates from selected analyses into one summary table, as shown in

Figure 2. The report only groups analyses of the same type; it will not group Bulletin 17B
and General Frequency analyses into the same report. To open a summary table, first
select multiple analyses in the study tree and then select the Results>Summary Report
menu option.

The following new features were added to result graphs:

a)

The user can now add a point to the graph. To add a point, place the mouse
anywhere in the plot area and click the right mouse button. Then select Add
Marker Point to add a point. The program requires the user to define the
probability and magnitude of the point before it is added to the plot. Draw
properties can be edited for these user-defined points by placing the mouse on
top of the point and clicking the right mouse button. Select the Edit Properties
option in the pop-up menu.
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b) It is more straight-forward to add a line to the graph. In Version 1.0, the
program would add a line based on where the mouse was located when the Add
Marker menu options was selected. Now the program asks the user to define
the magnitude or probability of the line before it is added to the graph.

¢) The user can now edit the range of the x-axis. To do this, open a plot and place
the mouse pointer anywhere along the x-axis. Click the right mouse button and
choose the Edit Properties menu option. Then uncheck the Maximum and/or
Minimum boxes and edit the range of the x-axis, as shown in Figure 3.

B Bulletin1 7bSummary. rpt
Eile Edit Search Format

File: | TemptSSP_ExamplesiBulletin1 ThResults'Bulletind FhSummary.rpt

Bulletin 17B Summary Report
Mon Jan 05 Z1:14:51 P3T 2009

Table 1 3ummary of 3tatistics

Analysis Data Mean SRR e o T e e o P O Hist Outlier Zero/ Syst Hist
Name Name Dew Stn Roml Waht Adpt Evnmt Hi Lo Msng Ewnt Perd
FFA4 Test 1 FISHEILL CREEE-BEEACON-FLOW 3.3768 0.255 0.730 0.600 0.677 0.677 o o o o 24
FFA Test 2 FLOYD RIVER-JAMES IA-FLOW 3.547 0.447 0.175 -0.300 0.074 0,074 o Ak o o 39 g2
FFA4 Test 3 BACK CREEE-JONES SPRINGS, WV-FLOW 3. 741 0.231 0.623 0.500 0. 586 0. 586 o o ol o 368
FFA Test 4 CORESTIMEA CREEE-NEWMAN, CA-FLOW 2.975 0.678 -0.578 -0.300 -0.472 -0.472 o o i & 42
FFA Test 5 EASKASKIA RIVER-VANDALIA, IL-FLOW 4. 126 0.273 0.408 -0.400 0.1z 0.1z i} o z o 60
FFA Test 6 RIDLEY CREEK-MOYLAN, PA-FLOW 3.120 0.283 1.088 0.400 0.890 0,890 i o o o 24 132

Table 2 Summary of Frequency Curve Ordinates

Analysis Data Percent Change Exceedanc

Name HName k] 95 a0 an 50 20 10 5 2 ik 0.5
FFA Test 1 FISHKILL CREEK-BEACON-FLOW §30.5 1038.5 119z.1 1433.2 2194.5 3657.1 4959.3  6506.1  9031.5 11333.3  14215.0
FFA Test 2 FLOYD RIVER-JAMES IA-FLOW 345.4 B71.3 855.3 1471.8 3404.8 B8015.8 12638.5 18470.8 28425.7 3798l.6 49600.7
FFL Test 3 BACK CREEK-JONES SPRINGS, WY-FLOW 2004.3 2524.6 2901.0 3490.3 5238.5 §449.0 11181.3 14322.2 19266.5 23729.3 289347
FFA Test 4 ORESTIMBA CREEE-NEWMAN, Ci-FLOW 15.2 6l.8 121.3 266.5 1043.8 3450.0 6041.4 9289.3 14572.3 19286.3 24623. 1
FFL Test § KASKASKIA RIVER-VANDALIA, IL-FLOW 3283.5 4792.4 5305.6 7652.2  12824.3 22082.5 29659.4 33061.7 50712.8 61633.1  73371.2
FFA Test 6 RIDLEY CREEK-MOYLAN, PA-FLOW 4dd. 5 543.3 62z.3 754.3 1186.0 2181.5 3162.5 4435.8 6724.2 9065.9 12086.4
< >

IERE 11

Figure 2. Example Summary Report.
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Figure 3. Axis Properties Dialog Used for Customizing the Range of the X-Axis.

New capabilities were added to the volume-duration frequency analysis to incorporate
outliers and historic data when computing the data statistics. Figure 4 shows the new
Options tab in the volume-duration frequency editor. This figure shows that the user can
define a Low Outlier Threshold for each duration as well as use Historic Data. High and
low outlier tests are based on the procedures outlined in Bulletin 17B and are applied in the
same manner in the Volume-Duration Frequency Analysis. In addition, HEC-SSP uses
historic data as recommended in Bulletin 17B. The program will update the text and
calculation procedure based on whether Analyze Maximums or Analyze Minimums is
selected on the General tab.
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General| Options | Duration Table | Analvtical | Graphical

Floww Curations User Specified Frequency Ordinates Historic Period Data
Change or add fo default values Use Yalues from Table below [ ize Histaric Data
Duration in days Freguency in Percent Histarie Period
1 01| Start vear:
7 0.2
15 05 End ear:
60 1.0
120 2.0 Duration High Threshald
5.0 1-day A
10.0 T-day
i 18-day
Output Labeling Low Outlier Threshald B0-day
120-day v

Data Mame
DSE data name 15 FLOW

[ Use Low Gutlier Threshald Historic Events

Duration Low Threshold ear 1-day 7-day 15-day
[ thange label 1-day

. T-day
Data Unit 15-day
DSS DataUnitis  CFS G0-day
130-day

[ thange label

Figure 4. New Options Tab in the Volume-Duration Frequency Analysis.

When computing a volume-duration frequency analysis, the program will issue a warning
message if any of the maximum/minimum flows occur a specific number of days after the
beginning of the year. The number of days is determined by the duration plus 5 days. For
example, for a 15-day duration, the program issues a warning if the maximum/minimum is
within 20 days after the beginning of the year. If water year is chosen, then the program
issues a warning if the maximum/minimum occurs between October 1 — October 20. This
warning is an attempt to let the user know if a maximum or minimum flow is generated by
an event that began in the previous year. The goal is to prevent a scenario in which the
same flow event causes maximum/minimum flows in consecutive years.

One way to determine when the year should begin is to plot each year of record on top of
each another, as shown in Figure 5. A new feature was added in which the program will
create a graph like the one shown in Figure 5. Simply click the Plot Yearly Data button
located on the General tab of the volume-duration frequency analysis editor.

When computing a volume-duration frequency analysis, the program now flags the number
of years with at least one day of missing flow. This information is included on the Tabular
Results tab. The table contains “# Zero/Missing,” which is the number of years with no data

and “# Years with Missing Data” which is the number of years with at least one day of
missing flow data.
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Figure 5. New Plot Generated by the Volume-Duration Frequency Analysis Editor.

Bug Fixes

The development team continues to test the software even after a new release is made.

The team found and repaired a number of bugs since the release of Version 1.0. The
following list describes the bug fixes:

1) The study unit system is set by the user when a new study is created (Create New

Study dialog). Besides setting the units for the study, the user can also set the
display units (View->Set Study Display Units). The display units are used for

summary tables and plots. You can create a new study using English units and then
set the display units to SI. In Version 1.0, the display units were set by default to

English units even if the study units were set to SI. This was causing some

confusion when users examined result tables and graphs. Now, the program will

automatically set the display units to the same unit system as defined when the
project is created.

2) The user defined ordinates, defined on the Curve Input tab (Volume-Duration

Frequency Analysis editor), were not plotted correctly in the graphical curve plot
when a minimum flow analysis was computed. The program now correctly plots the

user-defined curve when performing a minimum flow analysis.
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3) The program would crash when plot buttons were pressed if the analysis had not
been computed. Now the program does not crash when the plot buttons are pressed
if the analysis has not been computed.

4)

5)

6)

7)

8)

9)

All plots

can be customized using the Plot Properties editor. This editor can be

opened by selecting the Edit>Plot Properties menu options on a plot window. In
Version 1.0, some of the curves in a plot were not visible in the Plot Properties curve
list. Now, all curves in the plot are visible in the Plot Properties curve list, as shown

elow.

Ei Bulletin 17B Plot for FFA Test 1 Properties

Cunes

Select Viewport:

Cures | Viewport| Title | Axis | Legend Layaut

4 Percent Confidence Limit L
95 Percent Confidence Limit [
Obsemed Events dAeibull nlotting nositions)

Diraw Curve Show in Legend

Curve properties can be edited by hovering the mouse over a line in the graph or
legend and clicking the right mouse button. In the shortcut menu, choose the Edit
Properties menu option. In Version 1.0, the program did not automatically highlight
the curve that was selected when the Properties editor was opened. Now, this curve
is automatically selected when the Properties editor is opened.

The number of Historic Period years should be empty in the Number of Events table
on the Tabular Results tab if the Use Historic Data box is not checked on the Options
tab. This was not always the case in Version 1.0. Now, the program leaves the
Historic Period field empty if the Use Historic Data box is not checked.

Menu options are disabled and enabled based on what is selected in the study tree.
For example, the Results>Graph menu option is disabled if no Bulletin 17B,
General Frequency, or Volume-Duration Frequency analysis is selected in the study
tree. Also, some menu options need to be disabled if no study is open. Not all menu
options were correctly following this behavior and have been fixed. These menu
options include: File>Export, Maps>Map Window Settings, Maps—->Zoom to Entire
Map Window Extents, Maps—> Import, Maps->Export, Analysis>New, and all items on
the Windows menu.

The program took longer and longer to import data into a study as the number of
data sets increased. Data importing was improved for Version 1.1 so that it does not
take as long to import a data set even if a large number of data sets have already
been imported into the study.

The General Frequency Analysis editor was only saving Data Values in the graphical
curve table if the graphical analysis was computed. Now, the program saves values
in the graphical curve table without the user having to compute the graphical

analysis.
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10)The Compute Manager can be used to compute multiple analyses. To open the
Compute Manager, select the Analysis>Compute Manager menu option. Then
select all analyses to be computed and click the compute button. In Version 1.0, the
analysis report was not being generated when the analysis was computed by the
Compute Manager. Now, the program generates the analysis report when the
analysis is computed by the Compute Manager.

Documentation

The Statistical Software Package HEC-SSP: User's Manual contains extensive information on
installing and using the program. Details on the use of each feature and capabilities in the
program are included. The manual has been updated with information describing new
features added to the program for this Version 1.1 release.

Bug Reports and Suggestions

HEC does not provide technical support for this software to non-Corps users; however, we
will respond to all documented instances of program errors. If you encounter a problem,
then please take the time to send us a bug report. The report must be written and should
be submitted directly to the HEC-SSP team at: hec.ssp@usace.army.mil

The bug report should include the following information:

. Contact Information: Name, Phone, and E-mail address.

. What version of the software are you using?

. What operating system are you using?

. An explanation of the problem.

. If the problem is reproducible, please list the steps required to cause it.
(example : "1. Create a new file. 2. Insert some text ...")

. If the problem is not reproducible (only happened once, or occasionally for no
apparent reason) please describe the circumstances in which it occurred and the
symptoms observed (note : it is much harder for us to fix non-reproducible bugs).

7. If the problem causes any error messages to appear, please write down the exact

text displayed.

ADhWNERER

o

Note: Please attach your data files if possible. This will assist in debugging the problem.

If you have any suggestions or ideas for enhancing HEC-SSP, please e-mail your
suggestions to hec.ssp@usace.army.mil.
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