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Workshop: 
 Application of HEC-HMS using 

Gridded Precipitation in Watersheds 
Outside of the United States 

 

Overview 
This workshop is designed to help users applying HEC-GeoHMS and HEC-HMS 
in watersheds outside of the United States. In particular, this workshop will 
demonstrate the application of gridded precipitation within HEC-HMS outside of 
the regions covered by the HRAP and SHG grid systems.  Prior to HEC-HMS 
version 4.2, it was not possible to utilize the gridded precipitation option in HEC-
HMS for areas outside of the U.S. due to limitations in how gridded data was 
stored in HEC-DSS.  The HEC-DSS grid data libraries have been modified to 
include storage of gridded data in the Universal Transverse Mercator (UTM) 
spatial reference system. 

Gridded precipitation can come from different sources and this workshop 
demonstrates the application of precipitation grids developed using precipitation 
gage information and from satellite derived precipitation estimates.  In addition to 
setting up a gridded model, the workshop shows how to prepare an HMS model 
to run with a variety of sources of precipitation data – point rainfall, grid-based 
interpolation, and satellite precipitation.   

Although the workshop uses the PERSIANN gridded precipitation product as one 
example, the workshop does not promote the use of PERSIANN for watershed 
model, the use of PERSIANN data was meant to show a possible data source 
and how it could be utilized for an HEC-HMS model.  PERSIANN data, which 
makes use of many different satellite-based estimate of precipitation, can be 
downloaded from the Center for Hydrometeorology and Remote Sensing 
(CHRS), which is part of the University of California at Irvine 
(http://chrs.web.uci.edu/).  The workshop does discuss model calibration.  The 
workshop also introduces a number of software applications, including 

http://chrs.web.uci.edu/
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GageInterp, Data Storage System (DSS), ESRI Model Builder, and utility 
software like DSS2ASCII and ASCII2DSS.   

Please Note: This Workshop is intended for Watersheds located outside of 
the United States. The data in the workshop is intended for informational 
use only. 

In this workshop, the user will: 

• Develop an HEC-HMS Basin Model using HEC-GeoHMS. 
o Generate a UTM ModClark Grid Cell Parameter File (necessary step in 

order to apply gridded precipitation). 
• Develop Grid Based Precipitation with GageInterp. 

o Learn how to prepare a GageInterp Control File. 
o Learn how to run GageInterp and then transfer Gridded Precipitation to an 

HEC-HMS Model. 
• Develop gridded DSS records from the satellite based PERSIANN-CDR data 

set.  
• Calibrate an HEC-HMS model to Multiple Precipitation Boundary Conditions. 

o Modelling method 1) Point Rainfall with the Clark Unit Hydrograph 
method. 

o Modelling method 2) Gridded Precipitation from GageInterp with the Clark 
Unit Hydrograph method. 

o Modelling method 3) Gridded Precipitation from GageInterp with the 
ModClark Unit Hydrograph method. 

o Modelling method 4) Satellite Data using the PERSIANN-CDR data set 
with the ModClark unit Hydrograph method. 

 
The project files for this workshop are available as well.  There is a directory that includes 
all project files for starting the workshop and then the solution files.  As show below, the 
“Before” directory includes the workshop files you would start with if you wanted to follow 
along with the workshop instructions.  The “After” directory contains the project files that 
you should get when completing all the steps in the workshop. The computer programs 
required to generate UTM grids in DSS are provided in the “hecexe” directory and 
documentation for those programs is provided in the docs directory. 
 
Folder \...\Mongolia_UTM\Before\ contains data sets before the workshop 
Folder \...\Mongolia_UTM\After\ contains data sets after the workshop 
Folder \...\Mongolia_UTM\hecexe\ contains grid processing programs 
Folder \...\Mongolia_UTM\docs\ contains documentation for grid programs 
 
Before proceeding, please read the accompanying “Program Setup” document and follow 
the instructions it contains to install the utility programs required by this workshop. 
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The Watershed 
The study area for this workshop is 2,820 square kilometers of the approximately 
6750 square kilometer Tuul River watershed. The Tuul River watershed is 
located in the central and northern region of Mongolia. There are two streamflow 
gages in the study area that contain daily flow measurements for June, July, and 
August 1993.  The most downstream streamflow gage is located near the City of 
Ulaanbataar, approximately 15 km upstream of the Chinggis Khan International 
Airport.  The other upstream streamflow gage is located near the City of Terelz.  
The Tuul River has a highly braided floodplain with several bridge crossings.  
The watershed is located in UTM Zone 48 North.  A map of the watershed is 
shown in (Figure 1).   
 

 
 

  

Figure 1: Tuul River Watershed 
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Task 1: Developing an HEC-HMS Basin Model using HEC-GeoHMS 
 

In this task, we will utilize the Terrain Preprocessing tools to develop an initial subbasin 
and stream network within HEC-GeoHMS. The workshop will finalize subbasin and river 
delineations and then create initial model files for an HEC-HMS model.  This task is 
divided into two sections. Part 1a sets up an ArcMap project that includes GeoHMS and 
loads a terrain model. Part 1b creates the HMS model elements—subbasins, routing 
reaches, junctions—that will represent the Tuul basin in HEC-HMS and exports them 
from ArcGIS into model files that can be imported into the HEC-HMS program. 
 
Users who are already familiar with GeoHMS may want to skip ahead to Steps 21-25 of 
part 1b, which shows how the UTM grid and the corresponding gridcell file are created. 
Users who are not familiar with GeoHMS should refer to the GeoHMS User’s Manual for 
more in-depth discussion of the steps below. 
 
1a. Starting an ArcMap Project and configuring for GeoHMS.      

 
1. Open ArcMap with the Blank Map template selected. Click OK. 
2. Make sure the GeoHMS Tools toolbox is added to ArcToolbox.  Click the 

ArcToolbox Window button to open ArcToolbox.  If you do not see  
GeoHMS toolbox, then place the mouse pointer on top of ArcToolbox and click 
the right mouse button. Select the Add Toolbox option in the list. By default, 
these toolboxes are located at 
C:\ProgramFiles(x86)\ArcGIS\Desktop10.2\ArcToolbox\Toolboxes.  

3. Load the Spatial Analyst Extension by selecting the Customize menu => 
Extensions. Make sure Spatial Analyst is turned on. 

4. Make sure Background Processing is turned off.  Select the Geoprocessing 
menu => Geoprocessing Options. Make sure the Enable box is Not checked 
for Background Processing. 

5. Load the HEC-GeoHMS toolbar. Select Customize => Toolbars… and check 
the HEC-GeoHMS toolbar. 

6. Load the terrain data. Click the Add Data button and navigate to 
Before\GeoHMS_UTM\fil_clip and click the Add button.  The terrain data 
should have already been projected into the appropriate UTM zone.  Usually, the 
first data layer added to an ArcMap project is used to set the projection for the 
data frame.  All data layers created by GeoHMS will be set to the same 
projection as the data frame.  
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7. Prepare to save the ArcMap document 
with relative path names by selecting 
File => Map Document Properties. 
Check the box to “Store relative 
pathnames to data sources” and click 
OK. Using relative pathnames makes it 
easier to pass an ArcMap project from 
one computer to another, as long as all 
data layers and ArcMap document are 
saved in the same directory (Figure 2).  

  

Figure 2: Map Document Properties 
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1b. Completing the GeoHMS project and generate files for and HEC-HMS project.  
Steps 1 through 9 show how to develop the initial subbasin and river network by using 
GeoHMS and the terrain data to delineate subbasins and reaches.  The GeoHMS 
Terrain Preprocessing menu contains menu options for each of the steps below.  

1. Fill the Sinks 
• Preprocessing => Fill Sinks (This step 

has already been completed). 
• The Output DEM is fil_clip (Figure 3). 

 
 
 
 
 
 
 
 
 
 
 

2. Flow Direction 
• Preprocessing => Flow Direction.  
• Confirm that the Input Hydro DEM is 

fil_clip. 
• Use the default name Fdr for the Output 

Flow Direction Grid (Figure 4). 
• Click OK. 

 
3. Flow Accumulation 

• Preprocessing => Flow Accumulation. 
• Confirm Input Flow Direction Grid is Fdr. 
• Use the default name Fac for the Output 

Flow Accumulation Grid. 
• Click OK. 

 

  

Figure 3: Digital Elevation Model 

Figure 4: Flow Direction 
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4. Stream Definition 
• Preprocessing => Stream Definition. 
• Confirm that the Input Flow 

Accumulation Grid is Fac. 
• Enter a stream threshold of 300000 cells 

(Number of cells to define stream) 
(Figure 5). 

• Use the default name Str for the Output 
Stream Grid. 

• Click OK. 
 

5. Stream Segmentation 
• Preprocessing => Stream 

Segmentation. 
• Confirm that the Input Stream Grid is 

Str and Input Flow Direction Grid is Fdr. 
• Use the default name StrLnk for the 

Output Stream Link Grid. 
• Click OK. 

 

6. Catchment Grid Delineation 
• Preprocessing => Catchment Grid 

Delineation (Figure 6). 
• Confirm that the Input Flow Direction 

Grid is Fdr and Input Link Grid is 
StrLnk. 

• Use the default name Cat for the Output Catchment Grid. 
• Click OK. 

 

7. Watershed Polygon Processing 
• Preprocessing => Catchment Polygon 

Processing (Figure 7). 
• Confirm that the Input Catchment Grid is 

Cat. 
• Use the default name Catchment for the 

Output Catchment. 
• Click OK. 

 

8. Drainage Line Processing 
• Preprocessing => Drainage Line 

Processing (Figure 7). 
• Confirm that the Input Stream Link Grid is 

StrLnk and Flow Direction Grid is Fdr. 

Figure 5: Stream Definition 

Figure 6: Catchment Grid Delineation 

Figure 7: Catchment and Drainage Line Processing 
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• Use the default name DrainageLine for the Output Drainage Line layer. 
• Click OK. 

 
9. Adjoint Catchment Processing 

• Preprocessing => Adjoint Catchment Processing. 
• Confirm Input Drainage Line is DrainageLine and Input Catchment is 

Catchment. 
• Use the default name AdjointCatchment for the Output Adjoint Catchment 

layer. 
• Click OK. 

 

Step 10 is required to create a study area specific 
data frame.  The study data frame will allow the 
user to customize the subbasin and river 
delineation and compute properties for each 
subbasin and river reach.  

10. Setup and Extract the Dataset for a 
Hydrologic Model 
• Project Setup => Start New Project. 
• Specify outlet location with Add Project 

Points tool (see blue push pin) (Figure 8). 
• Project Setup => Generate Project. 
• On the Generate Project form, specify 

layers in your terrain preprocessing data 
frame. 

• Click OK. 
 

Steps 11 and 12 show how to customize the subbasin and river delineation.  
Determining how many subbasin and river reach segments is one of the most important 
decisions made in a modeling study and impact model calibration and performance.  
The number of subbasins for the Tuul River watershed was kept small due to the limited 
number of observed streamflow gages.  Only five subbasins were used to model the 
area upstream of the Ulaanbataar stream gage; however, many more subbasins could 
have been specified.  

 

  

Figure 8: Add Project Point 
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11. Basin Subdivision 
• Use the GeoHMS Subbasin Divide tool to subdivide the subbasins at stream 

flow gage locations.  In the HEC-HMS model, these gage locations would later 
be useful for comparing simulated vs. 
observed hydrographs during calibration 
steps. 

 

12. Basin Merge 
• Use the ArcMap Select Features tool 

and select the subbasins you want to 
merge together. 

• The GeoHMS toolbar has a menu 
option for merging subbasins, Basin 
Processing => Basin Merge. 

• After subbasin merge and river merge, 
final subbasin and stream delineation is 
shown in Figure 9.   

 

Steps 13 through 17 are required to compute subbasin and reach characteristics.  Tools 
on the Characteristics menu are used in these steps.   

13. River Length 
• Characteristics => River Length. 
• Click OK. 

 

14. River Slope 
• Characteristics => River Slope. 
• Specify the Raw DEM as the Input Raw DEM. 
• Specify River for Input River layer. 
• Click OK. 

 

15. Longest Flow Path 
• Characteristics => Longest Flowpath (see Figure 10). 
• Verify the Input Raw DEM, Flow Direction Grid and Subbasin layers are 

selected.  
• Accept the default name for the Output Longest Flow Path layer. 
• Click OK. 

Figure 9: Basin Merge 

Stream flow 
gage 
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16. Basin Centroid 
• Characteristics => Basin Centroid. 

(see Figure 10) 
• Choose the Subbasin layer. 
• Use the default name for the Output 

Centroidal Layer. 
• Click OK. 

 
17. Centroidal Flow Path 

• Characteristics => Centroidal 
Longest Flowpath. (see Figure 10) 

• The program prompts the user to 
verify the Subbasin, Centroid, and 
Longest Flow Path layers. 

• Use the default name for the Output Centroidal Flow Path layer. 
• Click OK. 

 

Steps 18 through 21 are required to define the modeling processes and the naming 
convention used throughout the model.  GeoHMS will assign default names to 
subbasins, reaches, and junctions.  These names should be modified to include project 
specific names.  The GeoHMS Parameters menu contains the tools discussed in the 
following steps.  

18. Select HMS Process 
• Parameters => Select HMS Processes. 
• Verify that the Subbasin and River layers are selected from the dropdown 

menus, select Parameters Applicable to your project. 
• Click OK. 

 
19. River Auto Name 

• Parameters => River Auto Name. 
• Verify that the River layer is selected. 
• Click OK. 

 
20. Basin Auto Name 

• Parameters => Basin Auto Name. 
• Verify that the Subbasin layer is selected. 
• Click OK. 

 

Centroid 

Longest 
Flow 
Path 

Centroidal 
Flow Path 

Figure 10: Longest Flow-path 
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Step 21 overlays the precipitation grid over the watershed and assigns cells in that grid 
to the subbasins in the model. This step creates the numbering system for the cells as it 
will be applied in the HMS model. It is essential that the coordinate system and cell size 
chosen at this step must be the same as those that will be used for georeferencing the 
precipitation data and loading it into DSS grid records. 
 
21. Grid Cell Processing 

• Parameters => Grid Cell Processing (Figure 11) 
• Select the grid cell method: SHG 
• Select SHG grid cell: 2000 (meters implied)  
• Select the projection => Change => Projected Coordinate System => UTM 

=> WGS 1984 => Northern Hemisphere => WGS 1984 UTM Zone 48N (Figure 
12). Click OK. 

• Verify that the appropriate layers and default name for the new layer are 
selected in Figure 13 and Figure 14.   

• Click OK. 
• The resulting gridded subbasin is shown in (Figure 15). 
• Click OK. 

 

 

 

Figure 11: Grid Cell Processing 

Figure 12: WGS 1984 UTM Zone 48N 

Figure 13: Grid Cell View 
Figure 14:  Grid Cell Processing 
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Figure 15: Resulting Gridded Subbasins 

 

Steps 22 through 24 are required to create the HEC-HMS project specific files.  Tools 
on the GeoHMS HMS menu are included below.  

22. Map to HMS Units 
• HMS => Map to HMS Units. 
• Select the “SI” unit system. 
• Click OK. 

 
23. Check and Create HMS Schematic 

• HMS => Check Data. 
• Click Yes. 
• HMS => HMS Schematic. 
• Click Ok. 
• HMS =>Toggle Legend => HMS Legend (Figure 16). 
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           Figure 16: HMS Legend 

 
24. Export HMS Model Files 

• HMS => Add Coordinates and make sure the correct layers are selected. 
• Click OK. 
• HMS => Prepare Data for Model Export. 
• Click OK. 
• HMS => Background Shape File. 
• Click OK. 
• HMS => Basin Model File.  
• Click OK. 

 

The last step is to create the grid cell parameter file.  The grid cell parameter file 
contains a list of each grid cell located within a subbasin and is required for HEC-HMS 
to apply gridded precipitation within a DSS record to the subbasin element.  Each 
GridCell within the subbasin contains the X coordinate (Xcoord), Y coordinate (Ycoord), 
travel length to the subbasin outlet, and area. 

25. Export ModClark Grid Cell File 
• HMS => Grid Cell File (Figure 17) 
• Click OK. 
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Figure 17: ModClark Grid Cell File 

Once the files have been created by GeoHMS, then they can be imported into an HEC-
HMS project.  The required files include the Basin Model file and the Grid Cell 
Parameter file.  The subbasin and reach shapefiles are not required but can be used for 
adding background layers to the HEC-HMS basin model.   

Task 1 Summary 

We have used GeoHMS to create a basin model and a gridcell file for the Tuul 
watershed. The gricell file assigns grid cells to subbasins in the basin model using X 
and Y cell index values based on coordinates in UTM zone 48. To use this model to 
simulate a runoff event in the basin, we need to provide precipitation grids that are 
georeferenced and indexed using the same coordinate system and the same row and 
column positioning and indexing. Task 2 uses the gageInterp program to construct 
these precipitation grids, and Task 3 imports precipitation grids from an online archive 
and re-projects them to align with the cells in our basin model. 
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Task 2: Develop Grid Based Precipitation with GageInterp 
 

There are two precipitation gages within the study area that recorded cumulative 
precipitation in 12-hour increments. In Task 2, we will work with the GageInterp program 
to create gridded precipitation records for use in HEC-HMS by interpolating point rainfall 
from time-series reports at these two rain gages. The products of GageInterp for this 
task are precipitation grids in UTM coordinates saved in a DSS file. The origin, extent 
and cell size of these grids must align with the gridcell file created in Task 1, so that the 
precipitation reported on these grids can be applied to the subbsins in the HMS model. 

GageInterp is a command line program that is controlled by parameters in an input 
control file or entered on the command line at run time. The type of information required 
in a GageInterp control file includes start and end time of precipitation, time interval, 
precipitation grid type and cell size, extent of the grid, filename of the observed 
precipitation, point rainfall gage locations and data, and output filename of the 
interpolated precipitation grids. These parameters are described more fully in the 
gageInterp manual that is included with this workshop data set. 

A. GageInterp Parameters  
Much of the information that gageInterp needs to generate the grids correctly can be 
entered into the control file without reference to the HMS or GeoHMS projects. That 
information is provided in the file “Mongolia_UTM_starter.ctl” shown in Figure 18. 

The first block of text includes the start and end time of the period (the year 1993) for 
which grids will be created, and the time step, expressed in minutes, that each grid 
represents. In this case, the time step matches the 12-hour reporting interval of the two 
precipitation gages.  In this workshop, the grids are created every 720 minutes from 01 
January 1993 to 31 December 1993.   

The second block of text includes information about the grid type. We’re using a UTM 
grid system, since it is the only grid system that gageInterp supports for locations 
outside of the U.S.  The watershed is located in UTM zone 48N and the cell size if 2000 
meters—matching the coordinate system and cell size we chose for the gridcell file we 
created in GeoHMS.  

The third block of text includes information about the grid, the location of the lower left 
grid cell (cell origin) and the number of rows and columns. The values for the row and 
column numbers are blank, and will be filled by examining our GeoHMS project. 

The fourth block of text includes the name of the output DSS file, used to save the 
gridded precipitation grids, as well as the pathname parts. 

Finally, the last two text blocks contain information about the rain gages, the location of 
the DSS file storing the rain gage data and then a block of text for each gage that 
includes the name, DSS pathname, geographic location of the precipitation gage, and 
then the time zone and datum of the precipitation gage. 
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Figure 18 Partially Completed GageInterp Control File 

The location of the precipitation grid that gageInterp writes must match or extend 
beyond the range of cells in the basin model and gridcell file we created with GeoHMS 
in Task 1. Steps 1 through 8 below demonstrate one approach for determining the origin 
of the UTM grid as cell index numbers for the lower left corner of the grid and the extent 
of the grid as numbers of rows and columns.  

1. Open the gridcell processing dataset file (GeoHMS_UTM in our example) in 
ArcMap (Figure 19).    

 

 

 

  

Start Time, End Time and Time 
Step for the precipitation grids. 

Grid type, and cell size in meters.   

DSS file and path where 
grids will be written.   

DSS file containing precipitation 
gage time-series data  

Locations and DSS paths 
for the precipitation gages  

Position and size of output 
grids to be entered here.   
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  Figure 19: GeoHMS_UTM 

2. Right-click on the GC_GeoHMS_UTM data frame and choose Activate 
(Figure 20).  This data frame was used to generate the UTM grid by 
GeoHMS.  The coordinate information can be extracted by the projection and 
data layers.  

 
  Figure 20: Activate Data Frame 

 

3. Right Click GC_GeoHMS_UTM (in ArcGIS Table of Contents) => Properties 
=> General => Units => Display => From Dropdown Menu. Choose 
Degrees Minutes Seconds in the Display dropdown menu (Figure 21).   
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  Figure 21:  Dropdown Menu Choose Degrees Minutes Seconds 

4. Select the Identify  Tool => Click on Bottom Left Grid Cell.  The Identify Screen 
will open (Figure 22).   

 

5. As shown in Figure 22, click the arrow within the Location field to expand the 
list of possible location units.  Choose Degrees Minutes Seconds.  

6. Write down CELL_X = 308, Cell_Y = 2635.  The cell origin is (308, 2635). 

7. Repeat previous steps to find coordinates for upper right corner of the grid. 
Write down CELL_X = 372, CELL_Y = 2692 (Figure 23). 

Figure 22: Identify Screen open 
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8. The number of grid columns can be computed by subtracting the upper right 
column number from the lower left column number and adding a value of 1.           

                                                                                                                  
GridCols = (CELL_X(Upper cell) - CELL_X (Lower Cell) ) ) + 1 

GridRows= (CELL_Y(Upper cell) - CELL_Y (Lower Cell) ) ) + 1 

So the grid is 65 columns wide and 58 rows high. 

To finish the GageInterp Control File, insert the lines for the origin and ranges of 
the output grid extent. The result should look like Figure 24.  

The GageInterp control file is located in the …\GageInterp directory and the 
filename is Mongolia_UTM.CTL. As shown in Figure 24, the control file can be 
completed with the dimensions of the output grids, expressed as row and column 
numbers. The third block of text is now completed, showing the location of the 
lower left grid cell (cell origin) and the number of rows and columns.  

Figure 23: Upper Right Corner Information 
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With the control file compete, we can now create precipitation grids using the 
gageInterp program.  
  

Figure 24: GageInterp Control File 

Grid Origin and number or 
Rows and Columns  
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B. GageInterp Analysis Software 
Before proceeding, make sure that you have read 
the accompanying “Program Setup” document 
and that the utility programs required by this 
workshop are installed as described there. 
 

1. Using a Windows explorer, navigate to 
the folder that contains the gageInterp 
control file “Mongolia_UTM.ctl”. This is 
the “Before\GageInterp” folder as the 
files are provided. 

2. Type CMD in address tool bar (Figure 
25) to open the DOS command prompt.   

3. Refering to the “Program Setup” document, verify that you can run the 
gageInterp program from the command prompt in this directory. You may 
need to use the “set” command to add the directory where gageInterp is 
located to the PATH system variable. 

4. Input the following command: 

GAGEINTERP CON=Mongolia_UTM.CTL   

Figure 26 GageInterp Command 
 

Figure 25:  Command Prompt 
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5. Click Enter and watch GageInterp run (Figure 27). 

 

GageInterp should run to competeion with the data and control files provided. 
If the program doesn’t run, verify the PATH enviroment variable includes the 
directory where gageInterp is installed, and that the the “sup” directory is 
installed in the same directory as the gageInterp executable. 

6. A successful GageInterp run will create precipitation grids in a DSS file 
named PrecipGrid.DSS in the directory where it was run. Figure 28 shows a 
gridded estimate of the 12 hours of precipitation ending 02AUG1993 at 12:00 
as displayed in the HEC-DSSVue program. (You must use version 2.5 or later 
of DSSVue to visualize the grids as the version of DSSVue on the webpage 
will not support display grids in the UTM projection. Refer again to the 
“Program Setup” document for suggestions about running an up-to-date 
version of DSSVue.) 

There were a limited number of precipitation gages used for this workshop, 
only two gages were available for the entire watershed.  Notice in Figure 28 
how GageInterp created the interpolation surface. A “bullseye” pattern is 
evident as theinverse distance (ID2W) interpolation method was used, the 
ID2W method is the default method. 

A copy of the GageInterp User’s Manual is included in the 
Mongolia_UTM\docs directory.  

Figure 27: Command Run Result 
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 Figure 28: Grid-based Precipitation on 02AUG1993 at 12:00 in HEC-DSSVue Program 

After a successful gageInterp run, the PrecipGrid.DSS file should contain 729 
precipitation grids, each representing estimated precipitation over the study area at a 
time step of 720 minutes. In order to visualize the precipitation grids over subbasin 
shapefiles and to verify that precipitation grid is in alignment with ModClark grid, the 
utility program DSS2ASCIIGrid.exe can be used to export individual precipitation grids 
from DSS as ASCII files. Then, the ASCII files can be imported into an ArcGIS project 
and viewed with other GIS data layers. Below are steps for using DSS2ASCIIGrid 
program.  A copy of the DSS2ASCGrid program is in the \...\Mongolia_UTM\exe 
directory. 

7. From the same DOS command prompt that you used to run gageInterp, type 
this command  

dss2ascGrid 

You should see a usage message in response to this command. If you don’t 
see the usage message, review the “Program Setup” document and make 
sure that the “dss2ascGrid.exe” file is in the same directory as gageInterp and 
that the PATH includes that directory. 

The following command – with its arguments – will read the precipiation grid 
named by DSS file and path and write its contents to a text file that can be 
read as a grid by ArcGIS.  

dss2ascGrid.exe DSS=PRECIPGRID.DSS 
PATH=/UTM/MONGOLIA/PRECIP/02AUG1993:1200/02AUG1993:2400/INT
ERPOLATED/ OUT=02AUG1993.ASC PREC=2 
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A brief document describing the dss2ascGrid and asc2dssGrid programs is 
provided in the “docs” directory.  

Figure 29 shows the precipitation grid for 02AUG1993 at 12:00 shown in 
ArcMap with the subbasins and gridcells for the created with GeoHMS. 

 
 Figure 29: Grid-based Precipitation on 02AUG1993 at 12:00 in ArcMap 
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Task 3: Develop Grid-Based Precipitation with Satellite Data  
 

This task goes through the steps of gathering satellite based precipitation data, 
reformatting the data, and then converting the data into a DSS record that HEC-HMS 
can use. As stated at the beginning of this workshop, the PERSIANN-CDR data set was 
used; however, the steps included here could be used for other satellite based 
precipitation estimates. The PERSIANN-CDR data set is not being promoted for other 
hydrologic modeling studies; it is up to the hydrologic modeler to verify the quality of the 
precipitation data used for modeling purposes.  

A. Visualize and download the Satellite data  

To access data from the Center for Hydrometeorology and Remote Sensing 
(CHRS) from the University of California at Irvine, follow the steps below to 
visualizing, select, and download the data:   

1. Go to http://chrs.web.uci.edu/. 
2. Click on Research Areas => Satellite Precipitation => Data Access              

(Figure 30). 

 
 Figure 30: Center for Hydrometeorology and Remote Sensing (CHRS) 

3. Click the Visualization tab, Select Dataset: PERSIANN-CDR, Time Step: 
Daily, Domain: Country, select Mongolia on map (Figure 31). 

4. Enter DateTime (yyyy-mm-dd) and click Visualize to see the availability of 
data for the period of time.  
 

http://chrs.web.uci.edu/
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 Figure 31: Visualization of Available Precipitation Data 

Click the Download tab, select Dataset: PERSIANN-CDR, Time Step: Daily, 
Domain: Country, enter DateTime 1993-06-01 to 1993-09-30, Format: ArcGrid, 
Compression: Zip, click Download. 

  

5. A window will prompt the user for an email to send a download link to when 
the data is ready. 

 

 
 Figure 33: Download Email Window Prompt 

Figure 32: Download PERSIANN-CDR Data 
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6. Create folder \...\Mongolia_UTM\Before\Persiann\ASCII with Windows 

Explorer. 
7. When the file has been downloaded, unzip the file to the empty folder 

\...\Mongolia_UTM\Before \Persiann\ASCII.  Using the time window defined in 
step 5, there should be 122 ASCII files.  These precipitation grids are initially 
25,000 meter by 25,000 meter and in the World Geographic System (WGS) 
projection.  The following section describes the steps necessary to process the 
precipitation grids into DSS so they can be used by HEC-HMS.  

 

B. Prepare the Data  
The PERSIANN-CDR data, as downloaded, does not include geographical 
references or projection. The data, as downloaded, is in grids with a spacing of 1/4 
degree in un-projected longitude and latitude. (We have assumed that these 
coordinates are relative to the WGS84 geographic reference system.) Before the 
precipitation data can be used by HEC-HMS, the data must: 1) Converted from 
ASCII file form to an ESRI raster, 2) The projection must be defined, 3) The raster 
files must be reprojected to UTM zone 48N and grid must be resampled to a 2000 
meter cell size, and 4) the raster files must be converted back to the ASCII file 
format.  The ModelBuilder tool within ArcMap is useful in processing multiple files 
with standard ArcGIS tools.  These four steps to process the satellite data are shown 
in detail below. 

Step 1 – Convert ASCII files to the ESRI Raster file format 

The PERSANN data was downloaded and extracted to an empty folder.  The 
PERSIANN data consisted of a number of files with each file containing precipitation 
data with the date in the file name.  For example, the file CDR_19930601z.asc is an 
ASCII file with precipitation for year as 1993, month 06 (June), and day 01 (first).  As 
shown below, these ASCII files were converted to rasters files and save in another 
output folder.  In order to preserve the date information in the raster name, the 
ModelBuilder tool iterates through each ASCII file in the folder and creates a 
precipitation raster with the same name in the output folder. 

• Folder of Input data = \...\Mongolia_UTM\Before\Persiann\ASCII 
• Folder of Output data = \...\Mongolia_UTM\Before\Persiann\Raster 
• Name of ModelBuilder tool = Model_ASCII_to_Raster 

 

ArcMap 10.2.1 was used for this workshop.  You can create the following 
ModelBuilder tool from steps in this workshop. However, a completed ModelBuilder 
tool (Precip_Tools.tbx) is provided in the folder 
\...\Mongolia_UTM\Before\Persiann\ModelBuilder and can be added and used in 
ArcToolbox. 

 
To create your own Model Builder tool: 
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a. Open ArcMap => Blank Map => OK. 
b. Click on the ModelBuilder tool or Geoprocessing => ModelBuilder 

(highlighted in Figure 34). 
 

  
Figure 34: ModelBuilder Tool 

 
c. A blank ModelBuilder window will open up (Figure 35).      

 
 

d. Click Insert => Iterators => Files to add an iterator to the ModelBuilder 
project which will loop through all of the files in a folder. 

e. Double-click Iterate Files.  
f. Select Folder => ASCII (the location of the folder that holds all the ASCII 

files) (Figure 36). 

 
 

 
g. Enter File Extension => asc (this will specify the extension of the files that 

will only be used in the process). 
h. Click OK. 

  

Figure 36: Iterate Files 

Figure 35: ModelBuilder Window 
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i. Click on Geoprocessing => ArcToolbox => 
Conversion Tools => To Raster => Drag 
ASCII to Raster (Figure 37) into the 
ModelBuilder project. 

j. Click on Connect Tool (Figure 38) and 
connect File.asc to ASCII to Raster.  
 

 
 

k. Within the ModelBuilder window, double-click ASCII to Raster. 
l. Input ASCII raster file => File.asc (Figure 39). 
m. Create folder \...\Mongolia_UTM\Before\Persiann\Raster with Windows 

Explorer. 
n. Output raster should be saved to a different folder 

\...\Mongolia_UTM\Before\Persiann\Raster\ %name%.  The variable, 
%name%, is used to preserve the filename (containing date information) of 
the input data. 

o. Enter Output data type (optional): FLOAT. 
p. Click OK. 
q. Model => Run. 
r. Click Close. 

Figure 38: The Connect Tool 

Figure 37: ASCII to Raster Tool 
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The final product for the ModelBuilder tool should be similar to Figure 40 and the 
folders should look like Figure 41 (ASCII Input Data) and Figure 42 (ESRI raster 
Output Data). 

 
 

Figure 39: ASCII to Raster Parameters 

Figure 40: ModelBuilder with ASCII to Raster 
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Step 2 – Assign Projection Information to the Precipitation Raster Files 

In this step, a new ModelBuilder tool is created to iterate through each precipitation 
raster and add the projection information (file prj.adf) into each raster folder. The 
projection is defined as World Geographical System (WGS84). 

• Folder of Input data = \...\ Mongolia_UTM\Before\Persiann\Raster 
• Folder of Output data = \...\Mongolia_UTM\Before\Persiann\Raster 
• Name of ModelBuilder tool = Define_Projection_WGS 

 
a. Open a blank ModelBuilder tool.  
b. Click Insert => Iterators => Rasters. 
c. Double-click Iterate Rasters. 

Figure 41: ASCII Input Folder 

Figure 42: Raster Output Folder 



32 
 

d. Enter Workspace or Raster Catalog => Raster 
and select the folder that has Raster data. 

e. Click OK. 
f. Click on Geoprocessing => ArcToolbox => 

Data Management Tools => Projections and 
Transformations => Drag Define Projection 
(Figure 43) into ModelBuilder. 

g. Click on the Connect tool and connect 
cdr_19930601z.asc to Define Projection.  

h. Double-click on Define Projection. 
i. Input Dataset or Feature Class should already 

be filled.  
j. Enter Coordinate System => Geographic 

Coordinate Systems => World => WGS 1984 
(Figure 44).  

k. Click OK. 

 Figure 44: Spatial Reference Properties 

Figure 43: Define Projection Tool 
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l. Model => Run as shown in Figure 45. 

 
 

m. The resulting projection file, prj.adf, is added to each raster as shown in Figure 
46. 

 
Step 3 – Reproject from WGS to UTM zone 48N and Resample the Cell Size to 2000 
Meters 

In this step, a new ModelBuilder tool is created to iterate through each precipitation 
raster and re-project the raster to UTM Zone 48 N and save projected rasters in another 
output folder.  It is also important to resample the grid to a 2000 meter cell size so that 
the precipitation rasters are aligned with the ModClark grid created using GeoHMS.  
The ModelBuilder tool iterates through each raster file in the folder and creates a 
reprojected raster with the same name in the output folder. 

Figure 46: Output Projection File WGS 

Figure 45: ModelBuilder Define Projection 
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• Folder of Input data = \...\ Mongolia_UTM\Before\Persiann\Raster 
• Folder of Output data = \...\Mongolia_UTM\Before\Persiann\UTM 
• Name of ModelBuilder tool = Project_UTM 

 
 

a. Create the folder 
\...\Mongolia_UTM\Before\Persiann\UTM with 
Windows Explorer. 

b. Start a new ModelBuilder project.  
c. Click Insert => Iterators => Rasters. 
d. Double-click Iterate Rasters.  
e. Enter Workspace or Raster Catalog => 

Raster (the folder that has Raster data). 
f. Click OK. 
g. Click on Geoprocessing => ArcToolbox => 

Data Management Tools => Projections and 
Transformations => Raster => drag Project 
Raster (Figure 47) into the ModelBuilder 
project. 

h. Click on Connect and connect cdr_19930601z 
to Project Raster.  

i. Double-click on Project Raster. 
j. Input Raster should already be filled. 
k. Output Raster Dataset should be a different 

folder \...\Mongolia_UTM\Before\Persiann\UTM 
\%name%  

l. Select Output Coordinate System => 
Projected Coordinate Systems => UTM => 
WGS 1984 => Northern Hemisphere => WGS 
1984 UTM Zone 48N (Figure 48).  Click OK. 

m. Select Sample Technique (optional): Bilinear. 
n. Enter Output Cell Size (optional): X = 2000 and Y= 2000.  The output cell 

size of 2000 is important in order to match the 2000-meter cell size in the 
ModClark grid cell file. 

o. Enter Registration Point (optional): X Coordinate = 0 and Y Coordinate = 
0.  The registration point at (0, 0) is important in order to match with the origin 
coordinate of the ModClark grid cell file. 

Figure 47: Project Raster 
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p. Click OK. 

 
 Figure 48: Project Raster Parameters 
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q. Model => Run (Figure 49). 

 
 
 

r. The resulting Raster is in UTM folder (Figure 50).  

 
 

Step 4 – Convert UTM Rasters to ASCII Files 

The PERSIANN data is now in raster format with the desired UTM coordinate system 
and cell size. The last ModelBuilder tool described below will iterate through each raster 
and export the raster to an ASCII file in another output folder. The resulting ASCII files 
also contain the same name as the input raster files. These ASCII files will be imported 
later into a DSS file for use within HEC-HMS.  

• Folder of Input data = \...\Mongolia_UTM\Before\Persiann\UTM 
• Folder of Output data = \...\Mongolia_UTM\Before\Persiann\UTM-ASCII 
• Name of ModelBuilder tool = Raster UTM to ASCII 

Figure 49: ModelBuilder Project UTM 

Figure 50: Project Raster Output Folder 
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a. Create folder 
\...\Mongolia_UTM\Before\Persiann\UTM-ASCII 
using Windows Explorer. 

b. Create a new ModelBuilder project. 
c. Click Insert => Iterators => Rasters. 
d. Double-click Iterate Rasters (Figure 52). 
e. Enter Workspace or Raster Catalog => UTM 

the folder that has UTM Raster data. 
f. Enter Raster Format (optional): GRID. 
g. Click OK. 
h. Click on Geoprocessing => ArcToolbox => 

Conversion Tools => From Raster => Drag 
Raster to ASCII (Figure 51) into the 
ModelBuilder project. 

i. Click on Connect and connect cdr_19930601z 
to Raster to ASCII. 
 

j. Double-click on Raster to ASCII. 
k. Input Raster (Figure 53) should already be filled. 

 Figure 53: Raster to ASCII Parameters 

Figure 52:  Iterate Rasters 

Figure 51: Raster to ASCII Conversion 
Tool 
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l. Output Raster Dataset should be in a different folder 
\...\Mongolia_UTM\Before\Persiann\ UTM-ASCII\%name%.ASC 

m. Click OK.  
n. Model => Run (Figure 54). 

 
o. The resulting ASCII files with UTM projection are shown in Figure 55. 

 

 

  

 

Figure 54: ModelBuilder Raster UTM to ASCII 

Figure 55: Output Folder UTM-ASCII 
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Step 5 – Import ASCII Files to DSS 

The previous steps showed how to reproject and resample the gridded PERSIANN 
satellite based precipitation data. The final step to process the ASCII files from Step 4 to 
gridded records in DSS rely on using the ASC2DSSGrid utility program. The 
ASC2DSSGrid program is a DOS based program that requires input information to 
convert an ASCII file to a DSS record. We will create a batch file to automate the import 
process. The batch file can be created with a text editor and saved with a *.bat 
extension. Each line in the batch file executes the ASC2DSSGrid utility program with 
parameters like input file, output DSS file, DSS pathname, dates, grid type, unit, and 
data type. After using the copy/paste command in the text editor, the user can edit the 
input file name, dates, etc. to import each ASCII file to DSS.  

• Folder of Input data = \...\Mongolia_UTM\Before\Persiann\UTM-ASCII 
• Folder of Output data = \...\Mongolia_UTM\Before\Persiann\UTM-ASCII 

 
Copy the ASC2DSSGrid.exe file from the \...\Mongolia_UTM\Before\GageInterp\exe 
directory to the \...\Mongolia_UTM\Before\Persiann\UTM-ASCII Directory.  
 

a. Create a batch file, GRID2DSSGrid.bat, with a text editor. 
b. The first line in the file should call the set command to put the directory 

containing asc2dssGrid.exe onto the PATH environment variable: 
 
Set PATH=C:\HECEXE\;%PATH% 
 
Substitute your actual install directory for “C:\HECEXE\ if it’s different.  

c. For each ASCII file, a command line should be used as shown below.  With 
copy and paste, the user can edit each command line with appropriate input 
filename and time (Figure 56). 

 

 
The following command is used to convert the ASCII file with precipitation on 
June 1, 1993 to a DSS record.  
 
asc2DSSGrid INPUT=CDR_19930601z.asc DSS=Persiann.dss 
PATH=/UTM48/Mongolia/Precip/01JUN1993:0000/01JUN1993:2400/PROJECTE
D/ GRIDTYPE=UTM ZONE=48N DUNITS=mm DTYPE=PER-CUM 
 
d. Run the batch file by double-clicking on the GRID2DSSGrid.bat file. 

Figure 56: ASCE2DSSGrid Batch File 
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e. The resulting DSS file, PERSIANN.DSS, contains gridded precipitation 
records from each data file from June 1 to September 30, 1993 and is shown 
in HEC-DSSVue in Figure 57 and Figure 58. 

  

Figure 57: PERSIANN-CDR DSS File 
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Figure 58: HEC-DSSVue with PERSIANN-CDR Data 

 
 
 
 

Task 4: Calibrate an HEC-HMS Model to Multiple Precipitation Sources.   
 

This task demonstrates how to add gridded precipitation to an HEC-HMS project.  Many 
of the steps needed to create and configure an HEC-HMS project have already been 
completed for you.  In this task, we will use the previously developed precipitation data 
(from GageInterp and the satellite based information) and create simulation runs with 
HEC-HMS model. The HEC-HMS model contains the following four simulation runs 
below. 
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A. Point Rainfall with the Clark unit hydrograph method, 
B. Gridded precipitation from GageInterp with the Clark unit hydrograph method, 
C. Gridded Precipitation from GageInterp with the ModClark transform method, 
D. Gridded Precipitation from PERISIANN-CDR with the ModClark transform 

method. 
 
With most of the HMS model setup already 
completed, we only will need to setup the 
meteorologic models.  The HEC-HMS model 
was setup by importing the basin model from 
the GeoHMS project and the subbasin and 
stream shapefiles for background map 
visualization.  The grid cell file was imported 
as well in order to use gridded precipitation.  
Refer to the HEC-HMS User’s manual for 
loading the grid cell parameter file into a 
basin model.  After populating required 
hydrologic modeling parameters, the model 
was calibrated to observed streamflow 
gages.  The HEC-HMS data structure is 
shown in the Watershed Explorer (Figure 59) 
and the Basin Model (Figure 60). 

Figure 59: HMS Data Structure 
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Below are HEC-HMS model calibration steps for adjusting hydrologic parameters and 
comparing simulated and observed hydrographs at gage locations.  It is important to 
understand the impact from each model parameter and to adjust model parameters 
within a reasonable range.   

Figure 60: Overview HEC-HMS Basin Model 
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Loss 
Parameters 

• Loss parameters can be adjusted to increase the runoff 
volume

• Select the Parameters ⇒ Loss ⇒ Initial and Constant 
Loss menu option to open the Initial and Constant Loss
global parameter editor.

• Adjust the loss rate to better match the computed runoff 
volume and peak flows with observed data.

Baseflow

• Adjust the Baseflow rate to better match the computed 
runoff volume with observed data.

Clark Unit 
Hydrograph 
Parameters

• Adjust the Clark unit hydrograph parameters control the 
hydrograph peak flow timing and magnitude. 

Nash-Sutcliffe 
value 

• Compare the Nash-Sutcliffe value with each calibrate run.  
This number should be close to 1.  The total runoff volume 
should be similar to the observed runoff volume.  
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A. Point Rainfall Applied to the Clark Unit 
Hydrograph Transform Method 

 
This modeling option has been completed for you.  
The precipitation gage data was loaded into the 
project and the model was calibrated to observed flow 
at two locations.  
 
In this step, we will utilize point rainfall (Figure 61 to 
Figure 63) as specified hyetographs in the 
meteorologic model.  The same two precipitation 
gages used to create gridded precipitation were used 
directly for subbasin rainfall.  The closest precipitation 
gage was assigned to each subbasin.  The user can 
refer the HEC-HMS User’s and Technical 
Reference Manuals for description about the Clark 
and ModClark Unit Hydrograph transformation 
method. 
 
 

 
 
The Observed.DSS contains point rainfall and streamflow gage data. Two precipitation 
gages were added to the HEC-HMS project and they were linked to records in the 
observed.dss file, as shown in Figure 63.  
 
Below are the steps for setting up the meteorologic model: 

1. Add a new meteorological model to the project.  

Calibration Point 
#1: Subbasin 

W250 

Calibration Point 
#2: Junction J67 

Figure 62: Calibration Points 

Figure 61: Point Rainfall 
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a. Select the Specified Hyetograph method and link the meteorologic model 
to the correct basin model.  

2. Add 2 new precipitation gages and link them with the observed.dss DSS file 
(Figure 63). 

3. Within the meteorological model created in step 1, link each subbasin to the 
closest precipitation gage. 

 
 

As shown in Figure 64, a simulation run was created and named Run 1993 Point Rain 
Clark.  The simulation run combines the “Mongolia_Clark” basin model, the “Met 1993 
Point Rain” meteorologic model, and the “Control 1993” control specifications. The 
simulation was computed and the simulated and observed flow hydrographs were 
compared at gage locations.  Model parameters were adjusted to improve the model.  

  

Figure 63: Point Rainfall Precipitation Gage 
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Figure 64: Simulation Run - Point Rain Clark Configuration 
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Below are results at calibration point #1 at Subbasin W250 (Figure 65). 
  

 
 Figure 65: Graph Subbasin W250 

Below are results at calibration point #2 at Junction J67 (Figure 66).  
 

 
 Figure 66: Graph for Junction J67 
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B. Gridded Precipitation from GageInterp Applied to the Clark Unit Hydrograph 
Transform Method 

 
Most of the steps in this modeling option have been completed for you.  The gridded 
precipitation records created by GageInterp (Task 2) were loaded into the project. The 
only required step remaining is to select the right precipitation gridset in the 
meteorologic model.  The basin model has already been calibrated for the gridded 
precipitation data set.  
The following steps show how to load a new precipitation gridset.  

1. Click Components => Grid Data Manager => Precipitation Gridsets and add 
two new precipitation gages, one can be named GageInterp and then other 
gridset can be named Persiann.  Link the GageInterp gridset to the DSS file 
created by GageInterp in Task 2, the DSS file should be named PrecipGrid.dss.   

2. Select Data Source: Single Record HEC-DSS.  

3. Browse and select DSS Filename: 
\...\Mongolia_UTM\Before\HMS_UTM\Mongolia_UTM\data\PrecipGrid.dss. 

4. Browse and select the DSS pathname as shown in Figure 67. 

 

The following step shows how to select the GageInterp gridset in the meteorologic 
model and then the results from the simulation using interpolated precipitation.  The 
basin model parameters have already been adjusted so that the model matches 
observed flow.  The model parameters are different than the basin model used in the 
rain gage modeling methods as the precipitation boundary condition is different.  It is 
important to make the model is re-calibrated each time the boundary condition 
information changes.   

5. Click on Meteorologic Models => Met 1993 Grid GageInterp => Gridded 
Precipitation.  Select the Grid Name: PrecipGrid_1993 from drop-down menu 
as shown in Figure 68. 

 

Figure 67: Grid-based Precipitation with GageInterp 
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Below is Simulation Run 1993 GageInterp Clark in the Watershed Explorer, Figure 69.  
The “Mondgolia_GageInterp_Clark” basin model is paired with the “Met 1993 Grid 
GageInterp” meteorologic model.   

 
 

  

Figure 68: GageInterp Gridded Precipitation 

Figure 69: Simulation Run - GageInterp Clark Configuration 
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Below are results at calibration point #1, at Subbasin W250 (Figure 70). 

 
Figure 70: Result at Calibration Point #1 at Subbasin W250 

Below are results at calibration point #2, at Junction J67 (Figure 71). 

 
 

Figure 71: Result at Calibration Point #2 at Junction J67 
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C. Gridded Precipitation from GageInterp Applied to the ModClark Unit Hydrograph 
Transform Method 

 
Most of the steps in this modeling option have been completed for you.  The gridded 
precipitation records created by GageInterp (Task 2) were loaded into the project and 
the meteorologic model used in Task B above was already linked to the GageInterp 
precipitation gridset. The only required step remaining is to make sure the basin model 
has the grid cell file selected.  The grid cell file is required so that HEC-HMS can map 
grid cells located within each subbasin to precipitation within the precipitation grids.  The 
basin model has already been calibrated for the gridded precipitation data set and the 
change to the ModClark transform method.  
 
Below is the simulation run named Run 1993 GageInterp ModClark, as shown in 
Figure.  The simulation combines the “Mongolia_ModClark” basin model and the “Met 
1993 Grid GageInterp” meteorologic model.  

 
 Figure 72: GageInterp ModClark Configuration 
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Below are results at calibration point #1, at Subbasin W250 (Figure 73). 

 

Below are results at calibration point #2, at Junction J67 (Figure 74).  
 

 
Figure 74: Calibration Point #2 at Junction J67 

  

Figure 73: Calibration Point #1 at Subbasin W250 
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D. Gridded Precipitation from PERSIANN-CDR Applied to the ModClark Unit 
Hydrograph Transform Method 

 

Most of the steps in this modeling option have been completed for you.  The gridded 
precipitation records created when processing the PERSIANN satellite based 
precipitation (Task 3) were loaded into the project.  You will need to update the 
meteorologic model to use the PERSIANN gridset, as described below.  

The following steps show how to add a gridset and link it to a DSS file.    

1. Click Components => Grid Data Manager => Precipitation Gridsets.  Add a 
new precipitation grid set.  Name the new gridset “Persiann”. 

2. Select Data Source: Single Record HEC-DSS.  

3. Browse and select DSS Filename: 
\...\Mongolia_UTM\Before\HMS_UTM\Mongolia_UTM\data\ Persiann.DSS. 

4. Browse and select DSS pathname as shown in Figure 75. 

 
After the gridset has been added to the project, it can be reference in the “Met 1993 
Persiann” meteorologic model.   

• Click on Meteorologic Models => Met 1993 Persiann and open the Gridded 
Precipitation tab in the component editor.   

• Select the Persiann grid from the drop-down menu as shown in Figure 76. 

 

 

Figure 75: PERSIANN-CDR Precipitation Data 
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The simulation run named Run 1993 Persiann ModClark is shown in Figure 77.  The 
simulation run combines the “Mongolia_Persiann” basin model and the “Met 1993 
Persiann” meteorological model.  

 

Figure 76: PERSIANN Gridded Precipitation 

Figure 77: Simulation Run -PERSIANN ModClark  
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Below are results at calibration point #1, at Subbasin W250 (Figure 78).

 

Below are results at calibration point #2, at Junction J67 (Figure 79).  

 
 
 
 
 

Figure 78: Calibration Point #1 at Subbasin W250 

Figure 79: Calibration Point #2 at Junction J67 
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Even though the purpose of the workshop was not to compare precipitation products, 
Figure 80 shows the basin hyetographs for subbasin W250.  The hyetographs include 
one developed by using only one precipitation gage, another created by interpolating a 
precipitation grid using two rain gages in the study area, and the third hyetograph shows 
results from the PERSIANN-CDR dataset. All precipitation data sources were converted 
to daily cumulative precipitation.  The low precipitation intensity from the PERSIANN-
CDR dataset explains the poor results shown in Figure 78 and Figure 79.   
 

 
Figure 80: Comparison of Precipitation Products 

 
As mentioned, the goal of this workshop was to demonstrate how gridded precipitation 
could be developed and applied to HEC-HMS models in watersheds outside of the 
United States.  The required information to perform gridded modeling outside of the 
United States includes a Grid Cell file, created using HEC-GeoHMS (shown in Task 1), 
and gridded precipitation.  Tasks 2 and 3 show how gridded precipitation, stored in 
DSS, can be created using the GageInterp program or using utility tools from HEC to 
convert ASCII grid files into DSS records.  Task 4 shows how to load the precipitation 
grids into an HMS project and then incorporate the grids into a meteorologic model.  
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